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Introduction

A couple years ago, I was teaching a workshop on advanced SketchUp
techniques to a group of extremely bright middle and high school (or
so [ thought) students in Hot Springs, Arkansas. As subject matter went, |
wasn’t pulling any punches — we were breezing through material [ wouldn’t
think of introducing to most groups of adults. At one point, a boy raised his
hand to ask a question, and I noticed he looked younger than most of the
others. Squinting, I read a logo on his T-shirt that told me he was in elemen-
tary school. “You're in sixth grade?” I asked, a little stunned. These kids were
motoring, after all. The boy didn’t even look up. He shook his head, double-
clicked something, and mumbled, “Third.” He was 8 years old.

SketchUp was invented back in 1999 by a couple of 3D industry veterans (or
refugees, depending on your perspective) to make it easier for people to see
their ideas in three dimensions. That was it, really — they just wanted to
make a piece of software that anyone could use to build 3D models. What I
saw in Arkansas makes me think they were successful.

Before it was acquired in 2006 by Google, SketchUp cost $495 a copy, and it
was already a mainstay of architects’ and other designers’ software toolkits.
No other 3D modeler was as easy to understand as SketchUp, meaning that
even senior folks (many of whom thought their CD/DVD trays were cup
holders) started picking it up. These days, SketchUp is being used at home,
in school, and at work by anyone with a need to represent 3D information the
way it’s meant to be represented: in 3D. Google SketchUp (as it’s now called)
is available as a free download in six languages and is just as popular interna-
tionally as it is in North America.

About This Book

The thing I like least about software is figuring out how it works. [ once saw a
movie where the main character acquired knowledge by plugging a cable (a
rather fat cable, actually) into a hole in the back of his head. A computer then
uploaded new capabilities — languages, martial arts, fashion sense (appar-
ently) — directly into his brain. Afterward, the character ate a snack and took
anap. That’s how I wish I could get to know new software.
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This book, on the other hand, is a fairly analog affair. In it,  do my best to
guide you through the process of building 3D models with SketchUp. [ wrote
this book for people who are new to 3D modeling, so I don’t assume you
know anything about polygons, vertices, or linear arrays. The nice thing is
that the people who make SketchUp don’t assume you know any of those
things, either. That means I don’t have to spend many words explaining
theoretical concepts, which I think we can both appreciate.

[ don’t think many people want to use software just for the sake of using soft-
ware. You probably didn’t learn to drive just because you thought seatbelts
and turn signals were cool; 'm betting you wanted to be able to get around
in a car. People use SketchUp so that they can build 3D models. As such,
most of this book focuses on what you can do with SketchUp, and not what
SketchUp does. Naturally, this has a few implications:

v~ I use the word you a lot. You're reading this book because you have
something you want to build in 3D on your computer, and you think
SketchUp can help you do that. I try to keep this in mind by letting you
know how you can use the features I talk about to do what you want to do.

v~ I err on the side of architecture. The fact is, a lot of people want to
use SketchUp to model buildings, so I'm assuming that a good many of
you (the collective you, in this case) want to do the same. You can use
SketchUp to build just about anything you want, but to ignore the fact
that it’s extra-great for architecture would be silly.

1+ 1 don’t cover everything SketchUp can do. If this book were about
SketchUp, and not modeling with SketchUp, [ would list every feature,
every tool, and every command in exhaustive detail. | would tell you
exactly what every radio button and slider bar is for. [ would, in effect,
just copy the documentation that comes with SketchUp (available in the
Help menu) and call it a day. In writing this book, I had to make a tough
choice: I had to figure out what to show you and, more importantly,
what to leave out. The Table of Contents I settled on is a list of what
most people want to know, most of the time.

Just in case you're interested, here’s what didn’t make the cut (and why):

¢ The Dimension and Label tools: I left these out because they're
so simple to use that I didn’t think they needed any explanation.
That’s not to say they’re not great — they are. It’s just that this
book could only be so long.

e The 3D Text tool: Why’d I leave this one out? Like the Dimension
and Label tools, it’s too easy to use. Just try it out and you’ll see
what [ mean.
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e Style Builder: Because it’s a separate program that comes with
SketchUp Pro 7, I decided not to dive into Style Builder. You use it
to create your own Styles for SketchUp; learn more about Styles in
Chapter 9.

¢ Ruby: Actually, I do talk a little bit about Ruby, but only in Chapter
17, which is practically at the end of the book. Ruby is a scripting
(programming) language that you (maybe) can use to code your
own tools for SketchUp. I think that says it all, don’t you?

One more thing: Because SketchUp is a cross-platform program (meaning that
it’s available for both Windows and Macintosh computers), I make reference
to both operating systems throughout this book. In most cases, SketchUp
works the same in Windows and on a Mac, but where it doesn’t, [ point out
the differences. Just so you know, any figures in this book that show the
SketchUp user interface show the Windows version.

Foolish Assumptions

I mentioned earlier that I don’t presume you know anything about 3D modeling,
much less 3D modeling with SketchUp, in this book. That’s true — you’re
safe even if you call SketchUp “Sketch’em-Up” (which I've heard more than
once, believe it or not). If you happen to know a thing or two about SketchUp,
[ think you'll still find plenty of useful stuff in this book. Even though it’s
written with beginners in mind, I've included a lot that definitely isn’t
beginner-level information. I mean for this book to be useful for people with
just about any level of SketchUp skill.

That said, I assume you’re familiar with a few important concepts. To begin
with, I assume you know how to work your computer well enough to under-
stand how to do basic things like saving and opening files. I don’t cover those
things in this book because SketchUp handles them just like every other
program does. If you're trying to model with SketchUp and figure out how to
use a computer at the same time, Wiley has some excellent books that can
help you out, such as Windows Vista For Dummies, by Andy Rathbone, or Mac
OS X Leopard For Dummies, by Bob LeVitus, just to name two; visit www .
dummies . com for other options.

Next, I take for granted that you have, and know how to work, a mouse with
a scroll wheel. SketchUp all but requires you to have a scroll wheel mouse —
especially when you're just starting out. The good news for folks who don’t
have one is that they’re fairly cheap. Just look for something with a left
button, a right button, and a little scroll wheel in the middle.
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Finally, I assume you have at least occasional access to the Internet. Don’t
panic! Unlike most Google applications, you don’t have to be online to use
SketchUp — I do most of my best work on airplanes, in fact. You can find
some great resources on the Web, though, and I point them out when I think
they’re important.

How This Book Is Organized

Tell me if you think this is strange: | read most computer books in completely
random order. | never start at the beginning and work my way through. In
fact, I only pick them up for two reasons:

v To figure something out: I like to have a book on hand when I'm
beginning something new because I like the way books work. If I need
help, I look it up, but something else invariably happens — I end up
reading more than I needed to, and I usually end up finding out some-
thing I didn’t even know I didn’t know. That almost never happens when
[ use digital media; it’s too good at providing me with just the answer to
my question. Computers are lousy for browsers like me.

v To kill time: | hate to admit this, but I don’t usually keep my computer
books anywhere near my computer. | keep them in the bathroom,
because my bathroom has excellent light for reading and because I'm
afraid that a television would fall in the bathtub and electrocute me.
When I'm just killing time, I open my book to a random page and start
reading.

Despite these two facts, this book does have structure. Basic concepts are
grouped in the first few chapters, and more advanced material appears
toward the end. Chapter 3 is entirely devoted to a step-by-step approach to
getting started, just for those who like to get to know software that way.

In general, though, this book is intended to be a reference. If you keep
reading from this page on, right to the end of the index, you’ll have a pretty
good idea of how to use SketchUp to make 3D models — but that isn’t what
I'm expecting you to do. I recommend that you start with Chapters 1 and 2,
just to get your bearings. After that, you should use the Table of Contents or
the index to find what you’re looking for; then proceed from there.

To make it easier to understand how certain chapters are related, this book

lumps them together into parts. Check out the following summaries to get an
idea of what’s in each one.
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Part I: Getting Started with SketchUp

If you're completely new to SketchUp and 3D modeling, this is the most
important part in this book. Start here, lest you get frustrated and decide to
use these pages to line your rabbit coop. Chapter 1 talks about how SketchUp
fits into the bigger 3D modeling picture. Chapter 2 lays out all — that’s 100
percent — of the basic concepts you need to understand to do anything
useful with SketchUp. Chapter 3 offers a basic end-to-end workflow for
creating and sharing a model. You can skip it, but I think it’s a nice way to
ease into the program.

Part 1I: Modeling in SketchUp

SketchUp is a 3D modeling tool, so this part is, in Shakespeare’s eternal
words, “where it’s at.” Chapter 4 dives right into using SketchUp to make
buildings, with an emphasis on drawing and extruding simple plans, modeling
stairs, and constructing roofs. This isn’t easy, mind you, but it’s what a lot of
people want to use SketchUp to do, so I put it right at the beginning.

Chapter 5 deals with using groups and components, two of the most important
elements in any SketchUp model you make. Chapter 6 deals with tools you
can use to manage big models, and Chapter 7 lays out advanced techniques
for modeling things like terrain, characters, and other non-boxy objects. In
Chapter 8 I talk about using photographs in SketchUp. The second part of the
chapter is all about SketchUp’s photo-matching feature, which I guarantee
will make you smile.

Part I11: Viewing Your Model
in Different Ways

Making models in SketchUp is only half the fun. The chapters in this
part present some of this software’s truly unique presentation features.
Chapter 9 dives into Styles and Shadows. Also, don’t skip the last part of
Chapter 10 on using sections to create animations — it’s easy and more
rewarding than almost anything else you can do in SketchUp.
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Part IU: Sharing What You've Made

These chapters are dedicated to getting your models out into the world.

In Chapter 11 I talk about using SketchUp with Google Earth, which, if you
haven’t tried it, is reason in itself to have a fast Internet connection. Chapters
12 and 13 deal with printing and exporting images and movies from your
model files. Chapter 14 is an introduction to LayOut. This whole-new pro-
gram, which is included as part of SketchUp Pro, is for creating 2D presenta-
tion documents that automatically link to your 3D models.

Part U: The Part of Tens

My favorite thing about books in the For Dummies series is the way they
embrace people’s love of lists. I could have spread the information contained
in these ultra-short chapters throughout the entire book, but it’s so much
easier to read when it’s all in one place, don’t you think?

Chapter 15 is a list of ten things that you’ll definitely struggle with when
you're first using SketchUp; remember to check here before you do anything
drastic. Chapter 16 lists great add-ons that’ll make your SketchUping more
enjoyable, and Chapter 17 is all about where to turn when the information
you need isn’t in this book.

On the Web site

[ created a little online presence for this book in order to be able to share
more information with you. This book’s Web site (www.dummies.com/go/
SketchUp7FD) includes lots of useful stuff:

v A Bonus Chapter: The previous edition of Google SketchUp For Dummies
included a whole chapter on exporting 2D and 3D vector information
with SketchUp Pro. That information is still relevant, but I cut it out of
this book to make room for new features in SketchUp 7. The good news
is that you can get the whole chapter in digital form on the Web site.

v Videos: | recorded about six dozen videos and put them up on YouTube.
They’re pretty basic (just me talking and modeling) but seeing SketchUp
in action is often very helpful — black and white pictures can only
convey so much. All my videos are also embedded in this book’s Web
site, and they’re organized by chapter and section to make them easier
to find.
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1 Color images: It often helps to be able to see a figure in color, so I put
color versions of some of the images in this book online.

v SketchUp files: These are actually stored on the Google 3D Warehouse
(which you can find out about in Chapters 5 and 11), but I link to them
to make them easier to find.

v~ Links to other cool resources: There’s a world of great SketchUp
material — plugins, components, models, blogs — out there, and you
can find direct links to many of them on my Web site.

Icons Used in This Book

@ This icon indicates a piece of information I think will probably save you time.

When you're working in SketchUp, you need to know a lot of things. [ use the
Remember icon to remind you of something I cover earlier in the book, just in
case you might have forgotten (or skipped) it.

Everyone’s a little bit of a nerd sometimes, and paragraphs that bear this icon
indulge that nerdiness. You can skip them without fear of missing anything
important, but reading them can give you something to annoy your SketchUp
friends with later on.

When you see this icon, pay special attention. It occurs rarely, but when it
does, something you do could harm your work.

This icon denotes a spot where you can find supporting material on this
book’s companion Web site, including videos, sample files, and links to helpful
material, which you can find at www . dummies.com/go/SketchUp7FD.

[ revised this book to cover SketchUp 7, but instead of adding a section at
the beginning that lists everything that’s new, I added the information
throughout — I think it makes more sense that way. This icon denotes what’s
new or different in the new version.

If you'd like to see a complete list of new features and improvements in
SketchUp 7, open your Web browser of choice and try doing a Google search
for new in SketchUp 7 — something gloriously list-like will no doubt appear.

www.it-ebooks.info

/


http://www.it-ebooks.info/

8 Google SketchUp 7 For Dummies

www.it-ebooks.info


http://www.it-ebooks.info/

Part|

Getting Started
with SketchUp

By Rich Tennant

Seriously — why always a black
Bat Cave? Why not a mauve
Bat Cave? Or an eggshell Bat Cave?
We could at least mock it up in  §
SketchUp to see how it would look...
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In this part . . .

Fis part of the book is dedicated to helping you get
your bearings. It’s not a step-by-step guide to starting
a new file in SketchUp; instead, it provides a little bit of
information about what SketchUp is, what you can use it
to do, and how to get the most out of it.

Chapter 1 is a very general overview of Google SketchUp. I
try not to bore you with too much background informa-
tion, but here’s where you can read about what the soft-
ware is supposed to let you do, how it compares to other
3D modeling applications, and where everything is.

In Chapter 2, I jump right in. There are a few things about
SketchUp you absolutely need to know when you’re just
getting started, and here’s where I lay them out. I think
this is the most important chapter in this book; read it,
and you’ll know more about SketchUp than millions of
other folks who already use it every day.

The contents of Chapter 3 are included for the benefit of
those readers who like to learn software by getting their
hands dirty right away. The whole chapter is a workflow
that takes you through the process of making a simple
model, changing the way it looks, and creating an image of
it that you can keep forever.
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Chapter 1
Meeting Google SketchUp

In This Chapter

Finding out why it’s free from Google

Comparing SketchUp with other 3D software

Finding out what you can and can’t do with SketchUp
Looking around the application

Once upon a time, software for building three-dimensional (3D) models
of thing like buildings, cars, and other stuff was hard to use. I mean
really hard — people went to school for years to learn it. And if that wasn’t
bad enough, 3D modeling software was expensive. It was so expensive that
the only people who used it were professionals and software pirates (people
who stole it, basically). Then along came SketchUp.

Operating under the assumption that lots of people might want — and need —
to make 3D models, the folks who invented SketchUp decided to design a
program that worked more intuitively. Instead of making you think about 3D
models as complex mathematical constructs (the way computers think), they
created an interface that lets you build models using elements you're already
familiar with: lines and shapes.

So do you need to know how to draw to use SketchUp? In the latest version of
the software, not really. Traditional drawing is about franslating what you see
onto a flat piece of paper: going from 3D to 2D, which is hard to do for most
people. In SketchUp, you’re always in 3D, so no translation is involved — you
just build, and SketchUp takes care of stuff like perspective and shading for you.

This first chapter is about putting SketchUp in context: why Google offers it
for free, how it compares to other 3D software, and what you can (and can’t)
do with it. In the last part of the chapter, I give a quick tour of the program,
just to let you know where things are.
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Things You Ought to Know Right Away

Before I continue, here’s some information you might need:

+* You get SketchUp by downloading it from the Internet. Just type
http://sketchup.google.com into your Web browser and read
through the first page of the Google SketchUp Web site. Click the links
to download the application to your computer, and then follow the
installation instructions on the Web.

v SketchUp works in Windows and Mac OS X. Google SketchUp is
available for both operating systems, and it looks (and works) about
the same way on both.

v A Pro version is available. Google offers a Pro version of SketchUp
(called Google SketchUp Pro) that you can buy if you need it. It includes
a few terrific features that folks like architects, production designers,
and other design professionals need for exchanging files with other
software. SketchUp Pro also includes a whole separate application
for creating presentation documents with your SketchUp models. It’s
called LayOut, and it’s the subject of Chapter 14. If you think you might
need Pro, you can download a free trial version at http: //sketchup.
google.com.

Where SketchUp Fits in Google’s World

A long time ago, somebody invented photography (hey — this isn’t a history
book), and all of a sudden there was a way to make pictures of things that
didn’t involve drawing, engraving, or painting. Nowadays, you can’t throw

a rock without hitting a photograph of something. Everything (it seems) can
take pictures, including people’s phones. Photography is the main way that
visual information is communicated.

But what comes after photography? Google (and just about every science-
fiction writer who ever lived) thinks it’s 3D, and here’s why: You live in 3D.
The furniture you buy (or build) is 3D, and so is the route you take to work.
Because so many of the decisions you need to make (buying a couch, finding
your way) involve 3D information, wouldn'’t it be nice to be able to experience
that information in 3D?

Software like SketchUp lets you see 3D information on a 2D screen, which is
good, but affordable 3D printers and holography (yep, holograms) are just
over the horizon. All that’s left is to build a model of every single thing in the
world — and guess who’s going to do it?
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You. By making SketchUp free for everyone, Google is leading the 3D charge.
Rather than relying on a small number of 3D nerds to get around to modeling
everything in the universe, Google made SketchUp available to anyone who
wants to participate. After all, Google is about organizing the world’s informa-
tion — not creating it. By giving SketchUp away, the company has created a
whole new kind of information to organize. Chapter 11 is all about SketchUp
and Google Earth, as well as the Google 3D Warehouse, where the world’s 3D
information is being stored — at least for now.

Comparing Sketchlp to Other
3D Modeling Programs

If you're reading this book, I presume you're at least interested in two things:
building 3D models and using SketchUp to do so. The following sections

tell you something about how SketchUp compares to other 3D modeling
programs — how long it takes to figure out how to use it and what kind of
models it produces.

Jumping vight in

When it comes to widely available 3D modeling software, it really doesn’t get
any easier than SketchUp. This software has been as successful as it has for
one reason, and it has everything to do with how quickly people are able to
get good enough at SketchUp to build something within a couple of hours of
launching it for the first time. You have no thick manuals to read, no special
geometric concepts to understand; modeling in SketchUp is about grabbing
your mouse and making something.

So how long should it take you to discover how it works? It depends on your
background and experience, but in general, you can expect to be able to
make something recognizable in under four hours. That’s not to say you’ll be
a whiz — it just means that SketchUp’s learning curve is extremely favorable.
You don’t need to know much to get started, and you'll still be picking things
up years from now. In fact, I've learned a couple of things just writing this
book.

But is SketchUp easy? Lots of people say so, but I think it’s all relative.
SketchUp is without a doubt easier than any other modeling program I've
tried, but 3D modeling itself can be tricky. Some people catch on right away,
and some folks take longer. But I can say this for sure: If you want to build 3D
models, and you have an afternoon to spare, there’s no better place to start
than SketchUp.
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Understanding the difference
between paper and clay

Three-dimensional modeling software comes in two basic flavors: solids and
surfaces. Figure 1-1 and the following points illustrate the difference:

Surface models are hollow Solid models are solid

|
Figure 1-1:
SketchUp
models are
hollow.
|

1 SketchUp is a surfaces modeler. Everything in SketchUp is basically
made up of thin (infinitely thin, actually) surfaces — these are called
faces. Even things that look thick (like cinder-block walls) are actually
hollow shells. Making models in SketchUp is a lot like building things out
of paper — really, really thin paper.

Surface modelers like SketchUp are great for making models quickly,
because all you really need to worry about is modeling what things look
like. That’s not to say that they’re less capable; it’s just that they’re
primarily intended for visualization.

v Using a solids modeler is more like working with clay. When you cut
a solid model in half, you create new surfaces where you cut; that’s
because objects are, well, solid. Programs like SolidWorks, FormeZ, and
Inventor create solid models.

People who make parts — like mechanical engineers and industrial
designers — tend to work with solid models because they can use
them to do some pretty precise calculations. Being able to calculate the
volume of an object means that you can figure how much it will weigh,
for example. Also, special machines can produce real-life prototypes
directly from a solid-model file. These prototypes are handy for seeing
how lots of little things are going to fit together.

An important point to reinforce here is that there’s no “best” type of model-

ing software. It all depends on three things: how you like to work, what you're
modeling, and what you plan to do with your model when it’s done.
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When [ said (a few paragraphs ago) that 3D modeling programs come in two
basic flavors, I sort of lied. The truth is, you can split them into two groups
another way as well: by the kind of math they use to produce 3D models. You
can find polygonal modelers (of which SketchUp is an example) and curves-
based modelers. The former type uses straight lines and flat surfaces to define
everything — even things that look curvy, aren’t. The latter kind of modeler
uses true curves to define lines and surfaces. These yield organic, flowing
forms that are much more realistic than those produced by polygonal modelers,
but that put a lot more strain on the computers that have to run them — and
the people who have to figure out how to use them. Ultimately, it’s a trade-off
between simplicity and realism.

What You Should (and Shouldn’t)
Expect SketchUp to Do

Have you ever been to a hardware store and noticed the “multitool” gizmos
on the racks next to the checkout stands? [ once saw one that was a combina-
tion screwdriver, pliers, saw, tape measure, and (I swear) hammer. | some-
times wonder whether the hardware-store people put them there as a joke,
just to make you feel better about standing in line.

I generally don’t like tools that claim to be able to do everything. I much
prefer specialists — tools that are designed for doing one thing really well. In
the case of SketchUp, that one thing is building 3D models.

Here’s a list of things (all model-building-related) that you can do with
SketchUp:

1~ Start a model in lots of different ways: With SketchUp, you can begin a
model in whatever way makes sense for what you're building:

¢ From scratch: When you first launch SketchUp, you see nothing
except a little person standing in the middle of your screen. If you
want, you can even delete him, leaving you a completely blank
slate on which to model anything you want.

¢ In Google Earth: Chapter 11 goes into this in detail. Basically, you
can bring an aerial photograph of any place on Earth (including
your home) into SketchUp and start modeling right on top of it.

¢ From a photograph: The second part of Chapter 8 talks all about
how you can use SketchUp to build a model based on a photo of
the thing you want to build. It’s not really a beginner-level feature,
but it’s there.
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e With another computer file: SketchUp can import images and
CAD (computer-aided drawing) files so that you can use them as a
starting point for what you want to make.

1 Work loose or work tight: One of my favorite things about SketchUp is
that you can model without worrying about exactly how big something
is. You can make models that are super-sketchy, but if you want, you can
also make models that are absolutely precise. SketchUp is just like paper
in that way; the amount of detail you add is entirely up to you.

v Build something real or make something up: What you build with
SketchUp really isn’t the issue. You only work with lines and shapes —
in SketchUp, they’re called edges and faces — so how you arrange them
is your business. SketchUp isn’t intended for making buildings any more
than it is for creating other things. It’s just a tool for drawing in three
dimensions.

v+~ Share your models: After you’'ve made something you want to show off,
you can do a number of things, which you can discover in detail in Part IV:

¢ Print: Yep, you can print from SketchUp.

¢ Export images: If you want to generate an image file of a particular

view, you can export one in any of several popular formats.

¢ Export movies: Animations are a great way to present three-
dimensional information, and SketchUp can create them easily.

Is it a toaster or a bungalow?

SketchUp models are made from two basic
kinds of geometry: edges (which are straight
lines) and faces (which are 2D surfaces bound
by edges). That's it. When you use SketchUp to
draw a bunch of edges and faces in the shape
of a staircase, all SketchUp knows is how many
edges and faces it has to keep track of, and
where they all go. There's no such thing as a
stairin SketchUp — just edges and faces.

That said, there’s a brand new development
in SketchUp 7: Dynamic Components are pre-
programmed objects that know what they are. A
dynamic staircase, for example, is smart enough
to know that it should add or subtract steps
when you make it bigger or smaller. Dynamic
Components are a hig step for SketchUp;
all of a sudden, there's a class of stuff in the

programthathas(whatsoftwaretypeswould call)
intelligence. What's that mean for you? For
starters, SketchUp is easier to pick up than
it's ever been. | go on and on about Dynamic
Components in Chapter 5.

With the exception of Dynamic Components,
though, things in SketchUp don't have any idea
what they’re supposed to represent. Coming to
this realization has the tendency to freak some
people out. If you want a model of something,
you have to make it out of edges and faces. The
thing to remember is that SketchUp was created
to let you model anything, not just buildings, so
its tools are designed to manipulate geometry.
That's good news, believe it or not, because it
means that you're not restricted in any way; you
can model anything you can imagine.
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¢ Export other 3D model formats: With the Pro version of SketchUp,
you can share your model with other pieces of software to create
CAD drawings, generate photorealistic renderings, and more.

¢ Upload to the 3D Warehouse: This is a giant, online repository of
SketchUp models that you can add to (and take from) all you want.

What can’t SketchUp do? A few things, actually — but that’s okay. SketchUp
was designed from the outset to be the friendliest, fastest, and most useful
modeler available — and that’s it, really. Fantastic programs are available
that do the things in the following list, and SketchUp can exchange files with
most of them:

+” Photorealistic rendering: Most 3D modelers have their own, built-in
photo renderers, but creating model views that look like photographs
is a pretty specialized undertaking. SketchUp has always focused on
something called nonphotorealistic rendering (NPR) instead. NPR (as it’s
known) is essentially technology that makes things look hand-drawn — sort
of the opposite of photorealism. If you want to make realistic views of
your models, I talk about some renderers that work great with SketchUp
in Chapter 16.

v Animation: A few paragraphs ago, | mentioned that SketchUp can export
animations, but that’s a different thing. The movies that you can make
with SketchUp involve moving your “camera” around your model. True
animation software lets you move the things inside your model around.
SketchUp doesn’t do that, but the Pro version lets you export to a
number of different programs that do.

Taking the Ten-Minute SketchUp Tour

The point of this portion of the chapter is to show you where everything is —
kind of like the way a parent shows a new babysitter around the house before
leaving for a couple of hours. It’s not meant to explain what anything does,
per se. | just want you to feel like you know where to start looking when you
find yourself hunting around for something.

Just like most programs you already use, SketchUp has five main parts.
Figure 1-2 shows all of them, in both the Windows and Mac versions of the
program. I describe these parts, plus an additional feature, in the following
list:

1 Modeling window: See the big area in the middle of your computer
screen? That’s your modeling window, and it’s where you spend
99 percent of your time in SketchUp. You build your model there; it’s
sort of a frame into a 3D world inside your computer. What you see in
your modeling window is always a 3D view of your model, even if you
happen to be looking at it from the top or side.
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Figure 1-2:
All of
SketchUp's
parts: in
Windows
(left) and on
the Mac.

+ Menu bar: For anyone who has used a computer in the last 30 years,

the menu bar is nothing new. Each menu contains a long list of options,
commands, tools, settings, and other goodies that pertain to just about
everything you do in SketchUp.

v Toolbars: These contain buttons that you can click to activate tools and

commands; they are faster than using the menu bar. SketchUp has a few
different toolbars, but only one is visible when you launch it the first
time: the Getting Started toolbar.

If your modeling window is too narrow to show all the tools on the
Getting Started toolbar, you can click the arrow on the right to see the
rest of them.

1 Dialog boxes: Some programs call them palettes and some call them

inspectors; SketchUp doesn’t call them anything. Its documentation
(the SketchUp Help document you can get to in the Help menu) refers to
some of them as managers and some as dialog boxes, but I thought I'd
keep things simple and just call them all the same thing: dialog boxes.

v~ Status bar: You can consider this your SketchUp dashboard, I suppose.

It contains contextual information you use while you’re modeling.

+* Context menus: Right-clicking things in your modeling window usually

causes a context menu of commands and options to open. These are
always relevant to whatever you happen to right-click (and whatever
you’re doing at the time), so the contents of each context menu are
different.

Getting Started toolbar

Menu bar Dialog box

. T T e Wi e DR} 1+

I-L,.;./r_\or QWS LRI E SR Diea T V\AROC CIRELXIFOTARDTH Y
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Modeling window Status bar
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¥ Although the following items aren’t part of the SketchUp user interface (all the

stuff I just listed in the previous list), they’re a critical part of modeling in
SketchUp:

+ A mouse with a scroll wheel: You usually find a left button (the one you
use all the time), a right button (the one that opens the context menus),
and a center scroll wheel that you both roll back and forth and click
down like a button. You should get one if you don’t already have one —
it’'ll improve your SketchUp experience more than any single other thing
you could buy.

v A keyboard: This sounds silly, but some people have tried to use
SketchUp without one; it’s just not possible. So many of the things you
need to do all the time (like make copies) involve your keyboard, so
you’d better have one handy if you're planning to use SketchUp.

Hanging out at the menu bar

SketchUp’s menus are a pretty straightforward affair; you won’t find anything
surprising like “Launch Rocket” in any of them, unfortunately. All the same,
here’s what they contain:

v~ File: Includes options for creating, opening, and saving SketchUp files.
It’s also where to go if you want to import or export a file, or make a
printout of your model view.

v~ Edit: Has all the commands that affect the bits of your model that are
selected.

v View: This one’s a little tricky. You’d think it would contain all the
options for flying around in 3D space, but it doesn’t — that stuff’s on the
Camera menu. Instead, the View menu includes all the controls you use
to affect the appearance of your model itself: what’s visible, how faces
look, and so on. View also contains settings for turning on and off certain
elements of SketchUp’s user interface.

1 Camera: Contains controls for viewing your model from different angles.

In SketchUp, your “camera” is your point of view, literally.

v Draw: Includes tools for drawing edges and faces in your modeling
window.

v Tools: Most of SketchUp’s tools are contained here, except of course for
the ones you use for drawing.

v Window: If you're ever wondering where to find a dialog box you want
to use, this is the place to look; they’re all right here.
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Where are all the tools?

The Getting Started toolbar contains a small  »~ Windows: Choose View=>Toolbars. The

subset of the tools that you can use in SketchUp. mother lode! | recommend starting off with
The thinking (which | agree with, incidentally) the Large Tool Set to begin with, and then
is that seeing all the tools right away tends adding toolbars as you need them (and as
to overwhelm new users, so having a limited you figure out what they do).

selection helps people out. v Mac: Choose Viewr>Tool Palettese>Large

To get access to more tools (through toolbars, Tool Set. To add even more tools, right-click
anyway — you can always access everything the Getting Started toolbar (the one right
through the menus), you do different things, above your modeling window) and choose
depending on which operating system you're Customize Toolbar. Now drag whatever
using: tools you want onto your toolbar, and click

the Done button.

v Plugins: You can get extra tools for SketchUp — little programs that
“plug in” to it and add functionality. Some of them show up here after
they’re installed. Chapter 16 has some information on these.

v Help: When you're stuck, and this book isn’t helping (heaven forbid),
check out the Help menu. It’s the gateway to SketchUp salvation.

Checking the status bar

Even though the big part in the middle is the most obvious part, there’s
plenty more to the modeling window that you should know about:

v Context-specific instructions: Most of the time, you check here to see
what options might be available for whatever you're doing. Modifier
keys (keyboard strokes that you use in combination with certain tools
to perform additional functions), step-by-step instructions, and general
information about what you’re doing all show up in one place: right
here.

v The Measurements box: The Measurements box is where numbers
show up (to put it as simply as I can). Chapter 2 goes into more detail
about it, but the basic purpose of the Measurements box is to allow you
to be precise while you’'re modeling.
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1~ Status indicator icons: SketchUp 7 has three little icons that appear in
the lower-left corner of your screen. They change to tell you things
about your model, and you can click them to find out what they do. The
most important one to note (this early on in your SketchUp tutelage) is
the one that looks like a question mark. When you click it, it opens the
Instructor dialog box, which contains information about the tool you're
currently using.

Taking a peek at the dialog boxes

Most graphics programs have a ton of little controller boxes that float around
your screen, and SketchUp is no exception. After the dialog boxes are open,
you can “dock” them together by moving them close to each other, but most
people I know end up with them all over the place — me included. Dialog
boxes in SketchUp contain controls for all kinds of things; here are some of
the ones that I think deserve special attention:

v Preferences: While the Model Info dialog box (see the next point)
contains settings for the SketchUp file you have open right now, the
Preferences dialog box has controls for how SketchUp behaves no
matter what file you have open. Pay particular attention to the Shortcuts
panel, where you can set up keyboard shortcuts for any tool or com-
mand in the program.

On the Mac, the Preferences dialog box is on the SketchUp menu, which
doesn’t exist in the Windows version of SketchUp.

Some changes to the Preference settings don’t take effect until you open
another file or restart SketchUp altogether, so don’t worry if you can’t
see a difference right away.

v Model Info: This dialog box is, to quote the bard, the mother of all
dialog boxes. It has controls for everything under the sun; you should
definitely open it and take your time going through it. Chances are, the
next time you can’t find the setting you’re looking for, it’s in Model Info.

v~ Entity Info: This little guy is small, but it shows information about
entities — edges, faces, groups, components, and lots of other things —
in your model. Keeping it open is a good idea, because it helps you see
what you have selected.

v Instructor: The Instructor only does one thing: It shows you how to
use whatever tool happens to be activated. While you're discovering
SketchUp, you should keep the Instructor dialog box open off to the
side. You can also open it at any time by clicking the little “?” icon in the
Status bar, at the bottom of your screen.
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Chapter 2

Establishing the Modeling
Mind-Set

In This Chapter

Understanding edges and faces

Representing three dimensions on a two-dimensional screen
Finding out about the colored drawing axes

Inferencing like a pro

Seeing what you're doing

Drawing edges accurately

Working precisely with the Measurement box

Selecting things to work on

Moving and copying objects in your model

Using guides to line things up

Adding color and texture to your work

Wlen you were learning how to drive a car, you probably didn’t just
get behind the wheel, step on the gas, and figure it out as you went

along. (If you did, you probably have bigger things to worry about than
getting started with SketchUp.) My point is, you should really know several
things before you get started. This chapter is dedicated to introducing
those things — concepts, really — that can make your first few hours with
SketchUp a lot more productive and fun.

So here’s the deal: I've divided this chapter into three main parts:

v The first part talks about edges and faces — the basic stuff that SketchUp
models are made of.

v The second part deals with the way SketchUp lets you work in 3D (three
dimensions) on a 2D (flat) surface — namely, your computer screen.
Understanding how SketchUp represents depth is everything when it
comes to making models. If you've never used 3D modeling software
before, pay close attention to the middle part of this chapter.
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v The final part of this chapter is all about the things you need to do all
the time — things like navigating around your model, drawing lines,
selecting objects, and working with accurate measurements.

It’s Alt about Edges and Faces

WBER
s&
&

|
Figure 2-1:
SketchUp
models are
made from
edges and
faces.
|

In SketchUp, everything is made up of one of two kinds of things: edges and
faces. They’re the basic building blocks of every model you’ll ever make.

Collectively, the edges and faces in your model are called geometry. When
someone (including me) refers to geometry, we're talking about edges and
faces. Other modeling programs have other kinds of geometry, but SketchUp
is pretty simple. That’s a good thing — there’s less to keep track of.

The drawing on the left in Figure 2-1 is a basic cube drawn in SketchUp.

It’s composed of 12 edges and 6 faces. The model on the right is a lot more
complex, but the geometry’s the same: It’s all just edges and faces.

Edge Face Face Edge

Living on (with, actually) the edge

Edges are lines. You can use lots of different tools to draw them, erase them,
move them around, hide them, and even stretch them out. Here are some
things you ought to know about SketchUp edges:

v~ Edges are always straight. Not only is everything in your SketchUp
model made up of edges, but all those edges are also perfectly straight.
Even arcs and circles are made of small straight-line segments, as shown
in Figure 2-2.
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|
Figure 2-2:
Even curved
lines are
made up

of straight
edges.
|

|
Figure 2-3:
Even
organic
shapes and
curvy forms
are made up
of straight
edges.
|

Straight edges

1~ Edges don’t have a thickness. This one’s a little tricky to get your head

around. You never have to worry about how thick the edges in your
model are because that’s just not how SketchUp works. Depending on
how you choose to display your model, your edges may look like they
have different thicknesses, but your edges themselves don’t have a built-
in thickness. You can read more about making your edges look thick in
Chapter 9.

1 Just because you can’t see the edges doesn’t mean they’re not there.

Edges can be hidden so that you can’t see them; doing so is a popular
way to make certain forms. Take a look at Figure 2-3. On the left is a
model that looks rounded. On the right, I've made the hidden edges vis-
ible as dashed lines — see how even surfaces that look smoothly curved
are made of straight edges?

These edges are smoothed, but still there
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Facing the facts about faces

Faces are surfaces. If you think of SketchUp models as being made of tooth-
picks and paper (which they kind of are), faces are basically the paper.
Here’s what you need to know about them:

* You can’t have faces without edges. To have a face, you need to have at
least three coplanar (on the same plane) edges that form a loop. In other
words, a face is defined by the edges that surround it, and those edges
all have to be on the same, flat plane. Because you need at least three
straight lines to make a closed shape, faces must have at least three
sides. There’s no limit to the number of sides a SketchUp face can have,
though. Figure 2-4 shows what happens when you get rid of an edge that
defines one or more faces.

Figure 2-4:
You need
at least
three edges
to make a
face.
|
1 Faces are always flat. In SketchUp, even surfaces that look curved are
made up of multiple, flat faces. In the model shown in Figure 2-5, you
can see that what looks like organically shaped surfaces (on the left)
are really just lots of smaller faces (on the right). To make a bunch of
flat faces look like one big, curvy surface, the edges between them are
smoothed; you can find out more about smoothing edges in Chapter 6.
Each of these triangles is perfectly flat
|
Figure 2-5: |
All faces are anvs el
flat, even
the ones
that make
up larger,
curvy
surfaces.
|
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v Just like edges, faces don’t have any thickness. If faces are a lot like
pieces of paper, they’re infinitely thin pieces of paper — they don’t have
any thickness. To make a thick surface (say, like a 6-inch-thick wall), you
need to use two faces side by side.

Understanding the relationship
between edges and faces

Now that you know that models are made from edges and faces, you're most
of the way to understanding how SketchUp works. Here’s some information
that should fill in the gaps (and also check out additional resources on this
book’s companion Web site; see the Introduction for details about the site):

v+ Every time SketchUp can make a face, it will. There’s no such thing as
a “Face tool” in this software; SketchUp just automatically makes a face
every time you finish drawing a closed shape out of three or more copla-
nar edges. Figure 2-6 shows this in action: As soon as I connect the last
edge that [ draw to the first one to close the loop, SketchUp creates a
face.

Figure 2-6:
SketchUp
automati-
cally makes
aface
whenever
you create a
closed loop
of coplanar
edges.
|

+* You can’t stop SketchUp from creating faces, but you can erase them
if you want. If a face you don’t want ends up getting created, just right-
click it and choose Erase from the context menu. That face will be
deleted, but the edges that defined it will remain. (See Figure 2-7.)

v If you delete one of the edges that defines a face, that face will be
deleted, too. When I erase one of the edges in the cube (with the Eraser
tool, in this case), both of the faces that were defined by that edge disap-
pear. This happens because it’s impossible to have a face without also
having all its edges.
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|
Figure 2-7:
You can
delete a
face without
deleting the
edges that
define it.
|

|
Figure 2-8:
Justretrace
any edge

on a closed
loop to tell
SketchUp

to create a
new face.
|

Figure 2-9:
Splitting a
face with

an edge,
and then
extruding
one of the
new faces.

1 Retracing an edge re-creates a missing face. If you already have a closed
loop of coplanar edges, but no face (because you erased it, perhaps),
you can redraw one of the edges to make a new face. Just use the Line
tool to trace over one of the edge segments, and a face will reappear.
(See Figure 2-8.)

Drawing an edge from here... ..to here... ...causes this face to be created

1 Drawing an edge all the way across a face splits the face in two. When
you draw an edge (like with the Line tool) from one side of a face to
another, you cut that face in two. The same thing happens when you
draw a closed loop of edges (like a rectangle) on a face — you end up
with two faces, one “inside” the other. In Figure 2-9, I split a face in two
with the Line tool, and then I extrude one of them out a little bit with the
Push/Pull tool.
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és\LETCIf(,'o + Drawing an edge that crosses another edge automatically splits both
S edges where they cross. This is new for SketchUp 7. In previous ver-
] sions, edges didn’t split each other; you had to do it manually with the

y Line tool.

Drawing in 3D on a 2D Screen

For computer programmers, letting you draw three-dimensional objects on
your screen is a difficult problem. You wouldn’t think it would be such a big
deal; after all, people have been drawing in perspective for a very long time. If
some old guy could figure it out 500 years ago, why should it give your com-
puter any problems?

The thing is, human perception of depth on paper is a trick of the eye.

And of course, your computer doesn’t have eyes that enable it to interpret
depth without thinking about it. You need to give it explicit instructions. In
SketchUp, this means using drawing axes and inferences, as I explain in the
sections that follow.

Don’t worry about drawing in perspective

Contrary to popular belief, modeling in SketchUp
doesn’t involve drawing in perspective and
letting the software figure out what you mean.
There are two reasons for which this turns out
to be a very good thing:

* Most people can't draw in perspective
anyway. | can see you nodding, because
even if you're one of the few folks who
can, you know darn well that most people
couldn't draw an accurate 3D view of the
inside of a room if their life depended on

= (8 CLOI) ULy (1) E I ) it — drawing just isn’t one of the things

out what you're trying to do. This has
probably happened to you: You're working
away at your computer, and the software
you're using tries to “help” by guessing
what you’re doing. Sometimes it works, but
most of the time it doesn't, and eventually,
it gets really annoying. Even if SketchUp
were able to interpret your perspective
drawings, you'd probably spend more time
correcting its mistakes than actually building
something.

we're taught, unfortunately. So even if
SketchUp did work by turning your 2D
perspective drawings into 3D models (which
it most certainly doesn't), the vast majority
of those who “can’t draw” wouldn’t be
able to use it. And that would be a shame,
because building 3D models is a real kick.
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Giving instructions with the drawing axes

Color Plate 1 is a shot of the SketchUp modeling window, right after you create
a new file. See the three colored lines that cross in the lower-left corner of the
screen? These are the drawing axes, and they’re the key to understanding how
SketchUp works. Simply put, you use SketchUp’s drawing axes to figure out
where you are (and where you want to go) in 3D space. When you’re working
with the color axes, you need to keep three important things in mind:

v The red, green, and blue drawing axes define three-dimensional
space in your model. If you were standing at the spot where all three
axes meet (the axis origin), the blue axis would run vertically, passing
through your head and feet. The red and green axes define the ground
plane in SketchUp; you’d be standing on top of them. The axes are all at
right angles to one another, and extend to infinity from the origin.

+ When you draw, move, or copy something parallel to one of the
colored axes, you’re working in that color’s direction. Take a look at
Color Plate 2. In the first image, I'm drawing a line parallel to the red
axis, so I would say I'm drawing “in the red direction.” I'm sure that the
line 'm drawing is parallel to the red axis because it turns red to let me
know. In the second image, I'm moving a box parallel to the blue axis,
so I'm “moving in the blue direction.” I know I'm parallel to the blue axis
because a dotted, blue line appears to tell me so.

1 The whole point of using the red, green, and blue axes is to let
SketchUp know what you mean. Remember that the big problem
with modeling in 3D on a computer is the fact that you're working on
a 2D screen. Consider the example shown in Color Plate 3: If I click the
cylinder with the Move tool and move my cursor up, how is SketchUp
supposed to know whether I mean to move it up in space (above the
ground) or back in space? That’s where the colored axes come into play:
If I want to move it up, I go in the blue direction. If | want to move it back,
[ follow the green direction (because the green axis happens to run from
the front to the back of my screen).

When you’re working in SketchUp, you use the colored drawing axes all
the time. They’re not just handy; they’re what makes SketchUp work.
Having colored axes (instead of ones labeled x, y, and z) lets you draw
in 3D space without having to type in commands to tell your computer
where you want to draw. They make modeling in SketchUp quick, accu-
rate, and relatively intuitive. All you have to do is make sure that you're
working in your intended color direction as you model by lining up your
objects with the axes and watching the screen tips that tell you what
direction you're working in. After your first couple of hours with the
software, paying attention to the colors becomes second nature — I
promise.
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Keeping an eye out for inferences

If you've spent any time fiddling with SketchUp, you’ve noticed all the little
colored circles, squares, dotted lines, yellow tags, and other doodads that
show up as you move your cursor around your modeling window. All this stuff
is referred to collectively as SketchUp’s inference engine, and its sole purpose
is to help you while you're building models. Luckily, it does. Without inferences
(the aforementioned doodads), SketchUp wouldn’t be very useful.

Point inferences

Generally, SketchUp’s inferences help you be more precise. Point inferences
(see Color Plate 2-4) appear when you move your cursor over specific parts
of your model. They look like little colored circles and squares, and if you
pause for a second, they’re accompanied by a yellow tag that says what they
are. For example, watching for the little green Endpoint inference (which
appears whenever your cursor is over one of the ends of an edge) helps you
accurately connect an edge you're drawing to the end of another edge in your
model. Here’s a list of them (I don’t give descriptions because I think they’re
pretty self-explanatory):

v Endpoint (green)

v Midpoint (cyan or light blue)
v Intersection (red X)

v On Edge (red)

v Center (of a circle, green)

v On Face (dark blue)

In SketchUp, lines are called edges, and surfaces are called faces. Everything in
your model is made up of edges and faces.

Linear inferences

As you’ve probably already noticed, color plays a big part in SketchUp’s user
interface (the way it looks). Maybe the best example of this is in the soft-
ware’s linear inferences — the “helper lines” that show up to help you work
more precisely. Color Plate 2-5 is an illustration of all of them in action, and
here’s a description of what they do:

+* On Axis: When an edge you’re drawing is parallel to one of the colored
drawing axes, the edge turns the color of that axis.

v+ From Point: This one’s a little harder to describe. When you’re moving
your cursor, sometimes you’ll see a colored, dotted line appear. This
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means that you're “lined up” with the point at the end of the dotted line.
Naturally, the color of the From Point inference corresponds to which-
ever axis you're lined up “on.” Sometimes From Point inferences show
up on their own, and sometimes you have to encourage them; see the
section “Encouraging inferences,” later in this chapter, for details.

v Perpendicular: When you'’re drawing an edge that’s perpendicular to
another edge, the one you're drawing turns magenta (reddish purple).

v~ Parallel: When it’s parallel to another edge in your model, the edge
you’re drawing turns magenta to let you know. You tell SketchUp which
edge you're interested in “being parallel to” by encouraging an inference.

1 Tangent at Vertex: This one only applies when you’re drawing an arc
(using the Arc tool) that starts at the endpoint of another arc. When the
arc you're drawing is tangent to the other one, the one you're drawing
turns cyan. Tangent, in this case, means that the transition between the
two arcs is smooth.

One of the most important inferences in SketchUp is one that you probably
didn’t even realize was an inference. It’s the fact that, unless you specifically
start on an edge or a face in your model, you’ll always be drawing on the
ground plane by default. That’s right — if you just start creating stuff in the
middle of nowhere, SketchUp just assumes that you mean to be drawing on
the ground.

Using inferences to help you model

A big part of using SketchUp’s inference engine involves locking and encourag-
ing inferences — sometimes even simultaneously. At first, it'll seem a little like
that thing where you pat your head and rub your stomach at the same time,
but with practice, it gets easier.

Locking inferences

If you hold down Shift when you see any of the first four types of linear infer-
ences described previously, that inference gets locked — and stays locked
until you release Shift. When you lock an inference, you constrain whatever
tool you're using to only work in the direction of the inference you locked.
Confused? Check out the following example for some clarity.

Color Plate 6 shows a situation where it would be useful to lock a blue On
Axis inference while I'm using the Line tool. I want to draw a vertical line
that’s exactly as tall as the peak of the house’s roof, so here’s what I do:

1. Click once to start drawing an edge.
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2. Move my cursor up until I see the edge I'm drawing turn blue.

This is the blue On Axis inference that lets me know I'm exactly parallel
to the blue drawing axis.

3. Hold down Shift to lock the inference I see.

My edge gets thicker to let me know it’s locked, and now I can only draw
in the blue direction (no matter where I move my cursor).

4. Click the peak of the roof to make my vertical edge end at exactly that
height.

5. Release Shift to unlock the inference.

Encouraging inferences

Sometimes, an inference you need doesn’t show up on its own — when this
happens, you have to encourage it. To encourage an inference, just hover
your cursor over the part of your model you’d like to “infer” from, and then
slowly go back to whatever you were doing when you decided you could use
an inference. The following example demonstrates how to encourage an
inference.

Color Plate 7 shows a model of a cylinder. I'd like to start drawing an edge
that lines up perfectly with the center of the circle on top of the cylinder, but
[ don’t want it to start at the center itself. Follow these steps:

1. Hover (don’t click) over the edge of the circle for about two seconds.

2. Move slowly toward the middle of the circle until the Center Point
inference appears.

3. Hover (still don’t click) over the center point for a couple of seconds.

4. Move your cursor slowly in the direction of where you want to start
drawing your edge.

A dotted From Point inference should appear.

5. Click to start drawing your edge.

Warming Up Your SketchlUp Muscles

[ can think of seven activities you’ll need to do every time you use SketchUp.
Formal-education types would probably call them “core competencies,” but |
find language like that tends to put people to sleep. Whatever you care to call
these activities, I'll introduce them all at the same time, in the following sec-
tions, so you can come back and get a quick refresher whenever you want.
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Getting the best view of what you're doing

Using SketchUp without learning how to orbit, zoom, and pan is like trying to
build a ship in a bottle. In the dark. With your hands tied behind your back.
Using chopsticks. Get the picture?

Fully half of modeling in SketchUp uses the aforementioned navigation tools,
which let you change your view so that you can see what you’re doing. Most
people who try to figure out SketchUp on their own take too long to under-
stand this; they spend hours squinting, grunting, and having an all-around
miserable time trying to “get at” what they’re working on. The following sec-
tions help you avoid the headache (literally).

SketchUp has three tools that are dedicated to letting you get a better view of
your model. [ usually call them the Big Three, but I'm a little afraid of lawsuits
from big companies in Detroit, so I'll just refer to them collectively as the navi-
gation tools.

Going into orbit

Hold a glass of water in your hand. Now twist and turn your wrist around in
every direction so that the water’s all over you and the rest of the room. Stop
when the glass is completely empty. [ think that’s a pretty memorable way to
find out about the Orbit tool, don’t you?

Just as your wrist helps you twist and turn a glass to see it from every angle,
think of using Orbit as the way to fly around your work. Figure 2-10 shows
Orbit in all its glory.

Here’s some stuff you should know about using Orbit:

+~ It’s on the Camera menu. By far the least productive way to use Orbit is
to choose it from the Camera menu.

v It’s also on the toolbar. The second-least productive way to activate
Orbit is to click its button on the toolbar. It looks like two blue arrows
trying to form a ball.

+* You can orbit using your mouse. Here’s how you should always orbit:
Click the scroll wheel of your mouse and hold it down. Now move your
mouse around. See your model swiveling around? Release the scroll
wheel when you’re done. Using your mouse to orbit means that you
don’t have to switch tools every time you want a better view, which
saves you truckloads of time.
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Figure 2-10:
The Orbit
tool lets you
see your
model from
any angle.
|

Zooming in and out

Hold your empty glass at arm’s length. Close your eyes, and then bring the
glass rushing toward you, stopping right when it smashes you in the nose.

Now throw the glass across the room, noticing how it shrinks as it gets far-
ther away. That, in a nutshell, describes the Zoom tool.

You use Zoom to get closer to (and farther from) your model. If you're work-
ing on something small, you zoom in until it fills your modeling window. To
see everything at once, zoom out. Figure 2-11 is a demonstration. I can think
of a couple things to tell you about Zoom:

Zoomed in Zoomed in even more

|
Figure 2-11: |
Use the
Zoom tool to
get closer to

the action.
|
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v Just like Orbit, you can activate the Zoom tool in several ways. The
worst way is from the Camera menu; the next-worst way is to click the
Zoom tool button in the toolbar. If you use Zoom either of these two
ways, you actually zoom in and out by clicking and dragging up and
down on your screen.

The best way to zoom is to roll your finger on the scroll wheel of your
mouse to zoom in and out. Instead of clicking the scroll wheel to orbit,
just roll your scroll wheel back and forth to zoom. And just like Orbit,
using your mouse to zoom means that you don’t have to switch tools — as
soon as you stop zooming, you revert to whatever tool you were using
before.

v Use Zoom Extents to see everything. Technically, Zoom Extents is a
separate tool altogether, but I think it’s related enough to mention here.
If you want your model to fill your modeling window (which is especially
useful when you “get lost” with the navigation tools — trust me, it
happens to everyone), just choose Camera=>Zoom Extents.

<P When you use the Zoom tool, SketchUp zooms in on your cursor; just position it
over whatever part of your model you want to zoom in on (or zoom out from).
If your cursor isn’t over any of your model’s geometry (faces and edges), the
Zoom tool won’t work very well — you’ll end up zooming either really slowly
or really quickly.

Just panning around

Using the Pan tool is a lot like washing windows — you move the paper towel
back and forth, but it stays flat and it never gets any closer or farther away
from you. The Pan tool is basically for sliding your model view around in
your modeling window. To see something that’s to the right, you use Pan to
slide your model to the left. It’s as simple as that. You should know these
three things about Pan:

v Pan is on the Camera menu. But that’s not where you should go to
activate it.

v Pan is also on the toolbar. You could access the Pan tool by clicking its
button on the toolbar (it looks like a severed hand), but there’s a better
way. ...

1+ Hold down your mouse’s scroll wheel button and press Shift. When
you do both at the same time — basically, Orbit+Shift — your cursor
temporarily turns into the Pan tool. When it does so, move your mouse
to pan.
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Figure 2-12:
Use the Line
tool to draw
edges.
|

Drawing edges with ease

Being able to use the Line tool without having to think too much about it is the
secret to being able to model anything you want in SketchUp. You use the Line
tool to draw individual edges, and because SketchUp models are really just
fancy collections of edges (carefully arranged, I'll admit), anything you can
make in SketchUp, you can make with the Line tool.

SketchUp models are made up of edges and faces. Anytime you have three or
more edges that are connected and on the same plane, SketchUp creates a face.
If you erase one of the edges that “defines” a face (borders it), the face disap-
pears, too. Take a look at the section “It’s All about Edges and Faces,” earlier
in this chapter, for more information on the relationship between edges and
faces.

Drawing edges is simple. Just follow these steps:

1. Select the Line tool (some people call it the Pencil tool).
2. Click where you want your line to begin.

3. Move your cursor to the desired endpoint for your line, and click
again to end.

Figure 2-12 demonstrates the basic idea.

When you draw a line segment with the Line tool, notice how SketchUp
automatically tries to draw another line? This is called rubber banding —
the Line tool lets you “continue” to draw edge segments, automatically
starting each new one at the end of the previous one you drew.

4. When you want the Line tool to stop drawing lines, press Esc to snip
the line at the last spot you clicked.
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Depending on what you're making, and on how 2. Choose the Drawing panel from the list on
you work, you might want to turn the Line tool’s the left in the Preferences dialog box.
rubber-banding behavior off. To do so, follow
these steps:

1. Choose Windowr>Preferences (SketchUp=>
Preferences on the Mac).

Turning off “rubber-banding” lines

3. Deselect the Continue Line Drawing check
box.

A\

SketchUp lets you draw lines in two ways: You can either use the click-drag-
release method or the click-move-click one. They both work, of course, but

[ highly recommend training yourself to do the latter. You’ll have more con-
trol, and your hand won'’t get as tired. When you draw edges by clicking and
dragging your mouse (click-drag-release), you're a lot more likely to “drop”
your line accidentally. Because the Line tool only draws straight lines, think
about using it less like a pencil (even though it looks like one) and more like a
spool of sticky thread.

The Eraser tool is specifically designed for erasing edges; use it by clicking
the edges you don't like to delete them. You can also drag over edges with the
Eraser, but I think that’s a little harder to get used to.

Injecting accuracy into your model

It’s all well and fine to make a model, but most of the time, you need to make
sure that it’s accurate. Without a certain level of accuracy, it’s not as useful for
figuring things out. The key to accuracy in SketchUp is the little text box that
lives in the lower-right corner of your SketchUp window — the one I point out
in Figure 2-13.

It’s called the Measurements box, and here are some of the things you can do
with it:

1 Make a line a certain length

v Draw a rectangle a certain size

v Push/pull a face a certain distance

v Change the number of sides in a polygon

v Move something a given distance
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Figure 2-13:
SketchUp's
Measure-
ments box

is the key

to working
precisely.
|

7 Untitled - BEx

Eile Edit View Camera Draw Tools Window Help
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[elect end point or enter value, | tengthp5a5a |

Value Control box

1 Rotate something by a certain number of degrees
v Make a certain number of copies
v Divide a line into a certain number of segments

v Change your field of view (how much you can see)
Here are some things you should know about the Measurements box:

+* You don’t have to click in the Measurements box to enter a number.
This one’s a big one: When they’re first starting out with SketchUp,
people assume that they need to click in the Measurements box (to
select it, presumably) before they can start typing. They (and you)
don’t — just start typing, and whatever you type shows up in the box
automatically. When it comes to being precise, SketchUp is always “lis-
tening” for you to type something in this box.

1 The Measurements box is context-sensitive. This means that what it
controls depends on what you happen to be doing at the time. If you're
drawing an edge with the Line tool, it knows that whatever you type is a
length; if you're rotating something, it knows to listen for an angle.
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+ You the set the default units for the Measurements box in the Model
Info dialog box. Perhaps you want a line you're drawing to be 14 inches
long. If you’re set up to use inches as your default unit of measurement,
just type 14 into the Measurements box and press Enter — SketchUp
assumes that you mean 14 inches. If you want to draw something 14 feet
long, you would type in 14', just to let SketchUp know that you mean feet
instead of inches. You can override the default unit of measurement by
typing in any unit you want. If you want to move something a distance
of 25 meters, type in 25m and press Enter. You set the default units for
the Measurements box in the Units panel of the Model Info dialog box
(which is on the Window menu).

* Sometimes, the Measurements box does more than one thing. In
certain circumstances, you can change its mode (what it’s “listening
for”) by typing in a unit type after a number. For example, when you’re
drawing a circle, the default “value” in the Measurements box is the
radius — if you type 6 and press Enter, you’ll end up with a circle with a
radius of 6 inches. But if you type in 6s, you're telling SketchUp that you
want 6 sides (and not inches), so you'll end up with a circle with 6 sides.
If you type in 6 and press Enter, and then type in 6s and press Enter
again, SketchUp will draw a hexagon (a 6-sided circle) with a radius of 6
inches.

v The Measurements box lets you change your mind. As long as you
don’t do anything after you press Enter, you can always type a new
value and press Enter again; there’s no limit to the number of times you
can change your mind.

+* You can use the Measurements box during an operation. In most
cases, you can use the Measurements box to be precise while you're
using a tool. Here’s how that works:

1. Click once to start your operation (such as drawing a line or using
the Move tool).

2. Move your mouse so that you're “going in the correct color direc-
tion.” If you’re using the Line tool and you want to draw parallel to
the green axis, make sure that the edge you're drawing is green. Be
sure not to click again.

3. Without clicking the Measurements box, just type in the dimension
you want; you should see it appear in the box.

4. Press Enter to complete the operation.

+* You can also use the Measurements box after an operation. Doing this
revises what you've just done. These steps should give you an idea of
what I'm talking about:

1. Complete your operation. This might be drawing a line, moving
something, rotating something, or any of the other things [ men-
tioned at the beginning of this section.
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2. Before you do anything else, type in whatever dimension you
intended, and then press Enter. Whatever you did should be
redone according to what you typed in.

To give you a more concrete example, say [ want to move my box (shown in
Figure 2-14) a total of 5 meters in the red direction (parallel to the red axis).
Here’s what I'd do:

1. Using the Move tool, I click the box once to pick it up.

2. I move my mouse until I see the linear inference that tells me I'm moving
in the red direction.

3. Itype in 5m, and then I press Enter. My box is positioned exactly 5
meters from where I picked it up.

4. On second thought, [ don’t think I'm happy with the 5 meters, so I decide
to change it. I type in 15m, and then press Enter again; the box moves
another 10 meters in the blue direction. I can keep doing this until 'm
happy (or bored).

7 Untitled - Pro BEE|

File Edit View Camera Draw Tools Window Help

A ZBOC I RBBILXOEH2ZAR DL

Figure 2-14:
| move

the box 5
meters,
and then

| change
my mind
and move

it 15 meters
instead.
E— O @ @ @ Select end point or enter value. Length |12' 8 3/16"
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Resizing everything with the Tape Measure tool

Consider that you've been working away in
SketchUp, not paying particular attention to how
big anything in your model is, when you sud-
denly decide that you need what you’ve made to
be a specific size. SketchUp has a terrific trick
for taking care of this exact situation: You can
use the Tape Measure tool to resize your whole
model based on a single measurement.

Here's how it works: In the following figure,
I've started to model a simple staircase, and
now | want to make sure that it's the right size;
doing so will make it easier to keep working on
it. | know | want the riser height (the vertical
distance between the steps) to be 7 inches, so
this is what | do:

1. Select the Tape Measure tool (choose
Tools=>Tape Measure).

2. Make sure that the Tape Measure is in
Measure mode by pressing Ctrl (Option on
the Mac) until you don’t see a plus sign (+)
next to the Tape Measure cursor.

3. To measure the distance | want to change
(in this case, the riser height), | click once
to start measuring and click again to stop.

4. | type in the dimension | want what | just
measured to be: 7 (for 7 inches).

5. In the dialog box that appears, asking me
whether | want to resize my whole model,
| click the Yes button.

When | click the Yes button, my whole model
is resized proportionately to the dimension |
entered.

Measure from here... ... to here

v FBOC CHEBLAOF VIR DLO 0T

SketchUp

\?} Do you want to resize the model?

v FBOC CHEBLXOF VIR DLO 0T

"
%
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Selecting What You Mean to Select

If you want to move something in your model, or rotate it, or copy it, or do any
number of other things to it, you need to select it first. When you select ele-
ments, you're telling SketchUp that this is the stuff you want to work with. To
select things, you use (drum roll, please) the Select tool, which looks exactly
the same as the Select tool in every other graphics program on the planet —
it’s an arrow. That’s a good thing, because selecting isn’t the sort of thing you
should have to relearn every time you pick up a new program. Here’s every-
thing you need to know about selecting things in SketchUp:

v Just click anything in your model to select it (while you’re using the
Select tool, of course).

1 To select more than one thing, hold down Shift while you click all the
things you want to select. (See Figure 2-15.)

<P Shift works both ways when it comes to the Select tool. You can use it
to add to your set of selected objects (which I mention above), but you
can also use it to subtract an object from your selection. In other words,
if you have a bunch of stuff selected, and you want to deselect some-
thing in particular, just hold down Shift while you click it — it won’t be
selected anymore.

1 Selected objects in SketchUp look different depending on what kind of
objects they are:

e Selected edges and guides turn blue.
¢ Selected faces look covered in tiny blue dots.

¢ Selected groups and components (which you can read about in
Chapter 5) get a blue box around them.

¢ Selected section planes (see Chapter 10 for more info on these)
turn blue.

|
Figure 2-15: &
Click things v
with the
Select tool
to select
them. Hold |
down Shift ©
to select
more than
one thing.
|

Length 10m Length |15m
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<P +* A much fancier way to select things in your model is to double- and
triple-click them. When you double-click a face, you select that face and
all the edges that define it. Double-clicking an edge gives you that edge
plus all the faces that are connected to it. When you triple-click an edge
or a face, you select the whole object that it’s a part of. Figure 2-16
shows what I mean.

Figure 2-16:
Try single-,
double-, and
triple-
clicking L e . o o T
edges and 4 e 1 o [
facesin " ' ) )
your model
to make
different
kinds of
selections.
|

Double-click selects the Triple-click selects the
Single click selects a face face and edges whole object

+* You can also select several things at once by dragging a box around
them. You have two kinds of selection boxes; which one you use
depends on what you're trying to select (see Figure 2-17):

e Window selection: If you click and drag from left to right to make
a selection box, you create a window selection. In this case, only
things that are entirely inside your selection box are selected.

¢ Crossing selection: If you click and drag from right to left to make a
selection box, you create a crossing selection. With one of these,
anything your selection box touches (including what’s inside) ends
up getting selected.

I keep saying that selected stuff turns blue in SketchUp, but you can make it turn
any color you want. Blue is just the default color for new documents you create.
The “selected things” color is one of the settings you can adjust in the Styles
dialog box; if you're interested, you can read all about styles in Chapter 9.

Just because you can’t see something doesn’t mean it isn’t selected. Whenever
you make a selection, it’s a very good idea to orbit around to make sure
you've got only what you intended to get. Accidentally selecting too much is
an easy mistake to make.
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Only this is selected

Figure 2-17:
Dragging
left to right
selects
everything
inside your B E—— All this is selected too
selection |
box.
Dragging
right to left
selects
everything
that your
selec-
tion box
touches.
|

Mm/inq and copying like a champ

To move things around in SketchUp, you use the Move tool. To make a copy of
something, you use the Move tool in combination with a button on your key-
board: Ctrl in Windows and Option on a Mac. It’s really that simple.

Moving things around

The Move tool is the one that looks like crossed red arrows. Using it involves
clicking the entity you want to move, moving it to where you want it to be, and
clicking again to drop it. It’s not a complicated maneuver, but getting the hang
of it takes a little bit of time. Here are some tips for using Move successfully:

v Click, move, and click. Don’t drag your mouse. Just like using the Line
tool, try to avoid the temptation to use the Move tool by clicking and
dragging around with your mouse; doing so makes things a lot harder.
Instead, practice clicking once to pick things up, moving your mouse
without any buttons held down, and clicking again to put down what-
ever you're moving.

www.it-ebooks.info


http://www.it-ebooks.info/

Part I: Getting Started with SketchUp

v Click a point that will let you position it exactly where you want when
you drop it (instead of just clicking anywhere on the thing you’re
trying to move to pick it up). Figure 2-18 shows two boxes that I want
precisely to stack on top of each other. If I just click anywhere on the
first box and move it over the other one, I can’t place it where I want;
SketchUp just doesn’t work that way.

To stack the boxes precisely, I have to click the botfom corner of the
soon-to-be top box to grab it there, and then move my cursor over the top
corner of the bottom box to drop it. Now my boxes are lined up perfectly.

Picking it up here... ..doesn't let you stack properly

i o —
.[c'.__hﬁ '_.- ,

I Picking it up here... ...lets you stack precisely
Figure 2-18:
To move
things
precisely,
choose
precise
points to
grab things
and put
them down.
|

\
L
/
AN

1~ Press Esc to cancel a move operation. Here’s something beginners do
all the time: They start to move something (or start moving something
accidentally), and then they change their minds. Instead of pressing Esc,
they try to use Move to put things back the way they were. Inevitably,
they don’t, and things end up getting messed up.

If you change your mind in the middle of moving something, just press
Esc; everything will go back to the way it was.
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+ Don’t forget about inferences. To move something in one of the colored
directions, just wait until you see the dotted On Axis linear inference
appear; then hold down Shift to lock yourself in that direction. For more
information about using SketchUp’s inference engine, check out the sec-
tion “Keeping an eye out for inferences,” earlier in this chapter.

v Don’t forget about the Measurements box. You can move things precise
distances using the Measurements box; have a look at the section “Injecting
accuracy into your model,” earlier in this chapter, to find out how.

Modeling with the Move tool

In SketchUp, the Move tool is very important for modeling; it’s not just for
moving whole objects around. You can also use it to move just about any-
thing, including vertices (edges’ endpoints), edges, faces, and combinations of
any of these. By only moving certain entities (all the things I just mentioned),
you can change the shape of your geometry pretty drastically. Figure 2-19
shows what [ mean.

Moving a vertex

Figure 2-19:
You canuse |
the Move
tool on
vertices,
edges,
and faces
to model
different
forms.
|

Moving an edge Moving a face
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Telling SketchUp who's boss with Auto-Fold

This will happen to you sooner or later: You'll
be trying to move a vertex, an edge, or a face,
and you won't be able to go in the direction you
want. SketchUp doesn't like to let you create
folds (when extra faces and edges are created
in place of a single face) with the Move tool, so
it constrains your movement to directions that
won't end up adding them. If SketchUp won't

let you move whatever you're trying to move,
force it by doing one very important thing:
Press and hold down Alt (88 on a Mac) while
you're moving. When you do this, you're telling
SketchUp that it's okay to proceed — to create
folds if it has to. This is called Auto-Fold, and the
following figure shows how it works.

Click once with the Move tool
to start moving

Hold down Alt (38 on a Mac)
and move your mouse

\\3

Using the Move tool to create forms (instead of just moving them around) is
an incredibly powerful way to work, but isn’t particularly intuitive. After all,

nothing in the physical world behaves like the Move tool — you can’t just grab

the edge of a hardwood floor and move it up to turn it into a ramp in real life.
In SketchUp, you can — and should.
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To preselect or not to preselect

The Move tool works in two different ways; you’ll eventually need to use both
of them, depending on what you’re trying to move:

1 Moving a selection: When you have a selection of one or more entities,
the Move tool only moves the things you've selected. This comes in
handy every time you need to move more than one object; Figure 2-20
shows a selection being moved with the Move tool.

This isn't selected ...s0 it doesn’t move with the rest
|
Figure 2-20:
Using the
Move tool
when you
have a

selection |
only moves
the things
in that
selection.
|

1 Moving without a selection: If you don’t have anything selected, you
can click anything in your model with the Move tool to move it around.
Only the thing you click is moved. Figure 2-21 shows what I'm talking
about.

Making copies with the Move tool

Lots of folks spend time hunting around in SketchUp, trying to figure out how
to make copies. It’s very simple: You just press a modifier key (a button on
your keyboard that tells SketchUp to do something different) while you're
using the Move tool. Instead of moving something, you move a copy of it.
Here are a couple of things to keep in mind:

1 Press Ctrl to copy in Windows, and press Option to copy on a Mac.
This tells SketchUp to switch from Move to Copy while you’re moving
something with the Move tool. Your cursor shows a little + next to it,
and your copy moves when you move your mouse. Figure 2-22 shows
3 this in action.

If you decide you don’t want to make a copy, just press Ctrl (Option)
again to toggle back to Move; the + sign will disappear.

v Copying is just like moving, except you’re moving a copy. This means
that all the same rules that apply to using the Move tool apply to making
copies, too.
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__| 22

Figure 2-21:
Without
anything
selected,
you can
click
anything in
your model
with the
Move tool to
start moving
it around.

Figure 2-22:
Press Ctrl
(Optionona
Mac) to tell
SketchUp to
make a copy
while you're
moving
something.
|

<P +* You can make more than one copy at a time. Perhaps [ wanted to make
five equally spaced copies of a column, as shown in Figure 2-23. All [ have
to do is move a copy to where [ want my last column to be; then I type
in 5/ and press Enter. This makes five copies of my column and spaces
them evenly befween the first and last column in the row. Neat, huh?

If I know how far apart [ want my copies to be, [ can move a copy that
distance, type in 5x, and press Enter. My five copies appear equally
spaced in a row. (See Figure 2-24.)
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Figure 2-23:
Make
evenly
spaced
copies by Length 5/
typing in
the number
of copies
you want
followed by
a slash (/),
and press
Enter.
|

Figure 2-24:
To make
multiple
copiesina
row, type in
the number
of copies
you want,
type an x,
and press
Enter.
|

Length |5x ‘
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Figure 2-25:
Use guides
to measure
things
before you
draw.
|

Making and using guides

Sometimes you need to draw temporary lines while you’re modeling. These
temporary lines, called guides, are useful for lining things up, making things
the right size, and generally adding precision and accuracy to what you're
building.

In previous versions of SketchUp, guides were called construction geometry,
because that’s basically what they are: a special kind of entity that you create
when and where you need them. They aren’t part of your model, because
they’re not edges or faces. This means that you can choose to hide them or
delete them — they don’t affect the rest of your geometry.

Figure 2-25 shows an example of guides in action. I use guides positioned 12
inches from the wall and 36 inches apart to draw the sides of a doorway. I
use another guide 6 feet, 8 inches from the floor to indicate the top, and then
[ draw a rectangle, bounded by my guides, which I know is exactly the right
size. When I'm done, | erase my guides with the Eraser tool, as I explain in a
moment.

/ __HH"“‘MHE / __HH"“‘MHE
. _\_\_\_\_\_‘_"—\—\_ _\_\_\_\_\_\_"—\—\_

/ﬁxhﬁ"‘“‘xam / _HEHE

Creating guides with the Tape Measure tool

You can create three different kinds of guides, and you use the Tape Measure
tool to make all of them. (See Figure 2-26.)
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Click here to start

Parallel guide line

<

Click here to start
...and here to finish

Linear guide line

Figure 2-26:
Use the
Tape
Measure
tool to
create guide
lines and
points.
|

Click here to start

Guide point

v Parallel guide lines: Clicking anywhere (except the endpoints or mid-
point) along an edge with the Tape Measure tells SketchUp that you
want to create a guide parallel to that edge. (See Figure 2-26.) Just move
your mouse and you’ll see a parallel, dashed line; click again to place it
wherever you want.

v Linear guide lines: To create a guide along an edge in your model, click
one of the endpoints or the midpoint once, and then click again some-
where else along the edge.

+* Guide points: You might want to place a point somewhere in space; you
can do exactly that with guide points. With the Tape Measure tool, click
an edge’s midpoint or endpoint, and then click again somewhere else in
space. A little x appears at the end of a dashed line — that’s your new
guide point.
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Here’s an important point about the Tape Measure tool: It has two modes, and
it only creates guides in one of them. Pressing Ctrl (Option on a Mac) toggles
between the modes. When you see a + next to your cursor, your Tape Measure
can make guides; when there’s no +, it can’t.

Using guides to make your life easier

As you’re working along in this software, you’ll find yourself using guides
all the time; they’re an indispensable part of the way modeling in SketchUp
works. Here are some things you should know about using them:

1 Position guides precisely using the Measurements box. Check out the
section “Injecting accuracy into your model,” earlier in this chapter, to
find out how.

v Erase guides one at a time. Just click or drag over them with the Eraser
tool to delete guides individually. You can also right-click them and
choose Erase from the context menu.

v Erase all your guides at once. Choosing Edit=>Delete Guides does just
that.

v Hide guides individually or all at once. Right-click a single guide and
choose Hide to hide it, or deselect View=>Guides to hide all of them. It’s
a good idea to hide your guides instead of erasing them, especially while
you're still modeling.

1 Select, move, copy, and rotate guides just like any other entity in your
model. Guides aren’t edges, but you can treat them that way a lot of the
time.

Painting your faces with color and texture

When it comes to adding colors and textures — collectively referred to in
SketchUp as materials — to your model, there’s really only one place you
need to look, and one tool you need to use — the Materials dialog box and
the Paint Bucket tool, respectively.

The Matevials dialog box

To open the Materials dialog box (or Colors dialog box on the Mac), choose
Windowr>Materials. Figure 2-27 shows what you see when you do. The
Materials dialog box is radically different in the Windows and Mac versions of
SketchUp, but that’s okay — they basically do the same thing.
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In SketchUp, you can choose from two different kinds of materials to apply to
the faces in your model:

v Colors: These are simple — colors are always solid colors. You can’t
have gradients (where one color fades into another), but you can pretty
much make any color you want.

1 Textures: Basically, a SketchUp texture is a tiny image — a photograph,
really — that gets tiled over and over to cover the face you apply it to.
If you paint a face with, say, a brick texture, what you're really doing is
telling SketchUp to cover the surface with however many “brick photo”
tiles it takes to do the job. The preview image you see in the Materials
dialog box is actually a picture of a single texture image tile.

SketchUp comes with a whole bunch of textures, and you can always go
online and choose from thousands more available for sale. And if that’s
still not enough, you can make your own (though the process is well
beyond the scope of this humble tome).
W On the Mac, you have to click the little brick icon in the Materials dialog box
to see the textures libraries that ship with SketchUp; it’s the drop-down list
next to the little house icon.

Here’s some more interesting information about SketchUp materials:
1 Materials can be translucent. Sliding the Opacity slider makes the

material you've selected more or less translucent, which makes seeing
through windows in your model a lot easier.
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1 Textures can have transparent areas. If you take a look at the materi-
als in the Fencing library, you’ll notice that a lot of them look kind of
strange; they have areas of black that don’t seem right. These black
areas are areas of transparency — when you paint a face with one of
these textures, you'll be able to see through the areas that look black.

+* You can edit materials, and even make your own. I'd consider this to
be a pretty advanced use of SketchUp, so I'm not going to talk about it in
this book, but I thought you should at least know it’s possible.

The Paint Bucket tool

The Paint Bucket tool looks just like — you guessed it — a bucket of paint.
Activating it automatically opens the Materials dialog box, which is handy.
Here’s everything you need to know about the Paint Bucket:

v You fill it by clicking in the Materials dialog box. Just click a material
to load your bucket, and then click the face you want to paint. It’s as

simple as that.

1+ Holding down Alt (38 on a Mac) switches to the Sample tool. With the
Sample tool, you can click any face in your model to load your Paint
Bucket with that face’s material. Release the Alt key to revert to the
Paint Bucket tool.

1 Holding down Shift paints all similar faces. If you hold down Shift when
you click to paint a face, all faces in your model that match the one you
click will be painted, too. If things don’t turn out the way you want, just
choose Edit>Undo to go back a step.
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In This Chapter

Building a simple model
Changing the way the model looks
Exporting a JPEG file that you can e-mail

f you can’t wait to get your hands dirty (so to speak), you've come to the

right chapter. Here, I help you make a simple model step by step, spin it
around, paint it, and even apply styles and shadows. You don’t need to read
another word of this book to be able to follow along, although I do refer you
to chapters where you can find out more. Above all, these pages are about
doing and about the basics of putting together the various SketchUp features
to produce a knockout model in no time.

So what are you going to build? Perhaps a doghouse. The nice thing about
doghouses is that they’re a lot like peoplehouses in the ways that count:
They have doors and roofs, and just about everybody has seen one.

“&N\BER One last thing: Just about every other piece of this book is written so that you
& can jump around to the bits you need; you don’t have to follow a particular
order. I'm afraid this chapter is the exception to that rule. If you want to follow
along, you should start on this page and work your way to the end. Otherwise,
things just won’t make sense.

Setting Things Up

[ know — setup is boring. Who wants to flip through menus and options
dialog boxes instead of jumping in? [ completely agree, so I'll keep this short
and sweet. This section is just about making sure that you're starting at the
right place. That’s it.
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Follow these steps to get ready:

1. Launch Google SketchUp.
2. Choose your default settings.

If you've never launched SketchUp on your computer before, you'll see
the Welcome to SketchUp dialog box. (See Figure 3-1.) Here’s what to do
if it pops up:

‘Welcome to SketchUp

Figure 3-1:
The Learn to use SketchUp
Watch more videos
Welcome to Read the documentation

SketchUp
dialog box,
which pops | \
up the first Q:\‘!‘.l_‘gflﬁh‘_"\cg_gﬁgj‘Iﬂ,
timeyou - T Jc{replayvid:en
launch

SketchUp. [fLr_temelte .
I Always show on startup
|

a. Click the Choose Template button.

b. Choose one of the “Architectural Design” templates — it doesn’t
matter if you prefer Feet and Inches or Millimeters.

c. Click the Start using SketchUp button to close the dialog box and
open a new SketchUp file.

If the Welcome to SketchUp dialog box doesn’t appear, someone (maybe
you) has told the dialog box not to show up automatically on startup.
Don’t worry — just follow these steps to set things straight:

a. Choose Help ="Welcome to SketchUp from the menu bar.
b. Do Steps a and b from the list a few sentences ago.
c. Open a new file by choosing Filec>New.

<P If you'’re using the Pro version of SketchUp 7, the Welcome to SketchUp
dialog box looks a little different — it includes information about your
software license. The best place to go for help when you’re having trou-
ble with your license is the SketchUp Help Center. Choose Help=>Online
Help Center to go there directly from SketchUp.
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3. Make sure that you can see the Getting Started toolbar.

Figure 3-2 shows the Getting Started toolbar. If it’s not visible in your
modeling window, choose Viewr>Toolbars=>Getting Started to make it
show up. If you're on a Mac, choose View=>Show Toolbar.

|
Figure 3-2:

The Getting Line Arc  Eraser Push/Pull Orbit  Zoom
Started | | | | |

toobarlives [n [/W@C - ¢ BB ERSE H2ZAR QL =€ 7]

at the top of | | |

your madal- Rectangle Paint Bucket Zoom Extents
ing window.
—— Select Pan

4. Clear your modeling window.

If this isn’t the first time SketchUp has been run on your computer, you
might see dialog boxes all over the place. If that’s the case, just open the
Window menu and make sure that everything is deselected to get rid of
them.

Making a Quick Model

Figure 3-3 shows what your computer screen should look like at this point.
You should see a row of tools across the top of your modeling window, a
little man, and three colored modeling axes (red, green, and blue lines).

. A T e T emec 098 s XNOE SR s o
Figure 3-3:
This is what

your screen

should !
look like in L
Windows i |
(left) and
on a Mac
(right). |
\\EWEB

(9

Follow these steps to build a doghouse (and check this book’s companion
Web site at www . dummies . com/go/SketchUp7FD for additional help):
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|
Figure 3-4:
Draw a 3D
rectangle on
the ground.
|

\\3

1. Delete the little man on your screen.

Using the Select tool (the arrow on the far left of your toolbar), click the
little man to select him (his name is Sang, in case that matters to you),
and then choose Edit=>Delete.

. Choose Camera~Standard Views=Iso.

This switches you to an isometric (3D) view of your model, which allows
you to build something without having to “move around.”

. Draw a rectangle on the ground.

Use the Rectangle tool (between the pencil and the circle on your tool-
bar) to draw a rectangle by doing the following:

a. Click once to place one corner on the left side of your screen.

b. Click again to place the opposite corner on the right side of your
screen.

Remember that you're in a 3D, perspective, view of the world, so your
rectangle will look more like a diamond — 90-degree angles don’t look
like 90-degree angles in perspective. Figure 3-4 shows what you should
be aiming for in this step.

Click here to start drawing Finish drawing here

It’s important to draw the right kind of rectangle for this example (or for
any model you're trying to create in Perspective view), so try it a few times
until it looks like the rectangle in Figure 3-4. To go back a step, choose
Edit=>Undo Rectangle; the last thing you did will be undone. You can use
Undo to go back as many steps as you like, so feel free to use it anytime.
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4. Use the Push/Pull tool to extrude your rectangle into a box.

Use this tool (it looks like a brown box with a red arrow coming out the
top) to pull your rectangle into a box by following these steps:

a. Click the rectangle once to start the push/pull operation.

b. Click again, somewhere above your rectangle, to stop pushing/
pulling.

At this point, you should have something that looks like Figure 3-5; if you
don’t, use Push/Pull again to make your box look about the right height.

Figure 3-5:
Use the
Push/Pull
tool to
extrude your
rectangle
into a box.
|

o If you are happily pushing/pulling away on your box, and everything

suddenly disappears, it’s because you pushed/pulled the top of your
box all the way to the ground. Just choose Edit>Undo and keep going.

5. Draw a couple of diagonal lines for your roof.

Use the Line tool (it’s shaped like a pencil) to draw two diagonal edges
(lines) that will form your peaked roof, as shown in Figure 3-6. Follow
these steps:

a. Click once at the midpoint of the top of your box’s front face to
start your line.

You’'ll know you're at the midpoint when you see a small, light-blue
dot and the word Midpoint appears. Move slowly to make sure that
you see it.

b. Click again somewhere along one of the side edges of your box’s
front face to end your line.
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Click here to start drawing Click here to finish your first edge
Figure 3-6:
Draw two
diagonal
lines that
will become
your peaked
roof.
|
Wait until you see a red On Edge cue (just like the Midpoint one
in the last step) before you click; if you don’t, your new line won’t
end on the edge like it’s supposed to.
c. Repeat the previous two steps to draw a similar (but opposite) line
from the midpoint to the edge on the other side of the face.
Don’t worry about making your diagonal lines symmetrical; for the
purposes of this exercise, it’s not important that they are.
6. Push/pull the triangles away to leave a sloped roof.
Use the Push/Pull tool (the same one you used back in Step 4) to get rid
of the triangular parts of your box, leaving you with a sloped roof. Have
a look at Figure 3-7 to see this in action, and follow these steps:
|
Figure 3-7:
Use the
Push/Pull
tool to form
a peaked
roof on your
box.
|
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a. Select the Push/Pull tool, then click the right triangular face once
to start the push/pull operation.

b. Move your cursor to the right to push the triangle as far as it will
go (even with the end of your box).

c. Click again (on the triangle) to end the push/pull operation and to
make the triangular face disappear.

d. Still using the Push/Pull tool, double-click the left triangular face to
repeat the previous push/pull operation, making that face disap-
pear as well.

7. Draw a rectangle on your front face.

Switch back to the Rectangle tool (which you used in Step 3) and draw

a rectangle on the front face of your pointy box. Make sure that the
bottom of your rectangle is flush with the bottom of your box by watch-
ing for the red On Edge hint to appear before you click. Check out Figure
3-8 to see what it should look like when you’re done.

Finish here

|
Figure 3-8:
A rectangle
drawn on
the front of
your pointy
box.
|

Click here to start drawing

Q‘&N\BER Using the Rectangle tool is a two-step process: You click once to place
& one corner and again to place the opposite corner. Try not to draw lines
and shapes in SketchUp by dragging your cursor; doing so makes things
more difficult. Practice clicking once to start an operation (like drawing
a rectangle) and clicking again to stop.

www.it-ebooks.info


http://www.it-ebooks.info/

64

Part I: Getting Started with SketchUp

8. Draw an arc on top of the rectangle you just drew.

Use the Arc tool (to the right of the Circle tool) to draw an arc on top of
your rectangle (see Figure 3-9). Follow these steps to draw an arc:

Click here to start Click here second

|
Figure 3-9:
Draw an
arc on top
of your
rectangle.
|
Click up here third
a. Click the upper-left corner of the rectangle to place one endpoint
of your arc. Make sure that you see the green Endpoint hint before
you click.
b. Click the upper-right corner of the rectangle to place the other end-
point of your arc.
c. Move your cursor up to “bow out” the line you’'re drawing into an
arc, and click when you're happy with how it looks.
9. Select the Eraser tool and then click the horizontal line between the
rectangle and the arc to erase that line.
10. Push/pull the doorway inward.
Use the Push/Pull tool (which you’re an old hand with by now) to push
Q‘&N\BER the “doorway” face you created in Steps 7 through 9 in just a bit.
Y
&

You use Push/Pull by clicking a face once to start, moving your cursor to
“push/pull” it in or out, and then clicking again to stop.
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11. Erase the horizontal line at the bottom of the doorway by clicking it
with the Eraser tool.

This makes the line (and the whole face above it) disappear. Figure 3-10
shows what your finished doghouse should look like.

|
Figure 3-10: |
Create
the door
opening
by erasing |
its bottom |
edge.
|

For a more detailed introduction to drawing lines and working with mid-
points, angles, and more, flip to Chapter 2.

Slapping on Some Paint

[ have an ulterior motive for getting you to paint your doghouse: To color

it, you have to understand how to spin it around first. Moving around your
model is the most important skill to develop when you're first learning
SketchUp. Run through these steps to apply colors (and textures) to the faces
in your model, and to find out about moving around while you’re doing it:

1. Choose Window=>Materials to open the Materials dialog box (see
Figure 3-11). Click a color or texture you like.

When you do, you automatically “pick up” the Paint Bucket tool and fill
it with your chosen material.

2. Paint some of the faces in your model by clicking any face you want to
paint with the Paint Bucket tool.

3. Switch materials.
Choose another material from the Materials dialog box by clicking it.
4. Paint the rest of the faces you can see. (Refer to Figure 3-12.)

Loop through Steps 2 to 4 for as long as you like. Finding the Materials
dialog box in SketchUp is just like getting a brand-new box of crayons
when you were little (you know, the big box, with the built-in sharpener).
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Figure 3-11:
The
Materials
dialog box
in Windows
(left) and on
a Mac.
|

Figure 3-12:
Use the
Paint
Bucket tool
to paint
everything
you can see.
|
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5. Choose the Orbit tool; it’s just to the left of the creepy white hand on
the toolbar.

6. Click somewhere on the left side of your screen and drag your cursor
over to the right. (See Figure 3-13.) Release your mouse button when
you’re done.

Your model spins! This is called orbiting. Orbit around some more, just
to get the hang of it.

If you're orbiting, and you’ve dragged your cursor over as far as it will
go, and you haven’t orbited as much as you wanted to, don’t fret. Just
release the mouse button, move your cursor over to where it was when
you started orbiting, and orbit some more by clicking and dragging. You
usually can’t see what you want to see with a single orbit; you need a
bunch of separate drags (separate orbits, I guess) to get things looking
the way you want them to.
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Figure 3-13:
Choose the
Orbit tool
and drag
your
cursor to
spin your

model |

around.
|
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7. Zoom in and out if you need to by selecting the Zoom tool and

dragging your cursor up and down in your modeling window.

The Zoom tool looks like a magnifying glass, and it’s on the other side of
the creepy white hand. Dragging up zooms in, and down zooms out.

. If needed, move around in two dimensions with the Pan tool by

selecting it and then clicking and dragging the Pan cursor inside your
modeling window.

The Pan tool is the creepy white hand between Orbit and Zoom. You use
Pan to slide your model around inside your modeling window without
spinning it around or making it look bigger or smaller. You can pan in
any direction.

. Use the Orbit, Zoom, Pan, and Paint Bucket tools to finish painting

your doghouse.

Now that you know how to move around your model, here’s how I'd like
you to paint it (Color Plate 8 shows what it should look like):

¢ Paint the exterior walls red-brown.
¢ Paint the roof light blue.

¢ Paint the interior yellow-orange.

When you're just starting out, it’s easy to get a little lost with the navigation
tools (Orbit, Zoom, and Pan); it happens to everybody. If you find yourself in
a pickle, just choose Camera=>Zoom Extents. When you do, SketchUp auto-
matically plunks your model right in front of you; check out Figure 3-14 to see
Zoom Extents in action. Just so you know, Zoom Extents is also a button on
the toolbar; it’s right next to the Zoom tool.

Chapter 2 is the place to look for extra tips and tricks on orbiting, zooming,
and panning, as well as for details about using the Materials dialog box to
paint the faces of an object.
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Figure 3-14:
Use Zoom
Extents
anytime you
can'tfigure
out where
your model
went.
|
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Giving Your Model Some Style

SketchUp Styles allow you to change your model’s appearance — the way it’s
drawn, basically — with just a few clicks of your mouse. You can create your
own styles, of course, but SketchUp also comes with a library of pre-made
ones that you can use without knowing anything about how they work.

Figure 3-15:
The
Assorted
Styles
libraryisa
sampler of
ready-mixed
SketchUp
styles.
|

Follow these steps to try out a couple of styles on your doghouse:

1. Choose Windowr>Styles.

The Styles dialog box opens.
2. Click the Select tab to show the Select pane.

3. In the Libraries drop-down menu (see Figure 3-15), choose the
Assorted Styles library.

Styles
PS5O Graded

' — Created by Paul
Stevenson Oles.
- Graded paper texture

Select |edt | Mx |

¢I E:) m Assorted Styles hd E’

0 Goin
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4. Click through the different styles to see what they’re about.

When you click a style in the Styles dialog box, that style is applied to
your model. Figure 3-16 shows our doghouse with a few different styles
applied — can you figure out which ones?

Figure 3-16:
The same
doghouse

with four
very differ-
ent styles
applied to it.
|

5. Go back to your original style.

Click the little house icon in the Styles dialog box to see a list of all the
Styles you've applied to your model. Find the one called “Architectural
Design Style” (it should be first in the list) and click to choose it.

Switching on the Sun

You're about to use what I consider to be one of SketchUp’s best features:
shadows. When you turn on shadows, you’re activating SketchUp’s built-in
sun. The shadows you see in your modeling window are accurate for whatever
time and location you set. For the purposes of this example, though, don’t
worry about accuracy. Go through these steps to let the light shine in:

1. Use Orbit, Zoom, and Pan to get an aerial, three-quarter view of your
doghouse, sort of like the one shown in Figure 3-17.

www.it-ebooks.info


http://www.it-ebooks.info/

70 Part I: Getting Started with SketchUp

|
Figure 3-17: |
Use Orbit,
Zoom, and
Pan to navi-
gate around
until your
model looks ~
something |
like this.
|

2. Choose Window~>Shadows.
This opens the Shadow Settings dialog box (as shown in Figure 3-18).

Slide back and forth
|

Flg“re 3-18: v Display shadows o

The Shagiow Time: [ p— [~ oy =]
Settings o |, T raesho [ =]

ial X |
dialog bo R—

controls the
. ark —— -
position of g b

’ i_ Use sun for shading
SketchUp's |, =

bu||t-|n sun. ¥ Onfaces W Onground I From edges

3. Select the Display Shadows check box to turn on the sun.
Your doghouse should be casting a shadow on the ground.

4. In the Shadow Settings dialog box, move the Time slider back and
forth.

Changing the time of day means that you’re moving SketchUp’s sun
around in the sky. When the sun moves around, so do your shadows.
Take a look at Figure 3-19 to see what | mean.
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|
Figure 3-19:
Moving

the Time

slider back |

and forth
changes the
position of
your
shadows.
|

7:31 a.m. 3:16 p.m.

For more about fine-tuning light and shadows, check out Chapter 9.

Sharing Your Masterpiece

Now that you have a model that looks about the way you want it to, you
probably want to show it to someone. The easiest way to do that is by
exporting a JPEG image that you can attach to an e-mail. Follow these steps
and you’ll be on your way:

1. Navigate around (using Orbit, Zoom, and Pan) until you like the view
of your model that you see in your modeling window.
2. Choose Filew>Export=>2D Graphic.

3. In the Export dialog box that opens, choose JPEG from the Export
Type drop-down menu.

4. Pick a location on your computer system, and give your exported
image a name.

5. Click the Export button to create a JPEG image of what'’s visible in
your modeling window.

Exporting a JPEG file is just one way to share models. To find out about all
your options, see Part IV, which explains how to share your model on Google
Earth, as a printout, as an image or animation, or as a slick presentation that
will (hopefully) impress all your friends.
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The 5th Wave By Rich Tennant
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“My brother built the bayn, but the silo came from
a design T did in Google SketchUp.”
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In this part . . .

LVhen all is said and done, SketchUp is about making
3D models. Sure, you can paint them, make anima-
tions with them, print them, and e-mail images of them to
your friends, but first you have to actually create them.

Chapter 4 makes the assumption that sooner or later,
you're going to want to use SketchUp to make a model of a
building. Starting with drawing simple floor plans and pro-
ceeding into the transition from 2D to 3D, modeling stairs
and creating roofs, this chapter does its best to get you
started.

In Chapters 5 and 6, I go over all the different ways you
can organize your model; doing so improves your model-
ing efficiency, your computer’s performance, and ulti-
mately, your sanity. You don’t have to be a tidy person to
“work clean” in SketchUp — I'm living proof.

Don’t want to use SketchUp to just model buildings?
Chapter 7 describes how to use things like components
and the Follow Me tool to create some pretty advanced
models.

Chapter 8 talks about how you can use photographs in
SketchUp, both to “paint” your faces, and to create whole
models based on photographs of objects like buildings
and furniture.
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Chapter 4

Building Buildings

In This Chapter

Drafting a simple floorplan

Going from a 2D plan to a 3D model

Inserting doors and windows

Modeling stairs

Adding a roof

3

Even though SketchUp lets you make (just about) anything you can think
of, certain forms are easier to make than others. Fortunately, these
kinds of shapes are exactly the ones that most people want to make with
SketchUp, most of the time. That’s no accident; SketchUp was designed with
architecture in mind, so the whole paradigm — the fact that SketchUp models
are made of faces and edges, and the kinds of tools it offers — is perfect for
making things like buildings.

But what about curvy, swoopy buildings? You can use SketchUp to make
those, too, but they’re a little harder, so I don’t think they’re a good place to
start. Because most of us live in boxy places with right-angled rooms and flat
ceilings, that kind of architecture is relatively easy to understand.

In this chapter I introduce you to some of the fundamentals of SketchUp mod-
eling in terms of making simple, rectilinear buildings. By writing about how

to build certain kinds of things, instead of just describing what the individual
tools do, I hope to make it easier for you to get started. Even if you're not
planning to use SketchUp to model any of the things I describe, you should
still be able to apply these concepts to your own creations.

One more thing: Just about every page in this chapter relies heavily on the
stuff I introduce in Chapter 2. Working with the colored drawing axes, select-
ing objects, navigating around your model, and drawing things accurately are
pretty key to making anything in SketchUp, so be prepared to flip back and
forth while you're getting used to how things work. I like to use paper clips as
bookmarks, but I'm sure you have your own method. . . .
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Drawing Floors and Walls

<MBER
é"\&

|
Figure 4-1:
Use single
faces for
exterior
models

and double
faces for
interior
ones.
|

A\

Most floors and walls are flat surfaces, so it’s easy to model them with
straight edges and flat faces in SketchUp. In fact, chances are good that the
first thing you ever modeled in SketchUp looked a lot like the floor and walls
of a building.

I can think of two different kinds of architectural models that most people
want to create in SketchUp; how you approach modeling floors and walls
depends entirely on the type of model you’re making:

v Exterior: An exterior model of a building is basically just an empty shell;
you don’t have interior walls, rooms, or furniture to worry about. This
type of model is a slightly simpler proposition for folks who are just
starting out.

v~ Interior: An interior model of a building is significantly more complicated
than an exterior-only one; dealing with interior wall thicknesses, floor
heights, ceilings, and furnishings involves a lot more modeling prowess.

Here’s the thing: Because everything in SketchUp is made up of super-flat
faces (they have no thickness), the only way to model a wall that’s, say, 8
inches thick is to use two faces side by side and 8 inches apart. For models
where you need to show wall thicknesses — namely, interior models — this
is what you’ll have to do. Exterior models are easier to make because you can
use single faces to represent walls. Figure 4-1 shows what I'm talking about.

Single-face walls Double-face walls

>

- /\
b

One of the biggest mistakes new SketchUp users make is attempting an
“inside-outside” model right off the bat. Making a model that shows both the
interior and the exterior of a building at the same time is, to be honest, way
too hard when you're just getting started. Instead, build two separate models
if you need both interior and exterior views. If you need a combination model
later on, you’ll be able to build it in a quarter of the time it took you to build
either of the first two — [ guarantee it.
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Starting out in 2D

Of course, you can make a 3D model of a building’s interior in lots of different
ways, but I'm going to show you the one I think makes the most sense.
Basically, it involves drawing a two-dimensional floorplan that includes all
your interior and exterior walls, and then pulling it up to be the right height.
In my method, you don’t worry about doors, windows, or stairs until after
your model is extruded; you put them in afterward, which I think is an easier
and more logical way to work.

If you're importing a floorplan from another piece of software like AutoCAD
or VectorWorks, I think you’ll appreciate this approach — it lets you take 2D
information and make it 3D, regardless of where it comes from.

Even though SketchUp is a 3D modeling program through and through, it’s
not a bad tool for drawing simple 2D plans. The toolset is adequate and easy
to use, and doing a couple of things before you get started will help a lot.

The thing to keep in mind is that SketchUp isn’t a full-fledged drafting pro-
gram, and it probably never will be.

If you're an architect-type who needs to do heavy-duty CAD (computer-aided
drawing) work, you should probably be drafting in another piece of soft-
ware and importing your work into SketchUp when you need 3D. If you're
just drawing your house or the place where you work, look no farther —
SketchUp should do just fine.

Switching to a 2D view

If you're going to use SketchUp to draw a 2D plan, the first thing you need to
do is orient your point of view. It’s easiest to draw in 2D when you’re directly
above your work, looking down at the ground plane. You also want to make
sure that you're not seeing things in perspective, which distorts your view of
what you have.

Follow these simple steps to set things up (and find additional help on this
book’s companion Web site at www . dummies.com/go/SketchUp7FD):

1. Create a new SketchUp file.

Depending on the template you have set to open when you create a
new SketchUp file, you might already be in a 2D view. If all you see
are the red and green axes on a white background, you can skip Step
2. Remember that you can always switch templates by choosing
Help=>Welcome to SketchUp and clicking on the Templates section of
the dialog box that pops up.

2. Choose Camera~Standard=>Top.

This changes your viewpoint so that you're looking directly down at the
ground.
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3. Choose Camera~ Parallel Projection.

Switching from Perspective to Parallel Projection makes it easier to draw
plans in 2D. At this point, your modeling window should look like the
one shown in Figure 4-2.

Green axis

—_— ()

Figure 4-2:
Your model-
ing window
should look
like this
before you
start draw-
ing in 2D.
|

T
Sang Red axis

<P Feel free to delete Sang. That little diagonal line that’s visible in your model-
ing window when you're in Top view is a top view of Sang — the 2D guy who
appears in every new SketchUp file you create. To get rid of Sang, just right-
click him and choose Erase.

Dusting off SketchUp’s drafting tools

Here’s some good news: You don’t need many tools to draft a 2D plan in
SketchUp. Figure 4-3 shows the basic toolbar; everything you need is right
there:
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|
Figure 4-3: Are
All the tools Line Circle Eraser Offset Pan
you need to | | | | |
aatnd [ /BOC | - LB EIROE HLZARA DL 2 ©
in SketchUp | | |
are on the Select Tape Zoom
basic Measure
toolbar. Zoom
— Extents
v Line tool: You use the Line tool (which looks like a pencil) to draw
edges, which are one of the two basic building blocks of SketchUp
models. Fundamentally, you click to start drawing an edge and click
again to finish it. (You can find lots more information about drawing
lines in Chapter 2.)
v Eraser tool: You use the Eraser to erase edges; see Figure 4-4. Keep in
mind that you can’t use the Eraser to delete faces, though erasing one of
the edges that defines a face automatically erases that face, too. Take a
look at the section about edges and faces at the beginning of Chapter 2
for more detail on this. You can use the Eraser in two different ways:
¢ Clicking: Click edges to erase them one at a time.
¢ Dragging: Click and drag over edges to erase them; this is faster if
you have lots of edges you want to get rid of.
. Eraser tool Edge has been erased
Figure 4-4:
Use the
Eraser tool
to erase
edges. x
Erasing an
edge that
defines a
face erases
that face,
too.
|

v Circle tool: Drawing circles in SketchUp is pretty easy: You click once
to define the center and again to define a point on the circle (which
also defines the radius). To enter in a precise radius, just draw a circle,
type in a radius, and press Enter (see Figure 4-5). For more information
on typing while you draw, check out the section on model accuracy in
Chapter 2.
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Type the radius you want and

—— Click to set the center Click again to set the radius press Enter

Figure 4-5: | - |

Drawing A

circlesis |

easy with F < )
s

the Circle N

tool.
|
v Arc tool: To draw an arc, you click once to define one end, again to
define the other end, and a third time to define the bulge (how much the
arc sticks out). If you want, you can type in a radius after you draw your
arc by entering the radius, the units, and the letter r. If you want an arc
with a radius of 4 feet, you would draw it however big, type in 4'r, and
press Enter. This is shown in Figure 4-6.
2. then click here...
1. Click here to start... 3. then click here.
Top
Z.
|
Figure 4-6:
Using the
Arc toolis a
three-step
operation.
|
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v Offset tool: The Offset tool helps you draw edges that are a constant
distance apart from edges that already exist in your model. Pictures
are usually better than words, so take a look at Figure 4-7. Using Offset
on the shape I've drawn lets me create another shape that’s exactly 6
inches bigger all the way around (middle image), or 6 inches smaller all
the way around (right image). Offsetting edges is a useful way to create
things like doorways and window trim.

Click to start drawing; then

move your cursor 6 inch outside offset 6 inch inside offset
| |
Figure 4-7: F = = =
Offset :
lets you :
create j \
edges /
based on / /
other edges.
|
You can use Offset in two ways; for both ways you click once to start off-
setting and again to stop:
¢ Click a face to offset all its edges. If nothing is selected, clicking
a face with the Offset tool lets you offset all that face’s edges by a
constant amount (as shown in Figure 4-7).
* Preselect one or more coplanar (on the same plane) edges, and
then use Offset. If you have some edges selected, you can use
Offset on just those edges; this comes in handy for drawing things
like doorframes and balconies, as shown in Figure 4-8.
Select the edges you want to offset Use Offset to create more edges
|
Figure 4-8:
Using Offset
on a set of
preselected
edges is
handy for
drawing
things like
doorframes.
|
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Figure 4-9: |

To make
an exterior
model, just

measure the
outside of
your build-
ing to draw
an outline in
SketchUp.
|

1 Tape Measure tool: The Tape Measure is one of those tools that does
a bunch of different things. To use it for measuring distances, click any
two points in your model to measure the distance between them. The
distance readout is in the Measurements box, in the lower-right corner
of your modeling window. You can also use it for sizing a model and for
creating guides, as [ explain in Chapter 2.

Coming up with a simple plan

If all you're trying to do is model an exterior view of a building, just measure
around the perimeter, draw the outline of the building in SketchUp, and pro-
ceed from there. (See Figure 4-9.) Your walls will only be a single face thick
(meaning paper-thin), but that’s okay — you’re only interested in the outside,

anyway.

If, on the other hand, you want to create an interior view, your life is a little
bit more complicated. The business of measuring an existing building so that
you can model it on the computer is easier said than done — even experi-
enced architects and builders often get confused when trying to create as-
builts, as drawings of existing buildings are called. Closets, ventilation spaces,
interior walls, and all kinds of other obstructions inevitably get in the way of
getting good measurements; most of the time, you just have to give it your
best shot and then tweak things a bit to make them right.

Drawing an interior outline

Because the main goal of making an interior model of a building is to end up
with accurate interior spaces, you need to work from the inside out. If your
tape measure is long enough, try to figure out a way to get the major dimen-
sions first — this means the total interior width and length of the inside of
your building. You might not be able to, but do your best. After that, it’s
really just a matter of working your way around, using basic arithmetic and
logic to figure things out.

www.it-ebooks.info


http://www.it-ebooks.info/

Chapter 4: Building Buildings & 3

<P It really helps to make a paper drawing before you start in with SketchUp.
You’ll know what you need to do, leaving all your concentration for drafting
on the computer. Figure 4-10 shows the paper sketch [ used when modeling
my own house.

Figure 4-10:
This is

the paper
sketch |
used to
model my
house in
SketchUp.

—— s
«\\E 8
/ //,'—_‘

‘\\\\ ,,}}

’

From this paper drawing, here’s how I would draw a basic interior outline of
my house:

1. I switch into a 2D, overhead view.

The section “Switching to a 2D view,” earlier in this chapter, explains
how.

2. Using the Line tool, I draw an edge 17 feet long (see Figure 4-11, top
left), representing the eastern wall of the house.
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Figure 4-11:
| start by
drawing an
edge 17 feet
long; then |
draw a per-
pendicular
edge 11 feet
10 inches
long.
|

To draw it, I click once to start the edge, move my cursor up until I see
the green linear inference (indicating that I'm drawing parallel to the
green axis), and click again to end my line. To make it 17 feet long, [ type
in 17’ and then press Enter — the line resizes itself automatically to be
exactly 17 feet in length. If I wanted to, I could use the Tape Measure to
double-check what I did.

Finish 1. Start 2. Type 17" and press Enter

B -

/

3. Draw another edge 4. Type 11”10 and press Enter

3. I draw an edge 11 feet 10 inches long, starting at the end of the first

edge, heading to the right in the red direction. (See Figure 4-11,
bottom right.)

To do this, I do exactly what I did to draw the first edge, except that I
move parallel to the red axis this time, type in 11’10, and then press
Enter.

. I keep going all the way around the house, until I get back to where I

started. (See Figure 4-12))

If I make a mistake, I either use the Eraser to get rid of edges I'm
unhappy with or I choose Editz>Undo to go back a step or two.
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Figure 4-12:
The com-
pleted
interior
perimeter of
my house.
|

3

Edge Face

5. If all my measurements don’t add up, I adjust things so that they do —
a few extra inches here and there never killed anyone, after all.

After I completed my outline (forming a closed loop of edges that were
all on the same plane), a face automatically appeared. Now I have a total
of 11 edges and 1 face.

When you’re drafting in 2D, whatever you do, don’t use the Orbit tool.
Because you're working in 2D, you only need to use Zoom and Pan to navigate
around your drawing. (See Chapter 2 for more information on this.) If you
accidentally end up orbiting your model into a 3D view, follow the steps in the
section “Switching to a 2D view,” earlier in this chapter, to get things back in
order.

If you get lost, and no amount of zooming and panning gets you back to a view
of your floorplan, choose Cameraw>Zoom Extents — think of it as an emer-
gency lever you can pull to fill your modeling window with your geometry.

Offsetting an exterior wall

I decided to offset (using the Offset tool) an exterior wall thickness, just to
make it easier to visualize my spaces. Here’s how [ do it:
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Figure 4-13:
| use Offset
to create an
exterior wall
thickness,
and then

| do some
cleanup
using the
Line and
Eraser tools.
|

\\3

1. Using the Offset tool, I offset my closed shape by 8 inches to the

outside. (See Figure 4-13, left.)

An offset of 8 inches is a pretty standard thickness for an exterior wall,
especially for houses in my neck of the woods. This is how [ use the
Offset tool:

a. I make sure that nothing is selected by choosing Edit=>Select None.
b. I click once inside my shape.

c. I click again outside my shape to make a second, bigger shape.

d. I type in 8 and then press Enter.

Offset an exterior wall
thickness Draw in edges Delete unwanted edges

o

2. Because I know there are no alcoves on the exterior, I use the Line

tool to close them off, creating pockets of wall that are thicker than
the rest. (See Figure 4-13, middle.)

. I use the Eraser tool to get rid of the extra edges. (See Figure 4-13,

right.)

By deleting the extra edges, I go back to having only two faces: one
representing the floor and one representing the exterior wall thickness.
It doesn’t matter that the wall is thicker in a couple of places; I can
always go back and fiddle with it later on.

Putting in the interior walls

For this part of the process, | use guides a lot. If you haven’t done so already,
read Chapter 2 and check out the last part — you'll find a full description of
guides and how to use them.

When I'm drafting a floorplan in SketchUp, I find it really helps to ignore things
like doors and windows — where a doorway should be in a wall, I just draw a
solid wall. I like to add in doors and windows after I've extruded my floorplan
into a three-dimensional figure.
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Here’s how I put in the few interior walls on the first floor of my house:

1. With the Tape Measure tool, I drag a parallel guide 5 feet, 3" inches
from the inside of my entryway. (See Figure 4-14, left.)

To do this, I just click the edge from which [ want to draw the guide,
move my cursor to the right (to tell SketchUp which way to go), type
5’3.5, and press Enter.

|
Figure 4-14:  Create a parallel guide Create more guides Draw edges using your guides
| draw a
guideto | i i
help me
locate my
first interior b | > | =
wall, and |
then | draw
a bunch
more.
|
2. I draw a few more guides the same way I drew the first one.
Working from my pencil drawing, I figure out the location of each inte-
rior wall, and I create guides to measure off the space. (See Figure 4-14,
right.)
3. Switching to the Line tool, I draw in edges to represent the interior
walls.
By using the guides as, er, guides, it’s easy to draw my edges correctly.
Figure 4-15 shows what [ have so far.
<P Don’t forget to zoom! When you have a jumble of edges and guides, and

you can’t see what you're doing, just zoom in. It sounds obvious, but
you’d be surprised how many folks forget to change their point of view
while they’re working — it makes all the difference.

4. I use the Eraser to delete my guides.

5. I use the Eraser to get rid of all the extra edge segments. (See Figure
4-16.)

By doing this, I go back to only having two faces in my model (one for
the floor and one for the walls). When it is time to extrude my plan into
walls, as I explain in a moment, performing this step will help out a lot.
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Figure 4-15:
| just use
the Line

tool to cre-
ate edges
where my
guides

come
together.
|

Figure 4-16:
Using the
Eraser, |
delete my

guidesand [

all the little

edge seg-

ments left
over from
drawing

the interior
walls.
|

Top

Erase your guides

Solid lines are edges

Erase tiny unwanted edges

Going from 2D to 3D

With a 2D plan in hand, the next step is to extrude it into a 3D model. This
is basically a one-step process, and it involves the tool that made SketchUp
famous: Push/Pull. In the following sections, I take a simple floorplan (one I
drew earlier in this chapter) and turn it into three-dimensional walls.
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Figure 4-17:
Before |
start work-
ingin 3D,

| switch
overtoa3D
view.
|

Getting a good view

Before I pop up my plan into the third dimension, [ need to change my point
of view to get a better view of what I'm doing. (See Figure 4-17.) Follow these
steps:

Switch to Perspective view Switch to Iso view

=
YIRS eV ForAa 9 ev

1

N

1. Choose Camera~Perspective.

This turns on SketchUp’s perspective engine, meaning that now I can see
things more realistically — the way people really see things in 3D.

2. Choose Camera~Standard-Iso.

This switches me from a top view to an isometric (three-quarter) one. |
could do this with the Orbit tool, too — you always have more than one
way to do everything in SketchUp.

3. Choose Camerar>Zoom Extents.

Zoom Extents has its own button on the basic toolbar, but I thought I'd
stick with the Camera menu theme, just for consistency.
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4. Choose Camera~Field of View, type in 45, and press Enter.

You've changed the field of view from 35 to 45 degrees. By default,
SketchUp'’s field of view is set to 35 degrees. (For more information on
what this means, check out Chapter 10.)

Pushing/pulling your way to happiness

The Push/Pull tool is a simple creature; you use it to extrude flat faces into
3D shapes. It works (like everything else in SketchUp) by clicking — you click
a face once to start pushing/pulling it, move your cursor until you like what
you see, and then click again to stop push/pulling. That’s it. I doubt that any
software tool has ever been so satisfyingly easy to use and understand. For
more detail on Push/Pull, see the nearby sidebar, “More fun with Push/Pull.”

\\3

Push/Pull only works on flat faces; if you need to do something to a curved
face, you’ll have to use something else. Read about the Intersect with Model
feature in the section “Getting to know Intersect with Model,” later in this
chapter — it might be what you're looking for.

To use Push/Pull to extrude my house’s first floorplan into a 3D model, this is
what I do. (See Figure 4-18.)

L
Figure 4-18:
|use Push/  Click to start Push/Pulling Move your cursor Type a height and press Enter
Pull to |
extrude one .
of my faces _f_,f;,\ .
into all the Wﬁ
wallsin - /
my house. N 8.
Presto! \
L

1. Select the Push/Pull tool from the toolbar.
It looks like a little box with a red arrow coming out the top.
2. Click the wall’s face once to start extruding it.

If I click the “floor” face, I would end up extruding that, instead. If you
choose the wrong face by accident, press Esc to cancel the operation,
and try again.

3. I move my cursor up to pull up the walls; click to stop extruding.

It doesn’t matter how much I extrude my face, because I'm going to add
precision in the next step.
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4. I type 8' and press Enter.

When I do this, my push/pull distance is revised to be exactly 8 feet —
the height of the walls in my house.

If you forget to erase any little edge segments before using Push/Pull, all your
walls might not be pulled up at once. In this case, use Push/Pull again on any
faces that need it.

Adding doors and windows

You can make openings in your walls in a couple of different ways. What you
choose to do depends on what kind of building you’re modeling, whether
you're using single-face or double-face walls, and how much detail you plan
to include in your model. You have two options:

1 Use SketchUp components that cut openings themselves. SketchUp
comes with a handful of sample doors and windows that you can drag
and drop into your model. The really cool thing about these is that they
cut their own openings when you place them. Here’s the catch, though:
SketchUp’s “cut opening” components only work on single-face walls,
which means that they’re really only useful for exterior building models. If
you're building an interior model, you’ll have to cut your own openings.

v Cut openings yourself. For double-face walls, this is your only option;
luckily, it’s easy to do. Basically, you draw an outline for the opening
you want to create, and then you use Push/Pull to create the opening —
it works the same way for doors and windows.

Using SketchUp's handy-dandy components

As long as you’re making an exterior model, you can use the doors and win-
dows that come with SketchUp. These are components, which you can read
more about in Chapter 5. Without going into a ton of detail, here’s what you
need to know about them:

v They’re accessible from the Components dialog box. Choose
Window=>Components to open the dialog box, and then choose the
“Architecture” collection from the Navigation drop-down menu (it looks
like an upside-down triangle). The “Doors” and “Windows” collections
are in there somewhere. Keep in mind that you need to be online for this
to work — the collections are hosted on Google’s 3D Warehouse, some-
where in cyberspace.

+* You can find hundreds more online. If you’re connected to the Internet,
you can type any search query (like “revolving door”) into the little
search area at the top of the Components dialog box. This scours the
3D Warehouse for whatever you're looking for, and shows the results
below. Some advice: There’s lots of stuff in the world, so be specific.
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Because Push/Pull is the tool that most people
think of when they think of SketchUp, | thought
you might appreciate knowing more about
what it can do. The people who invented this
software (back in the last millennium) started
with the idea for Push/Pull —that’s how closely
linked SketchUp and Push/Pull are. Here are
four things about Push/Pull that aren’t immedi-
ately obvious when you first start using it:

v Double-click with the Push/Pull tool to
extrude a face by the last distance you
pushed/pulled. When you double-click a
face, it automatically gets pushed/pulled by
the same amount as the last face you used
Push/Pull on.

v~ Press Ctrl (Option on a Mac) to push/pull »~
a copy of your face. The first graphic in
the following figure shows what I'm talk-
ing about here. Instead of using Push/Pull
the regular way, you can use a modifier
key to extrude a copy of the face you're

More fun with Push/Pull

pushing/pulling. This comes in super-handy
for modeling things like multistory buildings
quickly.

While pushing/pulling, hover over other
parts of your geometry to tell SketchUp how
far to extrude. Take a look at the second
graphic. Perhaps | want to use Push/Pull to
extrude a cylinder that is exactly the same
height as my box. Before | click the second
time to stop pushing/pulling, | hover over a
point on the top of the box; now the cylinder
is exactly that tall. To complete the opera-
tion, | click while I'm still hovering over the
box. It's pretty simple, and it'll save you
hours of time after you're used to doing it.

Pushing/pulling a face into another, copla-
nar face automatically cuts a hole. In fact,
this is how you make openings (like doors
and windows) in double-face walls. The
last graphic shows this in action.

Hit Control Push/Pull a face all the
(Option on Mac) Click while way into another one
to copy your face you're hovering to make both disappear

v~ They are editable. I go into lots of detail about this in Chapter 5, but
here’s the gist: If you don’t like something about one of SketchUp’s
built-in doors or windows, you can change it.

S\kETc”Qo . .
§ 1 Some are dynamic. In SketchUp 7, some components have special
g 6 abilities that make them easier to resize and otherwise reconfigure. You
\g? can read all about Dynamic Components in Chapter 5.

v They cut their own openings, but the openings aren’t permanent.
When you move or delete a door or window component you've placed,

its opening goes with it.
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Adding a hole-cutting component to your model is a piece of cake. Follow
these steps to do it yourself. (See Figure 4-19.)

window and
door com-
ponents in
your model
is a breeze.
|

Figure 4-19: — - =
Placing ?— ?

Click a component Place itin
your model

1. In the Components dialog box, click the component that you want to
place in your model.

2. Place the component where you want it to be.
3. If you don’t like where it is, use the Move tool (read all about it in
Chapter 2) to reposition your component.

Figure 4-20 shows a simple building to which I've added a door and a couple
of window components. Notice how I use guides to line things up — doing so
is the best way to make sure that everything’s in the right spot.

————.

Components

Figure 4-20:
Use guides
to help you
line up
components
you add to
your model.

Guides
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Making your own openings

Most of the time, you won’t be able to get away with using SketchUp’s built-
in door and window components — the fact that they can’t cut through

two-faced walls means that they’re limited to external use only. That’s okay
though; cutting your own holes in walls is quick and easy, and you’ll always

end up with exactly what you want.

To cut a precise opening in a double-face wall, here’s what you need to do;
Figure 4-21 shows the basic steps:

1. Mark where you want your opening to be with guides.

|
Figure 4-21:
Use guides
to plan

For a refresher on using guides, have a look at the section “Making and
using guides,” in Chapter 2.

. Draw the outline of the opening you want to create, making sure to

create a new face in the process.

You can use any of the drawing tools to do this, though [ recommend
sticking with the Line tool when you're starting out. You’ll know you’ve
made a new face if the edges in your outline look thin; if they don’t, check
out the nearby sidebar, “Working through thick and thin,” for more info.

. Use Push/Pull to extrude your new face back into the thickness of the

wall until it touches the face behind it.

If everything goes well, your face should disappear, taking with it the
corresponding area of the face behind it. Now you have an opening in
your wall. If your face doesn’t disappear, and no opening is created, it’s
probably for one of the following reasons:

¢ Your faces aren’t parallel to each other. This technique only
works if both faces are parallel. Keep in mind that just because two
faces look parallel doesn’t mean that they are.

¢ You hit an edge. If you push/pull your face into a face with an edge
crossing it, SketchUp gets confused and doesn’t cut an opening.
Use Undo, get rid of the pesky edge (if you can), and try again.

Create guides Draw edges Push/Pull all the way through

where you
want an
opening, |
and then
push/pull

allthe way |~

through
both faces.
|

\ B!\

e
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Working through thick and thin

Pay attention to which edges look thick and = Thick edges sit on top of faces. If the edge
which ones look thin. When you're drawing in 2D, you just drew looks thicker than some of
you can tell a lot from an edge’s appearance: the other edges in your model, it isn't actu-
ally cutting through the face it's on — it's
only sitting on top. Most of the time, this is
because it has one free end. So-called free
edges aren’t connected to other edges at
both ends (see the second image).

v~ Thin edges cut through faces. Edges that
are thin are ones that have “sunk in”; you
can think of them like cuts from a razor-
sharp knife. When you successfully split a
face with an edge that you draw with the
Line tool, it looks thin. The first image in
the following figure shows what I'm talking
about.

This edge is sunken Free (one-sided) edges don't sink in

> [v

Don’t forget to orbit! If you can’t quite push/pull what you mean to push/pull,
orbit around until you can see what you're doing.

A\

Staring Down Stairs

There are probably a million different ways to make stairs in SketchUp, but
(naturally) I have my favorites. In the following sections, you’ll find two dif-
ferent methods that work equally well; take a look at both of them and then
decide which works best for your situation. In the last part of Chapter 5, I
describe a third, slightly trickier (but way more powerful) way of making
stairs using components; feel free to take a look if you're feeling more
advanced.
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éc_,\LETCIf(,'o SketchUp 7 introduced Dynamic Components, which has some pretty neat
implications for people who need stairs to use in their models. So-called
dynamic stair components automatically add or subtract individual steps as
y you make them bigger or smaller with the Scale tool. Depending on what
you're trying to accomplish, one of these pre-made dynamic stair components
might save you a bunch of time. Find out more about them in the Dynamic
Components section of Chapter 5.

NEW,

Before I dive in, here’s some simple stairway vocabulary, just in case you
need it; take a look at Figure 4-22 for a visual reference:

v Rise and run: The rise is the total distance your staircase needs to
climb. If the vertical distance from your first floor to your second (your
floor-to-floor distance) is 10 feet, that’s your rise. The run is the total
horizontal distance your staircase takes up. A set of stairs with a big rise
and a small run would be really steep.

v Tread: A tread is an individual step — the part of the staircase you step
on. When someone refers to the size of a tread, he’s talking about the
depth — the distance from the front to the back of the tread. Typically,
this is anywhere from 9 to 24 inches, but treads of 10 to 12 inches are
most comfortable to walk on.

v~ Riser: The riser is the part of the step that connects each tread in the
vertical direction. Risers are usually about 5 to 7 inches high, but that
depends on your building. Not all staircases have actual risers (think of
steps with gaps between treads), but they all have a riser height.

v Landing: A landing is a platform somewhere around the middle of a set
of stairs. Landings are necessary in real life, but modeling them can be a
pain; figuring out staircases with landings is definitely more complicated.
Sometimes, it’s easier if you think of your landings as really big steps.

The Subdivided Rectangles method

This is the way most people think to draw their first set of stairs. It’s intuitive
and simple, but it’s also a bit more time-consuming than the other methods I
describe in this book.

<P The key to the Subdivided Rectangles method is to use a special trick you
can do with edges: Called Divide, it lets you pick any edge and divide it up
into as many segments as you want. If you know how many steps you need to
draw, but not how deep each individual tread needs to be, this comes in really
handy.
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Tread Riser Landing

|
Figure 4-22:
The
anatomy of
a staircase.
|

Run Rise

& WEg
S
\“\‘ ""I// Here’s how the Subdivided Rectangles method works. (See Figure 4-23.)

’

1. Start by drawing a rectangle the size of the staircase you want to
build.

\3
P I strongly recommend modeling steps as a group, separate from the rest

of your building, and then moving them into position when they’re done.
You can read all about groups in Chapter 5.

2. With the Select tool, right-click one of the long edges of your rectangle
and choose Divide.

If your staircase is wider than it is long, right-click one of the short
edges, instead.

3. Before you do anything else, type in the number of treads you want to
create and press Enter.

This command automatically divides your edge into many more edges,
eliminating the need to calculate how deep each of your treads needs
to be. Essentially, each of your new edges will become the side of one of
your treads.
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Divide edge into smaller edges,
marking off treads Connect new endpoints

Divide vertical edge marking off vertical risers

Infer to the endpoints on this divided edge

Figure 4-23:
The
Subdivided
Rectangles
method of
building
stairs.
|

4. Draw a line from the endpoint of each of your new edges, dividing
your original rectangle into many smaller rectangles.

You can use the Line or the Rectangle tool to do this; pick whichever
one you're most comfortable with.
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5. From one of the corners of your original rectangle, draw a vertical
edge the height of your staircase’s total rise.

6. Use the Divide command to split your new edge into however many
risers you need in your staircase (generally your number of treads,
plus one).

Repeat Steps 2 and 3 to do this. The endpoints of your new, little edges
will tell you how high to make each of your steps.

7. Push/pull the rectangle that represents your last step to the correct
height.

Here’s where you need to use the hover-click technique that I describe
in the sidebar “More fun with Push/Pull,” earlier in this chapter. Just
click once to start pushing/pulling, hover over the endpoint that
corresponds to the height of that tread, and click again. Your step will
automatically be extruded to the right height.

\3
) It’s a good idea to start extruding your highest step first, but keep in
mind that it doesn’t go all the way to the top; you always have a riser
between your last step and your upper floor.
8. Repeat Step 7 for each of your remaining steps.
V?‘“\NG! 9. Use the Eraser to get rid of any extra edges you don’t need.

Don’t accidentally erase geometry on the part of your staircase you
can't see.

The Copied Profile method

This method for modeling a staircase relies, like the last one, on using Push/
Pull to create a three-dimensional form from a 2D face, but I think you'll agree
it’s a lot more elegant. In a nutshell, you draw the profile — the side view,
sort of — of a single step, and then you copy as many steps as you need,
create a single face, and extrude the whole thing into shape. It’s breathtak-
ingly satisfying the first time you do it — one of those “guaranteed to make
you smile” SketchUp operations you’ll want to repeat for friends (assuming
you have nerdy friends like me).

Follow these steps to make a staircase using the Copied Profile method. (See
Figure 4-24.)
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Figure 4-24:
The Copied
Profile
method,

in glorious
grayscale.
|

Start with a vertical face ~ Draw the profile of a single step Copy it up

Type the number of copies,
thenx, and press Enter Push/Pull the stair into 3D

. Start with a large, vertical face; make sure that it’s big enough for the

flight of stairs you want to build.

You're going to end up pushing/pulling the whole shebang out of the
side of this face, just so you know.

. In the bottom corner of the face, draw the profile (side outline) of a

single step.

[ usually use the Line tool to do this, though you might want to use an
arc or two, depending on the level of detail you need. For a refresher on
drawing lines accurately, check out Chapter 2.

. Select all the edges that make up your step profile.

Remember that you can hold down Shift while clicking with the Select
tool to add multiple objects to your selection. Chapter 2 has lots of
selection tips.

. Make a copy of your step profile and place it above your first one.

If you’re unfamiliar with how to make copies using the Move tool, refer
to the section on moving and copying, toward the end of Chapter 2.

. Type in the number of steps you’d like to make, type the letter x, and

then press Enter.

For example, if you wanted ten steps, you would type in 10x. This tech-
nique repeats the copy operation you just did by however many times
you tell it to; adding an x at the end of the number tells SketchUp you
want to make copies.
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6. Draw an edge to make sure that all your step profiles are part of a
single face.

You don’t have to do this step if your stair profiles already fit perfectly
on your vertical face; if you measured carefully, they just might. If you
can’t seem to make things work, read the sidebar “Working through
thick and thin,” earlier in this chapter. That might shed some light on
what’s going on.

7. Push/pull the staircase face out to be the width you need it to be.

This is the part that seems like magic to most folks; I don’t think it ever
gets old.
N This method of stairway building also works great in combination with the
Follow Me tool, which I talk about in Chapter 6. Figure 4-25 should whet your
appetite — Follow Me is cool beans, all the way around.

Figure 4-25:
Using Profile Extrusion path for Follow Me
Follow

Me (more
details in
Chapter 6)

with the —— : >
Copied I </ = \?

Profile r 5 —
method pro- /\ \/\
duces some ' = ' —
impressive
geometry,
indeed.
|

Raising the Roof

If you're lucky, the roof you want to build is fairly simple. Unfortunately,
home builders sometimes go a little crazy, creating roofs with dozens of
different pitches (slopes), dormers, and other doodads that make modeling
them a nightmare. For this reason, 'm going to keep things pretty simple: The
following sections are dedicated to showing you how to identify and model
some of the basic roof forms. After that, I tell you about a great tool you can
use to assemble complicated roofs from less-complicated pieces — it’s called
Intersect with Model, and I think you’ll get a kick out of it.
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The tricky thing about roofs is that they’re hard to see. If you want to make a
model of something that already exists, it helps to be able to get a good look
at it — that’s not always possible with roofs. One neat way to get a better view
of a roof you're trying to build is to find it in Google Earth. For more information,
check out Chapter 11.

Always, always make a group out of your whole building before you start
working on your roof.

Before I dive in, what follows is a brief guide to general roof types and
terminology; this might come in handy for some of the explanations I give
later on. Figure 4-26 provides a visual accompaniment to my written
descriptions:

v~ Flat roof: Flat roofs are just that, except they aren’t — if a roof were
really flat, it would collect water and leak. That’s why even roofs that
look flat are sloped very slightly.

v Pitched roof: Any roof that isn’t flat is technically a pitched roof.
v Shed roof: A shed roof is one that slopes from one side to the other.

v Gabled roof: Gabled roofs have two planes that slope away from a
central ridge.

v Hip roof: A hip roof is one where the sides and ends all slope in different
directions.

v Pitch: The angle of a roof surface.

1 Gable: A gable is the pointy section of wall that sits under the peak of a
pitched roof.

v Eave: Eaves are the parts of a roof that overhang the building.

v Fascia: Fascia is the trim around the edge of a roof’s eaves where gutters
are sometimes attached.

v~ Soffit: A soffit is the underside of an overhanging eave.
v Rake: The rake is the part of a gabled roof that overhangs the gable.

v Valley: A valley is formed when two roof slopes come together; this is
where water flows when it rains.

v Dormer: Dormers are the little things that pop up above roof surfaces.
They often have windows, and they serve to make attic spaces more
usable.

v~ Parapet: Flat roofs that don’t have eaves have parapets: These are
extensions of the building’s walls that go up a few feet past the roof
itself.

www.it-ebooks.info


http://www.it-ebooks.info/

Chapter 4: Building Buildings ] ()3

Gabled roof Dormer Valley  Hip roof Flat roof Parapet  Shed roof

\ l \ \ | /

Fascia Soffit Gable Rake Eave

/
Figure 4-26:
Some differ-
ent kinds of
roofs, and
their various
and sundry
parts.
|
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Figure 4-27:
Modeling
parapets on
flat-roofed
buildings is
easy.
|

|
Figure 4-28:
Eaves are
the parts of
the roof that
overhang a
building’s
walls.
|

Offset to the inside

Building flat roofs with parapets

Good news — SketchUp was practically made for modeling these kinds of
roofs. By using a combination of the Offset tool and Push/Pull, you should be
able to make a parapet in under a minute. Follow these steps (see Figure 4-27):

Push/pull your parapet up

1. With the Offset tool, click the top face of your building.

2. Click again somewhere inside the same face to create another face.

3. Type in the thickness of your parapet, and then press Enter.

This redraws your offset edges to be a precise distance from the edges
of your original face. How thick should your parapet be? It all depends
on your building, but most parapets are between 6 and 12 inches thick.

4. Push/pull your outside face (the one around the perimeter of your

roof) into a parapet.

5. Type in the height of your parapet, and then press Enter.

Creating eaves for buildings

with pitched roofs

My favorite way to create eaves (roof overhangs) is to use the Offset tool.
Follow these steps to get the general idea (see Figure 4-28):

Offset an overhang

Delete the inside face

Push/Pull a fascia thickness

=

-
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Pitched roofs can make you crazy

That fact notwithstanding, a few tips might .~ Draw a top view of your roof on paper first.
make building your next one a little easier: | find this really helps me figure things out.

» Start by making the rest of your building Adding measurements and angles is even

a group. Always make a group out of your
whole building before you start working on
your roof. If you don't, your geometry will
start sticking together, you'll end up eras-
ing walls by accident, and eventually, you'll
lose your mind. On top of that, it's really
handy to be able to separate your roof from
the rest of your building whenever you
want. You can also group your roof, if that
makes sense for what you're doing. Check
out Chapter 5 for a full rundown on making
and using groups.

better — anything so that you know what
you need to do when you get around to
using SketchUp.

Learn to use the Protractor tool. This tool
(which is on the Tools menu) is for measur-
ing angles and, more importantly, creat-
ing angled guides. Because sloped roofs
are all about angles, you probably need
to use the Protractor sooner or later. The
best way to find out how it works is to
open the Instructor dialog box by choosing
Window=>Instructor and then activating
the Protractor tool.

1. Make a group out of your whole building before you start modeling

the roof.

This makes it easier to keep your roof separate, which in turn makes

your model easier to work with.

. Use the Line tool to create an outline of the parts of your roof that will
have eaves of the same height.

The goal here is to end up with a single face to offset. A lot of buildings
have complex roofs with eaves of all different heights; for the sake of
this step, just create a face which, when offset, will create roof over-
hangs in the right places.

. Use the Offset tool to create an overhanging face.

For instructions on how to use Offset, see the section “Dusting off
SketchUp’s drafting tools,” earlier in this chapter.

. Erase the edges of your original face.
A quick way to do this (with the Select tool) is to:

a. Double-click inside your first face; this selects both it and the
edges that define it.

b. Press Delete to erase everything that’s selected.
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5. Push/pull your overhanging roof face to create a thick fascia.

Different roofs have fasciae of different thicknesses; if you don’t know
yours, just take your best guess.

Constructing gabled roofs

You can approach the construction of a gabled roof in a bunch of different
ways (every SketchUp expert has his or her favorite), but I find one method
in particular that works well on a consistent basis.

Follow these steps to build a gabled roof, which is shown in Figure 4-29:

Create an angled guide with the Protractor Draw a vertical edge

Complete the roof profile Push/pull it back

Figure 4-29:
Gabled

roofs are
relatively
easy to
make in
SketchUp.
|

1. Create a roof overhang, following the steps in the previous section.

Most gabled roofs have eaves, so you’ll probably need to do this for
your building.

2. Use the Protractor tool to create an angled guide at the corner of your
roof.
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See the nearby sidebar, “Pitched roofs can make you crazy,” for more
information about drawing angled guides with the Protractor.

Architects and builders often express angles as rise over run ratios. For
example, a 4:12 (pronounced four in twelve) roof slope rises 4 feet for
every 12 feet it runs — a 1:12 slope is very shallow, and a 12:12 slope is
very steep. When using the Protractor tool, SketchUp’s Measurements
box understands angles expressed as ratios as well as those expressed
in degrees. Typing 6:12 yields a slope of 6 in 12.

3. Use the Line tool to draw a vertical edge from the midpoint of your
roof to the angled guide you created in Step 1.

The point at which your edge and your guide meet is the height of your
roof ridge.

4. Draw two edges from the top of your vertical line to the corners of
your roof.

This should cause two triangular faces to be created.

5. Erase the vertical edge you drew in Step 3 and the guide you drew in
Step 1.

6. Push/pull your triangular gable back.

If your gabled roof extends all the way to the other end of your build-
ing, push/pull it back that far. If your roof runs into another section of
roof (as in Figure 4-30), extrude it back until it’s completely “buried.”
The section “Sticking your roof together,” later in this chapter, has more
information on what to do when you’re making a complex roof.

Push/pull it all the way into the other roof pitch

Figure 4-30:
If your
gabled roof
is partof a
larger roof
structure,

it might just
run into
another roof
pitch. Let it.
|

7. Finish your eaves, fascia, soffit, and rake(s) however you want.

You find lots of different kinds of gabled roof details, so I can’t cover
them all, but Figure 4-31 shows a few common ones. Instead of writing
about them (which would get confusing anyway), I'll let the pictures do
the talking.
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Figure 4-31:
Some
common
gabled

roof details
and how to
make them.
|
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Making hip roofs

Believe it or not, building a hip roof is easier than making a gabled one. Hip
roofs don’t have rakes, which makes them a lot less complicated to model.
Follow these steps to find out what I mean (see Figure 4-32):

Create a guide that distance
Measure half-width of your gable from end of gable

S

Draw edges connecting ridge and corners

and erase 3 edges that form gable Now you have a hip
/\ /“"‘-——-__
/{/ E - & H‘_‘\\x

— . P “‘:x
Figure 4-32:
To make .
a hip roof, \tm
start with a \
gabled one. \

1. Follow Steps 1 through 5 in the preceding section “Constructing
gabled roofs.”

2. Measure the distance from the midpoint of the gable to the corner of
the roof.

Because hip roofs have pitches that are the same on all sides, you can
use a simple trick to figure out where to locate the hip in your roof. It’s a
lot easier than using the Protractor; trust me.

3. With the Tape Measure, create a guide the distance you just measured
from the end of the gable.
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4. Draw edges from the point on the ridge you just located to the corners
of your roof.

This does two things: It splits the sides of your roof into two faces each
and creates a new face (which you can’t see yet) under the gabled end of
your roof.

5. Erase the three edges that form the gabled end of your roof, revealing
the “hipped” pitch underneath.

Neat, huh? Now all three faces of your roof are the same pitch — just the
way they should be.

6. If appropriate, repeat the process on the other end of your roof.

Sticking your roof together

In general, the newer and more expensive a house is, the more roof slopes

it has. Who knows why this is the case; it probably has something to do
with folks thinking complex-roofed houses look more like French chateaus.
Whether or not crazy roofs (there’s my bias showing again) are a good thing
isn’t relevant to this book, but I know one thing for sure: They’re a pain in
the, um, gutters to model.

Getting to know Intersect with Model

Luckily, SketchUp has a relatively little-known feature that often helps when
it comes to making roofs with lots of pitches: Intersect with Model. Here’s
what you need to know about this terrific little tool:

v~ Intersect with Model makes new geometry from existing geometry.
That’s how it works: It takes faces you’ve selected and creates edges
wherever they intersect. You use Intersect with Model in cases where
you need to create forms that are the union (both put together), dif-
ference (one minus the other), or intersection (the part they have in
common) of other forms. Figure 4-33 shows what I'm talking about:
Perhaps [ want to make a model that’s a cube with a cylinder-shaped
chunk taken out of it. | would model the cube and model the cylinder.
After positioning them carefully, I could then use Intersect with Model
to create edges where the two shapes’ faces come together. After that,
[ would use the Eraser to get rid of the edges I didn’t want — the rest of
the cylinder, in this case.

1 Intersect with Model and the Eraser tool go hand in hand. Anytime
you use Intersect with Model, you need to follow up by spending some
time deleting the geometry you don’t want. This isn’t a bad thing, but it
does mean that you need to be good at orbiting, zooming, and panning
around your model. It also means that you need to be handy with the
Eraser.
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|
Figure 4-33:
Using
Intersect
with Model
tocuta
partial cylin-
deroutof a
cube.
|

” Most of the time, choose to Intersect with Model. This tool has three
different modes (just introduced in SketchUp 6), but the majority of the
time, you’ll end up using the basic one. Here’s what all three of them do:

¢ Intersect with Model: Creates edges everywhere your selected
faces intersect with other faces in your model — whether the other
faces are selected or not.

¢ Intersect Selected: Only creates edges where selected faces inter-
sect with other selected faces. This is handy if you're trying to be a
little bit more precise.

¢ Intersect with Context: This one’s a little trickier: Choosing this

option creates edges where faces within the same group or compo-
nent intersect; that’s why it’s only available when you're editing a

group or component.
v~ Intersect with Model doesn’t have a button. To use it, you have to either:

¢ Right-click and choose Intersect with Model.

¢ Choose Edit=vIntersect.

Most 3D modeling programs let you do Boolean operations, meaning that you're
encouraged to make models by adding, subtracting, and intersecting different
shapes to make new ones. This makes sense for solids modelers (like SolidWorks,
Inventor, and FormeZ) because this paradigm is a lot like sculpting with clay. But
because SketchUp is more paper-like than clay-like (it’s not clay-like at all, come
to think of it), Boolean operations are not technically possible. Intersect with
Model is about as close as SketchUp comes to letting you work this way.

Using Intersect with Model to make roofs

When it comes to creating roofs, you can use Intersect with Model to
combine a whole bunch of gables, hips, dormers, sheds, and so on into a
single roof. It’s no cakewalk, and it requires a fair amount of planning, but it

works great when nothing else will.
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Figure 4-34:
Here's a
typically
complex

roof that |
could use
Intersect
with Model
to unify.
|
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Figure 4-34 shows a complicated roof with several different elements. Gabled
roofs have been pushed/pulled into the main hip roof form at all different
heights, but edges don’t exist where all the different faces meet. In the steps
that follow, I use Intersect with Model to create the edges [ want and then I use
the Eraser to clean up my mess:

Erase from underside stuff that doesn’t belong

e

1. Select the whole roof.

You can select the whole roof a number of ways, but the one that I find
works the best is to first hide the group that contains the rest of your
building, and then draw a big selection box around the whole roof with
the Select tool.

2. Choose Edit=Intersect=>Intersect Selected.

This tells SketchUp to go through and create edges everywhere you
have faces that intersect — everywhere they pass through each other
without an edge.

3. Get out your Eraser and carefully delete all the extra geometry on the
inside of your roof.

[ won't lie; this can be a lot of work. But it’s a whole lot easier than using
the Line tool and SketchUp’s inference engine to figure out where every-
thing should go. The last image in Figure 4-37 shows the end result.

When all else fails, use the Line tool

Fancy tools like Follow Me and Intersect with  there’s no tomorrow. SketchUp users who really
Model are useful most of the time, but for some  know what they’re doing can draw anything with
roofs, you just have to resort to drawing good old  the Line tool and the Eraser too; it's a beautiful
edges. If that's the case, you'd better get familiar  thing to watch. Unfortunately, it's not a beautiful
with most of the stuff at the beginning of Chapter  thing to write (or read) about in a black-and-white
2, because you're going to be inferencing like
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book, so | can't show you as much “modeling  All the same, check out the following figure. In
from first principles” stuff as I'd like. it, | use the Line tool and SketchUp's venerable

inference engine to add a gabled dormer to a
sloped roof surface. With practice, you can, too.

Draw a profile

Use Follow Me Select the whole roof, right click, and
then choose Intersect with Model

Clean up the mess

>
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Chapter 5
Falling in Love with Components

In This Chapter
Lumping together geometry into groups
Discovering the wonder and majesty of components
Using components to make symmetrical models
Building stairs with component instances
Getting familiar with Dynamic Components
Making your own Dynamic Components with SketchUp Pro 7

wish there was a way to use the typography in this book to convey the

relative importance of certain topics; if there was, the word COMPONENTS
would be printed 4 inches high, and it would be colored neon green.
Components are that important.

Making a component (or a group) is like gluing together some of the geom-
etry in your model. Edges and faces that are grouped together act like mini-
models inside your main model; you use components and groups to make

it easier to select, move, hide, and otherwise work with parts of your model
that need to be kept separate. Getting used to using groups and components
is the single biggest thing you can do to get better at SketchUp.

This chapter is about creating and using SketchUp components to make your
life a whole lot simpler. I begin by talking about groups (which are a little bit
like lobotomized components). After that, I jump into components — finding
them, managing them, and making your own. The last part of this chapter

is brand new for SketchUp 7; it’s all about Dynamic Components, which are
the best thing to happen to SketchUp since the invention of the scroll-wheel
mouse.
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Grouping Things Together

|
Figure 5-1:
Making the
roof into

a group
means that
it won't stick
to the rest
of your
building.

Anyone who’s worked with SketchUp for even a short time has probably
noticed something: SketchUp geometry (the edges and faces that make up
your model) is sticky. That is to say, stuff in your model wants to stick to other
stuff. The people who invented SketchUp built it this way on purpose; the rea-
sons why would take a while to explain. Suffice it to say, making and using
groups are the keys to keeping the stuff in your model from sticking together.

You have many reasons to make groups; here are a few of them:

v Grouped geometry doesn’t stick to anything. Perhaps you’ve modeled
a building, and you want to add a roof. You want to be able to remove
the roof by moving it out of the way with the Move tool, but every time
you try, you end up pulling the whole top part of the house along with it
(like the middle image in Figure 5-1). Making the roof a separate group
allows you to let it sit on top of your house without sticking there,
making it easier to deal with, as shown in the right image in Figure 5-1.

The house is being stretched

'.L.":-l QI”Q ) Qi u !'_J Fay

+ Using groups makes it easier to work with your model. You can select
all the geometry in a group by clicking it once with the Select tool. You
can move groups around and make copies with the Move tool. To edit
a group, you double-click it with the Select tool. To stop editing it, you
click outside it, somewhere else in your modeling window.

+* You can name groups. If you turn a selection of geometry in your model
into a group, you can give it a name. In the Outliner (which I talk about
in Chapter 7) you can see a list of the groups (and components) in your
model, and if you’'ve given them names, you can see what you have.
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Follow these steps to create a group:

1. Select the geometry (edges and faces) you’d like to turn into a group.

The simplest way to select multiple entities (edges and faces) is to click
them one at a time with the Select tool while holding down Shift. You
can also use the Select tool to drag a box around the entities you want
to select, but this can be tough, depending on where they are. For more
information on making selections, check out Chapter 2.

2. Choose Edit->Make Group.

You can also right-click and choose Make Group from the context menu
that pops up.
o If you want to “ungroup” the geometry in a group, you need to explode it.
Right-click the group and choose Explode from the context menu. The edges
and faces that were grouped together aren’t grouped together anymore.

Working with Components

Even though components are incredibly important, there’s nothing too magi-
cal about them — they’re just groupings of geometry (edges and faces) that
make working in SketchUp faster, easier, and more fun. In a lot of ways, com-
ponents are really just fancy groups — they do a lot of the same things. In
the following sections, I talk about what makes components special and give
some examples of what you can do with them. Next, I give a quick tour of the
Components dialog box, pointing out where components live and how you
can organize them. The last part of this section is devoted to making your
own. It’s not hard, and after you can make components, you’ll be on your
way to SketchUp stardom. (Check out Chapter 11 for more on sharing your
SketchUp models with the world.)

What makes components so great?

By now, you've probably figured out that I'm a big fan of using components
whenever you can. Here’s why:

v Everything that’s true about groups is true about components. That’s
right: Components are just like groups, only better (in some ways, at
least). Components don’t stick to the rest of your model, you can give
them meaningful names, and you can select them, move them, copy
them, and edit them easily — just like you can with groups.
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Figure 5-2:
Changing
of a com-

changes all
instances,

3

1 Components update automatically. When you use multiple copies

(called instances) of the same component in your model, they’re

all spookily linked. Changing one makes all of them change, which
saves loads of time. Consider a window component that I created and
made two copies of, as shown in Figure 5-2. When | add something (in
this case, some shutters) to one instance of that component, all the
instances are updated. Now [ have three windows, and they all have
shutters.

These windows are instances
of the same component

o A

1 Using components can help you keep track of quantities. You can use

the Components dialog box to count, select, substitute, and otherwise
manage all the component instances in your model. Figure 5-3 shows
a great big (and ugly) building I designed to go with the window com-
ponent I made. [ have a lot more control because they’re component
instances than I would have otherwise.

* You can make a component cut an opening automatically. Perhaps

you’ve made a window (which I have) and you’d like that window to
poke a hole through whatever surface you stick it to (which I do). You
can set up SketchUp components to cut their own openings in faces.
These openings are even temporary; when you delete the component,
the hole disappears. Check out Figure 5-4 to see this in action.

Components that are set up to automatically cut openings can only do
so through a single face. Even if your wall is two faces thick, your com-
ponents will cut through only one of them.

»* You can use your components in other models. It’s a simple operation

to make any component you build available for use whenever you're
working in SketchUp, no matter what model you're working on. If you
have a group of parts or other things you always use, making your own
component collection can save you a lot of time and effort. There’s more
information about creating your own component collections later in this
section.
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Figure 5-3:
Quickly
count all the
Window 1
instances in
your model
(left), or
even swap
them out

for another
component.
(I'like heli-
copters,
don'tyou?)
|
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+* Components are great for making symmetrical models. Because you
can flip a component instance and keep working on it, and because com-
ponent instances automatically update when you change one of them,
using components is a great way to model anything that’s symmetrical.
And if you look around, you’ll notice that most of the things we use are
symmetrical. The second-to-last part of this chapter dives headlong into

modeling symmetrical things like couches and hatchbacks;

shows some examples.
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Figure 5-4:
Components

can cut their
own holes
in surfaces,
which is
handy for
windows
and doors.
|

|
Figure 5-5:
What do

all these
things have
in common?
They're
symmetrical.
|

Exploring the Components dialog box

oKETCH,,,  It’s all fine and well that SketchUp lets you turn bits of your models into
S components, [ suppose, but wouldn’t it be nice if you had someplace to keep
] them? And wouldn’t it be great if you could use components made by other
people to spiff up your model, instead of having to build everything yourself?
As you've probably already guessed, both of these things are possible, and
both involve the Components dialog box, which you can find on the Window
menu. It’s been completely overhauled for SketchUp 7.
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The Google 3D Warehouse

Imagine a place online where everyone in the
world can share SketchUp models for free.
That's the 3D Warehouse in a nutshell. It's
hosted by Google, it's available in over 20 lan-
guages, and it's searchable — just like you'd
expect from the world’s most popular search
engine.

You can get to the 3D Warehouse in a couple of
different ways:

v+ 0On the Web: Just type http: //sketch

v~ Through SketchUp: New for SketchUp 7,
the Components dialog box is hooked up
directly to the 3D Warehouse, as long as
you're online. You can also open the 3D
Warehouse in a separate window by choos-
ing File=>3D Warehouse=>Get Models.

Anything you find on the 3D Warehouse, you
can download and use in your own models. You
can also upload anything you make so that other
people can use it. Find out more about sharing

121

up . google. com/3dwarehouse into your work on the 3D Warehouse in Chapter 11.

your Web browser.

QWP Here’s something you need to realize: You can bring any SketchUp model on
your computer into your current file as a component. That’s because compo-
nents are really just SketchUp files embedded in other SketchUp files. When
you create a component in your model, you're effectively creating a new,
nested SketchUp file. Neat, huh?

The Components dialog box is made up of four major areas, which I describe
in the following sections.

Info and buttons

[ don’t really know what to call this part of the dialog box, so I'll call it like
it is: It’s for information and buttons. Figure 5-6 points out its elements, and
here’s what everything does:

v Name: The name of the component you select appears here. If it’s a
component in your model, it’s editable. If it’s in one of the default col-
lections, it’s not. A component is considered to be in your model if it
appears in your In Model collection, which you can read about in the
section “The Select pane,” later in this chapter.

v Description: Some, but not all, components have descriptions associ-
ated with them. You can write one when you're creating a new com-
ponent, or you can add one to an existing component in your model.
Just like the name, you can only edit descriptions for models in your In
Model library.
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v~ Display Secondary Selection Pane button: Clicking this button opens a
second view of your collections at the bottom of the Components dialog
box. You use this to manage the components on your computer system.

The Select pane

This is where your components live (if they can be said to live anywhere).
You use the Select pane to view, organize, and choose components.
Figure 5-7 shows the Select pane in all its glory.

+ In Model Collection button: SketchUp automatically keeps track of the
components you've used in your model and puts a copy of each of them
in your In Model collection. Each SketchUp file you create has its own
In Model collection, which contains the components that exist in that
model. Clicking the In Model Collection button displays the components
in your In Model collection, if you have any.

1 Collections List button: The components listed under the Favorites
heading are a mix of two different collection types:

¢ Local collections are folders of components that live on your hard
drive. You can access them anytime because they refer to files on
your computer.

¢ Online collections are groupings of components that live in the
Google 3D Warehouse (which you can read lots more about in this
book). Unlike local collections, you can only access online collec-
tions when you’re — you guessed it — online.
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|
Figure 5-7:
The Select
pane in the
Components
dialog box.
|

\\3
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Unfortunately, there’s no way to tell just by looking at them in the list
which collections are local and which are online. If you click the name
of a collection and see a Searching Google 3D Warehouse progress bar
before you see any models, that collection is online.

v+ 3D Warehouse Search bar: It works just like regular Google search:
Type in what you’re looking for and press Enter. Models in the Google
3D Warehouse that match your search terms appear in the Components
window below. Naturally, you need to be online for this to work.

v Components Window: This window displays the components in the cur-
rently selected component collection, or the results of a 3D Warehouse
search you've just performed. Click a component to use it in your model.

Components that have a little green arrow icon next to them are special;
they’re called Dynamic Components. They're new in SketchUp 7 and
they have special abilities. You can read about DCs later in this chapter.

v View Options button: Pretty simple, really. This is where you decide
how to view the components (or subcollections) in the Components
window.

1 Collection Details menu: Here’s where you manage your component
collections. A bunch of options exist, so I'd better explain what most of
them mean:
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¢ Open a local collection: Lets you choose a folder on your com-
puter system to use as a component collection. Any SketchUp
models in that folder show up in the Components Window, ready
to be used as components in your models.

¢ Create a new collection: Allows you to create a folder somewhere
on your computer system that you can use as a component collec-
tion. This is handy if you have a number of components that you use
all the time; putting them all in one place makes them easier to find.

¢ Save as a local collection: When you choose this option, SketchUp
lets you save the components that currently appear in your
Components Window as a brand-new local collection. If the com-
ponents you're viewing are online, copies of them get downloaded
to your computer. If you're viewing your In Model collection, the
contents get copied and included in a new folder. If you're already
viewing a local collection, this option isn’t available.

¢ View in Google 3D Warehouse: If you're viewing an online collec-
tion, this option opens that collection in a separate window that
displays the 3D Warehouse in much more detail.

¢ 3D Warehouse Terms of Service: Choose this option if you're
having trouble sleeping. If you're wondering who owns the stuff on
the 3D Warehouse, this is where it’s at.

Add to Favorites: Choosing this option adds whatever you're
viewing in the Components Window to the Favorites section of the
Collections list. That goes for local collections (folders on your
computer); online collections (from the 3D Warehouse); and 3D
Warehouse Searches. That’s right — you can save a search as a
favorite collection. The models in a Favorite Search collection will
always be different, depending on what’s in the 3D Warehouse.

The next two options only appear when you’re viewing your In Model
collection:

¢ Expand: Because components can be made up of other, nested
components, a component you use in your model might really be
lots of components. Choosing Expand displays all the components
in your model, whether or not they’re nested inside other compo-
nents. Most of the time, you’ll probably want to leave Expand dese-
lected.

<P ¢ Purge Unused: Choose this to get rid of any components in your In
Model collection that aren’t in your model anymore. Be sure to use
this before you send your SketchUp file to someone else; it’ll seri-
ously reduce your file size and make things a whole lot neater.
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Select and replace all your troubles away

On top of all the buttons, menus, and windows
you can immediately see in the Select pane
of the Components dialog box, some hidden
options exist that most people don't find until
they go looking for them; they're on the context
menu that pops up when you right-click an In
Model collection component:

v~ Select Instances: Perhaps you have 15
instances (copies) of the same component
in your model, and you want to select them
all. Just make sure that you're viewing your
In Model collection, and then right-click the
component (in the Components dialog box)
whose instances you want to select all of.
Choose Select Instances, and your work’s
done. This can save you tons of time, par-
ticularly if you have component instances
all over the place.

v+~ Replace Selected: Now you might want to
swap in a different component for one that's
in your model. Simply select the component
instances (in your modeling window) that
you want to replace, and then right-click
the component (in the Components dialog
box) that you want to use instead. Choose
Replace Selected from the context menu to
perform the swap.

Ready for an even better tip? Use Select
Instances and Replace Selected together
to help you work more efficiently. Instead of
placing 20 big, heavy tree components in your
model (which can seriously slow things down),
use a smaller, simpler component instead (like
a stick). When you're finished modeling, use
Select Instances to select all the stand-in com-
ponents atonce, and then use Replace Selected
to swap in the real component.

The Edit pane

125
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Because the options in this part of the Components dialog box are similar to
the ones you get when you make a new component, you should check out the
section “Creating your own components,” later in this chapter, for the whole
scoop.

You can only use the options in the Edit pane on components in your In Model
collection — everything is grayed out for components that live in any other
place.

The Statistics pane

Can you remember who won the 1975 Super Bowl? How many home runs did
Hank Aaron hit in his career? Do you always check the nutrition information
panel on food packaging? You might be a sucker for statistics, and if so, wel-
come home. . ..
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|
Figure 5-8:
The
Statistics
pane of the
Components
dialog box:
Geek out on
numbers.
|
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Even if you're not, the Statistics pane is a useful place to spend some time.
You use it to keep track of all the details related to whatever component you
have selected in the Components dialog box. (See Figure 5-8.) This is espe-
cially useful for doing the following things:

Components

Plywood sheet 438, 1/2" thick gy

== & #x8' sheet of plywood that
is 1/2" thick for use in
construction,

Select | Edt  Statistis |

All geometry = ¥ Expand

Name J Count
Edges 12
Faces

Component Instances
Guides

Guide Points

Groups

Images

3d Polylines

Section Planes
Dimensions

Text

coooocoococoo

17 Instances

v Checking the size of your components: The information in the Edges
and Faces areas of this pane lets you know how much geometry is in a
component. If you're worried about file size or your computer’s perfor-
mance, try to use small components — ones with low numbers of faces
and edges.

1 Seeing what components are inside your components: The Component
Instances line lists how many component instances are in your selected
component. If you switch from All Geometry to Components in the drop-
down list at the top of the pane, you can see a list of all the constituent
components: subcomponents within your main component.

The Statistics pane doesn’t show details for components you have selected

in your actual model; it only shows information about the component that’s
selected in the Select pane of the Components dialog box. To see information
about whatever component (or other kind of object) you have selected in
your modeling window, use the Entity Info dialog box (located in the Window
menu).

Creating your own components

Now that I've got you all jazzed up about the wonder and mystery of using
components in your models, I'll bet you can’t wait to start making your own.
At least | hope so — using components is probably the single best SketchUp
habit you can develop. Here’s why:
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1 Components keep file sizes down. When you use several instances of a
single component, SketchUp only has to remember the information for
one of them. This means that your files are smaller, which in turn means

you’ll have an easier time e-mailing, uploading, and opening them on
your computer.

1 Components show up in the Outliner. If you're a person who’s at all
interested in not wasting time hunting around for things you've mis-
placed, you should create lots of components. Doing so means that
you’ll be able to see, hide, unhide, and rearrange them in the Outliner,
which I go over in Chapter 7.

+ Components can save your sanity. Hooray! You've finished a model of
the new airport — and it only took three weeks! Too bad the planning
commission wants you to add a sunshade detail to every one of the
1,300 windows in the project. If you made that window a component,
you’re golden. If, on the other hand, that window isn’t a component,

you’re going to be spending a very long night holding hands with your
computer mouse.

1+ Components can be dynamic. New for SketchUp 7, Dynamic
Components are components with special abilities. They can be set up
with multiple configurations, taught to scale intelligently, programmed
to perform simple animations, and more. Anyone can use existing DCs,
but only people with SketchUp Pro 7 can create new ones. Check out

“Discovering Dynamic Components” later in this chapter, for the whole
story.

Making a new component

Creating simple components is a pretty easy process, but making more com-
plicated ones — components that automatically cut openings, stick to sur-
faces, and always face the viewer — can be a little trickier. Follow these steps,
regardless of what kind of component you're trying to make:

1. Select at least two edges and faces you’d like to turn into a
component.
For more information on making selections, see Chapter 2.
2. Choose Edit~>Create Component.
The Create Component dialog box opens. (See Figure 5-9.)

3. Give your new component a name and description.

Of these two, the name is by far the most important. Make sure to
choose one that’s descriptive enough that you’ll understand it when you
open your model a year from now.
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Create Component
General
Name: |BE sure to name your component.
Description: | add a description if you like.
I
Figure 5-9: | sigment
The Create Clue to: |None | SetComponent Axes
Component I™ Cut opening
. ™ Al 2 . .
dialog box. s : Ii—Only available for components that aren't glued
S.O ma ny I¥ Replace selection with component
options . .. o
I

4. Set the alignment options for your new component.

Wondering what the heck all this stuff means? I don’t blame you — it can
be a bit confusing the first time. For a quick introduction to each option
and tips for using it, check out Table 5-1.

5. Select the Replace Selection with Component check box, if it isn’t
already selected.

This drops your new component into your model right where your
selected geometry was, saving you from having to insert it yourself from
the Components dialog box.

6. Click the Create button to create your new component.

Table 5-1 Component Alignment Options
Option What It Does Tips and Tricks
Glue To Makes a component Use this feature for objects

automatically stick to a
specific plane. For example,
a chair will almost always
be sitting on a floor. It will
almost never be stuck to a
wall, turned sideways. When
a component is glued to a
surface, using the Move tool
only moves it around on that
surface — never perpen-
dicular to it (up and down, if
the surface is a floor).

that you want to remain on the
surface you put them on, espe-
cially objects you'll want to
rearrange: Furniture, windows,
and doors are prime examples.
If you want to “unstick” a glued
component from a particular
surface, right-click it and
choose Unglue from the
context menu.
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Option What It Does Tips and Tricks
Set Sets a component’s axis Click the Set Component Axes
Component origin and orientation. This button to choose where you
Axes is important primarily if you want your component’s axis
have SketchUp Pro 7 and are origin to be (where the red,
planning to make this into a green, and blue axes meet).
Dynamic Component. If you Click once to center your
aren't, you can safely leave axes, again to establish the
this alone. red direction, and again to
establish the green and blue
directions. If you're creating
a Dynamic Component, this is
something you absolutely must
know how to do.
Cut For components “on” a As with pre-made components,
Opening surface, select this check this opening is temporary:
box to automatically cut an If you delete the component
opening in surfaces you stick instance, the opening disap-
the component to. pears. If you move the com-
ponent instance, the opening
moves, too.
Always Makes a component always Using flat, lightweight compo-
Face face you, no matter how you nents instead of 3D heavy ones
Camera orbit around. To make your 2D is a great way to have lots of
Face-Me components (that's people and trees in your model
what they're called) work without bogging down your
right, rotate your component- computer.
to-be so that it's perpendicular
to your model’s green axis
before you choose Make
Component.
Shadows Only available when the You should leave this check box
Face Sun Always Face Camera check selected unless your Face-Me

box is selected, and is
selected by default.

component meets the ground
in two or more separate places,
as shown in Figure 5-10.

Components can only cut through one face at a time. If your model’s walls are
two faces thick, you’ll have to cut your window and door openings manually.
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Figure 5-10:
Deselect the
Shadows
Face Sun
check box
if your
component
touches the
ground in
more than
one place.
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[ Shadows face sun

¥ Replace selection with component

s  COrrect Shadow

Making your own doors and windows

If you're kind of nerdy like | am, nothing beats 2. Delete the face you just created to make a
making your own window and door compo- hole in your vertical surface.

nents. Here's what you need to know (check
out the illustration that follows this sidebar for
visual instructions):

3. Select all four edges of the hole you just
created. Then right-click one of the edges
and choose Make Component from the

1. Start by drawing a rectangle on a vertical context menu.
surface, like a wall.
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. Make sure that Glue to Any, Cut Opening,
and Replace Selection with Component are
all selected; then click the Create button to
create your new component.

. With the Select tool, double-click your
new component (in the modeling window)
to edit it; the rest of your model will appear
to fade back a bit.

. Use the modeling tools just like you
always would to keep building your door
or window any way you want.

. When you're done, click outside your com-
ponent to stop editing it.

Chapter 5: Falling in Love with Components 13 ’

If the opening you create ever closes up, one of
two things probably happened:

+ A new surface was created. Try deleting
the offending surface to see whether that
fixes things; it usually does.

v~ The cutting boundary was messed up. The
cutting boundary consists of the edges that
define the hole your component is cutting.
If you take away those edges, SketchUp
doesn’t know where to cut the hole any-
more. Drawing them back in usually sets
things straight.
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Editing, exploding, and locking component instances

Right-clicking a component instance in your modeling window opens a context
menu that offers lots of useful choices; here’s what some of them let you do:

1 Edit Component: To edit all instances of a component at once, right-
click any instance and choose Edit Component from the context menu.
The rest of your model will fade back, and you’ll see a dashed bounding
box around your component. When you’re done, click somewhere out-
side the bounding box to finish editing; your changes have been made in
every instance of that component in your model.

1 Make Unique: Sometimes you want to make changes to only one or a
few of the instances of a component in your model. In this case, select
the instance(s) you want to edit, right-click one of them, and choose
Make Unique from the context menu. This turns the instances you
selected into a separate component. Now edit any of them; only those
instances you made unique will reflect your changes.

v Explode: When you explode a component instance, you're effectively
turning it back into regular ol’ geometry. Explode is a lot like Ungroup in
other software programs (in SketchUp, you use Explode to disassemble
both components and groups).

v Lock: Locking a group or a component instance means that nobody —
including you — can mess with it until it’s unlocked. You should use this
on parts of your model you don’t want to change accidentally. To unlock
something, right-click it and choose Unlock.

Taking Advantage of Components
to Build Better Models

The fact is, a huge amount of the stuff in the galaxy is made up of some kind
of repeated element. In the case of bilaterally symmetrical objects (like most
furniture), that element is a mirrored half; for things like staircases, it’s a
step or tread. The whole is composed of two or more instances of a single
part. This makes modeling a heck of a lot easier, because it means you don’t
often have to model things in their entirety — especially if you're using
components.

The following is a list of reasons why you should work with components
whenever you're building an object that’s made up of repeated elements:

v It’s faster. This one’s obvious. Not having to model the same things

twice provides you with more time for playing golf or answering e-mail,
depending on what you prefer to do.
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v It’s smarter. Everybody knows that things change, and when they do,
it’s nice not to have to make the same changes more than once. Using
component instances means only ever having to do things once.

v It’s sexy. Modeling something and then watching it repeat in a bunch of
other places are fun to do, and the overall effect impresses the heck out
of a crowd. Somehow, people will think you’re smarter if they see things
appearing “out of nowhere.”

In this section, I describe two methods for modeling with components. The
first involves symmetrical objects, and it covers about 50 percent of the
things you might ever want to model. The second technique applies to things
like stairs and fences, which are both perfect examples of why components
were invented in the first place.

Modeling symmetrically: Good
news for lazy people

And smart people, | suppose. First off, take a hard look at the shape of the
things you might want to model. I want you to think about all the objects in
the universe. I'll wait a couple of minutes while you do that. Done so soon?
Good. Everything in the world (as I'm sure you realized) can be categorized
as either of the following formal types:

v Symmetrical: Objects that exhibit bilateral symmetry are made of mir-
rored halves. You're (more or less) bilaterally symmetrical, and so is
your car. Another kind of symmetry is radial symmetry, starfish are good
examples of this, as are umbrellas and apple pies. If you were going to
build a model of something that exhibits some form of symmetry, build-
ing one part and making copies would be a smarter way to do it.

v Asymmetrical: Some things — puddles, oak trees, many houses — aren’t
symmetrical. There’s no real trick to making these things; you just have
to make some coffee, settle in, and get to work.

You can take advantage of both bilateral and radial symmetry with SketchUp
components. To do so, you just assemble those components as follows,
depending on what type of symmetry your object has (also take a look at
Figure 5-11):

v~ Bilateral symmetry: To make a model of something that’s bilaterally
symmetrical, you just build half, make it into a component, and flip over
a copy.

v~ Radial symmetry: Radially symmetrical objects can be (conceptually,
anyway) cut into identical wedges that all radiate from a central axis. You
can use components to model things like car wheels and turrets by build-
ing a single wedge and rotating a bunch of copies around a central point.
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Figure 5-11:
Bilateral
symmetry
(top) and
radial
symmetry
(bottom)
make your
SketchUp
life a lot
easier.
|

Axis of symmetry

Working smarter by only building half

Bilaterally symmetrical forms are everywhere. Most animals you can name,
the majority of the furniture in your house, your personal helicopter — they
can all be modeled by building half, creating a component, and flipping over

a copy.

Follow these steps to get the general idea of how to start building a bilater-
ally symmetrical model in SketchUp (see Figure 5-12):
1. Make a simple box.

You can do this however you want, but I think the easiest way is to draw
a rectangle and push/pull it into 3D.

2. Draw a diagonal edge on the corner of your box.

The point of this step is to mark one side of your box so that when you
flip it over, you don’t get confused about which side is which.

3. Turn your box into a component.

Refer to “Creating your own components,” earlier in this chapter, if
you’re wondering how to do this.
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4. Make a copy of your new component instance.

The last part of Chapter 2 has information about moving and copying
objects in SketchUp, but here’s a simple version:

a. Choose the Move tool.

b. Press Ctrl (Option on a Mac) to toggle from Move to Copy mode.
You should see a little plus sign (+) next to your cursor.

c. Click your component instance.

d. Move your copy over beside the original, and click again to drop it.
Make sure that you move in either the red or the green direction; it
makes things easier in the next step.

5. Flip the copy over.

To do this, right-click the copy and choose Flip Along from the context
menu. If you moved your copy in the red direction in the previous step,
choose Flip Along=>Component’s Red. Choose Component’s Green if you
moved in the green direction.

6. Stick the two halves back together.

Using the Move tool (this time without Copy toggled on), pick up your
copy from the corner and move it over, dropping it on the corresponding
corner of the original. Take a look at the last image in Figure 5-12 to see
what I mean. Doing this precisely is important, if you want your model to

look right.
Make a box Turn itinto a component Move a copy over
r_fﬂh“‘a_ o
N . B =
\\\\ III =, < x\ 1 |
\\.\'\_... i
—— Flip the copy Stick the two halves together
Figure 5-12:
Getting set &
up to build =
a bilaterally =
symmetrical =
model. R -
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Now you're set up to start building symmetrically. If you want, you can do a
test to make sure things went smoothly (see Figure 5-13). Follow these steps:

1. With the Select tool, double-click one of the halves of your model to
edit it.

2. Draw a circle on the top surface and push/pull it into a cylinder.

If the same thing happens on the other side, you're good to go. If the same
thing doesn’t happen on the other side, it’s possible that:

* You're not really editing one of your component instances. If you
aren’t, you're drawing on top of your component instead of in it. You'll
know you’re in Component Edit mode if the rest of your model looks
grayed out.

+* You never made a component in the first place. If your halves don’t
have blue boxes around them when you select them, they’re not compo-
nent instances. Start a new file and try again, paying particular attention
to Step 3 in the preceding steps.

I“"'v.. e

| e

Figure 5-13:
Test your
setup to
make sure
that every-
thing works.
|

Whatever you do on this
side should happen on the
other side, too
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Making two halves look like one whole

Looking carefully at the little boat in the figure
that follows, notice how the edges in the middle
clearly show that it's made out of two halves?
If | were to erase those edges, my whole model
would disappear, because those edges are
defining faces, and without edges, faces can't
exist.

Instead of erasing those unwanted edges, | can
hide them by using the Eraser while pressing
Shift. See the second and third images of the
boat? When | hold down Shift as | drag over the
edges | want to hide with the Eraser, they disap-
pear. Two things are important to know about
hidden edges:

Distracting edges

v+ Hidden edges aren’t gone forever. Actually,
this applies to any hidden geometry in your
model. To see what's hidden, choose
View=>Hidden Geometry. To hide it again,
just choose the same thing.

v To edit hidden edges, you have to make
them visible. If you need to make changes
to your model that involve edges you've
already hidden, you can either view
your hidden geometry (see the previous
point) or unhide them altogether. Just
show your hidden geometry, select the
edges you want to unhide, and choose
Edit=>Unhide=>Selected.

Use Eraser to hide

The coolest things since radially sliced bread
You can model objects that exhibit radial symmetry just as easily as those

with bilateral symmetry; you just start out slightly differently. The only thing
you have to decide before you start is how many wedges — how many identi-

cal parts — your object is made of.

To set yourself up to model something with radial symmetry, you start by

modeling one wedge, then you make it into a component, and then you rotate

copies around the center. Follow these steps to get the hang of it yourself:

1. Draw a polygon with as many sides as the number of segments you
need for the object you’re modeling.
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Here’s the easiest way to draw a polygon in SketchUp, as shown in
Figure 5-14:

a. Choose Tools=>Polygon to select the Polygon tool.

b. Click once to establish the center (I like to do this on the axis
origin), move your cursor, and then click again to establish the
radius. Don’t worry about being accurate right now.

c. Before you do anything else, type in the number of sides you’d like
your polygon to have and press Enter.

Figure 5-14: Make a polygon Define a wedge Erase the rest
Draw a

polygon to
start, draw : . : .
two edges |' N |' Y |
to create a \ | | J B |
wedge, and e S
erase the ) ’
rest of your

polygon.
|

2. Draw edges from the center of your polygon to two adjacent vertices
(endpoints) on the perimeter, creating a wedge.

To find the center of a polygon (or a circle), hover your cursor over the
outline for a couple of seconds and move the cursor toward the middle;
a center inference point should appear.

3. Erase the rest of your polygon, leaving only the wedge.
4. Turn your wedge into a component.

Check out “Making your own components,” earlier in this chapter, if
you’re unsure of how to do this.

5. Make copies of your wedge component instance with the Rotate tool
(see Figure 5-15).

Just like with the Move tool, you can use the Rotate tool to make copies.
You can even make an array (more than one copy at a time). Here’s how
to doit:

a. Select your wedge’s edges (sorry — I just wanted to say that).
Select the face, too.

b. Choose Tools=>Rotate to select the Rotate tool.
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<MBE,

Figure 5-15:
Use the
Rotate tool
to make
copies of
your wedge
component
instance.
|

c. Press Ctrl (Option on a Mac) to tell SketchUp you want to make a
copy; a + should appear next to your cursor.

d. Click the pointy end of your wedge to set your center of rotation.

e. Click one of the opposite corners of your wedge to set your rota-
tion start point.

f. Click the other corner to make a rotated copy of your wedge.

g. Before you do anything else, type in the number of additional
wedges you want, followed by the letter x, and then press Enter.

6. Test your setup, if you want.
Follow the steps at the end of the previous section in this chapter to test
things out.

Hiding the edges in your component instances makes your finished model
look a whole lot better. Take a look at the sidebar “Making two halves look like
one whole,” earlier in this chapter, to read how.

Click to define center of rotation Click to start rotating

Press Ctrl (Option on Mac) to rotate copy Make more copies
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Figure 5-16:
Model a
single step,
making sure
that the
depth and
height are
accurate.
|

Modeling with repeated elements

A staircase is a perfect example of an object that’s composed of several iden-
tical elements. If, when you hear the phrase “several identical elements,” a
big, flashing neon sign that screams “COMPONENTS!” doesn’t appear in your
head, you're not using SketchUp enough. On the other hand, maybe there’s
something wrong with me. . . .

In the following example, I'm trying to kill two birds with one stone: I'm using
it to demonstrate how you might use components to model more efficiently,

and I'm using it to show readers of Chapter 4 the smartest way to build a set

of stairs.

The Treads Are Components method involves (you guessed it) making

each tread (step) in your staircase into an instance of the same component.
Basically, you build one simple tread that’s the right depth, make it into a
component, and copy a bunch of instances into a full flight of stairs. Because
every step is linked, anything you do to one automatically happens to all of
them. If you don’t know the first thing about components, now would be a
terrific time to start from the beginning of this very chapter.

Go through these steps to build a staircase using the Treads Are Components
method:

1. Model a single step, including the tread and the riser.

You can make this very simple at this stage, if you want to; all that mat-
ters is that the tread depth and the riser height are correct. You can fiddle
with everything else later. Figure 5-16 shows a simple example of this.

2. Make a component out of the step you just built.

Take a look at “Making your own components,” earlier in this chapter, if
you need help.
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Figure 5-17:
Make your
step into a
component

instance,
move a copy
into position
ahove the
original, and
then create
an array.
|

. Move a copy of your step into position, above the first one (see

Figure 5-17).

. Type in the total number of steps you want, type an x, and then press

Enter.

You're creating a linear array, meaning that you’re making several
copies at regular intervals, in the same direction you moved the first
one. Typing 12x generates 12 steps the same distance apart as the first
step and its copy. The last image on the right in Figure 5-17 shows what |
mean.

. With the Select tool, double-click any one of your steps to edit all

instances of your component.

Everything besides the component instance you’re editing should fade
out a little.

. Go nuts.

This really is the fun part. Having your staircase made up of multiple
component instances means that you have all the flexibility to make
drastic changes to the whole thing without ever having to repeat your-
self. Add a nosing (a bump at the leading edge of each tread), a stringer
(a diagonal piece of structure that supports all your steps), or even a
handrail by getting creative with how you modify a single component
instance. Figure 5-18 shows some of what you can do. The color insert in
this book shows the Treads Are Components method applied to building
a circular stair.

=] Create Component

zurf General

Name: | Step

Description: ﬁ

| Algnment

Glue to: |None ~| SetComponent Axes
- i
[~ Aways face camera

[V Replace selection with component

i -
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|
Figure 5-18:

A flight of
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side string-
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a single
component
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Once upon a time, the smartest thing a component could do was cut its own
hole in a surface. “Wow!” all of us SketchUp aficionados thought, “Components
are geniuses!” And so they were — until SketchUp 7 came along. With the
latest release, the folks at Google have introduced an entirely new dimension
to modeling with SketchUp: Dynamic Components are components with spe-
cial powers.

Until version 7, SketchUp components were basically dumb. If you wanted to
make a staircase longer, you had to make copies of the steps and place them
in the right spot. If you needed to change the color of a car, you had to dig
out the Paint Bucket and dive into the geometry. The problem was that com-
ponents didn’t know what they were supposed to represent; they were just
groupings of faces and edges in the shape of an object.

Dynamic Components (DCs) are models that have an idea of what they are;
they know what to do when you interact with them. This section outlines
what DCs represent for SketchUp modelers, how to use them, and how to go
about creating your own.

Getting acquainted with DCs

There’s a lot to cover, so dive right in. Here’s what you need to know about
Dynamic Components:

1 DCs are just like regular components, but with extra information
added. That extra information makes them easier to deal with than
other components, because they know how they’re supposed to behave
when you need to use them. More on that later.
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1+ They can do all sorts of things. Describing what DCs do is tricky
because they're all different. The simple (but totally unsatisfying)
answer is that they do what they’ve been programmed to do. I think
some examples are in order (see Figure 5-19):

* A dynamic door component might be set up to swing open when
you click it with the Interact tool.

¢ The same dynamic door might also be configured into different
sizes, styles, and finishes by using simple drop-down menus in the
Component Options dialog box.

¢ A dynamic stair component might automatically add or remove
steps as you use the Scale tool to make it taller or shorter.

# Camy Optians =50
Arched Top Door

Arched Top Inswinging Door
Configurable Component

Irswngng Arched Top Boor
Heght |64 =1
width (24 =1
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18
]
— 20
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24 tﬁ

24
24
200
34
32

| 14
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= A 4 :@ = .
Figure 5-19:
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Components h 03
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¢ A dynamic chair might be scaled into a sofa, but without stretching
the arms — it would also add cushions as you make it longer.

e Sang (the little dude who shows up by default when you start a
new SketchUp file) is also dynamic: click his shirt with the Interact
tool to cycle through the Google colors.

1 Anyone can use DCs. Both the free and Pro versions of SketchUp 7 can
read and use Dynamic Components. The SketchUp team invented them
(at least partially) to make SketchUp easier for new modelers to pick up.

+* You need Pro to make your own DCs. If you need to build your own
Dynamic Components (or modify ones that other folks have made), you
need a copy of SketchUp Pro 7. If you’d like, you can download a free trial
of Pro from the SketchUp Web site: http: //sketchup.google.com.

+* DCs are free. People are adding new DCs to the Google 3D Warehouse
every day. As you can imagine, companies that make things like furni-
ture and building products (windows, kitchen cabinets, flooring) are
really excited about the possibilities that Dynamic Components offer.
Many of them are in the process of producing DCs of everything in their
catalogues and posting them to the 3D Warehouse. That’s good news for
us; soon you can download and use a configurable model of almost any-
thing you need.

v They’re in the 3D Warehouse. When you download SketchUp, you find
a few sample DCs in the Components dialog box. They’re the ones with
the little, green dynamic icon next to them (that looks kind of like an
arrow). The best way to get more is to visit the 3D Warehouse and do a
special search:

1. Choose File=>3D Warehousem>Get Models to open a window into
the 3D Warehouse from inside SketchUp.

2. Add the following parameter to any search for models you do:
:isdynamic. For example, if you were looking for a dynamic door,
you’d search for door :isdynamic. You can also just search for
is:dynamic to find all of the DCs in the 3D Warehouse.

Using Dynamic Components

In SketchUp 7, you can interact with Dynamic Components in three basic
ways. Depending on what it’s been set up to do, a particular DC might
respond to one, two, or all three of the following interactions.

Smart Scaling

DCs designed to react intelligently to the Scale tool are the closest thing to
true magic that SketchUp offers. Instead of stretching and getting all dis-
torted when you scale them, the parts that are supposed to change dimen-
sions, do; the other parts don'’t.
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Take a look at Figure 5-20. The first image shows what happens when I scale
a non-dynamic window component to make it wider. See how the frame
stretches? Yuck. The image on the bottom shows the dynamic version of
the same window. It gets wider when I scale it, but the frame stays the same
thickness. It’s smart enough to know that only some parts of it should get
wider when I scale it.

There’s another way that DCs can scale smartly: by adding or subtracting
pieces as they get bigger or smaller. Dynamic stairs are a perfect example of
this, as you can see in Figure 5-21. When I use the Scale tool to make it taller,
the staircase adds steps instead of stretching.

Original

Non-dynamic component stretches

Figure 5-20:
Scaling
anon-
dynamic
window
(top)
stretches
the whole
thing. The
DC version
scales
properly.
|

Dynamic component resizes correctly
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Figure 5-21:
When you
make it
taller, this
dynamic
staircase
adds steps
instead of
stretching.
|

\3 . AR .
) You can turn on the Dynamic Component toolbar, which is a quicker way to

work with DCs than constantly using the menu bar. Just choose View=>
Toolbars>Dynamic Components, and you're all set.

Component Options

Version 7 added the Component Options dialog box, which is on the Window
menu. You can configure DCs that have been hooked up to this dialog box by
choosing options from drop-down lists, typing in dimensions, and performing
other simple tasks. When you change a setting in Component Options, the
DC you've selected updates to reflect the change. It’s kind of like modeling by
remote control.
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The Component Options dialog box looks different for every DC.
The first image in Figure 5-22 shows the Component Options dialog box for a
simple, straight staircase I built. I set it up so you can choose a riser height
and a tread depth from preprogrammed lists. The dialog box also displays
the total height (rise), total length (run), and number of steps in the staircase
as it currently appears.
The second image in Figure 5-22 shows the Component Options for a circular-
stair DC. I wanted to provide a lot of configuration options, so it looks a lot
different. The dialog box lets you enter a size, structure type, and other infor-
mation, then redraws the staircase based on your specifications.
¥ Component Options BIE]=] ¥ Component Options 3] =[]
” Simple Stair o Circular Stair
Z ".'Ee%
Choose a riser height and a tread depth.
Floor to Floor Height ’M—
Riser |7inches = Inside Radius ]3'5'—
T'E_ad lu“"dm = Outside Radus 84
ot |39 Riser Height (ideal) l)"
Total Run [50°
Tread Thickness ,1'—
Total Treads |6
angleMethod [Center Depth =]
— Center Depth (deal) {117
Figure 5-22: Stepnge 105
The m Support Type |Inside and Outside Stringers -
Component Stringer Height |47
Options Center Pole Height [218”
dla|Og bOX Handrail Type |Inside and Outside Handrails =
|00kS diﬁer' Handrail Height 42"
ngie (actual ,D—
ent for every e
Dynamic
Component.
| @

The Interact tool

The Interact tool is another all-new thing in SketchUp 7. Activate the Interact
tool by choosing it from the Tools menu. Using it couldn’t be simpler: When
aDC is set up to react to the Interact tool, it does stuff when you click it. Its
actions depend on what you’'ve programmed it to do.
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™ Click to activate

Figure 5-23:
Clicking
stuff with
the Interact
tool makes
things
happen.
|
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Check out the truck in Figure 5-23. It’s been designed to react to the Interact
tool in a few different ways:

v Clicking the back of the truck cycles through the following options: box,
flatbed, or flatbed with rails.

v Clicking the front wheels turns them from side to side.

v Clicking the doors makes them open and close.

When you're hovering over a DC that’s been connected to the Interact tool,
your cursor (it was originally called the Magic Finger) gets a little yellow glow
at the end of it.

Poking around to see what happens

You can’t know which interactions you can use with any particular Dynamic
Component just by looking at it. If you know you’re dealing with a DC, the
best way to figure out what it does is to experiment:

v Select it and open Component Options to see if there’s anything there.

v Get the Interact tool and hover over it to see if a glow appears at the end
of your cursor.

v Get the Scale tool and click it to show its scale grips (little green boxes).
If any show up, grab one and scale to see what happens. If none show
up, your DC can’t be scaled with the Scale tool.

You should know that groups can be dynamic, too. Deep down in the dark
recesses of SketchUp’s programming, groups and components are pretty much
the same thing — groups are just components that behave differently. This
means that it’s possible to have a group that’s been assigned dynamic abilities.
What does it matter to you? Not much, but I thought I'd point it out. It’s good
to know, especially if you plan to build your own DCs with SketchUp Pro.

Building your own Dynamic Components

Keeping in mind that this topic could easily occupy the remainder of this
book if I let it, making your own Dynamic Components really is easier than

it sounds. If you’'ve been reading the rest of this section, you’ve probably
noticed that I use the word programmed a lot in conjunction with DCs; I
shouldn’t. DC creation has nothing to do with programming at all, and you
certainly don’t need to be a programmer to do it — goodness knows I'm not.

You need SketchUp Pro 7 to create new Dynamic Components.

www.it-ebooks.info

149


http://www.it-ebooks.info/

150 Partii: Modeling in SketchUp

,\Q&. B

Based on the limited amount of time I (and everyone else) have been making
my own DCs, here are the things I think it's most important to know before
you get started:

v It’s based on spreadsheets. If you're familiar with using formulas and

simple functions in programs like Microsoft Excel or Google Docs, you’ll
catch on right away. It also helps to remember a little bit of algebra. If
you're frowning right now, I'm afraid you might be in for a bit of a bumpy
ride. There’s no getting around it: Creating Dynamic Components is way
more technical than anything else you’ll ever do in SketchUp.

+* You need to be very familiar with groups and components. When

you’re building a DC that has many different parts, you build each of
those parts as a separate component. Many DCs end up being made

of complicated hierarchies of components nested inside other compo-
nents, which are in turn nested inside other components. If you haven’t
already done so, take the time to read this chapter from the beginning —
it’s a start.

+* You need to know about Component Axes. Because a SketchUp com-

ponent is actually a mini-model inside your main model, it has its own
set of red, green, and blue axes. If you double-click any component with
Select, you'll see what [ mean.

Here’s where it gets interesting: Every single one of the dimensions or
spatial positions you specify when you’re building a DC refers to the
Component Axes of the components you're working on. When it comes
to making DCs, it’s all about knowing where each component’s axes are,
and being very comfortable with repositioning them when you have to.
Have a look at the sidebar “Getting to know your components’ axes” for
more about this.

1 Colors are now letters. Until now, you've been able to get away

with thinking about SketchUp’s three directional axes in terms of
colors; they're just red, green, and blue. When it comes to Dynamic
Components, things get a little bit more complicated. This is what you
need to know: X is red, Y is green, and Z is blue.

Coping with Component Attributes

First, a word of warning: This section is technical and boring and won’t mean
much to you until you've gotten a little further with DCs. It’s a little bit like
reading the owner’s manual for a car before you get behind the wheel — infor-
mative but essentially meaningless. This section is here because it contains
information you'll need sooner than later, and because it’s too long to be a
sidebar.

I strongly suggest skipping to the following DC example sections and coming
back when you feel like it. Now that that’s out of the way . . .
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Getting to know your components’ axes

Every SketchUp component — dynamic or oth-
erwise — has its own set of red, green, and blue
axes. To build your own Dynamic Components,
you always need to know exactly where each
component’s axes are. Moreover, you need to
be able to relocate them when necessary; as
you get into authoring DCs, it becomes second
nature. Component Axes are as integral to DCs
as the Push/Pull tool is to regular SketchUp
modeling.

To see a component’s axes, double-click it with
the Select tool (as if you're planning to edit it).
The axes are in the corner of the component by
default, but you can place them wherever you
like. You can do this in two ways:

v+ When you're creating the component. The
Create Component dialog box has a button
labeled Set Component Axes. Clicking it lets
you position your new component’s axes

anywhere you like. As you get familiar with
DCs, you develop a good sense of where
they should go, right from the start. Until
then, there's always . . .

v~ Anytime after that. Right-click the compo-
nent and choose Change Axes. When you
do, your cursor turns into a set of axes.
Click to place the origin (where the three
colors meet), click again to orient the red
direction, and again to indicate which way
is up.

| know what you're thinking: Where am | sup-
posed to put them? The answer, unfortunately,
isn't simple. It all depends on what you're build-
ing and how you're building it. For right now,
simply knowing that your component has its
own axes and that you control where they are is
the first step in understanding how DCs work.

you want it to do.

Building Dynamic Components is all about setting up rules and relationships
for the different parts of your model. Each piece of information about your
DC — dimensions, colors, angles, copies, visibility — is a discrete value

called an attribute. Which attributes your DC has depends entirely on what

In SketchUp Pro 7, you manage all of your components’ attributes in a new
dialog box called Component Attributes. Choose Window=>Component

Attributes from the menu bar to open it up. Figure 5-24 shows what it looks
like for a semi-simple dynamic staircase.

It’s set up like a spreadsheet — like a series of spreadsheets, actually.
There’s one for each component and subcomponent in your DC, and they’re
indented so you can see what’s nested inside what. The staircase example in
this sidebar includes three children, or subcomponents: Tread, Backstop, and
Stringer.
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Figure 5-24:
The
Component
Attributes
dialog box

is where

the magic
happens.
|

\\3

Click the Toggle Formula button to see your formulas (right)

## Component Attributes m ## Component Attributes 2=
11| Info | 14 Funct\uns___ Q i 11| Info | 14 Funct\uns___ Q :f*_
@ Add attributes below to create your component options. Wgit @ Add attributes below to create your component options. Visit
our getting started quide for tutorials our getting started quide for tutorials
~ ~
= Staircase inch = Staircase ]
Component Info Component Info
Name Simple Stair Name Simple Stair
Size Size
LenZ 3 LenZ
Behaviors Behaviors
ScaleTool E ScaleTool
Custom Custom
RiserActual 5.576685 RiserActual =LenZ/StepNumber
Riserldeal - 5| Riserldeal - &
StepNumber 7 StepNumber =ROUND(LenZRiserldeal 0)
StringerHeight 2 StringerHeight 2
SiringerThick 3 a ] StringerThick 3 a
TreadDepth 10 a TreadDepth 10 a
TreadThick 15 B TreadThick 15 B
ZOverallRise 39 B ZOverallRise =ROUND(LenZ,0) B
ZOverallRun 60 5| ZOverallRun =(StepNumber-1)*TreadDepth a
ZOverStepCount 6 B ZOverStepCount  =StepNumber-1 B
®| Add attribute ®| Add attribute
# Tread ] # Tread ]
# Backstop ek | # Backstop ek |
#  Stringer e #  Stringer e
b b
Values View Formula View

The Component Attributes dialog box only shows two levels of hierarchy

at a time. If you have more than two levels of nesting in your DC, drill down
into your component (by double-clicking it with the Select tool) to make the
deeper levels appear in Component Attributes.

Each row in the dialog box is a single attribute. The name of the attribute is
in the cell on the left, and the value is in the cell on the right. Some attributes
are very simple (StringerHeight), some are formulas that calculate values
based on other attributes (RiserActual), and some include scary-looking
functions (StepNumber). You can switch between viewing formulas and

the values they produce by clicking the Toggle Formula View button in the
upper-right corner of the dialog box.
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If you're used to working with spreadsheets, this should be familiar territory.
These tips are for creating and editing attributes:

v Add an attribute by clicking the + icon in the last row of your compo-
nent. When you do, a list of pre-made attributes pops up. Click one to
add it, or type in a name to create a custom attribute.

v~ Edit the name of an attribute by double-clicking it. Keep your attri-
bute names short but meaningful. Use underscoring (Like_This) or
CamelCase (LikeThis) instead of spaces.

1~ Edit the value of an attribute by clicking its cell. When you're finished
editing, press Enter to register the change. If you don’t, your edit won’t
take.

1 Grayed-out values are just there. See how the value of LenZ in the com-
ponent Staircase is lighter than most of the others? That means that it’s
a current value; it’s not a value I specified. It just happens to be the cur-
rent value of that attribute.

1 Use = to constrain an attribute. When you type an equal sign (=) before
anything you enter for an attribute, you're telling SketchUp that what
comes after is a rule; it constrains that attribute. If | make a box and type
6 for the length, 8 for the width, and =12 for the height, 've made a rule
that no matter how I scale the box, it will always snap back to being 12
inches high. Typing a value without an = simply sets that value until it
changes. Using an = tells SketchUp to preserve that value at all costs.

v Since formulas and functions are basically constraints, use an = before
them, too. Just like in other spreadsheets.

v To reference another attribute, click it. When you’re entering a for-
mula, you don’t have to type the names of other attributes you want to
use; you can click them to add them automatically. It’s faster and makes
for more accurate formulas.

v~ The ! indicates a referenced attribute from another component. In
the child component Tread, the attribute LenY is defined as =Staircase!
TreadDepth. The exclamation point () means you're looking at the
attribute TreadDepth from the parent component Staircase.

v Attributes appear in alphabetical order. No matter what order you
add them in, your attributes always arrange themselves in alphabetical
order — in Component Attributes and in the Component Options dialog
box. To make them appear the way you want, try adding a prefix (like
A_and B_) to your attributes’ names.
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Figure 5-25:
This table
component
is made

up of five
subcompo-
nents, each
with its own
Component
Axes.
|

When SketchUp is calculating values for the formulas in a DC, SketchUp
always starts at the first formula in the top-level component and works down
from there. When it gets to the bottom (the last formula in the lowest-level
nested component in your DC), it redraws the model. This means that values
that are calculated later in the process have no effect on formulas earlier in
the process. You need to keep this in mind when you’re planning complicated
DCs with lots and lots of formulas.

Damn the torpedoes: Smart Scaling

I think the best way to get started with Dynamic Components is to dive right
in and look at an example. Writing about stuff like this in the abstract makes
my brain sore. | assume you feel the same way.

Here’s a fairly (but not entirely) simple one: The first image in Figure 5-25 is

a table that I've made dynamic; I can use the Scale tool to make it longer or

wider but not taller. When [ scale it, the legs don’t get distorted — they stay
the same size. I can use the Component Options dialog box to choose table

height, leg thickness, and tabletop thickness. I can also use the Interact tool
to cycle through three different color choices.

Main component axis origin
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Look at how the table’s put together. The second image in Figure 5-25 shows
that it has five parts, all of which are individual components nested inside
the main component called Table, for a total of six components:

V¥ Table
® TableTop
® TableLegl
® TableLeg2
® TableLeg3

® TableLegd

Next, pay attention to where I've positioned the Component Axes for each
part. (Take a look at the sidebar “Getting to know your components’ axes” if
you’re wondering what’s going on.) The third image in Figure 5-25 shows the
location of the axes for each of the six components. I placed the axes for each
leg at the outside corners of the table so that scaling the table also reposi-
tions the legs.

Now take a look at the Component Attributes dialog box for the component
Table; see Figure 5-26. Component Attributes is the spreadsheet-like interface
where you put in all your formulas, and it’s available on the Window menu.
Refer to the section “Coping with Component Attributes,” earlier in this chap-
ter, for details. Notice the following:

+* Subcomponents are indented under their parent component. In this
case, the four TableLegs and TableTop are children of the main compo-
nent Table.

+* Each component is collapsible. Clicking the little triangles next to each
component reveals and hides the rows (called atfributes) associated with
that component. Right now, only Table, TableLegl, and TableTop are
expanded. The formulas in TableLeg2, 3, and 4 are identical to the ones
in TableLegl, so I didn’t show them in the image.

1 Table has a total of six visible attributes. Here’s what each of them
does:

e LenZ: Short for “Length in the Z direction,” it determines the over-
all height of Table. The Z direction is the same as the blue direc-
tion. While I'm at it, X is red and Y is green.

¢ Material: Determines the material (in this case, the color) of Table.
This attribute’s value is set by the formula in the OnClick attribute,
which I cover in a moment.

www.it-ebooks.info

155


http://www.it-ebooks.info/

156 Partii: Modeling in SketchUp

Figure 5-26:
The
Component
Attributes
dialog box

is where
you make
components
dynamic.
|

\\3

ﬁf Component Attributes 3=

|i| info | |A{ Functions il

Add attributes below to create your component options. Visit
our getting started quide for tutorials.

®| Add attribute

= Table
Size
LenZ
Behaviors
Material
ScaleTool
onClick SET(Material,"red”,"green”,"white”)
Custom
Leg 2 B—
Top ks

# Ta.bIELegd inch
= TableLeg1 nch
Size | —
Lenx TablelLeg — T
LenY =TablelLeg
LenZ =TablelLenZ-TableTop \
@ | Add attribute —
+ Ta.bIeLEQEI inch
# TableLeg3 inch
= TableTop inch
Size
LenZ =TableMop
@ Add attribute

The height of the table

The current color
How the Scale tool works on this DC

What to do when someone clicks on it
The dimension of the leg

The dimension of the top

The size of the leg along the X axis

The size of the leg along the Y axis

The size of the leg along the Z axis

The size of the top along the Z axis

¢ ScaleTool: Determines which scale grips appear when Table is
scaled. “Some scale handles hidden” refers to the fact that I've
decided to hide all but the X (red) and Y (green) direction scale
grips, so that Table can only be scaled wider and longer. I clicked
the Details button (on the right side of the row) to set which grips

should be visible.

OnClick: Determines what happens when someone clicks Table

with the Interact tool. Here, I've used the Set() function to tell it
to cycle through three colors. When it’s clicked, it sets the attri-
bute Material to one of the three values listed in the function: red,

green, or white.

To learn more about the DC-building functions, click the More
button at the top of the Component Attributes dialog box. 'm
afraid I just don’t have enough space to go into any detail about

them in this book.
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* Leg: Determines the thickness of each TableLeg.
e Top: Determines the thickness of TableTop.
v TableLeg]l has three visible attributes. They’re very similar, actually:

¢ LenX: Short for “Length in the X direction,” it determines the
dimension of TableLeg in the X (red) direction. The value of
this attribute is equal to the value of the attribute Leg in Table:
=TablelLeg.

e LenY: Short for “Length in the Y direction,” it determines the
dimension of TableLeg in the Y (green) direction.

¢ LenZ: Short for “Length in the Z direction,” it determines the
dimension of TableLeg in the Z (blue) direction. The value of this
attribute is equal to the difference between the overall table height
and the thickness of the tabletop: =Table!LenZ-Table!Top.

v~ TableTop has only one visible attribute. “LenZ,” in this case, deter-
mines the dimension of TableTop in the Z (blue) direction. Its value is
equal to the value of the attribute Top in Table: =Table!Top.

Having fun yet? Don’t worry — it gets easier the more you do it. Look at
one more aspect of the way I set up this DC: the way it’s connected to the
Component Options dialog box.

Take another look at Figure 5-26; see the little Details button next to the LenZ,
Leg, and Top attributes in Table? Clicking that button opens a special part of
the Component Attributes dialog box. There you can decide if — and how —
that attribute should be visible in the Component Options dialog box.

Figure 5-27 shows the Component Options dialog box for Table, as well as

the settings in Component Attributes that make those options available.

Figure 5-27: _
The choices i Component Options =alE

in the | =g y Table

Component
Options
dialog box
are deter' Table Height |30 |
mlned by Leqg Thickness JZ'
settings
you make in
Component
Attributes.
|

Top Thickness | 3
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Pass those attributes up the chain
For an attribute (SketchUp sometimes calls If your DC has multiple layers of nested compo-
them options) to show up in the Component nents, and you want to show an option associ-
Options dialog box, it has to be associated with  ated with one that's buried a few layers deep,
the parent (main) component of a Dynamic  you need to create attributes in each parent
Component. In other words, if you want to be  component to create what | like to call an attri-
able to set an attribute from the Component bute chain. It's a little bit messy, but c’est /a
Options dialog hox, make sure it's in the top  vie. Take a look at the following diagram to see
level of your DC. what I'm talking about.
Hubcap Style | Executive v
Grandpa
Executive D
P. Diddy
W Automobile (main DC)
Hut ,f_
V¥ Wheels (chafd of Automobile)
HubcapStyle=Automobile!HubcapStyle
Y FrontWheels (child of Wheels) D
HubcapStyle=Wheels!Hubc style
‘ W RightFront (child of FrontWheels)
HubcapStyle=FrontWheels!HubcapStyle
' RF_Hubcap (child of FrontWheels) ’
......... St =RightFront!HubcapStyle
Moving right along: Smart Replication
«Q&,WEg Here’s another example: The bookcase in Figure 5-28 is a Dynamic Component
S that automatically adds shelves as you use the Scale tool to make it taller.

“\\\\‘;;:,,,/

When you scale is shorter, it removes shelves. This DC is an example of a
behavior I like to call smart replication, meaning that it adds (or removes)
copies of a particular part as it changes size. As you can imagine, things like

stairways and fences also benefit from this kind of setup.
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Figure 5-28:
This
bookcase
automati-
cally adds
or removes
shelves as
you change
its height.
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The key to making DCs that replicate automatically is to use the Copies attri-
bute (which I describe at the end of this section, oddly enough). It takes most

new DC-makers a couple of tries to figure out Copies, so don’t get discouraged.
This stuff isn’t rocket science, but it isn’t exactly finger painting, either.

The images in Figure 5-28 show three things:

1 The effect of using the Scale tool on the bookcase. Notice that I've set
up this DC to only be able to scale in the blue (height) and red (width)
directions.

+* The subcomponents in the DC. The hierarchy of this Dynamic
Component is very simple. The parent (main) component is called
Bookcase, and it contains three children (subcomponents):

¢ Right: The right-hand vertical support.

e Left: The left-hand vertical support.

e Shelf: Even though the bookcase currently has four shelves, this
DC actually only has one Shelf component in it. The other three

are copies that have been generated based on the bookshelf’s
total height.

blue

Main component axis origin
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+» The Component Axes of each component. As always, where you locate
the axes for your DCs (and their children) is the single biggest factor in
determining how complicated your formulas will be. Take a look at the
sidebar “Getting to know your components’ axes” for advice.
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Here’s why [ located my components’ axes where I did:

¢ Bookcase: The axis origin is right smack dab in the middle, along
the bottom edge of the front of the component. I put it there
because Bookcase is symmetrical; it’s the same on both sides. If I
ever need to add parts that are equidistant (equally far) from the
center of the bookcase, specifying their locations (by means of for-
mulas) is a lot easier — one is just the negative of the other.

¢ Right and Left: Their axes are positioned on the outside edges of
the bookcase so that scaling Bookcase to change its width will also
move Right and Left. If  hadn’t done this, I'd be forced to use a
formula to tell each of them where to be, relative to the rest of the
component. It’s all about making things simpler while retaining the
flexibility to make changes later.

¢ Shelf: Just like its parent component Bookcase, the axis origin for
this component is in the center. Putting it there makes it easy to
specify its location relative to the rest of the component.

Figure 5-29 is an image of the Component Attributes dialog box for Bookcase.
Here’s a brief rundown on the attributes (remember those?) for each of the
four components:

+* Bookcase has four visible attributes:

¢ ScaleTool: Clicking the Details button on the right of the row lets
you specify how this component is allowed to be scaled.

¢ Shelf: The thickness of each shelf, in inches.
e Sides: The thickness of the side pieces, in inches.
¢ Spacing: The center-to-center spacing between shelves.

v Left and Right have only one visible attribute each. It's LenX, and it
determines the thickness of the side pieces. Its value is equal to the
value of Sides, in Bookcase. Having these two subcomponents refer to
an attribute in their parent component makes changing them easier; it’s
one place instead of two.

+ Shelf has five visible attributes:

¢ X: Determines the location of the axis origin of Shelf relative to the
axis origin of Bookcase, along the X (red) axis. Because I centered
the axes on each component when I set things up, | can make this
value 0. Effectively, the center of each shelf should be 0 inches
from the center of the bookcase.
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—— What the Scale tool does
| The shelf dimension

+—— The side upright dimension
—— The shelf spacing

The size of the upright
along the X axis

The position along the
parent component’s X axis

The position along the
— parent component's Y axis

The size of the shelf along
the X axis

~ The size of the shelf along
the Z axis

How many copies of Shelf

to draw

e Z: Determines the location of the axis origin of Shelf relative to the

axis origin of Bookcase, along the Z (blue) axis. Basically, it deter-
mines the height of each shelf by multiplying two values together:
the shelf spacing (Spacing in Bookcase) and the copy number of
the shelf.

Here’s where it gets interesting. There are four shelves in
Bookcase, but only one component called Shelf, right? That’s
because the other three (the top three, in this case) are copies of
the first one. Take a look at my description of the Copies attribute,
a couple of paragraphs from now, to get the rest of the story.

The word copy in this formula (Z=copy*Bookcase!Spacing) tells
SketchUp to use the copy number of the shelf it’s trying to posi-
tion. If it’s drawing the third shelf, it uses the copy number 2
(because it’s the second copy) to do the calculation. If the shelf
spacing is 8 inches, then the third shelf is 8 x 2 inches high.
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¢ LenX: Determines the dimension of Shelf in the X (red) direction.
This attribute’s formula takes the overall width of Bookcase and
subtracts the thickness of the two side pieces.

¢ LenZ: Determines the dimension of Shelf in the Z (blue) direction —
its thickness. According to this attribute’s simple formula, its value
is equal to the value of Shelf in Bookcase. By referring to an attribute
in the parent component (Bookcase), you can expose its value in the
Component Options dialog box. That way, it’s easier for anyone to
edit. Take a look at the “Pass those attributes up the chain” sidebar
to find out more about this.

¢ Copies: Determines how many copies of this component will be
created. Take a look at the formula: I told it to decide how
many shelves to draw by taking the overall height of Bookcase
(BookcasellLenZ), subtracting the thickness of a single
shelf (Bookcase!Shelf), and dividing by the shelf spacing
(Bookcase!Spacing).

The attribute Copies automatically rounds down to the nearest whole number,
which is why [ don’t have to worry about SketchUp trying to draw a fraction of
a shelf. When you're building your own smart-replication DCs, you sometimes
need to specify the number of shelves in another attribute. In that case, take a
look at the ROUND, FLOOR, and CEILING functions listed in the drop-down
menu at the top of the Component Attributes dialog box.

Just for good measure: Rotation and Animation

It might not be the most useful thing you can design Dynamic Components to
do, but it sure is satisfying. Making your models come to life is actually easier
than making them scale intelligently, which is good news all around.

Look at Figure 5-30: It’s a simple two-door cabinet that I made into a DC.
When I click one of the doors with the Interact tool, it swings open. When I
click it again, it swings shut. Couldn’t be simpler. Pay special attention to the
third image in Figure 5-30; it shows where I placed the Component Axes for
the cabinet door on the right. They’re where the hinge would be if there was
one. The door swings about (around) the Z (blue) axis.

Figure 5-31 shows the Component Attributes dialog box for Cabinet. I've
hidden the sections for all but the two doors, DoorR and DoorL. — they’re the
only ones that matter for this example.

Here’s some detail about the two visible attributes for each door:

v RotZ: Determines the angle that the component is currently rotated
around the Z (blue) axis. When your component isn’t rotated, this angle
is 0. Entering a value of 90 for this attribute rotates your component 90
degrees. Note that positive values rotate counterclockwise, and negative
ones (like -90) rotate clockwise.
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Figure 5-30:
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+* OnClick: Determines what happens when someone clicks Door with the
Interact tool. Here, the ANIMATE function tells Door to animate while it
changes the value of RotZ, which in turn causes the door to swing open
or closed. The two numbers after RotZ in the function are the values I
want it to plug into that attribute when I click with the Interact tool: 0
degrees, and then 130 degrees (or —130 degrees, for the door on the left
side). It returns to the beginning when it gets to the end of the list, so
clicking multiple times tells RotZ to alternate between 0 and 130 (or -130)
degrees forever.

You can choose between a couple of other animation functions; ANIMATE is
just the simplest to understand. The others let you control things like duration
and easing (speeding up and slowing down). Check out the list of functions in
Component Attributes and experiment.

You can find all of the Dynamic Components in this chapter on this book’s
companion Web site. You can also find videos, color images, and links to other
DC help resources. You should definitely dissect as many DCs as you can to
see how they work; taking a look at the Dynamic Components Training collec-
tion in your Components dialog box is a great place to start.
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Chapter 6
Going Beyond Buildings

In This Chapter
Extruding around circles and along paths with Follow Me
Rounding off corners
Mastering the Scale tool
Modeling tapered forms
Discovering the Sandbox tools
Creating terrain surfaces the easy way

Here’s something you already know: There’s more to life than model-

ing buildings. Even though SketchUp is really good at letting you make
models of built structures, you can use it to build just about anything you can
think of — all it takes is time, ingenuity, and the ability to take a step back
and break things down into their basic parts. SketchUp provides some fan-
tastic tools for creating forms that aren’t the least bit boxy, but they’re not

as obvious as Push/Pull and Rectangle, so most people never find them. This

o

chapter is devoted to helping you discover SketchUp’s “rounder” side.

In this chapter, | present tools, techniques, and other tips for creating forms
that are distinctly unbuilding-like — my hope is that you’ll use them to push
the limits of what you think SketchUp can do.

Extruding with Purpose: Follow Me

Follow Me is probably the best example of a powerful SketchUp tool with
kind of an underwhelming name. The problem that faced the software
designers when they were trying to figure out what to call their new baby was
this: It does what other 3D modeling programs dedicate two or three other
tools to doing. They chose an unconventional name because it’s a wholly
unconventional tool.

In the following sections, I talk about how to use Follow Me to create a

number of different types of shapes; examples of these are shown in
Figure 6-1 and are as follows:
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|
Figure 6-1:
Follow Me
lets you
create all
kinds of
different
shapes.
|

~ Bottles, spindles, and spheres: These are all examples of lathed forms.
You can create these by spinning a 2D profile (shape) around a central
axis to create a 3D model.

v Pipes, gutters, and moldings: If you look closely, all three of these
things are basically created by extruding a 2D face along a 3D path; the
result is a complex 3D form.

v+ Chamfers, fillets, and dados: Without explaining what all of these things
are (I get to that later in this chapter), know this: You can use Follow Me
to cut away profiles, too.

Using Follow Me

At its core, Follow Me lets you create forms that are extrusions. It’s a little
bit like Push/Pull, except that it doesn’t just work in one direction. You tell
Follow Me to follow a path, and it extrudes a face all along that path. This
means that you need three things to use Follow Me:

v A path: In SketchUp, you can use any edge, or series of edges, as a
path. All you have to do is make sure that they’re drawn before you use
Follow Me.

v A face: Just like with Push/Pull, Follow Me needs a face to extrude. You
can use any face in your model, but it needs to be created before you
start using Follow Me.

v Undo: Imagining what a 2D face will look like as a 3D shape isn’t easy — it
usually takes a couple of tries to get a Follow Me operation right. That’s
what Undo is for, after all.

Follow these steps to use Follow Me; Figure 6-2 shows a basic example of how
it works:

1. Draw a face to use as an extrusion profile.

In this example, I'm creating a pipe, so my extrusion profile is a circular
face.
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|
Figure 6-2:
Using

Follow Me
to create

a simple
extruded
shape.
|
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2. Draw an edge (or edges) to use as an extrusion path.

Although the edge (or edges) is touching the face in this case, it doesn’t
have to for Follow Me to work.

3. Select the complete extrusion path you want to use.

Check out the section on making selections in Chapter 2 for pointers on
using the Select tool to best advantage.

4. Activate the Follow Me tool by choosing Tools=>Follow Me.
5. Click the face you want to extrude.

Magic! Your face (extrusion profile) is extruded along the path you
chose in Step 3, creating a 3D form (in this case, a section of pipe).

If you want to use Follow Me all the way around the perimeter of a face, you
don’t need to spend time selecting all the individual edges. Just select the face
and then use Follow Me; the tool automatically runs all the way around any
face you have selected.

You can use Follow Me another way, too: Instead of preselecting a path (as
in Step 3 of the preceding list), you can click any face with Follow Me and
attempt to drag it along edges in your model. While this works on simple
things, I find that preselecting a path works a lot better — it’s really the only
option for using Follow Me in a predictable way.

Making lathed forms like
spheres and bottles

And nuclear power plant chimneys. A surprising number of things can be
modeled by using Follow Me to perform a lathe operation. A lathe is a tool
that carpenters (and machinists) use to spin a block of raw material while
they carve into it — that’s how baseball bats are made (the good ones,

anyway).

A simple example of a lathed object is a sphere. Here’s how you might make
one with Follow Me:
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|
Figure 6-3:
Using the
Rotate tool
to make a
rotated copy
of a circle.
|
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1. Draw a circle on the ground.

2. Rotate a copy of your circle up by 90 degrees, as shown in Figure 6-3.

Click and hold down
mouse button Drag here

If you’re wondering how to do this, follow these steps:
. Select the face of your circle with the Select tool.
. Choose Tools=>Rotate to activate the Rotate tool.

. Press Ctrl (Option on a Mac) to tell SketchUp you want to make a

copy.

. Click a green endpoint inference along the edge of your circle and

hold down your mouse button to drag. Don’t let go just yet.

. Still dragging, move your cursor over to the endpoint on the exact

opposite side of your circle; then release your mouse button. Now
your axis of rotation is a line right through the center of your circle.

. Click anywhere on the edge of your circle, and then move your

mouse over a little bit.

g. Type in 90 and press Enter.

You can read all about the Rotate tool in the sidebar “Wrapping your
head around the Rotate tool,” later in this chapter.

3. Make sure that one of your circles is selected.

4. With the Follow Me tool, click the circle that’s not selected (see
Figure 6-4).

Now you have a sphere. The Follow Me tool lathed your circular face
around the path you selected — the other circle.

If you really need a sphere, the easiest way to get one is in the Components
dialog box. The Shapes library that comes installed with SketchUp has a
selection of spheres (and cones and other things) you can choose from.

If you want to make your curved surfaces look smooth (hiding the edges
between them), check out the sidebar “Smoothing out those unsightly
edges,” later in this chapter.
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|
Figure 6-4:
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|
Figure 6-5:
A few
examples

of lathed
objects
created with
Follow Me.
|
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Under normal circumstances, you only have to model half a profile to use
Follow Me to make it three-dimensional. Figure 6-5 shows a few different
examples of 3D objects.

Creating extruded shapes like
qutters and handrails

A lot of the time, you’ll want to use Follow Me to create geometry (edges
and faces) that’s attached to another part of your model. An example of this
might be modeling a gutter that runs all the way around the roof of your
house. In this case, you're likely to already have the path along which you
want to extrude a profile (the edge of the roof).

When you’re using Follow Me to extrude a face along a path that consists
of edges that already exist as part of your model, there are two things you
should always do:

1 Before using Follow Me, make the rest of your model a separate
group. Take my word for it — Follow Me can sometimes mess things up,
so you want to be able to keep the geometry it creates separate, just in
case.
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1 Make a copy of your extrusion path outside your group. There’s a con-
sequence to working with Follow Me on top of a group: The edge (or
edges) you want to use as an extrusion path will no longer be available,
because you can’t use Follow Me with a path that’s in a separate group
or component.

What to do? You need to make a copy of the path outside the group, and
then use the copy to do the Follow Me operation. Here’s the best way to
make a copy of the path:

1. With the Select tool, double-click your group to edit it.
2. Select the path you want to use for Follow Me.
3. Choose Edit=>Copy.

4. Exit (stop editing) your group by clicking somewhere else in your
modeling window.

5. Choose Edit>Paste in Place. Now you have a copy of the path you
want to use, and it’s outside your group.

Take a look at Chapter 17. You'll find a Ruby script (don’t worry — I explain
what that means) called “Weld” that’s super-useful for creating extrusion
paths for Follow Me.

When you’re using an existing edge (or series of edges) as an extrusion path,
the hard part is getting your profile in the right place. You have a choice

of two ways to proceed; which one you use depends on what you need to
model:

v Draw the profile in place. Do this only if the extrusion path is parallel to
one of the colored drawing axes.

v Draw the profile on the ground and then move it into position. If your
extrusion path doesn’t start out parallel to a colored drawing axis, you
should probably draw your profile somewhere else and move it into
place later.

Drawing your profile in place

Consider that I have a model of a house. [ want to use Follow Me to add a
gutter that goes all the way around the perimeter of the roof. [ decide to draw
the profile in place (right on the roof itself) because the edges of the roof

are drawn parallel to the colored drawing axes. This means that I'll have an
easier time using the Line tool to draw in midair.

The trick to drawing an extrusion profile that isn’t on the ground is to start
by drawing a rectangular face. You then draw the profile on the face and
erase the rest of the rectangle. Figure 6-6 shows how you would draw the pro-
file of a gutter directly on the corner of a roof; the steps that follow explain
the same things in words:
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Why your computer is so slow

When you use Follow Me with an extrusion
profile that's a circle or an arc, you're creating
a piece of 3D geometry that's very big. By big,
| mean that it has lots of faces, and faces are
what make your computer slow down. Without
going into detail about how SketchUp works
(I don’t really know that anyway), keep this in
mind: The more faces you have in your model,
the worse your computer’s performance will be.
At a certain point, you'll stop being able to orbit,
your scenes (which | talk about in Chapter 10)
will stutter, and you'll be tempted to do some-
thing terrible to someone you don’t know.

The first pipe in the figure that follows has been
extruded using Follow Me. It was made with a
24-sided circle as an extrusion profile, and it
has 338 faces. Hidden Geometry is turned on (in
the View menu) so that you can see how many
faces you have.

The second pipe uses a 10-sided circle as an
extrusion profile. As a result, it only has 116
faces. What an improvement!

338 faces

116 faces 52 faces

The third pipe also uses a 10-sided circle as
an extrusion profile, but the arc in its extrusion
path is made up of only 4 segments, instead
of the usual 12. It has a total of 52 faces. Even
better.

The second image in the figure shows all three
pipes with Hidden Geometry turned off. Is the
difference in detail worth the exponential
increase in the number of faces? Most of the
time, the answer is no.

To change the number of sides in a circle or an
arc, just before or just after you create it, follow
these steps:

1. Type in the number of sides you'd like to
have.

2. Type an s to tell SketchUp that you mean
“sides.”

3. Press Enter.

171

1. Zoom in on what you’re doing.

[ can’t tell you how many people try to work without filling their
modeling windows with the subject at hand. Not doing so is

like trying to do a crossword puzzle while looking the wrong
way through a pair of binoculars. Get close — SketchUp models
don’t bite!

www.it-ebooks.info


http://www.it-ebooks.info/

172 Parti: Modeling in SketchUp

This part of roof Watch the color inferences

Draw a rectangle Draw your profile on the rectangle

Erase the rest Use Follow Me

|
Figure 6-6:
Drawing an
extrusion
profile in
place by
starting with |
arectangle.
|

2. Using the Line tool, draw a rectangle whose face is perpendicular to
the edge you want to use for Follow Me.

This involves paying careful attention to SketchUp’s inference engine;
watch the colors to make sure that you're drawing in the right direction.
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3. Use the Line tool (and SketchUp’s other drawing tools) to draw your
profile directly on the rectangle you just drew.

The important thing here is to make sure that your extrusion profile is a
single face; if it’s not, Follow Me won’t work the way you want it to.

4. Erase the rest of your rectangle, leaving only the profile.

Drawing your profile somewhere else

The awful thing about handrails is that they’re almost always at funny angles,
not parallel to a colored axis. When it’s not convenient to draw your extrusion

profile in place, it’s best to draw it on the ground and move it into position

afterwards.

Wrapping your head around the Rotate tool

In the last version of SketchUp, the software’s
designers introduced a feature that pretty much
everybody realizes is great: You can establish
your axis of rotation (the invisible line around
which you're rotating) while you're using the
Rotate tool. This makes it about a million times
easier to rotate things around, and those of us
who use SketchUp a lot danced little jigs (albeit
awkwardly) when we heard the news.

By default, the Rotate tool “sticks” itself to
whatever plane you happen to be hovering
over —that’s why it changes color as you move
its big, round cursor all over your screen. When
it's blue, its axis of rotation is the blue axis; the
same goes for red and green. When it's black,
its axis of rotation doesn't line up with any of the
colored drawing axes.

If you want to show SketchUp the axis of
rotation you want to use while you're using the
Rotate tool, you can. In this case, using Rotate
goes from being a three-step operation to a
five-step one (check out the following figure for
a visual explanation):

1. Click once to establish your center of
rotation, but don't let go— keep your finger
on your mouse button.

2. Drag your cursor around (still holding the
mouse button down) until your axis of rota-
tion is where you want it. As you drag, you'll
notice your Rotate cursor changing orienta-
tion; the line from the center of the cursor to
your mouse is the axis of rotation.

3. Release your mouse button to set your axis
of rotation.

4. Click (but don’t drag) the point at which you
want to “pick up” whatever you're rotating.

5. Click again to drop the thing you're rotating
where you want it.

Whew! It takes practice, but it's worth it. The
efficiency you gain by being able to rotate
things in free space is huge. Two more things
about Rotate, while I'm on the subject:

v~ Type in a rotate angle during or after you
rotate something. Check out the section

(continued)
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(continued)

about modeling with accuracy in Chapter 1+~ Press Ctrl (Option on a Mac) to make a

2 for more information on using the VCB copy. This works just like it does in the
(Value Control Box) to be precise while Move tool, which you can also read about
you're modeling. in Chapter 2.

Click Drag to locate axis of rotation

<

2

Release mouse to define axis Click to rotate

Click to finish rotating
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Here’s the trick: Draw a tail — a short edge — perpendicular to your extru-
sion profile. You can use this tail to help line up your profile with the edge
you want to use as an extrusion path for Follow Me. The following steps, and
Figure 6-7, describe how you would draw and position a profile for a handrail:

Extrusion path Draw a tail

Box indicates Extrusion Move handrail profile
a group path  to bottom of extrusion path Rotate into position

|
Figure 6-7:
Drawa
short tail |

on your
extrusion |
profile to
help you
position it
with the
Move and
Rotate tools.
I | e

1. Draw your extrusion profile flat on the ground.
2. Draw a short edge perpendicular to the face you just drew.

This tail should come from the point where you want your profile to
attach to the extrusion path.
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3. Make your profile and its tail into a group.

This makes it easier to move and rotate around all at once. See Chapter
5 for information on creating and using groups, if you need it.

4. Using the Move tool, place your profile at the end of the extrusion
path.

To make sure that you position it accurately, pick it up by clicking the
point where the tail meets the face, and drop it by clicking the end of the
extrusion path.

5. With the Rotate tool, rotate your profile into position.

Here’s where you need to use a bit of skill. See the nearby sidebar,
“Wrapping your head around the Rotate tool,” for guidance. The Rotate
tool is easy to use when you get the hang of it.

6. Right-click the group you made in Step 3 and choose Explode; delete
your tail.

Subtracting from a model with Follow Me

What if you want to model a bar of soap? Or a sofa cushion? Or anything that
doesn’t have a sharp edge? The best way to round off edges in SketchUp is to
use Follow Me. In addition to using it to add to your model, you can also sub-
tract from your model.

Here’s how it works: If you draw an extrusion profile on the end face of a long-
ish form, you can use Follow Me to remove a strip of material along whatever
path you specify. Figure 6-8 demonstrates the concept on the top of a box.

If the extrusion path you want to use for a Follow Me operation consists of the
entire perimeter of a face (as is the case in Figure 6-8), you can save time by
just selecting the face instead of all the edges that define it.

But what if you want to create a corner that’s rounded in both directions,

as so many corners are? That one’s a little trickier to do in SketchUp, but
because it’s such a common problem, I thought I'd devote a few hundred
words to explaining how to do it. The basic technique involves using Follow
Me on a corner you've already rounded with the Push/Pull tool. After you
have a corner that'’s filleted with an arc of the correct radius, you can use
copies (or component instances, if you're clever) of that corner several
times, wherever you need them. It’s not what I'd call an elegant solution, but
it’s possible, and it works when you need it to.
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Draw an arc Select a path

Click the face with Follow Me

fﬂfﬂf\

|
Figure 6-8:
Creating a
filleted

edge with
Follow Me.
|

Figure 6-9 gives a step-by-step, visual account of the process, while [ explain
it in words, as follows:

1. Draw a box.

It doesn’t really matter how big, as long as it’s big enough for the fillet
you want to apply.

2. With the Arc tool, draw an arc on the corner of the box.

When you’re drawing an arc on a corner, keep an eye out for the
inferences that help you draw properly:

a. After clicking to place one endpoint of your arc, as you cut across
the corner, the point at which your line turns magenta is where
your endpoints are equidistant (the same distance) from the corner
across which you’re cutting.

b. After clicking to place your second endpoint, you see a point at
which the arc you're drawing turns magenta — this means your
arc is tangent to (continuous with) both edges it’s connected to.
You want this to be the case, so you should click when you see
magenta.
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Draw an arc Push/Pull away the corner

Draw identical arc Select the whole path

Click with Follow Me

|
Figure 6-9:
Making
acorner
that's
filleted in
both
directions.
|

WMBER
é_‘,‘“‘" I strongly recommend reducing the number of sides on your arc before
you start filleting away. See the sidebar “Why your computer is so slow,’

earlier in this chapter, to find out why.

)

3. Push/pull the new face down to round off the corner.
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4. Draw another, identical arc on one of the corners directly adjacent to
the corner you just rounded.

This is where you'll have to refer to Figure 6-14. Pictures are better than
words when it comes to explaining things like which corners are adja-
cent to which.

5. Select the edges shown in Figure 6-14.
6. Activate the Follow Me tool.

7. Click the arc corner face to extrude it along the path you selected in
Step 4.

8. Hide or smooth out any edges that need hiding or smoothing.

For information about hiding edges, see the sidebar “Making two halves
look like one whole,” earlier in this chapter. Check out the “Smoothing
out those unsightly edges” sidebar for the whole scoop on how to
smooth edges.

After you have a fully rounded corner, you can use a bunch of them to
make anything you want; it just takes a little planning. Figure 6-10 shows
a simple bar of soap I created out of eight rounded corners, copied and
flipped accordingly. The text (in case you're wondering) was created with
SketchUp’s 3D Text tool, which you can find on the Tools menu.

Copy and flip Copy and flip

Figure 6-10:
Assembling
a bunch of
rounded
corners
to make
objects is :
relatively N\
easy.
|

Copy and flip Hide and smooth edges; then add text

www.it-ebooks.info


http://www.it-ebooks.info/

’ 80 Part Il: Modeling in SketchUp

Smoothing out those unsightly edges

If you're wondering how to get rid of all the ugly
lines you end up with when you use Follow Me,
the answer is pretty simple: You can smooth
edges, justlike you can hide them. (See the side-
bar “Making two halves look like one whole,”
earlier in this book, for more information about
hiding edges.) The difference between hiding
and smoothing is illustrated by the images of
the cylinders in the figure that follows:

v+ Whenyou hide an edge between two faces,
SketchUp still treats those faces as though
your edge is still there — it just doesn't
show the edge. Materials you've applied to
each face stay separate, and each face is
lit separately by SketchUp's sun. The latter
fact is the reason why simply hiding the
edges between faces that are supposed
to represent a smooth curve doesn’t make
things look smooth — you still end up with
a faceted look.

v When you smooth an edge between two
faces, you're telling SketchUp to treat
them as a single face — with a single
material and smooth-looking shading. The

difference is pretty huge, as you can see in
the second cylinder.

You can smooth edges in two different ways:

v~ Use the Eraser. To smooth edges with the
Eraser tool, hold down Ctrl (Option on the
Mac) while you click or drag over the edges
you want to smooth.

v~ Use the Soften Edges dialog box. Located
on the Window menu, this dialog box lets
you smooth a bunch of selected edges all
atonce, according to what angle their adja-
cent faces are at. It's a little complicated at
first, but here’'s what you need to know to
get started: Select the edges you want to
smooth, and then move the slider to the right
until things look the way you want them to.

To unsmooth edges, follow these steps:

1. Turn on Hidden Geometry to make edges
visible.

2. Select the edges you want to unsmooth.

3. In the Soften Edges dialog box, move the
slider all the way to the left.

Visible edges Hidden edges Smoothed edges

Modeling with the Scale tool

It’s not obvious, but real heroes rarely are. The Scale tool is, in my opinion,
the single most misunderstood member of SketchUp’s mercifully limited
toolkit. New modelers assume that Scale is for resizing things in your model.
That’s technically true, but most folks only use it to resize whole objects; the
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real power of Scale happens when you use it on parts of objects to change
their shape. Take a look at Figure 6-11 to see what [ mean.

Figure 6-11:
Using the
Scale tool

on parts

of objects
changes
their shape.
|
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Getting the hang of Scale

The basic principle of this technique is pretty simple: You select the geom-
etry (edges and faces) in your model that you want to resize, activate the
Scale tool, and go to town.

Here’s a list of steps, just so it’s crystal clear (Figure 6-12 tells the story in
pictures):

Figure 6-12:
The Scale
toolis a
cinch

to use.
|

1. Select the part of your model that you want to scale.

Use the Select tool to do this; check out the latter part of Chapter 2 if
you need a refresher.

2. Activate the Scale tool by choosing Tools=>Scale from the menu bar.

You can also make Scale active by clicking its button on the toolbar, or
by pressing S on your keyboard. After you activate Scale, the geometry
you selected in Step 1 should be enclosed in a box of little green cubes
called grips.

3. Click a grip and then move your mouse to start scaling your selected
geometry.

Take a look at the next part of this section for the lowdown on all the dif-
ferent grips.

4. When you’re finished scaling, click again to stop.

While I'm on the subject of Scale, here are a few more things you should
know:

v Use different grips to scale different ways. Which grip (the little green
boxes that appear when you activate the Scale tool) you use determines
how your geometry scales:

e Corner grips scale proportionally — nothing gets distorted when
you use them.

¢ Edge and side grips distort your geometry as you scale — use
them to squeeze what you’re scaling.
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+* Hold down Shift to scale proportionally. This happens automatically if
you're using one of the corner grips, but not if you're using any others. If
you don’t want what you’re scaling to be distorted, hold down Shift.

+* Hold down Control (Option on a Mac) to scale about the center of your
selection. I find myself doing this more often than not.

1 Type in a scaling factor to scale accurately. To scale by 50 percent,
type 0.5. Typing 3.57 scales your geometry by 357 percent, and typing
1.0 doesn’t scale it at all. Take a look at Chapter 2 to read more about
using numbers while you work.

v Which grips appear depend on what you're scaling. Have a look at
Figure 6-13 to see what I'm talking about.

This face is perpendicular
E— This face is off-axis to blue axis

Figure 6-13: e o e

Brioe G -4
depend on . )\

what you're . R

trying to e e
scale.
|

e Most of the time, you’ll see a scaling box enclosed by 26 green
grips.

¢ If you're scaling flat, coplanar geometry (faces and edges that all lie
on the same plane), AND that plane is perfectly aligned with one of
the major planes in your model, then you get a rectangle consisting
of 8 grips instead of a box comprised of 26.

éc.,\kETCHoA e If what you’re scaling is a Dynamic Component, you may see any-
S 6 where from 0 to all 26 grips; it depends on how the builder set up
z the component. Take a look at Chapter 5 for more information
y about Dynamic Components.
<P + You can’t make a copy while you’re scaling. Both the Move and Rotate

tools let you make copies by holding down a button on your keyboard
while you're using them, but Scale doesn’t work this way, unfortunately.
If you need to make a scaled copy, try this instead:

1. Select the geometry that you want to scale and copy.

2. Make it into a group. (See Chapter 5 for more information on
making groups.)

3. Choose Edit=>Copy from the menu bar.
4. Choose Edit=>Paste in Place from the menu bar.

5. Scale the copied group as you would anything else.
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Scaling profiles to make organic forms

Here’s where it gets really interesting. [ need to thank tiber-SketchUpper
Justin Chin (who goes by the handle monsterzero online) for demonstrating
the power of this technique. It’s great because it’s easy to understand and
powerful enough to be applied all over the place; that’s why I'm so excited to
show it to you in this book.

So what is it? This method involves using the Scale tool in combination with
a series of 2D profiles to create curvy, lumpy, distinctly un-boxy 3D shapes.
An awful lot of the stuff in the universe fits squarely in this category: me, you,
slugs, intergalactic alien fighter vessels, bananas — just about everything
that wasn’t made by a machine can be modeled using the “scaled profiles”
method of 3D modeling.

Combining Scale and Push/Pull

The simplest way to use this method is in association with Push/Pull. Here’s a
very simple example of how it works (check out Figure 6-14 for an illustrated
view):

1. Create a 2D shape.

This shape might be something simple (like a circle), or something more
complex; it all depends on what you're trying to model. It might also be
a “half-shape” if what you're trying to make exhibits bilateral symme-
try. Take a look at the last section in Chapter 5 for more information on
using components to build symmetrical models.

2. Push/pull your 2D shape into a 3D form.

3. Scale the new face you created so it’s slightly bigger (or slightly
smaller) than the original 2D shape from Step 1.

Refer to the previous section in this chapter for more specifics about
using the Scale tool. Pay special attention to the points about using mod-
ifier keys (keyboard buttons) to scale proportionally or about the center
of what you’re working on.

4. Push/pull the face you scaled in the previous step.
Try to make this extrusion about the same as the one you made in Step 2.

Remember that you can usually double-click a face with the Push/Pull
tool to repeat the last Push/Pull operation you did.

5. Repeat Steps 3 and 4 until you’re done.

You can add skillful use of the Rotate tool into the mix if you like; doing
so allows you to curve and bend your form as you shape it.
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Figure 6-14:
Using

Scale and
Push/Pull
together

is a simple
way to make
organic
forms.
|
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Figure 6-15:
You can go
back and
scale any
profile at
any time
while you're
working.
|

Keep the following tidbits in mind as you explore this technique:

1 Watch your polygon count. Polygons are faces, basically — the more
you have, the “heavier” your model becomes, and the worse it performs
on your computer. Try to minimize the number of faces you’re working
with by reducing the number of edges in your original 2D shape. Have a
look at the sidebar “Why your computer is so slow,” earlier in this
chapter, for the whole scoop.

v Don’t be afraid to go back and tweak. The beauty of this method is its
flexibility. While you're working, you can select any of the 2D profiles
(shapes) in your model and use the Scale tool to tweak them. Just select
the loop of edges along the perimeter of the profile you want to scale
and take it from there. Check out Figure 6-15 to see what I'm referring to.

Combining Scale and Follow Me

Another way to create extruded forms is to use Follow Me. (See the first part
of this chapter if you need a refresher.) This technique is ideally suited to
making long, curvy, tapered things like tentacles and antlers. It’s a little time
consuming, but it works like a charm.

Modeling a simplified bull’s horn is a good, straightforward illustration of
how the Follow Me variation of this method works. Here’s how I'd go about it;
take a look at Figure 6-16 to see the story in pictures:

1. Draw a circle.

This is the extrusion profile for Follow Me. Strongly consider reducing
the number of sides in your circle from the standard 24 to something
more like 10 or 12. See the sidebar “Why your computer is so slow” (ear-
lier in this chapter) to find out how and why you should do this.

2. Draw a 10-sided arc that starts perpendicular the center of the circle
you drew in Step 1.

Type 10s and press Enter right after you click to finish drawing your arc.
This tells SketchUp to make sure your arc has 10 sides (instead of the
default 12). Why 10 sides? It makes the math easier a few steps from now.
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Figure 6-16:
Use Scale
with Follow
Me to
create long,
tapered
forms (like
this bull’s
horn).
|

\§ . . .
P The easiest way to create a halfway-accurate arc in 3D space is to start by

drawing a rectangle. Once you’re sure this rectangle is properly situated,
use the Arc tool to draw on top of it, then delete everything but the arc.
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. Select the arc you just drew.

This is the extrusion path for Follow Me.

. Activate the Follow Me tool by choosing Tools=>Follow Me from the

menu bar.

. Click the circle you drew in Step 1 to extrude it along the path you

drew in Step 2.

. Choose Viewr>Hidden Geometry from the menu bar.

Showing the hidden geometry in your model lets you select the edges
that were automatically smoothed (made hidden) when you used Follow
Me in Step 5.

. Scale the face at the end of your new extrusion by a factor of (.1.

See “Getting the hang of Scale,” earlier in this chapter, for instructions
on how to do this. Use any of the four corner grips on the scaling box,
and don’t forget to hold down Control (Option on a Mac) while you're
scaling — this forces SketchUp to scale about the center of the face
you're resizing.

. Select the edges that define the next-to-last profile in your extruded

form.

Depending on the angle of your arc, making this selection can get tricky.
Here are some considerations that might help:

e See Chapter 2 for tips on making selections.

e Choose View=>Face Stylem>X-ray from the menu bar to make it
easier to see what you've selected.

Hold down Control (Option on a Mac) while you're orbiting to turn
off SketchUp’s “blue is up/down gravity bias.” While orbiting this
way, try drawing lots of tight, little circles with your mouse to get
your view to tilt in the direction your want. This is by no means
simple stuff, but getting the hang of temporarily disabling the
Orbit tool’s tendency to keep the blue axis straight up and down
is a very nifty way to work. Doing so makes it infinitely easier to
get just the right angle for making a window selection. This in turn
makes selecting the edges that define profiles a whole lot easier,
and that’s what becoming a Zen master of the Orbit tool is all
about.

. Scale the edges you selected in the previous step by a factor of 0.2.

Starting to see what’s happening?

Repeat Steps 8 and 9 for each of the remaining profiles in your form,
increasing the scaling factor by 0.1 each time.

Of course, you can absolutely choose to sculpt your form however you
like, but this method (counting up by tenths) yields a smooth taper.
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Have a look at the Santa and reindeer project in the color insert (in the center
of this book) to get an idea of the kind of fancy, not-a-box models you can
build once you master the Scale tool. It’s not beginner-level material, but it’s
worth the time when you’re ready for it.

Digging Around in the Sandbox

Continuing in the grand tradition of building extremely powerful tools and
then hiding them away so you’ll never find them, the people at SketchUp
introduced the Sandbox in version 5 of the software. It’s not new, but owing
to its less-than-obvious location, most SketchUp users have never used it. So
what’s the Sandbox for? Here are the facts:

v The Sandbox is a collection of tools. You're supposed to use them to
model things like terrain — the stuff your buildings sit on (or in, if what
you’re making is underground). That said, like all of SketchUp’s tools,
they’re incredibly flexible. You can use them to model anything you want.

v+ The Sandbox is in both free and Pro: Despite what many people think,
the Sandbox tools aren’t just for Pro users; people who use the free ver-
sion of SketchUp can use them, too. They’re just hidden, which brings
me to my next point.

v The Sandbox is hidden. The reasons for this are complicated, but the
tools in the Sandbox are a little bit special; they’re extensions, which
means that you have to find them and turn them on before you can start
using them. If you’re using SketchUp Pro 7, you can skip the first two
steps in the following list — they’re already turned on.

Follow these steps to switch on the Sandbox tools:

1. Choose Window=>Preferences from the menu bar to open the
Preferences dialog box. (Choose SketchUp=>Preferences if you're
on a Mac.)

2. In the Extensions panel, make sure the Sandbox Tools check box is
selected.

3. Close the Preferences dialog box.

4. Choose View=>Toolbars=>Sandbox from the menu bar to show the
Sandbox toolbar.

Taking inventory of the Sandbox tools

Before you dive into using them, I think it’s helpful to know what each of the
tools in the Sandbox actually does. The following sections provide a rundown
on what you’ll find.
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3

From Contours

You know the squiggly lines on topographical maps that show you where the
hills and valleys are? They’re called contour lines (or contours) because they
represent the contours of the terrain; every point on a single line is the same
height above sea level as every other point on that line. Where the lines are
close together, the ground between them is steep. Where the lines are far
apart, the slope is less steep. Cartographers, surveyors, engineers, and archi-
tects use contour lines to represent 3D terrain in flat formats like maps and
site drawings.

Sometimes, you’ll have contour lines for a building site that you want to
model in 3D. You can use the From Contours tool in the Sandbox to automati-
cally generate a three-dimensional surface from a set of contour lines. Have a
look at Figure 6-17 to see what I'm talking about.

Here are some things to keep in mind about the From Contours tool:

v It’s a two-step tool. Using From Contours is simple once you get the
hang of it:

1. Select all of the Contour lines you want to use to create a surface.

2. Choose Draw=>Sandbox=>From Contours from the menu bar (or click
the From Contours tool button, if the Sandbox toolbar is visible).

If you can’t see the Sandbox tools in your menus, you haven’t turned them
on yet. See the previous section in this book to rectify the situation.

+* Your contour lines need to be lifted up. The From Contours tool
creates a surface from contour lines that are already positioned at their
proper heights in 3D space. Most of the time you’ll be working with
contours that were part of a 2D drawing, and that means you’ll probably
have to lift them up yourself using the Move tool — one at a time. It’s
tedious but necessary. Just oil up the Select tool, put on some music,
and get to work. For a refresher on selecting things, take a look at the
last part of Chapter 2.

+* You'll end up with a group. When you use From Contours, SketchUp
automatically makes your new surface (the one you generated from your
contour lines) into a group. It leaves the original lines themselves com-
pletely alone; you can move them away, hide them, or delete them if you
want. | recommend making another group out of them, putting them on
a separate layer (see Chapter 7 for more on this) and hiding that layer
until you need it again.

To edit the faces and edges inside a group, double-click it with the Select
tool to go inside it. Refer to Chapter 5 for all the details on groups and
components.
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Figure 6-17:
Use the
From
Contours
tool to turn

a set of con-
tour lines
into a 3D
surface.
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Separate your lines from your surface
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v To edit your new surface, turn on Hidden Geometry. The flowing,
organic surface you just created is actually just a bunch of little tri-
angles. The From Contours tool smoothes the edges that define them,
but they're there. To see them, choose Viewr>Hidden Geometry from the
menu bar.

v Try to keep it reasonable. The From Contours tool is super useful, but
it has its limits. The trouble is that it’s too easy to use it to create enor-
mous amounts of geometry (faces and edges) that can really bog down
your system. If it’s taking forever for your contours to turn into a sur-
face, or if that surface is so big that your computer turns blue and curls
up into a fetal position (so to speak), you need to go back a few steps
and do one (or perhaps all) of the following:

e Work on a smaller area. As nice as it would be to have the whole
neighborhood in your SketchUp model, you might have to narrow
your scope. Only creating what you need is good modeling policy.

¢ Only use every other contour line. Doing this effectively halves
the amount of geometry in your resulting surface.

¢ Dumb down the contour lines themselves. This is a little bit
hard to explain, but here goes: The From Contours tool works by
connecting adjacent contour lines together with edges that form
triangles. How many triangles it creates depends on how many
individual edge segments are in each contour line; Figure 6-18
provides an illustration. Unless you created the contour lines to
begin with — there’s a good chance you imported them as part of
a CAD drawing — you have no control over how detailed they are.
Redrawing each contour line is a major bummer, but luckily, you
can download a great Ruby script called Simplify Contours that
makes the process much simpler. Take a look at Chapter 16 for
more information on using Ruby scripts.

+* You don’t have to start with existing contour lines. In fact, drawing
your own edges and using From Contours to generate a surface from
them is one of the most powerful ways to create organic, non-boxy
forms in SketchUp. Take a look at the next part of this chapter to see
what I mean.

v Get ready to do some cleanup. The surfaces that From Contours cre-
ates usually need to be cleaned up to some extent. Use the Eraser to
delete extra geometry (you'll find lots along the top and bottom edges of
your surface), and the Flip Edge tool to correct the orientation of some
of your triangular faces. Keep reading to find out more about this.
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Figure 6-18:
How many
triangles
get created
depends on
the number
of edge
segments in
the contour
lines you
start with.
|

Low-detail lines yield fewer triangular faces

Flip Edge

Flip Edge is a simple beast, but it’s indispensable if you're working with the
From Contours tool. Basically, you use it to clean up the surfaces that From
Contours creates. When you turn contour lines into a surface, you get lots
and lots of triangular faces. Sometimes, the From Contours tool decides to
draw an edge between the wrong two line segments, creating two triangular
faces that form a “flat spot” in your surface. Figure 6-19 shows what I'm talk-
ing about.

You get rid of these flat spots manually by flipping the edges that create
them. Doing so changes the resulting triangular faces, usually making them
end up side-by-side (instead of one-above-the-other).

To use the Flip Edge tool (Tools=>Sandbox=Flip Edge), just click the edge you
want to flip. If you're not sure about an edge, go ahead and flip it, then see if
things look better. If they don’t, you can always undo or flip it back.

From Scratch

You use the From Scratch tool to create a big, flat rectangle that represents
a chunk of terrain. Since it’s already divided into triangular faces, it’s easy to
use the Smoove tool (which I talk about next in this chapter) to shape it into
hills, valleys, berms, sand traps, and whatever else you have in mind.
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Figure 6-19:
Use the Flip
Edge tool to
correct mis-
takes made
by the From
Contours
tool.
|

’ Flip incorrect edges

Here’s the thing, though: It’s a very rare occasion that you have carte blanche
with a piece of land. Unless you're designing something like a golf course in
the middle of a dry lake bed, or terraforming a new planet for colonization,
you probably have pre-existing terrain conditions to contend with. And if
that’s the case, you're probably better starting off with a set of contour lines
that describe those conditions — I talk all about the From Contours tool ear-
lier in this chapter.

So although the From Scratch Tool works great, I doubt you’ll end up needing
to use it much. All the same, here’s how to do so, just in case.

Follow these steps to create a new terrain surface with the From Scratch tool,
and take a look at Figure 6-20 while you're at it:

1. Choose Draw=>Sandbox=>From Scratch from the menu bar to activate
the From Scratch tool.

2. Type in a grid spacing amount and press Enter.
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Figure 6-20:
Use the
From
Scratch tool
to create big
swatches of
flat terrain.
Ah, the pos-
sibilities. . ..
|

The default grid spacing amount is 10 feet, which means the tool draws
a rectangle made up of squares that are 10 feet across. The grid spacing
you choose depends on how big an area you’re planning to model, and
on how detailed you plan to make the terrain for that model.

If I were modeling a single-family house on a reasonably sized lot, I'd
probably use a grid spacing of 2 feet — that would provide enough detail
for elements like walkways and small berms without creating too much
geometry for my computer to handle. If I were laying out an 18-hole golf
course, on the other hand, I'd choose a grid spacing closer to 50 feet,
then add detail to certain areas later on.
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3. Click to position one corner of your new terrain surface where you
want it.

4. Click to determine the width of the surface you’re drawing.
5. Click to establish the length of your new terrain surface.

When you’re done, the great big rectangle you've created will automati-
cally be a group. Double-click with the Select tool to edit it, and good
luck. You'll probably decide to use the Smoove tool next; read on to find
out how.

Smoove

It’s a tool for moving smoothly — get it? Smooth + Move = Smoove. I'll wait
while you compose yourself.

Smoove is actually one of the coolest tools in SketchUp. It lets you shape ter-
rain (or any horizontal surface that’s made up of smaller, triangular faces)
by pushing and pulling (sort of) bumps and depressions of any size. It’s fun
to use, and it yields results that you’d be hard-pressed to produce with any
other tool in SketchUp. Figure 6-21 shows what Smoove can do.

Follow these steps to shape a surface with Smoove:

1. Double-click the group containing your terrain to begin editing it.
If your terrain isn’t part of a group, then forget I said that.

2. Choose Tools=>Sandbox=>Smoove from the menu bar to activate the
Smoove tool.

3. Type in a radius and press Enter.

Smoove creates lumps and bumps and dimples that are circular. The
radius you enter here determines how big those lumps and bumps and
dimples should be.

4. Click somewhere on your terrain surface to start smooving.

5. Move your mouse up or down (to create a bump or a depression), then
click again to stop smooving.

Fun, huh? Here are some more things to keep in mind when you’re using
Smoove:

v Use the From Scratch tool beforehand. You don’t have to, but creating a
surface with the From Scratch tool (described earlier in this chapter) is by
far the easiest way to end up with terrain which you can smoove easily.

1 Try smooving to edit other terrain surfaces. You can also use Smoove
after you create a terrain surface with the From Contours tool. In fact,
Smoove works on any geometry — it just works best on surfaces made
up of triangular faces.
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Figure 6-21:
Smoove
creates

shapes that

are unlike
anything
else you can
make with
SketchUp.
|

1 Double-click to repeat your previous Smoove. As with Push/Pull,
double-clicking tells SketchUp to carry out the same operation as you
did the last time you used the tool.
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1 Pre-select to smoove shapes other than circles. Any faces and edges
you select before you use the Smoove tool will move up (or down) by
a constant amount. This means you can use Smoove to create things
like ridges and ditches by selecting the right geometry beforehand.
Figure 6-22 provides a much-needed picture of what I mean.

Figure 6-22:
Pre-select
faces and

edgesto
smoove
shapes
other than
circles.
|

Stamp

Eventually, you might need to plunk a building (or some other structure)
down on the terrain you've lovingly crafted. The Stamp tool provides an easy
way to — you guessed it — stamp a building footprint into a terrain surface,
creating a flat “pad” for something to sit on. It also provides a way to create
a gently sloping offset around the perimeter of your stamped form. This cre-
ates a smoother transition between the new, flat pad and the existing terrain.

Follow these steps to use the Stamp tool; check out Figure 6-23 to see the cor-
responding pictures:
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|
Figure 6-23:
Use the
Stamp tool
to create
anice, flat ~__
spot for your |\
building.
|
1. Move whatever it is you want to stamp into position above your ter-
rain surface.
It shouldn’t be touching; it should be floating in space directly above your
terrain. Also, it helps to make a group before you start moving anything;
take a look at Chapter 5 to find out all about groups and components.
<P If you're having trouble moving it into position accurately, I suggest moving

it to the correct height first, then switching to a top, no-perspective view
to finish the job. Look in the Camera menu for both of these commands.

2. Choose Tools~>Sandbox>Stamp from the menu bar to activate the
Stamp tool.
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3. Click the floating object to tell SketchUp what you want to use as the
stamp.

4. Type in an offset distance, then press Enter.

The offset distance is the amount of space around the perimeter of
whatever you’re stamping that SketchUp uses to smooth the transition
between the flat spot it’s creating and the existing terrain. The offset
amount you choose depends entirely on what you're stamping. Go nuts,
and thank your lucky stars for Undo.

5. Move your cursor over your terrain surface and click again.
6. Move (but don’t drag) your mouse up and down to position the flat
pad in space, then click again to finish the operation.
Here are a couple of things you should know about using Stamp:
v SketchUp uses the bottommost face in your stamp object as the tem-
plate for the flat pad it creates in your terrain.

v Go back a few pages and read about the Flip Edge tool; Stamp creates
triangular faces that sometimes need cleaning up.

Drape

The Drape tool works a little like a cookie cutter; you use it to transfer edges
from an object down onto another surface, which is directly beneath it.

Perhaps you have a gently-sloping terrain, and you want to draw a meander-
ing path on it. The path only has to follow the contours of the terrain, but you
still want to paint it with a different material — so it needs to be a separate
face. In this case, you’d draw the path on a separate face and use the Drape
tool to transfer it to your terrain surface.

Taking the above example, follow these steps to use the Drape tool to draw a
path on a non-flat terrain surface (Figure 6-24 illustrates the steps):

1. Use the Line tool (see the last part of Chapter 2) to draw a flat face
somewhere directly above your terrain surface.

If you can, it’s not a bad idea to make your flat face exactly the same size
as your terrain. Just make sure it’s big enough for whatever you're plan-
ning to draw next (in this example, a path).

2. Paint the face you just created with a translucent material.

I find that a light gray works well; there’s a good one in the Translucent
library, inside the Materials dialog box.
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Figure 6-24:
Use Drape
to transfer
edges onto

your terrain

surface.
|
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3. Use the Line tool to carry up any important points on your terrain
surface.

In this case, I want to make sure my path begins precisely at the door of
the building, so I draw vertical lines from the sides of the door to the flat
face directly above. That way, I'll have something to snap to in Step 6.

4. Choose Camerar>Standard Views=>Top from the menu bar to switch to
a top view.

5. Choose Camerar>Parallel Projection from the menu bar to turn off

perspective.
6. On the upper face, draw the edges you’d like to drape.
WMBER
43“(" Make sure that your edges form closed loops to create faces. If they

don’t, you’ll have a miserable time trying to paint the path (in this case)
once it’s draped onto your terrain surface.

7. Orbit your model so you can see both the upper and lower surfaces.

8. Soften/smooth the edges of the triangles in your terrain surface (if
they aren’t already).

To do this, follow these steps:
1. Select all of the edges and faces in your terrain.
2. Choose Window=>Soften Edges from the menu bar.

3. In the Soften/Smooth Edges dialog box, move the slider all the
way to the right and make sure that both the Smooth Normals and
Soften Coplanar check boxes are selected.

9. Select the edges you want to drape.

If your edges define closed faces, you can select those faces instead;
sometimes that’s easier than selecting a bunch of individual edges. Take
a look at the last part of Chapter 2 for tips on selecting things.

10. Choose Drawr>Sandbox=>Drape from the menu bar to activate the
Drape tool.

11. Click once on your terrain surface to drape the edges you selected in
Step 9.

It doesn’t matter if your terrain is inside a group — the Drape tool will
work anyway.

Add Detail

Like the Flip Edge tool, Add Detail is kind of a one-trick pony. You use it to
add triangles to areas of your terrain surface that need more detail. That way,
you can save geometry (and file size, and waiting) by only having lots of faces
in the areas of your terrain that require it. If I were designing a golf course, I'd
use very big triangles for the vast majority of it. I'd use the Add Detail tool to
add triangles to areas where I planned to have smallish things like sand traps.
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You can use the Add Detail tool in two different ways:

v Add detail to an area all at once. This is actually my favorite way to

use this tool; it’s quick and easy to understand. All you have to do is
select the faces on your terrain you want to subdivide, then choose
Tools=>Sandbox=>Add Detail from the menu bar. Take a look at Figure
6-25 to see what happens when you do.

1+ Add detail to faces one at a time. To be honest, I've never used the

tool this way, but here goes: You can activate the tool (see the previous
bullet) without having any geometry selected, then click faces or edges
on your terrain to divide them into more faces. I suppose this comes in
handy when you’re modeling something very precisely.

Roughing out a site

Perhaps your building is sitting on a piece of land that isn’t flat, and you want
to model the terrain around it. Maybe you’re trying to reproduce existing site
conditions, or maybe you're in the process of designing the landscape for a
project. You can use From Contours to quickly generate a surface from just a
few simple outlines.

Follow these steps to model a terrain surface with the From Contours tool
(see Figure 6-26):

1.

Extend the bottom of your building down so the exterior walls drop
below ground level.

. Make your building into a group.

See Chapter 5 if you need help.

. Use SketchUp’s drafting tools to draw the outline of the chunk of ter-

rain you want to model around the building.

You should end up with a horizontal face by using a combination of the
Tape Measure and Line tools. Keep in mind that this outline should be
flat; just pretend you're drawing in 2D space. It doesn’t matter if the out-
line you draw is below, above, or in line with the building — you’ll see
why in the next step.

. Use the Push/Pull tool to extrude the face you drew in Step 3 into a

box that extends above and below your building, then delete the top
and bottom faces of the box you just drew.

. Paint the walls of your box with a translucent material.

You can find some in the Translucent library, in the Materials dialog box.

. Draw edges on the sides of the box that represent where the ground

should intersect them.
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Figure 6-25:

Use the
Add Detail
tool to add

triangles
to selected

areas of
your terrain

surface.
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Figure 6-26:
You can
create
irregular
terrain sur-
faces very

quickly with |

the From
Contours
tool.
|
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All hail the From Contours tool

| really can’t stress enough how useful the From
Contours tool is. All it does, really, is connect
edges in 3D space with more edges, which
in turn creates triangular faces. The folks at
SketchUp designed it to make it easier to create
terrain, but you can use it create all kinds of
irregular surfaces.

The following image shows a tent canopy that |
created in about ten minutes with the Line tool,
the Arc tool, the Eraser, and From Contours.

Full credit for this discovery goes to my
friend Daniel Tal, a landscape architect and
SketchUpper extraordinaire who regularly
builds models that defy explanation. In fact,
Daniel has written a book about SketchUp
and design that should be available at your
local bookstore. If you're serious about build-
ing smart, clean models, | highly recommend
checking it out.

7. Draw edges on the sides of the building that represent where the
ground meets the building.

8. Delete the box you created in Step 4, leaving only the edges you drew

in Step 6.

9. Select all of the edges you drew in Steps 6 and 7.
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10. Choose Draw~>Sandbox~>From Contours from the menu bar to generate
a surface based on the edges you selected in the previous step.

Take a look at the previous section in this book for some tips on using
From Contours; at this point, you need to use the Flip Edge tool and the
Eraser to do some cleanup — particularly in the area where your build-
ing is supposed to go.
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Chapter 7

Keeping Your Model Organized

In This Chapter

Taking stock of your model with the Outliner
Avoiding problems by using layers the right way
Looking at how everything works together

Scarting with this chapter, I might sound like your mom: “Clean up your
room! Don’t leave your toys in the driveway! Put your dishes in the
sink!” As everybody knows, living life can be a messy ordeal, and modeling in
SketchUp is no exception. As you crank away at whatever it is you're build-
ing, you will reach a time when you stop, orbit around, and wonder how your
model got to be such a pigsty. It’s inevitable.

Luckily, SketchUp includes a bunch of different ways to keep your geometry
(edges and faces) from getting out of control. Because big, unwieldy, dis-
organized models are a pain to work with — they can slow your computer,
or even cause SketchUp to crash — you should definitely get in the habit
of “working clean” (as cooking shows like to call it). As I said earlier, [ don’t
mean to nag; I just want you to be familiar with the techniques experienced
SketchUp modelers use to keep from going insane.

In this chapter, I present the two main tools that SketchUp provides for
organizing your model. In the first section, I outline both and talk about what
they’re for. Then I dive in to each one in a good amount of detail, describing
how to use them and how not to use them (are you listening, layers?). This
chapter ends with a detailed example of how both methods can be used
together to make your life easier; I show you how I organize a model of my
house.
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Taking Stock of Vour Organization
Options
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When it comes to sorting out the thousands of edges and faces in your
model, it’s all about lumping things together into useful sets. After you've
separated things out, you can name them, hide them, and even lock them so
that you (or somebody else) can’t mess them up.

If you haven’t read about groups and components yet, now would be a good
time to go back and take a look at Chapter 5 — the stuff in this chapter is best
understood if you have a firm grasp on the stuff in that one.

You have two organizational methods at your disposal in SketchUp. The best
modelers use both all the time:

v Outliner: The Outliner is a dialog box that’s basically a fancy list of

all the groups and components in your SketchUp model. It shows you
which groups and components are nested inside other ones, lets you
assign names for them, and gives you an easy way to hide parts of your
model you don’t want to see. If you use a lot of components (and you
should), the Outliner may well become your new best friend.

v Layers: This is where a lot of people reading this book let out a big sigh

of relief. “Thank goodness,” they’re thinking, “I was beginning to think
SketchUp doesn’t have layers.” For people who are used to organizing
content in other software programs, layers are usually where it’s at — you
put different kinds of things on different layers, name the layers, and then
turn them on and off when you need to. It’s a pretty simple concept.

In SketchUp, layers are similar, but there’s a problem: Using layers the
wrong way can seriously mess up your model. I'm not kidding. If you're
going to use them, read the section “Discovering the Ins and Outs of
Layers,” later in this chapter. Not doing so could result in serious injury
or even death (depending on how upset you get when your 50-hour
model gets ruined).

Seeing the Big Picture: The Outliner

I'm a person who really likes to make lists. Not only that, but I love to look at
lists — information arranged neatly into collapsible rows is the kind of thing
that brings a tear to my eye.
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Figure 7-1:
The Outliner,
when |

have a few
components
in my model.
|

Now, before you decide that I ought to be locked in a small room with cush-
ions on the walls, consider this: most halfway-complicated SketchUp models
consist of dozens, if not hundreds, of groups and components. These groups
and components are nested inside each other like Russian dolls, and a lot of
them are heavy, computer-killing behemoths like three-dimensional trees and
shrubs.

Without a list, how are you going to manage all your groups and compo-
nents? How are you going to keep track of what you have, hide what you
don’t want to see, and (more importantly) unhide what you do want to see? |
thought so — I guess it turns out I'm not so crazy after all.

Taking a good look at the Outliner

You can open the Outliner dialog box by choosing Window=>Outliner.
Figure 7-1 shows what it looks like when a model consists of a simple room
with some furniture in it. Each piece of furniture is a separate component
which I downloaded from the Google 3D Warehouse. (Check out Chapter 5
for the whole story.)

This symbol means this is a component instance

Fitter: | B

Living Room
<Chair_Arm>

<Clock_Wall>

<Couch_Rounded>
<Couch_Rounded_Loveseat>
<Door_3-0x6-8_Left Rev
<Frame_3x4'>

<Frame_3x4>
<Shelving_Modern_Modular_30x30_Unit>
<TV_FlatScreen_48in>
<Table_Coffee_RiceChest>

<Table_End>

<Table_End>

Group

5 <Books5>

5 <Chest Step>
<Globe>

= <vase>
<Vase_Short_Flowers>

%

*
*
o=

This symbol means this is a group These components are nested

inside a group
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The Outliner dialog box has the following features:

v Search filter box: If you type a word or phrase into this box, the
Outliner only shows the items in your model that include that word or
phrase in their name. If I were to type in coffee, only the coffee table
component would be visible.

v Outliner Options flyout menu: This handy little menu contains three
options:

¢ Expand All: Choose this option to have the Outliner show all the
nested groups and components in your model — every last one of
them (provided they’re on visible layers).

é‘v(,N\BEI? It’s important to note that the Outliner only shows groups and
& components that exist on layers that are visible in your model.
In other words, anything on a hidden layer won’t appear in the
Outliner, so be extra careful if you're using both the Outliner and
layers to organize your model. You can read all about layers in the
next section.

¢ Collapse All: This option collapses your Outliner view so that
you only see fop-level groups and components — ones that aren’t
nested inside other groups and components.

¢ Sort by Name: Select this option to make the Outliner list the
groups and components in your model alphabetically.

v Outliner List window: All the groups and components in your model are
listed here. Groups and components that have nested groups and com-
ponents inside them have an Expand/Collapse toggle arrow next to their
names. When they’re expanded, the constituent groups and components
appear as an indented list below them.

Making good use of the Outliner

BER
&("N\ If you're going to use lots of groups and components (and you should), having
&
the Outliner open on your screen is one of the best things you can do to model
efficiently.
Here’s why:

v Use the Outliner to control visibility. Instead of right-clicking groups
and components in your model to hide them, use the Outliner instead.
Just right-click the name of any element in the Outliner and choose Hide.
When you do, the element is hidden in your modeling window, and its
name is grayed out and italicized in the Outliner. To unhide it, just right-
click its name in the Outliner and choose Unhide.
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 Drag and drop elements in the Outliner to change their nesting order.
Don’t like having the component you just created nested inside another
component? Simply drag its name in the Outliner to the top of the list.
This moves it to the top level, meaning that it’s not embedded in any-
thing. You can also use the Outliner to drag groups and components
into other ones, too.

v Find and select things using the Outliner. When you select something
in the Outliner, its name gets highlighted and it is selected in your mod-
eling window. This is a much easier way to select nested groups and
components, especially if you're working with a complex model.

Discovering the Ins and Outs of Layers

I’'m gonna give it to you straight: Layers are a very useful part of SketchUp,
and they can make your life a lot easier. Layers can also be a major source of
heartache, because they can really mess up your model if you're not careful.
I'll try to get you going on the right track.

What layers are — and what they're not

In a 2D program like Photoshop or lllustrator, the concept of layers makes

a lot of sense: You can have content on any number of layers, sort of like a
stack of transparencies. You find a distinct order to your layers, so anything
that’s on the top layer is visually in front of everything on all the other layers.
Figure 7-2 shows what I'm talking about.

Figure 7-2:
In 2D soft-

ware, layers
are pretty .
straightfor- .

ward.
|
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Figure 7-3:
The Layers
dialog box.
|

But hold on a second — SketchUp isn’t a 2D program,; it’s a 3D program. So
how can it have layers? How can objects in three-dimensional space be lay-
ered on top of each other so that things on higher layers appear in front of
things on lower ones? In short, they can’t — it’s impossible. This means that
layers in SketchUp are different from layers in most other graphics programs,
and that’s confusing for lots of people.

SketchUp has a layers system because some of the very first SketchUp users
were architects, and many, many architects use drawing software called
AutoCAD. Because AutoCAD uses layers extensively, layers were incorporated
into SketchUp to maximize compatibility between the two products. When you
import a layered AutoCAD file into SketchUp, its layers show up as SketchUp
layers, which is pretty convenient.

So what are SketchUp layers for? Layers are for controlling visibility. You use
them to gather particular kinds of geometry so that you can easily turn it on
(make it visible) and turn it off (make it invisible) when you need to. That said,
layers don’t work the same way as groups and components; your edges and
faces aren’t isolated from other parts of your model, which can cause major
confusion if you're not careful. Take a look at the section “Staying out of trou-
ble,” later in this chapter, to find out more.

Using layers in SketchUp

You can find the Layers dialog box on the Window menu. It’s a pretty simple
piece of machinery, as you can see in Figure 7-3. Here’s what everything does:

Add Layer Layer Options flyout menu

Delete Layer

Name | visible | Color
@ LayerD [ ]
O Layerl ]

— Layers list

v Add Layer: Clicking this button adds a new layer to your SketchUp file.

1 Delete Layer: Click this button to delete the currently selected layer. If
anything is on the layer you’re trying to delete, SketchUp will ask you
what you want to do with it; choose an option and select Delete.
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v Layer Options flyout menu: This contains the following useful options:

¢ Purge: When you choose Purge, SketchUp deletes all the layers
that don’t contain geometry. This is a handy way to keep your file
neat and tidy.

¢ Color by Layer: Notice how each layer in the list has a little
material swatch next to it? Choosing Color by Layer temporarily
changes all the colors in your SketchUp model to match the colors
(or textures) assigned to each layer. To see what’s on each layer,
this is the way to go.

v~ Layers list: This is a list of all the layers in your SketchUp file. You need
to know about these three columns:

¢ Name: Double-click a layer’s name to edit it. Giving your layers
meaningful names is a good way to quickly find what you’re
looking for.

e Visible: This check box is the heart and soul of the Layers dialog
box. When it’s selected, the geometry on that layer is visible; when
it’s not, it’s not.

¢ Color: You can choose to view your model using Color by Layer,
which [ describe in the previous list. You can choose which mate-
rial (color or texture) to assign to each layer by clicking the Color
swatch.

Adding a new layer
Follow these steps to add a layer to your SketchUp file:

1. Choose Window=>Layers.
This opens the Layers dialog box.
2. Click the Add Layer button to add a new layer to the Layers list.

If you want, you can double-click your new layer to rename it.

Moving entities to a different layer
Moving things from one layer to another involves using the Entity Info dialog
box. Follow these steps to move an entity (an edge, face, group, or compo-
nent) to a different layer:

1. Select the entity or entities you want to move to another layer.

Keep in mind that you should only be moving groups and components to
other layers; have a look at the next section in this chapter to find out why.

2. Choose Window=>Entity Info.

This opens the Entity Info dialog box. You can also open it by right-
clicking your selected entities and choosing Entity Info from the context
menu.
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3. In the Entity Info dialog box, choose a layer from the Layer drop-down

list.

Your selected entities are now on the layer you chose from the list.

Staying out of trouble

As [ said before, layers can be really helpful, but you need to know how to
use them; if you don’t, bad things can happen. Here’s some more detail:

v Do all your modeling on Layer(. Always make sure that Layer0 is your

current layer when you’re working. Keeping all your loose geometry
(that’s not part of a group or component) together in one place is the
only way to make sure that you don’t end up with edges and faces all
over the place. SketchUp, unfortunately, lets you put geometry on what-
ever layer you want, which means that you can end up with a face on
one layer, and one or more of the edges that define it on another. When
that happens, it’s next to impossible to work out where everything
belongs; you’ll spend literally hours trying to straighten things out. This
property of SketchUp’s layers system is a major stumbling point for new
SketchUp users; knowing to keep everything on Layer( can save you a
lot of anguish.

+* Don’t move anything but groups and components to other layers. If

you’re going to use layers, follow this rule: Never put anything on a layer
other than Layer0 unless it’s a group or a component. Doing so ensures
that you don’t end up with stray edges and faces on separate layers.

v Use layers to organize big groups of similar things. More complicated

SketchUp models often include things like trees, furniture, cars, and
people. These kinds of things are almost always already components,
so they’re perfect candidates for being kept on separate layers. I often
make a layer called Trees and put all my tree components on it. This
makes it easy to hide and show all my trees all at once. This speeds my
workflow by improving my computer’s performance. (Trees are usually
big, complicated components with lots of faces.)

v Don’t use layers to organize interconnected geometry; use the

Outliner instead. By inferconnected geometry, I mean things like building
floor levels and staircases. These model parts aren’t meant to be physi-
cally separate from other parts (like vehicles and people are). When you
put Level 1 on one layer and Level 2 on another, more often than not,
you’ll get confused about what belongs where: Is the staircase part of
Level 1 or Level 2? Instead, make a group for Level 1, a group for Level 2,
and a group for the staircase — you’ll need less headache medicine at
the end of the day.
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1 Feel free to use layers to iterate. lteration is the process of doing multi-
ple versions of the same thing. Lots of designers work this way to figure
out problems and present different options to their clients. Using layers
is a great way to iterate: You can move each version of the thing you're
working on to a different layer, and then turn them on and off to show
each in turn. Just remember to follow the rule about only using groups
and components on separate layers (mentioned previously), and you’ll
be fine.

Putting It All Together

,\\\E B

L / I,,-.'s
\‘\\\\{ ,,//

!

|
Figure 7-4:
I'm using

all of
SketchUp's
organiza-
tional tools
to build this
model.
|

In this chapter (and in Chapter 5), I talk about each of SketchUp’s organiza-
tional methods in isolation: discussing how they work, why they’re special,
and when to use them. In fact, you’ll probably end up using a combination of
all of them when you’re working in SketchUp, so I thought it might be helpful
to see an example of everything in action.

Figure 7-4 (along with a couple of the pages in this book’s color insert) shows
a model of a small house I'm building in SketchUp. I'm using all of SketchUp’s
organizational tools to help me manage my model’s complexity while I'm
working:

Outliner =
Filter: | B
[2] House Model

- m First Floor
=i~ m Second Floor

n <Bathtub_60x321975-12-20 01:39:01 -0700>
# s <Jewelry Bench>
11 <Sink_Counter_Backsplash1975-12-20 01:31:5
<Tolet2>
# s <Washer-FrontLoad 26in>
# & <WasherFront Load 26in>
w First Floar Ceiing
=~ m Shell
m Chimnzy

m Exterior Walls
= m Roofs
w Second Floor Ceiing

< B2

Layers ]

RS B
Name. | visible | color |
@ Layerd | |
O Furniture [ |
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|
Figure 7-5:
Each floor of
my house,
aswell as
the roof and
the exterior
walls, is a
group.
|

A\

v+ Each floor level is a group. By working with each floor level as a sepa-

rate group, I'm able to use the Outliner to hide whichever one I'm not
working on. This makes it easier to see what I'm doing. I'm including the
house’s only staircase in the first floor group, because that turns out to
be the easiest thing to do.

I've decided to include the interior walls on each level of my house in
that level’s group. I don’t think I'll ever have to hide them, so it wasn’t
worth making them a separate group. For what it’s worth, I think the
same thing probably applies to most buildings, unless you plan to study
different floor plans with different interior wall arrangements.

v The roof and exterior walls are groups inside of another group. [ want

to be able to “remove” the roof and the exterior walls separately, so I've
made each of them a group. I also want to be able to hide and unhide
them both at the same time, so I made a group called Shell that includes
both of them. Using the Outliner, I can selectively show or hide just the
geometry [ want. (See Figure 7-5.)

The floor levels, roof, and exterior walls of my house are groups instead
of components because they’re unique — I only have one First Floor, so
it doesn’t need to be a component.

All groups are visible Shell group is hidden Only First Floor group is visible

v All the furniture and plumbing fixtures are components. All the com-

ponents I use to furnish my house are ones I either built myself, took
from the Components dialog box, or found in the 3D Warehouse.

But I only have one couch: Why make it a component instead of a group?
By making every piece of furniture in my model a component, 'm able
to see a list of my furniture in the In Model collection of the Components
dialog box. (See Figure 7-6.) I can also save that as a separate compo-
nent collection on my computer. The next time [ move, I'll have all my
furniture in a single place, ready to drop into a model of my new house.
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Figure 7-6:
Because all
my pieces
of furniture
are com-
ponents, |
can use the
Components
dialog box
to make

my own,
custom
component
collection.
|

3
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B=|  Open or create a local collection...
- Save as a local collection... R

3D Warehouse Terms of Service

“Il & Expand
[

v~ All my furniture is on a separate layer. Because furniture components

can be a little heavy (taxing my computer system), and because [ want to
be able to see my house without furniture, I created a new layer (called
Furniture) and moved all my furniture onto it. Using the Layers dialog
box, I can control the visibility of that layer with a single click of my
mouse.

But why not just create a group from all my furniture components and
use the Outliner to hide and unhide them all, instead of bothering with
layers? Good question. Because it’s easier to change a component’s
layer than it is to add it to an existing group. To add something to a
group, [ would need to use the Outliner to drag and drop it in the proper
place; with complex models, this can be a hassle. Changing a compo-

nent’s layer is just a matter of using the Entity Info dialog box to choose
from a list.
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Chapter 8

Modeling with Photographs

In This Chapter

Painting faces in your model with photographs

Tweaking your textured faces with the Texture Tweaker

Modeling on top of photo-textured faces

Building a model from scratch with SketchUp’s photo-matching tools

Using photo-matching to match your model to a photograph

A\

Fese days, it’s next to impossible to meet someone who doesn’t take pic-
tures. Aside from the millions of digital cameras out there, lots of mobile
phones have cameras in them, too. I expect that by the time I'm working on
the next edition of this book, I'll be writing about the digital cameras we all
have in our sunglasses — just wink to take a snapshot and then blink three
times to e-mail it to your grandma.

You can use all these photos you're taking in SketchUp in a couple of differ-
ent ways:

v If you have a model you’d like to paint with photographs, you can
do that in SketchUp. You can apply photos to faces and then use the
information in the pictures to help you model; building windows is a lot
easier when they’re painted right on the wall. That’s what I talk about in
the first part of this chapter.

v If you want to use a photo to help you model something from scratch,
you can do that in SketchUp, too. Photo-matching makes it (relatively)
simple to bring in a picture, set things up so that your modeling window
view matches the perspective in the photo, and then build what you see
by tracing with SketchUp’s modeling tools. Sound like fun? It is — and
that’s why [ devote the whole second half of this chapter to it.

Neither of these techniques is what I'd call super-easy — that’s why I put this
chapter at the end of the modeling part of this book. If you haven’t at least
skimmed through Chapter 4, | recommend doing so; you'll spend less time
scratching your head and thinking evil thoughts about me.
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Painting Faces with Photos

Funny thing about the tool I'm about to explain: Nobody really seems to know
what it’s called. During its development, the SketchUp team referred to it as
the Texture Tweaker, mostly because both words start with the same letter,
and they thought that was catchy. For some reason, it’s called the Position
Texture tool in SketchUp’s Help documentation, even though it’s not really a
tool — at least not in the traditional sense. There’s no button for the Texture
Tweaker/Position Texture tool; you can only get to it by choosing a command
from a menu. All the same, it’s one of SketchUp’s coolest — and most useful —
“hidden” features.

I refer to it by its original name; I'm a sucker for alliteration. Here are some of
the things you can do with the Texture Tweaker:

v Stick artwork to 3D prototypes or packaging designs

v Create photo-realistic buildings that you can upload (send) to Google
Earth (See Chapter 11 for more detail on this.)

v Figure out where things like windows, doors, signs, and ornamentation
belong on your building models

Adding photos to faces

Technically, painting surfaces with pictures using 3D software is mapping, as
in “I mapped a photo of your face to the underside of the pile-driver model
I'm building.” Different software programs have different methods for mapping
(MBER pictures to faces, and luckily, SketchUp’s is very straightforward.
Mapping photos of building facades to your building models with the Texture
Tweaker/Position Texture tool has a number of benefits:

v Using photographs can make your models look more realistic.

v Taking advantage of details that are visible in a photograph (instead of
modeling them) results in a smaller, easier-to-manage model.

» You can use a photograph to help you locate building elements, like
doors, windows, and signs, if you plan to model them.

v Models to which you apply photo textures can be submitted to the
3D Warehouse, where they might be used on Google Earth’s default
Buildings layer (Chapter 11 has all the details on this).
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Figure 8-1:
Make sure
to pick Use
as Texture.
|
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SketchUp uses lots of different terms to refer to the stuff you can paint faces
with; generically, they’re all called materials. Materials can be colors or tex-
tures; textures are image-based, and colors are a single, solid hue. When you
import an image to map it to a face, it becomes a texture — just like any of the
other textures in your Materials dialog box. Read more about using materials
in SketchUp at the end of Chapter 2.

Follow these steps to map an image to a face (and find additional help on this
book’s companion Web site; see the Introduction for details):

Before you begin, I should probably mention that you need to have at least
one face in your model before you go through these steps; if you don’t, you
won’t have anything to map your texture to.
1. Choose File=>Import.
The Open dialog box opens.
2. Select the image file you want to use as a texture.

You can use JPEGs, TIFFs, PNGs, and PDFs as textures in SketchUp; all of
these are common image-file formats.

3. Select the Use as Texture option shown in Figure 8-1.

Open [B[%]

Lookin: [ (5 Images - e B Er

Preview

£ psc17s.Pe

J %) _psc1roz.pe
Recent = _psc170s.pG
N ¥ _DSC1703.3PG
B ¥ _psc1710.0p6
|8 pscirivre

Desidop 5] _psc1712.p6
¥l _DsC1713.9PG
¥ _psc1714.006
] _DsC1715.0PG
% _pscari3.pg
* _DSC4714.jpg " Use as image

Wy Documents

)
Jg (¥ Use a5 texture
My Computer (" Use for Photo Match
o
My Network  File name [_Dscarisipq | Open
Places
Files of type: | & Supported Image Types | Cancel

4. Click the Open button.

This closes the Open dialog box, switches your active tool to Paint
Bucket, and “loads” your cursor with the image you chose to import.

5. Click once in the lower-left corner of the face you want to “paint” (see
Figure 8-2).
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|
Figure 8-2:
Click once
to locate the
lower-left
corner of
the image
you're using
as a texture,
and then
again to
locate the
upper-right
corner.
|

Where you click tells SketchUp where to position the lower-left corner of
the image you’re using as a texture. You can click anywhere on the face
you’re trying to paint, but I recommend the lower-left corner — it keeps
things simple.

Click here to place the bottom left ...then click here to finish
corner of your image... placing your image

6. Click somewhere else on the face you’re painting; see Figure 8-2.

Time for a little bit of theory: Image textures in SketchUp are made up of
tiles. To make a large area of texture (like a brick wall), SketchUp uses a
bunch of tiles right next to each other. In the case of a brick wall, it may
look like there are thousands of bricks, but it’s really just the same tile
of about 50 bricks repeated over and over again.

Because SketchUp treats imported image textures just like any other tex-
ture, what you’re really doing when you click to locate the upper-right
corner of your image is this: You're telling SketchUp how big to make
the tile for your new photo texture. Don’t worry too much about getting
it right the first time, though — you can always tweak things later on
(hence the name Texture Tweaker).
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Unless the proportions of your image perfectly match the face onto which it
was mapped, you should see your image repeating. Don’t worry — that’s
normal. SketchUp automatically tiles your image to fill the whole face. If you
want to edit your new texture so that it doesn’t look tiled (and you probably
do), keep reading. You can scale, rotate, skew, or even stretch your texture to
make it look however you want.

Editing your textures

After you’'ve successfully mapped an image to a face, you're probably going
to want to change it somehow: make it bigger, flip it over, rotate it around —
you get the idea. This is where the Texture Tweaker/Position Texture tool
comes in.

The Position Texture tool is actually more of a mode; I call it Texture Edit
mode. Within this mode, you can be in either of two submodes. Their names
are less important than what they do, so that’s how I describe them:

+ Move/Scale/Rotate/Shear/Distort Texture mode: You use this mode
to move, scale, rotate, shear, or distort your texture (surprised?); it’s
technical name is Fixed Pin mode — you’ll see why in a little bit.

v Stretch Texture mode: Stretch Texture mode lets you edit your texture
by stretching it to fit the face it’s painted on. If you want to map a photo-
graph of a building facade to your model, this is the mode you want to
use. In SketchUp’s Help documentation, Stretch Texture mode is called
Free Pin mode, just in case you're interested.

You can only edit textures on flat faces; the Texture Tweaker doesn’t work on
curved faces. To find out more about working with textures and curved faces,
see the section, “The tricky case: Mapping photo textures to curved surfaces,”
later in this chapter.

Moving, scaling, rotating, shearing, and distorting your texture

The title of this section should pretty much say it all — doing the aforemen-
tioned things to your texture involves the Texture Tweaker, which is a little
bit hidden, unfortunately.

Follow these steps to move, scale, rotate, or skew your texture:

1. With the Select tool, click the face with the texture you want to edit.
2. Choose Edit~>Face~>Texturer>Position.
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This enables (deep breath) Move/Scale/Rotate/Shear/Distort Texture
mode. You should be able to see a transparent version of your image,
along with four pins, each a different color. Have a look at Color Plate 9
to see what I'm talking about. If all your pins are yellow, you’re in Stretch
Texture mode. Right-click your textured face and make sure there’s a

<® check mark next to Fixed Pins to switch into the correct mode.

A quicker way to get to Edit mode is to right-click the textured face and
then choose Texture=>Position from the context menu.

3. Edit your texture.

At this point, the things you can do to edit your texture are located in
two different places.

Right-clicking your texture opens a context menu with the following
options:

¢ Done: Tells SketchUp you’re finished editing your texture.

® Reset: Undoes all the changes you’ve made to your texture, and
makes things look like they did before you started messing around.

¢ Flip: Flips your texture left to right or up and down, depending on
which suboption you choose.

¢ Rotate: Rotates your texture 90, 180, or 270 degrees, depending on
which suboption you choose.

¢ Fixed Pins: When this option is selected, you're in Move/Scale/
Rotate/Shear/Distort Texture mode (Fixed Pin mode). Deselecting
it switches you over to Stretch Texture mode, which I talk about in
the section “Stretching a photo over a face,” later in this chapter.

¢ Undo/Redo: Goes back or forward a step in your working process.
Dragging each of the colored pins has a different effect (see Figure 8-3):

¢ Scale/Shear (Blue) pin: Scales and shears your texture while you
drag it. Shearing keeps the top and bottom edges parallel while
making the image “lean” to the left or right.

¢ Distort (Yellow) pin: Distorts your texture while you drag it; in this
case, the distortion looks like kind of a perspective effect.

¢ Scale/Rotate (Green) pin: Scales and rotates your texture while
you drag it.

e Move (Red) pin: Moves your texture around while you drag it. Of
all four colored pins, I think this one’s the most useful. I use it all
the time to precisely reposition brick, shingle, and other building
material textures in my model.

<P Instead of just dragging around the colored pins, try single-clicking one
of them to pick it up; this lets you place it wherever you want (just click
again to drop it). This comes in especially handy when you’re using the
Move and Rotate pins.
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Blue (Shear) pin Yellow (Distort) pin

Figure 8-3:
Dragging |
each of the
colored
pins does
something
different.

Green (Rotate) pin Red (Move) pin

4. Click anywhere outside your texture in your modeling window to exit
Edit mode.

You can also right-click and choose Done from the context menu, or
press Enter.

Stretching a photo over a face

The basic metaphor here is one of a photograph printed on a piece of really
stretchy fabric. You stretch the fabric until the photo looks the way you want
and then you hold it in place with pins.

\\3

Follow these steps to stretch your texture using the Texture Tweaker’s Stretch
Texture mode:

1. With the Select tool, click the face with the texture you want to edit.
2. Choose Edit~>Face>Texturer>Position.

A quicker way to get to Edit mode is to right-click the textured face and
choose Texture>Position from the context menu.

3. Right-click your texture and deselect the Fixed Pins option (make sure
that no check mark is next to it).
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Figure 8-4:
You know
you're in
Stretch
Texture
mode when
all the pins
are yellow.
|

Deselecting Fixed Pins switches you to Stretch Texture mode (or Free
Pin mode, if you're reading SketchUp’s online Help). Instead of four
differently colored pins with little symbols next to them, you should see
four, identical yellow pins — Figure 8-4 shows you what to expect.

4. Click a pin to pick it up.

Your cursor should clench up into a fist, and the pin should follow it as
you move your mouse around.

Press Esc to drop the pin you're carrying without moving it; pressing
Esc cancels any operation in SketchUp.

. Place the pin at the corner of the building in your photograph by

clicking once.

If the pin you're “carrying” is the upper-left one, drop it on the upper-left
corner of the building in your photograph, as shown in Figure 8-5.

. Click and drag the pin you just moved to the corresponding corner of

the face you’re working on.

If the pin you just moved is the upper-left one, drag it over to the upper-
left corner of the face whose texture you're “tweaking.” Check out Figure
8-6 to see this in action.
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Place the pin here

|
Figure 8-5:
Place the
pin at the
correspond-
ing corner
(upper-left
to upper-
left, for
instance) of
the build-
ing in your
photo.
|

|
Figure 8-6:
Drag the

pin you just
placed to
the cor-
responding
corner of
the face
you're work-
ing on.
|
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7. Repeat Steps 4-6 for each of the three remaining pins (see Figure 8-7).

If you need to, feel free to orbit, zoom, and pan around your model to
get the best view of what you're doing; just use the scroll wheel on your
mouse to navigate without switching tools.

\§

P A good way to work is to pick up and drop each yellow pin in the general
vicinity of the precise spot you want to place it. Then zoom in and use
your better point of view to do a more accurate job.

= 8. Press Enter to exit Texture Edit mode.

If you don’t like what you see, just go back and edit the texture again; there’s
no limit to the number of times you can muck around.

I

Figure 8-7: |
Repeat
Steps 4-6
for each of
the other
three yellow
pins.
|

Scaling your model until the photo looks right

When you’re happy with the way your texture is stretched to fit the face, one
of two things will be true:

v The proportions are correct. By this, | mean that the photo doesn’t look
stretched or squashed. This will only be the case if the face to which
you applied the photo texture was already exactly the right size.

+* The proportions aren’t correct. If the photo texture you just “tweaked”
looks stretched or squashed, the face it’s on is the wrong size. No
worries — you just need to stretch the whole face until the texture looks
right. Better yet, if you know how big the face is supposed to be (in real
life), you can stretch it until it’s correct.
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Photomodelers rejoice

For SketchUp 7, the folks at Google added three
super-useful new features that make it a whole
lot easier to build efficient (small file size) photo-
textured models.

Make Unique Texture: Right-clicking any face in
your model and choosing Make Unique Texture
does two things: It creates a copy of the tex-
ture you've selected, and it crops (trims away
everything thatisn't visible) that copy according
to the face it's on. Why is this important? Just
because you can't see part of animage doesn’t
mean it's not there; SketchUp saves the whole
photo with the model, even if you only end up
using a little bit of it. In a complex model with
dozens of photo textures, all that invisible, extra
photo data can really add up. Making your
textures unique can make your models much,
much smaller.

Combine Textures: This lets you take two or
more textures in your model and combine them
into a single texture. Why? The fewer unique
textures in your model, the smaller its file size.
Follow these steps to use this feature:

1. Selecttwo or more coplanar(on the same
plane) faces with different textures applied
to them.

2. Right-click on any of the faces you
selected in Step 1 and choose Combine
Textures. This creates a new texture in the

In Model library of your Materials dialog
box. Letting SketchUp delete the interior
edges (the ones between the faces whose
textures you combined) further reduces
your file size because it eliminates faces.

Edit Texture Image: Perhaps there’s something
in a photograph you're using, and you don’t
want it to be there. You use Edit Texture Image
to open the texture you've selected in an image-
editing program; you can edit it directly. Which
image-editing program actually opens depends
on what you have installed on your computer;
you specify which one you want to use in the
Applications panel of the Preferences dialog
box. For what it's worth, most designers use
Adobe Photoshop, but you can use whatever
you've got.

Follow these steps to use Edit Texture Image:

1. Right-click the texture in your model
you want to edit and choose Texturec>Edit
Texture Image.

2. Inthe program that opens up, make what-
ever changes you need to make.

3. Save (don't Save As) the image you're
editing and close it if you like.

4. Back in SketchUp, check to make sure
your edits have been applied.

=S
=S

@)
,,/}/\

—
—

Follow these steps to stretch a face until the texture looks right:

1. Use the Tape Measure tool to create guides that you can use to

accurately stretch your face.

In this case, I know the building I'm modeling is supposed to be 50 feet
wide. I talk about using the Tape Measure tool and guides in Chapter 2,
just in case you need a refresher.
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|
Figure 8-8:
Select
everything
you want to
stretch.
|

2. Select the face you want to stretch.

If your model is at a fairly early stage, just select the whole kit and
caboodle. Triple-click the face with the Select tool to select it and every-
thing attached to it. Figure 8-8 shows my whole model selected, because
I'm just starting out.

3. Choose Tools=>Scale to activate the Scale tool.

When the Scale tool’s active, everything that’s selected in your model
should be surrounded by SketchUp’s Scale Box — its 27 little green
cubes (they’re called grips) and thick, yellow lines are hard to miss.

. Scale your selection to be the right size (see Figure 8-9).

Use the Scale tool by clicking on the grips and moving your cursor to
stretch whatever’s selected (including your texture). Click again to stop
scaling.

To scale something precisely using a guide, click a scale grip to grab it and
then hover over the relevant guide to tell SketchUp that’s where you want to
scale to. Click again to finish the scale operation.
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|
Figure 8-9:
Use the
Scale tool's
gripsto
stretch your
selection

(texture |

and all).
|
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Modeling on top of photo textures

After you place a photo texture on the right face and in the right place on
that face (I'm turning into Dr. Seuss), [ wouldn’t blame you a bit for wanting
to use the information in your photograph to help you add geometry to your
model. It’s a great way to be more or less accurate without having to measure
much, and the combination of photo textures and a few simple push/pull
operations can be very convincing.

The thing you have to know

Modeling with photo-textured faces isn’t hard, but you have to know one
critical step before you can do it: You have to make sure that your texture is
projected.

Figure 8-10 shows what happens when you try to push/pull an opening in a
photo-textured face: On the left, when the texture isn’t projected, the inside
faces are painted with random parts of the texture, making your model look
like a sticker-laden eye puzzle. On the right, when it is projected, note how
the “inside” faces that are produced by the push/pull operation are a plain,
easy-to-discern gray. I call this painting with “stretched” pixels, and the result
is typically more appropriate for what you're doing.

It’s a good idea to make sure that your face’s texture is projected before you
start drawing on top of it. Happily, telling SketchUp to make a photo texture
projected is just a matter of flipping a switch. Right-click the face with the
photo texture and choose Texture=>Projected from the context menu. If you
see a check mark next to Projected, your texture is already projected; don’t
choose anything.
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. Textures not projected Textures are projected
Figure 8-10:

Pushing/ Wallpaper effect Stretched Pixels effect No Textures
pulling an
opening in
a textured
face when
the texture
isn't pro-
jected (left),
and when it
is projected.

Modeling with projected textures: A basic workflow

Follow these steps to get the hang of working with projected textures (see
Figure 8-11):

Stretched pixels

Figure 8-11:
Working
with
projected
textures.
I

Sample texture Paint texture on sloped surface
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1. Make a basic rectangular box.
2. Apply a photo texture to one of the side faces.
Check out the section, “Adding photos to faces,” earlier in this chapter.

3. Right-click the textured face and choose Texture= Projected from the
context menu.

Make sure that Projected has a check mark next to it.

4. Draw a rectangle on the textured face and push/pull it inward.
Notice the “stretched pixels” effect?

5. Add other angles or features to your model, if you like.
In Figure 8-11, I create an angled face.

6. Switch to the Paint Bucket tool.

7. Hold down Alt (3§ on a Mac) and click somewhere on the textured face
to sample the texture. (Your cursor should look like an eyedropper
when you do this.)

This “loads” your Paint Bucket with the projected texture.

8. Release the Alt (38) key to switch back to the Paint Bucket cursor, and
click the angled face once to paint it with the projected texture.

You should see the “stretched pixels” effect here, too.

The tricky case: Mapping photo textures to curved surfaces

This is always one of the first things folks ask about, and it always makes me
wince a little. The thing is, mapping projected textures to curved surfaces

is complicated, and in four years of SketchUping, I can count the number of
times I've needed to do it on one finger. Nevertheless, you can do it, with a
little effort.

The key is to line up a flat surface with the curved surface to which you want
to apply the photo texture. You then “paint” the flat surface with the texture,
make it projected, sample it, and finally, paint the curved surface with the
projected, sampled texture. Whew.

Follow these steps to get the basic idea (see Figure 8-12):

1. Create a curved surface.

In this case, [ draw a couple of arcs on the top face of a rectangular
block and then use Push/Pull to create a curved surface by “pushing”
one of the top faces down to make it disappear.
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2. Create a flat surface that lines up with your curved surface.

[ use the Line tool and SketchUp’s inferencing system to draw a flat face
that lines up with (and is the same size as) my curved surface.

3. Apply a photo texture to your flat surface and make sure that it’s
positioned correctly.

You can refer to the earlier parts of this chapter for detailed instructions
on how to do this.

4. Right-click the textured face and choose Texture=>Projected.

This ensures that the texture is projected, which is the key to this whole
operation.

5. Use the Paint Bucket tool with the Alt key (38 on a Mac) held down to
sample the projected texture.

This “loads” your Paint Bucket tool with the projected texture.

6. Use the Paint Bucket tool without pressing anything on your key-
board to paint the curved surface with the projected texture.

If everything goes as it’s supposed to, the photo texture should be
painted on your curved surface; the pixels in the image should look
stretched in some places.

7. Delete the flat surface that you originally mapped the image to; you
don’t need it anymore.
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If you're trying to do this on your own curved surface, and things don’t seem
to be working, your curved surface is probably part of a group or component.
Either explode or double-click to edit the group or component before you do
Step 6 and see if that helps.

Modeling Directly from a Photo:
Introducing Photo-Matching

A\

The first time [ saw SketchUp’s photo-matching feature in action, I giggled
and clapped my hands like a 2-year-old at a petting zoo. 'm not ashamed of
it, either. Sometimes technology that’s so useful, so unexpectedly satisfying,
comes along, and you just can’t help yourself. Besides — people think I'm a
little strange, anyway.

So what’s it do? You can use this feature to do a couple of things:

v Build a model based on a photograph: If you have a good photograph
(or multiple photographs) of the thing you want to model, SketchUp’s
photo-matching feature can help you set things up so that building your
model is much easier.

1 Match your model view to a photograph: Perhaps you have a model
of a building and a photograph of the spot where the building will be
constructed. You can use photo-matching to position your “camera” in
SketchUp to be exactly where the real-life camera was when the photo-
graph was taken. Then, you can create a composite image that shows
what your building will look like in context.

Photo-matching only works on photographs of objects with at least one pair of
surfaces that are at right angles to each other. Luckily, this includes millions
of things you might want to build, but still, if the thing you want to photo-
match is entirely round, or wavy, or even triangular, this method won’t work.

Looking at all the pretty colors

Like some of SketchUp’s other features, photo-matching is more of a method
than a tool: You use it to set things up, you model a bit, you use the Match
Photo dialog box a bit, and so on. If you don’t know the basics of modeling
in SketchUp yet, you won’t have any luck with photo-matching — it’s really
more of an intermediate-level feature, if such a thing exists.
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Color Plate 10 shows what your screen might look like when you're in the
throes of photo-matching. I'll admit it’s daunting, but after you've used it
once or twice, it’s not so bad. I include the image in the color section of this
book because SketchUp’s photo-matching method (at least at the beginning
of the process) uses color as a critical part of its user interface.

The following elements of the photo-matching interface show up in your
modeling window:

v Photograph: The photograph you pick to work with shows up as a kind
of background in your modeling window; it stays there as long as you
don’t use Orbit to change your view. To bring it back, click the Scene
tab (at the top of your modeling window) labeled with the photograph’s
name.

v Perspective bars: These come in two pairs: one green and one red. You
use them when you’re setting up a new matched photo by dragging their
ends (grips) to line them up with perpendicular pairs of parallel edges in
your photograph. For a clearer explanation of how this works, see the
next section in this chapter.

v Horizon line: This is a yellow, horizontal bar that, in most cases, you
won’t have to use. It represents the horizon line in your model view,
and as long as you placed the perspective bars correctly, it takes care of
itself.

v Vanishing point grips: These live at both ends of the horizon line, and
once again, as long as you did a good job of setting up the perspective
bars, you shouldn’t have to touch them.

v Axis origin: This is the spot where the red, green, and blue axes meet.
You position it yourself to tell SketchUp where the ground surface is.

v~ Scale line/vertical axis: Clicking and dragging this blue line lets you
roughly scale your photograph by using the colored photo-matching
grid lines. After you're done, you can always scale your model more
accurately using the Tape Measure tool (check out Chapter 2 for more
information on how to do this).

You also need to work with a few things that appear outside your modeling
window:

v Matched photo scene tab: When you create a new matched photo, you
create a new scene, too (you can read all about scenes in Chapter 10).
Clicking a matched photo scene tab returns your view to the one you set
up when you created (or edited) that matched photo. It also makes the
associated photograph reappear — handy if you've orbited into another
view.

1 Match Photo dialog box. This is photo-matching Mission Control. It’s
where you can find almost all the controls you need for creating, editing,
and working with your matched photo.
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Getting set up for photo-matching

Modeling with SketchUp’s photo-matching feature is generally a step-by-step
procedure. Whether you’re building a new model or lining up an existing
model with a photograph, you start by getting your modeling window ready.
How you do this depends on which one you’re trying to do:

1 Use a photograph to build a model: If this is what you want to do, open
a fresh, new SketchUp file and you’re good to go.

v Line up a model you’ve built already with a photograph: This case
requires you to re-orient your view and then reposition your drawing
axes before you're ready to begin photo-matching. To do this, follow
these steps:

1. Orbit around until your model view more or less matches the camera
position in your photograph.

2. Choose Tools=>Axes.

3. Click to place your Axis Origin somewhere on your model.

The Axis origin is where your colored axes meet. Try to choose a spot
that’s also visible in your photograph, if there is one.

4. Click somewhere in the lower-left quadrant of your modeling window.

This ensures that the red axis runs from the upper-left to the lower-right
corner of your screen.

5. Watch your linear inferences to be sure that your repositioned red
axis is parallel to some of the edges in your model.

Chapter 2 has more about linear inferences.
6. Click somewhere in the upper-right quadrant of your modeling
window to make sure that the blue axis is pointing up.

After your modeling window is set up, follow these steps to create a new
matched photo in your SketchUp file:

1. Choose CameracoMatch New Photo.

A dialog box opens.

2. Select the image on your computer that you want to use and click the
Open button.

The dialog box closes, and you see the image you chose in your modeling
window. You also see a jumble of colorful techno-spaghetti all over the
place. Don’t worry — it’s all part of the photo-matching interface. Figure
8-13 gives you an idea of what I'm referring to; Color Plate 10 shows the
same image in color.
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SketchUp’s photo-matching feature requires that you use certain kinds
of photographs for it to work properly. See the sidebar, “Taking the
right kind of picture,” later in this chapter, for pointers on what kinds of
photos you can — and can’t — use.

. In the Match Photo dialog box (which should open automatically),

choose the style that matches your photograph.

The style buttons in the Match Photo dialog box correspond to three
different types of photographs you might be using.

e Inside if your photo is an interior view
¢ Above if it’s an aerial shot

¢ Qutside if your photo is an exterior view taken from a human
vantage point

Figure 8-14 shows examples of each of these scenarios.

. Begin positioning the perspective bars, starting with the two green

ones, by lining them up with any two parallel edges.

The tops and bottoms of windows are good candidates, as are rooflines,
tabletops, and ceiling tiles. Take a deep breath — this is easier than it
looks. You move each perspective bar one at a time, dragging each end
into position separately. Color Plate 11 shows what I mean in color.
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The following tips can help you get the bars positioned correctly:

e Zoom in and out (using the scroll wheel on your mouse) to get a
better view of your photograph while you're placing your perspective
bars. The more accurate you can be, the better things will turn out.

¢ Pick nice, long edges in your photograph to match your bars to;
you’ll get better results that way.

e If you're working with an existing model, it might help to hide it
while you place your perspective bars; sometimes it gets in the
way. Just deselect the Model check box in the Match Photo dialog
box to temporarily hide it.

5. Line up the two red perspective bars with a different set of parallel
edges — just be sure that these parallel edges are perpendicular (at
right angles) to the first pair.

\NG/
gg‘“ If the parallel edges aren’t perpendicular to the first set of edges, photo-

matching doesn’t work. Color Plate 12 shows what it looks like when all
four perspective bars have been positioned properly.

6. Drag the axis origin (the little square where the axes come together)
to a place where your building touches the ground.

This is how you tell SketchUp where the ground plane is. Try to make
sure your axis origin is right at the intersection of two perpendicular
edges — it’ll make things easier later on. Color Plate 13 shows what this
looks like.

If you're photo-matching an existing model, dragging the axis origin
moves your model, too. Line up your model with the photograph so
that the spot where you placed the axis origin is right on top of the
corresponding spot in your photo. Don’t worry about size right now;
you’ll deal with that in a moment.
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7. Roughly set the scale of your photograph by clicking and dragging
anywhere on the blue scale/vertical axis line to zoom in or out until
your photograph looks to be at about the right scale.

You do this by first setting your grid spacing in the Match Photo dialog
box and then using the grid lines in your modeling window to “eyeball”
the size of your photo until it looks about right.

Color Plate 14 shows an example where my grid spacing is set at 5 feet
(the default setting). Because I know the barn in my photo is about 20
feet tall, I zoom in or out until it’s about 4 grid lines high, because 4
times 5 feet is 20 feet.

If you're trying to match an existing model to your photo, just zoom in
or out until your model looks like it’s the right size.

You don’t have to be very exact at this stage of the game. You can
always scale your model later by using the Tape Measure tool (Chapter
2 talks about how to do that).

8. Click the Done button in the Match Photo dialog box.

When you click the Done button, you stop editing your matched photo.
All the colorful lines and grips disappear, and you’re left with the photo
you brought in, your model axes, and your thoughts. It might have
seemed like a lot of magic, but what you did was pretty simple: You
used photo-matching to create a scene (which I talk about extensively
in Chapter 10) with a camera position and lens settings that match the
ones used to take the picture that’s on your screen. In effect, you're
now “standing” exactly where the photographer was standing when the
photograph was taken.

Modeling by photo-matching

Setting up a new matched photo was just the first step. Now it’s time to use
SketchUp’s modeling tools (with a little help from the Match Photo dialog
box) to build a model based on the photograph you matched. Here are a
couple of the basic concepts:

v It’s not a linear process. Building a model using a matched photo entails
going between drawing edges, orbiting around, drawing some more
edges, going back to your matched photo scene, and drawing yet more
edges. Every photo is different, so the ones you work with will present
unique challenges that you’ll (hopefully) have fun figuring out.

1+ Don’t forget the photo textures. By far one of the coolest features of
photo-matching is the ability to automatically photo-texture your model’s
faces using your photograph as “paint.” It’s a one-button operation, and
it’s guaranteed to make you smile.
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Taking the right kind of picture

Your level of success with photo-matching
depends to some extent on the photograph you
start out with. Here are some tips for what kind of
images are good candidates for this process:

v Cropped photos won’t work. Photo-
matching uses your photo’s center point
to help figure out its perspective; if you try
to use a picture that's been cropped (had
some of the original shot cut away), the
center point will be different, and things
won't work properly.

v Make sure that the edges of two perpen-
dicular surfaces are visible in the shot. You
need to be able to see planes that are at
right angles to each other to be able to use
photo-matching properly.

v~ Shoot at a 45-degree angle if you can.

Because of the way perspective works,
you'll get a more accurate result if you use
a photograph where you can see both per-
pendicular surfaces clearly; if one of them
is sharply distorted, you'll have a harder
time. The images in the following figure
show what I'm talking about.

Watch out for lens distortion. \When you
take a picture with a wide-angle lens,
some of the straight lines in the image bow
a little bit, depending on where they are in
the frame. Try to use photos taken with a
normal or telephoto lens: 50mm to 100mm
is a good bet.

Good Match Photo candidate: you can see both sides clearly
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Follow these steps to start building a model with Photo Match:

1. Click the matched photo scene tab to make sure that you’re lined up
properly.
If you orbit away from the vantage point you set up, you'll know it; your
photograph will disappear. You can easily get back by clicking the scene
tab for your matched photo. It’s labeled with the name of your photo,
and it’s at the top of your modeling window (see Figure 8-15).

Scene tab for this Photo Match

File Edit |View Camera Draw Tools Window Help

A /ZPOC CFREBLRSFIGZAROLO @Y

Photo: _DSC1708.7PG
Cpacity:
¥ todel

Praject tevtures from photo

Figure 8-15:
Clicking

the scene
tab for your
matched
photo zings
you back to
that vantage
point (and
brings back
your
photograph).

| shift to extend select. Drag mouse to select multipl =

2. Trace one of the edges in your photograph with the Line tool.

Make sure that you're drawing in one of the three main directions: red,
<P green, or blue. Color Plate 15 shows this in action.

It’s a good idea to start drawing at the axis origin; it’ll help to keep you
from getting confused.
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. Keep tracing with the Line tool until you have a rectangular face.

The key here is to make sure that you keep watching the color of your
edges as you draw. You always want to see your lines turn red, green, or
blue when you’re starting out. Have a look at Color Plate 16 to see what
this looks like.

Be careful not to orbit while you're drawing — if you do, repeat Step 1
and keep going. You can zoom and pan all you want, though.

. Click the Project Textures from Photo button in the Match Photo

dialog box.

Every time you do this, SketchUp paints the faces in your model with
the photograph you used while photo-matching. The face you created in
Step 3 should now be photo-textured according to the image you used to
model it. Orbit around and you’ll see what I mean (see Color Plate 17).

. Click the matched photo scene tab to return to your photo-matching

view.

. Use SketchUp’s modeling tools to continue to “trace” the photograph

in three dimensions.
Here are some pointers for doing this successfully:

¢ Always start an edge at the end of an edge you’ve already
drawn. If you don’t, your geometry won’t make any sense, and you
won'’t end up with what you expect.

¢ Never draw an edge in “midair.” Okay — this is the same as the
last one, but it bears repeating: If you don’t draw edges based on
other edges, you won'’t get good results.

Orbit frequently to see what’s going on. You'll be surprised what
you have sometimes — tracing a 2D image in 3D is tricky business.
Get in the habit of orbiting around to check on things and draw
certain edges. Click the matched photo scene tab to return to the
proper view.

¢ Use other tools (like Push/Pull and Offset) when appropri-
ate. Nothing prevents you from using the full complement of
SketchUp’s modeling tools. I just prefer to stick to Line and Eraser
while I'm drawing the basic skeleton of my model with SketchUp’s
photo-matching tools. I think it’s simpler.

¢ Pay attention to the colors. With a photograph as an underlay, it’s
a little harder to see what you're doing. But when photo-matching,
watching to make sure that you’re drawing the edge you intend to
draw is critical.
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¢ Draw angles by “connecting the dots.” If you need to trace an
edge in your photo that doesn’t line up with any of the colored
axes (an angled roofline, for example), figure out where the end-
points are by drawing perpendicular edges and connecting them
with an angled line. Color plate 18 shows this in glorious, full-
spectrum detail.

¢ If you want, keep pressing the Project Textures from Photo
button to use the photograph to paint your model. Of course,
using Project Textures from Photo only works on faces that are
visible in the photograph. For everything else, you need to use the
Paint Bucket and the Texture Tweaker (which I describe in the first
part of this chapter) to do your best.

If you have more than one picture of the thing you want to model, you can use
photo-matching on each to help you build it. Just get as far as you can with the
first photo and then start again with the next, using the geometry you created
as an “existing building.” Refer back to “Getting set up for photo-matching”
earlier in this chapter, and follow the steps to line up an existing model with a
new photograph.

Color Plate 19 shows a model I started to build of Habitat 67, in Montreal. |
used two pictures to create two matches in the same SketchUp file, which let
me build more of the model than I could see in a single picture.

New for SketchUp 7, you can edit any texture in your model — including ones
produced by photo-matching — by opening them in image-editing software
(like Photoshop) directly from SketchUp. This is handy for taking out stuff you
might not want in your photos, like trees, cars and ex-husbands. Take a look
at the sidebar “Editing the image itself,” earlier in this chapter, for all the juicy
details.
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Ihe 5th Wave By Rich Tennant
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“Oddly enough he spent nine hours organizing
the lagout of this voom in SketchUp.”
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In this part . . .

Building models is actually only half of what Google
SketchUp is all about. After you've actually got

something built, you can do a whole bunch of things with
your geometry. Chapter 9 describes Styles, a unique fea-
ture that lets you change the way your model looks. Want
to make it look hand-drawn? One click. How about some-
thing more realistic? Another click. Using Styles is like
having a tiny artist strapped to your clicking finger — but
in a good way.

Also in Chapter 9, I talk about using Shadows to make
your model look more realistic, and (in cases where it’s
relevant) to study how the sun will affect your design. Just
like Styles, applying Shadows to your model is laughably
easy; it’s just a matter of clicking a box and moving a cou-
ple of sliders around.

Chapter 10 covers three important aspects of exploring
your model: walking around, Scenes, and Sections. When
it comes to seeing (and showing off) your model from
inside SketchUp, this is pretty much where it begins

and ends.
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Working with Styles and Shadows

In This Chapter

Discovering how to style responsibly
Giving your model some styles

Whipping up some styles of your own
Finding out about the Shadows dialog box
Using shadows to make models look better
Displaying and studying accurate shadows

t’s all fine and well to build elegant and efficient models, but that’s only
part of what this software’s all about. SketchUp is also a very capable
tool for presenting the stuff you build. Deciding how it should look — loose
and sketchy, quasi-photorealistic, or anything in between — can be lots of
fun, and making the right decisions can go a long way toward helping your

models communicate what they’re supposed to.

The first half of this chapter is about Styles. If you're the sort of person who
likes to draw, you're in for a treat. If you can’t draw a straight line with a
ruler, you're in for an even bigger treat. SketchUp Styles are all about decid-
ing how your geometry — all your faces and edges — will actually look. Take
a peek at Color Plate 21 for an idea of what styles can do.

I've dedicated the second half of this chapter to SketchUp’s Shadows feature.
Displaying shadows is an easy operation; it’s a matter of clicking a single
button. Adding shadows to your model views offers lots of ways to make
them look more realistic, more accurate, and more readable. And, well, more
delicious. You'll see what [ mean.
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Changing Your Model’s Appearance
with Styles

This section provides a complete rundown of how to use styles in SketchUp
7. First off, I talk about why you’d want to use styles in the first place. With so
many options, I go into how you can avoid what I call stylesitis — an inflam-
mation of your styles related to getting stuck trying to decide how to make
your model look.

Choosing how and where to apply styles

The thing to remember about styles is that they’re endless. With a million
permutations of dozens of settings, you could spend all day fiddling with the
way your model looks. I've found that keeping one question in mind — Does
this setting help my model say what [ want it to say? — helps me to focus on
what’s important. There’s no doubt styles are cool, but making them useful is
the key to keeping them under control.

To help you make smart decisions about using SketchUp styles, you should
consider at least two factors when you're “styling” your model:

1 The subject of your model’s “level of completeness”: | like to reserve
sketchy styles for models that are still evolving. The message this sends
is “this isn’t permanent/I'm open to suggestions/all of this can change
if it has to.” As my design gets closer to its final form, the appearance
of my model generally gets less rough and more polished. I use styles
to communicate how much input my audience can have and what deci-
sions still need to be made.

+* How much your audience knows about design: When it comes to how
styles are perceived, there’s a big difference between an architecture-
school jury and a nondesigner client who'’s building a house for the
first time. Design professionals are more experienced at understanding
3D objects from 2D representations, so they don’t need as many visual
clues to help them along. The essence of styles is really to provide these
clues, so here’s a rule of thumb: The more your audience knows about
design, the simpler you should keep your styles.

Before you dive in to styles, remember also that a little style goes a long way.
No matter how tempting it is to go hog-wild with the styles settings, please
resist the urge. Remember that the purpose of styles is to help your model
communicate and not to make it look “pretty” or “cool.” If the style of your
worKk is getting noticed more than its content, tone things down. Figure 9-1
shows an example of going overboard with styles and then reining things in.
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Applying styles to your models

The easiest way to get started with styles is to apply the premade styles that
come with SketchUp. You find scads of them, which is great, because seeing
what’s been done is the best way to see what’s possible. As you go through
this section, you’ll no doubt get ideas for your own styles, and that’s where
the fun begins.

Applying a SketchUp style to your model is a four-step process, and it goes
like this:

1. Choose Windowr>Styles to open the Styles dialog box.

2. Click the Select tab to make sure that you're looking at the Select
pane.

3. Choose a styles collection from the Styles Collections drop-down list.

[ introduce you to the collections that come preinstalled with SketchUp
7 in a moment.

4. Click a style in the Styles window to apply it to your model.

This may come as a surprise, but it’s not possible to view your model without
any style at all. This is because styles are really just combinations of display
settings; some styles are fancier than others, but no matter what you do, you
always have to have a style applied. If you want to get a relatively neutral view
of your model, [ suggest choosing from the selection in the Default Styles
collection.

One of the best things about SketchUp is that you're rarely left out in the
cold when it comes to content. Whether it’s styles, components, or materi-
als, SketchUp comes with plenty of examples to get you started. Figure 9-2 is
a shot of the Styles Collections drop-down list you’ll see when SketchUp 7 is
new out of the box.
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Here’s some information about the most interesting ones:

v+ In Model: The In Model collection shows you all the styles you've
applied to your model. It keeps track of every style you’'ve ever applied
to your model, whether that style is still applied or not. To see a current
list of styles in your SketchUp file:

1. Choose the In Model styles collection to show a list of styles
you’'ve applied to your model.

2. Click the Details flyout menu and choose Purge Unused to get rid
of any styles you aren’t currently using.

v Default Styles: Think basic. With the exception of the first one (which
is the default style for all new SketchUp files you create), these styles
are as minimal as it gets: white background, black edges, white-and-gray
front-and-back faces, and no fancy edge effects. I use these styles to get
back to a clean starting point for all my models; I like to start simple and
build from there.

1~ Sketchy Edges: The Sketchy Edges styles in SketchUp 7 are the result of
more than a year’s work on something called nonphotorealistic render-
ing (see the nearby sidebar, “Running from realism: NPR styles,” for the
whole story). Basically, the miracle (okay, technological innovation)
involves using real hand-drawn lines instead of digital ones to render
edges. The result is that you can make your models look more like
manual sketches than ever before. Before SketchUp 6, this effect has
always looked unbelievably cheesy on the computer, like an anxious
robot trying too hard to seem human. Not anymore, though. You can
safely use the Sketchy Edges styles to convey any of the following:

e That your design is in process
¢ That your model is a proposal and not a finished product

¢ That you welcome feedback in any and all forms
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Running from realism: NPR styles

In the world of 3D modeling software, the trend
has been toward photorealism. Rays of digital
light are bounced around a billion times inside
your computer until you can see every glint of
sunlight in every dewdrop on every blade of
grass on the lawn. The standard of perfection
is how close the model comes to looking like a
photograph, and in a lot of cases, that standard
has been met— I've seen computer renderings
that look more lifelike than life itself.

But what about models of buildings or other
things that aren‘t completely finished? Perhaps
you're an architect who's designing a house
for a client. If you aren’t sure what kind of tile
you'll end up using on your roof, how are you
supposed to make a photorealistic rendering
of it? You could just go ahead and throw any
old tile up there as a placeholder, but that could
backfire. Your client could hate the tile and
decide not to hire you without ever telling you
why, and all because of something you didn't
even choose.

What you need is a way to show only the deci-
sions you've made so far, and thatis exactly why
architects and other designers make sketches
instead of photorealistic renderings. When
you're designing, decisions don't all happen
at once, so you need to be able to add detail
as your design evolves. Sketching allows you
to do that because it offers a continuum from
“cartoony” to photographic, with everything in
between. The following figure is an illustration
of this.

Programs like SketchUp offer what's called
NPR, or nonphotorealistic rendering, as a way
to solve this problem for people who design in
3D. Instead of spending processor power on
making representations that look like photo-
graphs, the people who make SketchUp went
in the opposite direction; they've made a tool
that lets you make drawings that are useful
throughout the design process. And because
SketchUp’s NPR engine works in real time, you
can make changes on the fly, in front of your
audience.

Editing and saving your styles

If you're handy in the kitchen, you've probably heard the saying that cooking
is an art and baking is a science. Cooking allows you to experiment — adding
a little of this and a dash of that while you’re making a sauce won’t wreck
anything. When it comes to baking, taking liberties with a recipe can be a
train wreck. What was supposed to be a cake can easily turn into a doorstop.
[ found this out when I made a lovely chocolate doorstop for my girlfriend’s

birthday not so long ago. . ..
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Luckily, making your own styles has a lot more in common with cooking than
it does with baking. Go ahead and fiddle around; you can’t do any irreversible
harm. Playing with styles doesn’t affect the geometry in your model in any
way, and because styles are just combinations of settings, you can always go
back to the way things were before you started.

Of the three panes in the Styles dialog box, Edit is definitely the blue whale
of the group. You find more controls and settings here than you can shake
a stick at, so SketchUp’s designers broke the Edit pane up into five sections.
Here’s a short description of each:

v Edge: The Edge section contains all the controls that affect the appear-
ance of edges in your model. This includes their visibility, their color,
and other special effects you can apply.

v Face: This section controls the appearance of faces in your model,
including their default colors, their visibility, and their transparency.

v+ Background: The Background section has controls for setting the color
and visibility of the background, the sky, and the ground plane in your
model.

v Watermark: These are images that you can use as backgrounds or as
overlays. The Watermark section gives you control over these.

+* Modeling: The Modeling section provides controls for setting the color
and visibility of a bunch of elements in your model, including section
planes and guides.

The following sections explain each part of the Edit pane in detail; I also pro-
vide suggestions for using some of the settings.

T
NY),
>

Introducing Style Builder

If you're using the Pro version of SketchUp 7,
you have access to a brand-new tool called
Style Builder. It's a completely separate appli-
cation (just like LayOut) that is put on your com-
puter when you install SketchUp Pro 7.

Style Builder lets you create NPR styles based
on edges you draw. Yep, that's right — you
can make your SketchUp models look like
you drew them by hand with your medium of
choice (finger paint, Sharpie, bloody knife . .. ).
All'you need is a scanner and a piece of soft-
ware like Photoshop, and you'll be good to go.

The best thing about the styles you create with
Style Builder is that they’re completely unique.
Unless you share them with someone else, no
one will ever be able to make SketchUp models
that look like yours.

Because Style Builder is a whole other pro-
gram, and because it's only included in the Pro
version of SketchUp, this is all I'll say about it in
this book. Take a look at this book’s Web site for
lots more information, though — if you've got it,
Style Builder is too cool to ignore.
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Figure 9-3:
The Edge
section

comes in
two flavors:
regular and

NPR.

Tweaking edge settings

The Edge section is tricky because it changes a little bit depending on what
kind of style you currently have applied to your model. NPR styles have dif-
ferent settings than regular, non-NPR styles. Figure 9-3 shows both versions
of the Edge section, which you open by choosing Window=>Styles, selecting
the Edit tab, and then clicking the box icon on the far left.
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Color: [all same - Color: [al same N |

SketchUp 7 comes with two different kinds of styles: regular and NPR. NPR
stands for nonphotorealistic rendering, wherein SketchUp uses digitized, hand-
drawn lines to render the edges in your model. All the styles in the Sketchy
Edges collection, as well as all the ones in the Assorted Styles collection, are
NPR styles. Because you can create your own styles based on existing ones, all
the styles you create using Edge settings from one of these NPR styles is an
NPR style, too.

Here’s the lowdown on some of the less-obvious settings in the Edge section;
check out Figure 9-4 for a visual reference:

v Profiles: Selecting the Profiles check box tells SketchUp to use a thicker
line for edges that outline shapes in your model. Using profile lines is a
pretty standard drawing convention that’s been around for a long time. |
think SketchUp looks better with Profiles on, but [ always have mine dialed
down to 2 pixels; 3 pixels (which is the default) seems too beefy to me.

v Depth Cue: Using different line thicknesses to convey depth is another
drawing convention that’s popular. Objects closest to the viewer are
drawn with the thickest lines, whereas the most distant things in the
scene are drawn with the thinnest ones.
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Depth Cue is SketchUp’s automatic way of letting you apply this effect
to your models. When its check box is selected, Depth Cue dynamically
assigns line thicknesses (draftspersons call them line weights) accord-
ing to how far away from you things are in your model. The number you
type in is both your desired number of line weights and the thickness of
the fattest line SketchUp will use. I like to use a maximum line weight of
5 or 6 pixels.
3

One more thing: When I'm using Depth Cue, I turn off Profiles. [ don’t
think these two drawing conventions work well together, so I always
choose to use one or the other.
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v Halo: | really wish Halo were available for non-NPR styles because it’s
just that great. What Halo does is very simple: It automatically ends cer-
tain lines before they run into other ones, creating a halo of empty space
around objects in the foreground. This keeps your model looking neat
and easy to read. In fact, this is a drawing trick that pencil-and-paper
users have been using forever to convey depth; look closely at most car-
toons and you’ll see what [ mean.

The number you type into the Halo box represents the amount of
breathing room SketchUp gives your edges. The unit of measure is
pixels, but there’s no real science to it; just play with the number until
things look right to you. For what it’s worth, I like to crank it up.

v Level of Detail: When you slide the Level of Detail controller (which
only appears when you've applied an NPR style) back and forth, you're
effectively telling SketchUp how busy you want your model to look. The
farther to the right you slide it, the more of your edges SketchUp dis-
plays. You should experiment with this setting to see what looks best
for your model. Figure 9-8 shows what happens when I slide the Level of
Detail controller from left to right.

v Color: You use the Color drop-down list to tell SketchUp what color
to use for all the edges in your model. Here’s what each of the options
means:

e All Same: This tells SketchUp to use the same color for all the
edges in your model. You tell it what color to use by clicking the
color well on the right and choosing a color.

¢ By Material: Choosing this causes your model’s edges to take on
the color of whatever material they’re painted with. Because most
people don’t know that you can paint edges different colors, this
doesn’t get used very often.

By Axis: Now here’s a useful, but hidden, gem. Choosing to color
your edges by axis tells SketchUp to make everything that’s paral-
lel to one of the colored axes the color of that axis. Edges that
aren’t parallel to any of them stay black. Why is this so important?
When something is screwy with your model — faces won’t extrude,
or lines won’t sink in — switching your edge colors to By Axis is
the first thing you should do. You’ll be surprised how many of your
edges aren’t what they seem. Have a look at Chapter 15 for more
about this.

Changing the way faces look

The Face section of the Styles dialog box is very simple — at least compared
to the Edge section (what isn’t, really?). This area of the SketchUp user inter-
face controls the appearance of faces, or surfaces, in your model. From here,
you can affect their color, visibility, and translucency. Figure 9-5 shows the
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In SketchUp, every face you create has a back and a front. You can choose
what colors to use by default for all new faces you create by clicking the
Front and Back color wells and picking a color. I recommend sticking with
neutral tones for your defaults; you can always paint individual faces later on.

Sometimes when you’re modeling in SketchUp, a face will be turned “inside
out.” Follow these steps to flip a face around so that the right side is showing:

1. Select the face you want to flip.

2. Right-click and choose Reverse Faces.

Knowing which face is the front and which is the back is especially important if
you plan to export your model to another program. Some of these, like 3D
Studio Max, use the distinction between front and back to make important dis-
tinctions about what to display. In these cases, showing the wrong side of a
face can end up producing unexpected results. I talk more about this in Part IV.

Style

Even though these are called Face styles, they have nothing to do with Styles,
the SketchUp feature that half of this chapter is about. Face styles might as
well be called Face modes because that’s what they are: different modes for
viewing the faces in your model. You can flip between them as much as you
like without affecting your geometry. Each one has its purpose, and all are
shown in Figure 9-6:
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If you're looking for something to provide a
sense of depth in your model views, look no fur-
ther than the Fog feature. New for this version
of SketchUp, Fog does exactly what it says — it
makes your model look like it's enshrouded in
fog (see the accompanying figure). You'd think
that a feature this neat would be a little compli-
cated, but it's the opposite. Follow these three
steps to let the fog roll into your model:

1. Choose Window=>Fog to open the Fog
dialog box.

2. Selectthe Display Fog check box to turn on
the fog effect.

3. Fool around with the controls until you like

In a fog?

| wish the process of controlling how Fog looks
was more scientific, but I'm afraid it's not. You
just play around with the sliders until you have
the amount of fog you want. But justin case you
absolutely need to know, here’s what the slid-
ers do:

v+~ Top slider (0%): This controls the point in
space at which Fog begins to appear in
your model. When it's all the way to the
right (toward infinity), you can't see any
fog.

v~ Bottom slider (100%): This controls the point
in space at which the fog is completely
opaque. As you move the slider from left to
right, you're moving the “completely invis-

what you see.

ible” point farther away.

v Wireframe: In Wireframe mode, your faces are invisible. Because you
can’t see them, you can’t affect them. Only your edges are visible, which
makes this mode handy for doing two things:

<P e When you’re selecting edges, switch to Wireframe mode to make
sure that you've selected what you meant to select. Because no
faces block your view, this is the best way to make sure that you're
getting only what you want.

e After you've used Intersect with Model, you usually have stray
edges lying around. Wireframe is the quickest way to erase them
because you can see what you're doing. See Chapter 4 for details
on Intersect with Model.
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+* Hidden Line: Hidden Line mode displays all your faces using whatever
color you're using for the background; it’s really as simple as that. If
you'’re trying to make a clean, black-and-white line drawing that looks
like a technical illustration, make your background white. (I talk about
how later in this chapter.)

v~ Shaded: This Face style displays your faces with colors on them. Faces
painted with a solid color appear that color. Faces to which you've added
textures are shown with a color that best approximates their overall
color. If your texture has a lot of brown in it, SketchUp picks a brown and
uses that. For models with a lot of these textures, switching to Shaded
mode can really speed up orbiting, zooming, and otherwise navigating
around. Unless [ absolutely need to see textures I've applied to my faces,
I tend to stay in Shaded mode whenever I'm working on my model.
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+* Shaded with Textures: Use Shaded with Textures when you want to see
your model with textures visible. Because this mode puts a lot of strain
on your computer, it can also be the slowest mode to work in. [ only
turn it on when I'm working on a small model, or when I need to see the
textures I've applied to my faces. Obviously, if you’re going for a photo-
realistic effect, this is the mode to choose. It’s also the mode that best
approximates what your model will look like when (and if) you export it
to Google Earth.

v Display Shaded Using All Same: When you want to quickly give your
model a simplified color scheme, use this Face style; it uses your default
front and back face colors to paint your model. You can also use this
setting to check the orientation of your faces if you're exporting your
model to another piece of 3D software.

v X-Ray: Unlike using translucent materials on only some of your faces
(like glass and water), flipping on X-Ray lets you see through all your
faces. I tend to use it when [ want to see through a wall or a floor to
show what’s behind it. If you're in a plan (overhead) view, it’s a great
way to demonstrate how a floor level relates to the one below it.

Transparency

Because how well SketchUp runs on your computer depends on what'’s in
your model, and because displaying transparency (as in translucent materi-
als) is an especially taxing operation for SketchUp and your computer to
handle, you can decide how to display translucent materials:

+ Enable transparency: Deselect this check box to display translu-
cent materials as opaque. You should turn off transparency to speed
SketchUp’s performance if you find that it’s slowed down.

v+ Transparency quality: If you decide to display transparency, you can
further fine-tune your system’s performance by telling SketchUp how to
render that transparency: You have the choice of better performance,
nicer graphics, or an average of the two.

Setting up the background

In the Background section of the Styles dialog box, you choose colors and
decide whether you want to be able to see a sky and a ground plane. It
doesn’t get less complicated than this, folks. Check out Figure 9-7 to get a
view of the Background section, along with an idea of how it works. To open
these options in your own copy of SketchUp, choose Window=>Styles, select
the Edit tab, and click the middle icon, at the top of the tab. You have the fol-
lowing options in the Background section:

v Background: For most models, I set the background to white — I guess
I'm a traditionalist.
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v Sky: Choosing to display a sky in your modeling window makes things

slightly more realistic, but the real purpose of this feature is to provide a
point of reference for your model. In 3D views of big things like architec-
ture, it’s nice to be able to see the horizon. Another reason for turning
on the sky is to set the mood — keep in mind that the sky isn’t always
blue. I've seen some beautiful SketchUp renderings wherein the sky was
sunset (or maybe nuclear winter) orange.

v Ground: | have to admit that I'm not a big fan of turning on the Ground

feature, and here’s why: It’s very hard to find a ground color that looks
halfway good, no matter what you’re building. I also don’t like the fact
that you can’t dig into the earth to make sunken spaces (like courtyards)
with the ground turned on. Instead of turning on this feature, I prefer to
make my own ground planes with faces and edges. It’s more flexible, and
[ think it looks better.

Styles
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@ @Om @ Background

Background
v Sky

IV (e | -| Transparency

¥ show ground from below

le X,
| Google Earth

Simple Google Earth
colors, Please note -
Dark red back face

Bt |mx |

Working with watermarks

Watermarks are much easier to understand if you don’t think about them as
actual watermarks. They’re not anything like watermarks, in fact — they’re
much more useful. If [ had to define them (and because I'm writing this book,
[ guess 1 do), I'd put it this way: Watermarks are graphics that you can apply
either behind or in front of your model to produce certain effects. Here are a
few of the things you can do with SketchUp watermarks:

v Simulate a paper texture, just like some of the styles in the Assorted

17
7

Styles collection
Apply a permanent logo or other graphic to your model view

Layer a translucent or cutout image in the foreground to simulate look-
ing through a frosted window or binoculars
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v Add a photographic background like “Outer Space” or “Inside My Colon”
to create a unique model setting

Eyeing the watermark controls
Figure 9-8 shows the Watermark section of the Styles dialog box. Here’s a
brief introduction to what some of the less-obvious controls do:

ot o
I Spraypaint on Brick a
Sketchy Graffiti spay @
. edges with brick
texture watermarks [s)

Select Edt |mx |
@ ED D@ @ Watermark

¥ Display watermarks
@O % )
Thumb | Name
|
“ Watermark2
Figure 9-8:
The Model space
Watermark

ta b g Watermark1

v Add, Remove, and Edit Watermark buttons: The +, -, and gears icons
allow you to add, remove, and edit (respectively) watermarks in the
style you're editing.

v WatermarKk List: This list shows all your watermarks in relation to some-

thing called Model Space, which is the space occupied by your model.
All watermarks are either in front of or behind your model, making them

overlays or underlays, respectively.
+* Move Up or Down arrows: Use these buttons to change the “stacking”

order of the watermarks in your model view. Select the watermark you
want to move in the list and then click one of these buttons to move it

up or down in the order.

Adding a watermark
Watermarks are by no means simple, but working with them, miraculously
enough, is. Follow these steps to add a watermark to your model view:

1. Click the Add Watermark button to begin the process of adding a
watermark.

The Open dialog box appears.
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2. Find the image you want to use as a watermark and then click the

Open button to open the first Choose Watermark dialog box (see
Figure 9-9).

You can use any of these graphics file formats: TIFF, JPEG, PNG, and GIF.

This is way beyond the scope of this book, but I think it’s worth men-
tioning because you're bound to need this sooner or later: If you want to
make a watermark out of an image that isn’t a solid rectangle (like a
logo), you need to use a graphics file format, like PNG or GIF, that sup-
ports alpha channels. An alpha channel is an extra layer of information
in a graphics file that describes which areas of your image are supposed

to be transparent. It sounds complicated, but it’s really a straightfor-
ward concept. To make an image with an alpha channel, you need a

piece of software like Photoshop or GIMP. Try searching for alpha chan-

nels on Google for more information.
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3. Type in a name for your watermark in the Name box.

4. Choose whether you want your new watermark to be in the back-
ground or in the foreground as an overlay and click the Next button.

5. Decide whether to use your watermark as a mask.

Selecting this check box tells SketchUp to make your watermark trans-
parent, which kind of simulates a real watermark. How transparent each
part becomes is based on how bright it is. White is the brightest color,
so anything white in your watermark becomes completely transparent.
Things that are black turn your background color, and everything in
between turns a shade of your background color. The possibilities for
this feature are interesting, but [ haven’t found any good uses for it yet.

6. Adjust the amount that your watermark blends with what’s behind it,
and click the Next button.

In this case, Blend is really just a synonym for Transparency. By sliding
the Blend slider back and forth, you can adjust the transparency of your
watermark.

Blend comes in handy for making paper textures because that process
involves using the same watermark twice: once as an overlay and once
as an underlay. The overlay version gets “blended” in so that your
model appears to be drawn on top of it. To see how this works, apply
one of the Paper Texture styles to your model, and then edit each of the
watermarks to check out its settings.

7. Decide how you want your watermark to be displayed and then click
the Finish button.

You have three choices for how SketchUp can display your watermark:
stretched to fit the entire window, tiled across the window, and posi-
tioned in the window. If you select Stretched to Fit the Entire Window,
be sure to select the Locked Aspect Ratio check box if your watermark is
a logo that you don’t want to appear distorted.

Editing a watermark
You can edit any watermark in your SketchUp file at any time. Follow these

simple steps to edit a watermark:
1. Select the watermark you want to edit in the Watermark list.

You can find the Watermark list on the Watermark tab, in the Edit pane
of the Styles dialog box.

2. Click the Edit Watermark button to open the Edit Watermark dialog box.

3. Use the controls in the Edit Watermark dialog box and click the OK
button when you’re done.

For a complete description of the controls in this dialog box, see the pre-
vious section in this chapter.
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Tweaking modeling settings

All you need to know about the controls in the Modeling section (see Figure
9-10) of the Styles dialog box is that there’s not much to know. You use the
controls to adjust the color and visibility of all the elements of your model
that aren’t geometry. To open these options, choose Windowr>Styles, select
the Edit tab, and click the box icon on the far right, at the top of the tab. The
controls are described as follows:

0 o

Select Edt |k |

DOOLGE

Selected .
toked [l
Guides .

Modeling

Inactive Section .

Active section

Section Cuts .
Section cutwidth | 5

™ Hidden Geometry [¥ Section Planes
I¥ Section Cuts
IV Model Axes

™ Color by Layer
V¥ Guides

+* Controls with color wells: Click the wells to change the color of that
type of element.

v Section cut width: This refers to the thickness of the lines, in pixels, that
make up the section cut when you’re using a section plane. For more
about this, have a look at the information on cutting sections in Chapter
10.

1 Controls with check boxes: Use these to control the visibility of that
type of element in your model. Three of them are a little confusing:

¢ Color by Layer: Tells SketchUp to color your geometry accord-
ing to the colors you've set up in the Layers dialog box. Check out
Chapter 7 for more on this.

¢ Section Planes: This refers to the section plane objects that you
use to cut sections. They're gray with four arrows on their corners.

e Section Cuts: Unlike section planes, this setting controls the vis-
ibility of the section cut effect itself. With this deselected, your sec-
tion planes won’t appear to be cutting anything.
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Mixing styles to create new ones

You can use the Mix pane to combine features of multiple styles in order to
make new ones. Instead of working through the sections of the Edit pane, flip-
ping controls on and off, sliding sliders, and picking colors, the Mix pane lets
you build new styles by dropping existing ones onto special “category” wells.
In addition to being a nifty way to work, this is the only way you can switch a
style’s edge settings between NPR and non-NPR lines.

NPR refers to the styles in the Assorted Styles, Sketchy Edges, and
Competition Winners collections. These nonphotorealistic rendering styles
use scanned, hand-drawn lines to draw the edges in your model. If you have
SketchUp Pro, you can use Style Builder to make your own NPR styles from
lines you draw and scan in yourself. Take a look at the sidebar “Introducing
Style Builder” for more information.

Follow these steps to change a style using the Mix pane (see Figure 9-11):

1. Choose Windowr>Styles and click the Mix tab in the Styles dialog box
to open the Mix pane.

As part of the Mix pane, the secondary selection pane opens at the
bottom of the dialog box. This provides you with a way to view your
styles without having to switch from the Mix pane to the Select one.

2. Find the style you want to sample from in the secondary selection
pane. You can call this your source style.

Say that you’re working on a new style, and you want your edges to
look just like those in the Marker Loose style that came with SketchUp.
In this example, choose the Sketchy Edges collection from the Styles
Collections drop-down list, where you’ll find the Marker Loose style.

3. Windows users: Click the source style from the Styles list in the sec-
ondary selection pane to sample it and then click the category well
that corresponds to the style setting you want to apply.

Mac users: Drag your source style from the Styles list in the secondary
selection pane to the category well that corresponds to the style set-
ting you want to apply.

In this case, sample the Marker Loose style from the secondary selection
pane and drop it on the Edge Settings Category well because you want
the edge settings from that style to be applied to the style you're work-
ing on.

4. To save your style after you’re done adding all the bits and pieces, see
the following section.
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Figure 9-11:
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Saving and sharing

styles you make

As you’re working along in SketchUp, you’ll want to create your own styles.
You’ll also want to save those styles so that you can use them in other

models. If you're part

of a team, it’s likely that everyone will want to have

access to the same styles so that all your models look consistent.

Saving the styles you've made

When it comes to creating your own styles, you can approach things in two
different ways. Each of these ways gets its own button (see Figure 9-12):

* Create new style: Clicking this button creates a new style with the set-
tings you currently have active. When you create a new style, it shows
up in your In Model collection of styles and is saved with your model.
The Create button can be found in the upper-right corner of the dialog

@, ”

box, and looks like a couple of objects with a “+” sign on it.

1 Update style with changes: This button updates the current style with
any settings changes you’ve made in the Edit or Mix panes. If you want
to modify an existing style without creating a new one, this is the way
to go. You can find the Update button right below the Create button in
the upper-right corner of the dialog box; it looks like two arrows chasing
each other around in a circle.
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— Create New Style
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Updating an existing style
To make adjustments to a style in your model, you need to update it. Follow
these steps to update a style:

1. Apply the style you want to update to your model.

If you need help with this, follow the steps in the section, “Applying
Styles to Your Models,” earlier in this chapter.

2. Use the controls in the Edit pane to make changes to the style.

3. Click the Update Style with Changes button in the Styles dialog box to
update the style with your changes.

\P
p You use the Update Style with Changes button to rename existing styles, too.

Just type the new name into the Name box (at the top of the Styles dialog
box), press Enter, and then click the Update button.

@‘NBEH When you update a style, only the copy of the style that’s saved with your
model is updated. You aren’t altering the copy of the style that shows up in
every new SketchUp file you create.

Creating a new style

Creating a new style adds it to your In Model collection of styles, which
means that you can come back and apply it to your model anytime you like.
Follow these steps to create a new style:

1. Click the Create New Style button in the Styles dialog box.
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This duplicates the style that was applied to your model before you
clicked the Create New Style button. Your new style appears in your In
Model collection as [name of the original style]1.

2. Use the controls in the Edit pane to set up your style the way you want.

Frequently, you’ll want to make a new style after you've already made
changes to an existing one. If you want to create a new style that reflects
modifications you've already made, just switch Steps 1 and 2 around.

3. Use the Name box (at the top of the Styles dialog box) to give your
new style a name and press Enter.

If you want, you can also give your new style a description in the
Description box, though you might want to wait until later. After all, it’s
hard to describe something you haven’t made yet.

4. Click the Update button.

This updates your new style with all the changes you made in Steps 2
and 3.

5. Check the In Model collection in the Select pane to make sure that
your new style is there.

Click the In Model button (which looks like a little house) to see your In
Model Styles collection. Your new style should appear alphabetically in
the list.

If a bunch of styles exist in your In Model collection that you aren’t using any-
more and you want to clean things up, right-click the Details flyout menu and

choose Purge Unused. This gets rid of any styles that aren’t currently applied
to any scenes in your model. Have a look at Chapter 10 to find out more about
scenes.

Creating a new style doesn’t automatically make it available for use in other
SketchUp files. To find out how to do this, keep reading.

Using your styles in other models

After you've updated or created a style, you’ll probably want to make that
style available in other SketchUp models. To make this happen, you need to
be able to create your own styles collections. Collections are folders on your
computer that contain the styles that show up in the Styles dialog box. You
can create your own collections to keep the styles you invent neat and tidy.

Follow these steps to create a collection to contain your styles:

1. Choose Window=>Styles to open the Styles dialog box.
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2. Click the Select tab to make sure that you're looking at the Select pane.

. Click the Details flyout menu and choose Create a new collection.

This opens the Add New Collection dialog box.

. Navigate to the folder on your computer or network where you would

like to create your collection.

You can locate your new collection anywhere you like, but I recom-
mend putting it in the same folder as the other styles collections on
your computer:

e Windows: C:/Program Files/Google/Google SketchUp 7/Styles

e Mac: Hard Drive/Library/Application Support/Google SketchUp 7/
SketchUp/Styles

. Click Make New Folder if you’re on a Windows computer (New Folder

on a Mac).

The new folder you create becomes your new collection.

. Type in a name for your new collection.

Call your new collection “Josephine’s Collection.” You can call it some-
thing else if your name isn’t Josephine.

. If you’re on a Mac, make sure that the Add to Favorites check box is

checked.

. Click the Save button.

The Add New Collection dialog box closes, and your collection is added
to the Favorites section of the Collections drop-down list. It will be there
in every SketchUp model you open on this computer.

After you've created a new collection, you can add styles to it in order to
make them available from any model you're working on.

Follow these steps to make a style available for use in other SketchUp files:

1. Choose Window=>Styles.

The Style dialog box appears.

2. Click the Select tab.
3. Click the In Model button to display your In Model collection.

The In Model button looks like a little house. The In Model collection
contains all the styles you’ve used in your model, including the ones
you've created.
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Figure 9-13:
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4. Click the Show Secondary Selection Pane button.

When you click this button, which looks like a black-and-white rectangle
and is in the upper-right corner of the Styles dialog box, a second copy
of the Select pane pops out of the bottom of the Styles dialog box (see
Figure 9-13). You use this pane to drag and drop styles between folders
on your computer, which makes it easier to keep them organized.

. In the secondary selection pane, choose the collection to which you

want to add your style.
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If you've created a collection specifically for the styles you make, choose
that one, or you can pick any of the collections in the Collections drop-
down list.

. Drag your style from the In Model styles list fo the Styles list in the

secondary selection pane.

By dragging and dropping your style from the upper list to the lower
one, you're making it available to anyone who has access to that collec-
tion. This means that you can use it in other SketchUp models you build
on your computer. To share it with other members of your team, copy
your style to a collection somewhere where other people can get to it,
like on a network.
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Working with Shadows

Figure 9-14:
Dial up the
sunin the
Shadow
Settings
dialog box.
|

Typically, you add shadows to a SketchUp drawing for two key reasons:

+ To display or print a model in a more realistic way: Turning on shadows
adds depth and realism and gives your model an added level of complex-
ity that makes it look like you worked harder than you really did.

v To study the effect of the sun on what you’ve built (or plan to build)
in a specific geographic location: Shadow studies are an integral part of
the design of any built object. If you’re making a sunroom, you need to
know that the sun is actually going to hit it, no? You can use SketchUp to
show exactly how the sun will affect your creation, at every time of day,
on every day of the year.

In this section, I start out with a brief, nuts-and-bolts description of how all
the controls work, without diving too much into why you’d want to pick one
setting instead of another. The second part of this section is devoted to run-
ning through each of the preceding scenarios and using the controls to make
SketchUp do exactly what you want it to.

Discovering SketchUp’s Shadow Settings

The basic thing to understand about shadows in SketchUp is that, just like in
real life, they’re controlled by changing the position of the sun. Because the
sun moves exactly the same way every year, you just pick a date and time,
and SketchUp automatically displays the correct shadows by figuring out
where the sun should be. Hooray for math!

You do all these simple maneuvers in the Shadow Settings dialog box, shown
in Figure 9-14. The sections that follow introduce how the controls work so
you can apply to them to your model.
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Turning on the sun

Shadows aren’t on by default, so the first thing you need to know about
applying shadows is how to turn them on. Follow these simple steps:

1. Choose Window=>Shadows to display the Shadow Settings dialog box.
2. At the top of the dialog box, select the Display Shadows check box.

Clicking it turns on the sun in SketchUp, casting shadows throughout
your model and, generally speaking, making everything much more
exciting.

Setting a shadow'’s time and date

The Shadow Settings dialog box has time and date controls, which you use to
change the position of the SketchUp sun. The time and date you choose, in
turn, controls the appearance of shadows in your model:

1~ Setting the time: You don’t have to be Copernicus to figure out how to
set the time of day; move the Time slider back and forth, or type a time
into the little box on the right. Notice the little times at each end of the
slider? These represent sunrise and sunset for the day of the year you've
set in the Date control, described in the next point.

1~ Setting the date: Just like the time of day, you set the day of the year by
moving the Date slider back and forth, or by typing in a date in the little
box on the right. If you slide the Date control back and forth, notice that
the sunrise and sunset times change in the Time control, in the previous
point.

To toggle open or closed the extra shadow controls, click the triangular
Expand button in the upper-right corner of the Shadow Settings dialog box.

Choosing where shadows are displayed

The Display check boxes in the Shadow Settings dialog box enable you to
control where shadows are cast. Depending on your model, you may want to
toggle these on or off.

v On Faces: Deselecting the On Faces check box means that shadows
aren’t cast on faces in your model. This is on by default, and should
probably be left on, unless you only want to cast shadows on the
ground. For what it’s worth, I always have it selected.

+* On Ground: Deselecting the On Ground check box causes shadows not
to be cast on the ground plane. Again, this is on by default, but some-
times you’ll want to turn it off. A prime example of this is when some-
thing you’re building extends underground.
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v From Edges: Selecting the From Edges check box tells SketchUp to allow
edges to cast shadows. This applies to single edges that are not associ-
ated with faces — things like ropes, poles, and sticks are often modeled
with edges like these.

Using shadows to add depth and realism

The neat thing about shadows in SketchUp is how easily you can apply
them — and how easy they are to adjust. In the previous sections, I give a
dry rundown of the basic controls in the Shadow Settings dialog box. In the
following sections, I show you how to use those controls to add depth, real-
ism, and delicious nuance to your models. If only Caravaggio had had it so
good. . ..

There are lots of times when you’ll need to use shadows to make your draw-
ings read better; most of them fit into one of the following three categories:

v+ Indoor scenes: The sun is the only source of lighting that SketchUp has,
so any shadows you use in interior views have to come from it.

* Objects that aren’t in any particular location: For things like cars and
furniture, it doesn’t matter that the shadows are geographically accurate;
all that matters it that they help make your model look good.

v 2D views: Without shadows, it’s next to impossible to read depth in 2D
views of 3D space.

Lighting indoor spaces

Adding shadows to interior views presents an interesting problem: Because
SketchUp has no lights besides the sun, how are you supposed to make any-
thing that looks halfway realistic? With a ceiling in your room, everything’s
dark. If you leave off the ceiling, your model looks ridiculous. Don’t despair —
here are some tricks I've learned:

1 Decrease the darkness of the shadows. Sliding the Dark slider to the
right brightens your view considerably. You'll still be able to see the
shadows cast by the sun coming through windows and other openings,
but the whole room won’t look like something bad is about to happen.
Check out Figure 9-15 to see what [ mean.

1 Make an impossible ceiling. As long as you haven’t modeled anything
on top of the interior you're planning to show, you can tell the ceiling
not to cast a shadow. That way, sunlight will shine directly onto your
furniture, casting gloriously complex shadows all over everything.
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Figure 9-16 shows this ceiling method in action; follow these steps to do it
yourself:

1. Adjust the settings in the Shadow Settings dialog box until the sun is
shining through one or more windows in your view.

This ensures that shadows cast by objects in your room look like they’'re
caused by light from the windows.
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To make it seem like overhead lighting is in your space, set the time of
day to about noon. The shadows cast by furniture and similar objects
will be directly below the objects themselves. One more thing: If you
have lighting fixtures on the ceiling, remember to set them not to cast
shadows in the Entity Info dialog box (read on).

. Choose Window=>Entity Info.

This opens the Entity Info dialog box.

. Select any faces that make up the ceiling.

Hold down Shift to select more than one thing at a time.

. In the Entity Info dialog box, deselect the Cast Shadows check box.

The ceiling now no longer casts a shadow, brightening your space
considerably.

. Repeat Steps 3 and 4 for the following faces and objects:

e The wall with the windows in it
¢ The windows themselves

¢ Any walls in your view that are casting shadows on the floor of
your space

. Move the Dark slider over to about 50.

This brightens things even more and makes your shadows more
believable.
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Making 3D objects pop

Adding shadows to freestanding things like tables and lamps and pineapples
is a mostly aesthetic undertaking; just fiddle with the controls until things
look good to you, and you'll be okay. Here are some things (which are illus-
trated in Figure 9-17) to keep in mind:
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1~ Take it easy on the contrast — especially when it comes to very com-
plex shapes or faces with photos mapped to them. When your model is
too contrasty and dramatic, it can be hard to figure out what’s going on.
To decrease the contrast:

1. Move the Dark slider over to about 55.
2. Move the Light slider down to 60 or 70.

v Shorten your shadows. It’s strange to see objects lit as though the light
source is very far away; overhead lighting looks more natural. To make
your shadows look better, follow these steps:

1. Set the Date slider to a day in the early autumn.
2. Set the Time slider to a time between 10 a.m. and 2 p.m.
Q&N\BER v Don’t be afraid to rotate your model around. Remember that you can’t
& get every possible shadow position by using only the controls in the

Shadow Settings dialog box; to get the effect you want, you might have
to rotate your model by selecting it and using the Rotate tool.
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v Select the From Edges check box. Lots of times, modelers use free
edges to add fine detail to models (think of a harp or a loom). Selecting
the From Edges check box tells SketchUp to allow those edges to cast
shadows, which makes complex objects look about 900 percent cooler.

v~ Pay attention to the transparency of faces. When you have a face
painted with a transparent material, you can decide whether that face
should cast a shadow — chances are that it shouldn’t. In SketchUp, the
rule is that materials that are more than 50 percent transparent cast
shadows. So, if you don’t want one of your transparent-looking faces to
cast a shadow, do one of the following:

¢ Select the face, and then deselect the Cast Shadows check box in
the Entity Info dialog box.

e Adjust the opacity of the face’s material to be less than 50 percent
in the Materials dialog box. For more information on how to do
this, have a look at Chapter 2.

Creating accurate shadow studies

One of the most useful features in SketchUp is the ability to display accurate
shadows. To do this, three pieces of information are necessary:

v The time of day
v The day of the year
v The latitude of the building site

The sun’s position (and thus the position of shadows) depends on geographic
location — that is to say, latitude. The shadow cast by a building at 3:00 on
March 5 in Minsk is very different from that cast by a similar building, at the
same time of day, on the same date in Nairobi.

If you're displaying shadows on a model of a toaster oven, geographic loca-
tion probably doesn’t matter to you; the shadows are just there for effect. But
if you're trying to see how much time your pool deck will spend in the sun
during the summer months, you need to tell SketchUp where you are.

Telling SketchUp where you are

How many of us know the precise latitude of where we live? I sure don'’t. It’s a
good thing SketchUp makes it easy to tell it where in the world your model is
supposed to be. You can georeference your model (give it a geographic loca-
tion) in two ways; which one you choose will probably depend on whether
you have an Internet connection handy:
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v Using Google Earth: This is by far the simplest approach, but it requires
that you have a precise idea of where your model is supposed to be on
the globe. Because it involves Google Earth, it also requires that you be
connected to the Internet for the operation. If you know exactly where
your model is supposed to go, and you’re online, use this method. Take
a look at the section “Building Models for Google Earth” in Chapter 11
for a complete set of instructions.

v Using the Model Info dialog box: This method is a little more compli-
cated, but it’s your only option if you're not online (or if you’d rather not
use Google Earth). Read on for all the gory details.

To give your model a geographic location without using Google Earth, follow
these steps (see Figure 9-18):

Georeferencing
O I” Use georeferencing

Geographic Location

Country: [ Canada -
Location: |montreal (QUE) -

Latitude: 45,5170N
Longitude: 73,5670\

Set custom location...

Solar Orientation

Narth angle: 0.0 <  Select

™ Show in model

Figure 9-18:
Giving your
model a
geographic
location.
|

1. Somewhere on the ground in your model, draw a short line to indicate
the direction of north.

You might already have a north indicator if you're working with
imported geometry (from AutoCAD, for instance).

2. Choose Window=>Model Info to open the Model Info dialog box.
3. On the left side of the Model Info dialog box, choose Location.
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QWP If the Use Georeferencing check box is selected and the Country and
Location drop-down lists say N/A or Custom, stop here. Your model has
already been geographically located and you don’t need to go through
any of the following steps. Close the Model Info dialog box, make your-
self some coffee, and waste the time you just saved avoiding the next
seven steps.

4. Choose a country from the Country drop-down list.
5. Choose a location from the Location drop-down list.

If the location you want isn’t listed, choose the closest one, or click the
<P Custom Location button to enter a set of coordinates.

To find coordinates for just about anywhere in the world, try searching
for city, country coordinates on Google; something usually pops up.

6. Click the Select button to the right of the North angle box.

Do this instead of typing in a north angle (which I find overly compli-
cated). Back in your model window, your cursor will have become a
biggish circle with four lines radiating out from the center, as shown in
Figure 9-19.

7. Click the southern end of the line you drew in Step 1.

(D 1 use georeferencng
Geographic Location
Conty: [ ]
tocaton: [oomrea () 2]

Latitude: 45.5170N

Longitude: 73.5670W
‘Solar Orientation
Northangle: [232.5 <] Select

I™ Show in mode!

Figure 9-19:
Telling
SketchUp
where

north is.
|
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8. Click the northern end of the same line, finishing the operation.

9. If you want, select the Show in Model check box to display the direc-
tion of north as a yellow line.

10. Close the Model Info dialog box.

The shadows in SketchUp are now specific to the geographic location
you've just set up. If you like, you can erase the line you drew in Step 1.

Displaying accurate shadows for a given time and place

Now that you’ve told SketchUp where your model is, it’s a pretty simple pro-
cess to study how the sun will affect your project, as shown in Figure 9-20.
This is the fun part; all you have to do is move some sliders around. If you
have an audience, get ready for some completely undeserved praise.

|
Figure 9-20: |
Studying the
effect of the
sun on your
model.
|

To study how the sun will affect your project, follow these steps:

1. Orbit, zoom, and pan around until you have a good view of the part of
your project you want to study.

2. Choose Windowr>Shadows to open the Shadow Settings dialog box.
3. Select the Display Shadows check box to turn on SketchUp’s sun.
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4. Type a month and day into the box to the right of the Date slider, and
press Enter.

5. Move the Time slider back and forth to see how the shadows will
move over the course of that day.

6. Pick a time of day using the Time controls.

7. Move the Date slider back and forth to see how the sun will affect
your project at that time of day over the course of the year.

Uses for shadows
Even if you're not an architect, you might want  »* To make sure that the overhang behind
to study shadows accurately for these reasons: your house will provide enough shade at

v To figure out where to locate the plants in L

your garden that need the most light (orthe ¢~ To plan and build a 50-foot stone sundial as
most shade) a birthday gift for your Druidic neighbor

v To see when sunlight will be coming
straight through the skylight you're thinking
of installing
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Chapter 10

Presenting Your Model
Inside SketchUp

In This Chapter

Walking around inside your model

Creating scenes to capture particular views

Making animations with scenes

Cutting slices through your model with section planes

Generating plans and sections

A fter you've made a model, you're probably going to want to show it to
someone. How you present your work depends on the idea you're trying
to convey. The tricky part about using SketchUp to present a model isn’t
actually using the tools; it’s choosing the right tools to get your idea across
without distracting your audience with a bunch of extra information. Most 3D
models have so much to look at that the real challenge is to figure out a pre-
sentation method that helps you focus on the stuff you want to talk about.

In this chapter I talk about three different ways to show off your models with-
out ever leaving SketchUp. If you’'ve made a building, you can walk around
inside it. You can even walk up and down stairs and ramps — just like in a
video game. You can create animated slide shows by setting up scenes with
different camera views, times of day, and even visual styles. If you want to
talk about what’s inside your model, you can cut sections through it without
taking it apart.

As you're reading this chapter, keep in mind what you want your model to
communicate. Think about how you might use each method to make a differ-
ent kind of point, and think about the order in which you’d like those points
to be made. As with everything else in SketchUp (and in life, [ suppose), a
little bit of planning goes a long way. That said, presenting a model live in
SketchUp is undeniably sexy; you can’t really go wrong, so have fun.
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Exploring Your Creation on Foot
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Few experiences in life are as satisfying as running around inside your model.
After you’ve made a space, you can drop down into it and explore by walking
around, going up and down stairs, bumping into walls, and even falling off

of ledges. You can check to make sure that the television is visible from the
kitchen, say, or experience what it would be like to wander down the hall. In
a potentially confusing building (like an airport or a train station), you could
figure out where to put the signs by allowing someone who’s never seen your
model to explore the space “on foot.”

These tools were made for walking

A couple of tools in SketchUp are dedicated to moving around your model as
if you were actually inside it. The first step (no pun intended) is to position
yourself so that it seems like you're standing inside your model. This can be
tricky with just the Orbit, Pan, and Zoom tools, so SketchUp provides a tool
just for this: Position Camera. After you’re standing in the right spot (and at
the right height), you use the Walk tool to move around. It’s as simple as that.

The Position Camera and Walk tools get you walking around inside your
model.

Standing in the right spot: The Position Camera tool

The essence of the Position Camera tool is its ability to precisely place your
viewpoint in SketchUp in a particular spot. That’s really all it does, but it
works in two different ways. (See this book’s Web site at www . dummies . com/
go/SketchUpFD for more details.)

1+ 1 want to be standing right here. Choose Camera>Position Camera
from the menu bar and then click anywhere in the modeling window to
automatically position your viewpoint 5 feet, 6 inches above wherever
you clicked. Because this is the average eye-height of an adult human
being, the result is that you are, for all intents and purposes, standing on
the spot where you clicked; see Figure 10-1. After using Position Camera,
SketchUp automatically switches to the Look Around tool, assuming that
you might want to have a look around. I talk about Look Around in the
next section of this chapter.

You're not stuck being five-and-a-half-feet tall forever. After you use
Position Camera, type in the height you’d rather be and press Enter.
Type 18”to see a golden retriever’s view of the world, or type 7’ to pre-
tend you play for the L.A. Lakers. Keep in mind that the Measurements
box (the spot in the lower-right corner where numbers appear) displays
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your eye height as a distance from the ground, and not from whatever
surface you're “standing on.” To set your eye height to be 5 feet above a
platform that’s 10 feet high, you'd type in 15’.

1 want my eyes to be right here, and I want to be looking in this direc-
tion. Select Position Camera, click the mouse button while in the spot
where you want your eyes to be, drag over to the thing you want to
be looking at (you'll see a dashed line connecting the two points), and
release the mouse button (as shown in Figure 10-2). Try this technique a
couple of times; it takes a bit of practice to master. Use Position Camera
in this way if you want to stand in a particular spot and look in a particu-
lar direction. This technique works great with scenes, which I talk about
later in this chapter.

Figure 10-1:
Drop your-
self into
your model *
with the
Position
Camera tool.

Figure 10-2:
Aim your
view by
using
Position
Camera

in another
way.

Stepping out with the Walk tool

After you've used Position Camera to place yourself in your model, use the

Walk tool to move through it. (Again, find out more on this book’s companion
Web site.)

To walk around, click and drag the mouse in the direction you want to move:

v Straight up is forward.
v Straight down is backward.

v Anything to the left or right causes you to turn while you’re walking.
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The farther you move your cursor, the faster you walk. Release the mouse
button to stop. If you've ever played video games, you'll get used to it
quickly. If Scrabble is more your speed, it’'ll take a few minutes to get the
hang of things.

You can even use the Walk tool to walk up and down stairs and ramps. Keep in
mind that the highest step you can climb is 22 inches — anything higher and
you get the “bump” cursor, just like you walked into a wall. Also, if you walk
off a high surface, you’ll fall to the surface below. It’s times like these that I
wish SketchUp had cartoon sound effects. . . .

Using modifier keys in combination with the Walk tool makes SketchUp even
more like a video game:

v Hold down Ctrl (Option on a Mac) to run instead of walking. This might
be useful if you're trying to simulate what it would be like if a werewolf
were chasing you through your model.

+* Hold down Shift to move straight up (like you’re growing), straight down
(like you're shrinking), or sideways (like a crab).

v+ Hold down Alt (88 on a Mac) to disable collision detection, which allows
you to walk through walls instead of bumping into them. Burglars find
this handy for entering models without having to break any windows.

Stopping to look around

Look Around is the third tool in SketchUp that’s dedicated to exploring your
model from the inside. If using Position Camera is like swooping in to stand
in a particular spot, and Walk is like moving around while maintaining a con-
stant eye-height, Look Around is like turning your head while standing in one
spot. It’s pretty well named, I think; it does exactly what it says.

Using Look Around is so simple it hardly merits these steps:

1. Choose Camerar>Look Around.

2. Click and drag around in the modeling window to turn your virtual
head.

Don’t move too fast or you’ll strain your virtual neck, though. Just kidding.

While in any of the navigation tools, right-click to access any other navigation
tool; this makes switching between them a little easier.

When you use Look Around with the field of view tool I discuss in the next

section, you get a pretty darned realistic simulation of what it would be like
to be standing in your model.
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Figure 10-3:
The wider

your field [

of view, the
more you
can see.
|

Setting your field of view

Field of view is how much of your model you can see in your modeling
window at one time. Imagine your eyesight kind of like a cone, with the
pointy end pointing at your eyes and the cone getting bigger as it gets farther
away from you. Everything that falls inside the cone is visible to you, and
everything outside the cone isn’t.

If you increase the angle of the cone at the pointy end, the cone gets wider,
and you see more of what’s in front of you. If you decrease the angle, the
cone gets narrower, and you see less; see Figure 10-3.

Measured in degrees, a wide field of view means that you can see more of your
model without having to move around. The bigger the angle, the more you can
see. This comes in handy when you’re inside a SketchUp model you're working
on, because it’s hard to work on things you can’t see.

It’s a good idea to fiddle with your field of view while walking around inside
your model. Follow these steps to do so:

1. Choose Camerar>Field of View.

Notice that the Measurements box in the lower-right corner of your
modeling window says Field of View and that the default value is 35 deg.
This means that you currently have a 35-degree cone of vision, which is
kind of narrow.
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2. Type 60 and press Enter.

Your field of view is increased, and you now have a wider view of your
model. The trade-off is that you see more distortion at the edges of your
modeling window as more information is being displayed in the same
amount of space.

A good rule of thumb for setting your field of view is to strike a balance
between quantity and quality; a wider view always means more distortion. For
views of the outside of something I've built, I like to use a field of view of 35 to
45 degrees. For interior views, I use 60 or 70 degrees.

If you know something about photography, you can express field of view in
millimeters, just like you're using a camera lens. Typing in 28mm gives you a
wide-angle view, just like you're looking through a 28mm lens. For people who
think about field of view in these terms, this can be a lot more intuitive than
trying to imagine cones of vision.

Taking the Scenic Route

WMBER
@&
&

Wouldn't it be great if you could save a particular view of your model? And
wouldn’t it be even greater if that view could also save things like styles and
shadow settings? What if you could come back to any of these saved views
by clicking a button on your screen? What if this whole paragraph were just a
series of questions?

SketchUp scenes are (you guessed it) saved views of your model. It’s prob-
ably easiest to think of scenes as cameras, except that scenes can save much
more than just camera positions.

Although they don’t get a lot of space in this book (they don’t even get their
own chapter), scenes are one of the most important features in SketchUp, for
three reasons:

1 Scenes can save you hours of time. It’s not always easy to get back to
exactly the right view by using Orbit, Zoom, and Pan. Sometimes a view
involves shadows, styles, sections (you read about those later), and
even hidden geometry. It can be a pain to set up everything the way you
need it, every time you need it. It’s not that SketchUp’s hard — it’s just
that you have a lot of different ways to view your model. Making a scene
reduces the process of changing dozens of settings to a single click of
your mouse.

1 Scenes are by far the most effective way of presenting your model.
Saving a scene for each point that you’d like to make in a presentation
allows you to focus on what you're trying to say. Instead of fumbling
around with the navigation tools, turning on shadows, and making
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Figure 10-4:
| wanted to
show very
specific
views, so

| created
scenes.
|

the roof visible, you can click a button to transition to the next scene
(which you've already set up exactly the way you want it). Figure 10-4
shows a set of scenes I created to present a house I designed for my dog,
Savannah.

1 Scenes are the key to making animations. You make animations by cre-
ating a series of scenes and telling SketchUp to figure out the transitions
between them. The process, which is explained in later sections, is as
simple as clicking a button.

After you get used to them, you’ll find yourself using scenes all the time. Here
are some of the most common uses for scenes:

v Showing shade conditions for the same area at different times of the day

v Saving scenes for each floorplan, building section, and other important
view of your model

v Building a walk-through or flyover animation of your design

v Creating scenes to show several views of the same thing with different
options (the pointy roof or the flat one, Madam?)

v Demonstrating change over time by showing or hiding a succession of
components

Creating scenes

Let’s get one thing straight: Making a scene in SketchUp is not like taking a
snapshot of your model. If you create a scene to save a view, then do some
more modeling, and then return to that scene, your model will not go back to
the way it was when you created the scene. The camera position will be the
same and the settings will be the same, but your geometry won’t be. This is a
pretty important concept, and one that makes using scenes so powerful.
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When scenes and styles collide

Sooner or later, you'll be presented with the
Warning — Scenes and Styles dialog box
shown here. It pops up whenever you try to
create a scene without first saving the changes
you've made to the style applied to your model.
In other words, SketchUp tries to help out by
reminding you to keep styles in mind while
you're working with scenes. (The first part of
Chapter 9 is all about styles, just in case you
need a refresher.)

This warning dialog box gives you three
options; here’s some guidance on which one
to choose:

v~ Save as a New Style: Adds a new style
to your In Model styles library. When you
come back to this scene, it looks exactly the
way it did when you created it. Choosing
this option is the safest way to proceed
because it can't affect any other scene.

v~ Update the Selected Style: Choose this
option only if you know what effect this will
have on the other scenes in your model —

if the style you're updating is applied to any
of them, you'll affect the way they look. In
models with lots of scenes and styles, this
can have big implications.

Do Nothing to Save Changes: Creates
a scene with your current style applied,
completely ignoring any changes you may
have made to that style. When you come
back to this scene, it looks different than it
did when you created it. Only choose this
option if you really know what you're doing,
or if you enjoy doing the same thing more
than once.

Warning - Scenes and Styles

Warning! You are creating or updating a scene and have not
saved the changes you've made to your style.

What would you like to do with your style changes?
+ Save as a new style.
" Update the selected style.

" Do nothing to save changes.
’_

Create Scene Cancel

GMBER A scene is just a set of view settings, which means that they’re automatically
updated to reflect your changes every time you edit your model. You can
make some scenes and use them all the way through your process, from when
you start modeling to when you present your design to the president. Or to
your mother.

Creating scenes is a simple process. The basic idea is that you add a scene to
your SketchUp file whenever you have a view you want to return to later. You
can always delete scenes, so there’s no downside to using lots of them. Follow
these steps to make a new scene (and check this book’s companion Web site
for additional help):

®
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1. Choose Windowr>Scenes to open the Scenes dialog box.

When it first opens, it doesn’t look like there’s much to the Scenes dialog
box. Expanding it by clicking the expansion toggle in the upper-right
corner reveals more options, which [ cover in the next section, but don’t
worry about that right now.

2. Set up your view however you want.

Navigate around until you’re happy with your point of view. If you want,
use the Shadows and Styles dialog boxes to change the way your model
looks.

3. Click the Add button to make a new scene with your current view
settings.

At this point, a new scene is added to your SketchUp file. If this is the
first scene you've created, it will be called Scene 1 and will appear in two
places (see Figure 10-5):

® As alist item in the Scenes dialog box, right underneath the Add
button

¢ As a tab at the top of your modeling window, labeled Scene 1

@ BugBuggy 2.skp - SketchUp
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Scenes ]
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Figure 10-5: |
The scene
you just
added
shows up in
two places. .
| ] [Select start point Length
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QgN\BEH Nothing is generated outside of SketchUp when you add a scene; it’s not like
& exporting a JPEG or a TIFF. Scenes are just little bits of programming code that
“remember” the view settings in effect when they were created. Scenes also
don’t add much to your file size, so you don’t have to worry about using too
many of them.

Moving from scene to scene
Activate a scene you've added earlier by doing one of three things:

v Double-clicking the name of the scene in the Scenes dialog box.
v Clicking the tab for that scene at the top of the modeling window.

v Right-clicking any scene tab and choosing Play Animation to make
SketchUp automatically flip through your scenes. (Choose Play
Animation again to make the animation stop.)

Notice how the transition from one scene to the next is animated? You don’t
have to do anything special to make this happen; it’s something SketchUp
automatically does to make things look better (and ultimately, to make you
look better).

You can adjust the way SketchUp transitions between scenes, which is
handy for customizing your presentations. Follow these steps to access
these settings:

1. Choose Window="Model Info.

2. On the left side of the Model Info dialog box, choose Animation.

The Animation settings panel in the Model Info dialog box (see Figure
10-6) isn’t very complicated, but it can make a huge difference in the
appearance of your scene-related presentations.

Model Info B

I Animation Scene Transitions

Components

- Credits I Enabl transiti

Figure 10-6: | [Sncnmens shescene warstons

File 2 j seconds
The Location

. . Rendering Scene Delay
Animation sitsics —
settings | |unis | seconds
panelis a
big help in
customizing
your pre-
sentations.
|
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A really great way to use scenes is to pretend .~ Adjustyourfield of view. For interior anima-

you're walking or flying through your model. By tions, make your camera “see” a wider area
setting up your scenes sequentially, you can by setting your field of view to 60 degrees. |
give a seamless tour without having to mess like to set my field of view between 30 and
around with the navigation tools. This is espe- 45 degrees for exterior views, but there's
cially handy when you need to be able to “walk no hard and fast rule. | talk about how to
and talk” atthe same time. do this in the section “Setting your field of

Here are some tips that can help you to simulate
a person walking or flying through your model  »~ Make sure that your scenes aren’t too far
with scenes:

Chapter 10: Presenting Your Model Inside SketchUp 295

3. In the Scene Transitions area, set how SketchUp transitions from one

scene to another.

These settings apply to both manual (clicking a page tab) and automatic
(playing an animation) scene transitions:

¢ Enable Scene Transitions: Deselect this check box to make
SketchUp change scenes without animating the transitions
between them. You’'ll probably want to do this if your model is so
complex (or your computer is so slow) that animated transitions
don’t look good.

¢ Seconds: If you've selected the Enable Scene Transitions check
box, the number of seconds you enter here will be the amount of
time it takes SketchUp to transition from one scene to the next. If
you’re “moving the camera” very far between scenes, it’s a good
idea to bump up the transition time so that your audience doesn’t
get sick. I find three seconds to be a good compromise between
nausea and boredom.

If you're presenting an incomplete model (perhaps you’ve thought about
the garage and the living room, but nothing in between), it can be help-
ful to turn off scene transitions. That way, your audience won’t see the
things you haven’t worked on when you click a tab to change scenes. It’s
sneaky, but effective.

. In the Scene Delay area, set the length of time SketchUp pauses on

each slide before it moves to the next one.

If you want it to seem like you're walking or flying, set this to 0. If you
want time to talk about each scene in your presentation, bump this up a
few seconds.

Making walk-throughs

view,” earlier in this chapter.

apart. Instead of racing through a room
like it's on fire, don't be afraid to add more

(continued)
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(continued)

scenes. Your audience will thank you by not
throwing up on your conference table.

Add scenes at equal distance intervals.
Because SketchUp only lets you control the
scene transition timing for all your scenes
at once, it's best to make sure that your
scenes are set up about the same distance
apart. If you don't, your walk-through ani-
mations will be jerky and strange, like my
dancing.

Don’t forget the animation settings in the
Model Info dialog box. Set the scene delay
to 0 seconds so that your animation doesn’t
pause at every scene. For a normal walk-
ing speed, set your scene transitions so
that you're moving about 5 feet per second.
If your scenes are about 20 feet apart, set

your scene transition time to 4 seconds.
This gives your audience time to look
around and notice things. For flying anima-
tions, pick a scene transition time that looks
good.

Slide around corners. \When you're setting
up a walking animation, you have an easy,
reliable way to turn corners without seem-
ing too robotic. The method is illustrated in
the following figure. Basically, the trick is to
add a scene just short of where you want to
turn — in this case, a few feet ahead of the
doorway. The key is to angle your view into
the turn slightly. You should set up your next
scene just past the turn, close to the inside
and facing the new view. This technique
makes it seem like you're turning corners
naturally.

Modifying scenes after you've made ‘em

After you create a whole bunch of scenes, it’s inevitable that you're going
to need to fiddle with them in some way. After all, modifying something is
almost always easier than making it all over again, and the same thing holds
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Figure 10-7:
You can
modify
scenes

by right-
clicking
scene tabs
or by using
the Scenes
dialog box.
|
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true for scenes. Because your SketchUp model will change a million times,
understanding how to make changes to your existing scenes can save you a
lot of time in the long run.

Certain aspects of the scene-modification process can get a little tricky. This is
kind of surprising, given how simple the rest of working with scenes can be,
but I think it’s inevitable. You deal with a lot of complexity when working in
SketchUp, and this is just one of the places where that complexity rears its
ugly head. The upshot: Pay special attention to the section on updating
scenes, and don’t worry if it takes a little while to figure things out. It happens
to the best of us.

Reordering, renaming, and removing scenes

Making simple modifications to scenes, such as reordering, renaming, and
removing them, is easy. You can accomplish each of these in two ways: You
either use the Scenes dialog box, or you right-click the scene tabs at the top
of your modeling window. Figure 10-7 is an illustration.

7 BugBuggy 2.skp - T SEe|
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To access the modification controls in the Scenes dialog box, click the arrow-
shaped expansion button in the upper-right corner.
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Here’s how to reorder, rename, or remove scenes:

1 Reordering scenes: You can change the order in which scenes play in
a slide show. If you're using scenes, you’ll need to do this often — trust
me. Use one of the following methods:

¢ Right-click the tab of the scene you want to move (in the modeling
window) and choose Move Right or Move Left.

¢ In the expanded Scenes dialog box, click the name of the scene you
want to move to select it, and then click the up or down arrows
to the right of the list to change the scene’s position in the scene

order.
\‘&N\BER +* Renaming scenes: It’s a good idea to give your scenes meaningful
& names: “Living Room,” “Top View,” and “Shadows at 5:00 p.m.” are

descriptive enough to be useful. “Scene 14,” | find, lacks a certain je ne
sais quoi. Use one of the following methods:

¢ Right-click the scene tab and choose Rename.

¢ In the Scenes dialog box, select the scene you want to rename and
type something into the Name field below the list. If you're feeling
really organized, go ahead and give it a description, too — more
information never hurts.

+* Removing scenes: If you don’t need a scene anymore, feel free to delete
it. However, if you have a scene that you don’t want to appear in slide
shows, you don’t have to get rid of it. Use one of the following methods
to remove a scene:

¢ Right-click the scene tab and choose Delete to get rid of it
permanently.

¢ In the Scenes dialog box, select the scene you want to ax and click
the Delete button.

To exclude a scene from slide shows without getting rid of it, select its
name in the list and deselect the Include in Animation check box.

Working with scene properties

Okay. Turn off the television. Send the kids outside to play. Do whatever you
need to do to concentrate, because wrapping your head around the concept of
scene properties isn’t altogether straightforward. I do my best to explain it.

Basically, a scene is just a collection of saved viewing properties. Each of
these properties has something to do with how your model looks:

1+ Camera location: Camera location properties include the camera posi-

tion, or viewpoint, and the field of view. I discuss field of view earlier in
this chapter.
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+ Hidden geometry: Hidden geometry properties are really just one thing:
what elements are hidden and what elements aren’t. These properties
keep track of the visibility of the lines, faces, groups, and components in
your model.

v~ Visible layers: Visible layer properties keep track of the visibility of
layers in your model.

1 Active section planes: Active section plane properties include the vis-
ibility of section planes and whether they’re active. I talk about sections
in the last part of this chapter.

v~ Style and fog: Style and fog properties are all the settings in the Styles
and Fog dialog boxes, and there are a lot of them.

1 Shadow settings: Shadow settings properties include whether shadows
are turned on and the time and date for which the shadows are set. They
also include all the other settings in the Shadow Settings dialog box.

v Axes locations: Axes location properties are very specific. They keep
track of the visibility of the main red, green, and blue axes in your mod-
eling window. Because you’ll often want to hide the axes when giving a
presentation, these elements get their own properties.

Here’s the tricky part: You can have your scenes save (remember) any combi-
nation of the preceding properties — it’s not an all-or-nothing proposition.
Once the full impact of this information soaks in, you'll realize that this means
that scenes are much more powerful than they first appear.

By creating scenes that only save one or two properties (instead of all
seven), you can use scenes to do some pretty nifty things. Here are three of
my favorites:

v Create scenes that only affect your camera location, allowing you to
return to any point of view without affecting anything else about the way
your model looks (such as styles and hidden geometry).

v Create scenes that only affect styles and shadows, letting you quickly
change between simple and complex (hard on your computer) display
settings without affecting your camera location.

v Create scenes that have different combinations of hidden geometry to
look at design alternatives without changing your model’s style and
camera location.

The key to working with scene properties is the expanded Scenes dialog box,

visible in Figure 10-8. It’s really pretty simple, but folks who understand it are
few and far between. Prepare to join the informed minority.
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Figure 10-8:
Choose
which
scene
properties
to save

in the
expanded
Scenes
dialog box.
|

WING/
&

Scenes X,
®eC f£28

Scene 1
Scene 2

v Indude in animation

Name: | Scene 2
Description:

Properties [ Camera Location
SAVE: 15 Hidden Geometry
|v Visible Layers
[ Active Section Planes
[v Style and Fog
[v Shadow Settings
|v Axes Location

Follow these steps to set which properties a scene should save:
1. In the Scenes dialog box, select the scene whose properties you want
to fiddle with.

You don’t have to be viewing this scene when you edit it; you can edit
properties for any scene at any time.

2. If not already expanded, click the arrow button in the upper-right
corner of the Scenes dialog box.

3. Check the boxes next to the properties you want to save.

That’s it. You don’t have to click Save anywhere to make your changes
stick. A little anticlimactic, no?

Updating scenes

If you want to update (make changes to) an existing scene, you have a couple
of options:

v~ Update all of the scene’s properties at once, which is a piece of cake.

v Update the scene’s properties selectively, which is not quite as simple.
Read on for both sets of instructions.

Updating all the scene properties at once

The simplest way to modify a scene is to not worry about individual properties.
After you update a scene, you can’t use Undo to revert things back to the way

they were. Save your SketchUp file right before updating a scene and choosing
Filew>Revert if you don’t like how things turn out.
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If all you want to do is update a scene after you've made an adjustment to the
appearance of your model, you're in luck. Follow these steps:
1. Click the tab of the scene you want to update.
The tabs are at the top of the modeling window.

2. Make whatever styles, shadows, camera, or other display changes you
want to your model.

3. Right-click the current scene tab and choose Update.

Be careful not to accidentally double-click the tab or you'll reactivate the
scene and lose all the changes you made. The old scene properties are
replaced by the new ones, and you're home free.

Updating scene properties selectively

Here’s where things get complicated. At times in your SketchUp life, you’ll
want to update a scene without updating all its properties.

Updating scenes selectively involves making changes that you won'’t be able to
see immediately; whenever you do this, you have the potential for disaster to
strike. Copy your SketchUp file before updating more than one scene at a time,
just in case something awful happens.

Maybe you’ve used scenes to create a tour of the sunroom you’re designing
for a client, and you want to change the shadow settings to make your model
look brighter. You have 30 scenes in your presentation, and your meeting’s
in 5 minutes. You don’t have time to change and update all 30 scenes one at a
time. What to do? Follow these steps (and have a look at Figure 10-9):

1. Adjust the shadow settings to where you’d like them to be for all the
scenes you’d like to update.

While this example deals with shadows, this same method applies to any
scene properties changes you’d like to make.

2. In the Scenes dialog box, select all the scenes you’d like to update.
Hold down Shift to select more than one scene at a time.

3. Click the Update button in the Scenes dialog box.
A Properties to Update dialog box appears.

4. Select the Shadow Settings check box and click the Update button.

If all you want to update are the shadow settings, make sure that only
that check box is selected. More generally, you would select the check
box next to each of the properties you want to update. All the selected
scenes are updated with those new properties, and all the properties left
deselected remain unchanged.
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Figure 10-9:
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Mastering the Sectional Approach

Software like SketchUp has a funny way of providing moments of perfect sim-
plicity, moments when you sit back, scratch your head, and think to yourself,
“That’s it? That’s all there is to it?”

Sections in SketchUp offer one of those moments. To put it simply, sections
are objects that let you cut away parts of your model to look inside. You
place them wherever you need them, use them to create views you wouldn'’t
otherwise be able to get, and then delete them when you’re done. When you
move a section plane, you get instant feedback; the “cut” view of your model
moves, too. If you want to get fancy, you can embed them in scenes and even
use them in animations. Sections are the icing on the SketchUp cake: easy to
use, incredibly important, and impressive as all get out.

People use sections for all kinds of things:
v Creating standard orthographic views (like plans and sections) of build-

ings and other objects

v Making cutaway views of complex models to make them easier to
understand

v Working on the interiors of buildings without having to move or hide
geometry

v Generating sectional animations with scenes
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Cutting plans and sections

The most common use for sections is to create straight-on, cut-through views
of your model. Some of the views often include dimensions and are typical of
the kinds of drawings that architects make to design and explain space.

They’re useful because

v They’re easy to read.
» You can take measurements from them (if they’re printed to scale).

v They provide information that no other drawing type can.

The following terms (which are illustrated in Figure 10-10) can help you create
different views of your model more easily:

v Plan: A planimetric view, or plan, is a top-down, two-dimensional, non-
perspectival view of an object or space. Put simply, it’s every drawing
of a house floorplan you've ever seen. You generate a plan by cutting
an imaginary horizontal slice through your model. Everything below the
slice is visible, and everything above it isn’t.

v Section: Not to be confused with sections (the SketchUp feature about
which this section of the book is written), a sectional view, or section, is
a from-the-side, two-dimensional, nonperspectival view of an object or
space. You would make a section by cutting an imaginary vertical slice
through your model. Just like in a plan view, everything on one side of
the slice is visible, and everything on the other side is hidden.

You cut plans and sections by adding section planes to your model. These
are a little abstract, because nothing like them exists in real life. In SketchUp,
section planes are objects that affect the visibility of certain parts of your
model. When a section plane is active, everything in front of it is visible and
everything behind is hidden. Everywhere your model is cut by a section
plane, a slightly thicker section cut line appears.
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Cutting like an architect

In architecture, the convention is to cutplans at
a height of 48 inches, meaning that the imagi-
nary horizontal slice is made 4 feet above the
floor surface. This ensures that doors and most
windows are shown cut through by the slice,
while counters, tables, and other furniture are
below it, and thus are fully visible. You can see
what | mean in Figure 10-10. These things are
important when you're trying to explain a space
to someone. After all, architectural drawings
are two-dimensional abstractions of three-
dimensional space, and every little bit of clarity
helps.

When it comes to architectural sections (as
opposed to sections, the SketchUp feature),

there’s no convention for where to cut them, but
you should follow a couple of rules:

v Never cut through columns. If you show a
column in section, it looks like a wall. This
is bad, because sections are supposed to
show the degree to which a space is open
or closed. You can walk around a column,
but you can't walk through a wall (at least |
can't).

v+ Try your best to cut through stairs, ele-
vators, and other vertical circulation.
Showing how people move up and down
through your building makes your drawings
a lot more readable, not to mention interest-

ing. Figure 10-10 shows what I'm getting at.

<P If you're using Windows, open the Sections toolbar by choosing Viewr>
Toolbars=Sections. If you're on a Mac, the Section Plane tool is in the Large
Tool Set, which you can activate by choosing View=>Tool Palettes=>Large Tool
Set. On both platforms, Section Plane looks like a white circle with letters and
,\\\EWEB numbers in it.
//,,,ﬂ

e

To add a section plane, follow these steps:

SR ,,@

1. Choose Tools=>Section Plane to activate the Section Plane tool.

You can also activate Section Plane by choosing its icon from the Large
Tool Set (Mac) or the Sections toolbar (Windows), if you have it open.

2. Move the Section Plane tool around your model.

Notice how the orientation of the Section Plane cursor (which is quite
large) changes to be coplanar to whatever surface you're hovering over.
Check out Figure 10-11 to see this in action.

3. When you’ve figured out where you want it, click once to add a sec-
tion plane.

To create a plan view, add a horizontal section plane by clicking a hori-
zontal plane like a floor. For a sectional view, add a vertical section
plane by clicking a wall or other vertical surface. You can, of course, add
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section planes wherever you want; they don’t have to be aligned to hori-
zontal or vertical planes. Figure 10-12 shows a section plane added to a
model of a house.

ST
.// T—

P

Figure 10-11:
The Section
Plane tool
changes as
you move it
around your
model.
|

Figure 10-12:
Add a
section
plane
wherever
you want
one, and
then move
itinto
position.
|
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Figure 10-13:
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4. Choose the Move tool.

5. Move the section plane you just added by clicking it once to pick it up

and again to drop it.

You can only slide your section plane back and forth in two directions;
SketchUp only allows section planes to move perpendicular to their cut-
ting planes. When you're deciding where to locate your cut, the nearby
sidebar, “Cutting like an architect,” offers helpful pointers.

After you've added a section plane and moved it to the desired location,
you can rotate and even copy it, just like any other object in your model.
It will never affect your geometry — just the way you view it.

. If you need to rotate your section plane, select it and use the Rotate

tool.

Why rotate a section plane? In certain circumstances, rotating a sec-
tion plane (instead of creating a brand-new one) can help to explain a
complex interior space. Showing a plan view becoming a sectional one
is a powerful way to explain architectural drawings to an audience that
doesn’t understand them.

Read more about the Rotate tool in Chapter 6.

. To make a new section plane by copying an existing one, use the

Move or Rotate tool to do it the same way you would make a copy of
any other SketchUp object.

Chapter 2 explains these basic actions in detail.

Copying section planes is a great way to space them a known distance
apart; this can be trickier if you use the Section Plane tool to keep
adding new ones, instead.

Figure 10-13 shows moving, rotating, and copying a section plane.

When the section plane you've added is in position, you're ready to control
how it impacts visibility in a number of other ways. See the following sections
for details.
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Figure 10-14:
Right-
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a section
plane gives
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Controlling individual section planes

You can control the way section planes behave by right-clicking them to
bring up a context menu that looks like the one shown in Figure 10-14. I show
examples of what the following options do in the same illustration:

[% Entity Info
Erase Delete
Hide

Reverse

=" v Active Cut

Align View

Create Group from Slice

v Reverse: This option flips the direction of the section plane, hiding
everything that was previously visible, and revealing everything that
used to be behind the cut. Use this when you need to see inside the rest
of your model.

v Active Cut: Although you can have multiple section planes in your
model, only one of them can be active at a time. The active cut is the sec-
tion plane that is actually cutting through your model; others are consid-
ered inactive. If you have more than one section plane, use Active Cut to
tell SketchUp which one should be active.

You can have more than one active section plane in your model at a
time, but doing so requires that you nest, or embed, each section plane
in a separate group or component. It’s possible to achieve some pretty
spiffy effects with this technique, but I'm afraid [ don’t have room to
include more than this mention of it in this book. You can read all about
groups and components in Chapter 5.
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Figure 10-15: 7=
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v Align View: When you choose Align View, your view changes so that
you’re looking straight on at the section plane. You can use this option
to produce views like the ones that I describe in the section “Getting dif-
ferent sectional views,” later in this chapter.

v Create Group from Slice: This option doesn’t have much to do with the
other choices in this context menu; it’s really a modeling tool. You can
use this to do exactly what it says: create a group from the active slice,
or section plane. I don’t use this very often, but it comes in handy for
creating filled-in section cuts for final presentations.

Setting section-plane visibility
If you want to control the visibility of all your section planes at once, a couple
of menu options can help. You use both of these toggles in combination to

control how section cuts appear in your model. These two options, shown on
the View menu, are illustrated in Figure 10-15:

f8La0F e INAS B 0w

v Section Planes: This choice toggles the visibility of section-plane objects
without affecting the section cuts they produce. More simply, deselect-
ing Section Planes hides all the section planes in your model, but doesn’t
turn off the section cut effect, as shown in the middle image in Figure
10-14. This is how you’ll probably want to show most of your sectional
views, so this is a pretty important toggle.

1 Section Cut: Deselecting this option toggles the section cut effect on and
off without affecting the visibility of the section-plane objects in your
model. This choice is sort of the opposite of Section Planes, in the previ-
ous point, but it’s every bit as important.

Getting different sectional views

Using section planes, you can get a couple of useful and impressive views of
your model without much trouble. The second builds on the first, and both
are shown in Figure 10-16. A section perspective (left) is a special kind of way
to view a three-dimensional space. The second type, an orthographic view
(right), is straight on and doesn’t use perspective.
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Figure 10-16:
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Matking a section perspective

If you imagine cutting a building in half and then looking at the cut surface
straight on while looking inside, you have a section perspective. The section
part of the term refers to the fact that the building has been cut away. The
perspective part indicates that objects seen inside the space appear to get
smaller as they get farther away.

Section perspectives are a great (not to mention incredibly cool) way of show-
ing interior space in a way that’s understandable to most people. To create a
section perspective using the Section Plane tool in SketchUp, follow these
steps (and check out this book’s companion Web site at www . dummies . com/
go/SketchUpFD for additional help):

1. Select the section plane you’d like to use to make a section perspec-
tive by clicking it with the Select tool.

When it’s selected, your section plane turns blue, assuming that you
haven’t changed any of the default colors in the Styles dialog box.

2. If the selected section plane isn’t active, right-click and choose
Active Cut.

Active section planes cut through their surrounding geometry. If your
section plane is visible but isn’t cutting through anything, it isn’t active.

3. Right-click the selected section plane and choose Align View.

This aligns your view so that it’s straight on (perpendicular) to your sec-
tion plane.

4. If you can’t see your model properly, choose Camera~>Zoom Extents.

This zooms your view so that you can see your whole model in the
modeling window.
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Generating an orthographic section

Ever seen a technical drawing that included top, front, rear, and side views
of the same object? Chances are that was an orthographic projection, which
is a common way for three-dimensional objects to be drawn so that they
can be built.

Producing an orthographic section of your model is pretty easy; it’s only one
extra step beyond making a section perspective. Here’s how to do it:

1. Follow Steps 1-3 in the preceding section, as if you’re making a sec-
tion perspective.

2. Choose Camera>Parallel Projection.

This switches off Perspective, turning your view into a true orthographic
representation of your model. If you printed it at a specific scale, you
could take measurements from the printout.

To print a plan or section view of your model at a particular scale, have a look
at Chapter 12, where I explain the whole process.

Creating section animations with scenes

This is probably one of the most useful and impressive things you can do
with this software, but some people who have been using SketchUp for years
don’t know about it. The basic idea is that you can use scenes to create ani-
mations where your section planes move inside your model. Here are a few
reasons you might want to use this technique:

v If you have a building with several levels, you can create an animated
presentation that shows a cutaway plan view of each level.

v Using an animated section plane to “get inside” your model is a much
classier transition than simply hiding certain parts of it.

»* When you need to show the relationship between the plan and section
views for a project, using an animated section plane helps to explain the
concept of different architectural views to 3D beginners.

Follow these steps to create a basic section animation. A simple example is
illustrated in Figure 10-17 (and check out this book’s companion Web site for
additional help):

1. Add a section plane to your model.

[ give a complete explanation of how to create section planes in the sec-
tion “Cutting plans and sections,” earlier in this chapter.
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Figure 10-17:
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. Add a scene to your model.

Check out the section “Creating scenes,” earlier in this chapter, for a
complete rundown on adding scenes.

. Add another section plane to your model.

You can add another section plane in one of two ways:

¢ Use the Section Plane tool to create a brand-new one. This is
probably the easiest option, and it’s the one I recommend if you're
just starting out.

¢ Use the Move tool to copy an existing section plane. | talk about
copying section planes in the section “Cutting plans and sections,”
earlier in this chapter.

Make sure that your new section plane is active; if it is, it’ll be cutting
through your model. If it isn’t, right-click the section plane and choose
Active Cut from the context menu.

. Add another scene to your model.

This new scene remembers which is the active section plane.

. Click through the scenes you added to view your animation.

You should see an animated section cut as SketchUp transitions from
one scene to the next. If you don’t, make sure that you have scene transi-
tions enabled. You can verify this by choosing Window=>Model Info and
then choosing the Animations panel in the Model Info dialog box. The
Scene Transitions check box should be selected.

If you don'’t like being able to see the section-plane objects (the boxy things
with arrows on their corners) in your animation, switch them off by deselect-
ing Section Planes on the View menu. You should still be able to see your sec-
tion cuts, but you won’t see any ugly gray rectangles flying around.
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The hardest thing to remember about using scenes and section planes to
make section animations is this: You need a separate section plane for each
scene that you create. That is to say, SketchUp animates the transition from
one active section plane to another active section plane. If all you do is move
the same section plane to another spot and add a scene, this technique won’t
work. Believe it or not, it took me two years to figure this out, so don’t feel
dense if you need to come back and read this section a couple of times.
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Sharing What
You've Made

By Rich Tennant

The 5th Wave

“ Jeez-this Google Tarth just gets better and

better, doesn’t it3”
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suppose for some people in the world, 3D modeling is

an intensely private endeavor; they build something in
SketchUp, burn the SKP file to a disc, and then hide the
disc in the crawlspace under the house.

If you're not one of these people, you're probably looking
forward to doing something with the models you make —
printing them, making animations, and sending them to
other software programs. After all, for most folks,
SketchUp is just the beginning of a process that includes
lots of other steps.

The chapters in this part describe all the different things
you can do with your models after you build them.
Chapter 11 talks about using SketchUp with Google Earth.
Chapter 12 is about printing, and Chapter 13 describes the
process of exporting images and animations. Chapter 14 is
a quick overview of LayOut, the brand-new presentation
document design tool that comes with SketchUp 7 Pro.
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Working with Google Earth
and the 3D Warehouse

In This Chapter
Tying together all of Google’s 3D software

Poking around Google Earth
Building a model in SketchUp and sending it to Google Earth
Contributing to the 3D Warehouse

f you've ever used Google Earth, you know what it’s like to look up from

your computer and realize you just have no idea what time it is. There is
no better way to spend several hours than to travel to Paris, Cairo, and the
South Pole while checking out the peak of Mount Everest and looking at your
old elementary school along the way. I love Google Earth because it does
what Star Trek said computers are supposed to let us do — forget we're using
technology and explore information in a way we never could before.

What if you could see 3D models of buildings and other man-made structures
in Google Earth the same way that you can see aerial images and 3D topogra-
phy? You can. What if you could build your own models, in SketchUp, and see
them in Google Earth? You can do that, too. What if you could allow everyone
who uses Google Earth — there are hundreds of millions of them — to see
your models in their copies of Google Earth, no matter where they are? Now
you're getting the idea. . . .
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In this chapter, I talk about making SketchUp models that you and (if you
want) anyone else can see on Google Earth. [ also talk about the Google 3D
Warehouse: a great big, online repository of free 3D models that anyone
(including you) can contribute to or borrow from. It’s a big, friendly 3D world
out there, and this chapter is your Getting Started guide.

Getting the Big (3D) Picture

Okay. So there’s SketchUp, which (I have to assume) you're pretty familiar
with by now. Then there’s Google Earth, which you’ve probably seen and
which you probably think is pretty neat. Finally, there’s the 3D Warehouse,
which you might not know anything about — don’t worry about that. Here’s
the “lay of the land” when it comes to the relationship among these three
things and what they’re supposed to do:

v Google SketchUp: Because SketchUp is especially good for architec-
ture, you can use it to make buildings that you can look at in Google
Earth. If you want, you can also upload (send) what you make to the 3D
Warehouse, where anyone who finds it can download (borrow) your
model and use it in his or her own copy of SketchUp.

v Google Earth (http://earth.google.com): Earth is a software pro-
gram that lets you explore the world by “flying” around, zooming in on
things that interest you. The more you zoom, the better the detail gets;
in some places, you can see things as small as coffee cups. The imagery
in Google Earth is anywhere from a couple of weeks to four years old,
but it gets updated all the time. If you want, you can build models in
SketchUp and view them in Google Earth. You can also see models that
other people have made. Eventually, Google Earth will include entire 3D
cities, built in SketchUp by people all over the world.

v Google 3D Warehouse (http://sketchup.google.
com/3dwarehouse): The 3D Warehouse is a huge collection of 3D
models that lives on Google’s servers. The models all come from people
just like you and me; anyone can contribute models, and anyone can use
them in their own SketchUp projects. Some of the best models in the 3D
Warehouse are used in a special layer where anyone can see them while
they’re flying around in Google Earth.

If you're the kind of person who likes diagrams (I know I am), Figure 11-1

might help; it shows the SketchUp/Earth/3D Warehouse workflow in a non-
paragraphish way.
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Figure 11-1:
SketchUp,
Google
Earth, and
the 3D
Warehouse
are all
related.
|
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Taking the Ten-Minute Tour
of Google Earth

Google Earth is a pretty deep piece of software, not because it’s hard to use
(it’s not) but because you can use it to do an awful lot. 'm not even going to
try to explain it in this section; this is the “zooming past it in a speeding car”
tour that should be enough to get you started.
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Getting Google Earth

Here’s a piece of good news for you: Just like Google SketchUp, the basic ver-
sion of Google Earth is free. Why? My mother always told me not to look a
gift horse in the mouth, and Google Earth is the Secretariat of gift horses. All
that matters to me is that people with a computer that can run SketchUp can
also run Google Earth, and they don’t have to pay for it. Here are some more
things you need to know:

+» You get Google Earth by downloading it. Just go to http://earth.
google. com, click the Downloads link on the left, select your operat-
ing system, and then click the big Download button. While you’re there,
check out some of the other features of the site. You should be able to
find answers to any other questions you have, as well as links to online
help, user communities, and more. You can even find out about what
you get in the fancier versions of Google Earth, if that’s what floats
your boat.

+* You need a fast Internet connection. The magic of Google Earth is its
ability to show you detailed imagery of the whole world — that’s lots
and lots of data that Google keeps on its servers until you request it by
flying somewhere and zooming in. The faster your Internet connection,
the faster you can stream imagery, 3D buildings, and topography into
your copy of Google Earth. As you can imagine, Google Earth isn’t worth
a darn if you're not online.

+* You should clear your schedule. If this is the first time you’'ve used
Google Earth, don’t plan to do much of anything else for the next few
hours. It’s that much fun — and that addictive. If any geography nuts
reside in your household, you might need to buy another computer.

Getting your first dose

Google Earth can do a bunch of stuff, but the following sections describe the
first three things you should do with the software; have a look at Figure 11-2
for a view of the Google Earth user interface.

Flying around

Check out the upper-right corner of the screen; you'll find the navigation
controls for Google Earth conveniently grouped together. Notice how they
appear when you hover over them? Go ahead and play around to figure out
what they do. Here’s some help:
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Figure 11-2:
Google
Earthin all
its glory.

v Zoom: Move this slider back and forth to zoom in and out on whatever’s
in the center of your screen. As you approach the ground, you'll auto-
matically “pull up” to end up “standing” on your virtual feet. You can

also use the scroll wheel on your mouse to zoom, just like you do in
SketchUp.

+* Pan/Move: You can move around by clicking and holding down the
arrow buttons to go forward, backwards, left and right, but the easier
way is to use your mouse. Just click and drag to “spin” the world in
whatever direction you want.

v Rotate/Tilt: Drag the wheel to spin yourself around without moving.
Click the N button to reorient the world so that north is up. Click and
drag on the arrows in the center to turn and tilt your view (a lot like the
Look Around tool in SketchUp).

If you're looking at an area with mountains, they should look like a 3D
image (if they don’t, make sure that the Terrain layer is enabled in the
lower-left corner). You can also tilt by holding down your scroll wheel
button, the same way you do to orbit in SketchUp. (See Chapter 2 for
more on orbiting.)
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Going someplace specific

See the blank field in the upper-left corner that says “Fly To”? Go ahead and
type in an address anywhere in the world, and Google Earth will fly you
directly there. It works better for some places than others, but nobody’s
perfect. Here are some tips:

v Use the right format. If you're entering an address in the United States
or Canada, use this format: Street Number Street Name, Zip (Postal)
Code. Here’s an example: 1234 Cherry Blvd, 64254. If it doesn’t work the
first time, try a few variations.

v Type in landmarks. Try typing Eiffel Tower or Statue of Liberty. [ have
no idea how Google does this, but it just seems to work.

v Get directions. Click the Directions tab (also in the upper-left corner of
the screen), and then enter Origin and Destination addresses to see a
list of driving directions along with a colored path on the ground.

Making some placemarks

You can stick “pins” into Google Earth to mark locations you’d like to come
back to later; they’re called placemarks. Follow these steps to create one
yourself:

1. Fly to where you want to create a placemark.

2. Click the Create Placemark button at the top of the screen.

3. Move your placemark (it looks like a thumbtack) to exactly where you
want it (on top of your house, for instance).

4. Give your placemark a name in the Edit Placemark dialog box.
5. Click the OK button.

Your new placemark should show up in the Places section on the left of your
screen. No matter where you are in the world, double-clicking the name of
your placemark in the Places list will fly you right there.

Building Models for Google Earth

Google Earth is fun and all, but you're interested in SketchUp, right? What
you want to do is build a model of a building (maybe your house) and see
it in Google Earth. After you’'ve done that, you can e-mail the model to your
friends (or clients) so that they can see it in Google Earth, too. And if you're
especially proud of what you make, you can upload it to the 3D Warehouse
so that the whole world can see it.
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Figure 11-3:
Making a
SketchUp
model for

Google
Earthis a
four-step
process.

|

First things first. In this section, I talk about the basic procedure for making a
model in SketchUp and viewing it in Google Earth. I also provide some tips for
making buildings that are optimized for Earth; big models plus Google Earth can
equal sluggish (like molasses in January) performance, and no one wants that.

Understanding the process

Very simply, building SketchUp models for Google Earth involves the follow-
ing steps:

1. Choosing a site in Google Earth.
2. Importing the view into SketchUp.
3. Building a model using the imported view as a guide.

4. Exporting your model to Google Earth.

Simple, huh? Figure 11-3 is a handy diagram for the visually oriented among us.

Google Earth SketchUp SketchUp Google Earth

™

1)

Finding a site and bringing
it into SketchUp

Follow these steps to import a building site into SketchUp from Google Earth:

1. Launch Google Earth.

Make sure that you're online when you launch Earth; if you aren’t, you
won'’t be able to see much of anything.
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2. In Google Earth, navigate to the area where you want to place a
model.

It doesn’t really matter how you get where you’re going; the important
thing is to fill your Google Earth window with the area that you want to
import into SketchUp. Take a look at Figure 11-4 to see what [ mean.

I DS T p—r— ey [R—————

3. Launch SketchUp and open a new file.

SketchUp opens a new file every time you launch it, so this step is
pretty easy.

4. Choose Tools=>Google Earth=>Get Current View from the menu bar.

When you do this, SketchUp imports a “snapshot” of whatever is visible
in your Google Earth window when you choose Get Current View.

If you want to import another snapshot from Google Earth into SketchUp,
you can. SketchUp automatically tiles together all the snapshots you “take”
(by choosing Get Current View) in your modeling window to form a kind of
patchwork. This is super-handy if you find that you didn’t get everything you
needed the first time.

You should know that you must be relatively close to the ground to take a
snapshot; if you try to capture an area from too high up, things won’t work.
Also, wait until your Google Earth view is at least 95 percent loaded before
you can capture a snapshot in SketchUp. (Patience is a virtue, after all.) Just
watch the little Streaming readout at the bottom of your Google Earth window
to know when you’'ve waited long enough.
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Modeling on a Google Earth snapshot

Now that you’ve imported a snapshot from Google Earth, you can build a
model on it. To do this, just go about your SketchUp business the way you
always do — everything about SketchUp stays exactly the same, even after
you import a snapshot.

To follow the steps in this section, you need to know how to do some basics,
such as how to use the Line tool to trace a building’s footprint, work with the
drawing axes, and more. [ cover these basics in detail in Chapter 2.

Building on top of a snapshot 101

Here are the basic steps for building a model on top of your Google Earth
snapshot:
1. Make sure that you have a flat view of your terrain.

Choose Tools=>Google Earth=>Toggle Terrain a couple of times to figure
out which is the flat view, and then start from there.

2. Trace the footprint of the building you want to model on the imported
black-and-white image. See image A in Figure 11-5.

Of course, you're more than welcome to model something that doesn’t
exist yet; if that’s the case, feel free to draw anything you like.

A B

Figure 11-5:
Draw on

top of your |
flattened
Google
Earth
snapshot.
|
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Figure 11-6:
Move your
model up or
down until
it's sitting
properly on
the terrain.
|

If the building you're trying to make doesn’t line up perfectly with the
colored axes, using the Line and Rectangle tools can be tricky. To fix this
problem, reposition your main drawing axes by choosing Tools=>Axes.
Click once to set your origin, again to establish the direction of your red
axis (parallel to one of the edges in your photo), and a third time to
establish your green axis. I like to set my origin at the corner of the
building I'm trying to make; I think it makes things easier.

. Use Push/Pull to extrude the footprint to the correct height (see image

B in Figure 11-5).

4. Keep modeling until you’re satisfied with what you have.

. Flip to a 3D view of your terrain (choose Tools=>Google Earth=>

Toggle Terrain), and then move your building up or down until it’s
sitting properly (see Figure 11-6).

Select everything you want to move, and then use the Move tool to move
it up or down. You can press the up- or down-arrow key to constrain
your move to the blue axis if you want.

If you have a SketchUp model you’ve already built that you’d like to
export to Google Earth, just import it into the same file as your snap-
shot. Choose File>Import from the menu bar, find it on your computer,
and bring it on in.

Make sure your building pokes through the ground
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Figure 11-7: r

Use Toggle
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Earth
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Letting SketchUp take care of the details

My favorite part of the whole Google Earth import process is how much time
it saves. There’s a whole bunch of information already in Google Earth, and
SketchUp is smart enough to take advantage of it:

v SketchUp geolocates your position automatically. This means that it

sets your latitude and longitude to match Google Earth, and orients your
snapshot in the right cardinal direction. This means that any shadow
studies you do with the Shadows feature will automatically be accurate
for wherever you were in Google Earth when you took your snapshot.

v Everything’s already the right size. Perhaps you take a snapshot of a

football field in Google Earth; when you measure that football field in
SketchUp, it will be exactly 100 yards long. That’s because SketchUp
scales your snapshot to the correct size as part of the import process.

1 There’s more to snapshots than meets the eye. The snapshot that

SketchUp imports from Google Earth is more than just a black-and-white
aerial photo — it also includes a chunk of topography called terrain. The
terrain is flat when you first import it because it’s easier to build on that
way, but you can toggle between flat and 3D (not flat) views by choos-
ing Tools=>Google Earthe>Toggle Terrain. Don'’t fret if you don’t see any
difference when you flip between the views — you probably just chose
a flat site. Figure 11-7 shows the same snapshot with terrain toggled off
(top) and on (bottom).

Thinking big by thinking small

When it comes to modeling for Google Earth, lightness is next to godli-

ness. By light, I mean the file size of your model, and by file size, I mean the
number of faces and textures you use to build it. The more complicated your
model, the slower Google Earth will run, and the more likely you'll be to
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throw your computer through a window in frustration. Now more than ever,
think about how you can do the most with the least — geometry, that is.
Follow these tips:

v Get rid of extra geometry. Lots of times when you’re modeling, you end
up with edges (and even faces) that don’t have a purpose. Figure 11-8
shows a prime example of the kinds of little edges you can erase to dras-
tically reduce the number of faces in your model.

+* Reduce the number of sides in your extruded arcs and circles.
SketchUp’s default number of sides for circles is 24. This means that
every time you use Push/Pull to extrude a circle into a cylinder, you
end up with 25 faces: 24 around the sides and the original one on top.
Instead of using circles with 24 sides, reduce the number of sides by
typing a number followed by the letter s and pressing Enter right after
you draw a circle. For example, to draw a 10-sided circle (plenty for
Google Earth), follow these steps:

1. Draw a circle with the Circle tool.

2. Type 10s (this should appear in the lower-right corner of your
modeling window), and then press Enter.

The same thing goes for arcs; you change the number of sides in them in
exactly the same way. I like to use 10-sided circles and 4-sided arcs when
I’'m modeling for Google Earth. Figure 11-9 shows the same pipe con-
structed by using Follow Me on two circles: one with 24 sides and one
with only 10. Note the difference in the number of faces in each version.

1 When you can, use photo detail instead of geometry. This really only
applies if you’re mapping photos (or using SketchUp’s photo-matching
feature) on the model you're making for Google Earth. If you are, it’s a
good idea to make as basic a model as you can, and let the detail in the
photo “do the talking.” Resist the temptation to model windows and
doors. Figure 11-10 shows a model I built for Google Earth. The view on
the left shows it with photo textures visible; the version on the right is
just the simple geometry. Surprised? You can read all about how to use
photos to add detail to your models in Chapter 8.

v~ Limit the size of your photo textures. Be sure to take a look at the side-
bar “Photomodelers rejoice” in Chapter 8, for a rundown on some new
tools that Google introduced for SketchUp 7. Basically, photos that you
use to paint your models can be heavy, so you should make sure that
you’re only saving the parts of them that you need — pay special atten-
tion to the new Make Unique Textures command.
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Figure 11-8:
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Figure 11-10:
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Viewing your model in Google Earth

After you've made a model on top of a snapshot, it’s a simple operation to
send it over to your copy of Google Earth. And after you've done that, you
can save it as a Google Earth KMZ file and e-mail it to all your friends. If

you’re modeling for clients instead of friends, you can send it to them, too.

Exporting from SketchUp to Google Earth

This process is so simple you could probably figure it out while you're talk-
ing on the phone. Follow these steps to send your model from SketchUp to
Google Earth on your computer:

1. Choose Tools=>Google Earth=>Place Model.

Doing this sends everything in your modeling window (with the excep-
tion of the Google Earth snapshot) over to Google Earth. Your computer
should automatically switch you over to Google Earth and fly you in so
that you’re looking at your model (see Figure 11-11).

2. If you decide you want to make changes to your model, go back to
SketchUp, make your changes, and then choose Place Model again.

Google Earth pops up a dialog box that asks you whether you want to
overwrite the old version of the model you placed the first time.

3. Click the Yes button if you’re sure that’s what you want to do.

4. Continue to go back and forth between SketchUp and Google Earth
until your model looks exactly the way you want it to.
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Saving your model as a Google Earth KMZ file

You can save your SketchUp model as a Google Earth KMZ file that you can
send to anyone. When someone opens the KMZ file, Google Earth opens on
his computer (if he has Google Earth), and he is “flown in” to look at the
model you made. Try sending directions to your next party this way; your
friends will think you're related to Albert Einstein. Follow these steps to save
your model:

1. In Google Earth, select your model by clicking it in the Temporary
Places list on the left of the screen.

Unless you’ve renamed it yourself, your model is called SUPreviewl.
Click it once to select it.

2. Choose File~>Saver>Save Place As.

The Save File dialog box opens.
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3. Give your file a name and figure out where to put it on your hard
drive.

4. Click the Save button to save your model as a KMZ file.

Becoming a SketchUp All-Star
with the 3D Warehouse

If you've ever wondered where Google gets most of the realistic buildings
that show up by default on the 3D Buildings layer in Google Earth, you should
go take a look in the mirror. That’s right: Google’s strategy for building the
whole man-made world in 3D is to rely on SketchUp users everywhere to
model their local context. That’s the biggest reason that SketchUp is a free
program, and it’s a pretty revolutionary way to think about tackling a mas-
sive project: millions of people working together to provide accurate, current
information that can be used by anyone.

Getting to the Google 3D Warehouse

So how can you get your models into Google Earth so that everyone can see
them? To do that, you need to upload your work into the 3D Warehouse.
Residing wherever Google’s other jillions of bits of data do, the 3D
Warehouse is a huge collection of 3D models that is searchable and, most
importantly, free for everyone to use.

The 3D Warehouse is basically a Web site; it exists online, and you need an
Internet connection to access it. You can get there in two different ways:

v From SketchUp: Choose File>3D Warehouse=>Get Models; when you do,
a mini Web browser opens right in front of your modeling window. Voila!

+ From the Web: Browse to http: //sketchup.google.
com/3dwarehouse. This is a great way to hunt for 3D models without
having to open SketchUp first.

Go ahead and poke around the 3D Warehouse. It’s amazing what you’ll

find; thousands of people are adding new content every day. Most of it isn’t
very useful, but you'll still find plenty of interesting things to download

and look at. I don’t explain all the ins and outs of the 3D Warehouse in this
book because I think it’s pretty self-explanatory. However, if you need more
information, check out the online Help — it’s at the bottom of your browser
window when you're in the 3D Warehouse.
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Minding your modeling manners

People sometimes ask me if anyone at Google is
paying attention to what gets uploaded to the 3D
Warehouse. The answer to that question is a little
bit complicated. For instance, nobody at Google
minds if you refer to a Web site or enter tags that
don’t have anything to do with the model you
upload — stuff like that is entirely up to you.

On the other hand, it's very frowned upon to

public, G-rated Web sites: pornography and/or
foul language will sound an alarm somewhere
at Google that will get your model yanked off the
3D Warehouse quicker than you can say “First
Amendment.” Tens of thousands of impres-
sionable, young eyeballs peruse Google's Web
sites every day, so it behooves Google to keep
those sites clean. If you have kids, I'm sure you
understand.

go anywhere near the usual taboo subjects for

Uploading your models

You can break the models in the 3D Warehouse into two broad categories:

v Geolocated: Things like buildings, monuments, bridges, and dams exist
in a specific geographic location; they never move around. These are
the kinds of models that show up on the 3D Buildings layer in Google
Earth, and the 3D Warehouse is where they come from. To upload your
own geolocated models, you need to start with a Google Earth snapshot;
this provides the geolocation information that Google needs to put your
model in the right place. Check out the section “Building Models for
Google Earth,” earlier in this chapter, for a blow-by-blow account of how
to build geolocated models that you can upload to the 3D Warehouse.

1 Nongeolocated: Objects like toasters, SUVs, wheelchairs, and sofas
aren’t unique, and they don’t exist in any one geographic location. No
physical address is associated with a model of a Honda Accord because
millions of them exist, and because Honda Accords move around. Stuff
like this never shows up in Google Earth because the folks at Google
wouldn’t know where to put it. That doesn’t mean it doesn’t belong in
the 3D Warehouse, though; models of nongeolocated stuff are incredibly
valuable for people who are making their own SketchUp models. When I
modeled my house, I furnished it with couches, beds, and other models I
found in the Warehouse.

Follow these steps to upload your own model to the Google 3D Warehouse:

1. Open the model you want to upload in SketchUp.
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When it comes to getting your models accepted
into Google Earth’s 3D Buildings layer (so that
everyone in the world can see them), it helps
to know the reasons models sometimes get
rejected:

v~ Terrain problems: When the terrain you
import from Google Earth doesn’t cut it, you
might have to “build up” the terrain around
your building by modeling it in SketchUp.
When you do, make sure it's textured
with a good-quality aerial photograph that
matches (more or less) the existing imagery
in Google Earth. Also make sure to model
only what you absolutely need for your
building — if it's too big, it won't fly.

v~ There's already another model in Google
Earth: Before you submit your model for
consideration, check Google Earth to make
sure there isn't already a version of your
building on the 3D Buildings layer. If there
is, your model will need to be better than
what's already there in order to replace it.

+* Photo-texture problems: Use good photo-
graphs as textures when you're modeling,
and be sure to position them accurately.
Take a look at Chapter 8 for the whole
scoop.

v~ Scale and position problems: This might
seem obvious, but it's a common occur-
rence; if your model isn’t the same size as
it is in the aerial imagery in Google Earth, it
won't be accepted. It also needs to appear
inthe correct spot— right on top of its own
photo in Google Earth.

v+ Your building doesn’t exist: If the build-
ing you submit doesn’t appear in Google
Earth’s aerial imagery, chances are good
that it'll get the big thumbs-down. If it really

Making sure your models get accepted

does exist, include web links to images of
the building in its surroundings in the model
description when you upload it to the 3D
Warehouse. If it's still under construction,
include a link to somewhere on the web
that details when it's due to be completed.

Floating problems: This one's simple —
make sure your building isn't floating above
the ground in Google Earth. It should be
sunken into the ground just enough to
appear realistic.

Ads: You can't include ads or other visual
“spam” on your models. If the building has
a mural or a billboard on it, that's OK, but
the ad has to be part of the original photo
texture on the model — it has to be a part
of the structure in real life.

Too much stuff: Don’t include extras like
cars, trees, streetlamps, people, or any-
thing else that isn't a part of the building
when you upload it.

v Z-fighting: When two faces are in the plane,

they flash when you orbit your model. This
is called Z-fighting, and it's as common as
dirt. If you see this phenomenon, there's a
good chance you slipped up and chose Use
as Image instead of Use as Texture when
you imported the image into your model —
resulting in two co-planar faces. Check out
“Adding photos to faces” in Chapter 8 for
the right way to apply images when you're
modeling.

Your model’s too big: Take a look at
“Thinking big by thinking small,” earlier in
this chapter, for tips on minimizing the size
of what you make. Remember: In Google
Earth, smaller files are always better.
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2. Fiddle around with your view until you like what you see.

When you upload a model to the 3D Warehouse, SketchUp automatically
creates a preview image that’s a snapshot of your modeling window.

3. Choose File~>3D Warehouse=>Share Model.

A mini-browser window opens, and it shows the logon screen for the 3D
Warehouse. If you want to upload models, you need a Google account.
They’re free; you just need a valid e-mail address to get one. If you don’t
already have one, follow the on-screen instructions to sign up.

When you’re creating your Google account, be sure to type something in
where the system asks for a “nickname.” If you don’t, everything you
upload will be attributed to “Anonymous.”

4. Enter your Google account information and click the Sign In button.

5. Fill out the Upload to 3D Warehouse form as completely as you can:

Title: Enter a title for your model. If it’s a public building, you
might enter its name. Something like “Royal West Academy” would
do nicely.

Description: Models with complete descriptions are very popular
with people who are hunting around the Warehouse. Try to use
complete sentences here; the more you write, the better.

Tags: Type in a string of words that describe the thing you mod-
eled. The 3D Warehouse search engine uses whatever you enter
here to help people find your model. To increase the number of
people who see what you made, add lots of tags. If | were upload-
ing a modern coffee table, I'd enter the following tags: coffee table,
table, coffee, modern, living room, furniture, glass, chrome, metal,
steel. You get the idea — be exhaustive.

Address: This field only appears if your model is geolocated, mean-
ing that you started with a Google Earth snapshot. If you know the
physical address of the thing you made, type it in.

Google Earth Ready: You only get this option if your model is geo-
located. If your model is accurate, correctly sized, and in the right
location, and if you want it to be considered for inclusion on the
default 3D Buildings layer of Google Earth, select this check box. If
you do, the folks at Google will consider adding it to Google Earth.
Keep your fingers crossed!

Web Site: If you have a Web-site address that you’d like people
who view your model to visit, enter it here. For example, if your
model is a historic building, you might include the Web site that
provides more information about it.
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6. Click the Upload button to add your model to the 3D Warehouse.

If everything works properly, you should get a page with your model on
it, along with all the information you just entered. The words “Model has
been uploaded successfully” will be highlighted in yellow at the top of
your browser window. Congratulations — you’re now a member of the
worldwide 3D community.

<P You can’t upload just any old model to the 3D Warehouse, unfortu-
nately. At the time [ was working on this book, the maximum file size you
could upload was 10MB, which is actually pretty big. You can check
your model’s file size in Explorer (on a Windows machine) or in Finder
(on a Mac).
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Printing Your Work

In This Chapter

Printing views of your model

Figuring out the printing dialog boxes

Printing to scale

A\\S

A s much as everyone likes to pretend that we all live in an all-digital
world, the ugly truth is that we don’t. People use more paper now than
they ever have; I have a stack of junk prints on the coffee table in front of

me as I'm writing this. It’s not that I have anything against trees — it’s just
that printing is so satisfying. I love having something I can fold up and put in
my pocket, or stick to the fridge, or mail to my Luddite relatives. Computer
screens are nice, but in most people’s minds, paper is real.

In this chapter I talk about how to print views of your SketchUp model.
Because the Windows and Mac versions of this procedure are so different,
[ dedicate a whole section to each platform. The last part of this chapter is
devoted to scaled printing — a topic that can sometimes make experienced
architects nervous. SketchUp makes printing to scale a little harder than it
could be, but it’s still a whole lot better than drawing things by hand.

If you'’re using the Pro version of SketchUp, you can always use LayOut to
print views of your models. LayOut makes it a lot easier to make both scaled
and non-scaled prints; take a look at the last part of Chapter 14 for all the juicy
details.

Printing from a Windows Computer

It’s very easy to print from SketchUp, as long as you’re not trying to do any-
thing too complicated. By complicated, [ mean printing to a particular scale,
which can be a harrowing experience the first couple of times you attempt it.
Fortunately, printing to scale is something most people almost never have to
do, so I've included instructions for how to do it at the end of this chapter.
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Making a basic print (Windows)

Most of the time, all you need to do is print exactly what you see on your
screen. Follow these steps to do that:

1. Make sure that you have the view you want to print in your modeling
window.

Unless you’re printing to scale (which I cover in the last part of this
chapter), SketchUp prints exactly what you see in your modeling
window.

2. Choose File>Print Setup.

This opens the Print Setup dialog box, which is where you make choices
about what printer and paper you want to print to.

3. In the Print Setup dialog box (see Figure 12-1), do the following:
a. Choose the printer you’d like to use.
b. Choose a paper size for your print.

c. Choose an orientation for your print; most of the time, you’ll want
to use Landscape, because your screen is usually wider than it

is tall.
Print Setup [2]%]
Printer
Name: |Brother HL-52500N series x| Properties
Status Ready
Type: Brother HL-52500N series
Where:  USBOO1
| B
Figure 12'1: Paper Orientation
The Print Size: Letter - ' Porirait
Setup dia- Source: | Auto Select ~| " Landscape
log box in
WindOWS. Help Network... Cancsl
|
4. Click the OK button to close the Print Setup dialog box.
5. Choose FileoPrint Preview.
QWP This opens the Print Preview dialog box. As an exact copy of the Print

dialog box, Print Preview lets you see an image of what your print will
look like before you send it to a printer. Lots of trees will thank you for
saving paper by using Print Preview every time you print.
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6. In the Print Preview dialog box, do the following:

a. In the Tabbed Scene Print Range area, choose which scenes you’d
like to print, if you have more than one. If you need to, you can
read all about scenes in Chapter 10.

. Tell SketchUp how many copies of each scene you need.

. Make sure that the Fit to Page check box is selected.

Q. o T

. Make sure that the Use Model Extents check box isn’t selected.

[¢]

. Choose a print quality for your printout. (I recommend High
Definition for most jobs.)

N For a complete description of all the knobs and doohickeys in the Print

Preview and Print dialog boxes, have a look at the next section in this
chapter.

7. Click the OK button.

The Print Preview dialog box closes and you get an on-screen preview of
what your print will look like.

8. If you like what you see, click the Print button in the upper-left corner
of the Print Preview window to open the Print dialog box.

If you don’t like what you’re about to print, click the Close button (at the
top of the screen) and go back to Step 1.

9. In the Print dialog box (which should look exactly like the Print
Preview dialog box), click the OK button.

Your print job goes to the printer.

Decoding the Windows Print dialog box

Three cheers for simplicity! The Print Preview and Print dialog boxes in
SketchUp are exactly the same. Figure 12-2 shows the former, because that’s
the one I advocate using first every time, but the descriptions in this section
apply to both.

Printer

If you used the Print Setup dialog box first, you shouldn’t need to change any
of the settings in this section. If you want, from the drop-down list you can
choose which printer to use. If you know something about printers, you can
even click the Properties button to make adjustments to your printer settings.
(Because settings are different for every printer on Earth, that’s between you
and your printer’s user manual — I'm afraid I can’t be of much help.)
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Print Preview
Printer
Name: |Brother HL-5250DN series =l Properties
Status Ready
Tvpe: Brother HL-5250DN series
Where:  USBOD1
Comment:
Tabbed Scene Print Range Copies
" Cument view Number of copies: 1 3:
I " Scenes from: |1 to: |4 |jt||:lt|_
. A S |_37€| F
Figure 12-2:
The Print | | "=
R ¥ Fitto page ™ Use model extents
Preview o
dialog box | epitot I [rdes =]
in Windows. B8 il = =7 foom =
The Print
dia |Og —T‘fd otttz Prirt Quality [High Definition |
box looks (o0 sr
ikl f
exa Ctly o L ™ Use high accuracy HLR
the same. =
|

Tabbed Scene Print Range

Use this area to tell SketchUp which of your scenes you’d like to print, if you
have more than one. This option is really handy for quickly printing all your
scenes. Select the Current View option to only print whatever’s currently in

your modeling window.

Copies

This one’s pretty basic: Choose how many copies of each view you’d like to
print. If you’re printing multiple copies of multiple scenes, select the Collate
check box to print packets, which can save you from having to assemble
them yourself. Here’s what happens when you’re printing three copies of four
scenes:

v Selecting the Collate check box prints the pages in the following order:
123412341234.

v Deselecting the Collate check box prints the pages like this:
111222333444.

Print Size

This is, by far, the most complicated part of this dialog box; Print Size con-
trols how your model will look on the printed page. Figure 12-3 shows the
effect of some of these settings on a final print.
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My SketchUp screen

Fitto Page

Figure 12-3:
Different
Print Size
settings
applied to
the same
view in
SketchUp.
|
Fit to Page and Use Model Extents

The Print Size controls are as follows:

v~ Fit to Page: Selecting this check box tells SketchUp to make your printed
page look like your Modeling Window. As long as the Use Model Extents
check box isn’t selected, you should be able to see exactly what you see
on your screen — no more, no less.
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1+ Use Model Extents: [ have to admit that [ don’t like this option; I almost
never select it. All this does is tell SketchUp to zoom in to make your
model (excluding your sky, ground, watermark, and whatever else might
be visible on your screen) fit the printed page. If [ want this effect, I just
use choose Camera=>Zoom Extents from the menu bar before I print my
model; it’s easier, and I know exactly what I'm getting.

1 Page Size: As long as you don’t have the Fit to Page check box selected,
you can manually enter a page size using these controls. If you type in a
width or height, SketchUp figures out the other dimension and pretends
it’s printing on a different-sized piece of paper.

The Page Size option is especially useful if you want to make a big print
by tiling together lots of smaller pages. See the next section in this chap-
ter for more details.

v Scale: Here’s where it gets a little complicated. To print to scale, you
have to do two things before you go anywhere near the Print or Print
Preview dialog boxes:

e Switch to Parallel Projection mode.
e Make sure that you're using one of the Standard views.

Take a look at the section “Printing to scale (Windows and Mac),” later
in this chapter, for a complete rundown on printing to scale in SketchUp.

Tiled Sheet Print Range

Perhaps you're printing at a scale that won't fit on a single page, or you've
entered a print size that’s bigger than the paper size you chose in the Print
Setup dialog box. The Tiled Sheet Print Range area lets you print your image
on multiple sheets and then attach them together later. You can get posters
from your small-format printer!

Print Quality

To be honest, I think there’s a little bit of voodoo involved in selecting a print
quality for your image. What you get with each setting depends a lot on

your model, so you should probably try out a couple different settings if you
have time.

v Draft and Standard are really only useful for making sure your model
appears the way you want it to on the printed page.

v I recommend using High Definition first, then bumping up to Ultra High
Definition if your computer/printer setup can handle it.
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Other settings

You can control the following odds-and-ends settings in the Print Preview
dialog box, too:

v 2-D Section Slice Only: If you have a visible section cut in your model
view, selecting this check box tells SketchUp to only print the section
cut edges. Figure 12-4 shows what the same model view would look like
without (on the left) and with (right) this option selected. I use this to
produce simple plan and section views that I can sketch on by hand.

v Use High Accuracy HLR: The bad news is that  have no idea what HLR
stands for. The good news is that it doesn’t really matter. Selecting
this check box tells SketchUp to send vector information to the printer
instead of the usual raster data. (Check out Chapter 13 for a description
of what these terms mean.) Why should you care? Vector lines look
much smoother and cleaner when printed, so your whole model will
look better — with one condition: Gradients (those nice, smooth shad-
ows on rounded surfaces) don’t print well as vectors. If you have a lot of
rounded or curvy surfaces in your model view, you probably don’t want
to choose this option. Try a print both ways and choose the one that

<P looks better. Thank goodness for Print Preview, huh?

If your model view includes a sketchy edges style, don’t use high accuracy
HLR; you won'’t see any of the nice, sketchy effects in your final print.

Figure 12-4: L )
Printing I

only the 2-D
section slice
yields a sim-
ple drawing
that's

easy to
sketch over.
|

Printing from a Mac

If you're using a Mac, the printing story is a little simpler than it is for folks
who use Windows computers — but only by a little. The first part of the fol-
lowing sections lays out a procedure for generating a simple, straightforward
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Figure 12-5:
The Page
Setup dialog
boxona
Mac lets
you select

a printer, a
paper size,
and a page
orientation.

print of what you see in your Modeling Window. The second part could be
called “Gross anatomy of the Mac Document Setup dialog box”; this is where
I go into some detail about what each and every setting does.

Making a basic print (Mac)

Follow these steps to print exactly what you see in your Modeling Window
on a Mac:

1.

Make sure that your modeling window contains whatever you want to
print.
SketchUp prints exactly what you see in your Modeling Window, unless

of course you're printing to scale. This is considerably more compli-
cated, so I gave it a whole section at the end of this chapter.

. Choose Filez>Page Setup.

This opens the Page Setup dialog box, where you decide what printer
and paper size to use.

. In the Page Setup dialog box (see Figure 12-5), do the following:

a. Choose the printer you'd like to use from the Format For drop-
down list.

b. Choose a paper size for your print.

c. Choose an orientation for your print. I usually end up using the
second or third one (Landscape), because my Modeling Window is
usually wider than it is tall.

4. Click the OK button to close the Page Setup dialog box.

5. Choose File>’Document Setup.

This opens the Document Setup dialog box.

(=)

Settings: | Page Attributes 43

Format for: | 1950 m
Canon 1950

Paper Size: = US Letter ﬂ
8.50in x 11.00 in

3 )

Orientation ‘li‘ I -

Scale: 100 %
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6. In the Document Setup dialog box, make sure that the Fit View to Page
check box is selected.

Check out the next section in this chapter for a full description of what
everything does.

7. Click the OK button to close the Document Setup dialog box.
8. Choose File=>Print to open the Print dialog box.
9. In the Print dialog box, click the Preview button.

This generates an on-screen preview of what your print will look like on
paper.

10. If the preview suits you, click the Print button to send your print job
to the printer.

If you’re not happy with the preview, click the Cancel button and start
again at Step 1. Isn’t printing fun?

Deciphering the Mac printing dialog boxes

Because printing from SketchUp on a Mac involves two separate dialog
boxes, [ describe both in the following sections.

The Document Setup dialog box

You use the settings in the Document Setup dialog box (see Figure 12-6) to
control how big your model prints. Here’s what everything does:

v Print Size: This one’s pretty self-explanatory, but here are some details
just in case:

¢ Fit View to Page: Select this check box tells SketchUp to make
your printed page look just like your Modeling Window on-screen.
It’s really that simple.

<P ¢ Width and Height: If the Fit View to Page check box is deselected,
you can type in either a width or a height for your final print. This is
the way to go if you want to print a tiled poster out of several sheets
of paper; just enter a final size and you’ll have a poster in no time flat.

v~ Print Scale: Use these settings to control the scale of your printed draw-
ing, if that’s the kind of print you're trying to make. Because printing to
scale is a bit of an ordeal, I devote the last section of this chapter to the
topic. Refer to that section for a description of what these settings do.

1 Pages Required: This is really just a readout of how many pages you
need to print. If you have selected the Fit View to Page check box, this
should say 1. If your print won'’t fit on one sheet, it will be tiled onto the
number of sheets displayed in this section of the dialog box.
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|
Figure 12-6:
The Mac
Document
Setup

dialog box.
|

WMBER
@&
&

Print Size

@ Fit View to Page
Width: 10 11/16"
Height: 7 9/16"

Print Scale

1" In Drawing
2'95/16 In Model

Pages Required

1 Page

(Caneel)

The Print dialog box

The Print dialog box on the Mac is something of a many-headed beast; sev-
eral more panels are hidden underneath the Copies & Pages drop-down
list. Luckily, you only need to use two. Both are pictured in Figure 12-7 and
described in the following list:

v Copies & Pages panel: The controls in this part of the Print dialog box
are pretty straightforward; use them to tell SketchUp how many copies
and pages you want to print:

¢ Copies: If you're printing more than one copy of a print that
includes multiple pages, select the Collated check box to tell
SketchUp to print packets, which can save you from having to col-
late them yourself.

¢ Pages: If the Pages Required readout at the bottom of the
Document Setup dialog box said that you need more than one
sheet to print your image, you can choose to print all or some of
those pages right here.

1 SketchUp panel: You use the settings in this panel to control the final
appearance of your print:

¢ Print Quality: I usually set this to High, but the results you get
depend a lot on your printer model. In general, | avoid Draft or
Standard unless I'm just making sure my page will look the way [
want it to. If you have time, try both High and Extra High and see
which one looks the best.

¢ Vector Printing: When you select this option, SketchUp sends
vector (instead of raster) information to the printer. Have a look at
Chapter 13 for a description of these terms.

The upshot here is that vector printing makes edges look much
smoother and cleaner but does a lousy job on gradients (the shad-
ows on your curved surfaces). Use vector printing if your model
view is made up of mostly flat faces, but try printing both ways
(with vector printing on and off) to see which looks better.
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Figure 12-7:
The Copies
& Pages and
SketchUp
panels of
the Print
dialog box.
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If your model view includes a sketchy edges style, don’t choose
Vector Printing; you won’t see any of the nice, sketchy effects in
your final print.

¢ Line Weight: This option only works if you've selected the Vector
Printing check box. The number in this box represents the thick-
ness of edges in your print; any edges that are 1 pixel thick in your
model view will be drawn with a line as thick as what you choose
for this option. The default is 0.50 points, but feel free to experi-
ment to see what looks best for your model.

Choose another panel here.

Printer: 1950 3
Presets: Standard 3]
—— Copies & Pages ﬂ—
Copies: l| @Ca\lated
Pages: @ Al
CiFrom: 1 to: 1
Ei' ( PDF¥ .’! (" Preview _',l ( Supplies.. .‘! (" Cancel _',l
Printer: 950 ﬂ
Presets: Standard ﬂ
SketchUp N
Print Quality ﬂ ! Vector Printing
Line Weight 0.50 7| points
£5| ( poFv ) ( Preview ) ( Supplies.. b (" Cancel ) ¢ Print )

This doesn’t matter unless you're using Vector Printing.

Printing to a Particular Scale

Here’s where printing gets interesting. Sometimes, instead of printing exactly
what you see on your screen so that it fits on a sheet of paper, you might
need to print a drawing to scale. See the nearby sidebar “Wrapping your head
around scale” for more information about drawing to scale.
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Keep in mind that if you have SketchUp Pro, you can use LayOut to generate
scaled views of your model very easily. Take a look at Chapter 14 for more
information.

Preparing to print to scale

Before you can print a view of your model to a particular scale, you have to
set things up properly. Here are some things to keep in mind:

1 Perspective views can’t be printed to scale. If you think about it, this
makes sense. In perspectival views, all lines appear to “go back” into
the distance, which means that they look shorter than they really are.
Because the whole point of a scaled drawing is to be able to take accu-
rate measurements directly off your printout, views with perspective
don’t work.

1 Switch to Parallel Projection if you want to print to scale. [ know, |
know — this is the same as the last point. But it’s important enough that
[ figure it’s worth mentioning twice. To change your viewing mode from
Perspective to Parallel Projection, choose Camera=>Parallel Projection.
That’s all there is to it.

+* You have to use the Standard views. SketchUp lets you quickly look at
your model from the top, bottom, and sides by switching to one of the
Standard views. Choose Camerar>Standard and pick any of the views
except Iso.

Printing to scale (Windows and Mac)

The steps in this section allow you to produce a scaled print from SketchUp;
I give Windows instructions first, and then Mac. When the user-interface
elements are different for the two platforms, the ones for Mac are shown in
parentheses. Figure 12-8 shows the relevant dialog boxes for printing to scale
in Windows and on a Mac.

Before you begin, make sure that you’'ve switched to Parallel Projection and
that your view is lined up the right way. See the previous section of this chap-
ter for the lowdown on what you need to do to prepare your model view for
scaled printing. Follow these steps to produce a scaled print:

1. Choose File=>Print Setup (Page Setup).

2. Select a printer, paper size, and paper orientation.

3. Click the OK button.

4. Choose File>Print Preview (Document Setup).
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5. Deselect the Fit to Page (Fit View to Page) check box.

6. Windows: Make sure that the Use Model Extents check box is deselected.

Mac users don’t have this option.

7. Enter the scale at which you’d like to print your model view.

If I want to print a drawing at !/+~inch scale, I enter the following:

¢ 1 Inches into the In the Printout (In Drawing) box
¢ 4 Feet into the In SketchUp (In Model) box

If I want to produce a print at 1:100 scale, I enter the following:

¢ 1 m into the In the Printout (In Drawing) box
¢ 100 m into the In SketchUp (In Model) box

8. Take note of how may pages you’ll need to print your drawing.

If you're using Windows, you can check this in the Tiled Sheet Print

Range area of the dialog box. On a Mac, the number of pages you’ll need

appears in the Pages Required section of the Document Setup dialog

box. If you want to print on a different-sized piece of paper, change the
setting in the Print Setup (Page Setup) dialog box.

Chapter 12: Printing Your Work

Wrapping your head around scale

When you print to scale, anyone with a special
ruler (called a scale, confusingly enough) can
take measurements from your drawing, as long
as he or she knows the scale at which it was
printed. You can use three different kinds of
drawing scales:

Architectural: In the United States, most people
use feet and inches to measure objects. Most
architectural scales substitute fractions of an
inch for a foot. Three common examples of
architectural scales follow:

v '/,inch =1foot (1 inch = 2 feet)
v 'fsinch = 1foot (1 inch = 4 feet)
v 'fsinch = 1foot (1 inch = 8 feet)

Engineering: When it comes to measuring big
things like parcels of land and college cam-
puses, U.S. architects, engineers, and surveyors
still use feet, but they use engineering scales

instead of architectural ones. Three common
engineering scales follow:

v 1inch =20 feet
v 1inch =50 feet
v 1inch =100 feet

Metric: Outside of the United States, virtually
everyone uses the metric system. Because all
measurement is based on the number 10, metric
scales can be applied to everything from very
small things (blood cells) to very big things
(countries). Metric scales use ratios instead of
units of measure. Here are three examples:

v 1:10 (The objects in the drawing are 10 times
bigger in real life.)

+* 1:100 (The objects in the drawing are 100
times bigger in real life.)

v+ 10:1(The objects in the drawing are 10 times
smaller in real life.)
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Figure 12-8:
Setting up
to printat 1
inch =4 foot
(Yainch=1
foot) scale.
|

9. If you want to print your drawing on a single sheet and it won't fit, try
using a smaller scale.

Using the !/ inch = 1 foot example, try shrinking the drawing to %/is inch =
1 foot scale. To do this, enter the following:

¢ 3 Inches into the In the Printout (In Drawing) box
¢ 16 Feet into the In SketchUp (In Model) box

When you’re happy with how your drawing will print, click the OK
button.

10.

11. Perform the step based on your computer:

e Windows: If you like what you see in the Print Preview window,
click the Print button (in the upper-left corner) to open the Print
dialog box.

e Mac: Choose Filew>Print.

In the Print dialog box, click the OK button to send your print job to
the printer.

12.

Refer to this chapter’s “Making a basic print” section (for your operating
system) for the whole story on basic printing from SketchUp.

When printing to scale, don't worry about these numbers.

Print Preview
Prrter
Name: [Brpther HL-5250DMN series | Properties
Status:  Repcy
Type:  Brgfher HL-52500N series
Whers:  USBO0T
Comment:
Tabbed Scene|Pint Range Copies
2 Number of copies: =

£ i Print Size

m[ [T ET‘_I@ -

I™ Use model extents

Scale

in the printout [1 Inches =

I Fit View to Page

Prirtt Size
I Fitto page|

Width: 4'2 1/2"

Height: 2' 11 3/4"

Print Scale

|4 -
In SketchUp Feet =] 1 In Drawing
Tied Sheet Pirt i 4 In Model
:‘ SRS Print Gualiy [igh Definion._~
* Al r Pages Required
¢ Pages from: [1 s
g ™ Use high accuracy HLR 25 Pages
= (Cancel )

To printat 1inch =4 feet, you'll need 20 pages
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Chapter 13
Exporting Images and Animations

In This Chapter
Creating 2D views of your model as TIFFs, JPEGs, and PNGs
Learning about pixels and resolution
Making sure that you export the right kind of image
Exporting the kind of movie file you need

Wmt to e-mail a JPEG of your new patio to your parents? How about
a movie that shows what it’s like to walk out onto that new patio? If

you need an image or a movie of your model, forget about viewing or printing
within SketchUp. Exporting is the way to go.

SketchUp can export both still images and animations in most of the major
graphics and movie formats. Here’s the part that’s a little bit confusing:
Which file formats you can export depend on the version of SketchUp you
have. If you have regular ol’ Google SketchUp (the free one), you can create
raster image files as well as movies. If you've sprung for Google SketchUp Pro,
you can also export vector files and a whole bunch of 3D formats; I talk about
all of them in the online Bonus Chapter for this book. (See the Introduction
for details about what’s online and where to find it.)

In this chapter, I talk about the export file formats that are common to both
versions of Google SketchUp. Just in case you’re not familiar with the terms
raster and vector, 1 give brief definitions of each. Then I go into some detail
about the 2D raster image formats that you can create with SketchUp. I spend
the last part of this chapter talking about exporting animations as movie files
that anyone can open and view.

Exporting 2D Images of Your Model

Even though the free version of SketchUp can only export 2D views of your
model as raster images, I think it’s helpful to know a little bit about graph-
ics file formats in general. If you're already an aficionado about these sorts
of things, or if you're in a big hurry, you can skip ahead to the section
“Exporting a raster image from SketchUp.”
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If you have SketchUp Pro, you have a much better way to get images out of
SketchUp: LayOut. In fact, LayOut might even be able to replace whatever
application is the reason you're trying to export an image in the first place.
Take a look at Chapter 14 for the whole story.

Pictures on your computer are divided into two basic flavors: raster and
vector. The difference between these two categories of file types has to do
with how they store image information. Here’s the one-minute version:

1~ Raster: Raster images are made up of dots. (Technically, these dots are
called pixels, just like the pixels that make up images you take with a
digital camera.) Raster file formats consist of information about the loca-
tion and color of each dot. When you export a raster, you decide how
many dots (pixels) it should include, which directly affects how big it
can be displayed. SketchUp exports TIFF, JPEG, and PNG raster images;
the Windows version also exports BMPs, although that’s nothing to get
excited about. You can read more about raster images in the sidebar
“Understanding rasters: Lots and lots of dots,” later in this chapter.

v Vector: Vector images consist of instructions written in computer
code. This code describes how to draw the image to whatever software
is trying to open it. The major advantage of using vector imagery (as
opposed to raster) lies in its scalability — vectors can be resized larger
or smaller without affecting their image quality, while rasters lose qual-
ity if you enlarge them too much. The free version of SketchUp can
only export raster images, but SketchUp Pro can export vectors in both
PDF and EPS file formats; you can read all about it in the online Bonus
Chapter 1.

Exporting a raster image from SketchUp

The process of exporting a view of your SketchUp model is fairly straightfor-
ward. Depending on which format you choose, the export options are slightly
different, but I address all of them in this section.

Follow these steps to export a raster image from SketchUp:

1. Adjust your model view until you see exactly what you’d like to export
as an image file.

SketchUp’s raster image export is WYSIWYG — What You See Is What
You Get. Basically, your entire modeling window view is exported as

an image, so use the navigation tools or click on a scene to set up your
view. Use styles, shadows, and fog to make your model look exactly the
way you want it to. To change the proportions of your image, resize your
SketchUp window. Follow these steps to do so:
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1. Windows only: If your SketchUp window is full screen, click the
Minimize button in its upper-right corner.

2. Drag the Resize tab in the lower-right corner of your SketchUp
window until the modeling window is the right proportion.

In Figure 13-1, I want to export a wide view of a house I modeled, so |
adjust the proportions of my modeling window until things look right.

| & Cover House 12 for Export.skp - SketchUp B[]
File Edit View Camera Draw Tools Window Help

P ZBOC I GRBLXSF HZAR OO €Y

Wide Perspective |

Figure 13-1:
Adjust your

view and
your model-
ing window

until things
look the SketchUp Modeling Window

way you
want them
to in your
exported
image.
— Exported Image
<P You might be wondering whether everything in your modeling window
shows up in an exported raster image. The red, green, and blue axes
don’t, which is good, but guides do, which is usually bad. If you don’t
want your guides to be visible in your exported image, deselect Guides
in the View menu.
2. Choose Filew>Export=>2D Graphic.
This opens the File Export dialog box.
3. Choose the file format you’d like to use from the Format drop-down list.
<P Before you go ahead and choose JPEG by default, you should know that

this file type isn’t always the best choice. For a complete description of
each format (as well as recommendations for when to choose each), see
the section “Looking at SketchUp’s raster formats,” later in this chapter.
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4. Choose a name and a location on your computer for your exported
image.

5. Click the Options button.

This opens the Export Options dialog box, where you can control how
your image is exported. Figure 13-2 shows what this dialog box looks like
for each of SketchUp’s raster file formats.

6. Adjust the settings in the Export Options dialog box.

Here’s a description of what the settings do:

Use View Size: Selecting this check box tells SketchUp to export an
image file that contains the same number of pixels as are currently
being used to display your model on-screen. If you're just planning
to use your exported image in an e-mail or in an on-screen pre-
sentation (like PowerPoint), you select Use View Size, but it’s still
better to manually control the pixel size of your exported image.

If you'’re planning to print your exported image, don’t select this
check box — whatever you do.

Width and Height: When you don’t select the Use View Size
check box, you can manually enter the size of your exported
image. Because this process requires a fair amount of figuring,
I've devoted a whole section to it; take a look at “Making sure that
you’re exporting enough pixels,” later in this chapter, to find out
what to type into the Width and Height boxes.

Anti-alias: Because raster images use grids of colored squares

to draw pictures, diagonal lines and edges can sometimes look
jagged and, well . . . lousy. Anti-aliasing is a process that fills in the
gaps around pixels with similar-colored pixels so that things look
smooth. Figure 13-3 illustrates the concept. In general, you want to
leave anti-aliasing on.

Resolution (Mac only): This is where you tell SketchUp how big
each pixel should be, and therefore how big (in inches or centi-
meters) your exported image should be. Pixel size is expressed in
terms of pixels per inch/centimeter. This option is only available
when the Use View Size check box isn’t selected. Just as with the
Width and Height boxes, I go into a lot of detail about image resolu-
tion in the next section of this chapter.

Transparent Background (Mac only, not for JPEGs): Mac users
can choose to export TIFFs and PNGs with transparent back-
grounds, which can make it easier to “cut out” your model in
another piece of software. Exporting your image with a transparent
background is also a nice way to use image-editing programs like
Photoshop to drop in a sky and ground plane later on. It’s too bad
this isn’t available for Windows users; it’s a really handy feature.
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Figure 13-2:
The Export
Options
dialog boxes
for TIFFs,
PNGs, and
BMPs (left)
and JPEGs.

Figure 13-3:
Aview of the
same image
with anti-
aliasing off
(left) and on.
|

¢ JPEG Compression (JPEG only): This slider lets you decide two
things at the same time: the file size of your exported image and
how good the image will look. The two are, of course, inversely
related; the farther to the left you move the slider, the smaller your
file will be, but the worse it will look. I never set JPEG compression
any lower than 8 — my models take too long to build for me to
make them look terrible on export.

7. Click the OK button to close the Export Options dialog box.

8. Back in the File Export dialog box, click the Export button to export
your raster image file.

You can find your exported file in whatever location on your computer
you specified in Step 4. What you do with it is entirely up to you — you
can e-mail it, print it, or use it in another software program to create a
presentation.

Don’t be alarmed if the export process takes longer than you think it
should. If you're exporting a pretty big image (one with lots and lots of
pixels), the export will take a while. Take the opportunity to call your
mother — she’ll appreciate it.

Export JPG Options
Image Size
F : 5 ¥ Use view size
xport Image Options
£ LAl Width: |714 piels
Image Size
¥ Lse view size Height: [268 e
Width: [714 pixels Rendering
Height: [268 pixels v Anti-alias
JPEG Compression
Rendering Smaller ————————— | Batter
W Anti-alias file v e T auality
ok | Cancel | oK Concel |
Export Options for Export Options for JPEGs

TIFFs, PNGs, and BMPs

No anti-aliasing With anti-aliasing
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Looking at SketchUp's raster formats

So you know you need to export a raster image from SketchUp, but which
one do you choose? You have four choices in Windows; three of them are
available on the Mac. The following sections give you the details.

When you export a raster image, you're saving your current view in SketchUp
to a separate file somewhere on your computer. As a raster image, that file
consists of tiny, colored dots called pixels — more pixels than you can shake a
stick at. When you look at all the pixels together, they form an image.

Tagged Image File (TIFF or TIF)

TIFFs are the stalwarts of the raster image file format world; everyone can
read them and just about everyone can create them. TIFF stands for Tagged
Image File Format, but that’s hardly important. Here’s everything you need to
know about TIFFs:

+ When image quality is important, choose TIFF. Unless file size is a
concern (because, for example, you need to send an image by e-mail),
always export a TIFF if you need a raster image. For everything from
working in Photoshop to creating a layout in InDesign or QuarkXPress, a
TIFF can provide the image quality you need.

v~ TIFFs don’t compress your image data. That means they don’t introduce
any garbage like JPEGs do, but it also means that they’re really big files.

v~ Pay attention to your pixel count. If you're exporting a TIFF, you're
probably looking for the best image quality you can get. And if that’s
the case, you need to make sure that your TIFF is “big” enough — that it
includes enough pixels — to display at the size you need. Have a look at
the next section in this chapter for more information.

JPEG (or JPG)

JPEG stands for Joint Photographic Experts Group, which makes it sound
much fancier than it really is. Almost every digital image you've ever seen
was a JPEG (pronounced JAY-peg); it’s the standard file format for images on
the Web. Check out these JPEG details:

+* When file size is a concern, choose JPEG. The whole point of the JPEG
file format is to compress raster images to manageable file sizes so that
they can be e-mailed and put on web sites. A JPEG is a fraction of the
size of a TIFF file with the same number of pixels, so JPEG is a great
choice if file size is more important to you than image quality.

1+ JPEGs compress file size by degrading image quality. This is known as
lossy compression; JPEG technology basically works by tossing out a lot
of the pixels in your image. JPEGs also introduce a fair amount of pixel
garbage; these smudges are called artifacts, and they’re awful.
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v+ JPEG + SketchUp = Danger. Because of the way the JPEG file format
works, JPEG exports from SketchUp are particularly susceptible to look-
ing terrible. Images from SketchUp usually include straight lines and
broad areas of color, both of which JPEG has a hard time handling. If
you’re going to export a JPEG from SketchUp, make sure that the JPEG
Compression slider is never set below 8. For more details, see the sec-
tion “Exporting a raster image from SketchUp,” earlier in this chapter.

\NG/
S

Portable Network Graphics (PNG)

Hooray for PNG! Pronounced ping, this graphics file format is my hero.
Unfortunately, it isn’t as widely used as it should be. If  had my druthers (I
keep leaving them on the subway), every raster export from SketchUp would
be a PNG. Why? Because, at least as far as SketchUp is concerned, PNG com-
bines all the best features of TIFF and JPEG. Why don’t more people use PNGs?
Because standards are hard to change, and right now, it’s a JPEG world. PNG
details are as follows:

<MBER

1 PNGs compress image data without affecting image quality. As a [oss-
less compression technology, PNGs are smaller files than TIFFs (just
like JPEGs), but they don’t mess up any pixels (totally unlike JPEGs).
Granted, PNGs aren’t as small as JPEGs, but I think the difference in
image quality is worth a few extra bits.

v If you’re exporting an image for someone who knows a thing or two
about computers, choose PNG. The truth is, some software doesn’t
know what to do with a PNG, so there’s a risk in using it. If you plan to
send your exported image to someone who knows what he’s doing, go
ahead and send a PNG — he’ll be impressed that you're “in the know.” If
the recipient of your export is less technologically sophisticated, stick
with a JPEG or TIFF file; it’s the safe choice.

Understanding rasters: Lots and lots of dots

When you look at a photograph on your com-
puter, you're really looking at a whole bunch
of tiny dots of color called pixels. These are
arranged in a rectangular grid called a raster.
Digital images that are composed of pixels
arranged in a raster grid are called raster
images, or rasters for short. Have a look at the
first image in the figure below for a close-up
view of a raster image. Here are some things to
keep in mind about rasters:

v~ Rasters are everywhere. Almost every
digital image you've ever seen is a raster.
TIFF, JPEG, and PNG are three of the most
common raster file formats, and SketchUp
exports all of them.

v~ Rasters are flexible. Every two-dimensional
image can be displayed as a raster; a grid
of colored squares is an incredibly effective
way of saving and sharing picture informa-
tion. As long as you have enough pixels, any
image can look good as a raster.
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v~ Rasters take up a lot of space. If you think
about how rasterimages work, it takes a lot
of information to describe a picture. Digital
images are made up of anywhere from
thousands to millions of pixels, and each
pixel can be any one of millions of colors.
To store a whole picture, a raster image file
needs to include the location and color of
each pixel; the bigger the picture, the more
pixels it takes to describe it, and the bigger
the file size gets.

v~ Rasters are measured in pixels. Because
every raster image is made up of a specific
number of pixels, you use a raster's pixel
dimensions to describe its size. If | told you
that I'd e-mailed you a photograph that was
800 x 600, you could expect to receive a pic-
ture that is 800 pixels wide by 600 pixels tall.
(See the following figure.) Pixels don't have a

IndividuEI pixels

physical size on their own—they're just dots
of color. You determine a picture’s physical
size by deciding how big its pixels should be;
this is referred to as resolution, and is gen-
erally expressed in terms of pixels per inch
(ppi). Check out the section “Making sure
that you're exporting enough pixels,” later in
this chapter, for the whole scoop.

Why use pixels instead of inches or centimeters
to describe the size of a digital image? It all has
to do with how computer screens work. Because
not all screens display things at the same size,
it's impossible to predict how big an image will
look when it shows up on someone’s computer.
Depending on the person’s display settings, an
800-x-600-pixel image might be a few inches
across, or it might take up the whole screen.
Giving a digital image’s dimensions in pixels is the
only accurate way of describing how “big” it is.

600 pixels

800 pixels

The PNG file format wasn’t developed to replace JPEG or TIFF; it was sup-
posed to stand in for GIF (Graphics Interchange Format), which is a file type
that SketchUp doesn’t export. Without going into too much detail, folks use
JPEG for images like photographs and GIF for things like logos. Because

exported SketchUp views usually have more in common with the latter, PNG
(the replacement for GIF) is the better choice. So why can’t PNG replace JPEG
and TIFF? For most photographs (which are the majority of images on the
Web), JPEG is better than PNG because it produces smaller files, which in turn
yields faster load times when you're surfing the Internet. TIFF is more versatile
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Figure 13-4:
More pix-
elsyield a

much more

detailed
image.

than PNG because it supports different color spaces, which are important to
people in the printing industry. For reasons that are beyond the scope of this
book, that isn’t relevant to exports from SketchUp; PNG is still (in my opinion)
the best — if not the safest — choice.

Windows Bitmap (BMP)

Windows Bitmap, or BMP, files are old school; they can only be used on
Windows, and they’re big. If a BMP were a car, it would be the old, rusty van
in your parents’ garage. As you can probably guess, [ don’t recommend using
BMPs for anything, with a couple of exceptions:

+ To send your exported file to someone with a very old Windows com-
puter: If the person to whom you’re sending an exported image has a
Windows computer that’s more than about five years old, I suppose I'd
send him a BMP.

1 To place an image in an old Windows version of layout software: I
your layout person is using a copy of Word or PageMaker that’s a few
years old, he might need a BMP file.

Making sure that you're exporting
enough pirels

When it comes to raster images, it’s all about pixels. The more pixels your
image has, the more detailed it is, and the bigger it can be displayed or
printed. Figure 13-4 shows the same image three times. The first image is 150
x 50, meaning that it’s 150 pixels wide by 50 pixels high. The second image is
300 x 100, and the third is 900 x 300. Notice how the image with more pixels
looks a lot better? That’s the whole point of this section.

150 x 50 pixels

300 x 100 pixels

900 x 300 pixels
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Why not always export a truckload of pixels, just in case you need them?
There are two reasons:

v Image exports with lots of pixels take a long time to process.

v Raster images are very big files.
How many pixels you need to export depends on what you're going to use
the image for. Very broadly, you can do two things with your image:

v Display or project it on a screen, digitally

v Print it

In the next two sections, I talk about each of these possibilities in detail.

Exporting enough pixels for a digital presentation

If you plan to use your exported image as part of an on-screen presentation, it’s
helpful to know what computer monitors and digital projectors can display:

v The smallest, oldest devices currently in use have images that are 800
pixels wide by 600 pixels high.

v At the other end of the spectrum, high-end, 30-inch LCD monitors dis-
play 2560 x 1600 pixels.

So it stands to reason that if you're exporting an image that will be viewed
on-screen only, you need to create an image that’s somewhere between 800
and 2500 pixels wide. Table 13-1 provides some guidelines on image sizes for
different digital applications.

Table 13-1 Suggested Image Sizes for On-Screen Use
How the Image Will Be Used Image Width (pixels)

E-mail 400 to 800

Web site, large image 600

Web site, small image 200

PowerPoint presentation (full screen) 800 or 1024 (depends on projector)
PowerPoint presentation (floating image) 400

For images that will be shown digitally, leave the Resolution setting (in the
Export Options dialog box) at 72 pixels per inch. For computer monitors and
digital projectors, the image resolution is meaningless because the pixels in
your image correspond directly to the pixels on your screen; inches and centi-
meters don’t even come into play.
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Understanding resolution: Exporting images for print

&‘N\BEB Images that you want to print need to have lots more pixels than ones that are

& only going to be displayed on-screen. That’s because printers — inkjet, laser,
and offset — all operate very differently than computer monitors and digital
projectors. When you print something, the pixels in your image turn into
microscopic specks of ink or toner, and these specks are smaller than the
pixels on your computer screen. To make a decent-sized print of your
exported image, it needs to contain enough pixels per inch of image. An
image’s pixel density, expressed in pixels per inch (ppi), is its resolution.

What kind of resolution you need depends on three things:

v The kind of device you’ll be printing to: For home inkjet printers, you
can get away with a resolution of as little as 150 ppi. If your image will be
appearing in a commercially produced book, you need a resolution of at
least 300 ppi.

1 How far away the image will be from the audience: There’s a big dif-
ference between a magazine page and a trade-show banner. For close-up
applications, a resolution of 200 to 300 ppi is appropriate. Large graph-
ics that will be viewed from several feet away can be as low as 60 ppi.

v The subject matter of the image itself: Photographic images tend to
consist of areas of color that blur together a bit; these kinds of images
can tolerate being printed at lower resolutions than drawings with lots of
intricate detail. For images with lots of lines (like SketchUp models), it’s
best to work with very high resolutions — 300 to 600 ppi — especially if
the image will be viewed close-up.

Table 13-2 provides some guidelines for exporting images that will be printed.

Table 13-2 Recommended Resolutions for Prints

How the Image Will Be Used Image Resolution Image Resolution
(pixels/inch) (pixels/centimeter)

8.5-x-11 or 11-x-17 inkjet or 200 to 300 80to 120

laser print

Color brochure or pamphlet 300 120

Magazine or book (color and 300 120

shadows)

Magazine or book (line- 450 to 600 180 to 240

work only)

Presentation board 150 to 200 60 to 80

Banner 60 to 100 2410 40

www.it-ebooks.info


http://www.it-ebooks.info/

360 Part IV: Sharing What You've Made

A\\S

\\3

Keep in mind that the biggest raster image that SketchUp can export is 10,000
pixels wide or tall (whichever is greater). This means that the largest banner
image, printed at 100 ppi, that SketchUp can create is about 100 inches wide.
To make larger images, you need to export a vector file; check out the details
on exporting to vector formats with SketchUp Pro in Bonus Chapter 1, online.

Follow these steps to make sure that you're exporting enough pixels to be
able to print your image properly:

1. In the Export Options dialog box, make sure that the Use View Size
check box is deselected.

To get to the Export Options dialog box, follow Steps 1 through 6 in the
section “Exporting a raster image from SketchUp,” earlier in this chapter.

2. Decide on the resolution that you need for your exported image.
(Refer to Table 13-2.)

Keep the resolution in your head or scribble it on a piece of paper.

3. Decide how big your exported image will be printed, in inches or
“centimeters.

Note your desired physical image size, just like you did with the resolu-
tion in the previous step.

4. Multiply your resolution from Step 2 by your image size from Step 3 to
get the number of pixels you need to export:

Resolution (pixels/in or cm) x Size (in or cm) = Number of pixels

In other words, if you know what resolution you need to export, and
you know how big your image will be printed, you can multiply the two
numbers to get the number of pixels you need. Here’s an example: 300
pixels/inch x 8 inches wide = 2,400 pixels wide.

To export an image that can be printed 8 inches wide at 300 ppi, you
need to export an image that’s 2,400 pixels wide. Figure 13-5 gives an
illustration of this example.

SketchUp’s default setting is to make your exported image match the pro-
portions of your modeling window; that is, you can only type in a width
or a height, but not both. If you're on a Mac, you can manually enter both
dimensions by clicking the Unlink (which looks like a chain). You can
always click it again to relink the width and height dimensions later.

5. Type in the width or height of the image you’d like to export, in pixels.

It’s usually pretty hard to know exactly how big your image will be
when it’s printed, and even if you do, you probably want to leave some
room for cropping. For these reasons, | always add 15-25 percent to
the number of pixels I figure I'll need. If my image calls for 2,400 pixels, I
export 3,000 pixels, just to be safe.
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<P If you're on a Mac, things are a little easier because SketchUp’s design-
ers built a pixel calculator right into the Export Options dialog box. Just
enter your desired resolution in the appropriate spot, change the width
and height units from pixels to inches or centimeters, and type in your
desired image size. SketchUp does the arithmetic for you.

6. Click the OK button to close the Export Options dialog box.

8inches wide x 300 ppi = 2400 pixels

Figure 13-5:
To figure
out how
many pixels
you need
to export,
multiply the
resolution | g i
by the phyS- v Anti-alias
ical size. | ¢ ] Eacd

Export Image Options

Image Size

Making Movies with Animation Export

When it comes to having nerdy fun, I think exporting movie animations of
your SketchUp models is right up there with iPods and store-bought fire-
works. Like both of these things, what’s so great about animation export is
how easy it is to do. That’s not to say that animation and digital video are
simple topics — they’re not. It would take a freight elevator to move the
books that have been written about working with video on the computer, but
I'm going to keep it simple. Because you and I are primarily interested in 3D
modeling, what you find in the following sections are instructions for doing
what you need to do.
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Getting ready for prime time

The key to exporting animations of your SketchUp models is using scenes; if
you haven’t read it already, now’s the time to check out Chapter 10. Scenes
are saved views of your model that you can arrange in any order you want.
When you export an animation, SketchUp strings together the scenes in your
model to create a movie file that can be played on just about any computer
made in the last several years.

Follow these steps to get your model ready to export as an animation:

1.
2.

Create scenes to build the “skeleton” of your animation.

To adjust the animation settings in the Model Info dialog box, choose
Window=>Model Info and then select the Animation panel.

[ explain all the controls in the section about moving from scene to
scene in Chapter 10.

. Click the Enable Scene Transitions check box to tell SketchUp to move

smoothly from one scene to the next.

. Enter a transition time to tell SketchUp how long to spend moving

between scenes.

If your Scene Delay is 0 (below), you can multiply your transition time
by your number of scenes to figure out how long your exported anima-
tion will be.

. Enter a scene delay time to pause at each scene before moving on to

the next one.

If you plan to talk about each scene, use the scene delay time to pause
before each one. If your animation is supposed to be a smooth walk-
through or flyover, set this to 0.

. Adjust the proportions of your modeling window to approximate the

proportions of your movie.

Unlike SketchUp’s 2D export formats, the proportions of your exported
movie don’t depend on those of your modeling window; that is to say,
making your modeling window long and skinny won’t result in a long and
skinny movie. You choose how many pixels wide and tall you want your
movie to be, so to get an idea of how much you’ll be able to see, make
your modeling window match the proportions of your exported file

(4:3 is common for video formats). Have a look at Step 1 in the section
“Exporting a raster image from SketchUp,” earlier in this chapter, for
guidance on adjusting your modeling window.

. When your project is ready to go, move on to the next section to

export your animation.
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Exporting a movie

Fortunately, you have only one choice if you want to export a movie from
SketchUp. If you’re using Windows, you create an AVI file; Mac users create
QuickTime MOVs.

If you're paying close attention to the available file formats for exporting
movies, you'll probably notice three more choices in the drop-down menu:
TIF, JPG, and PNG. [ don’t go into detail about these formats for animation
(movie) export in SketchUp because you probably won’t need them; choos-
ing to export in any of these formats will give you a pile of image files that
each represent one frame in your animation. People who want to include their
SketchUp animation in a Flash file should take advantage of this option, but
explaining how to do so is beyond the scope of this book.

While exporting animations in SketchUp is a pretty simple operation, figur-
ing out how to set all the animation export controls can seem like landing
the space shuttle. What follows are step-by-step instructions for generating a
movie file; settings recommendations are in the next section.

Follow these steps to export a movie file from SketchUp:

1. Prepare your model for export as an animation.

See the section “Getting ready for prime time,” earlier in this chapter, for
a list of things you need to do before you export an animation.

2. Choose Filew>Export->Animation.
This opens the Animation Export dialog box.

3. Give your movie file a name, and choose where it should be saved on
your computer system.

4. Make sure that the correct file format is selected.

In the Format drop-down menu, choose AVI if you're using Windows and
QuickTime if you're on a Mac.

5. Click the Options button to open the Animation Export Options dialog
box. (See Figure 13-6.)

6. Adjust the settings for the type of animation you want to export.

How you set everything up in this dialog box depends on how you plan
to use the animation you end up creating. Check out the next section in
this chapter for recommended settings for different applications.

If you're working on a Mac, there’s an extra drop-down menu that you
might find helpful: Format includes a short list of uses for your anima-
tion. Choosing one automatically sets most of the controls for you,
though (as you see in the next section) you can improve things a bit by
making some of your own selections.
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7. Select the Anti-alias check box, if it isn’t already selected.

10.

Choosing this doubles the amount of time it takes for your animation to
export, but it makes your edges look much better in the final movie.

. Click the Codec button (Windows) or the Expert button (Mac).

This opens the Video Compression (Compression Settings on a Mac)
dialog box. (See Figure 13-7.) Choose the correct settings for the type of
animation you want to export, again referring to the next section of this
chapter for details about what the options mean.

. Click the OK button in the compression dialog box, and click the OK

button again in the Export Options dialog box.
This returns you to the Animation Export dialog box.

Check to make sure that everything looks right, and then click the
Export button.

Because exporting an animation takes a while, it pays to double-check
your settings before you click the Export button. When the export is
complete, you can find your animation file in the location you specified
in Step 3. Double-clicking it should cause it to open in whatever movie-
playing software you have that can read it. On Windows computers, this
is usually Windows Media Player; on Macs, it’s QuickTime.

Figuring out the Animation Export
options settings

As I said before, digital video is complicated. Lucky for us, you don’t really
have to know what everything means to export the right kind of movie; you
just have to know how to set up everything.
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What follows are a number of different things you might want to do with your
animation, and recommended settings for getting good results. Feel free to
experiment, but the following sections are a good place to start.

For sending in an e-mail

If you're going to e-mail someone an animation file, you have to make the file
as small as you can. These settings can help you do just that:

Width and Height

Frame Rate

Codec (Windows)

Compression Type (Mac)

Key Frame Every

Compression Quality (Windows)
Quality (Mac)

www.it-ebooks.info

160 x 120

10 fps

Indeo Video 5.10
H.264

24 frames

50

Medium


http://www.it-ebooks.info/

366 Part IV: Sharing What You've Made

A\

For uploading to YouTube

YouTube (www.youtube.com) is a video-sharing site that can host your ani-
mations for free. Once it’s on YouTube, you can link to your video and even
embed it on your own web pages. You need to keep two things in mind when
you're creating a video for YouTube: Videos need to be under 1GB in file size,
and they need to be under ten minutes in length. These settings will yield a
“YouTubeable” video:

Width and Height 640 x 480

Frame Rate 30 fps

Codec (Windows) Indeo Video 5.10
Compression Type (Mac) H.264

Key Frame Every 24 frames
Compression Quality (Windows) 50

Quality (Mac) Medium

For viewing on-screen (computer or projector)

If you plan to use your animation as part of an on-screen presentation (such
as with PowerPoint or Keynote), you probably want it to look good full-
screen. You'll probably be using a digital projector to present, and these
days, most digital projectors come in two resolutions: 800 x 600 and 1024 x
768. If you know the resolution of the projector you'll be using, you’re made
in the shade. If you're unsure, export at the lower pixel count, just to be safe:

Width and Height 800 x 600 or 1024 x 768
Frame Rate 15 fps

Codec (Windows) Indeo Video 5.10
Compression Type (Mac) H.264

Key Frame Every 24 frames
Compression Quality (Windows) 100

Quality (Mac) Best

You want your exported animations to look smooth — the transitions from
one frame to the next shouldn’t be jumpy or awkward. If your camera is cover-
ing a lot of ground (in other words, moving a large distance between scenes)
in a very short time, you might want to experiment with increasing your frame
rate to smooth things out. Doing so adds more frames between transitions,
which means the camera isn’t traveling as far between frames.
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For exporting to DU (for viewing on a TV with a DUD player)

If you need to export an animation that will be burned onto a DVD that will
(in turn) be played in a DVD player, you should go all-in on quality and file
size. The export process will take a long time, but you’ll get the best-looking
movie you can get. Try these settings first:

Width and Height 720 x 480
Frame Rate 29.97 fps
Codec (Windows) Full Frame
Compression Type (Mac) DV/DVCPRO
Compression Quality (Windows) 100

Quality (Mac) Best

Scan Mode (Mac) Interlaced
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Chapter 14

Creating Presentation Documents
with LayQut

In This Chapter

Finding out what LayOut is for

Figuring out where everything is (and what it does)
Looking at what makes LayOut unique

Building a simple presentation document from scratch

Printing and exporting your work

people who design things in 3D have to present their ideas to other people,
and most of the time they have to present in a 2D format. Creating these
presentations almost always involves the use of layout or illustration soft-
ware like InDesign, Illustrator, or QuarkXPress; these programs are great, but
they can be expensive and tricky to get the hang of, especially if you’re not a
graphic designer.

If you're lucky enough to have the Pro version of Google SketchUp 7, you
have access to a whole separate piece of software called Google SketchUp
LayOut, or LayOut for short.

LayOut is a program that lets you create documents for presenting your 3D
SketchUp models, both on paper and on-screen. LayOut was designed to be
easy to use, quick to learn, and tightly integrated with SketchUp. The people
who built it want you to use LayOut to create all your design presentations;
here are some examples of what you can make:

v Information sheets

v Storyboards

v Design packs

1 Presentation boards and posters

v Vector illustrations and diagrams

v On-screen, PowerPoint-style slide shows
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LayOut gives you the tools to create cover pages, title blocks, callouts, and
symbols — whatever you need to accompany views of your model. You

can create presentations that are just about any physical size, and you can
export them as PDF files or images to send to other people. Best of all, when
your design changes in SketchUp, you can easily update your model views in
LayOut to reflect the changes. If you make your living designing and present-
ing ideas in 3D, LayOut can save you boatloads of time.

In this chapter, I give a pretty high-level overview of what you can do with
LayOut — there’s a lot of information to convey, after all. I start out with a
couple of pages about the different things you can use LayOut to accomplish.
I follow that up with a quick tour of the LayOut user interface, explaining
where everything is and what it’s supposed to do. Next, I take you through
the process of creating a simple presentation drawing set from one of your
SketchUp models — not exhaustively by any means, but it should be enough
to see you through a tight deadline.

Getting Your Bearings

Even though LayOut comes with SketchUp Pro, it’s not just a SketchUp
feature — LayOut is a full-fledged, gets-its-own-icon program. As such,
LayOut has its own menus, tools, dialog boxes, and Drawing Window. A
couple of versions from now, LayOut will probably have its own For Dummies
book. (Maybe I'll even get to write it!)

Even though LayOut’s user interface is pretty standard, [ want to give you
a quick overview of the different elements. Knowing that it’s a lot like other
software you've used (including SketchUp) should help you come up to
speed quickly. Figure 14-1 shows the LayOut user interface. The following
sections explain the various parts in more detail.

Some menu bar minutiae

Just like almost every other piece of software in the universe, LayOut has a
menu bar. And just like SketchUp, you can use LayOut’s menu bar to access
the vast majority of its tools, commands, settings, and dialog boxes. Here’s a
brief description of each of LayOut’s nine menus:

v File: No big surprises here — you use the items in the File menu to
create new LayOut files, save and adjust settings for the document
you’re working on, export PDFs and images, and insert SketchUp and
other graphics files.
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v~ Edit: You use the items in the Edit menu to copy and paste, work with clip-
<P ping masks (LayOut’s version of cropping), and control object grouping.

In the Windows version of LayOut, the Edit menu includes Preferences,
which is where you can do some things to customize LayOut.

v View: Besides standard stuff like controls for zooming, the most inter-
esting item here is Start Presentation, which lets you view your LayOut
as a PowerPoint-style slide presentation.

v Text: Fifty bonus points if you can figure out what the items in the Text
menu are for — there’s nothing out of the ordinary here.

v Arrange: Because LayOut documents are basically well-organized col-
lections of images, inserted SketchUp models, text, and callouts, you
need to be able to control everything’s place on the page. In the Arrange
menu, you find commands for controlling the horizontal, vertical, and
stacking-order position of every element in your document, as well as
controls for telling LayOut what snap settings to use.

<P Stacking order refers to the fact that all elements on the same layer in
your document are either in front of or behind other elements. When
one thing is overlapping another, their stacking order determines which
one you see and which one is hidden.

Snap settings help you position elements on your page by making it
easier to line things up with a grid or with other elements. Depending
on what you're trying to do, you might choose to work with both kinds
of snap settings, just one, or none at all; I usually switch between them
while I'm working.

v Tools: Here’s where you find all of LayOut’s tools (big surprise); there
are a lot more of them than you think. Luckily, most are pretty special-
ized, so you don’t need to know them all before you get started.

1 Pages: Given the complexity of most of the software we all have to use,
it’s almost adorable how few items live in the Pages menu. Your LayOut
presentation can have many pages, and here’s where you add, delete,
duplicate, and move among them.

v Window: In the Window menu, you find links to all of LayOut’s dialog
boxes; take a look at the next section in this chapter for a rundown on
all of them.

v Help: Just like in SketchUp, the Help menu should be the first place you
go when you're stuck.

v LayOut (Mac only): The Mac version of LayOut includes a LayOut menu,
which is standard operating procedure for Mac applications. The impor-
tant thing in this menu is Preferences, which lets you set up the program
the way you want it.
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interface. $ 2 oo
Click to select tems to manipulate. Shift-click to extend selection. Click-... | 5T v =
Measurements box
QWP In both the Windows and Mac versions of LayOut, you can have more than

one document open at a time. On the Mac, separate files look just like they do
for other programs — they’re all in different windows. LayOut on Windows is
a little different, though: Your open files are displayed as tabs across the top
of your Drawing Window, a little bit like scenes are in SketchUp. This con-

fuses some people who think that the tabs represent pages. Now you know;
they don’t.

A dialog box discourse

You can find most of LayOut’s knobs and switches in its eight dialog boxes.
In Windows, most of LayOut’s dialog boxes are contained in a “tray” that
appears on the right side of your screen by default. On the Mac, your dialog
boxes float around willy-nilly, but you can snap them together if you want.
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Here’s a one-minute description of each:

v Colors: Just about all your LayOut documents will use color in some
way, so you'll need this dialog box most of the time. The nice thing
about Color is that it appears when you need it; clicking any color well
in LayOut pops it open (if it wasn’t already open).

To hide a dialog box without closing it, click its title bar once to mini-
mize it. Click again to see the whole thing.

v~ Shape Style: A lot of the graphic elements in your presentation can have
color fills and strokes (outlines). The Shape Style dialog box is where
you control the appearance of those fills and strokes. Check out the
options in the Start and End drop-down menus — you won’t find callout
styles like these in most other layout programs.

v SketchUp Model: The greatest thing about LayOut (at least with respect
to other software like it) is its ability to include 2D views of your
SketchUp models. In the SketchUp Model dialog box, you can control all
sorts of things about the way your placed SketchUp model looks, includ-
ing camera views, scenes, styles, shadows, scale, and fog. For folks
who spend a lot of time laying out presentation drawings that include
SketchUp models, the SketchUp Model dialog box is a godsend. In fact,
it’s so important that [ gave it a whole section in this chapter.

v Text Style: If you've ever used another piece of page layout or illustra-
tion software, you should be pretty familiar with what the Text Style
dialog box lets you do. You use it to control the font, size, style, color,
and alignment of text in your document.

1 Pages: You use the Pages dialog box to manage the pages in your docu-
ment. You can add, delete, duplicate, and rearrange them to your heart’s
content. The List and Icon buttons at the top let you toggle between
views of your pages; I prefer to use the former and give my pages mean-
ingful names as I work. The little icons on the right control visibility for
full-screen presentations.

v Layers: You can have multiple layers of content in every LayOut docu-
ment you create.

Use the Layers dialog box to add, delete, and rearrange layers in your
document. The icons on the right let you hide (and show), lock, and
share individual layers.

Shared layers are somewhat unique to LayOut; they let you automatically
place elements on more than one page. For more detail, see the section
“Simplifying Layout with Layers” later in this chapter.
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v Scrapbooks: This one’s a little trickier to explain; scrapbooks are unique
to LayOut, so you probably haven’t worked with anything like them
before. Scrapbooks are LayOut files that live in a special folder on your
computer system. They contain colors, text styles, and graphic elements
(like scale cars, trees, and people) that you might need to use in more
than one of your LayOut documents. To use something you see in a
scrapbook, just click it with the Select tool, and then click again in your
Drawing Window to stamp it in. You can also sample things like colors,
line weights, and text styles by clicking with any other tool.

v Instructor: The Instructor dialog box works just like it does in SketchUp;
it shows information on whichever tool you happen to be using. If you're
just starting out with LayOut, make sure that this dialog box is open.

Setting up LayOut preferences

In LayOut, as in SketchUp, you have two kinds of preferences to worry about:
those that apply to every LayOut document you work on and those that only
apply to the document you happen to be working on at the moment. Settings
for the former are made in the Preferences dialog box; controls for the latter
reside in Document Setup. The following sections describe what [ mean.

Preferences

The LayOut Preferences dialog box is made up of eight panels. You open it by
choosing Edit=>Preferences in Windows or LayOut=>Preferences on the Mac.
Here’s what you’ll find on each panel:

v~ Applications: Tell LayOut what programs you want to use to edit image
and text files when you right-click them (in LayOut) and choose Open
with Image (or Text) Editor from the context menu.

v+ Backup: Work smart by letting LayOut auto-save and create automatic
backups of your file. Here’s where you tell it how often to do so.

v~ Folders: Let LayOut know where to look for the templates and scrap-
books on your computer. Templates show up when you start LayOut or
open a new document; scrapbooks appear in the Scrapbook dialog box.

v General: The Auto Render check box in this panel is handy if you're
working with big SketchUp models that take a long time for LayOut
to process while you're working. Deselect it to speed things up while
you’re roughing things out.

” Presentation: Decide where to display your full-screen presentation
when you’re in Presentation Mode.
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v Scales: You can choose from this list of scales for a SketchUp model
view you've placed in your LayOut document. If you want to use a
certain drawing scale and it doesn’t show up in the Scales pane of the
SketchUp Model dialog box, feel free to add it here. This is not the draw-
ing scale for the document you’re currently working on, so don’t worry
about that.

v~ Shortcuts: Just like SketchUp, you use this panel to define a keyboard
shortcut for any tool or command in LayOut.

v~ Startup: In this panel, tell LayOut how to behave every time you launch
it (or just start a new file).

Document Setup

The Document Setup dialog box includes five panels. You open it by choosing
File>Document Setup in the menu bar. Here’s the skinny on each panel:

v General: Feel free to enter information about yourself and your docu-
ment; this might be important if you’re working on a team.

v Grid: Nothing beats a grid for helping to line up elements in your pre-
sentations. Use the options in this panel to control the visibility and size
of the grid in your document, if you want one. For Major Grid, type in an
interval for the darker grid lines. For Minor Grid, enter the number of
divisions between dark lines you’d like to have. For !/~inch squares, you
would enter 1 inch for the former and 4 for the latter.

1 Paper: Here’s where you tell LayOut the size and color of the sheet of
paper you’d like to use for your document. The Rendering Resolution
part of this panel is new for SketchUp 7, and it’s great. If you're work-
ing with inserted SketchUp models of any complexity, set “Edit Quality”
to Low until you're ready to preview your document. Only set “Output
Quality” to High if you need to print or export documents that are small
enough to pass around at a meeting.

1 References: When you insert a SketchUp model or an image in your
LayOut document, LayOut creates a file reference that keeps track of
where it came from.

If you edit the original file (which you probably will), this panel lets you
know whether LayOut is showing the most currently saved version. For
people who go back and forth between design and presentation docu-
ments a lot (sound familiar?), the References panel is a gift from the
heavens.

v Units: Depending on where you live and work, you might use a different
system of measurement. Use the Units panel to pick the right one for
your workflow.
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Switching to LayQOut from similar software

If you're used to using other page-layout or
illustration software, some things about LayOut
are useful to know when you're just getting
started. The folks who designed LayOut did
things a little differently on purpose, hoping to
do for page layout in 2007 what they did for 3D
design seven years earlier— make it easier for
motivated people with no experience to pro-
duce good work, quickly.

Here, | point out the five things you should keep
in mind when you're exploring LayOut:

v LayOutincludes templates that help you get
up and running in no time. See the nearby
section “Starting out with templates” for
details.

v You caninsert models from SketchUp, skip-
ping the process of exporting your model
as an image file. Importing has the added
benefit of helping you automatically update
model views in your presentation. See the

section “Bringing in Everything You Need,”
later in this chapter, for details.

The Layers feature in LayOut is a powerful
tool for organizing your content. In particu-
lar, you can place content that appears on
more than one of your pages on a shared
layer, so you only have to position it once.
The section “Simplifying Layout with
Layers” later in this chapter outlines just
what you need to know.

In LayOut, you have enormous flexibility to
crop images, including model views, with
ease using clipping masks. The section
“Cropping with clipping masks,” later in this
chapter, explains how in four easy steps.

When your presentation is ready to go,
LayOut enables you to set up digital slide
shows in full-screen mode, as well as to
create printouts and PDF files.

Tooling around

LayOut has lots of tools, but as with most software, you spend most of your
time with only a handful of them. You can find the complete list in the Tools
menu, but it’s easier to get at them on the toolbar. This strip, across the top
of your Drawing Window, includes icons for the most commonly used tools
(and commands), but you can easily add others if you want to. Here’s a bullet
point on each of the tools in the LayOut toolbar’s default set. See Figure 14-2,
which shows the toolbar for the Windows version of LayOut.

v Select: Select, rotate, move, copy, and scale elements in your document.
Double-click to edit text and SketchUp model views.

v Line: Draw a straight line by clicking to define start points and end-
points. Draw a curved line by clicking and dragging to define your line’s
curvature. Press Esc to stop drawing a line.
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v Arc: Draw an arc by clicking once to define the arc’s center point, again
to start the arc (which defines its radius), and a third time to end the arc.

1 Rectangle: Draw a rectangle by clicking to define opposite corners. If
you’re drawing a rectangle with rounded corners or sides, you can use
the up- and down-arrow keys to adjust the amount of rounding.

v Circle: Draw a circle by clicking once to define a center and again to
define a radius.

v Polygon: Draw polygons by first entering a side count and then using
your mouse. Select the Polygon tool, type the number of sides followed by
the letter s (8s for an octagon), and then press Enter. Now click once with
your mouse to define a center point and again to draw the shape. Whew.

v Text: Draw an empty text box into which you can enter text. If you need
to edit text you've already typed, double-click it with the Select tool or
the Text tool.

Here’s a neat shortcut: You can tell a text box about the alignment of the
text it will contain by changing the way you draw it. Draw your text box
from left-to-right to specify left-justified text or right-to-left for right-justi-
fied. Even handier, hold down Control (Option on a Mac) to draw a text
box with text that is centered both horizontally and vertically.

v Label: Draw a text label with a leader line by clicking to define the end of
the line (where it’s pointing), clicking again to define the beginning, and
then typing in some text.

v Erase: Click or drag over any unlocked elements to erase them.

v~ Style: Click any element to sample (soak up) its fill, stroke, and other
attributes. Doing so turns the tool into the Bucket, which you use to apply
those attributes to other elements in your document by clicking them.

v~ Split: Cut one line segment (whether curved or straight) into two by
clicking where you want the split to occur. Turning Object Snap on (in
the Arrange menu) is very helpful for splitting shapes at their corners.

v Join: Turn two line segments (curved or straight) into a single one by
clicking each in turn. Both are highlighted blue when they’re joined.

1~ Start Presentation: Enter full-screen Presentation Mode.

1 Add Page: Add a page after the one you're on.

v Previous Page: View the previous page in your document.

1 Next Page: View the next page in your document.
Adding more tool icons to your toolbar is easy; just right-click the toolbar and
choose Customize to bring up the Customize dialog box. Now drag tool icons

up into your toolbar. If you're on Windows, you have to select the Command
tab first.
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Watch those defaults

All of LayOut's drawing and text tools come “out
of the box” with a default setting, depending on
the template you're using. For example, the Line
tool might be set to create a single-pixel black
line with a white shape fill. The Text tool might
be configured to create 10-point Verdana. Tools
automatically use the settings that were applied
the last time they were used.

It's easy enough to change the default settings
for your tools. Just follow these steps:

1. Click the tool icon you want to use.

2. In the Shape Style or Text dialog box,
choose the settings you want to use.

3. Draw or type to use the new settings.

Here's the thing: Changing the default settings
in one LayOut file doesn’t change them for other
files. Tool defaults stick to particular docu-
ments. If you want to change the default set-
tings for every new document you create, you
need to create your own template. Learn about
how to do that in “Starting out with templates,”
later in this chapter.

Figure 14-2:
The default
toolbarin
LayOut. You
can custom-
ize itif you
want to.
|
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Circle Start Presentation

Getting Set Up

Every time you launch LayOut, and every time you choose Filec>New, a dialog
box asks how you want to start out. (See Figure 14-3.) If you don’t see the dialog
box, you can switch it on in the Startup panel of the Preferences dialog box.

The theory is that when you open most programs, you usually want to do one
of two things:

1~ Start a new document: The New tab at the top of the dialog box

presents you with a list of templates that come preloaded in LayOut.
There’s nothing special about these templates — they’re just ready-
made LayOut files you can use as a starting point for your presentation.
Expand the items in the list on the left to see the available templates by
category.
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Figure 14-3:
The Getting
Started
dialog box.
|

+* Open a document you’ve already started: Click the Recent tab at the
top of the dialog box to show a list of LayOut files you've worked on
most recently. Select one and click the Open (Choose, on a Mac) button
to open it. To open an existing document that doesn’t appear in the
Recent list, click the Open an Existing File button to open the Open
dialog box.

Sometimes you see a third tab in your Getting Started dialog box: Recovered.
If LayOut has crashed on you, or if you ever had any LayOut files that weren’t
saved when things went awry, the document you were working on should
show up in the Recovered tab. It’s still a good idea to save often, though.
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=I- Default Templates
=)~ Paper
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Storyboard
= Tideblock
Cortemporary
Modem L o .
Rounded A3 Landscape A4 Landscape ARCH D Landscape
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[Pty e Tabloid Landscape
[ Aways Use Selected Tempiate

Starting out with templates

More often than not, you can find a template to use as a starting point for
your presentation. Browse the list, select one you like, and click the Open
(Choose, on a Mac) button to begin working with a template. You can also
create a custom template, as [ explain in a moment. In my experience, tem-
plates are the quickest way to get up and running with a new LayOut project.

Here are a few things you should know about templates (while I'm on the
subject); Figure 14-4 points them out in a screen shot:

v~ Pay attention to the layers. Many of the templates that come with
LayOut have multiple layers, and some of these layers are locked by
default. They’re locked so that you can’t accidentally move things
around, but you can always unlock them if you need to. In the Layers
dialog box, click the lock icon to lock or unlock a layer; knowing you
need to unlock a layer is especially handy when you want to swap in
your logo instead of using the generic “TLA” that comes preinstalled.
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Figure 14-4:
One of
LayOut's
fancier
prebuilt

templates. |
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+ Have a look at the pages. Most of the more interesting templates
include at least two pages; the first one’s a cover page. Don’t forget to
look at all the pages when you’re working with a template — many of
them open on the second page.

+* Double-click to edit text. One of the really neat things about LayOut is
that you can edit text on locked layers. Using the Select tool, just dou-
ble-click any text you want to edit (and in some templates, you’ll want to
edit all the text), type in new text, and then click once somewhere else
to finish the edit.

v~ Feel free to change colors. LayOut’s templates are designed so that
you can easily change the overall color scheme. Just unlock all the
layers, open the Shape Styles dialog box, and go nuts. For more informa-
tion about changing colors, see the section “Drawing something from
scratch,” later in this chapter.
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Use whatever graphics and colors you want

Double-click text to edit it

Most of the design presentations that you (or your firm) put together probably
look a lot alike — after all, they’re part of your brand identity. If the presenta-
tion documents you make are all variations on a couple of themes, why not
build your own templates and use them every time you need to start a new
project? You can set things up so that your templates appear in the Getting
Started dialog box, making it easier to build consistent presentations, quicker.
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Follow these steps to turn any LayOut file into a template:

1.

Build a LayOut file that includes all the elements you want.

These elements might include a title block, a logo, a page number, and a
cover page.

Make sure that you're viewing the page you want to use as the thumbnail
preview in the template list, before you move on to Step 2.

. Choose File~>Save as Template.

The Save as Template dialog box opens.

3. Type a name for your template.

4. Choose a location for your new template.

In the list at the bottom of the dialog box, click the folder (they’re all
folders) in which you want to include the template you're adding.

. Click OK. On a Mac, click Save.

The next time the Getting Started dialog box appears, your new template
will be in it.

Creating a new, blank document

If you decide not to start with one of LayOut’s handy-dandy templates, you’ll
need to set up a new document from scratch.

Follow these steps to create a fresh, new LayOut document:

1.

Launch LayQOut.

Keep in mind that LayOut and SketchUp are separate software programs,
so you need to launch them individually. If you’ve already launched
LayOut, choose File>New to open the Getting Started dialog box.

. In the Getting Started dialog box, click the New tab.

This shows a list of available templates on the left, with thumbnail pre-
views of each template on the right.

3. Click My Templates in the list on the left.

4. Select a Plain Paper template on the right, and click Open (Choose,

on a Mac).

The plain paper templates are completely white.
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10.

11.

12.

When a new, blank document that you can set up however you like
appears, you then need to set up your new document the way you want it.

. Choose File=>Document Setup.

This opens the Document Setup dialog box.

. Click Units in the panel list on the left, and select the measurement

units you prefer to use.

The Units panel lets you choose which units you’d like to use.

. Click Paper in the list on the left, and set your paper size and color.

If you know you’ll be printing on paper that isn’t white, you can simulate
the color by choosing one here. I don’t recommend trying to print out a
paper color; most printers don’t print full bleed (right to the edges), so
the effect really isn’t that great.

. Set up some margins, if you want to.

Margins are useful if you know how close to the edge of your paper you
can print.

. Set the Edit Quality to Low.

You want to make sure LayOut that doesn’t get bogged down on big
SketchUp models you insert later on. Read more about working with
inserted models later in this chapter.

Set the Output Quality according to your document size.

Basically, the Output Quality you choose depends on the physical size of
your printed document. As long as your paper size isn’t any bigger than
11 x 17 inches, you should probably choose High. For bigger presenta-
tions (like boards and posters), use Medium or even Low. The goal is to
limit the size of the file (in megabytes) that gets sent to your printer — if
it’s too big, things can get ugly. For more information on image resolu-
tion, have a look at Chapter 13.

Click Grid in the list of panels on the left, and set up your grid options
the way you want them.

Now you’re in the Grid panel. For more information about this section of
the Document Setup dialog box, see the section “Getting Your Bearings,”
earlier in this chapter.

Click the Close button to close the Document Setup dialog box.

Adding pages to your document

Follow these steps to add a few blank pages to your document:

1.

If your Pages dialog box isn’t already open, choose Windowr>Pages to
open it.
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2. Choose Pages>Add.

This adds a page to your document. You can also add pages by clicking
the little button that looks like a plus sign (in the upper-left corner of the
Pages dialog box). Add as many pages as you want.

\§ . . . ‘e
P My favorite way to add a new page is to duplicate an existing one. Just

click the Duplicate Selected Page button (between Add and Delete) in
the Pages dialog box.

3. In the Pages dialog box, double-click the name of your new page and
then type in a name for it.

4. Press Enter when you’re done.

Repeat to give all your pages meaningful names.

Moving around your document

You move around on the pages in your document just like you do in
SketchUp — except in 2D instead of 3D. Here’s how to move around:

v+ Panning: Hold down your scroll wheel button while moving your mouse
around to slide your page around in your Document Window. This is
called panning.

v Zooming: Roll your scroll wheel back and forth to zoom in and out on
your page. To fill your Document Window with the page you're viewing,
choose Scale to Fit (Zoom to Fit on the Mac) from the Zoom drop-down
list in your window’s lower-right corner.

1 Moving from page to page: Click the Next Page and the Previous Page
buttons on your toolbar to move among the pages in your document.
You can also click page names in the Pages dialog box, or use the Page
Up and Page Down button on your keyboard, if you have them.

Simplifying Layout with Layers

You use layers to create multipage documents with elements that are consis-
tent from page to page. You can have two different kinds of layers in LayOut:

v+ Unshared: Unshared layers are like layers in every other software
program. Any element (text, graphic, or otherwise) that you put on an
unshared layer exists only on one page: the page you're on when you
put the element on the layer.

v Shared: LayOut introduces the notion of shared layers; anything you put
on a shared layer appears on every page of your document, as long as
those pages are set up to show that layer.
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It’s all a little confusing at the beginning, so here are a few quick tips about
how you organize content on layers — including shared layers — as you
create presentations in LayOut:

+* You can make an element (like a logo) appear in the same spot on
more than one page by putting it on a shared layer. For example, the
logo and the project title need to appear in the same spot on every page;
I put these two elements on the shared layer called “On Every Page.”
In Figure 14-5, note how the logo and project title appear in exactly the
same place in the pages labeled B, C, and D.

v Put content that appears on only one page on an unshared layer.
Again, in the pages labeled B, C, and D, the image boxes and page titles
are different on each page, so I put them on the unshared layer called
“Default.”

* You can make any layer a shared layer by clicking the Sharing icon to
the right of its name in the Layers dialog box. (See Figure 14-5.)

+* You decide which pages should show which layers. For example, |
don’t want the logo and the project title to be on the cover page (labeled
A in Figure 14-5). I toggle the Show/Hide icon beside the “On Every Page”
layer to hide it on that page.
A\
When you’re manipulating elements on individual layers in LayOut, keep these
points in mind:

v To add a new layer, click the plus sign icon in the Layers dialog box.

+* To change which layer something’s on, select the destination layer in
the Layers dialog box, right-click the element you want to move, and
choose Move to Current Layer.

1 To see what layer an element is currently on, select the element, then
look for the tiny blue dot in the Layers dialog box. If you select two ele-
ments on two different layers, you see two blue dots.

+* To lock layers you’re not using, click the Lock icon. I know it’s annoying
to have to go and unlock a layer before you can modify its contents, but
it’s even more annoying to accidentally move the wrong things around,
or even delete them.

v To hide layers and improve your performance, make liberal use of
the Hide icon next to the name of each layer; this can really improve
LayOut’s performance, especially on slower computers. Hide any layers
F you’re not working with, and you’ll notice the difference.

I like to work with at least four layers, organizing content on each as follows:

v Elements that should appear in the same place on almost every page,
like logos and project titles
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v Things that appear in the same place on most pages, but that change
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Talking about text

Every file you create will probably have some
textinit, and LayOut 2 has some really neat (but
somewhat hidden) features that help a lot. In
this second version of the software, text boxes
are classified into two broad types, depending
on how you create them:

v+ Bounded: If you click and drag with the Text
tool, the text box you create is bounded.
Any text you enter into it that doesn't fit
won’t be visible, and you’ll get a little red
arrow at the bottom. That arrow tells you
that there’s more in your text box; you need
to use the Select tool to make it bigger in
order to show everything that's inside. You
should use a bounded text box whenever
your text needs to fit into a precise space in
your design.

v Unbounded: If, instead of creating a text box
with the Text tool, you simply click to place
your cursor somewhere on your page, the
text you create will be unbounded. It stays
inside a text box, but that text box automati-
cally resizes to accommodate whatever text

you put inside it. The labels you create with
the Label tool are examples of unbounded
text — it'd be a pain to manually resize
things whenever you modify a note. To turn
an unbounded text box into a bounded one,
just resize it with the Select tool, or choose
Textc>Make Unbounded.

It's no surprise that text in LayOut can be left,
center, or right aligned, but here’s something
you probably didn’t know: You can prescribe
the justification of a text box by drawing it a
certain way:

v~ Drag left to right to create a left-aligned
text box.

v~ Drag right to left to create a right-aligned
text box.

+* Hold down Control (Option on a Mac) to
create a center-aligned, vertically centered
text box. You can set vertical alignment
options (top, center, bottom) for a text box
in the Text dialog box.

Bringing in Everything You Need

\\J

After you have your document set up the way you want it, you probably want
to start bringing in images. Some programs call this importing, and others call
it placing. LayOut calls it inserting.

Vive la différence!

You can insert two kinds of images into your LayOut documents:

v Raster images: This means TIFFs, JPEGs, GIFs, BMPs, and PNGs — these
are all graphics file formats that save pictures as lots of tiny dots.

The Mac version of LayOut can also insert PDF files, which is indisputably

the best way to bring in vector art like logos. You can use a program like
Adobe Illustrator to save any Al (Illustrator) or EPS file as a PDF.
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1 SketchUp models: To get a SketchUp model view into your presentation,
LayOut lets you insert SketchUp models directly into your document.

With every other page-layout program in the universe, the only way to
include a view of a SketchUp model is to export that view from SketchUp as
an image file, and then place it in the layout program. Changing the SketchUp
file means having to go through the whole process again, and if your presen-
tation includes lots of SketchUp model views, it can take hours.

This brings us to LayOut’s raison d’étre: Instead of exporting views from
SketchUp to get them into LayOut, all you do is insert a SketchUp file. From
within LayOut, you can pick the view you like best. You can also use as many
views of the same model as you want. When your SketchUp file is modified,
LayOut knows about it and (using the References panel in the Document Setup
dialog box) lets you update all your views at once by clicking a single button.

In sections that follow, you find out the best tips and tricks for working with
models, as well as how to insert other images and text.

Inserting images and model views

Regardless of which kind of image you want to insert, the procedure is the
same; follow these steps to bring an image into your LayOut document:
1. Choose File>Insert.
This opens the Insert dialog box.

2. Find the file on your computer that you want to insert, select it, and
click the Open button.

This closes the Insert dialog box and places the image (or SketchUp
model) you chose on your current LayOut document page.

3. Use the Select tool to resize your image.
You can resize an image by clicking and dragging any corner.

Hold down Shift while you drag to resize proportionally; you probably
don’t want to distort your image by stretching it out.

4. Use the Select tool to move your image around and rotate it.

Click and drag to move any element in your document around on the
page. Use the Rotate knob (the little blue stick in the center of your
image) to rotate. To rotate about a different point (a different center
of rotation), just move the Rotate knob by clicking its center point and
dragging it around.

See the next section for tips on working with inserted SketchUp model
views.
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Working with inserted model views

Being able to choose views of your SketchUp models and put together docu-
ments to present them is what LayOut is all about. Text, vector drawing,
raster images, and everything else aside, LayOut is a tool for presenting
SketchUp models.

This section is about two things: managing the model views that you've
inserted into your LayOut document, and controlling how they look with the
SketchUp Model dialog box. With that binary objective in mind, read on. . ..

A bit of general advice

Figure 14-6 shows a view of a LayOut drawing window with a SketchUp model
I inserted. The following are some things I think you should know:

v Double-click to change your view. When you’re using the Select tool,
double-clicking a SketchUp model view allows you to orbit, pan, and
zoom around your model. When you like what you see, click anywhere
outside the view to exit.

+* Choose Open with SketchUp to edit your SketchUp model directly.
Choosing Open with SketchUp from the right-click context menu opens
your model in SketchUp, where you can make any edits you want. When
you’re done, save your SketchUp file, and then come back to LayOut;
your view will have changed to reflect the edits you made in SketchUp.

v Do your dimensioning in SketchUp. This may seem strange, but LayOut
doesn’t have a way to add dimensions to your drawings. Dimensions you
add in SketchUp show up in LayOut, though, so feel free to add them
there.

1 Create scenes in SketchUp to make life easier in LayOut. In the
SketchUp Model dialog box (which I talk about in a bit) you can pick a
scene. This is incredibly convenient, because getting just the right view
can be easier in SketchUp than it is in LayOut. If you know which views
you need, create scenes in SketchUp and then choose them in LayOut.
See Chapter 10 for details about creating scenes.

The SketchUp Model dialog box

Take a look at Figure 14-7. It shows the SketchUp Model dialog box, which is

bigger and better (much better) than ever in LayOut 2. It’s dense, but it’s 100
percent worth getting familiar with — managing the controls here will shave
hours off of your workflow. Here’s what all the gizmos and widgets do:
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v Scene: Lets you choose a scene from your SketchUp model to apply to
your model view LayOut. Because your modeling window in SketchUp
probably isn’t the same aspect ratio (proportions) as your image box in
LayOut, it might not look exactly the same, though.

v+ Show your model at scale: The next part of the SketchUp model dialog
box is where you set things up to display your model at a pre-defined
scale. Here’s how:

1. Select the model view in your LayOut file that you want to display
at scale.

2. Click Ortho to switch off perspective.

3. Choose a view (top, side, back) from the Standard View drop-
down list.

4. Choose a scale from the (unlabeled) Scale drop-down list.

1~ Preserve scale on resize: When this check box is selected, scaling the
box that contains your model view doesn’t scale the model view itself.
You can effectively use the Select tool to crop your model view by
changing the size and shape of its container.

v+ Shadows: Turns on and off shadows in your model view. Also lets you
set the date and time of day to control the position of the shadows.

v Fog: Turns on and off Fog in your model view, using the settings you last
applied to the model in SketchUp. Also lets you set the color of the fog.

+* Render and Auto: When the Auto check box is selected, LayOut auto-
matically renders (redraws) your model view every time you change
something about it — its style, shadows, container shape — you get
the idea. If your model is big and heavy, you have to wait while LayOut
works, and that can get old, fast.

Deselecting the Auto check box lets you decide when LayOut should
render your model view. Just click Render to tell LayOut to start cranking.

\3 . sl s .
P * Rendering style drop-down: This list is so much more important than

its location in this dialog box implies. Changing the setting here affects
the way your model looks, how it prints, and how long LayOut takes to
go about its business. There are your options:

¢ Raster: Renders your SketchUp model view as an image made up
of many, many little dots (check out Chapter 13 for more thorough
explanation of the terms raster and vector). The upshot: If your
model is rendered as a raster, it can display sketchy Styles, shad-
ows, and other effects that make it look like it does in SketchUp.
On the other hand, printing or exporting a raster image at large
sizes required it to have a very high pixel count, and that can make
LayOut choke. If you use too low a resolution (LayOut refers to
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resolution as Quality), your model will look jaggy and miserable.
The answer, if you're dealing with a big piece of paper, is to render
your model views as vector images — or hybrid ones, as you’ll see
in a couple of words.

Vector: Renders your selected model view as a vector image. Lines
appear smooth and crisp, but things like shadows, textures, and
sketchy Styles don’t show up. You should choose vector rendering
for model views that are line-heavy, like monochrome plans and
sections at scale. Choosing vector rendering for really big models
can take a while to process — just a warning.

Hybrid: Combines vector lines with raster faces, shadows, and
other goodies. Always try hybrid rendering if you have time, just to
see if you like how it looks.

v Styles: Clicking this tab at the top of the dialog box lets you pick the
Style that’s applied to your model. Pretty straightforward, but this panel
also includes a couple of other interesting controls:

¢ Tweak your line weights: Here, you can change the weight (thick-
ness) of the lines in your model view. The default value is .50, but
the setting you need depends a lot on your model, its Style, and
how big your document is. Fiddle with this number until you like
what you see.

¢ Background: Selecting this check box shows the background of
your SketchUp model view. Deselecting it drops out the back-
ground, making your model look like it’s floating in front of what-
ever’s behind it in LayOut.

Inserting text

You can insert a third type of content into LayOut documents: text. This is
useful if the text you want to use is already typed, spell-checked, proofread,
and ready to present.

Insert a text file the same way you do an image, but keep in mind that it has

to be an RTF (Rich Text Format) or TXT file. Luckily, any text editor (like
Word or TextEdit) can save to these formats.

Presentation-Perfect Images

After you import content, it’s generally not quite presentation-ready. You
may want to crop images or use the drawing tools to create a professional-
looking, well-organized layout. The following sections show you how.
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Figure 14-8:
Use clipping
masks to
hide parts

of images
you insert.
|

Cropping with clipping masks

Cropping an image means reframing it so that you can only see part of it;
every page-layout program on the planet allows you to crop images, and each
one insists that you do it a little differently. LayOut is no exception.

In LayOut, you use clipping masks to hide the parts of images that you don’t
want to see. Follow these steps to use a shape as a clipping mask. See
Figure 14-8:

1. Draw the shape you want to use as a clipping mask.

2. Make sure that it’s positioned properly over the image you want to crop.

3. Use the Select tool to select both the clipping mask object and the
image you want to crop.

Hold down Shift while clicking to select more than one object.

4. Right-click the selected elements and choose Create Clipping Mask
from the context menu.
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Curves are back

The Line tool in LayOut 2 has a secret: It's quite
simply the most intuitive Bézier curve vector
drawing tool I've ever used — and I've used a lot.
In vector software (like LayOut and lllustrator),
you can draw curved lines freehand, but they
don't usually look very good. It's hard to draw
smooth, flowing curves without some assis-
tance, and that's where the Line tool comes in.
Learning to use them usually takes a little getting
used to, but once you do, it's hard to go back.

So what makes LayOut’s Line tool so great?
Two things, actually:

v~ It's hooked up to the inference system.
SketchUp and LayOut share a similar “guid-
ance” system of colorful points and lines
that help you figure out where you are. By
turning on Object Snap when you're draw-
ing, you'll be able to line things up and draw
more accurately.

v+~ Draw and edit with two tools. You use the
Line tool to draw curves (and straight lines,
of course), and then you do all of your edit-
ing with the Select tool. Compared to curve
tools in other software, LayOut does a lot
more with a lot less.

Here are some pointers on creating and editing
curves with the Line tool:

v Click-click-click to draw straight line
segments. It works just like the Line tool in
SketchUp.

v Click-drag-release to draw curved line
segments. You “shape” your curve while
you're dragging.

v+~ Double-click with the Select tool to edit.
When you do, you'll see all of your line’s
control points and handles (the antenna-
looking things that poke out of your control
points). Click and drag points and handles
to edit your line, then click somewhere else
to stop editing.

v+~ Drag a control point on top of an adjacent
point to delete it. If you want to get rid of a
control point while you're editing a line, just
drag it onto one of its neighbors.

+* Hold down Control and click somewhere
on your line to add a point. Hold down
Option on a Mac.

+* Hold down Control and drag on a point to
pull out curve handles. That's the Option
key on a Mac.

+* Hold down Control and drag on a handle to
sharpen a curve.

Here are some fun facts about clipping masks in LayOut:

v Clipping masks work on inserted images. These include pictures and
SketchUp models that you place in your LayOut document.

1 Deleting clipping masks is easy. To see a whole image again, you
need to “release” its clipping mask. Select the image and then choose

Edit=>Release Clipping Mask.

v Edit clipping masks by double-clicking them. When you double-click
a clipping mask, you can see the whole image and the shape you used
to create the mask. Now you can modify the shape, the image, or both.
Clicking somewhere else on your page exits the edit mode.
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Drawing something from scratch

LayOut includes a full slate of drawing tools that you can use to create logos,
title bars, north arrows, graphic scales — anything you want. The drawings
you create are vectors, meaning that you can do the following:

v Scale them without losing quality

v Change their fill and stroke (outline) colors

v~ Split lines and then rejoin them to make new shapes

Because I don’t know what you want to draw, a step list would be pretty
pointless here. Instead, here are a few pointers to get you started:

v Use the right kind of snaps. It’s easier to draw exactly what you want

if you let the software help a bit. Just like SketchUp, LayOut includes an
elaborate (but easy-to-use) inference system of red and green dots and
lines to help you line things up. LayOut also allows you to use a grid
(that you define) to help you keep things straight:

¢ Snap to objects: Choose Arranger>Object Snap to turn on object
snapping; this gives you colored hints to help you draw.

¢ Snap to grid: Choose Arrange=>Grid Snap to turn on grid snapping.
Now your cursor automatically snaps to (is attracted to) the inter-
section of grid lines in your document — whether your grid is vis-
ible or not. See the section “Getting Your Bearings,” earlier in this
chapter, for more information on using grids in LayOut.

You can use any combination of snapping systems (Object or Grid)
while you’re working, but I prefer to use one or the other — it all
depends on what I'm trying to do. To save time, I assign a keyboard
shortcut that toggles each system on and off. (To do that, use the
Shortcuts panel in the Preferences dialog box, which you can find in the
Edit menu — on a Mac, it’s in the LayOut menu.)

+* You can type in measurement and angles. LayOut has a Measurements

box (in the lower-right corner), just like the one in SketchUp. Take a look
at Chapter 2 for tips on working accurately with Measurements.

+* Build complex shapes out of simpler ones. I'll use an example here:

Figure 14-9 shows how I would draw a simple arrow. You can follow
these steps to build one just like it:
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. Make sure that Grid Snap is turned off and Object Snap is turned on.

2. Draw a rectangle with the Rectangle tool.

. Draw a triangle with the Polygon tool. (Type in 3s and press Enter

before you start drawing to make sure that you're drawing a trian-
gle.) Hold down Shift to make sure that the bottom of the triangle
is a horizontal line.

4. Shift+click to select both shapes.

5. Choose Arrangem>Align=>Vertically to line up the rectangle and the

triangle vertically.

Don’t forget that you can always use the Undo feature to go back a
step; it’s in the Edit menu whenever you need it.

. Deselect both shapes by clicking once somewhere else on your page.

7. Select one of the shapes and move it up or down on the page (by

pressing the up- and down-arrow keys) until the two shapes overlap.

. Use the Arc tool to draw a half-circle at the bottom of the rectangle.

9. Using the Split tool, click and hold down each of the points of inter-

10.

11.

section in the figure; don’t let go until all the lines stop flashing
blue. Do this for all four intersection points to split the shapes into
a series of line segments.

Use the Join tool (it looks like a bottle of glue) to connect all the
line segments by clicking once on the “arrowhead” part, once on
each half of the “stem” part, and once on the half-circle. Now you
have one shape instead of three; verify this by clicking the shape
once with the Select tool. You should see one red “selected” rect-
angle around your new shape. If you don’t have one shape, try
using the Join tool again; sometimes it takes a couple of tries to get
things to work.

Move your new shape somewhere else, and then delete the left-
over line segments you don’t need.

+* Open the Shape Style dialog box. You use the Shape Style dialog box to
change the fill and stroke characteristics of elements in your document.
(See Figure 14-10.) In plain English, this is where you pick colors for the
things you draw. The controls are pretty straightforward, so you don’t
need much help from me; just experiment and see what happens.
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|
Figure 14-9:
Drawing

a simple
arrow by
combining a
rectangle, a
triangle, and

an arc.
|
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Living Life after LayOut

After you've created your LayOut document, you can do the following four
things:

v Print it
v Export it as a PDF file
v Export it as an image file

v View it as a full-screen presentation

Simple, huh? The next three sections provide some more detail on each of
these options.

Printing your work

Follow these steps to print your LayOut document:

1. Choose Filec>oPrint.
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In the Print dialog box, choose which pages to print and how many
copies you want.

2. Click the OK button to send your document to the printer.

Exporting a PDF

Anyone with Adobe Reader software (which is free and is already loaded on
millions of computers) can look at a PDF document you create; all you have
to do is e-mail it to him or her. Follow these steps to export your LayOut
document as a PDF file:

1. Choose File=>Export->PDF.

If you're on a Mac, choose Filec>Export, then make sure PDF is selected
in the Export dialog box. This opens the Export PDF dialog box.

2. Give your PDF file a name, and figure out where to save it on your
computer.

3. Click the Save button (in Windows) to open the PDF Export Options
dialog box (see Figure 14-11); click the Options button if you're on a Mac.

4. Set the PDF options the way you want them.
Here’s what everything means:
¢ Page: Choose which pages you want to export.

¢ Quality: See the section “Creating a new, blank document,” earlier
in this chapter, for a brief discussion about Output Quality. Here’s
a good rule of thumb: For documents that are small enough to be
hand-held, | recommend a setting of High. For anything bigger, go
with Medium or Low.

¢ Layers: PDFs can have layers, just like LayOut documents do. If it
makes sense to do so, you can export a layered PDF so that people
who view it can turn the layers on and off.

¢ Finish: Select this check box to view your PDF after it’s exported.
5. Mac only: Click the OK button to close the PDF Options dialog box.

6. Click the Export button (Save button on a Mac) to export your docu-
ment as a PDF file.

Exporting an image file

oKETCH,,  In LayOut 2, you can export the pages of your file as individual raster images in
either JPEG or PNG format. Take a look at the first part of Chapter 13 for more
information on the differences between JPEG and PNG if you need to. Follow
y these steps to export your LayOut document as one or more image files:

NEw,,
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Figure 14-11:
LayOut's
PDF Export
Options
dialog box.
|

Figure 14-12:
LayOut's
Image
Export
Options
dialog box.
|

1. Choose Filew>Export->Images.

If you're on a Mac, choose Filer>Export, then make sure PNG or JPEG is
selected in the Export dialog box. This opens the Export Image dialog box.

2. Name your file and tell LayOut where to save it on your computer.
3. Click the Save button (Options on a Mac).

The Image Export Options dialog box opens; see Figure 14-12.
4. Set the Image Export options.

Here’s what everything means:

® Pages: Choose which pages you want to export. Each page in your
LayOut document exports as a separate image file.

e Size: See the section “Making sure that you're exporting enough
pixels” in Chapter 13 for a complete rundown on pixel size and
image resolution.

¢ Finish: Select this check box to view your image after it’s exported.
5. Mac only: Click the OK button to close the Image Options dialog box.

6. Click the Export button (Save button on a Mac) to export your docu-
ment as one or more image files.

PDF Export Options
Export
C:\Documents and Settings’\aidanc My DocumentstGSL For Dummies'Screen
Page
oF]
O Fom: |1 To: |2
Quaality
Output Qualty | High .v
Layers
Create POF Layers from LayOut Layers
Finish
Show Bxport in PDF Viewer
o) o]

Image Export Options

Pages

© A
O From: |1 To: |2

Width 1056 | pixels
Height 816 pixels }f’uﬂ

Size

:
Resolution |96 pixels/inch

Finish
Show export in image viewer

===
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Going full-screen

Many times, design presentations for clients go beyond printed boards and
booklets; they include a digital slide show that usually involves a few hours
of work in a program like PowerPoint or Keynote (if you're on a Mac).

LayOut was designed to help you skip the PowerPoint step by letting you dis-
play your presentation in a full-screen view. You can move back and forth
between pages with the arrow keys on your computer, and you can even dou-
ble-click SketchUp model views to orbit them around. Follow these tips:

1 Switching to full-screen Presentation mode takes less than a second.
Choose Viewr>Start Presentation to view your presentation full-screen.
Press Esc to exit full-screen mode.

v Specify where you want your presentation to appear. Use the
Presentation panel in the Preferences dialog box to tell SketchUp which
monitor (or projector) you’d like to use to show your presentation.

1 Move from page to page. Use the left- and right-arrow keys to flip
through pages.

1 Choose which pages to show full-screen. You can decide not to show
certain pages in full-screen mode by toggling the "Show page in presen-
tations” icon to the right of those page names in the Pages dialog box
(make sure that you're in List view to be able to do this).

+* Double-click to change your view of a SketchUp model. When you'’re in
full-screen mode, you can double-click any SketchUp model view to orbit
and zoom around inside it. Just use your mouse’s scroll wheel button the
same way you do in SketchUp. Click anywhere outside the view to exit.

v Draw while you’re in full-screen mode. Try clicking and dragging while
you’re in full-screen mode; doing so lets you make red annotations right
on your presentation. If a client doesn’t like the porch you designed,
scrawl a big, red X over it to let him know you understand. When you hit
Escape to exit Presentation Mode, you can choose to save your annota-
tions as a separate layer.

1 Play scene animations right in full-screen mode. You can double-click,
then right-click a model view with scenes that you've set up in SketchUp
and choose Play Animation. LayOut will transition from scene to scene,
just like SketchUp does. You can read more about scenes in Chapter 10.
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The Sth Wave By Rich Tennant
CRaTENNpr

“So this is your design? T didn’t know Google
SketchUp had an ‘overkill’ function.”
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Let’s face it, everybody loves lists. The last part of this
book (and of every For Dummies book out there) is
dedicated to presenting useful information in short, bite-
sized chunks that you can read while you're standing in
the elevator. Or using the bathroom. Or waiting for your
turn in the shower.

Chapter 15 is a list of the problems that every new
SketchUp user runs into — check here when you’re ready
to pour acid all over your keyboard and move to Amish
country.

The list in Chapter 16 is mostly about promoting consum-
erism, but it’s also handy if you're wondering what else is
available that can improve the way you use SketchUp.

The last chapter in this book is, fittingly, about ten ways
that you can keep discovering more about SketchUp —
places to go, books to read, DVDs to watch. I'm a firm
believer that the best way to figure out anything is to see
it presented in more than one way, so I highly encourage
you to check out at least a couple of these resources.
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Ten SketchUp Traps and
Their Workarounds

In This Chapter

Knowing why faces, colors, and edges aren’t behaving right
Coping with a slow or crashing SketchUp

Viewing your model the way you want

Persuading components to budge

Recovering from Eraser disasters

Fe bad news is that every single new SketchUp user encounters certain
problems, usually in the first couple of hours using the software. I guess
you could call these problems growing pains. The good news is that such
predictability means that I can write a chapter that anticipates a lot of the
bad stuff you’ll go through. I can’t prevent it from happening, but I can help
you make sense of what’s going on so you can get on with your life as quickly
as possible.

SketchUp Won't Create a Face
Where ] Want It To

You've dutifully traced all around where you’d like SketchUp to create a face,
but nothing’s happening. Try checking whether your edges aren’t all on the
same plane or whether one edge is part of a separate group or component.
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To check whether you have a component problem, try hiding groups or com-
ponents and checking the edges to make sure that they’re all in the group or
component you think they’re in. See Chapter 5 for details.

é‘(“mBER However, 90 percent of the time when SketchUp doesn’t create a face where
& you think it should, an edge isn’t on the plane you think it’s on. To check
whether your edges are coplanar, draw an edge that cuts diagonally across
the area where you want a face to appear. If a face appears now, your edges
aren’t all on the same plane. To fix the problem, you have to figure out which
edge is the culprit.

[ call my favorite method for doing this the Color by Axis method; Color Plate
20 shows images of the steps that I describe:

1. In the Styles dialog box, change your edge color from All Same to
By Axis.

See Chapter 9 for details. SketchUp draws the edges in your model the
color of the axis to which they’re parallel; edges parallel to the red axis
will be red, and so on.

2. Look carefully at the edges you were hoping would define a face.

Are all the edges the color they’re supposed to be? If they’re not all sup-
posed to be parallel to the drawing axes, this technique doesn’t do much
good. But if they are, and one (or more) of them is black (instead of red
or green or blue), that edge (or edges) is your problem child. Fix it and
switch back to All Same when you’re done.

My Faces Are Two Different Colors

\‘\gN\BEI?
& In SketchUp, faces have two sides: a front and a back. By default, these two

sides are different colors.

When you do certain things like use Push/Pull or Follow Me on a face, some-
times the faces on the resulting geometry are “inside out.” If it bothers you to
have a two-tone model (I know it bothers me), right-click the faces you want
to flip over and choose Reverse Faces from the context menu. If you have lots
of them, you can select them all and then choose Reverse Faces to do them
all at once.
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Edqes on a Face Won’t Sink In

This tends to happen when you're trying to draw a rectangle (or another geo-
metric figure) on a face with one of SketchUp’s shape-drawing tools.
Ordinarily, the Rectangle tool creates a new face on top of any face you use it
on; after that, you can use Push/Pull to create a hole, if you want.

If your shape’s edges look thick instead of thin, they’re not cutting through
the face they’re drawn on. When that happens, try these approaches:

1 Retrace one of the edges. Sometimes that works — you’d be surprised
how often.

1 Select Hidden Geometry from the View menu. You're checking to make
sure that the face you just drew isn’t crossing any hidden or smoothed
edges; if it is, the face you thought was flat might not be.

1 Make sure that the face you drew on isn’t part of a group or compo-
nent. If it is, undo a few steps and then redraw your shape while you're
editing the group or component.

SketchUp Crashed and 1 Lost My Model

Unfortunately, SketchUp crashes happen sometimes.

The good news is that SketchUp automatically saves a copy of your file every
five minutes. The file that SketchUp auto saves is actually a separate file, which
it calls AutoSave_your filename.skp. If your file ever gets corrupted in a
crash, an intact file is ready for you to find and continue working on.

The problem is that most people don’t even know it’s there. Where is it?

v If you've ever saved your file, it’s in the same folder as the original.

v 1If you've never saved your file, it’s in your My Documents folder —
unless you're on a Mac, in which case it’s here:

User folder/Library/Application Support/
Google SketchUp 7/SketchUp/Autosave

Keep in mind that SketchUp normally cleans up after itself by deleting the
auto saved file when you close your model, and nothing untoward happens.
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To minimize the amount of work you lose when software (or hardware) goes
south, you should always do two things:

1 Save often. Compulsively, even.

v Save numbered copies as you're working. [ use Save As to create a new
copy of my work every half-hour or so. When I'm building a big model,
it’s not uncommon for me to have 40 or 50 saved versions of it on my
computer, dating back to when I first started working on it.

SketchlUp Is Sooooo Sloovovovoow

The bigger your model gets, the worse your performance gets, too. What makes
a model big? In a nutshell, faces. You should do everything in your power to
keep your model as small as you can. Here are some tips for doing that:

+” Reduce the number of sides on your extruded circles and arcs. See the
sidebar in Chapter 6 for instructions on how to do this.

1 Use 2D people and trees instead of 3D ones. 3D plants and people have
hundreds of faces each. Consider using 2D ones instead, especially if
your model won’t be seen much from overhead.

Some models are just big, and you can’t do much about it. Here are some
tricks for working with very large SketchUp models:

1 Make liberal use of the Outliner and layers. Explained in detail in
Chapter 7, these SketchUp features were specifically designed to let you
organize your model into manageable chunks. Hide everything you're
not working on at the moment — doing so gives your computer a fight-
ing chance.

1 Use substitution for large numbers of complex components. For exam-
ple, insert sticks as placeholders for big sets of 3D trees, cars, and other
big components. See the tips for replacing components in Chapter 5 for
details.

v Turn off shadows and switch to a simple style. It takes a lot of com-
puter horsepower to display shadows, edge effects, and textures in real
time on your monitor. When you’re working, turn off all that stuff.

1 Use scenes to navigate between views. Scenes aren’t just for present-
ing your model — they’re also great for working with it. Creating scenes
for the different views you commonly use, and with different combina-
tions of hidden geometry, means that you don’t have to orbit, pan, and
zoom around your gigantic model. Better yet, deselect Enable Scene
Transitions (in the Animation panel of the Model Info dialog box) to
speed things up even more.
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I Can’t Get a Good View of
the Inside of My Model

QN
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It’s not always easy to work on the inside of something in SketchUp. You can
do these things to make it easier, though:

v~ Cut into it with sections: SketchUp’s Sections feature lets you cut away
parts of your model — temporarily, of course — so that you can get a
better view of what’s inside. Take a look at Chapter 10 for the whole
story on sections.

v Widen your field of view: Field of view is basically the amount of your
model you can see on the screen at one time. A wider FOV is like having
better peripheral vision. You can read all about it in Chapter 10.

A Face Flashes When 1 Orbit

If you have two faces in the same spot — maybe one is in a separate group or
component — you see an effect called Z-fighting. SketchUp is deciding which
face to display by switching back and forth between them. It’s not a good solu-
tion, but certainly a logical one — at least for a piece of software. The only
way to get rid of Zfighting is to delete or hide one of the faces.

1 Can’t Move My Component
the Way 1 Want

Some components are set up to automatically glue to faces when you insert
them into your model. A glued component instance isn’t actually glued in one
place. Instead, it’s glued to the plane of the face you originally placed (or cre-
ated) it on. For example, if you place a sofa component on the floor of your
living room, you can only move it around on that plane — not up and down.

This behavior comes in handy when you’re dealing with things like furniture.
It allows you to use the Move tool to rearrange things without having to
worry about accidentally picking them up.

If you can’t move your component the way you want to, right-click it and

check to see whether Unglue is an option — if it is, choose it. Now you can
move your component around however you want.
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Bad Stuff Happens Every Time
1 Use the Eraser

It’s pretty easy to delete stuff accidentally with the Eraser tool. Worse yet,
you usually don’t notice what’s missing until it’s too late. Here are some tips
for erasing more accurately:

v Orbit around. Try to make sure that nothing is behind whatever it is
you're erasing; use SketchUp’s navigation tools to get a view of your
model that puts you out of danger.

v Switch to Wireframe mode. Choose View>Face Stylec>Wireframe when
you’re going to be using the Eraser heavily. That way, you won’t have
any faces to obstruct your view, and you’ll be less likely to erase the
wrong edges.

+* Double-check. I've gotten into the habit of giving my model a quick
once-over with the Orbit tool after I do a lot of erasing, just to make
sure that [ didn’t get rid of anything important. Put a sticky note on your
computer monitor that says something like CHECK AFTER ERASE! just to
remind yourself.

All My Edges and Faces Are
on Different Layers

NNG/
Vg‘

I'll be blunt — using Layers in SketchUp is a dangerous business. Chapter 7
has tips you should follow when using layers, so I won’t repeat them here, but
here’s the short version: You should always build everything on Layer0, and
only put whole groups or components on other layers if you really need to.

If you used layers, and now things are messed up, here’s what you can do
to recover:
1. Make sure that everything is visible.

Select Hidden Geometry on the View menu; then (in the Layers dialog
box) make all your layers visible. Just make sure that you can see every-
thing in your model.

2. Choose Edit->Select All.
3. In the Entity Info dialog box, move everything to Layer(.

4. In the Layers dialog box, delete your other layers. When prompted,
tell SketchUp to move anything remaining on them to Layer0.

5. Create new layers and follow the rules in Chapter 7.
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Ten Plugins, Extensions, and
Resources Worth Getting

In This Chapter

Places to find more components

Scripts that make your life easier and add power to SketchUp
Software for making your SketchUp views look like photographs
Fun hardware add-ons

Tle really great thing about SketchUp’s price is how much room it frees
up in your budget for nifty add-ons. This chapter is a list of ten such nifty
add-ons, along with a little bit of information about them and where you can
go to find them. I've split them up into four categories, just to make things
clearer: components, Ruby scripts, renderers, and hardware.

Components

Why make your own sofa when you can grab one from somewhere else?

If the zillions of components that you can download from the Google 3D
Warehouse aren’t enough for you (see Chapter 5 for more information about
this), the following sections provide some additional Web sites where you
can buy what you need.

Form Fonts

Form Fonts (www. formfonts.com) is a Web site that sells components “all
you can eat, buffet style.” You pay a (surprisingly low) monthly fee, and you
have access to thousands of high-quality models of just about anything you can
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think of. Form Fonts’ international team of modelers even takes requests — if
you need something that they don’t have, they can probably make it if you ask
nicely. In addition to components, Form Fonts also has tons of extra materials
you can apply to your work, as well as a growing library of styles. Even if you're
not interested in signing up, it’s worth checking out the Web site just to see the
beautiful models Form Fonts makes.

Sketchupmodels.com

Along the same lines as Form Fonts, Sketchupmodels.com is an online spot
where you can buy SketchUp components. This place isn’t a buffet, though;
you only buy what you need, a la carte. Some of its models might seem a
little expensive, but when you consider how much time it would take you to
make them yourself, it might be worth it to buy them — especially if you use
SketchUp for work.

Ruby Scripts

What’s a Ruby script, you ask? Basically, Google provides a way for people to
make their own plugins for SketchUp. These plugins are just mini-programs
(scripts) written in a computer programming language called Ruby. The best
thing about Ruby scripts (Rubies, for short) is that you don’t have to know
anything about Ruby, or programming in general, to use ones that other
people have created.

To install Rubies, you just drop them into a special folder on your computer:

v Windows: C: /Program Files/Google/Google SketchUp 7/
Plugins

v Mac: Hard Drive/Library/Application Support/Google
SketchUp 7/SketchUp/Plugins

The next time you launch SketchUp, Rubies you put in the preceding location
become available for you to use. How you use them depends on what they
do. They might show up on one of the toolbar menus or on your right-click
context menu. The more complex ones even come with their own little tool-
bars. Helpfully, most Rubies also come with a set of instructions that tells
you how to use them.

Luckily for those of us who aren’t programmers, plenty of smart folks out

there develop and (in some cases) sell Rubies that anyone can use. Here are
three places you can go to find some.
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Smustard.com

Smustard.com (www . smustard.com) is a Web site run by a few of these
smart folks. You can choose from dozens of helpful Rubies that add function-
ality to SketchUp, and best of all, they’re very inexpensive. Some of my favor-
ites include the following:

v Weld: This Ruby takes edges you've selected and welds them together
to make a single edge that you can select with a single click. This is super
handy when you’re using Follow Me.

v Drop: This takes a bunch of groups or components that you've selected
and drops them down in the blue direction until each hits a surface. If
you're trying to populate a sloping hillside with trees, it’s much easier
to make a big, flat grid of them in the air, then Drop them down to meet
the ground.

v Subdivide and Smooth: If you're interested in organic modeling — stuff
that isn’t boxy or otherwise angular — you should take a look at this
one. Basically, it lets you create smooth, blobby (I mean that in a good
way) forms based on proxies (boxes, sort of) that you manipulate. It
much cooler and more versatile than it sounds, though. Try searching
YouTube for sketchup subdivide and smooth to see some videos of
what it can do.

1 Windowizer: This one helps you create storefront windows much more
quickly than you could manually.

” PresentationBundle: This package of five Rubies helps you use scenes
to create better presentations. You can customize the transition time
between individual scenes, for instance, and even create really elaborate
fly-by animations.

v CAD cleanup scripts: If you routinely import 2D CAD drawings to
use as a starting point for SketchUp models, you need these scripts.
Without going into any detail, here’s a list of the CAD cleanup scripts
you should hunt for on Smustard: StrayLines, CloseOpens, MakeFaces,
IntersectOverlaps, Flatten, and DeleteShortLines.

Ruby Library Depot

The Ruby Library Depot (search for ruby library depot on the Web) is a
huge collection of Rubies from helpful software developers around the world.
You'll find tons of stuff to make your SketchUp life better there, but here are
two you shouldn’t miss:
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v~ Joint Push Pull: Wouldn't it be great if you could push/pull curved sur-
faces to give them thickness? With this plugin, you can. Even better, it
comes with great documentation when you download it.

v Tools on Surface: Use these drawing tools — Line, Offset, Circle,
Rectangle, Freehand — to draw directly on non-flat surfaces like terrain.

SketchyPhysics

This is only one plugin (so I'm not sure that it really needs its own giant
heading) but it’s so earth-shatteringly cool that I couldn’t leave it out.
SketchyPhysics (search for sketchyphysics on the Web) is an extension that
lets you apply real-world physical constraints (like gravity) to your SketchUp
models. You can, for instance, set up a row of dominoes, tip one over, and
watch them all fall down. Or build a machine with wheels, pistons, and

other mechanical parts and set it in motion. Search for sketchyphysics on
YouTube to see some unbelievable videos of folks using it. As of this writing,
SketchyPhysics only works on Windows machines, but I've heard rumors that
a Mac version might be in the works.

Renderers

3

One thing SketchUp does not do is create photorealistic renderings. Its styles
are great for making your models look hand drawn, but none of them can
make your work look like a photograph. Most SketchUp users are okay with
that, but for those who aren’t, you can find some nice solutions out there.

Of course, SketchUp Pro’s 3D export formats make it possible to render SKP
files with just about any of the dozens of iiber-powerful renderers on the
market, but the ones that I describe in the following list have three important
things in common: They work with the free version of SketchUp, they were
developed with SketchUp in mind, and you don’t have to work for George
Lucas to figure them out. Here’s the list:

v SU Podium (www . suplugins.com): SU Podium is a plugin that lets you
create photorealistic views right inside SketchUp. It’s relatively inexpen-
sive, straightforward to use, and the results you get are impressive. SU
Podium is available for both Windows and Mac, and there’s a free, lower-
resolution trial version you can get to see if it suits you.

v IDX Renditioner (www. idx-design.com): This software evolved from
another renderer called TurboSketch. Like SU Podium, it’s a plugin, it’s
available for Windows and Mac computers, and you can try a free version
that creates smaller (640 x 480 pixels) images. I recommend trying both
SU Podium and IDX Renditioner, and seeing which one you prefer.
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v Artlantis R (www.artlantis.com): If you're really serious about
making images that look like photographs, take a good look at Artlantis
R. Instead of running as a plugin inside SketchUp, it’s a fully functional,
separate piece of software that works with lots of other 3D modeling
programs. Its results are out of this world.

QWP Like I mentioned earlier, lots of rendering applications are out there, and
depending on what you want to do, different ones might work better than
others. If photo rendering is your thing, try plugging these names into your
favorite search engine: Kerkythea, Maxwell, Cheetah3D, and Vue. They’re hard
core, but they all work great.

Hardware

All you really need to use SketchUp is a computer with a decent video card, a
keyboard, and a mouse. On the other hand, having specialized hardware can
come in handy — especially if you find yourself using SketchUp all the time:

v A better video card: This isn’t really an option if you're on a laptop,
but if you use a desktop machine, upgrading your computer’s video
card (also called a graphics card) is the single best way to improve your
SketchUp experience. Your video card is a piece of hardware that han-
dles the stuff that shows up on your screen. Not all cards are made to be
used with 3D modeling programs — not even some that are made specif-
ically for whiz-bang video games. What you're looking for is something
that supports OpenGL 1.5 or higher and has a lot of video memory; the
more, the better. I've heard good things about cards made by NVIDIA
and ATL

1 SpaceNavigator from 3Dconnexion: Using a scroll-wheel mouse to fly
around in three-dimensional space works great for most people, but
lots of SketchUp power users swear by dedicated 3D navigation tools
like the SpaceNavigator. It looks a little like an enormous button that
sits on your desk, connected to your computer via a USB cable. You
use it with whatever hand isn’t on your mouse; it’s an add-on (and not
a replacement) for any other peripheral in your system. Basically, the
SpaceNavigator lets you orbit, pan, and zoom with subtle movements of
your hand — it really is a much more natural way to interact with a 3D
model. You'll find a bit of a learning curve, but that’s nothing for serious
SketchUp users. Anything that makes software easier and more fun to
use is worth the time it takes to master it.
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Chapter 17
Ten Ways to Discover Even More

In This Chapter

Checking out some great, free SketchUp information
Discovering other helpful resources

Don’t get me wrong — it’s not that I think this book is woefully incom-
plete. It’s just that I don’t think it’s possible to get too many different
forms of information, especially about something as dynamic as SketchUp.
You can find some great help resources out there, and I'd be remiss if I didn’t
point you to some of them.

The first half of this chapter is devoted to the free stuff; it’s all online and it’s
all available to anyone who wants it. In the second half of the chapter, I list
some of the best nonfree SketchUp resources I know of. If you're willing to
shell out a few bucks, you won’t be sorry — nothing beats seeing the same
information presented in different ways.

«\\gWEg Incidentally, this is probably a good place to mention the dozens of free
é § videos that [ produced to accompany this book. You can link to them from
\“““ -’I/// this book’s Web site (www . dummies.com/go/sketchupfd), but you can

also get to them directly on YouTube. To hear my (surprisingly Muppet-like)
= voice while I put SketchUp through its paces, check out www.youtube.com/
aidanchopra.
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Put Away Your Wallet

\\3

[ have a confession to make: At fancy receptions, I'm the one stuffing my
suit pockets with hors d’oeuvres wrapped in napkins. I love free stuff that
much. So without further ado, what follows are six complimentary sources of
SketchUp help.

Everything in this section requires that you have an Internet connection, so
make sure that your computer’s online before you try any of these.

v~ Official SketchUp Training Resources (http://sketchup.google.
com/training): Google itself publishes really first-rate learning materials
for SketchUp right on its Web site:

¢ Video Tutorials: When SketchUp was first launched in 2000, it
became known for its excellent video tutorials. [ can’t recommend
them highly enough; there’s nothing like seeing SketchUp in action.

¢ Self-Paced Tutorials: These are SketchUp files that use scenes to
teach different aspects of the program in a “follow along with me”
style. If this is how you like to figure things out, have a look.

+* Online Help Center: Google maintains big, extensive help centers (Web
sites, basically) for all its products. These include hundreds of articles
in question-and-answer format, created specifically to help new users
along. The easiest way to get to the SketchUp Help Center is to choose
Help=>Help Center from the SketchUp menu bar.

v Google SketchUp Help Group (http://groups.google.com/group/
sketchup): The SketchUp Help Group is an online discussion forum
where SketchUp users from all over the world can get help, ask ques-
tions, and show off their work.

v SketchUcation (www . sketchucation.com): Home of the SketchUp
Community Forums, this is easily the largest and most active group of
SketchUp users in the world. You'll find discussions, tutorials, plugins,
news, and piles of other good stuff at SketchUcation.

+* School Podcasts (www.go-2-school . com): These guys have a terrific
Web site. Check out the Podcasts area for a list of great, free online
videos they’'ve put together. They also have a couple of great learning
DVDs you can buy; I talk about them in the next part of this chapter.

v SU Wiki (www . suwiki . org): This Web site is built by SketchUp users,
for SketchUp users. It’s a gold mine of tutorials, tips and tricks, plugins,
and other resources that I'm sure you’ll find useful.
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Now Get Out Your Wallet

Really. These resources cost a bit of money, but they’re worth every penny:

v Bonnie Roskes’ books: Bonnie’s The SketchUp Book was the first one
available, and now she has several new titles, including SketchUp
books for kids. If you think you’d like to get another, bigger book about
SketchUp (written with architects and other design pros in mind), check
out Bonnie’s books at www. f1help.biz. (Notice the .biz suffix — .com
takes you somewhere else.)

v School DVD: [ mention School’s videos in the previous section, but
School’s designers have also produced the world’s first SketchUp educa-
tional/training DVDs, which you can order from its Web site (www.go-
2-school . com). The production quality on these things is outstanding,
and Mike and Alex (the School guys) do an amazing job of teaching
SketchUp for both Windows and the Mac.

+* Dennis Fukai’s books: One word: jaw-dropping detail (okay — three
words). Dennis’s books are hard to describe. He’s written four of them,
each is fully illustrated in SketchUp and each teaches a different subject.
If you want to discover more about using SketchUp in building construc-
tion or more about construction itself, or you just want to be completely
inspired by what you can do with SketchUp, have a look at these books.
Search for his name on Amazon (www.amazon.com) or go to his com-
pany’s Web site, www.insitebuilders.com.

v SketchUp Pro training: If you think you might benefit from being able
to spend a few hours with a real-live trainer and a handful of other
SketchUp students, Google Authorized Training Centers might be just
the thing. They’re located all over the world, so there might just be
one near you. Check out this Web site for more information: http://
sketchup.google.com/training/atc.
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2D drawings
DXF and DWG, BC9-BC13
EPIX, BC13-BC14
exporting, BC2
formats, BC2
PDF and EPS, BC3-BC9
2D images, exporting
about, 349-350
raster formats, 354-357
raster images, 350-353
resolution choices, 357-361
2-D Section Slice Only (printer), 341
2D to 3D plans, 88-91
2D views with sun, 275
3D data, BC15-B(C23
3D modeling programs, 13-15
3D objects, 278
3D on a 2D Screen, 29-33
3D Studio Max, 258, BC1
3D Warehouse, 91, 121, 122, 124, 144
3DS, BC15, BC16, BC19-BC21

o/ ] o

acceptance criteria, 3D Warehouse, 332
accuracy

of calculations, 14

of interior models, 82

in modeling, 38-42

in moving objects, 46

of shadows, 69-71, 279-283, 325
Active Cut (sections), 307
active section plane properties, 299, 303
Add Detail tool, 202-203
Add Layer, 214
Add New Collection dialog box, 271
Add Page tool, 377, 378
Add to Favorites, 124

adding layers, 215
adding pages, 382-383
add-ons
components
Form Fonts, 409-410
Sketchupmodels.com, 410
hardware, 413
renderers, 412-413
Ruby scripts
about, 410
Ruby Library Depot, 411-412
SketchyPhysics, 411-412
Smustard.com, 411
address format (Google Earth), 320
Adobe Illustrator, 386
ads as criteria, 3D Warehouse, 332
aerial views, 77
algebra, 150
Align View option (sections), 308
alignment
of components, 128-129
in LayOut, 386
alpha channel, 264
angles, rise over run ratios, 107
animation
about, 17, 361
activating, 294
movies, 363-364
in presentations, 310-312
scenes, 291, 362
settings, 364-367
anti-aliasing, 352, 364
Apple. See Mac
Applications preferences (LayOut), 374
Arc tool, 64, 80, 377, 378
ArchiCAD, BC18
Architectural Desktop, BC18
architectural drawings, 304
architectural scale, 347
artifacts (pixel garbage), 354
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Artlantis R (Web site), 413
as-builts, 82
aspect ratio (proportions), 390
assembly (organizational), 217-219
Assorted Styles, 267
asymmetry, 133
ATI video cards, 413
attributes, 150-154
audience
background, 250
image quality for, 359
Auto check box, 390
AutoCAD, 77, 214, BC1
AutoCAD DWG format. See DWG format
Autodesk Maya, BC15, BC16
Autodesk VIZ, BC16
Auto-Fold, 48
AVl files, 363
axes
colored, 30, 150
Component, 150, 151, 155, 160
location properties, 299
modeling, 150
vertical, 238
axis of rotation, 173
axis origin, 30, 238, 241

ol e

Back color, 258
background

in LayOut, 391

setup, 261-262
Background section, 254, 261-262
Backup (LayOut), 374
backup copies, 301
banners, 359
Bézier curve vector, 393
bilateral symmetry, 133
bisection, faces, 28-29
Bitmap (BMP) format, 357, 386
books, 359
Boolean operations, 111
bottles, 166, 167-169
bounded text boxes, 386
brochures, 359
building footprint, 198-200

building in halves, 134-137, 169
building on Google Earth snapshots,
323-324
building with radial symmetry, 137-139
buildings
about, 75
floors and walls
about, 76
doors and windows, 91-95
simple plans, 82-88
2D, 77-82
2D to 3D, 88-91
roofs
about, 101-103
assembly, 110-113
flat with parapets, 104
gabled, 106-108
hip, 109-110
pitched with eaves, 104-106
stairs, 95-101
bulge (how much an arc sticks out), 80

oo

CAD cleanup scripts (Ruby script), 411
calculation precision, 14
callout styles, 373
Camera

about, 19

location properties, 298, 299

tools, 34, 36

wide-angle lens, 290
cans and can’ts of SketchUp, 15-17
Cast Shadows check box, 279
Ceiling function, 162
center of rotation, 173
chamfers, 166
Cheetah3D, 413
children. See subcomponents
Chin, Justin (€ber-SketchUpper), 183
Circle tool, 79
clay, paper compared with, 14
cleanup of models, 192-193, 270
clipping masks, 392-393
Collapse All, 212
collapsible components, 155
Collate check box (printer), 338, 344
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Collections List button, 122-123
collision detection, 288
color
on faces, 54-56, 223, 257-258
in LayOut, 380, 395
modeling settings for, 266
photo-matching, 237-238
TIFF format choice, 356-357
Color by Layer check box, 215, 266
Color drop-down list, 257
colored axes, 30, 150
Colors dialog box, 373
columns, 304
Combine Textures, 231
Competition Winners styles, 267
completion stage, 250
Component Attributes dialog box, 151-153,
160-161, 162-163
Component Options dialog box, 146-147,
154, 157, 158
components
about, 115
add-ons, 409-410
alignment options, 128-129
axes, 150, 151, 155, 160
Components dialog box
about, 120-126
doors and windows, 91
forms in, 168
for tracking, 118
creating, 126-130
doors and windows, 91, 130-131
Dynamic Components
about, 16, 92, 142-144
advantages of, 127
building your own, 149-164
in Components Window, 123
nesting, 150
scaling, 183
for stairs, 96
using, 144-149
grouping, 116-117
immobility, 407
modeling
advantages of, 132-133
with repeated elements, 140-142
symmetric, 133-139

nesting, 126, 150, 151

organization, 218

resizing, 180-181

size of, 126

strengths, 117-120
Components dialog box

about, 120-126

doors and windows, 91

forms in, 168

for tracking, 118
Components Window, 123
compression (image files), 354, 355, 364
computer monitors, 358
computer performance factors

components, 121, 127

From Contours tool, 192

crashes/lost work, 209, 405-406

file cropping, 231

furniture, 219

in Google Earth, 321

organization, 209

oversized files, 171, 406

polygon count (faces), 186

right-sizing, 294

Shaded with Textures, 261

translucent materials, 261
constraints, attributes, 153
construction geometry, 52
context menus, 18
context-sensitivity, 21, 39
context-specific instructions, 20
contour lines (topographical maps), 190
contrast, with shadows, 278
Control (scaling around the center), 183
cookie cutter tool, 200
Copied Profile method, 99-101
copies

of components, 161, 162

printing, 338, 344
Copies & Pages panel:, 344
Copies attribute, 159
coplanar edges, 26
copying

with Move tool, 49-51

during scaling, 183

section planes, 306
corner grips (scaling proportionally), 182
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corners, 296, 377
cost

of Dynamic Components, 144

of Google Earth, 318

of Sandbox tools, 189

of SketchUp, 1, 11, 12, 13
crashes (computer), 209, 405-406
Create a new collection, 124
Create Group from Slice option

(sections), 308

creating styles, 268, 269-272
cropping

for computer performance, 231

in LayOut, 376, 392

in photograph selection, 243
crossing selection, 44
cursor appearance changes, 149
curved lines, 393
curved surfaces

challenges, 90

textures on, 225, 235-237
curves-based modelers, 15
Customize dialog box, 377
cut away profiles, 166
cut-through views, 303

o) e

dados, 166
DAE (Collada), BC15, BC16-BC18
date

setting, 274

in shadow studies, 279, 282-283
DCs. See Dynamic Components (DCs)
Default Styles collection, 251, 252
defaults

for circles, 326

color, 44, 258, 261

components, 121

field of view, 289

grid spacing, 195

image sizes, 360

inferences, 32

line thickness, 255

locked layers, 379, 380

Measurements box, 40

Rotate tool, 173

Sang, 144
shadow displays, 274
tools, 378
Delete Layer, 214
Depth Cue check box, 255-256
depth of stair treads, 96
depth perception, 29, 273, 275-279
detail levels, 202-203, 257
dialog boxes, 18, 21. See also specific
dialog boxes
difference (roof geometry), 110
digital presentation, 358
digital projector resolutions, 366
digital slide shows (LayOut), 376, 400
dimensioning, 388
Display check boxes (shadows), 274
Display Secondary Selection Pane
button, 122
Display Shaded Using All Same, 261
distance between scenes, 296
distortion, 225-227, 290
Divide edges, 96
docking dialog boxes, 21
Document Exchange Format. See DXF
format
Document Setup dialog box
in LayOut, 375
for Mac, 343-344
documents, blank, 381-382
doors
adding, 91-95
creating, 130-131
drawing, 64-65
dormers, 101, 102
Draft quality (printer), 340
drafting tools, 78-82
Drape tool, 200-202
Draw, 19
drawing axes, 30
drawing from scratch, 394-397
drawings, resolution choices, 359
driving directions (Google Earth), 320
Drop (Ruby script), 411
Dummies (Web site), 415
duplication as criterion, 3D Warehouse,
332
duration of animation, 164
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DVD viewing, 367

DWG format, BC2, BC9-BC13, BC15, BC 23

DWG/DXF Hidden Line Options dialog
box, BC10
DXF format, BC2, BC9-BC13, BC15, BC 23
Dynamic Components (DCs)
about, 16, 92, 142-144
advantages of, 127
building your own, 149-164
in Components Window, 123
nesting, 150
scaling, 183
for stairs, 96
using, 144-149
Web site, 164

oF o

easing (speed) of animation, 164
eaves, 102, 104-106
edge grips (distorted scaling), 182
Edge section, 254, 255-257
edges
about, 24-25
Divide, 96
drawing, 37-38
in faces, 26
hiding, 137, 180
layer problems, 408
in photograph selection, 243
relationship with faces, 27-29
segments remaining, 91
settings, 255-257
sketchy, 252, 267, 345
unsightly, 168, 180
unsmoothing, 180
Edit, 19
Edit pane, 125
Edit Texture Image, 231
editing
attributes, 153
clipping masks, 393
components, 92, 121, 132
with From Contours tool, 190, 192
curved lines, 393
with Smoove tool, 196
textures, 225-233

tiled surfaces, 225
watermarks, 265
editing styles
about, 253-254
background setup, 261-262
creating, 269-272
edge settings, 255-257
face changes, 257-261
model settings, 266
saving changes, 268
style mixing, 267
updating, 269
watermarks, 262-265
efficiency of components, 132-133
elevators, cut-through views, 304
e-mail, 358, 365
embedding. See nesting
emergency escapes, 85
Enable Scene Transitions check box, 295
Encapsulated Postscript files. See EPS
format
encouraging inferences, 33
engineering scale, 347
Entity Info dialog box, 21
EPIX, BC2, BC13-BC14
EPS format, 386, BC2, BC3-BC9
equidistant parts, 160
Eraser tool
accuracy of use, 408
with From Contours tool, 192
on edges, 79
Intersect with Model tool, 110
in LayOut, 377, 378
for smoothing edges, 180
using, 38
erasing
edges, 38
guide lines, 52, 54
pitfalls, 27, 37
Esc button, 46
ESRI ArcGIS, BC18
existence criteria, 3D Warehouse, 332
Expand, 124
Expand All, 212
Explode groups, 117
exploding components, 132
Export Epx Options dialog box, BC14
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Export Options dialog box, 352-353, 358,
BC16, BC17
exporting
animations
about, 361
movies, 363-364
scenes, 362
settings, 364-367
to Google Earth, 324, 328
image files, 398-399
with LayOut, 398-399
to 3D Warehouse, 330, 331-334
2D drawings, BC2
2D images
about, 349-350
raster formats, 354-357
raster images, 350-353
resolution choices, 357-361
exporting to other software
about, BC1
3D data formats, BC15-BC23
2D drawings
DXF and DWG, BC9-BC13
EPIX, BC13-BC14
exporting, BC2
formats, BC2
PDF and EPS, BC3-BC9
extension lines, BC8, BC12
extensions (Sandbox tools), 189
exterior models, 76, 82, 91, 290
exterior walls, offsetting, 85-86
extras as criteria, 3D Warehouse, 332
extruded forms, 166, 169-176
eye-height of an adult, 286

ofF e

Face section, 254, 257-258
faces

about, 26-27

changes, 257-261

definition, 14

flashing, 407

with Follow Me tool, 166

layer problems, 408

with photos, 222-225, 227-230, 233-237

relationship with edges, 27-29

texture editing, 225-233
fascia, 102

FBX, BC16-BC18
Fencing library, 56
field of view, 289-290, 295, 298, 407
File, 19
files
as components, 121, 127
criteria, 3D Warehouse, 332
cropping, 231
image file sizes, 354, 355, 356
oversized, 171
resizing, 192
right-sizing, 294, 325-326
size recommendations, 358
vector file size, BC5-BC6
fillets, 166
fills, 373
Fit to Page (printer), 339
Fit View to Page, 343
Fixed Pins, 228
Flash files, 363
flashing faces, 407
flat roof, 102
flat roofs with parapets, 104
Flip Edge tool, 192-193, 198
floating as criterion, 3D Warehouse, 332
Floor functions, 162
floor plans, 77, 86
floors
about, 76
doors and windows, 91-95
simple plans, 82-88
2D, 77-82
2D to 3D, 88-91
flying around (Google Earth), 318-320
fog
about, 259
in LayOut, 390
properties, 299
Folders (LayOut), 374
folds, 48
Follow Me tool
about, 165-166
gutters and handrails, 169-176
with scaling, 186-189
spheres and bottles, 167-169
stairway building, 101
subtracting from a model, 176-180
using, 166-167
Form Fonts (Web site), 409-410
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Form Z, 14

fractions of components, 162

free edges, 95

From Contours tool, 190-193, 196, 203-207
From Edges check box, 275, 279

From Scratch tool, 193-196

Front color, 258

Fukai, Dennis, 417

oG o

gabled roofs, 102, 106-108
General panel (LayOut), 375
General preferences (LayOut), 374
geolocation, 325, 331
geometry
changes, 110
definition, 24
with Follow Me tool, 169
hidden, 137
interconnected, 216
organization, 209, 214
resizing, 182, 326
scaling, 183
georeferencing (finding geographic
location), 279-282
Georeferencing check box, 281
Getting Started toolbar, 20, 59
GIF format, 264, 356, 386
GIMP, 264
Google Authorized Training Centers, 417
Google Earth
about, 315-316
approximating, 261
models for, 320-330
with shadow studies, 280
ten-minute tour, 317-320
3D picture, 316-317
3D Warehouse, 330-334
Web site, 318
Google SketchUp. See SketchUp
gradients as vectors (printing), 341, 344
graphic card quality, 413
Graphics Interchange Format. See GIF
format
grayed-out cells, 153
Grid panel (LayOut), 375
grid spacing, 195, 394
grips (scaling), 182-183, 232

Ground feature, 262

grouping, 116-117, 169-170, 218
groups, 149, 150, 190

guide lines, 52-54, 232

guide points, 53

gutters, 166, 170-173

o/ o

Halo (empty space), 257
handrails, 169-176
hardware, 413
Help center, 58
Help menu, 20, 371
hidden features
edges, 25, 137, 139
guide lines, 52, 54
layers, 384
hidden geometry properties, 299
Hidden Line Face style, BC5
Hidden Line mode, 260
Hidden Line Options (Windows only), BC9
high accuracy HLR (printer), 341
hip roofs, 102, 109-110
horizon line, 238
horizontal slices (sections), 303, 304
Hybrid (vector lines with raster faces), 391

o]e
icons used in this book, 383
IDX Renditioner (Web site), 412
[llustrator, 386, BC1
image insertion (LayOut), 386-387
image quality, 354, 355
importing

floor plans, 77

from Google Earth, 321-322
In Model button/collection, 252, 271, 272
indoor scenes with sun, 275-279
inference engine, 31
inference system, 393, 394
inferences, 31-33, 47
inkjet printers, 359
inserted model views, 387-391
inside out faces, 258
inside views. See interior models
“inside-outside” model, 76
instances (multiple copies), 118
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Instructor dialog box, 21, 374 lathed forms, 166, 167-169
Interact tool, 147-149, 156 latitude, 279, 282-283, 325
interconnected geometry, 216 Layer Options flyout menu, 215
interior models layers
about, 82-85 in LayOut, 376, 379, 380, 383-385
door/window openings, 91 organization, 213-217
invisible, 407 with Outliner, 217-219
openings, 91 problems with, 408
showing, 309 Layers dialog box, 214-215, 373
interior scenes with sun, 275-279 LayOut
interior view, 76 about, 369-370
interior walls, 86-88 exporting, 398-399
Internet connection speed, 318 full-screen view, 400
Intersect with Model tool, 101, 110-113, 259 insertion
intersection (roof geometry), 110 images, 387
Inventor, 14 model views, 387-391
isometric (3D) view, 60 text, 387-391
iteration, 217 launching
about, 378-379
o ] [ J documents, new, 381-382
moving around, 383
Join tool, 377, 378 pages, adding, 382-383
Joint Photographic Experts Group. See templates, 379-381
JPEG files layers, 383-386
Joint Push Pull (curved surfaces), 412 polishing
JPEG files about, 391
about, 354-355 cropping, 392-393
compression, 353 drawing from scratch, 394-397
as e-mail attachments, 71 printing, 335, 397-398
exporting, 350, 398 scaled views of models, 346
inserting, 386 user interface
limitations, 352, 356 dialog boxes, 372-374
movies, 363 menu bar, 370-372
as watermarks, 264 preferences, 374-376
tools, 376-378
(] K (] LayOut dialog boxes, 371, 372-374
LCD monitors, 358
Kerkythea, 413 lens distortion, 243
keyboard, 19 letter axes, 150
keyboard shortcuts (LayOut), 375, 394 Level of Detail controller, 257
Keynote, 366, 400 limitations
KMZ files (Google Earth), 328, 329, BC16 From Contours tool, 192
exporting from SketchUp free
(] L o version, 349
image transparency, 352
Label tool, 377, 378 for on-screen use, 358
landing, 96 perspective, 346
landmarks (Google Earth), 320 Push/Pull tool, 90

laser printers, 359
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raster format, BC6
SketchUp, 77, 360
vector images, BC9

line drawings, 359

line quality (Mac only), BC8

line thickness, 255, 256, 266, 391, BC11

Line tool

about, 79

in LayOut, 376, 378, 393

in roof modeling, 111
line weights. See line thickness
linear array, 141
linear guide lines, 53
linear inferences, 31-32
load times

animations, 364

exporting, 353

file format differences, 356

workarounds, 406
Local collections, 122
locked layers, 384
locking components, 132
locking inferences, 32-33
logo file format choices, 356
longitude, 325
Look Around tool, 288
lossy compression, 354, 355

ol o

Mac
copying, 49
floating dialog boxes, 372
folds, 48
Materials dialog box, 54, 55
Preferences dialog box, 21
printing from, 341-345
Sample tool, 56
Section Plane tool, 304
style mixing, 267
styles storage, 271
tools, 20
magazines, 359
Make Unique Texture, 231
Map Windows Fonts to PDF Base
Fonts, BC9
mapping photos, 222
Match Photo dialog box, 237, 238
Matched photo scene tab, 238

Materials dialog box, 54, 66, 223, 279
Maxwell, 413
Maya, BC15, BC16
measurement systems, 375
Measurements box
about, 20, 38-41
angles, 107
human heights, 286-287
in LayOut, 394
precision movements, 47
menu bar, 18, 19-20, 370-371
metric scale, 347
Microsoft. See Windows; specific programs
MicroStation, BC18
Model Collection button, 122, 124
Model collection of styles, 269
Model Info dialog box, 21, 280, 281, 296
Model library, 121
Model styles library, 292
model views, 387-391
modeling
advantages of, 132-133
axes, 59
component re-use, 118
on Google Earth snapshots, 323-328
with inferences, 32-33
with Move tool, 47-48
by photo-matching, 242-246
with projected textures, 233-235
with repeated elements, 140-142
settings, 266
simple plans, 59-65, 82-88
sites, 203-207
solids, 14
surfaces, 14
with symmetry, 133-139
on top of photo textures, 233-237
viewing requirements, 251
modeling mind-set
about, 23-24
edges and faces, 24-29
selecting with Google
about, 43-45
color and texture, 54-56
guides, 52-54
moving and copying, 45-51
3D on a 2D Screen, 29-33
warmup, 33-42
Modeling section, 254, 266
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modeling window
about, 17
clearing, 59
proportions for movies, 362
scene tab, 297
tabs, 293
models, importing (LayOut), 376
modifier keys, 20, 49
moldings, 166
mouse, 19, 34, 36
Move pins, 226
Move tool, 45-50
movies, exporting, 363-364
moving
Google Earth, 319
with LayOut, 383
texture, 225-227

o\ o

Name (Layers), 215
naming
components, 117
groups, 116
navigation tools
about, 34-36
Google Earth, 318-320
pitfalls, 67
nesting
active section planes, 307
components, 126, 150, 151, 211
re-ordering, 213
Next Page tool, 377, 378
nongeolocated models, 331
nonphotorealistic rendering (NPR)
about, 17, 252-253
detail levels with, 257
Style Builder for, 254
style choices, 255
switching between, 267
nosing (stairs), 141
NVIDIA video cards, 413

o () o

OBJ, BC15, BC16-BC18
Object Snap, 377, 393
objects in sun, 275

Official SketchUp Training Resources (Web
site), 416
offset printers, 359
Offset tool, 81
offsets around stamped forms, 198
offsetting walls, 85-86
On Faces check box, 274
on foot presentation approaches, 286-290
On Ground check box, 274
OnClick, 156, 164
Online collections, 122
Online Help, 58
Online Help Center (Google), 416
online sources for components, 91
on-screen viewing (computer or projector),
358, 366
opacity, 55, 261, 279
Open a local collection, 124
openings, cutting, 90, 91, 92, 94, 118
Orbit tool, 34-35, 67, 85
orbiting
as Eraser tool check, 408
Intersect with Model tool, 110
problems with, 171
repetition, 66
organic forms/modeling, 184-189, 411
organization
about, 209-210
assembly, 217-219
Layers, 213-217, 383-385
Outliner, 210-213
orientation checks, 261
orthographic sections, 310
Outliner
for component listings, 127
for group listings, 116
with Layers, 217-219
organization, 210-213
Outliner dialog box, 211-212
Outliner List window, 212
Outliner Options flyout menu, 212

oo
Page Size (printer), 340
pages
adding, 382-383
in LayOut, 380
Pages dialog box, 373, 383
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Pages Required, 343
paint application, 65-68
Paint Bucket tool, 56, 66
pamphlets, 359
Pan tool, 36, 67, 85
panning
Google Earth, 319
Intersect with Model tool, 110
in LayOut, 383
paper, clay compared with, 14
paper drawings, 83
Paper panel (LayOut), 375
parallel guide lines, 53
parallel projection, 78
Parallel Projection (printing), 346, BC8
parapets, 102, 104
parent components, 155, 159
parts, resizing, 180-181
path, 166, 167
PDF files, 386, 398, BC2, BC3-BC9
PDF/EPS Options dialog box, BC5
perspective
about, 29
in modeling, 60
in photograph selection, 243
printing limitations, 346
of sections, 309
switching from, BC8
perspective bars, 238, 240-241
photographs
about, 221
face painting
modeling of photo textures, 233-237
photo additions, 222-225
texture editing, 225-233
file format choices, 356
instead of geometry, 326
requirements for, 243
resolution choices, 359
photo-matching
color, 237-238
modeling by, 242-246
setup, 239-242
photo-matching interface elements, 238
photorealism, 17, 253, 412-413
Photoshop
alpha channel images with, 264
for SketchUp editing, 246
Style Builder with, 254

pin colors in Texture Tweaker, 226
pipes, 166
Piranesi, BC2, BC13
pitched roof, 102, 104-106
pitches (roof slopes), 101, 102
pitfalls. See also troubleshooting
clicking and dragging, 38, 45
curved surface textures, 225, 237
faces, 27-28
with Follow Me tool, 169-170
inside out faces, 258
“inside-outside” model, 76
Layers, 213, 216
losing changes, 301
navigation tools, 67
Orbit tool, 85
pitched roofs with eaves, 105
PNG format/software compatibility, 355
projected textures, 233
right-angle surfaces, 237
Rotate tool, 173
sketchy edges, 341
style excesses, 250
updating scenes, 297
pixels
about, 355, 356
garbage from, 354
resolution considerations, 357-361
with Use View Size check box, 352
placemarks, 320
planes in models, 303
planimetric views, 303
plug-ins, 20, BC18. See also add-ons
PNG format
exporting, 350, 398
inserting, 386
movies, 363
transparency with, 352
as watermarks, 264
point inferences, 31
polishing appearances, 137, 139
polygon count (faces), 186
Polygon tool, 377, 378
polygonal modelers, 15
Portable Document Format. See PDF files
Portable Network Graphics. See PNG
format
Position Camera tool, 286-287
position criteria, 3D Warehouse, 332
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Position Texture tool, 222, 225
PowerPoint
eliminating, 400
export settings, 366
image size recommendations, 358
LayOut previewing, 371
pre-existing terrain conditions, 194
Preferences, 371
Preferences dialog box, 21, 374-375, 394
pre-made dynamic components, 96
presentation approaches
about, 285
on foot, 286-290
scenes
about, 290-291
creating, 291-294
modifying, 296-302
moving among, 294-296
sections
about, 302
animations, 310-312
cutting, 303-310
presentation boards, 359
presentation documents. See LayOut
Presentation preferences (LayOut), 374
PresentationBundle (Ruby script), 411
Previous Page tool, 377, 378
Print dialog box (Mac), 344-345
Print Quality (printer), 340, 344
Print Scale, 343
Print Setup dialog box, 337
Print Size (printer), 338, 343
printing
with LayOut, 397-398
from a Mac, 341-345
resolution recommendations, 359-361
to scale, 335, 343, 345-348
from a Windows computer, 335-341
printing dialog boxes
Mac, 343-345
Windows (operating system), 337-341
Profile Lines (Windows only), BC7, BC11
profiles, drawing, 170-176
Profiles check box, 255, 256
projected textures, 233-235
properties
printer settings, 337
of scenes, 298-302
proportions, adjusting, 230-233

Protractor tool, 104-106, 107
Purge (Layers), 215
Purge Unused, 124, 270
Push/Pull tool
extruding into 3D, 88
with Follow Me tool, 176
Follow Me tool compared with, 166
limitations, 90
with scaling, 184-185

OQ.

QuickTime MOVs, 363

o R e

radial symmetry, 133, 137-139
rake, 102
raster formats

about, 355-356

exporting, 350-353, 398

in LayOut, 386, 390-391

limitations, BC6

printing, 341, 344

resolution choices, 357-361

types of, 354-357
realism, 275-279
rectangle choices, 60-61
Rectangle tool, 60, 63, 377, 378
reference point, 262
References panel (LayOut), 375
referencing attributes, 153
rejection criteria, 3D Warehouse, 332
relationships and rules, 151
relocating in layers, 215-216
removing scenes, 297-298
renaming scenes, 297-298
renaming styles, 269
renderers, 412-413
reordering scenes, 297-298
repeated elements, 132, 140-142
repetition on tiled surfaces, 225
resizing, 42
resolution. See also pixels

about, 357-361

in LayOut, 375

with Use View Size check box, 352
resources

about, 415
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free items, 415-416

purchases, 417
reusing LayOut files, 374
Reverse option (sections), 307
right-angle surfaces, 237
rise over run ratios, 107
rise/riser, 96
roofs

about, 101-103

assembly, 110-113

flat with parapets, 104

gabled, 106-108

hip, 109-110

pitched with eaves, 104-106

sloping, 61-63
Roskes, Bonnie, 417
Rotate pins, 226
Rotate tool, 173
rotating

in Google Earth, 319

models, 278

section planes, 306

texture, 225-227
Round function, 162
rounding off edges, 175
RTF files, 391
rubber-banding lines, 38
Ruby Library Depot (Web site), 411-412
Ruby scripts

about, 3, 410-412

with From Contours tool, 192

with Follow Me tool, 170
rules and relationships, 151
run, 96
running start

about, 57

paint, 65-68

quick model, 59-65

setup, 57-59

shadows, 69-71

style, 68-69

work sharing, 71

oS e

Sample tool, 56
Sandbox
site modeling, 203-207
tools, 189-203

Sang, 78, 144
Save as a local collection, 124
saving
backup copies, 301
KMZ files, 329-330
properties, 299
scenes, 290, 300
styles, 268
scalability
PDF files, BC7
of vector images, 350
vectors, BC6
scale
of DWG/DXF files, BC11
printing to, 335, 343, 345-348
showing/preserving, 390
types of, 347
Scale (printer), 340
scale line/vertical axis, 238
Scale tool
about, 180-181
attributes, 156
Dynamic Components, 144-146
modeling with, 180-183
organic forms, 184-189
Scales (LayOut), 375
scaling
criteria, 3D Warehouse, 332
drawings, BC8
models with photos, 230-233
photographs, 241
texture, 225-227
Scene Delay area, 295
scenes
about, 290-291
creating, 291-294, 388
exporting, 362
modifying, 296-302
moving among, 294-296
problems with, 171
Scenes and Styles dialog box, 292
Scenes dialog box, 293, 297, 299
School DVD, 417
School Podcasts (Web site), 416
Scrapbooks dialog box, 374
Search filter box, 212
section cut lines (Windows only), BC8
Section Cuts check box, 266
section lines, BC12
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Section Plane tool, 304, BC12
Section Planes check box, 266
sections

about, 302

animations, 310-312

cutting, 303-310

as workaround, 407
Sections toolbar, 304
Select and replace, 125
Select pane, 122-124
Select tool, 43, 376, 378, 393
selecting with Google

about, 43-45

guides, 52-54

moving and copying, 45-51
selecting with Move tool, 49
selecting with Outliner, 213
settings

animations, 364-367

in Model Info dialog box, 21

PDF files, BC6-BC9

scene views, 292

for shadows, 273-275, 276
setup

initial, 57-59

photo-matching, 239-242
Shaded mode, 260
Shaded with Textures, 261
Shadow Settings check box, 301
Shadow Settings dialog box, 273-275
shadow settings properties, 299
shadows

about, 69-71

accuracy, 279-283

depth and realism, 275-279

in LayOut, 390

settings, 273-275
Shape Style dialog box, 373, 395
shapes, increasing complexity of, 394-395
Shapes library, 168
sharing

among files, 271-272, 373, 376

components, 120

layers, 383
shearing texture, 225-227
shed roof, 102
Shift (scaling proportionally), 183

Shortcuts (LayOut), 375
Shortcuts panel, 21, 394
shortening shadows, 278
Show Extensions check box, BC12
side grips (distorted scaling), 182
simple plans
doghouse, 59-65
2D builds, 82-88
Simplify Contours (Ruby script), 192
site modeling, 203-207
size change automation, 158
sizing accuracy, 325
SketchUcation (Web site), 416
SketchUp. See also LayOut
about, 11-13
cans and can’ts, 15-17
DWG/DXF import limitations, BC10
file format options, 349
with Google Earth, 316, 320-321, 325
Help Group, 416
image quality problems, 354
limitations, 77, 360
models, 387
origins of, 1
Professional
differences, 58, 144
for Dynamic Components, 149
LayOut for printing, 335
perks, BC1-BC23
Sandbox tools, 189
ten-minute tour, 17-21
3D modeling programs compared, 13-15
with 3D Warehouse, 316
unsupported formats, 352, 356
Web site, 144
SketchUp 7
nonphotorealistic rendering, 254, 255
Style Builder, 254
texture editing changes, 246
SketchUp Help Group (Web site), 416
SketchUp Model dialog box, 373, 388-391
SketchUp panel (printer), 344
SketchUp Pro training, 417
Sketchupmodels (Web site), 410
Sketchy Edges styles, 252, 267, 345
SketchyPhysics, 411-412
SKP files, 412
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Sky feature, 262
smart replication, 158-162
smart scaling, 144-146, 154-158
smoothing edges, 168, 180
Smoove tool, 193, 196-198
Smustard (Web site), 411
snap settings, 371, 394-397
snapshots from Google Earth, 322-328
soffit, 102
Soften Edges dialog box, 180
software license, 58
solids, modeling, 14
SolidWorks, 14
Sort by Name, 212
space requirements, raster images, 356
SpaceNavigator from 3Dconnexion, 413
spacing section planes, 306
specific destinations (Google Earth), 320
spheres, 166, 167-169
spindles, 166
Split tool, 377, 378
spreadsheets for Dynamic Components,
150, 151
stacking order, 371
stairs
component options for, 146
cut-through views, 304
modeling, 95-101
steps, 140-142
Stamp tool, 198-200
Standard quality (printer), 340
Standard views (printing), 346
Start Presentation tool, 377, 378
Startup preferences (LayOut), 375
Statistics pane, 125-126
status bar, 18, 20-21
status indicator icons, 21
sticky geometry, 116
Stretch Texture mode, 225, 227-230
stringer (stairs), 141
strokes, 373
Style Builder, 3, 254
style properties, 299
Style tool, 377, 378
styles
about, 249
application of, 250-253

choices, 68-69
editing
about, 253-254
background setup, 261-262
creating, 269-272
edge settings, 255-257
face changes, 257-261
model settings, 266
saving changes, 268
style mixing, 267
updating, 269
watermarks, 262-265
in LayOut, 373, 391
mixing, 267
scenes compared, 292
updating, 390
Styles Collections drop-down list, 251-252
Styles dialog box, 254, 266, BC12
SU Podium (Web site), 412
SU Wiki (Web site), 416
subcomponents, 151, 155, 159
Subdivide and Smooth (Ruby script), 411
Subdivided Rectangles method, 96-99
subject matter as printing quality choice,
359
subtracting from a model, 175, 176-180
sun effects
on built objects, 273
turning on, 274
surfaces, modeling, 14
symmetry, modeling, 119, 133-139

o e

Tabbed Scene Print Range (printer), 338
taboo subjects, 331
Tagged Image Files. See TIFF format
tail (short edge), 175
Tal, Daniel (SketchUpper extraordinaire),
203-207
Tape Measure tool
about, 82
for guide lines, 52-53
resizing with, 42
toggling, 54
templates (LayOut), 376, 379-381
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ten-minute tour
of Google Earth, 317-320
of SketchUp, 17-21
terrain
criteria, 3D Warehouse, 332
Google Earth, 319, 325
modeling, 189, 193-196
Smoove tool on, 196
text boxes, 386
text editing (LayOut), 380
text files, inserting, 391
Text Style dialog box, 373
Text tool, 377, 378
texture
criteria, 3D Warehouse, 332
editing, 225-233
on faces, 54-56, 223
right-sizing, 326
Texture Tweaker, 222, 225
thickness
edges, 25, 95
faces, 27
3D data, BC15-BC23
3D modeling programs, 13-15
3D objects, 278
3D on a 2D Screen, 29-33
3D Studio Max, 258, BC1
3D Warehouse, 91, 121, 122, 124, 144
3DS, BC15, BC16, BC19-BC21
TIFF format
about, 264
color support, 356-357
exporting, 350
inserting, 386
movies, 363
transparency with, 352
as watermarks, 354
Tiled Sheet Print Range (printer), 340
tiles (image textures), 224
tilting in Google Earth, 319
time
setting, 274
in shadow studies, 279, 282-283
timing of scene transitions, 295-296
toolbars, 18, 34, 36

tools
LayOut, 371, 376-378
SketchUp, 19, 20
Tools on Surface (non-flat surfaces), 412
transitions in animations, 294-295, 366
translucency, 55
Translucent library, 200
transparency
as computer performance factor, 261
image backgrounds, 352
with shadows, 279
in textures, 56
of watermarks, 264, 265
traps and workarounds
component immobility, 407
crashes/lost work, 405-406
edges, 408
eraser problems, 408
faces, 403-405, 407, 408
inside views, 407
layers, 408
speed issues, 406
tread, 96
troubleshooting. See also pitfalls
component immobility, 407
crashes/lost work, 405-406
diagnosis with axis color, 257
edges, 408
eraser problems, 408
Esc button, 46
faces, 28, 403-405, 407, 408
inside views, 407
layers, 408
speed issues, 406
stray edges, 259
TV viewing, 367
tweaking, 186
2D drawings
DXF and DWG, BC9-BC13
EPIX, BC13-BC14
exporting, BC2
formats, BC2
PDF and EPS, BC3-BC9
2D images, exporting
about, 349-350
raster formats, 354-357
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raster images, 350-353
resolution choices, 357-361
2-D Section Slice Only (printer), 341
2D to 3D plans, 88-91
2D views with sun, 275
TXT files, 391

o lf o

unbounded text boxes, 386
Undo function, 166, 300
Unglue option, 407
ungrouping, 117, 132
union (roof geometry), 110
uniqueness, 132
Units panel (LayOut), 375
unlocking, 132
unshared layers, 383
unsmoothing edges, 180
updating

automatic, 117, 146, 268

Google Earth, 316

LayOut files, 375, 376, 390

scenes, 292, 297, 300-301

in SketchUp, 370

styles, 268-269
Use Model Extents (printer), 340
Use View Size check box, 352
uses for shadows, 283

oo

valley, 102
vanishing point grips, 238
vector file formats. See EPS format; PDF
files
vectors
about, 350, BC5-BC6
format, 391
limitations, BC9
printing, 341, 344-345
with SketchUp, 349, 360
VectorWorks, 77, BC18
vertical axis, 238
vertical slices (sections), 303, 304

video card quality, 413
video compression, 364
View, 19

View in Google 3D Warehouse, 124

View Options button, 123
viewing requirements, 251

viewpoint, 289-290, 295, 298, 308-310

visibility
hide/unhide, 212, 214
of layers, 215, 299
of modeling elements, 266
of sections, 303, 308
visual spam as criterion, 3D
Warehouse, 332
VRML, BC15, BC 21-BC22
Vue, 413

o ([ o

Walk tool, 286, 287-288

walking off high surfaces, 288
walk-through suggestions, 295-296

walls
about, 76
doors and windows, 91-95
simple plans, 82-88
2D, 77-82
2D to 3D, 88-91
warmup, 33-42

Watermark section, 254, 262-265

watermarks, editing, 262-265
Web sites
Artlantis R, 413
Dummies books, 415
Dynamic Components, 164
Form Fonts, 409-410
Google Earth, 318

Google SketchUp Help Group, 416

IDX Renditioner, 412

image file format choices, 354
image size recommendations, 358
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Official SketchUp Training Resources, 416

Ruby Library Depot, 411-412

School Podcasts, 416
SketchUcation, 416
SketchUp, 144

www.it-ebooks.info


http://www.it-ebooks.info/

436

Google SketchUp 7 For Dummies

Web sites (continued)
Sketchupmodels.com, 410
Smustard.com, 411
SU Podium, 412
SU Wiki, 416
3D Warehouse, 121
YouTube, 366, 411, 415

Welcome to SketchUp dialog box, 58

Weld (Ruby script), 170, 411

wide field of view, 289

Width and Height, 343, 352

Window, 19

Windowizer (Ruby script), 411

windows
adding, 91-95
creating, 130-131
selecting, 44

Windows (operating system)
copying, 49
Materials dialog box, 54
printing from, 335-341
Sections toolbar, 304
style mixing, 267
styles storage, 271
tools, 20

Windows Bitmap (BMP) format, 357

Windows Print dialog box, 337-341

Wireframe mode, 259, 408

work sharing, 71

workarounds
component immobility, 407
crashes/lost work, 405-406
diagnosis with axis color, 257
edges, 408
eraser problems, 408
Esc button, 46
faces, 28, 403-405, 407, 408
inside views, 407
layers, 408
speed issues, 406
stray edges, 259

o X o
X-Ray (transparency), 261
XSI, BC15, BC16-BC18

oyo

YouTube (Web site), 366, 411, 415

o/ o

Z-fighting, 332, 407

Zoom Extents tool, 36, 67
Zoom tool, 35-36, 67, 85
zooming, 110, 319, 383
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Computer Graphics & Design

SketchUp brings 3D to
everybody! Find out how, and
start creating 3D models today

Maybe you need to build 3D models for work, or maybe *What SketchUp can and can’t do
you've just always wanted to explore 3D modeling. Well,
Google SketchUp was made for you, and here’s what

* How to add style to your model

you need to get up to speed right away. Learn to make * Tips for building different types
buildings and other objects, print your models, export them Stiect:

to other programs (including Google Earth), create 3D * How to add stairs, furniture, and
animations,and more! landscaping

« Effects that add realism to your

* Hit th d ing — set up SketchUp, | bout ed
it the ground running — set up SketchUp, learn about edges models

and faces, use inferences and guides, and build your first model

* How to build models for Google

* Develop a workflow — set up basic end-to-end workflow for "
ar

creating and sharing models with your friends, clients, and co-

workers * Ways to solve common SketchUp

* Beyond buildings — model non-boxy objects like terrain, simple problems

characters, and household objects like furniture . .
*Ten plugins, extensions,and

* Take a different view — spruce up your models with styles and resources to consider
shadows to add effects, make objects pop, and enhance realism

* Create presentation documents — use LayOut in SketchUp Pro to
add text, callouts, and images; draw with vector tools; and print
models to scale

Go to dummies.come

Visit the companion Web site at www.dummies.com/ for more!

go/sketchup7fd to find a bonus chapter and videos
demonstrating more about what you can do with
Google SketchUp!

For Dummies®
A Branded Imprint of

$WILEY

$24.99 US/$29.99 CN / £16.99 UK

Aidan Chopra is the product evangelist for SketchUp at Google. He writes

. ISBN 978-0-470-27739-3
and edits SketchUpdate, a popular e-newsletter and blog that reaches

52499

hundreds of thousands of SketchUp users worldwide.
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