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1

INTRODUCTION

Excel is a very popular program. Millions of people throughout the world use it on a regular basis. But 
it’s a safe bet that the vast majority of users have yet to discover some of the amazing things this 
product can do. If I’ve done my job, you’ll find enough useful information in this book to help you use 
Excel on a new level.

What You Should Know
This book isn’t a beginner’s guide to Excel. Rather, it’s a book for those who already use Excel but 
realize that they have a lot more to learn. This book contains 101 tips and tricks that I’ve learned over 
the years, and I’m certain that about 99 percent of all Excel users will find something new and useful 
in these pages.

If you have absolutely no experience with Excel, this book might not be the best choice for you. To get 
the most out of this book, you should have some background in using Excel. Specifically, I assume that 
you know how to accomplish the following tasks with Excel:

➤	 Create workbooks, insert worksheets, save files, and perform other basic tasks.

➤	 Navigate through a workbook.

➤	 Use the Excel Ribbon and dialog boxes.

➤	 Use basic Windows features, such as file management and copy-and-paste techniques.

What You Should Have
To use this book, you need a copy of Microsoft Excel 2013 for Windows. If you use an older version of 
Excel, some of the tips won’t apply.

As far as hardware goes for the computer you use to run Excel, the faster, the better. And, of course, 
the more memory in your system, the happier you’ll be.
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Conventions in This Book
Take a minute to skim this section and become familiar with some of the typographic conventions 
used throughout this book.

Formula listings
Formulas usually appear on a separate line in monospace font. For example, I might list the following 
formula:

=VLOOKUP(StockNumber,PriceList,2,False)

Excel supports a special type of formula known as an array formula. When you enter an array formula, 
press Ctrl+Shift+Enter (not just Enter). Excel encloses an array formula in curly braces to remind you 
that it’s an array formula.

Note 	

Don’t type the curly braces for an array formula. Excel puts them in automatically.

Key names
Names of keys on the keyboard appear in normal type: for example, Alt, Home, PgDn, and Ctrl. When 
you need to press two or more keys simultaneously, the keys are connected with a plus sign: Press 
Ctrl+G to display the Go To dialog box.

The Ribbon
Excel 2013 features the Ribbon user interface, which was introduced in Excel 2007.

When you need to select a command by using the Ribbon, I describe the command by using the tab 
name, the group name, and the command name: for example, Choose Home➜Alignment➜Wrap 
Text. This command translates to “Click the Home tab, locate the Alignment group, and then click the 
Wrap Text button.”

Some commands use a drop-down Ribbon control. For example: Home➜Styles➜Conditional 
Formatting➜New Rule. In this case, you need to click the down-pointing arrow on the Conditional 
Formatting control in order to access the New Rule command.

Many commands begin with the word File. Clicking the File tab takes you to the Backstage View.

www.it-ebooks.info

http://www.it-ebooks.info/


Introduction 3

Functions, procedures, and named ranges
The names of the Excel worksheet functions appear in all uppercase letters: for example, “Use the 
SUM function to add the values in column A.”

Unless you’re dealing with text inside quotation marks, Excel isn’t sensitive to case. In other words, 
both the following formulas produce the same result:

=SUM(A1:A50)
=sum(a1:a50)

Excel, however, converts the characters in the second formula to uppercase.

Mouse conventions
The mouse terminology in this book is all standard fare: pointing, clicking, right-clicking, dragging, 
and so on. You know the drill.

What the icons mean
Throughout this book, icons appear in the left margin to call your attention to points that are particu-
larly important.

Note 	

I use Note icons to tell you that something is important — perhaps a concept that can 
help you master the task at hand or something fundamental for understanding subse-
quent material.

Caution	

I use Caution icons when the operation I’m describing can cause problems if you’re not 
careful.

Cross-Ref	

I use the Cross-Reference icon to refer you to other tips that have more to say on a par-
ticular topic.
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How This Book Is Organized
To provide some semblance of order, I grouped these tips and tricks into six parts:

➤	 Part I: Workbooks and Files

➤	 Part II: Formatting

➤	 Part III: Formulas

➤	 Part IV: Working with Data

➤	 Part V: Tables and Pivot Tables

➤	 Part VI: Charts and Graphics

How to Use This Book
This book really isn’t intended to be read from cover to cover, as you would read a novel — but I’m 
sure that some people will do so. More likely, you’ll want to use it as a reference book and consult it 
when necessary. If you’re faced with a challenging task, you may want to check the index first to see 
whether the book specifically addresses your problem. The order of the parts and tips is arbitrary. 
Most readers will probably skip around and pick up useful tidbits here and there.

There are also an additional 30 bonus tips that you’ll find at www.dummies.com/go/101excel 
2013tips.

About the Power Utility Pak Offer
Toward the back of this book is a coupon that you can redeem for a discounted copy of my award-
winning Power Utility Pak — a collection of useful Excel utilities, plus many new worksheet functions.

You can also use this coupon to purchase the complete VBA source code for a nominal fee. Study-
ing the code is an excellent way to pick up some useful programming techniques. You can  
take the product for a test drive by downloading the trial version from my website at http: 
//spreadsheetpage.com.

Note 	

Power Utility Pak version 7 requires the Windows version of Excel 2007 or later.
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PART I
Workbooks  
and Files
In this part, you’ll find tips and tricks covering some of the basics of Excel, including 
Protected View and AutoRecover, as well as working with the Quick Access toolbar 
and charging Excel’s color scheme.
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Tip 1: Changing the Look of Excel 7

Changing the Look of Excel
With Excel 2013, what you see isn’t necessarily what you have to live with. This tip describes several 
ways to change the look of Excel. Some changes affect only the appearance. Other options allow you 
to hide various parts of Excel to make more room for displaying your data — or maybe because you 
prefer a less-cluttered look.

Cosmetic changes
When the preview version of Microsoft Office 2013 became available, there was a minor uproar 
about its appearance. Compared to previous versions, the applications looked “flat” and many com-
plained about the overall white color.

When the final version was released, Microsoft added two alternative Office themes: light gray and 
dark gray. To switch to a different theme, choose File➜Options to display the Excel Options dialog 
box. Click the General tab and use the Office Theme drop-down list (see Figure 1-1). The theme 
choice affects the appearance of the title bar, row and column borders, task panes, the taskbar, and a 
few other items. The theme you choose applies to all other Office 2013 applications.

Figure 1-1: Selecting a different Office theme.

Figure 1-1 shows another option: Office Background. Use this drop-down list to select a background 
image that appears in the Excel title bar. Fortunately, one of the options is No Background.
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Hiding the Ribbon
To hide the Ribbon, click the Ribbon Display Options drop-down menu in the Excel title bar. You’ll 
see the choices shown in Figure 1-2.

Figure 1-2: Choosing how the Ribbon works.

Using options on the View tab
The View tab, shown in Figure 1-3, has three groups of commands that determine what you see 
onscreen.

➤	 Workbook Views group: These options control the overall view. Most of the time, you’ll use 
Normal view. Page Layout view is useful if you require precise control over how the pages 
are laid out. Page Break Preview also shows page breaks, but the display isn’t nearly as nice. 
The status bar has icons for each of these views. Custom Views enable you to create named 
views of worksheet settings (for example, a view in which certain columns are hidden).

➤	 Show group: The four checkboxes in this group control the visibility of the Ruler (relevant 
only in Page Layout view), the Formula bar, worksheet gridlines, and row and column 
headings.

➤	 Zoom group: These commands enable you to zoom the worksheet in or out. Another way to 
zoom is to use the Zoom slider on the status bar.

Figure 1-3: Controls on the View tab.
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Hiding other elements
To hide other elements, you must make a trip to the Advanced tab of the Excel Options dialog box 
(choose File➜Options). Figure 1-4 shows workbook display options and worksheet display options. 
These options are self-explanatory.

Figure 1-4: Display options on the Advanced tab of the Excel Options dialog box.

Hiding the status bar
You can also hide the status bar, at the bottom of the Excel window. Doing so, however, requires VBA 
code.

	 1.	 Press Alt+F11 to display the Visual Basic Editor.

	 2.	 Press Ctrl+G to display the Immediate window.

	 3.	 Type this statement and press Enter:

Application.DisplayStatusBar = False

The status bar will be removed from all open workbook windows. To redisplay the status bar, repeat 
those instructions, but specify True in the statement.
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Customizing the Quick Access Toolbar
If you find that you continually need to switch Ribbon tabs because a frequently used command 
never seems to be on the Ribbon that’s displayed, this tip is for you. The Quick Access toolbar is 
always visible, regardless of which Ribbon tab is selected. After you customize the Quick Access tool-
bar, your frequently used commands will always be one click away.

Note 	

The only situation in which the Quick Access toolbar is not visible is when the title bar is 
hidden (by choosing Auto-Hide the Ribbon from the Ribbon Display Options drop-down 
list in the title bar).

About the Quick Access toolbar
By default, the Quick Access toolbar is located on the left side of the Excel title bar, and it includes 
three tools:

➤	 Save: Saves the active workbook.

➤	 Undo: Reverses the effect of the last action.

➤	 Redo: Reverses the effect of the last undo.

Commands on the Quick Access toolbar always appear as small icons, with no text. When you hover 
your mouse pointer over an icon, you see the name of the command and a brief description.

As far as I can tell, the number of icons that you can add to your Quick Access toolbar is limitless. But 
regardless of the number of icons, the Quick Access toolbar always displays a single line of icons. If 
the number of icons exceeds the Excel window width, it displays an additional icon at the end: More 
Controls. Click the More Controls icon, and the hidden Quick Access toolbar icons appear in a pop-up 
window.

Adding new commands to the Quick Access toolbar
You can add a new command to the Quick Access toolbar in three ways:

➤	 Click the Quick Access toolbar drop-down control, which displays a down-pointing arrow 
and is located on the right side of the Quick Access toolbar (see Figure 2-1). The list contains 
several commonly used commands. Select a command from the list, and Excel adds it to your 
Quick Access toolbar.

➤	 Right-click any control on the Ribbon and choose Add to Quick Access Toolbar. The control is 
added to your Quick Access toolbar, positioned after the last control.

➤	 Use the Quick Access Toolbar tab of the Excel Options dialog box. A quick way to access this 
dialog box is to right-click any Quick Access toolbar or Ribbon control and choose Customize 
Quick Access Toolbar.
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Figure 2-1: The Quick Access toolbar drop-down menu is one way to add a new command to the Quick Access 
toolbar.

Figure 2-2 shows the Quick Access Toolbar tab of the Excel Options dialog box. The left side of the dia-
log box displays a list of Excel commands, and the right side shows the commands that are now on the 
Quick Access toolbar. Above the command list on the left is a drop-down control that lets you filter the 
list. Select an item from the drop-down list, and the list displays only the commands for that item.

Figure 2-2: Use the Quick Access Toolbar tab in the Excel Options dialog box to customize the Quick Access 
toolbar.
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Some of the items in the drop-down list are described here:

➤	 Popular Commands: Displays commands that Excel users commonly use.

➤	 Commands Not in the Ribbon: Displays a list of commands that you cannot access from the 
Ribbon.

➤	 All Commands: Displays a complete list of Excel commands.

➤	 Macros: Displays a list of all available macros.

➤	 File Tab: Displays the commands available in the back stage window.

➤	 Home Tab: Displays all commands that are available when the Home tab is active.

In addition, the drop-down list contains an item for every other tab.

Sometimes, you need to do some guessing to find a particular command. For example, if you want to 
add the command that displays the Excel Options dialog box, you can find it listed as Options, not 
Excel Options.

Note 	

Some commands simply aren’t available. For example, I’d like the Quick Access toolbar 
to display the command to toggle the “dashed line” page break display on a worksheet. 
The only way to issue that command is to display the Advanced tab of the Excel Options 
dialog box and then scroll down until you find the Show Page Breaks checkbox. No com-
mand for doing so can be added to the Quick Access toolbar.

To add an item to your Quick Access toolbar, select it from the list on the left and click Add. If you add 
a macro to your Quick Access toolbar, you can click the Modify button to change the text and choose 
a different icon for the macro.

Notice the drop-down control above the list on the right. This lets you create a Quick Access toolbar 
that’s specific to a particular workbook, which is most useful when you add workbook-specific macro 
commands to the Quick Access toolbar. Most of the time, you’ll use the setting labeled For All 
Documents (Default).

The only time you ever need to use the Quick Access Toolbar tab of the Excel Options dialog box is 
when you want to add a command that’s not on the Ribbon or add a command that executes a 
macro. In all other situations, it’s much easier to locate the command on the Ribbon, right-click the 
command, and choose Add to Quick Access Toolbar.

Only you can decide which commands to put on your Quick Access toolbar. In general, if you find 
that you use a particular command frequently, it should probably be on your Quick Access toolbar.
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Performing other Quick Access toolbar actions
Here are some other things you can do with your Quick Access toolbar:

➤	 Rearrange the Quick Access toolbar icons. If you want to change the order of your Quick 
Access toolbar icons, you can do so on the Customization tab of the Excel Options dialog 
box. Select the command and then use the up- and down-arrow buttons on the right to 
move the icon.

➤	 Display the Quick Access toolbar below the ribbon. To change the position of the Quick 
Access toolbar, choose the down-pointing arrow control and select Show below the Ribbon.

➤	 Remove Quick Access toolbar icons. The easiest way to remove an icon from your Quick 
Access toolbar is to right-click the icon and choose Remove from Quick Access Toolbar. You 
can also use the Quick Access Toolbar tab of the Excel Options dialog box. Just select the 
command in the list on the right and click the Remove button.

➤	 Share your Quick Access toolbar. Use the Import/Export button to save a file that contains 
your Quick Access toolbar customization. You can then share this file with others. 
Unfortunately, this file also contains any Ribbon customizations that you might have made 
(see Tip 3). In other words, you can’t share your Quick Access toolbar without also sharing 
your Ribbon customizations.

➤	 Reset the Quick Access toolbar. If you want to return the Quick Access toolbar to its default 
state, display the Quick Access Toolbar tab in the Excel Options dialog box and click the 
Reset button and choose Reset Only Quick Access Toolbar. All your customizations disap-
pear, and the Quick Access toolbar then displays its three default commands. 
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Customizing the Ribbon
Tip 2 describes how to customize the Quick Access toolbar by adding Ribbon commands, but some 
users prefer to make some changes to the Ribbon itself.

You can customize the Ribbon in these ways:

➤	 Add a new tab.

➤	 Add a new group to tab.

➤	 Add commands to a group.

➤	 Remove groups from a tab.

➤	 Remove commands from custom groups.

➤	 Change the order of the tabs.

➤	 Change the order of the groups within a tab.

➤	 Change the name of a tab.

➤	 Change the name of a group.

➤	 Reset the Ribbon to remove all customizations.

That’s a fairly comprehensive list of customization options, but you cannot do some actions:

➤	 You cannot remove built-in tabs — but you can hide them.

➤	 You cannot add commands to built-in groups.

➤	 You cannot remove commands from built-in groups.

➤	 You cannot change the order of commands in a built-in group.

Note 	

Unfortunately, you can’t customize the Ribbon (or Quick Access toolbar) by using VBA 
macros. However, developers can write RibbonX code and store it in workbook files. 
When the file is open, the Ribbon is modified to display new commands. Writing 
RibbonX is relatively complicated and is the subject of several complete books.

How to customize the Ribbon
You customize the Ribbon in the Customize Ribbon tab of the Excel Options dialog box (see Figure 3-1). 
The quickest way to display this dialog box is to right-click anywhere in the Ribbon and choose 
Customize the Ribbon.
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Figure 3-1: The Customize Ribbon tab of the Excel Options dialog box.

Customizing the Ribbon is very similar to customizing the Quick Access toolbar, which is described in 
Tip 2. The only difference is that you need to decide where to put the command within the Ribbon. 
Here’s the general procedure:

	 1.	 Right-click any part of the Ribbon, and choose Customize the Ribbon. Excel displays the 
Customize Ribbon tab of the Excel Options dialog box. 

	 2.	 Use the drop-down list on the left (labeled Choose Command From) to display various 
groups of commands.

	 3.	 Locate the command you want in the list box on the left and select it.

	 4.	 Use the drop-down list on the right (labeled Customize the Ribbon) to choose a group of tabs.

		  Main Tabs refers to the tabs that are always visible; Tool Tabs refers to the context tabs that 
appear when a particular object is selected.

	 5.	 In the list box on the right, select the tab and the group where you want to put the command.

		  You must click the “plus sign” controls to expand the hierarchical lists. Remember that you 
cannot add commands to built-in groups, so you may need to use the New Tab or New 
Group buttons to add a tab or group.

	 6.	 Click the Add button to add the selected command from the left to the group on the right.

When you are finished making your Ribbon changes, click OK to close the Excel Options dialog box.
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New tabs and groups are given generic names, so you’ll probably want to give them more meaning-
ful names. Use the Rename button to rename the selected tab or group. You can also rename built-in 
tabs and groups.

Although you cannot remove a built-in tab, you can hide the tab by unchecking the check box next 
to its name.

Figure 3-2 shows a part of a customized Ribbon. In this case, I added a group to the View tab. The 
new Text To Speech group has five commands. I inserted this new group between the Zoom and the 
Window groups.

Figure 3-2: The View tab, with a new group added.
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Understanding Protected View
There’s an excellent chance that you’ve already encountered an Excel feature known as Protected 
View. Although it may seem like Excel is trying to keep you from opening your own files, Protected 
View is all about protecting you from malware.

Malware refers to something that can harm your system. Hackers have figured out several ways to 
manipulate Excel files so that harmful code can execute. Protected View essentially prevents these 
types of attacks by opening a file in a protected environment (sometimes called a sandbox).

If you open an Excel workbook that you downloaded from the web, you’ll see a colorful message 
above the Formula bar (see Figure 4-1). In addition, Excel’s title bar displays the text [Protected View].

Figure 4-1: This message tells you the workbook was opened in Protected View.

If you’re certain that the file is safe, click Enable Editing. If you don’t enable editing, you’ll be able to 
view the contents of the workbook, but you won’t be able to make any changes to it.

If the workbook contains macros, you’ll see another message after you enable editing: Security 
Warning. Macros Have Been Disabled. If you’re sure that the macros are harmless, click Enable Content.

What causes Protected View?
Protected View kicks in for the following:

➤	 Files downloaded from the Internet

➤	 Attachments opened from Outlook

➤	 Files that open from potentially unsafe locations, such as your Temporary Internet Files 
folder

➤	 Files that are blocked by File Block Policy (a feature that allows administrators to define 
potentially dangerous files)

➤	 Files that were digitally signed, but the signature has expired

You have some control over how Protected View works. To change the settings, choose File➜Options 
and click Trust Center. Then click the Trust Center Settings button and click the Protected View tab in 
the Trust Center dialog box. Figure 4-2 shows the options. By default, all three options are checked.
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Figure 4-2: Change the Protected View settings in the Trust Center dialog box.

If you want to explicitly open a file in Protected View, choose File➜Open to display the Open dialog 
box. Select your file and then click the arrow to the right of the Open button. One of the options dis-
played is Open in Protected View.

If you enable editing in a workbook that opened in Protected View and then save the workbook, it 
will no longer open in Protected View.

Printing and copying
In some situations, you don’t care about working with the document. You just want to print it. 
Unfortunately, it’s not even possible to print a workbook unless you exit Protected View. Choose 
File➜Print and then click the Enable Printing button to exit Protected View.

Note that you can copy worksheet data from a Protected View document and paste it to another 
workbook. Formulas are not copied, but the current formula results are.

Forcing a file to open in Normal view
If you download a workbook and you’re absolutely certain that it’s safe, you can force it to open in 
Normal view. After downloading the workbook:

	 1.	 Right-click the workbook name (or icon) and choose Properties from the shortcut menu.

		  The Properties dialog box appears.

	 2.	 Click the General tab (see Figure 4-3).

	 3.	 Click the Unblock button.

	 4.	 Click OK to close the Properties dialog box.
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After performing these steps, the workbook will open in Excel in Normal view (not Protected View).

Figure 4-3: Forcing a workbook to open in Normal view.
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Understanding AutoRecover
If you’ve used computers for any length of time, you’ve probably lost some work. You forgot to save 
a file, or maybe the power went out and your unsaved work was lost. Or maybe you were working on 
something and didn’t think it was important, so you closed it without saving — and later realized 
that it was important. The AutoRecover feature in Excel can make these types of “doh!” moments less 
frequent.

As you work in Excel, your work is periodically saved, automatically. It happens in the background, so 
you don’t even know that it’s happening. You have the ability to access these autosaved versions of 
your work — even workbooks that you never explicitly saved.

This feature consists of two components:

➤	 Versions of a workbook are saved automatically, and you can view them.

➤	 Workbooks that you close without saving are saved as draft versions.

Recovering versions of the current workbook
To see whether any previous versions of the current workbook are available, choose File➜Info. The 
section labeled Versions lists the available old versions (if any) of the current workbook. Figure 5-1 
shows that two autosaved versions of the active workbook are available.

Figure 5-1: Two autosaved versions of this workbook are available.

You can open an autosaved version by clicking its name. Remember that opening an autosaved ver-
sion won’t automatically replace the current version of your workbook. Therefore, you can decide 
whether the autosaved version is preferable to the current version. Or you can just copy some infor-
mation that may have been accidentally deleted and paste it into your current workbook.

When you close the workbook, the autosaved versions are deleted.

Recovering unsaved work
When you close a workbook without saving your changes, Excel asks whether you want to save your 
changes. If that unsaved workbook has an autosaved version, the dialog box informs you of that fact, 
as shown in Figure 5-2.
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Figure 5-2: If you close a workbook without saving, Excel tells you whether an autosaved version will be available.

To recover a workbook that you closed without saving, choose File➜Info➜Manage Versions and 
choose Recover Unsaved Workbooks. You see a list of all unsaved versions of your workbooks. You 
can open them and (hopefully) recover something that you needed. These drafts are also listed in the 
recent file list, which displays when you choose File➜Recent.

Draft versions of unsaved workbooks are deleted after four days or until you edit the file.

Note 	

You can choose how AutoRecover works in the Save tab of the Excel Options dialog box. 
For example, you can change the autosave time interval (the default is 10 minutes), turn 
off autosave for a particular workbook, or disable this feature for all workbooks.
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Using a Workbook in a Browser
Microsoft’s Office Web Apps enable you to create, view, and edit workbooks directly in a browser. 
The experience isn’t exactly the same as using the desktop version of Excel, but it’s very similar. A key 
advantage is that you can access your workbooks from any location, and Excel need not be installed 
on the computer you use.

Note 	

This tip assumes that you have a Microsoft SkyDrive account (free) and are logged in. 
You can also use SharePoint.

After creating a workbook, choose File➜Save As and choose a location on your SkyDrive. This action 
saves your workbook on the cloud, and also saves a copy in your local SkyDrive folder. The two ver-
sions are synched.

Open your web browser and navigate to skydrive.com. Locate the workbook and click it. The work-
book appears in the Excel Web App. Figure 6-1 shows a workbook displayed in the Google Chrome 
browser. As you can see, it’s remarkably similar to the desktop version of Excel.

The Excel Web App is lacking some features, compared to the desktop version. For example, the fol-
lowing are not supported by the Excel Web App:

➤	 Macros

➤	 Add-ins

➤	 Data validation

➤	 Comments

➤	 Shapes and other inserted objects

Some features, such as worksheet protection, prevent the workbook from being opened.

Cloud computing is a great idea, and it could be a significant part of the future of computing. But it 
can also be frustrating because you’re at the mercy of your Internet provider and Microsoft. What if 
you need to get some work done, and the file you need is on the cloud? The message shown in 
Figure 6-2 could be frustrating.
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Figure 6-1: Viewing a workbook in a web browser.

Figure 6-2: The downside to storing your work in the cloud.
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Saving to a Read-Only Format
If you need to share information in a workbook with someone — and be assured that the informa-
tion remains intact and isn’t altered — you have several choices.

Send a printed copy
Printing a workbook on paper is the low-tech approach. If the recipient is not nearby, this option may 
also require some type of delivery service.

Send an electronic copy in the form of a PDF file
PDF files (for Portable Document Format) is a common file format, and just about everyone has soft-
ware installed that displays PDF files.

To save a workbook as a PDF file, choose File➜Export➜Create PDF/XPS Document and click the 
Create PDF/XPS button to display the Publish as PDF or XPS dialog box. Click the Options button for 
additional options:

➤	 Choose the pages

➤	 Specify what to save (the current range selection, the selected sheet(s), or the entire  
workbook

➤	 Save document properties and accessibility information

For best results, use Excel’s Page Layout view (View➜Workbook View➜Page Layout) before saving, 
so you’ll see exactly how the pages will break. Figure 7-1 shows Adobe Reader displaying an Excel 
workbook that was saved as a PDF file.

Note 	

Excel provides another option: XPS format (for XML Paper Specification). This is 
Microsoft’s format. When exporting from Excel, it’s limited to a single worksheet, and it 
doesn’t support images. An XPS viewer is installed with Windows. This format is not 
widely used.
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Figure 7-1: Adobe Reader displaying a PDF file created from an Excel workbook.

Send an MHTML file
Many Excel users don’t know about this file format. An MHTML faithfully renders an Excel workbook 
in a single file that can be opened with many browsers, including Internet Explorer, Opera, and 
Mozilla Firefox (extension required). Choose File➜Save As to display the Save As dialog box. Then 
select Single File Web Page (*.mht, *.mhtl) from the Save As Type drop-down menu.

Figure 7-2 shows a workbook that was saved as an MHTML file, displayed in the Internet Explorer 
browser. Note the worksheet tabs displayed along the bottom.
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If you need to send a read-only, non-alterable workbook, the MHTML format is probably your best 
choice (assuming that the recipient has a browser that supports this format).

Figure 7-2: An Excel workbook saved as an MHTML file and displayed in a web browser.
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Generating a List of Filenames
This tip describes how to retrieve a list of filenames in a folder and display them in a worksheet.

This technique uses an Excel 4 XLM macro function in a named formula. It’s useful because it’s a rela-
tively simple way of getting a list of filenames into a worksheet — something that normally requires 
a complex VBA macro.

Start with a new workbook and then follow these steps to create a named formula:

	 1.	 Choose Formulas➜Define Name to display the New Name dialog box.

	 2.	 Type FileList in the Name field.

	 3.	 Enter the following formula in the Refers To field (see Figure 8-1):

=FILES(Sheet1!$A$1)

	 4.	 Click OK to close the New Name dialog box.

Figure 8-1: Using the New Name dialog box to create a named formula.

Note that the FILES function is not a normal worksheet function. Rather, it’s an old XLM style macro 
function that is intended to be used on a special macro sheet. This function takes one argument (a 
directory path and a file specification) and returns an array of filenames in that directory that match 
the file specification.

A normal worksheet formula cannot use these old XLM functions, but named formulas can.

After defining the named formula, enter a directory path and file specification into cell A1. For example:

E:\Backup\Excel\*.xl*

Then this formula displays the first file found:

=INDEX(FileList, 1)

If you change the second argument to 2, it displays the second file found, and so on.
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Figure 8-2 shows an example. The path and file specification is in cell A1. Cell A2 contains this for-
mula, copied down the column:

=INDEX(FileList,ROW()-1)

The ROW function, as used here, generates a series of consecutive integers: 1, 2, 3, and so on. These 
integers are used as the second argument for the INDEX function. Note that cell A21 (and cells below 
it) displays an error. That’s because the directory has only 19 files, and the formula is attempting to 
display files that don’t exist.

When you change the directory or filespec in cell A1, the formulas update to display the new filenames.

Figure 8-2: Using an XLM macro in a named formula can generate a list of filenames in a worksheet.

Note 	

If you use this technique, you must save the workbook as a macro-enabled file (with an 
*.xlsm or *.xls extension).
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Generating a List of Sheet Names
Oddly, Excel doesn’t provide a direct way to generate a list of sheet names in a workbook. This tip 
describes how to generate a list of all the sheets in a workbook. Like the previous tip (“Generating a 
List of Filenames”), this tip uses an Excel 4 XLM macro function in a named formula.

Start with a workbook that has lots of worksheets or chart sheets. Then follow these steps to create a 
list of the sheet names:

	 1.	 Insert a new worksheet to hold the list of sheet names.

	 2.	 Choose Formulas➜Define Name to display the New Name dialog box.

	 3.	 Type SheetList in the Name field.

	 4.	 Enter the following formula in the Refers To field (see Figure 9-1):

=REPLACE(GET.WORKBOOK(1),1,FIND(“]”,GET.WORKBOOK(1)),””)

	 5.	 Click OK to close the New Name dialog box.

Figure 9-1: Using the New Name dialog box to create a named formula.

Note that this formula uses the GET.WORKBOOK function — which is not a normal worksheet func-
tion. Rather, it’s an old XLM-style macro function intended for use on a special macro sheet. Using an 
argument of 1 returns an array of sheet names, and each name is preceded by the workbook name. 
The REPLACE and FIND functions remove the workbook name from the sheet names.

To generate the sheet names, enter this formula in cell A1, and then copy it down the column:

=INDEX(SheetList,ROW())
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Figure 9-2 shows this formula in the range A1:A10. The workbook has seven sheets, so the formula 
returns a #REF! error when it attempts to display a nonexistent sheet name. To eliminate this error, 
modify the formula as follows:

=IFERROR(INDEX(SheetList,ROW()),””)

Figure 9-2: Using a formula to display a list of sheet names.

The list of sheet names will adjust if you add sheets, delete sheets, or rename sheets — but the 
adjustment doesn’t happen automatically. To force the formulas to update, press Ctrl+Alt+F9. If you 
want the sheet names to adjust automatically when the workbook is calculated, edit the named for-
mula to make it “volatile.”

=REPLACE(GET.WORKBOOK(1),1,FIND(“]”,GET.WORKBOOK(1)),””)&T(NOW())

What good is a list of sheet names? Figure 9-3 shows a table of contents created by using the 
HYPERLINK function. The formula in cell B1 is

=HYPERLINK(“#”&A1&”!A1”,”Go to sheet”)

Clicking a hyperlink activates the worksheet and selects cell A1. Unfortunately, Excel doesn’t support 
hyperlinking to a chart sheet, so you get an error if a hyperlink points to a chart sheet.
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Figure 9-3: Creating a list of hyperlinks.

Note 	

If you use this technique, you must save the workbook as a macro-enabled file (with an 
*.xlsm or *.xls extension).
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Using Document Themes
Over the years, I’ve seen hundreds of Excel workbooks that were created by others. A significant per-
centage of these workbooks have one thing in common: They are ugly!

In an effort to help users create more professional-looking documents, Microsoft designers (starting 
with Office 2007) incorporated the concept of Office document themes. Using themes is an easy (and 
almost foolproof) way to specify the colors and fonts and a variety of graphical effects in a document. 
Best of all, changing the entire look of your document is a breeze. A few mouse clicks is all it takes to 
apply a different theme and change the look of your workbook.

Importantly, the concept of themes is incorporated into other Office applications. Therefore, a com-
pany can easily create a standard look for all its documents.

Elements within Excel that are controlled by document themes are

➤	 Cells and ranges that use theme colors (as opposed to standard colors)

➤	 Tables

➤	 Charts

➤	 Conditional formatting (but not always)

➤	 Sparkline graphics

➤	 Pivot tables

➤	 PivotTable slicers and timelines

➤	 Shapes

➤	 SmartArt

➤	 WordArt

➤	 Sheet tab colors

Figure 10-1 shows a worksheet that contains various Excel elements. These items all use the default 
theme, which is known as Office Theme.

Figure 10-2 shows the same worksheet after applying a different document theme. The different 
theme changes the fonts, colors (which may not be apparent in the figure), and graphical effects for 
the SmartArt diagram.
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Figure 10-1: The elements in this worksheet use default formatting.

Figure 10-2: The worksheet, after applying a different theme.
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Applying a theme
Figure 10-3 shows the theme choices that appear when you choose Page➜Layout➜Themes. This 
display is a live preview. As you move your mouse over the theme choices, the active worksheet dis-
plays the theme. When you see a theme you like, click it to apply the theme to all worksheets in the 
workbook.

A theme applies to the entire workbook. You cannot use different themes on different worksheets 
within a workbook.

Figure 10-3: The built-in Excel theme choices.

When you specify a particular theme, you find that the gallery choices for various elements reflect 
the new theme. For example, the chart styles that you can choose from vary, depending on which 
theme is active.

Note 	

Because themes use different fonts and font sizes, changing to a different theme can 
affect the layout of your worksheet. For example, after you apply a new theme, a work-
sheet that printed on a single page may spill over to a second page. Therefore, you may 
need to make some adjustments after you apply a new theme. For best results, decide 
on a theme before you do too much work on the file.
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Customizing a theme
Office 2013 includes quite a few themes. If that’s not enough, you can modify them and even create 
your own themes.

Notice that the Page Layout➜Themes group contains three other controls: Colors, Fonts, and Effects. 
You can use these controls to change just one of the three components of a theme. For example, if 
you like the Urban theme but prefer different fonts, apply the Urban theme and then specify your 
preferred font set by using the Page Layout➜Themes➜Fonts control.

Each theme uses two fonts (one for headers and one for the body), and in some cases, these two 
fonts are the same. If none of the theme choices is suitable, choose Page Layout➜Themes➜Fonts➜ 

Create New Theme Fonts to specify the two fonts you prefer (see Figure 10-4). When you use the 
Home➜Fonts➜Font command, the two fonts from the current theme are listed first in the drop-
down list.

Figure 10-4: Use this dialog box to specify two fonts for a theme.

Use the Page Layout➜Themes➜Colors command to select a different set of colors. Also, if you’re so 
inclined, you can even create a custom set of colors by choosing Page Layout➜Themes➜Colors➜ 

Customize Colors. This command displays the dialog box shown in Figure 10-5. Note that each 
theme consists of 12 colors. Four of the colors are for text and backgrounds, six are for accents, and 
two are for hyperlinks. The first ten are the colors that appear in theme color selector controls. As you 
specify different colors, the Preview panel in the dialog box is updated.
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Figure 10-5: If you’re feeling creative, you can specify a set of custom colors for a theme.

Theme effects operate on graphical elements, such as SmartArt, shapes, and charts. You can’t cus-
tomize theme effects.

If you customize a theme by using different fonts or colors, you can save the new theme by choosing 
Page Layout➜Themes➜Save Current Theme. Your customized themes appear in the theme list in 
the Custom category. Other Office applications, such as Word and PowerPoint, can use these theme 
files.
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Understanding Excel Compatibility Issues
The most recent version of Excel is known as Excel 2013, and it’s version 15. Microsoft’s version num-
bering is a bit misleading because they’ve only released 12 versions of Excel for Windows. The first 
version was Excel 2, and they skipped right over versions 6 and 13.

Besides Excel 2013, three other versions of Excel for Windows are still widely used: Excel 2003, Excel 
2007, and Excel 2010.

If you create workbooks only for Excel 2013 users, you can skip this tip because you don’t have to be 
concerned with compatibility. But if you create workbooks for those who use an earlier version, you 
need to understand compatibility.

The Excel 2013 file formats
The current Excel file formats (all of which were introduced in Excel 2007) are

➤	 .xlsx: A workbook file that doesn’t contain macros

➤	 .xlsm: A workbook file that contains macros

➤	 .xltx: A workbook template file that doesn’t contain macros

➤	 .xltm: A workbook template file that contains macros

➤	 .xlsa: An add-in file

➤	 .xlsb: A binary file that’s similar to the old .xls format but able to accommodate the new  
features

➤	 .xlsk: A backup file

With the exception of .xlsb, these are all “open” XML files, which means that the file format is not pro-
prietary and other applications can read and write these types of files.

Note 	

The XML files are actually zip-compressed text files. If you rename one of these files to 
have a .zip extension, you can examine the contents using any of several zip file utilities — 
including the zip file support built into Windows. Taking a look at the innards of an Excel 
workbook is an interesting exercise for curious-minded users.

The Office Compatibility Pack
Normally, those who use a version prior to Excel 2007 can’t open workbooks saved in the newer Excel 
file formats. But, fortunately, Microsoft has released a free Compatibility Pack for Office 2003 and 
Office XP.

If an Office 2003 or Office XP user installs the Compatibility Pack, he can open files created in Office 
2007 or later and save files in the newer format. The Office programs that are affected are Excel, 

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 11: Understanding Excel Compatibility Issues38

Word, and PowerPoint. This software doesn’t endow the older versions with any new features — it 
just gives them the capability to open and save files in the new format.

To download the Compatibility Pack from Microsoft, search the web for Office Compatibility Pack.

It’s important to understand the limitations regarding version compatibility. Even though your col-
league is able to open your file, there is no guarantee that everything will function correctly or look 
the same.

Checking compatibility
If you save your workbook to an older file format (such as .xls, for versions prior to Excel 2007), Excel 
automatically runs the Compatibility Checker. The Compatibility Checker identifies the elements of 
your workbook that will result in a loss of functionality or fidelity (cosmetics).

Figure 11-1 shows the Compatibility Checker dialog box. Click the Select Versions to Show button to 
limit the compatibility-checking to a specific version of Excel.

Figure 11-1: The Compatibility Checker is a useful tool for those who share workbooks with other people.

The bottom part of the Compatibility Checker lists the potential compatibility problems. To display 
the results in a more readable format, click the Copy to New Sheet button.

Keep in mind that compatibility problems also can occur with Excel 2007 and Excel 2010, even 
though these versions use the same file format as Excel 2013. You can’t expect features that are new 
to Excel 2013 to work in earlier versions. For example, if you add slicers to table (a new feature in 
Excel 2013) and send it to a colleague who uses Excel 2010, the slicers won’t be displayed. In addi-
tion, formulas that use any of the new worksheet functions will return an error. The Compatibility 
Checker identifies these types of problems.
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Where to Change Printer Settings
If you want to print a copy of a worksheet with no fuss and bother, use the Quick Print option. One 
way to access this command is to choose File➜Print (which displays the Print pane of Backstage 
view) and then click the Print button.

However, if the default print settings aren’t good enough, you must make some adjustments. A little 
tweaking of the print settings can often improve your printed reports.

Unfortunately, Excel has no one-stop location for adjusting print setting. You can adjust print set-
tings in three places:

➤	 The Print settings screen in Backstage view, which opens when you choose File➜Print.

➤	 The Page Layout tab of the Ribbon.

➤	 The Page Setup dialog box, which opens when you click the dialog launcher in the lower-
right corner of the Page Layout➜Page Setup group on the Ribbon. You can also access the 
Page Setup dialog box from the Print settings screen in Backstage view.

Table 12-1 summarizes the locations where you can make various types of print-related adjustments 
in Excel 2013.

Table 12-1: Where to Change Printer Settings 

Setting Print Settings 
Screen

Page Layout  
Tab of Ribbon

Page Setup  
Dialog Box

Number of copies X

Printer to use X

What to print X

Specify worksheet print area X X

1-sided or 2-sided X

Collated X

Orientation X X X

Paper size X X X

Adjust margins X X X

Specify manual page breaks X

Specify repeating rows and/or columns X

Set print scaling X X

Print or hide gridlines X X

Print or hide row and column headings X X

continued
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Table 12-1: Where to Change Printer Settings (continued)

Setting Print Settings 
Screen

Page Layout  
Tab of Ribbon

Page Setup  
Dialog Box

Specify the first page number X

Center output on page X

Specify repeating rows or columns X

Specify header/footers and options X

Specify how to print cell comments X

Specify page order X

Specify black-and-white output X

Specify how to print error cells X

Launch dialog box for printer-specific  
settings

X X

This table might make printing seem more complicated than it really is. The key point to remember is 
this: If you can’t find a way to make a particular adjustment, it’s probably available from the Page 
Setup dialog box.
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PART II
Formatting
Excel has lots of formatting options to make your work look good. In this part, you’ll 
find tips that cover formatting numbers, copying formatting, and other topics.
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Working with Merged Cells
Merging cells is a simple concept: Join two or more cells to create a larger single cell. To merge cells, 
just select them and choose Home➜Alignment➜Merge & Center. Excel combines the selected cells 
and displays the contents of the upper-left cell, centered.

Merging cells is usually done as a way to enhance the appearance of a worksheet. Figure 13-1, for 
example, shows a worksheet with four sets of merged cells: C2:I2, J2:P2, B4:B8, and B9:B13. The 
merged cells in column B also use vertical text.

Figure 13-1: This worksheet has four sets of merged cells.

Remember that merged cells can contain only one piece of information: a single value, text, or a for-
mula. If you attempt to merge a range of cells that contains more than one nonempty cell, Excel 
prompts you with a warning that only the data in the upper-leftmost cell will be retained.

To unmerge cells, just select the merged area and click the Merge and Center button again.
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Other merge actions
Notice that the Merge and Center button is a drop-down menu. If you click the arrow, you see three 
additional commands:

➤	 Merge Across: Lets you select a range and then creates multiple merged cells — one for 
each row in the selection.

➤	 Merge Cells: Works just like Merge and Center, except that the content of the upper-left cell 
is not centered. (It retains its original horizontal alignment.)

➤	 Unmerge Cells: Unmerges the selected merged cell.

Wrapping text in merged cells is an easy way to display lengthy text. To make text wrap in merged 
cells, select the merged cells and choose Home➜Alignment➜Wrap Text. Use the vertical and hori-
zontal alignment controls in Home➜Alignment group to adjust the text position.

Figure 13-2 shows a worksheet in which 171 cells have been merged (19 rows and 9 columns). The 
text in the merged cells uses the Wrap Text option. 

Figure 13-2: Here 171 cells are merged into one.

Potential problems with merged cells
Many Excel users have a deep-seated hatred of merged cells. They avoid using this feature and urge 
everyone else to also avoid merged cells. But if you understand the limitations and potential prob-
lems, there’s no reason to completely avoid using merged cells.
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Here are a few things to keep in mind:

➤	 You can’t use merged cells in a table (created by choosing Insert➜Tables➜Table). This is 
understandable because data in a table must be consistent in terms of rows and columns. 
Merging cells in a table will destroy that consistency.

➤	 Normally, you can double-click a column header or row header to autofit the data in the col-
umn or row, but that feature doesn’t work if the row or column contains merged cells. 
Instead, you need to adjust the column width or row height manually.

➤	 Merged cells can also affect sorting and filtering. That’s another reason why merged cells 
aren’t allowed in tables. If you have a range of data that you will sort or filter, avoid using 
merged cells.

➤	 Finally, merged cells can cause problems with VBA macros. For example, if the cells in A1:D1 
are merged, a VBA statement such as the following will actually select four columns (not at 
all what the programmer intended):

Columns(“B:B”).Select

Locating all merged cells
To find out whether a worksheet contains merged cells, follow these steps:

	 1.	 Press Ctrl+F to open the Find and Replace dialog box.

	 2.	 Check to be sure the Find What field is empty.

	 3.	 Click the Options button to expand the dialog box.

	 4.	 Click the Format button to open the Find Format dialog box, where you specify the format-
ting to find.

	 5.	 In the Find Format dialog box, choose the Alignment tab and place a check mark next to 
Merged Cells.

	 6.	 Click OK to close the Find Format dialog box.

	 7.	 In the Find and Replace dialog box, click Find All.

Excel displays a list of all merged cells in the worksheet (see Figure 13-3). Click an address in the list, 
and the merged cell is activated.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 13: Working with Merged Cells46

Figure 13-3: Finding all merged cells in a worksheet.

Unmerging all merged cells
Here’s a quick way to unmerge all merged cells in a worksheet:

	 1.	 Select all cells in the worksheet.

		  A quick way to do so is to click the triangle at the intersection of the row headers and column 
headers.

	 2.	 Click the Home tab.

	 3.	 If the Merge & Center command is highlighted, click it.

Note 	

In Step 3, if the Merge & Center command isn’t highlighted, there are no merged cells. If 
you click the command when all cells are selected, all 17,179,869,184 cells in the work-
sheet will be merged.
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Alternatives to merged cells
In some cases, you can use Excel’s Center Across Selection command as an alternative to merged 
cells. This command is useful for centering text across several columns.

	 1.	 Enter the text to be centered in a cell.

	 2.	 Select the cell that has the text and additional cells to the right of it.

	 3.	 Press Ctrl+1 to display the Format Cells dialog box.

	 4.	 In the Format Cells dialog box, choose the Alignment tab.

	 5.	 In the Text Alignment section, choose the Horizontal drop-down and select Center Across 
Selection.

	 6.	 Click OK to close the Format Cells dialog box.

The text is centered across the selected cells.

Another alternative to merging cells is to use a text box. This is particular useful for text that must be 
displayed vertically. Figure 13-4 shows an example of a text box that displays vertical text. To add a 
text box, choose Insert➜Text➜Text Box, draw the box on the worksheet, and then enter the text. Use 
the text formatting tools on the Home tab to adjust the text; use the tools in the Drawing Tools➜ 

Format context tab to make other modifications (for example, to hide the text box outline).

Figure 13-4: Using a text box as an alternative to merged cells.
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Indenting Cell Contents
As you probably know, Excel (by default) left-aligns text and right-aligns numbers. Most of the time, 
that’s exactly how you want data to be aligned.

But if a column of text is to the right of a column of numbers, the information can be difficult to read. 
Figure 14-1 shows an example. All the data in this table uses the default alignment. The table would 
be more legible if there were a larger gap between the numbers and the text.

Figure 14-1: The legibility of this table can be improved by indenting the text.

Many users don’t realize that Excel can indent data — either from the left or from the right. 
Unfortunately, the command to indent is not on the Ribbon. You need to select the cells and then 
use the Alignment tab of the Format Cells dialog box (see Figure 14-2). A quick way to access this 
dialog box is to click the dialog launcher icon in the lower-right corner of the Home➜Alignment 
group.
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Figure 14-2: The Alignment tab of the Format Cells dialog box.

Use the Indent spinner to specify the size of the indenting. Usually, 1 is sufficient, but feel free to 
experiment. Then use the Horizontal drop-down list to choose the location for the indent: either Left 
(Indent) or Right (Indent). Click OK, and the text adjusts.

Figure 14-3 shows the original table after indenting the text. Much more legible!

Figure 14-3: Indenting the text makes the table easier to read.
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Using Named Styles
Throughout the years, one of the most underused features in Excel has been named styles. Named 
styles make it very easy to apply a set of predefined formatting options to a cell or range. In addition 
to saving time, using named styles helps to ensure a consistent look across your worksheets.

A style can consist of settings for up to six different attributes (which correspond to the tabs in the 
Format Cells dialog box):

➤	 Number format

➤	 Alignment (vertical and horizontal)

➤	 Font (type, size, and color)

➤	 Borders

➤	 Fill (background color)

➤	 Protection (locked and hidden)

The real power of styles is apparent when you change a component of a style. All cells that have 
been assigned that named style automatically incorporate the change. Suppose that you apply a par-
ticular style to a dozen cells scattered throughout your worksheet. Later, you realize that these cells 
should have a font size of 14 points rather than 12 points. Rather than change each cell, simply edit 
the style definition. All cells with that particular style change automatically.

Using the Style gallery
Excel comes with dozens of predefined styles, and you apply these styles in the Style gallery (located 
in the Home➜Styles group). Figure 15-1 shows the predefined styles in the Style gallery. To apply a 
style to the selected cell or range, just click the style. Notice that this gallery provides a preview. 
When you hover your mouse over a style, it’s temporarily applied to the selection so that you can see 
the effect. To make it permanent, just click the style.

After you apply a style to a cell, you can apply additional formatting to it by using any formatting 
method discussed in this chapter. Formatting modifications that you make to the cell don’t affect 
other cells that use the same style.

To maximize the value of styles, it’s best to avoid additional formatting. Rather, consider creating a 
new style (explained later in this tip).
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Figure 15-1: Use the Style gallery to work with named styles.

Modifying an existing style
To change an existing style, activate the Style gallery, right-click the style you want to modify, and 
choose Modify from the shortcut menu. Excel displays the Style dialog box, shown in Figure 15-2. In 
this example, the Style dialog box shows the settings for the Normal style, which is the default style 
for all cells. (The style definitions vary, depending on which document theme is active.)

Figure 15-2: Use the Style dialog box to modify named styles.
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Cells, by default, use the Normal style. Here’s a quick example of how you can use styles to change 
the default font used throughout your workbook:

	 1.	 Choose Home➜Styles➜Cell Styles.

		  Excel displays the list of styles for the active workbook.

	 2.	 Right-click Normal in the Styles list and choose Modify.

		  The Style dialog box opens with the current settings for the Normal style.

	 3.	 Click the Format button.

		  The Format Cells dialog box opens.

	 4.	 Click the Font tab and choose the font and size that you want as the default.

	 5.	 Click OK to return to the Style dialog box.

	 6.	 Click OK again to close the Style dialog box.

The font for all cells that use the Normal style changes to the font that you specified. You can change 
any formatting attributes for any style.

Creating new styles
In addition to using the built-in Excel styles, you can create your own styles. This flexibility can be 
quite handy because it enables you to apply your favorite formatting options very quickly and  
consistently.

To create a new style from an existing formatted cell, follow these steps:

	 1.	 Select a cell and apply all the formatting that you want to include in the new style.

		  You can use any of the formatting that’s available in the Format Cells dialog box.

	 2.	 After you format the cell to your liking, activate the Style gallery and choose New Cell Style.

		  The Style dialog box opens, along with a proposed generic name for the style. Note that 
Excel displays the words “By Example” to indicate that it’s basing the style on the current cell.

	 3.	 Enter a new style name in the Style Name box.

		  The check boxes show the current formats for the cell. By default, all check boxes are 
checked.

	 4.	 If you don’t want the style to include one or more format categories, remove the check 
marks from the appropriate boxes.

	 5.	 Click OK to create the style and close the dialog box.
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After you perform these steps, the new custom style is available in the Style gallery. Custom styles are 
available only in the workbook in which they were created. To copy your custom styles, see the sec-
tion that follows.

Note 	

The Protection option in the Styles dialog box controls whether users can modify cells 
for the selected style. This option is effective only if you also turn on worksheet protec-
tion, by choosing Review➜Changes➜Protect Sheet.

Merging styles from other workbooks
It’s important to understand that custom styles are stored with the workbook in which they were cre-
ated. If you created some custom styles, you probably don’t want to go through all the work to cre-
ate copies of those styles in each new Excel workbook. A better approach is to merge the styles from 
a workbook in which you previously created them.

To merge styles from another workbook, open both the workbook that contains the styles you want 
to merge and the workbook into which you want to merge styles. From the workbook into which you 
want to merge styles, activate the Style gallery and choose Merge Styles. The Merge Styles dialog box 
opens with a list of all open workbooks. Select the workbook that contains the styles you want to 
merge and click OK. Excel copies styles from the workbook you selected into the active workbook.

You may want to create a master workbook that contains all your custom styles so that you always 
know from which workbook to merge styles.
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Creating Custom Number Formats
Although Excel provides a good variety of built-in number formats, you may find that none of them 
suits your needs. In such a case, you can probably create a custom number format. You do so on the 
Number tab of the Format Cells dialog box (see Figure 16-1). The easiest way to display this dialog 
box is to press Ctrl+1. Or click the dialog box launcher in the Home➜Number group. (The dialog box 
launcher is the small icon to the right of the word Number.)

Figure 16-1: Create custom number formats on the Number tab of the Format Cells dialog box.

Many Excel users — even advanced users — avoid creating custom number formats because they 
think that the process is too complicated. In reality, custom number formats tend to look more com-
plex than they are.

You construct a number format by specifying a series of codes as a number format string. To enter a 
custom number format, follow these steps:

	 1.	 Press Ctrl+1 to display the Format Cells dialog box.

	 2.	 Click the Number tab and select the Custom category.

	 3.	 Enter your custom number format in the Type field.

		  See Tables 16-1 and 16-2 for examples of codes you can use to create your own, custom 
number formats.

	 4.	 Click OK to close the Format Cells dialog box.
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Parts of a number format string
A custom format string enables you to specify different format codes for four categories of values: 
positive numbers, negative numbers, zero values, and text. You do so by separating the codes for 
each category with a semicolon. The codes are arranged in four sections, separated by semicolons:

Positive format; Negative format; Zero format; Text format

The following general guidelines determine how many of these four sections you need to specify:

➤	 If your custom format string uses only one section, the format string applies to all values.

➤	 If you use two sections, the first section applies to positive values and zeros, and the second 
section applies to negative values.

➤	 If you use three sections, the first section applies to positive values, the second section 
applies to negative values, and the third section applies to zeros.

➤	 If you use all four sections, the last section applies to text stored in the cell.

The following example of a custom number format specifies a different format for each of these 
types:

[Green]General;[Red]-General;[Black]General;[Blue]General

This example takes advantage of the fact that colors have special codes. A cell formatted with this 
custom number format displays its contents in a different color, depending on the value. When a cell 
is formatted with this custom number format, a positive number is green, a negative number is red, a 
zero is black, and text is blue. By the way, using the Excel conditional formatting feature is a much 
better way to apply color to cells based on their content.

Note 	

When you create a custom number format, don’t overlook the Sample box in the 
Number tab of the Format Cells dialog box. This box displays the value in the active cell 
by using the format string in the Type field. Be sure to test your custom number formats 
by using the following data: a positive value, a negative value, a zero value, and text. 
Often, creating a custom number format takes several attempts. Each time you edit a 
format string, it’s added to the list. When you finally get the correct format string, open 
the Format Cells dialog box one more time and delete your previous attempts.

Custom number format codes
Table 16-1 briefly describes the formatting codes available for custom formats.
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Table 16-1: Codes Used to Create Custom Number Formats 
Code What It Does

General Displays the number in General format.

# Serves as a digit placeholder that displays only significant digits and doesn’t display 
insignificant zeros.

0 (zero) Serves as a digit placeholder that displays insignificant zeros if a number has fewer digits 
than there are zeros in the format.

? Serves as a digit placeholder that adds spaces for insignificant zeros on either side of the 
decimal point so that decimal points align when formatted with a fixed-width font; also 
used for fractions that have varying numbers of digits.

. Displays the decimal point.

% Displays a percentage.

, Displays the thousands separator.

E- E+ e- e+ Displays scientific notation.

$ – + / ( ) : space Displays the actual character.

\ Displays the next character in the format.

* Repeats the next character to fill the column width.

_ (underscore) Leaves a space equal to the width of the next character.

“text” Displays the text inside the double quotation marks.

@ Serves as a text placeholder.

[color] Displays the characters in the specified color and can be any of the following text strings 
(not case-sensitive): Black, Blue, Cyan, Green, Magenta, Red, White, or Yellow.

[COLOR n] Displays the corresponding color in the color palette, where n is a number from 0 to 56.

[condition value] Enables you to set your own criteria for each section of a number format.
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Table 16-2 describes the codes used to create custom formats for dates and times.

Table 16-2:	 Codes Used in Creating Custom Formats for Dates and Times 
Code What It Displays

M The month as a number without leading zeros (1–12)

mm The month as a number with leading zeros (01–12)

mmm The month as an abbreviation (Jan–Dec)

mmmm The month as a full name (January–December)

mmmmm The first letter of the month (J–D)

d The day as a number without leading zeros (1–31)

dd The day as a number with leading zeros (01–31)

ddd The day as an abbreviation (Sun–Sat)

dddd The day as a full name (Sunday–Saturday)

yy or yyyy The year as a two-digit number (00–99) or as a four-digit number (1900–9999)

h or hh The hour as a number without leading zeros (0–23) or as a number with leading zeros 
(00–23)

m or mm The minute as a number without leading zeros (0–59) or as a number with leading zeros 
(00–59)

s or ss The second as a number without leading zeros (0–59) or as a number with leading zeros 
(00–59)

[ ] Hours greater than 24 or minutes or seconds greater than 60

AM/PM The hour using a 12-hour clock or no AM/PM indicator if the hour uses a 24-hour clock
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Using Custom Number Formats  
to Scale Values
If you work with large numbers, you may prefer to display them scaled to thousands or millions 
rather than display the entire number. For example, you may want to display a number like 
132,432,145 in millions: 132.4.

The way to display scaled numbers is to use a custom number format. The actual unscaled number, 
of course, will be used in calculations that involve that cell. The formatting affects only how the num-
ber is displayed. To enter a custom number format, press Ctrl+1 to display the Format Cells dialog 
box. Then click the Number tab and select the Custom category. Put your custom number format in 
the Type field.

Table 17-1 shows examples of number formats that scale values in millions.

Table 17-1: Examples of Displaying Values in Millions 
Value Number Format Display

123456789 #,###,, 123

1.23457E+11 #,###,, 123,457

1000000 #,###,, 1

5000000 #,###,, 5

–5000000 #,###,, –5

0 #,###,, (blank)

123456789 #,###.00,, 123.46

1.23457E+11 #,###.00,, 123,457.00

1000000 #,###.00,, 1.00

5000000 #,###.00,, 5.00

–5000000 #,###.00,, –5.00

0 #,###.00,, .00

123456789 #,###,,”M” 123M

1.23457E+11 #,###,,”M” 123,457M

1000000 #,###,,”M” 1M

–5000000 #,###,,”M” –5M

123456789 #,###.0,,”M”_);(#,###.0,,”M)”;0.0”M”_) 123.5M 

1000000 #,###.0,,”M”_);(#,###.0,,”M)”;0.0”M”_) 1.0M 

–5000000 #,###.0,,”M”_);(#,###.0,,”M)”;0.0”M”_) (5.0M)

0 #,###.0,,”M”_);(#,###.0,,”M)”;0.0”M”_) 0.0M 
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Table 17-2 shows examples of number formats that scale values in thousands.

Table 17-2:	 Examples of Displaying Values in Thousands 
Value Number Format Display

123456 #,###, 123

1234565 #,###, 1,235

–323434 #,###, –323

123123.123 #,###, 123

499 #,###, (blank)

500 #,###, 1

500 #,###.00, .50

Table 17-3 shows examples of number formats that display values in hundreds.

Table 17-3:	 Examples of Displaying Values in Hundreds 
Value Number Format Display

546 0”.”00 5.46

100 0”.”00 1.00

9890 0”.”00 98.90

500 0”.”00 5.00

–500 0”.”00 –5.00

0 0”.”00 0.00
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Creating a Bulleted List
Word-processing software, such as Microsoft Word, makes it very easy to create a bulleted list of 
items. Excel doesn’t have a feature that creates bulleted lists, but it’s easy to fake it.

Using a bullet character
You can generate a bullet character by pressing Alt, and typing 0149 on the numeric keypad. If your 
keyboard lacks a numeric keypad, press the Function key and type numbers using the normal keys.

Figure 18-1 shows a list in which each item is preceded with a bullet character and a space. The cells 
use wrap-text formatting. Items that occupy more than one line are not indented. In a bulleted list, 
multiple lines are usually indented so they line up with the first line.

Figure 18-1: Inserting a bullet character before each item.

Figure 18-2 shows a second attempt. This approach requires two columns. Column A holds the bullet 
character, formatted so the bullet is top-aligned and right-aligned. The text is in column B.

Figure 18-2 also shows an alternative, a numbered list. The cells that contain the numbers use this 
custom number format, which displays a decimal point, but no decimal places:

General”. “

Note 	

You can, of course, use any character you like for the bullet. Use Insert➜Symbols➜ 

Symbol to display (and insert) characters from any font that’s installed on your system.
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Figure 18-2: Using an additional column for the bullet characters, or for numbers.

Using SmartArt
Another way to create a bulleted list in Excel is to use SmartArt. Choose Insert➜Illustrations➜ 

SmartArt, and choose the diagram style from the dialog box.

Figure 18-3 shows a “Vertical Bullet List” SmartArt diagram. This object is free-floating and can easily 
be moved and resized. The example shown here uses minimal formatting, but you have lots of con-
trol over the appearance of SmartArt.

Figure 18-3: Using SmartArt to hold a bulleted list.
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Shading Alternate Rows Using Conditional 
Formatting
When you create a table (using Insert➜Tables➜Table), you have the option of formatting the table in 
such a way that alternate rows are shaded. Alternate row shading can make your spreadsheets easier 
to read.

This tip describes how to use conditional formatting to obtain alternate row shading for any range of 
data. It’s a dynamic technique: If you add or delete rows within the conditional formatting area, the 
shading is updated automatically.

Displaying alternate row shading
Figure 19-1 shows an example. Here’s how to apply shading to alternate rows:

	 1.	 Select the range to format.

	 2.	 Choose Home➜Conditional Formatting➜New Rule.

		  The New Formatting Rule dialog box appears.

	 3.	 For the rule type, choose Use a Formula to Determine Which Cells to Format.

	 4.	 Enter the following formula in the box labeled Format Values Where This Formulas Is True:

=MOD(ROW(),2)=0

	 5.	 Click the Format button.

		  The Format Cells dialog box appears.

	 6.	 In the Format Cells dialog box, click the Fill tab and select a background fill color.

	 7.	 Click OK to close the Format Cells dialog box, and click OK again to close the New Formatting 
Rule dialog box.

This conditional formatting formula uses the ROW function (which returns the row number) and the 
MOD function (which returns the remainder of its first argument divided by its second argument). 
For cells in even-numbered rows, the MOD function returns 0, and cells in that row are formatted.

For alternate shading of columns, use the COLUMN function instead of the ROW function.
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Figure 19-1: Using conditional formatting to apply formatting to alternate rows.

Creating checkerboard shading
The following formula is a variation on the example in the preceding section. It applies formatting to 
alternate rows and columns, creating a checkerboard effect. Figure 19-2 shows the result.

=MOD(ROW(),2)=MOD(COLUMN(),2)

Figure 19-2: Conditional formatting produces this checkerboard effect.
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Shading groups of rows
Here’s another row shading variation. The following formula shades alternate groups of rows. It pro-
duces four rows of shaded rows, followed by four rows of unshaded rows, followed by four more 
shaded rows, and so on. Figure 19-3 shows an example.

=MOD(INT((ROW()-1)/4)+1,2)

For different sized groups, change the 4 to some other value. For example, use this formula to shade 
alternate groups of two rows:

=MOD(INT((ROW()-1)/2)+1,2)

Figure 19-3: Conditional formatting produces these groups of alternate shaded rows.
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Formatting Individual Characters in a Cell
Excel cell formatting isn’t an all-or-none proposition. In some cases, you might find it helpful to be 
able to format individual characters within a cell.

Note 	

This technique is limited to cells that contain text. It doesn’t work if the cell contains a 
value or a formula.

To apply formatting to characters within a text string, select those characters first. You can select 
them by clicking and dragging your mouse on the Formula bar, or you can double-click the cell and 
then click and drag the mouse to select specific characters directly in the cell. A more efficient way to 
select individual characters is to press F2 first and then use the arrow keys to move between charac-
ters and use the Shift+arrow keys to select characters.

When the characters are selected, use formatting controls to change the formatting. For example, 
you can make the selected text bold, italic, or a different color; you can even apply a different font. If 
you right-click, the Mini Toolbar appears, and you can use those controls to change the formatting of 
the selected characters.

Figure 20-1 shows a few examples of cells that contain individual character formatting.

Unfortunately, two useful formatting attributes are not available on the Ribbon or on the Mini 
Toolbar: superscript and subscript formatting. If you want to apply superscripts or subscripts, open 
the Font tab in the Format Cells dialog box. Just press Ctrl+1 after you select the text to format.

Figure 20-1: Examples of individual character formatting.
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Using the Format Painter
You’ve probably seen that little Format Painter paint brush icon in the Home➜Clipboard group. It’s 
an easy way to copy cell formatting — and it’s actually more versatile than you might think.

When you use the Format Painter, every aspect of the source range’s formatting is copied, including 
number formats, borders, cell merging, and conditional formatting.

Painting basics
Here’s how to use the Format Painter tool in its basic form:

	 1.	 Select a cell that contains the formatting that you want to duplicate.

	 2.	 Choose Home➜Clipboard➜Format Painter.

		  The mouse cursor displays a paintbrush to remind you that you’re in Format Painter mode 
(see Figure 21-1).

	 3.	 Drag the mouse over another range.

	 4.	 Release the mouse button, and the formatting is copied.

In Step 2, you can right-click the selected cell and choose the Format Painter icon from the Mini 
Toolbar.

Note that the Format Painter is mouse-centric. You cannot use the keyboard to do your painting.

Figure 21-1: Copying cell formatting by using the Format Painter.
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Format Painter variations
In Step 1 in the preceding section, if you select a range of cells, you can paint another range by click-
ing a single cell. The formatting is copied to a range that’s the same size as the original selection.

In Step 2, if you double-click the Format Painter button, Excel remains in Format Painter mode until 
you cancel it. This enables you to copy the format to multiple ranges of cells. To get out of Format 
Painter mode, press Esc or click the Format Painter button again.

You can also use the Format Painter to remove all formatting from a range and return the range to its 
pristine state. Start by selecting an unformatted cell. Then click the Format Painter button and drag it 
over the range.

The Format Painter also works with complete rows and columns. If you start by selecting one or more 
complete rows, the Format Painter also copies row height. The same thing occurs with column 
widths if you start by selecting one or more columns.

This feature even works with complete worksheets. For example, if you want to remove all format-
ting from a worksheet, select an unformatted cell, click the Format Painter button, and then click the 
“select all” button at the intersection of the row and column borders.

You can also use the Format Painter with shapes and other objects such as pictures. Just select the 
object, click the Format Painter button, and click another object. Figure 21-2 shows an example of 
copying shape formats using the Format Painter.

Note 	

Although the Format Painter is versatile, it doesn’t work with charts.

Figure 21-2: Using the Format Painter to copy shape formatting.

Finally, the Format Painter is a handy tool, but it doesn’t perform any actions that can’t be done via 
other methods. For example, you can copy a range, select another range, and use the Home➜ 

Clipboard➜Paste➜Formatting (R) command to paste the formatting only.
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Inserting a Watermark
A watermark is an image (or text) that appears on a printed page. A watermark can be a faint com-
pany logo or a word, such as DRAFT.

Excel doesn’t have an official command to print a watermark, but you can add a watermark by insert-
ing a picture in the page header or footer. Here’s how to do it:

	 1.	 Locate an image on your hard drive that you want to use for the watermark.

	 2.	 Choose View➜Workbook Views➜Page Layout View to enter Page Layout view.

	 3.	 Click the center section of the header.

	 4.	 Choose Header & Footer Tools➜Header & Footer Elements➜Picture.

		  The Insert Picture dialog box appears.

	 5.	 Click Browse and locate and select the image you picked in Step 1 (or locate a suitable image 
from other sources listed); then click Insert to insert the image.

	 6.	 Click outside the header to see your image.

	 7.	 To center the image vertically on the page, click the center section of the header and press 
Enter a few times before the &[Picture] code.

		  You’ll need to experiment to determine the number of carriage returns required to push the 
image into the body of the document.

	 8.	 If you need to adjust the image (for example, to make it lighter), click the center section of 
the header and then choose Header & Footer Tools➜Header & Footer Elements➜Format 
Picture; use the Image controls on the Picture tab of the Format Picture dialog box to adjust 
the image.

		  You may need to experiment with the settings to make sure that the worksheet text is legible.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 22: Inserting a Watermark 69

Figure 22-1 shows an example of a header image (a copyright symbol) used as a watermark. You can 
create a similar effect with plain text in the header (for example, the word DRAFT).

Figure 22-1: Displaying a watermark on a page.
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Showing Text and a Value in a Cell
If you need to display a number and text in a single cell, Excel gives you three options:

➤	 Concatenation

➤	 The TEXT function

➤	 A custom number format

Assume that cell A1 contains a value, and in a cell somewhere else in your worksheet, you want to 
display the text Total: along with that value. It looks something like this:

Total: 594.34

You could, of course, put the text Total: in the cell to the left. This section describes the three meth-
ods for accomplishing this task using a single cell.

Using concatenation
The following formula concatenates the text Total: with the value in cell A1:

=”Total: “&A1

This solution is the simplest, but it has a problem. The result of the formula is text, rather than a 
numeric value. Therefore, the cell cannot be used in a numeric formula. Also, the numeric portion will 
display with no formatting. For example, the formula might return

Total: 1594.34320933
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Using the TEXT function
Another solution uses the TEXT function, which displays a value by using a specified number format:

=TEXT(A1,”””Total: “”$#,0.00”)

This formula returns something like this:

Total: $1,594.34

The second argument for the TEXT function is a number format string — the same type of string that 
you use when you create a custom number format. Because the number portion is formatted, this 
approach looks good. But besides being a bit unwieldy (because of the extra quotation marks), this 
formula suffers from the same problem mentioned in the previous section: The result is not numeric.

Using a custom number format
If you want to display text and a value — and still be able to use that value in a numeric formula — 
the solution is to use a custom number format.

To add text, just create the number format string as usual and put the text within quotation marks. 
For this example, the following custom number format does the job:

“Total: “$#,0.00

Even though the cell displays text, Excel still considers the cell contents to be a numeric value. 
Therefore, you can use this cell in other formulas that perform calculations.
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Avoiding Font Substitution for Small Point 
Sizes
When you specify a font size smaller than eight points, you may notice that the numbers in a column 
no longer line up correctly. That’s because Excel uses a different (non-proportional) font for small 
text. Normally, each numeric character takes the same amount of horizontal space — that’s why 
numbers line up so nicely. But with a proportional font, numeric characters vary in width. The “1” 
character is more narrow than the “0” character, for example.

Figure 24-1 shows a worksheet with columns of numbers in varying font sizes. Notice that everything 
is fine until the point size is smaller than 8 points. In column E (7 points), the “1” character take up less 
space. In column F (6 points), the “5” and “7” characters also take up less space.

Figure 24-1: Various font sizes, with font substitution enabled.

Font substitution also occurs when you zoom the worksheet, using the Zoom slider in the status bar. 
Sometimes zooming out causes values to appear as a series of hash marks (#####). The point at 
which the font is changed seems to vary, depending on the size of the original font. For the default 
11-point font, zooming below 75% causes Excel to switch to a different font. 

You can instruct Excel to stop this font substitution for small font sizes, but doing so requires editing 
the Windows registry.

Note 	

Editing the registry can be dangerous if you don’t understand what you’re doing; always 
create a backup before you make any changes. If you’re not comfortable editing the 
registry, find someone who is — or just don’t implement this tip.
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	 1.	 Close Excel.

	 2.	 Click the Windows Start button and run regedit.exe, the Registry Editor program.

	 3.	 In the Registry Editor, navigate to this registry key:

HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Options

	 4.	 With that registry key selected, choose Edit➜New➜DWORD.

		  The entry will be named New Value #1.

	 5.	 Right-click the entry and choose Rename. Specify FontSub for the entry name.

	 6.	 Double-click the FontSub entry.

		  The Edit DWORD dialog box appears.

	 7.	 Specify 0 as the Value Data (the Base, Hexadecimal, or Decimal doesn’t matter), as shown in 
Figure 24-2.

	 8.	 Click OK to close the Edit DWORD dialog box.

	 9.	 Choose File➜Exit to quit Registry Editor.

Figure 24-2: Using Registry Editor to add a new value to the Windows registry.
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When you restart Excel, you’ll find that Excel no longer uses font substitution for small fonts. When 
font substitution is disabled, small text will be a bit more difficult to read, but the numbers will con-
tinue to line up, and you won’t see the #### display when you zoom out.

Figure 24-3 shows the worksheet in Figure 24-1, after disabling font substitution.

Figure 24-3: Various font sizes, with font substitution disabled.
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Updating Old Fonts
When you install Microsoft Office, several new fonts are added to your system, and these new fonts 
are used when you create a new workbook. The exact fonts that are used as defaults vary, depending 
on which document theme is in effect.

Cross-Ref	
See Tip 10 for more information about using document themes.

If you use the default Office theme, a newly created Excel workbook uses two new fonts: Cambria (for 
headings) and Calibri (for body text). When you open a workbook that was saved in a version prior to 
Excel 2007, the old fonts (probably Arial) aren’t updated. The difference in appearance between a 
worksheet that uses the old fonts and a worksheet that uses the new fonts is dramatic. When you 
compare an Excel 2003 worksheet with an Excel 2013 worksheet, the latter is much more readable 
and appears less cramped.

Figure 25-1 shows a workbook that was created in Excel 2003.

Figure 25-1: This Excel 2003 workbook uses Arial 10-point font as the normal font.
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To update the fonts in a workbook that was created in a previous version of Excel, follow these steps:

	 1.	 Press Ctrl+N to create a new, blank workbook.

	 2.	 Activate the workbook that uses the fonts to be updated.

	 3.	 Choose Home➜Styles➜Merge Styles

		  The Merge Styles dialog box appears.

	 4.	 In the Merge Styles dialog box, select the workbook that you created in Step 1 and click OK.

		  Excel asks whether you want to merge styles that have the same names.

	 5.	 Reply by clicking the Yes button.

This procedure updates the fonts used in all cells except those that have additional formatting, such 
as a different font size, bold, italic, colored text, or a shaded background. To change the font in these 
cells, follow these steps:

	 1.	 Select any single cell.

	 2.	 Choose Home➜Editing➜Find & Select➜Replace, or press Ctrl+H.

		  The Find and Replace dialog box appears.

	 3.	 Make sure that the two Format buttons are visible. If these buttons aren’t visible, click the 
Options button to expand the dialog box.

	 4.	 Click the upper Format button to display the Find Format dialog box.

	 5.	 Click the Font tab.

	 6.	 In the Font list, select the name of the font that you’re replacing (probably Arial, the old 
default font) and then click OK to close the Find Format dialog box.

	 7.	 Click the lower Format button to display the Replace Format dialog box.

	 8.	 Click the Font tab.

	 9.	 In the Font list, select the name of the font that will replace the old font (probably Calibri) 
and then click OK to close the Replace Format dialog box.

	 10.	 In the Find and Replace dialog box, click Replace All to replace the old font with the new 
font.
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Figure 25-2 shows the Excel 2003 workbook after updating the font.

Figure 25-2: This Excel workbook uses Calibri 11-point font as the normal font.
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PART III
Formulas
The ability to create formulas is what makes a spreadsheet. In this part, you’ll find 
formula-related tips that can make your workbooks more powerful than ever.
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Resizing the Formula Bar
In earlier versions of Excel, editing a cell that contains a lengthy formula or lots of text often obscures 
the worksheet. Figure 26-1 shows Excel 2003 when a cell that contains lengthy text is selected. 
Notice that many of the cells are covered up by the expanded Formula bar. Beginning with Excel 
2007, this problem is corrected.

Figure 26-1: In older versions of Excel, editing a lengthy formula or a cell that contains lots of text often 
obscures the worksheet.
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The Excel 2013 Formula bar displays a small arrow on the right; click the arrow, and the Formula bar 
expands. You can also drag the bottom border of the Formula bar to change its height. Also useful is 
a shortcut key combination: Ctrl+Shift+U. Pressing this key combination toggles the height of the 
Formula bar to show either one row or the previous size. If the expanded Formula bar isn’t tall 
enough to display all of the text in the active cell, a scrollbar displays to the right of the Formula bar.

Figure 26-2 shows an example of the resized Formula bar. As you can see, increasing the height of 
the Formula bar doesn’t obscure the information in the worksheet. Instead, the worksheet informa-
tion is displayed below the Formula bar. You can make the formula bar almost as tall as the work-
book window (one worksheet row always remains visible).

Figure 26-2: Changing the height of the formula bar makes it much easier to edit lengthy formulas and text, 
and you can still view all cells in your worksheet.

You can also resize the width of the Formula bar. Click and drag the three dots to the right of the 
Name box. When the Name box gets wider, the Formula bar gets narrower.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 27: Monitoring Formula Cells from Any Location 83

Monitoring Formula Cells from Any Location
If you have a large spreadsheet model, you might find it helpful to monitor the values in a few key 
cells as you change various input cells. The Watch Window feature makes this task very simple. Using 
the Watch Window, you can keep an eye on any number of cells, regardless of which worksheet or 
workbook is active. Using this feature can save time and eliminate scrolling and switching among 
worksheet tabs and workbook windows.

About the Watch Window
To display the Watch Window, choose Formulas➜Formula Auditing➜Watch Window. To watch a 
cell, click the Add Watch button in the Watch Window and then specify the cell in the Add Watch dia-
log box. When the Add Watch dialog box opens, you can add multiple cells by selecting a range or by 
pressing Ctrl and clicking individual cells.

For each cell, the Watch Window displays the workbook name, the worksheet name, the cell name (if 
it has one), the cell address, the current value, and the formula (if it has one).

Excel remembers the cells in a Watch Window, even between sessions. If you close a workbook that 
contains cells being monitored in the Watch Window, those cells are removed from the Watch 
Window. But if you reopen that workbook, the cells are displayed again.

Figure 27-1 shows the Watch Window, with several cells being monitored.

Figure 27-1: Using the Watch Window to monitor the value of formula cells.
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Customizing the Watch Window
The Watch Window is a task pane, and you can customize the display by doing any of the following:

➤	 Click and drag a border to change the size of the task pane.

➤	 Drag the task pane to an edge of an Excel workbook window, and it becomes docked rather 
than free floating.

➤	 Click and drag the borders in the header to change the width of the columns displayed. By 
dragging a column border all the way to the left, you can hide the column.

➤	 Click one of the headers to sort the contents by that column.

Navigating with the Watch Window
You can also use the Watch Window as a navigational aid. If you find that you often need to switch 
among worksheets, add a cell for each worksheet to the Watch Window. To activate a cell displayed 
in the Watch Window, double-click it in the Watch Window.

Note 	

Unfortunately, in Excel 2013, this navigational technique works only with the active 
workbook. In other words, double-clicking a Watch Window item that points to a cell in 
a different workbook will not activate the workbook. I don’t know if this is by design or 
if it’s a bug in Excel 2013.
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Learning Some AutoSum Tricks
Just about every Excel user knows about the AutoSum button. This command is so popular that it’s 
available in two Ribbon locations: in the Home➜Editing group and in the Formulas➜Function 
Library group.

Just activate a cell and click the button, and Excel analyzes the data surrounding the active cell and 
proposes a SUM formula. If the proposed range is correct, click the AutoSum button again (or press 
Enter), and the formula is inserted. If you change your mind, press Esc.

Be careful if the range to be summed contains any blank cells. A blank cell will cause Excel to mis-
identify the complete range. If Excel incorrectly guesses the range to be summed, just select the cor-
rect range to be summed and press Enter.

You can also access AutoSum using your keyboard. Pressing Alt+= has exactly the same effect as 
clicking the AutoSum button.

The AutoSum button can insert other types of formulas. Notice the little arrow on the right side of 
that button? Click it, and you see four other functions: AVERAGE, COUNT, MAX, and MIN (see Figure 
28-1). Click one of those items, and the appropriate formula is proposed. You also see a More 
Functions item, which simply displays the Insert Function dialog box — the same one that appears 
when you choose Formulas➜Function Library➜Insert Function (or click the fx button to the left of 
the formula bar).

Figure 28-1: Using the AutoSum button to insert other functions.

Note 	

In some situations (described next), AutoSum creates formulas automatically and 
doesn’t give you an opportunity to review the range to be summed. Don’t assume that 
Excel guessed the range correctly.
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Following are some additional tricks related to AutoSum:

➤	 If you need to enter a similar SUM formula into a range of cells, select the entire range before 
you click the AutoSum button. In this case, Excel inserts the functions for you without asking 
you — one formula in each of the selected cells.

➤	 To sum both across and down a table of numbers, select the range of numbers plus an addi-
tional column to the right and an additional row at the bottom. Click the AutoSum button, 
and Excel inserts the formulas that add the rows and the columns. In Figure 28-2, the range 
to be summed is D4:G15, so I selected an additional row and column: D4:H16. Clicking the 
AutoSum buttons puts formulas in row 16 and column H.

➤	 If you’re working with a table (created by choosing Insert➜Tables➜Table), using the AutoSum 
button after selecting the row below the table inserts a Total row for the table and creates for-
mulas that use the SUBTOTAL function rather than the SUM function. The SUBTOTAL function 
sums only the visible cells in the table, which is useful if you filter the data.

➤	 Unless you applied a different number format to the cell that will hold the SUM formula, 
AutoSum applies the same number format as the first cell in the range to be summed.

➤	 To create a SUM formula that uses only some of the values in a column, select the cells to be 
summed and then click the AutoSum button. Excel inserts the SUM formula in the first empty 
cell below the selected range. The selected range must be a contiguous group of cells — a 
multiple selection isn’t allowed.

Figure 28-2: Using AutoSum to insert SUM formulas for rows and columns.
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Knowing When to Use Absolute and Mixed 
References
When you create a formula that refers to another cell or range, the cell references are usually relative 
references. When you copy a formula that uses relative references, the cell references adjust to their 
new location in a relative manner. Assume this formula (which uses relative references) is in cell A13:

=SUM(A1:A12)

If you copy the formula to cell B13, the copied formula is

=SUM(B1:B12)

Most of the time, you want cell references to adjust when you copy formulas. That’s why most of the 
time you use relative references in formulas. But some situations require either absolute or relative 
references.

Using absolute references
You specify an absolute reference by using two dollar signs (one in front of the column part and one 
in front of the row part). Here are two examples of formulas that use absolute references:

=$A$1
=SUM($A$1:$F$24)

An absolute cell reference in a formula does not change, even when the formula is copied elsewhere. 
For example, assume the following formula is in cell B13:

=SUM($B$1:$B$12)

When you copy this formula to a different cell, the references do not adjust. The copied formula 
refers to the same cells as the original, and both formulas return the same result.

When do you use an absolute reference? The answer is simple: The only time you even need to think 
about using an absolute reference is if you plan to copy the formula — and you need the copied for-
mula to refer to the same range as the original.
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The easiest way to understand this concept is with an example. Figure 29-1 shows a simple work-
sheet. The formula in cell D2 is

=(B2*C2)*$B$7

Figure 29-1: Formula references to the sales tax cell should be absolute.

This formula uses relative cell references (B2 * C2) and also an absolute reference to the sales tax cell 
($B$7). This formula can be copied to the cells below, and all of the references will be correct. For 
example, after copying the formula in cell D2, cell D3 contains this formula:

=(B3*C3)*$B$7

The references to the cells in columns B and C are adjusted, but the reference to cell B7 is not — 
which is exactly what you want.

Using mixed references
In a mixed cell reference, either the column part or the row part of a reference is absolute (and there-
fore doesn’t change when the formula is copied and pasted). Mixed cell references aren’t used often, 
but as you see in this tip, in some situations, using mixed references makes your job much easier.

Here are two examples of mixed references:

=$A1
=A$1
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In the first example, the column part of the reference (A) is absolute, and the row part (1) is relative. In 
the second example, the column part of the reference is relative, and the row part is absolute.

Figure 29-2 shows a worksheet demonstrating a situation in which using mixed references is the best 
choice.

Figure 29-2: Using mixed cell references.

The formulas in the table calculate the area for various lengths and widths of a rectangle. Here’s the 
formula in cell C3:

=$B3*C$2

Notice that both cell references are mixed. The reference to cell B3 uses an absolute reference for the 
column ($B), and the reference to cell C2 uses an absolute reference for the row ($2). As a result, this 
formula can be copied down and across, and the calculations are correct. For example, the formula in 
cell F7 is

=$B7*F$2

If C3 used either absolute or relative references, copying the formula would produce incorrect 
results.
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Avoiding Error Displays in Formulas
Sometimes a formula returns an error, such as #REF! or #DIV/0!. Usually, you want to know when a 
formula error occurs so you can fix it. But in some cases, you might prefer to simply avoid displaying 
the error messages. Figure 30-1 shows an example.

Figure 30-1: The formulas in column D display an error if the data is missing.

Column D contains formulas that calculate the average sales volume. For example, cell D2 contains 
this formula:

=B2/C2

Using the IFERROR function
As you can see, the formula displays an error if the cells used in the calculation are empty. If you pre-
fer to hide those error values, you can do so by using an IFERROR function. This function takes two 
arguments: The first argument is the expression that’s checked for an error, and the second is the 
value to return if the formula evaluates to an error.

The formula presented earlier can be rewritten as

=IFERROR(B2/C2,””)

As you see in Figure 30-2, when this formula is copied down the column, the result is a bit more visu-
ally pleasing.
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By the way, you can put anything you like as the second argument for the IFERROR function. (It 
doesn’t have to be an empty string.) For example, you can make it a cell reference.

Figure 30-2: Using an IFERROR function to hide error values.

Note 	

The IFERROR function was introduced in Excel 2007, so it doesn’t work with earlier ver-
sions of Excel. If you plan to share your workbook with people who use Excel 2003 or 
earlier, you’ll need to use the ISERROR function — described next.

Using the ISERROR function
The ISERROR function is used with an IF function. For the example presented earlier, use this formula 
in cell D1:

=IF(ISERROR(B2/C2),””,B2/C2)

The ISERROR function returns TRUE if its argument evaluates to an error. In such a case, the IF func-
tion returns an empty string. Otherwise, the IF function returns the calculated value.

This method of avoiding an error display is a bit more complicated, and it’s also less efficient because 
the formula is actually evaluated two times if it doesn’t return an error. Therefore, unless you require 
compatibility with Excel 2003 or earlier versions, you should use the IFERROR functions.
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Creating Worksheet-Level Names
Normally, when you name a cell or range, you can use that name in all worksheets in the workbook. 
For example, if you create a name, say RegionTotal, that refers to the cell M32 on Sheet1, you can use 
this name in any formula in any worksheet. This name is a workbook-level name (or a global name). 
By default, all cell and range names are workbook-level names.

Suppose that you have several worksheets in a workbook (one for each region) and you want to use 
the same name (such as RegionTotal) on each sheet. In this case, you need to create worksheet-level 
names (sometimes referred to as local names).

To define the worksheet-level name RegionTotal, activate the worksheet in which you want to define 
the name and choose Formulas➜Defined Names➜Define Name. The New Name dialog box then 
appears. In the Names field, enter the name in the Name field and use the Scope drop-down list to 
select the sheet in which the name is valid. Figure 31-1 shows a worksheet-level name being created.

Figure 31-1: Creating a worksheet-level name.

You can also create a worksheet-level name by using the Name box (located to the left of the 
Formula bar). Select the cell or range you want named, click in the Name box, and type the name, 
preceded by the sheet name and an exclamation point. Press Enter to create the name. Here’s an 
example of a worksheet-level name:

Sheet3!RegionTotal
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If the worksheet name contains at least one space, enclose the worksheet name in apostrophes, like 
this:

‘Northwest Region’!RegionTotal

When you write a formula that uses a worksheet-level name on the sheet in which you defined it, you 
don’t need to include the worksheet name in the range name. (The Name box doesn’t display the 
worksheet name, either.) If you use the name in a formula on a different worksheet, however, you 
must use the entire name (sheet name, exclamation point, and name).

If you copy a worksheet that has worksheet-level names, the names are duplicated as worksheet-
level names in the new worksheet.

The Name Manager dialog box clearly identifies each name by its scope (see Figure 31-2). If the scope 
of a name isn’t Workbook, the dialog box lists the sheet on which the name is defined.

Figure 31-2: The Name Manager makes it easy to distinguish between workbook-level names and worksheet-
level names.

Note 	

Only the worksheet-level names on the current sheet appear in the Name box. Similarly, 
only worksheet-level names in the current sheet appear in the list when you open the 
Paste Name dialog box (by pressing F3).
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Using Named Constants
This tip describes a useful technique that can remove some clutter from your worksheets: named 
constants.

Consider a worksheet that generates an invoice and calculates sales tax for a sales amount. The com-
mon approach is to insert the sales tax rate value into a cell and then use this cell reference in your 
formulas. To make things easier, you probably would name this cell something like SalesTax.

You can store your sales tax rate by using a name (and avoid using a cell). Figure 32-1 demonstrates 
the following steps:

	 1.	 Choose Formulas➜Defined Names➜Define Name to open the New Name dialog box.

	 2.	 Type the name (in this case, SalesTax) into the Name field.

	 3.	 Specify Workbook as the scope for the name. If you want the name to be valid only on a  
particular worksheet, specify the worksheet in the Scope field of the New Name dialog box.

	 4.	 Click the Refers To field, delete its contents, and replace it with a simple formula, such as 
=7.5%.

	 5.	 Click OK to close the dialog box.

Figure 32-1: Defining a name that refers to a constant.
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The preceding steps create a named formula that doesn’t use any cell references. To try it out, enter 
the following formula into any cell:

=SalesTax

This simple formula returns .075, the result of the formula named SalesTax. Because this named for-
mula always returns the same result, you can think of it as a named constant. And you can use this 
constant in a more complex formula, such as this one:

=A1*SalesTax

A named constant can also consist of text. For example, you can define a constant for a company’s 
name. You can use the New Name dialog box to create the following formula, named MSFT:

=”Microsoft Corporation”

Then you can use a cell formula, such as this one:

=”Annual Report: “&MSFT

This formula returns the text Annual Report: Microsoft Corporation.

Note 	

Names that don’t refer to ranges don’t appear in the Name box or in the Go To dialog 
box (which appears when you press F5). This makes sense because these constants 
don’t reside anywhere tangible. They do, however, appear in the Paste Name dialog box 
(which appears when you press F3) and in the intellisense drop-down list when you’re 
creating a formula. This does make sense because you use these names in formulas.

As you might expect, you can change the value of the constant at any time by using the Name 
Manager dialog box (choose Formulas➜Defined Names➜Name Manager). Just click the Edit button 
to open the Edit Name dialog box. Then change the value in the Refers To field. When you close the 
dialog box, Excel uses the new value to recalculate the formulas that use this name.
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Sending Personalized E-Mail from Excel
This tip describes a method to compose and send short customized e-mail messages from Excel, 
using the HYPERLINK function.

About the HYPERLINK function
The HYPERLINK function creates a link that, when clicked, activates your default browser and navi-
gates to a web page. The function takes two arguments: the URL and the text that’s displayed in the 
cell. For example, this formula creates a link to my website:

=HYPERLINK(“http://spreadsheetpage.com”,”Spreadsheet Page”)

A URL can also contain an e-mail address. When clicked, the hyperlink opens the new message win-
dow of your default e-mail client, with the e-mail address in the “To” field. Here’s an example:

=HYPERLINK(“mailto:support@example.com”,”Email support”)

Note 	

If you don’t have a local default e-mail client and rely on a web-based e-mail service 
(such as Gmail or Hotmail), this technique won’t work.

You can also include a subject line. Here’s an example of the first argument for the HYPERLINK func-
tion that includes an e-mail subject line:

“mailto:support@example.com?subject=Help!”

In addition, you can include a short default message:

“mailto:support@example.com?subject=Help me!&body=I don’t understand this.”

Things get a bit more complicated if you want to include a line break in the message body. If that’s 
the case, you need to “percent encode” the line break by using this code: %0A. Here’s an example 
that inserts two line breaks into the e-mail body:

“mailto:support@example.com?subject=Help me!&body=I don’t understand 
this.%0A%0AYour customer”

Note 	

Technically, all non-alphanumeric characters should be encoded, including spaces. You 
can use the ENCODEURL function (introduced in Excel 2013) to encode any text string.
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A practical example using HYPERLINK
Figure 33-1 shows a worksheet set up to make it easy to send a brief personalized e-mail from Excel.

Figure 33-1: The hyperlink in cell B8, when clicked, opens the default e-mail client with a message ready  
to send.

Here’s a description of each cell:

➤	 B1: The first name of the e-mail recipient.

➤	 B2: The e-mail address.

➤	 B3: The subject line for the e-mail address.

➤	 B4: The subject line, encoded using this formula:

=ENCODEURL(B3)

➤	 B5: The body of the message. This cell uses wrap text formatting, and line breaks were 
entered by using Alt+Enter.
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➤	 B6: The body text, encoded using this formula:

=ENCODEURL(B5)

➤	 B7: The first argument for the HYPERLINK function, constructed by concatenating text and 
cells. The formula is

=”mailto:”&B2&”?subject=”&(B4)&”&body=”&B6&””

➤	 B8: This cell contains a formula that uses the HYPERLINK function:

=HYPERLINK(B7,”Click to send”)

Note 	

The length of the text in cell B7 (the first argument for the HYPERLINK function) cannot 
exceed 255 characters. If the text is too long, cell B8 displays a #VALUE error.

Figure 33-2 shows how it looks when Windows Live Mail is the default e-mail client.

Figure 33-2: This e-mail message was composed by the HYPERLINK function.
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Looking Up an Exact Value
The VLOOKUP and HLOOKUP functions are useful if you need to return a value from a table (in a 
range) by looking up another value.

The classic example of a lookup formula involves an income tax rate schedule (see Figure 34-1). The 
tax rate schedule shows the income tax rates for various income levels. The following formula (in cell 
B3) returns the tax rate for the income value in cell B2:

=VLOOKUP(B2,D2:F7,3)

Figure 34-1: Using VLOOKUP to look up a tax rate.

The tax table example demonstrates that VLOOKUP and HLOOKUP don’t require an exact match 
between the value to be looked up and the values in the lookup table. In some cases, though, you 
might require a perfect match. For example, when looking up an employee number, close doesn’t 
count. You require an exact match for the number.

To look up only an exact value, use the VLOOKUP (or HLOOKUP) function with the optional fourth 
argument set to FALSE.

Figure 34-2 shows a worksheet with a lookup table that contains employee numbers (column D) and 
employee names (column E). The formula in cell B2, which follows, looks up the employee number 
entered in cell B1 and returns the corresponding employee name:

=VLOOKUP(B1,D1:E11,2,FALSE)
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Because the last argument for the VLOOKUP function is FALSE, the function returns a value only if an 
exact match is found. If the value isn’t found, the formula returns #N/A. This is exactly what you want 
to happen, of course, because returning an approximate match for an employee number makes no 
sense. Also, notice that the employee numbers in column D aren’t in ascending order. If the last argu-
ment for VLOOKUP is FALSE, the values don’t need to be in ascending order.

Figure 34-2: This lookup table requires an exact match.

If you prefer to see something other than #N/A when the employee number isn’t found, you can use 
the IFERROR function to test for the #N/A result (using the ISNA function) and substitute a different 
string. The following formula displays the text “Not Found” rather than #N/A:

=IFERROR(VLOOKUP(B2,D1:E11,2,FALSE),”Not Found”)

The IFERROR function was introduced in Excel 2007, so if your workbook must be compatible with 
Excel 2003 and earlier versions, use this formula:

=IF(ISERROR(VLOOKUP(B2,D1:E11,2,FALSE)),”Not Found”,
VLOOKUP(B2,D1:E11,2,FALSE))
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Performing a Two-Way Lookup
A two-way lookup identifies the value at the intersection of a column and a row. This tip describes 
two methods to perform a two-way lookup.

Using a formula
Figure 35-1 shows a worksheet with a range that displays product sales by month. To retrieve sales 
for a particular month and product, the user enters a month in cell B1 and a product name in cell B2.

Figure 35-1: This table demonstrates a two-way lookup.

To simplify the process, the worksheet uses the named ranges shown in the following minitable.

Name Refers To

Month B1

Product B2

Table D1:H14

MonthList D1:D14

ProductList D1:H1

The following formula (in cell B4) uses the MATCH function to return the position of the Month 
within the MonthList range. For example, if the month is January, the formula returns 2 because 
January is the second item in the MonthList range (the first item is a blank cell, D1):

=MATCH(Month,MonthList,0)

The formula in cell B5 works similarly but uses the ProductList range:

=MATCH(Product,ProductList,0)
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The final formula, in cell B6, returns the corresponding sales amount. It uses the INDEX function with 
the results from cells B4 and B5:

=INDEX(Table,B4,B5)

You can combine these formulas into a single formula, as shown here:

=INDEX(Table,MATCH(Month,MonthList,0),MATCH(Product,ProductList,0))

Using implicit intersection
The second method to accomplish a two-way lookup is quite a bit simpler, but it requires that you 
create a name for each row and column in the table.

A quick way to name each row and column is to select the table and choose Formulas➜Defined 
Names➜Create from Selection. In the Create Names from Selection dialog box, specify that the 
names are in the top row and left column (see Figure 35-2). Click OK, and Excel creates the names.

Figure 35-2: Creating range names automatically.

After creating the names, you can use a simple formula to perform the two-way lookup, such as

=Sprockets July

This formula, which uses the range intersection operator (a space), returns July sales data for 
Sprockets.
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Performing a Two-Column Lookup
Some situations may require a lookup based on the values in two columns. Figure 36-1 shows an 
example.

Figure 36-1: This workbook performs a lookup by using information in two columns (D and E).

The lookup table contains automobile makes and models and a corresponding code for each one. 
The technique described here allows you to look up the value based on the car’s make and model.

The worksheet uses named ranges, as shown in the following minitable.

Range Name

F2:F12 Code

B1 Make

B2 Model

D2:D12 Range1

E2:E12 Range2

The following array formula displays the corresponding code for an automobile make and model:

=INDEX(Code,MATCH(Make&Model,Range1&Range2,0))

Note 	

When you enter an array formula, press Ctrl+Shift+Enter (not just Enter).

This formula works by concatenating the contents of Make and Model and then searching for this 
text in an array consisting of the corresponding concatenated text in Range1 and Range2.
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An alternative approach is to create a new two-column lookup table, as shown in Figure 36-2. This 
table contains the same information as the original table, but column H contains the data from col-
umns D and E, concatenated.

Figure 36-2: Avoid a two-column lookup by combing two columns into one.

After you create this new table, you can use a simpler formula to perform the lookup:

=VLOOKUP(Make&Model,H2:I12,2)
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Calculating Holidays
Determining the date for a particular holiday can be tricky. Some holidays, such as New Year’s Day 
and Independence Day (U.S.), are no-brainers because they always occur on the same date. For these 
kinds of holidays, you can simply use the DATE function. For example, to calculate New Year’s Day 
(which always falls on January 1) for a specific year stored in cell A1, you can enter this function:

=DATE(A1,1,1)

Other holidays are defined in terms of a particular occurrence of a particular weekday in a particular 
month. For example, Labor Day in the U.S. falls on the first Monday in September.

The formulas that follow all assume that cell A1 contains a year value (for example, 2013). Notice that 
because New Year’s Day, Independence Day, Veterans Day, and Christmas Day all fall on the same 
days of the year, their dates can be calculated by using the simple DATE function.

Figure 37-1 shows a workbook that contains all of these formulas.

Figure 37-1: Formulas calculate the dates of holidays for the year in cell A1.

New Year’s Day
This holiday always falls on January 1:

=DATE(A1,1,1)

Martin Luther King Jr. Day
This holiday occurs on the third Monday in January. The following formula calculates Martin Luther 
King Jr. Day for the year in cell A1:
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=DATE(A1,1,1)+IF(2<WEEKDAY(DATE(A1,1,1)),7-WEEKDAY(DATE(A1,1,1))
+2,2-WEEKDAY(DATE(A1,1,1)))+((3-1)*7)

Presidents’ Day
Presidents’ Day occurs on the third Monday in February. This formula calculates Presidents’ Day for 
the year in cell A1:

=DATE(A1,2,1)+IF(2<WEEKDAY(DATE(A1,2,1)),7-WEEKDAY(DATE(A1,2,1))
+2,2-WEEKDAY(DATE(A1,2,1)))+((3-1)*7)

Easter
Calculating the date for Easter is difficult because of the complicated manner in which Easter is deter-
mined. Easter Day is the first Sunday after the next full moon occurs after the vernal equinox. I found 
these formulas to calculate Easter on the web. I have no idea how they work. They don’t work if your 
workbook uses the 1904 date system.

=DOLLAR((“4/”&A1)/7+MOD(19*MOD(A1,19)-7,30)*14%,)*7-6

This one is slightly shorter, but equally obtuse:

=FLOOR(“5/”&DAY(MINUTE(A1/38)/2+56)&”/”&A1,7)-34

Memorial Day
The last Monday in May is Memorial Day. This formula calculates Memorial Day for the year in cell A1:

=DATE(A1,6,1)+IF(2<WEEKDAY(DATE(A1,6,1)),7-WEEKDAY(DATE(A1,6,1))
+2,2-WEEKDAY(DATE(A1,6,1)))+((1-1)*7)-7

Notice that this formula calculates the first Monday in June and then subtracts 7 from the result, to 
return the last Monday in May.

Independence Day
The Independence Day holiday always falls on July 4:

=DATE(A1,7,4)
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Labor Day
Labor Day occurs on the first Monday in September. This formula calculates Labor Day for the year in 
cell A1:

=DATE(A1,9,1)+IF(2<WEEKDAY(DATE(A1,9,1)),7-WEEKDAY(DATE(A1,9,1))
+2,2-WEEKDAY(DATE(A1,9,1)))+((1-1)*7)

Columbus Day
The Columbus Day holiday occurs on the second Monday in October. The following formula calcu-
lates Columbus Day for the year in cell A1:

=DATE(A1,10,1)+IF(2<WEEKDAY(DATE(A1,10,1)),7-WEEKDAY(DATE(A1,10,1))
+2,2-WEEKDAY(DATE(A1,10,1)))+((2-1)*7)

Veterans Day
The Veterans Day holiday always falls on November 11:

=DATE(A1,11,11)

Thanksgiving Day
Thanksgiving Day is celebrated on the fourth Thursday in November. This formula calculates 
Thanksgiving Day for the year in cell A1:

=DATE(A1,11,1)+IF(5<WEEKDAY(DATE(A1,11,1)),7-WEEKDAY(DATE(A1,11,1))
+5,5-WEEKDAY(DATE(A1,11,1)))+((4-1)*7)

Christmas Day
Christmas Day always falls on December 25:

=DATE(A1,12,25)
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Calculating a Person’s Age
Calculating a person’s age is a bit tricky because the calculation depends on not only the current year 
but also the current day. And then you have to consider the complications resulting from leap years.

In this tip, I present three methods to calculate a person’s age. These formulas assume that cell B1 
contains the date of birth (for example, 2/16/1952) and that cell B2 contains the current date (calcu-
lated with the TODAY function).

Method 1
The following formula subtracts the date of birth from the current date and divides by 365.25. The 
INT function then eliminates the decimal part of the result:

=INT((B2-B1)/365.25)

This formula isn’t 100 percent accurate because it divides by the average number of days in a year. 
For example, consider a child who is exactly one year old. This formula returns 0, not 1.

Method 2
A more accurate way to calculate age uses the YEARFRAC function:

=INT(YEARFRAC(B2, B1))

The YEARFRAC function is normally used in financial calculations, but it works just fine for calculating 
ages. This function calculates the fraction of the year represented by the number of whole days 
between two dates. Using the INT function eliminates the fraction and returns an integer that repre-
sents full years.

Method 3
The third method for calculating age uses the DATEDIF function. This undocumented function isn’t 
described in the Excel Help system:

=DATEDIF(B1,B2,”Y”)
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If you’re a stickler for accuracy, here’s another version:

=DATEDIF(B1,B2,”y”) & “ years, “&DATEDIF(B1,B2,”ym”) &
“ months, “&DATEDIF(B1,B2,”md”) & “ days”

This function returns a text string, like this:

33 years, 8 months, 17 days

About the DATEDIF function
The DATEDIF function, which isn’t documented in the Excel Help system, is one of the little Excel 
mysteries. Although the Excel 2000 Help system has an entry for DATEDIF, the function is not docu-
mented in earlier or later versions.

The old Lotus 1-2-3 spreadsheet program introduced DATEDIF, and Excel likely included the func-
tion for compatibility purposes.

DATEDIF calculates the difference between two dates and expresses the result in terms of months, 
days, or years. The syntax for the DATEDIF function is

=DATEDIF(Date1,Date2,Interval)

Date1 and Date2 are standard dates (or a reference to a cell that contains a date). Date1 must be ear-
lier (or equal to) Date2. The third argument, Interval, is a text string that specifies the unit of time 
that will be returned.

Valid interval codes are described in this list:

●	 m: The number of complete months between Date1 and Date2.
●	 d: The number of days between Date1 and Date2.
●	 y: The number of complete years between Date1 and Date2.
●	 ym: The number of months between Date1 and Date2. This interval excludes years, so it works 

as though the two dates are in the same year.
●	 yd: The number of days between Date1 and Date2. This interval excludes years, so it works as 

though Date1 and Date2 are in the same year.
●	 md: The number of days between Date1 and Date2. This interval excludes both month and 

year, so it works as though Date1 and Date2 are in the same month and the same year.
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Working with Pre-1900 Dates
According to Excel, the world began on January 1, 1900. If you work with historical information or do 
genealogy research, you may have noticed that Excel doesn’t recognize pre-1900 dates. For example, 
if you enter July 4, 1776, into a cell, Excel interprets it as text, not a date.

Unfortunately, the only way to work with pre-1900 dates is to enter the date into a cell as text. The 
problem, however, is that you can’t perform any manipulation on dates recognized as text. For exam-
ple, you can’t change its numeric formatting, you can’t determine which day of the week this date 
occurred on, and you can’t calculate the date that occurs seven days later.

Use three columns
To be able to sort by dates that precede 1900, enter the year, month, and day into separate cells. 
Figure 39-1 shows a simple example.

Figure 39-1: To allow sorting by pre-1900 dates, enter the year, month, and day into separate cells.

To sort the presidents by birthday, first do an ascending sort on column D (day), an ascending sort 
on column C (month), and finally, an ascending sort on column B (year). The result is shown in 
Figure 39-2.
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Unfortunately, you can’t perform other date-related operations for these pre-1900 dates. For exam-
ple, you cannot perform subtraction to determine ages.

Figure 39-2: The presidents sorted by birthday, after performing three sorts.

Use custom functions
I created an Excel add-in, XDATE, which contains a number of functions written in VBA. These func-
tions enable you to work with dates in the years 0100 through 9999. You can download a free copy 
from my website: http://spreadsheetpage.com.

The extended date functions are

➤	 XDATE(y,m,d,fmt): Returns a date for a given year, month, and day. As an option, you can 
provide a date formatting string.

➤	 XDATEADD(xdate1,days,fmt): Adds a specified number of days to a date. As an option, you 
can provide a date formatting string.

➤	 XDATEDIF(xdate1,xdate2): Returns the number of days between two dates.

➤	 XDATEYEARDIF(xdate1,xdate2): Returns the number of full years between two dates (use-
ful for calculating ages).
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➤	 XDATEYEAR(xdate1): Returns the year of a date.

➤	 XDATEMONTH(xdate1): Returns the month of a date.

➤	 XDATEDAY(xdate1): Returns the day of a date.

➤	 XDATEDOW(xdate1): Returns the day of the week of a date (as an integer between 1 and 7).

Figure 39-3 shows a worksheet that uses some of these custom functions.

Figure 39-3: Using custom functions to work with pre-1900 dates.

Note 	

The extended date functions don’t make any adjustments for changes made to the cal-
endar in 1582. Consequently, working with dates prior to October 15, 1582, may not 
yield correct results.
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Use a different product
A final option is to use a different spreadsheet product that supports pre-1900 dates. Figure 39-4 
shows Google Spreadsheet. This (free) product uses the same date serial number system as Excel, but 
uses negative values for dates prior to 1900. It supports dates from 1583 through 9956.

Figure 39-4: Google Spreadsheet can handle pre-1900 dates.
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Displaying a Live Calendar in a Range
This tip describes how to create a “live” calendar in a range of cells. Figure 40-1 shows an example. If 
you change the date that’s displayed at the top of the calendar, the calendar recalculates to display 
the dates for the month and year.

Figure 40-1: This calendar was created with a complex array formula.

To create this calendar in the range B2:H9, follow these steps:

	 1.	 Select B2:H2 and then merge the cells by choosing Home➜Alignment➜Merge & Center.

	 2.	 Enter a date into the merged range.

		  The day of the month isn’t important, so change the format of the cell to a custom format 
that doesn’t display the day: mmmm, yyyy.

	 3.	 Enter the abbreviated day names in the range B3:H3.

	 4.	 Select B4:H9 and then enter the following array formula without the line breaks.

		  Note: To enter an array formula, press Ctrl+Shift+Enter (not just Enter):

=IF(MONTH(DATE(YEAR(B2),MONTH(B2),1))
<>MONTH(DATE(YEAR(B2),MONTH(B2),1)-
(WEEKDAY(DATE(YEAR(B2),MONTH(B2),1))-1)
+{0;1;2;3;4;5}*7+{1,2,3,4,5,6,7}-1),””,
DATE(YEAR(B2),MONTH(B2),1)-
(WEEKDAY(DATE(YEAR(B2),MONTH(B2),1))-1)
+{0;1;2;3;4;5}*7+{1,2,3,4,5,6,7}-1)
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	 5.	 Select the range B4:H9 and choose Home➜Number➜More Number formats to display the 
Number tab of the Format Cells dialog box.

	 6.	 In the Format Cells dialog box, choose Custom and enter the following custom number for-
mat (which displays the day only) in the Type field:

d

	 7.	 Adjust the column widths and format the cells the way you like.

Change the date and year in cell B2, and the calendar updates automatically. After creating this cal-
endar, you can copy the range to any other worksheet or workbook.
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Returning the Last Nonblank Cell in a 
Column or Row
Suppose that you update a worksheet frequently by adding new data to its columns. You might need 
a way to reference the last value in a particular column (the value most recently entered). This tip 
presents three ways to accomplish this.

Figure 41-1 shows an example. The worksheet tracks the value of three funds in columns B:D. Notice 
that the information does not arrive at the same time. The goal is to get the sum of the most recent 
data for each fund. These values are calculated in the range G4:G6.

Figure 41-1: Use a formula to return the last non-empty cell in columns B:D.

Cell counting method
The formulas in G4, G5, and G6 are

=INDEX(B:B,COUNTA(B:B))
=INDEX(C:C,COUNTA(C:C))
=INDEX(D:D,COUNTA(D:D))

These formulas use the COUNTA function to count the number of non-empty cells in column C. This 
value is used as the second argument for the INDEX function. For example, in column B the last value 
is in row 6, COUNTA returns 6, and the INDEX function returns the 6th value in the column.

The preceding formulas work in most, but not all, situations. If the column has one or more empty 
cells interspersed, determining the last nonblank cell is a bit more challenging because the COUNTA 
function doesn’t count the empty cells. 
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Array formula method
The following array formula returns the contents of the last non-empty cell in the first 500 rows of 
column B, even if column B contains blank cells:

=INDEX(B:B,MAX(ROW(B:B)*(B:B<>””)))

Note 	

Press Ctrl+Shift+Enter (not just Enter) to enter an array formula.

You can, of course, modify the formula to work with a column other than column B. To use a different 
column, change the four column references from B to whatever column you need.

You can’t use this formula, as written, in the same column in which it’s working. Attempting to do so 
generates a circular reference. You can, however, modify it. For example, to use the function in cell 
B1, change the references so that they begin with row 2 rather than the entire columns. For example, 
use B2:B1000 to return the last non-empty cell in the range B2:B1000.

The following array formula is similar to the previous formula, but it returns the last non-empty cell in 
a row (in this case, row 1):

=INDEX(1:1,MAX(COLUMN(1:1)*(1:1<>””)))

To use this formula for a different row, change the three 1:1 row references to correspond to the cor-
rect row number.

Standard formula method
The final method uses a standard (non-array) formula, and is rather cryptic. This formula returns the 
last non-empty cell in column B:

=LOOKUP(2,1/(B:B<>””),B:B)

This formula ignores error values, so if the last non-empty cell contains an error (such as #DIV/0!), the 
formula returns the last non-empty, non-error cell.

The following formula returns the last non-empty, non-error cell in row 1:

=LOOKUP(2,1/(1:1<>””),1:1)
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Various Methods of Rounding Numbers
Rounding numbers is a common task, and Excel provides quite a few functions that round values in 
various ways.

You must understand the difference between rounding a value and formatting a value. When you for-
mat a number to display a specific number of decimal places, formulas that refer to that number use 
the actual value, which might differ from the displayed value. When you round a number, formulas 
that refer to that value use the rounded number.

Table 42-1 summarizes the Excel rounding functions.

Table 42-1:	 Excel Rounding Functions 
Function What It Does

CEILING.MATH Rounds a number up to the nearest specified multiple

DOLLARDE Converts a dollar price, expressed as a fraction, into a decimal number

DOLLARFR Converts a dollar price, expressed as a decimal, into a fractional number

EVEN Rounds up (away from zero) positive numbers to the nearest even integer; 
rounds down (away from zero) negative numbers to the nearest even integer

FLOOR.MATH Rounds a number down to the nearest integer or to the nearest specified 
multiple

INT Rounds a number down to make it an integer

MROUND Rounds a number to a specified multiple

ODD Rounds up (away from zero) numbers to the nearest odd integer; rounds 
down (away from zero) negative numbers to the nearest odd integer

ROUND Rounds a number to a specified number of digits

ROUNDDOWN Rounds down (toward zero) a number to a specified number of digits

ROUNDUP Rounds up (away from zero) a number to a specified number of digits

TRUNC Truncates a number to a specified number of significant digits

The following sections provide examples of formulas that use various types of rounding.

Rounding to the nearest multiple
The MROUND function is useful for rounding values to the nearest multiple. For example, you can 
use this function to round a number to the nearest 5. The following formula returns 135:

=MROUND(133,5)
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Rounding currency values
Often, you need to round currency values. For example, a calculated price might be a number like 
$45.78923. In such a case, you want to round the calculated price to the nearest penny. This process 
might sound simple, but you can round this type of value in one of three ways:

➤	 Round it up to the nearest penny.

➤	 Round it down to the nearest penny.

➤	 Round it to the nearest penny (the rounding can be up or down).

The following formula assumes that a dollar-and-cents value is in cell A1. The formula rounds the 
value to the nearest penny. For example, if cell A1 contains $12.421, the formula returns $12.42.

=ROUND(A1,2)

If you need to round up the value to the nearest penny, use the CEILING.MATH function. The follow-
ing formula rounds up the value in cell A1 to the nearest penny (if, for example, cell A1 contains 
$12.421, the formula returns $12.43):

=CEILING.MATH(A1,0.01)

To round down a dollar value, use the FLOOR.MATH function. The following formula, for example, 
rounds down the dollar value in cell A1 to the nearest penny (if cell A1 contains $12.421, the formula 
returns $12.42):

=FLOOR.MATH(A1,0.01)

To round up a dollar value to the nearest nickel, use this formula:

=CEILING.MATH(A1,0.05)

Using the INT and TRUNC functions
On the surface, the INT and TRUNC functions seem similar. Both convert a value to an integer. The 
TRUNC function simply removes the fractional part of a number. The INT function rounds down a 
number to the nearest integer, based on the value of the fractional part of the number.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 42: Various Methods of Rounding Numbers120

In practice, INT and TRUNC return different results only when using negative numbers. For example, 
the following formula returns –14.0:

=TRUNC(-14.2)

The next formula returns –15.0 because –14.2 is rounded down to the next lower integer:

=INT(-14.2)

The TRUNC function takes an additional (optional) argument that’s useful for truncating decimal val-
ues. For example, the following formula returns 54.33 (the value truncated to two decimal places):

=TRUNC(54.3333333,2)

Rounding to n significant digits
In some situations, you may need to round a value to a particular number of significant digits. For 
example, you may want to express the value 1,432,187 in terms of two significant digits (that is, as 
1,400,000). The value 84,356 expressed in terms of three significant digits is 84,300.

If the value is a positive number with no decimal places, the following formula does the job. This for-
mula rounds the number in cell A1 to two significant digits. To round to a different number of signifi-
cant digits, replace the 2 in this formula with a different number:

=ROUNDDOWN(A1,2-LEN(A1))

For non-integers and negative numbers, the solution is a bit trickier. The following formula provides 
a more general solution that rounds the value in cell A1 to the number of significant digits specified 
in cell A2. This formula works for positive and negative integers and non-integers:

=ROUND(A1,A2-1-INT(LOG10(ABS(A1))))

For example, if cell A1 contains 1.27845 and cell A2 contains 3, the formula returns 1.28000 (the 
value, rounded to three significant digits).
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Converting Between Measurement 
Systems
You know the distance from New York to London in miles, but your European office needs the num-
bers in kilometers. What’s the conversion factor?

The Excel CONVERT function can convert between a variety of measurements in these categories:

➤	 Area

➤	 Distance

➤	 Energy

➤	 Force

➤	 Information

➤	 Magnetism

➤	 Power

➤	 Pressure

➤	 Speed

➤	 Temperature

➤	 Time

➤	 Volume (or liquid measure)

➤	 Weight and mass

The CONVERT function requires three arguments: the value to be converted, the from-unit, and the 
to-unit. For example, if cell A1 contains a distance expressed in miles, use this formula to convert 
miles to kilometers:

=CONVERT(A1,”mi”,”km”)

The second and third arguments are unit abbreviations, which are listed in the Help system. Some 
abbreviations are commonly used, but others aren’t. And, of course, you must use the exact abbrevia-
tion. Furthermore, the unit abbreviations are case-sensitive, so the following formula returns an error:

=CONVERT(A1,”Mi”,”km”)
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The CONVERT function is even more versatile than it seems. When using metric units, you can apply a 
multiplier. In fact, the first example I presented uses a multiplier. The unit abbreviation for the third 
argument is m, for meters. I added the kilo-multiplier (k) to express the result in kilometers.

In some situations, the CONVERT function requires some creativity. For example, if you need to con-
vert 100 km/hour into miles/sec, the formula requires two uses of the CONVERT function:

=CONVERT(100,”km”,”mi”)/CONVERT(1,”hr”,”sec”)

The CONVERT function has been significantly enhanced in Excel 2013 and supports dozens of new 
measurement units.

If you can’t find a particular unit that works with the CONVERT function, perhaps Excel has another 
function that will do the job. Table 43-1 lists some other functions that convert between measure-
ment units.

Table 43-1: Other Conversion Functions 
Function Description

ARABIC* Converts an Arabic number to decimal.

BASE* Converts a decimal number to a specified base.

BIN2DEC Converts a binary number to decimal.

BIN2OCT Converts a binary number to octal.

DEC2BIN Converts a decimal number to binary.

DEC2HEX Converts a decimal number to hexadecimal.

DEC2OCT Converts a decimal number to octal.

DEGREES Converts an angle (in radians) to degrees.

HEX2BIN Converts a hexadecimal number to binary.

HEX2DEC Converts a hexadecimal number to decimal.

HEX2OCT Converts a hexadecimal number to octal.

OCT2BIN Converts an octal number to binary.

OCT2DEC Converts an octal number to decimal.

OCT2HEX Converts an octal number to hexadecimal.

RADIANS Converts an angle (in degrees) to radians.
* Function is new to Excel 2013.
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Counting Nonduplicated Entries in a 
Range
In some situations, you may need to count the number of nonduplicated entries in a range. Figure 
44-1 shows an example. Column A has a list of animals, and the goal is to count the number of differ-
ent animals in the list. The formula in cell B2 returns 6, which is the number of nonduplicated ani-
mals. This formula (an array formula, by the way) is

=SUM(1/COUNTIF(A1:A10,A1:A10))

To adapt this formula to your own worksheet, just change both instances of A1:A10 to the range 
address that you’re working with.

Note 	

When you enter an array formula, press Ctrl+Shift+Enter (not just Enter).

Figure 44-1: Use an array formula to count the number of nonduplicated entries in a range.

This formula is one of those “Internet classics” that is passed around on various websites and news-
groups. Credit goes to David Hager, who first came up with the formula.
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The preceding array formula works fine unless the range contains one or more empty cells. The fol-
lowing modified version of this array formula uses the IFERROR function to overcome this problem:

=SUM(IFERROR(1/COUNTIF(A1:A10,A1:A10),0))

The preceding formulas work with both values and text. If the range contains only numeric values or 
blank cells (but no text), you can use the following formula (which isn’t an array formula) to count the 
number of nonduplicated values:

=SUM(N(FREQUENCY(A1:A10,A1:A10)>0))
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Using the AGGREGATE Function
One of the most versatile functions available in Excel is AGGREGATE, which was introduced in Excel 
2010. You can use this multipurpose function to sum values, calculate an average, count entries, and 
more. What makes this function useful is that it can (optionally) ignore values in hidden rows and 
error values. In some cases, you can use AGGREGATE to replace a complex array formula.

The AGGREGATE function takes three arguments, but for some functions, an additional argument is 
required.

The first argument for the AGGREGATE function is a value between 1 and 19 that determines the 
type of calculation to perform. The calculation type, in essence, is one of Excel’s other functions. 
Table 45-1 contains a list of these values, with the function it mimics.

Table 45-1:	 Values for the First Argument of the AGGREGATE Function 
Argument Value Function

1 AVERAGE

2 COUNT

3 COUNTA

4 MAX

5 MIN

6 PRODUCT

7 STDEV.S

8 STDEV.P

9 SUM

10 VAR.S

11 VAR.P

12 MEDIAN

13 MODE.SNGL

14* LARGE

15* SMALL

16* PERCENTILE.INC 

17* QUARTILE.INC

18* PERCENTILE.EXC

19* QUARTILE.EXC
* Indicates a function that requires an additional (4th) argument.
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The second argument for the AGGREGATE function is an integer between 0 and 7 that specifies how 
hidden cells and errors are handled. Table 45-2 summarizes these options.

Table 45-2:	 Values for the Second Argument of the AGGREGATE Function 
Option Behavior

0 or omitted Ignore nested SUBTOTAL and AGGREGATE functions.

1 Ignore hidden rows, nested SUBTOTAL and AGGREGATE functions.

2 Ignore error values, nested SUBTOTAL and AGGREGATE functions.

3 Ignore hidden rows, error values, nested SUBTOTAL and AGGREGATE functions.

4 Ignore nothing.

5 Ignore hidden rows.

6 Ignore error values.

7 Ignore hidden rows and error values.

The third argument of the AGGREGGATE function is a range reference for the data to be aggregated.

Note 	

The SUBTOTAL function always ignores data that is hidden, but only if the hiding is a 
result of filtering a table or contracting an outline. The AGGREGATE function works simi-
larly, but also ignores data in rows that has been hidden manually. Note that this func-
tion does not ignore data in hidden columns. In other words, the AGGREGATE function 
was designed to work only with vertical ranges.

Fortunately, Excel provides “formula autocomplete” assistance when you enter this function in a for-
mula. Figure 45-1 shows the drop-down list of arguments that appears automatically. Choose the 
argument and press Tab to continue.

Figure 45-1: Using autocomplete to identify the argument values for AGGREGATE.
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Figure 45-2 shows an example of how the AGGREGATE function can be useful. The worksheet con-
tains pre-test and post-scores for eight students. Note that Charles did not take the post-test, so cells 
C4 and D4 contain the NA/# error value (to indicate not available).

Cell D11 contains a formula that uses the AVERAGE function to calculate the average change. This 
formula returns an error:

=AVERAGE(D2:D9)

The formula in cell D12 uses the AGGREGATE function, with the option to ignore error values:

=AGGREGATE(1,6,D2:D9)

Figure 45-2: Using the AGGREGATE function to calculate an average when the range contains an error value.

Remember that AGGREGATE works only with Excel 2010 and later. If a workbook that uses this func-
tion is opened in a previous version of Excel, the formula will display an error.
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Making an Exact Copy of a Range of 
Formulas
When you copy a cell that contains a formula, Excel adjusts all the relative cell references. Assume 
that cell D1 contains this formula:

=A1*B1

When you copy this cell, the two cell references are changed relative to the destination. If you copy 
D1 to D12, for example, the copied formula is

=A12*B12

Sometimes, you may prefer to make an exact copy of a formula. One way is to convert all the cell ref-
erences to absolute references (for example, change =A1*B1 to =$A$1*$B$1). Another way is to 
(temporarily) remove the equal sign from the formula, which converts the formula to text. Then you 
can copy the cell and manually insert the equal sign into the original formula and the copied formula.

What if you have a large range of formulas and you want to make an exact copy of those formulas? 
Editing each formula is tedious and error-prone. Here’s a way to accomplish the task. It uses Windows 
Notepad, but any text editor (including Microsoft Word) will do.

For the following steps, assume that you want to copy the formulas in A1:D10 on Sheet1 and make 
an exact copy in A13:D22, also on Sheet1:

	 1.	 Put Excel in Formula view mode.

		  To toggle Formula view mode, choose Formulas➜Formula Auditing➜Show Formulas.

	 2.	 Select the range to copy. In this case, A1:D10 on Sheet1.

	 3.	 Press Ctrl+C to copy the range.

	 4.	 Launch the Windows Notepad text editor.

	 5.	 Press Ctrl+V to paste the copied data into Notepad.

	 6.	 In Notepad, press Ctrl+A to select all of the text, followed by Ctrl+C to copy the text.

	 7.	 Activate Excel and activate the upper-left cell where you want to paste the formulas (in this 
example, A13 on Sheet2) and make sure that the sheet you’re copying to is in Formula view 
mode.

	 8.	 Press Ctrl+V to paste.

	 9.	 Choose Formulas➜Formula Auditing➜Show Formulas to toggle out of Formula view mode.
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The formulas will be pasted exactly as they appear in the source range.

Note 	

In some cases, the paste operation (in Step 8) won’t work correctly and the formulas will 
be split across two or more cells. If that happens, chances are that you used Excel’s Text-
to-Columns feature recently, and Excel is trying to be helpful by remembering how you 
last parsed your data. You need to fire up the Text to Columns Wizard and change the 
options. Choose Data➜Data Tools➜Text to Columns. In the Convert Text to Columns 
Wizard dialog box, choose the Delimited option and click Next. Clear all of the Delimiter 
option check marks except Tab, and click Cancel. After making this change, pasting the 
formulas will work correctly.
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Using the Background Error-Checking 
Features
If your worksheets use a lot of formulas, you may find it helpful to take advantage of the automatic 
error-checking feature. You enable this feature on the Formulas tab of the Excel Options dialog box 
(see Figure 47-1). To display this dialog box, choose File➜Options.

You turn error checking on or off by using the Enable Background Error Checking check box. In addi-
tion, you can specify which types of errors to check by selecting check boxes in the Error Checking 
Rules section.

Figure 47-1: Excel can check your formulas for potential errors.

When error checking is turned on, Excel continually checks your formulas. If a potential error is identi-
fied, Excel places an error indicator (a small triangle) in the upper-left corner of the cell. When the cell 
is activated, an error-checking button appears. Clicking this buttons provides you with a list of 
options. Figure 47-2 shows the options that appear when you click the error-checking button for a 
cell that contains a #DIV/0! error. The options vary, depending on the type of error.
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Figure 47-2: Clicking an error-checking button gives you a list of options.

In many cases, you choose to ignore an error by choosing the Ignore Error option, which eliminates 
the cell from subsequent error checks. You can select a range of formulas, and then choose Ignore 
Error to ignore them all. All previously ignored errors can be reset so that they appear again. (Click 
the Reset Ignored Errors button in the Excel Options dialog box.)

Even if you don’t use the automatic error-checking option, you can choose the Formulas➜Formula 
Auditing➜Error Checking command to open a dialog box that displays each potential error cell in 
sequence, much like using a spell-checking feature. Figure 47-3 shows the Error Checking dialog box. 
Note that because it’s a modeless dialog box, you can still access your worksheet when the Error 
Checking dialog box is open.

Figure 47-3: Using the Error Checking dialog box to cycle through potential errors identified by Excel.

Caution	

Understand that the error-checking feature isn’t perfect. In fact, it’s not even close to 
perfect. In other words, you can’t assume that you have an error-free worksheet simply 
because Excel doesn’t identify any potential errors! Also, be aware that this error-check-
ing feature doesn’t catch a common type of error — overwriting a formula cell with a 
value.
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Using the Inquire Add-In
Office 2013 Professional Plus includes a handy auditing add-in called Inquire. To install this add-in, 
follow these steps:

	 1.	 Choose File➜Options to display the Excel Options dialog box.

	 2.	 Click the Add-Ins tab.

	 3.	 Choose COM Add-Ins from the Manage drop-down list and click Go to display the COM Add-
Ins dialog box.

	 4.	 In the COM Add-Ins dialog box, select the Inquire item and click OK.

If the Inquire item is not in the list, that means your version of Office doesn’t include this add-in.

When the Inquire Add-In is installed, Excel displays a new tab: Inquire (see Figure 48-1).

Figure 48-1: The Inquire tab appears when the Inquire add-in is installed.

Workbook analysis
To analyze the active workbook, choose Inquire➜Report➜Workbook Analysis to display the 
Workbook Analysis Report dialog box shown in Figure 48-2. Use the Items list on the left to select an 
analysis item, and the results (if any) appear in the Results section on the right. To create a report (in 
a new workbook), select the items to include in the report and choose Excel Export. The report is 
very detailed and is a good way to document an Excel workbook.

Figure 48-2: The Workbook Analysis Report dialog box.
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Diagram tools
The items in the Inquire➜Diagram group each display a diagram:

➤	 Workbook relationships

➤	 Worksheet relationships

➤	 Cell relationships

Figure 48-3 shows an example of worksheet relationships in a workbook that has four worksheets. It 
shows that Sheet3 contains formulas that refer to Sheet1 and Sheet2, and Sheet4 has formulas that 
refer to Sheet1.

Figure 48-3: This diagram depicts relationships between worksheets.

Compare files
The Inquire➜Compare➜Compare Files command generates a detailed display that shows the differ-
ences between two workbooks. Both of the workbooks to be compared must be open.

Figure 48-4 shows an example of the output.
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Figure 48-4: Output from the Compare Files command.

Other options
The Inquire add-in has some additional options in the Inquire➜Miscellaneous group:

➤	 Clean Excess Cell Formatting: Removes unnecessary formatting from cells. For example, 
the command will remove formatting applied to entire rows or columns.

➤	 Workbook Passwords: If you use Inquire to analyze or compare workbooks that are pass-
word-protected, you can avoid having to type the password each time those files are 
opened.

➤	 Help: Displays help about the Inquire add-in features.
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Hiding and Locking Your Formulas
If you distribute workbooks to other users, you may want to hide your formulas. This tip describes 
how to do so.

Every cell has two key properties: Locked and Hidden. A locked cell can’t be changed, and the con-
tents of a hidden cell don’t appear in the Formula bar when the cell is selected. By default, every cell 
is locked and not hidden. But it’s important to remember that these attributes have no effect unless 
the worksheet itself is protected.

A common scenario is to lock (and possibly hide) formula cells and unlock constant (nonformula cells).

Hiding and locking formula cells
Follow these steps to hide all of the formula cells on the active worksheet:

	 1.	 Select a single cell, and choose Home➜Editing➜Find & Select➜Go To Special. Excel displays 
the Go To Special dialog box.

	 2.	 In the Go To Special dialog box, choose the Formulas option and make sure all four check 
boxes are checked (see Figure 49-1).

	 3.	 Click OK, and Excel selects all of the formula cells.

	 4.	 Right-click any of the selected formula cells and choose Format Cells from the shortcut menu.

		  The Format Cells dialog box appears.

	 5.	 Click the Protection tab to display the Locked and Hidden checkboxes.

	 6.	 Check both the Locked and the Hidden check boxes.

	 7.	 Click OK to close the Format Cells dialog box.

Figure 49-1: Using the Go To Special dialog box to select all formula cells.
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Unlocking nonformula cells
Follow these steps to unlock all of the nonformula cells:

	 1.	 Select a single cell, and choose Home➜Editing➜Find & Select➜Go To Special. Excel displays 
the Go To Special dialog box.

	 2.	 In the Go To Special dialog box, choose the Constants option and make sure all four check 
boxes are checked.

	 3.	 Click OK, and Excel selects all of the constant (nonformula) cells.

	 4.	 Right-click any of the selected formula cells and choose Format Cells from the shortcut 
menu. 

		  The Format Cells dialog box appears.

	 5.	 Click the Protection tab to display the Locked and Hidden check boxes.

	 6.	 Uncheck both the Locked and the Hidden check boxes.

	 7.	 Click OK to close the Format Cells dialog box.

Protecting the worksheet
The steps in the two previous sections have no effect unless the worksheet is protected. Follow these 
steps to protect the worksheet:

	 1.	 Choose Review➜Changes➜Protect Sheet to access the Protect Sheet dialog box (see  
Figure 49-2).

Figure 49-2: The Protect Sheet dialog box.
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	 2.	 In the Protect Sheet dialog box, specify a password (if desired). If you don’t specify a pass-
word, anyone can unprotect the sheet and see (or modify) the formulas.

	 3.	 Click OK, and you will be prompted to reenter the password.

When you protect a worksheet, many common actions are disabled. For example, the user cannot 
insert rows or columns, change column width, or create embedded charts. Use the options in the 
Protect Sheet dialog box to specify the actions that are allowed when the sheet is protected.

After performing these steps, cells that contain a formula are not displayed in the Formula bar. If the 
user attempts to edit the cell, the alert box shown in Figure 49-3 appears. Nonformula cells can be 
edited, as usual.

Figure 49-3: This alert box appears if the user attempts to edit a formula cell.

Note 	

Keep in mind that it is very easy to break the password for a protected sheet. If you’re 
looking for absolute security, hiding and locking formula cells is not the solution.
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Using the INDIRECT Function
To make a formula more flexible, you can use the Excel INDIRECT function to create a range refer-
ence. This rarely used function accepts a text argument that resembles a range reference and then 
converts the argument to an actual range reference. When you understand how this function works, 
you can use it to create more powerful interactive spreadsheets.

Specifying rows indirectly
Figure 50-1 shows an example that uses the INDIRECT function. The formula in cell E5 is

=SUM(INDIRECT(“B”&E2&”:B”&E3))

Figure 50-1: Using the INDIRECT function to sum user-specified rows.

The argument for the INDIRECT function uses the concatenation operator to build a range reference 
by using the values in cells E2 and E3. So, if E2 contains 2 and E3 contains 4, the range reference eval-
uates to this string:

“B2:B4”
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The INDIRECT function converts that string to an actual range reference, which is then passed to the 
SUM function. In effect, the formula returns

=SUM(B2:B4)

When you change the values in E2 or E3, the formula is updated to display the sum of the specified rows.

Specifying worksheet names indirectly
Figure 50-2 shows another example, this time using a worksheet reference.

Column A, on the Summary worksheet, contains text that corresponds to other worksheets in the 
workbook. Column B contains formulas that reference these text items. For example, the formula in 
cell B2 is

=SUM(INDIRECT(A2&”!F1:F10”))

Figure 50-2: Using the INDIRECT function to create references.

This formula concatenates the text in A2 with a range reference. The INDIRECT function evaluates the 
result and converts it to an actual range reference. The result is equivalent to this formula:

=SUM(North!F1:F10)

This formula is copied down the column. Each formula returns the sum of range F1:F10 on the corre-
sponding worksheet.
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Making a cell reference unchangeable
Another use for the INDIRECT function is to create a reference to a cell that never changes. For exam-
ple, consider this formula, which sums the values in the first 12 rows of column A:

=SUM(A1:A12)

If you insert a new row 1, Excel changes the formula to

=SUM(A2:A13)

In other words, the formula adjusts so that it continues to refer to the original data (and it no longer 
sums the first 12 rows of column A). To prevent Excel from changing the cell references, use the 
INDIRECT function:

=SUM(INDIRECT(“A1:A12”))

This formula always returns the sum of the first 12 rows in column A.
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Formula Editing in Dialog Boxes
This is a simple tip, but one that most users don’t know about.

When Excel displays a dialog box that accepts a range reference, the field that contains the range refer-
ence is always in point mode. For example, consider the New Name dialog box, shown in Figure 51-1. 
This dialog box appears when you choose Formulas➜Defined Names➜Define Name.

If you activate the Refers to Field and use the arrow keys to edit the range reference, you’ll find that 
you’re actually pointing to a range in the worksheet — not editing the reference text. The solution: 
Press F2.

The F2 key toggles between point mode and edit mode. In edit mode, the arrow keys work the same 
as when you’re editing a formula. Also notice that the current mode is displayed in the left corner of 
the status bar.

Figure 51-1: The Refers To field defaults to point mode. Press F2 to switch to edit mode.

This tip applies to all Excel dialog boxes that contain range selection fields.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 52: Converting a Vertical Range to a Table142

Converting a Vertical Range to a Table
Often, tabular data is imported into Excel as a single column. Figure 52-1 shows an example. Column 
A contains employee information, and each “record” consists of three consecutive cells in a single 
column: Name, Department, and Location. The goal is to convert this data so that each record 
appears in a single row, with three columns.

Figure 52-1: Vertical data that needs to be converted to three columns.

You can convert this type of data several ways, but here’s a method that’s fairly easy. It uses a single 
formula, which is copied to a range.

Enter the following formula in cell C1, and then copy it down and across. 

=INDIRECT(“A” &COLUMN()-2 + (ROW()-1)*3)
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Figure 52-2 shows the transformed data in C1:E7. 

Figure 52-2: Vertical data transformed to a table.

The formula works for vertical data that uses three cells per record, but it can be modified to handle 
vertical data that uses any number of cells per record by changing the “3” in the formula. For exam-
ple, if the vertical data has five fields, use this formula:

=INDIRECT(“A” &COLUMN()-2 + (ROW()-1)*5)
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PART IV
Working with  
Data
In this part, you’ll find tips related to working with data of all types. There’s an 
excellent chance that the tips here will improve your overall efficiency.
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Selecting Cells Efficiently
Many Excel users think that the only way to select a range of cells is to drag over the cells with the 
mouse. Although selecting cells with a mouse works, it’s rarely the most efficient way to accomplish 
the task. A better way is to use your keyboard to select ranges.

Selecting a range by using the Shift and arrow keys
The simplest way to select a range is to press (and hold) Shift and then use the arrow keys to high-
light the cells. For larger selections, you can use PgDn or PgUp while pressing Shift to move in larger 
increments.

You can also use the End key to quickly extend a selection to the last non-empty cell in a row or col-
umn. To select the range B3:B8 (see Figure 53-1) by using the keyboard, move the cell pointer to B3 
and then press the Shift key while you press End followed by the down-arrow key. Similarly, to select 
B3:D3, press the Shift key while you press End, followed by the right-arrow key.

Figure 53-1: A range of cells.
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Selecting the current region
Often, you need to select a large rectangular selection of cells — the current region. To select the 
entire block of cells, move the cell pointer anywhere within the range and press Ctrl+A.

Note 	

If the cell pointer is within a table (created by using Insert➜Tables➜Table), pressing 
Ctrl+A selects only the data. Press Ctrl+A a second time to select the table’s Header row 
and Total row.

Selecting a range by Shift+clicking
When you’re selecting a very large range, using the mouse may be the most efficient method — but 
dragging is not required. Select the upper-left cell in the range. Then scroll to the lower-right corner 
of the range, press Shift, and click the lower-right cell.

Selecting noncontiguous ranges
Most of the time, your range selections are probably simple rectangular ranges. In some cases, you 
may need to make a multiple selection — a selection that includes nonadjacent cells or ranges. For 
example, you may want to apply formatting to cells in different areas of your worksheet. If you make 
a multiple selection, you can apply the formatting in one step to all selected ranges. Figure 53-2 
shows an example of a multiple selection.

Figure 53-2: A multiple selection that consists of noncontiguous ranges.

You can select a noncontiguous range by using either the mouse or the keyboard.

Press Ctrl as you click and drag the mouse to highlight individual cells or ranges.

From the keyboard, select a range as described previously (by using the Shift key). Then press Shift+F8 
to select another range without canceling the previous range selection. Repeat this action as many 
times as needed. When you’re finished, press Shift+F8 again to return to normal selecting mode.
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Selecting entire rows
To select a single row, click a row number along the left of the worksheet. Or select any cell in the 
row and press Shift+spacebar.

To select multiple adjacent rows, click and drag in the row number area. Or select any cell in the first 
(or last) row and press Shift+spacebar to select the row. Then press Shift and use the arrow keys to 
extend the row selection down (or up).

To select multiple nonadjacent rows, press Ctrl while you click the row numbers for the rows you 
want to include.

Selecting entire columns
To select a single column, click a column letter along the top of the worksheet. Or select any cell in 
the column and press Ctrl+spacebar.

To select multiple adjacent columns, click and drag in the column letter section. Or select any cell in 
the first (or last) column and press Ctrl+spacebar to select the column. Then press Shift and use the 
arrow keys to extend the selection to the right (or left).

To select multiple nonadjacent columns, press Ctrl while you click the column letters for the columns 
you want to include.

Selecting multisheet ranges
In addition to two-dimensional ranges on a single worksheet, ranges can extend across multiple 
worksheets to be three-dimensional ranges.

Figure 53-3 shows a simple example of a multisheet workbook. The workbook has four sheets, 
named Totals, Operations, Marketing, and Manufacturing. The sheets are laid out identically.

Figure 53-3: Each worksheet in this workbook is laid out identically.
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Assume that you want to apply the same formatting to all sheets — for example, you want to 
make the column headings bold with background shading. Selecting a multisheet range is the 
best approach. When the ranges are selected, the formatting is applied to all sheets.

In general, selecting a multisheet range is a simple two-step process:

	 1.	 Select the range in one sheet.

	 2.	 Select the worksheets to include in the range.

	

To select a group of contiguous worksheets, press Shift and click the sheet tab of the 
last worksheet that you want to include in the selection. To select individual worksheets, 
press Ctrl and click the sheet tab of each worksheet that you want to select. When you 
make the selection, the sheet tabs of the selected sheets appear with a white back-
ground, and Excel displays [Group] on the title bar. When you finish working with the 
multisheet range, click any sheet tab to leave Group mode.

Note
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Automatically Filling a Range with a Series
If you need to fill a range with a series of values, one approach is to enter the first value, write a for-
mula to calculate the next value, and copy the formula. For example, Figure 54-1 shows a series of 
consecutive numbers in column A. Cell A1 contains the value 1, and cell A2 contains this formula, 
which was copied down the column:

=A1+1

Figure 54-1: Excel offers an easy way to generate a series of values like these.

Another approach is to let Excel do the work by using the handy AutoFill feature:

	 1.	 Enter 1 into cell A1.

	 2.	 Enter 2 into cell A2.

	 3.	 Select A1:A2.

	 4.	 Move the mouse cursor to the lower-right corner of cell A2 (the cell’s fill handle), and when 
the mouse pointer turns into a black plus sign, drag down the column to fill in the cells.

Note 	

You can turn this behavior on and off. If cells don’t have a fill handle, choose File➜ 

Options and click the Advanced tab in the Excel Options dialog box. Select the check 
box labeled Enable Fill Handle and Cell Drag-And-Drop.

The data entered in Steps 1 and 2 provide Excel with the information it needs to determine which type 
of series to use. If you entered 3 in cell A2, the series will consist of odd integers: 1, 3, 5, 7, and so on.

When you release the mouse button after dragging, Excel displays an Auto Fill Options drop-down 
list. Click to select other options. The list of options is particular helpful with dates. Figure 54-2 shows 
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the Auto Fill Options when working with a date series. You can quickly create a series of weekdays, 
months, or years.

Figure 54-2: Use the Auto Fill Options drop-down list to change the type of fill.

Here’s another AutoFill trick: If the data you start with is irregular, Excel completes the AutoFill action 
by doing a linear regression and fills in the predicted values. Figure 54-3 shows a worksheet with 
monthly sales values for January through July. If you use AutoFill after selecting C2:C8, Excel extends 
the best-fit linear sales trend and fills in the missing values. Figure 54-4 shows the predicted values, 
along with a chart.

Figure 54-3: Use AutoFill to perform a linear regression and predict sales values for August through December.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 54: Automatically Filling a Range with a Series 153

Figure 54-4: The sales figures, after using AutoFill to predict the next five months.

AutoFill also works with dates and even a few text items — day names and month names. The fol-
lowing table lists a few examples of the types of data that can be autofilled.

First Value Autofilled Values

Sunday Monday, Tuesday, Wednesday, and so on

Quarter-1 Quarter-2, Quarter-3, Quarter-4, Quarter-1, and so on

Jan Feb, Mar, Apr, and so on

January February, March, April, and so on

Month 1 Month 2, Month 3, Month 4, and so on

You can also create your own lists of items to be autofilled. To do so, open the Excel Options dialog box 
and click the Advanced tab. Then scroll down and click the Edit Custom Lists button to display the 
Custom Lists dialog box. Enter your items in the List Entries box (each on a new line). Then click the Add 
button to create the list. Figure 54-5 shows a custom list of region names that use Roman numerals.

Figure 54-5: These region names work with the Excel AutoFill feature.
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Fixing Trailing Minus Signs
Imported data sometimes displays negative values with a trailing minus sign. For example, a nega-
tive value may appear as 3,498- rather than the more common -3,498. Excel doesn’t convert these 
values. In fact, it considers them to be non-numeric text.

The solution is so simple it may surprise you:

	 1.	 Select the data that has the trailing minus signs. The selection can also include positive values.

	 2.	 Choose Data➜Data Tools➜Text to Columns.

	 3.	 When the Text to Columns dialog box appears, click Finish.

This procedure works because of a default setting in the Advanced Text Import Settings dialog box 
(which you don’t even see, normally). To display this dialog box, shown in Figure 55-1, go to Step 3 in 
the Text to Columns Wizard dialog box and click Advanced.

Or you can use Flash Fill to fix the trailing minus signs. If the range contains any positive values, you 
may need to provide several examples. See Tip 64 for information about the Flash Fill feature.

Figure 55-1: The Trailing Minus for Negative Numbers option makes it very easy to fix trailing minus signs in a 
range of data.
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Restricting Cursor Movement to Input Cells
A common type of worksheet uses two types of cells: input cells and formula cells. The user enters 
data into the input cells, and the formulas calculate and display the results.

Figure 56-1 shows a simple example. The input cells are in the range C4:C7. These cells are used by 
the formulas in C10:C13. To prevent the user from accidentally typing over formula cells, it’s useful to 
limit the cursor movement so that the formula cells can’t even be selected.

Figure 56-1: This worksheet has input cells at the top and formula cells below.

Setting up this sort of arrangement is a two-step process: Unlock the input cells and then protect the 
sheet. The following specific instructions are for the example shown in Figure 56-1:

	 1.	 Select C4:C7.

	 2.	 Press Ctrl+1 to display the Format Cells dialog box.

	 3.	 In the Format Cells dialog box, click the Protection tab, deselect the Locked check box, and 
click OK.

		  By default, all cells are locked.

	 4.	 Choose Review➜Changes➜Protect Sheet.

		  The Protect Sheet dialog box appears.

	 5.	 Deselect the Select Locked Cells check box and make sure that the Select Unlocked Cells 
check box is selected.

	 6.	 (Optional) Specify a password that will be required to unprotect the sheet.

	 7.	 Click OK.
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After you perform these steps, only the unlocked cells can be selected. If you need to make any 
changes to your worksheet, you need to unprotect the sheet first, by choosing Review➜Changes➜ 

Unprotect Sheet.

Although this example used a contiguous range of cells for the input, that isn’t necessary for the 
steps to work. The input cells can be scattered throughout your worksheet.

Note 	

Protecting a worksheet with a password isn’t a security feature. This type of password is 
easily cracked.
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Transforming Data with and Without 
Using Formulas
Often, you have a range of cells containing data that must be transformed in some way. For example, 
you might want to increase all values by five percent. Or you might need to divide each value by two. 
This tip describes two ways to perform these types of transformations.

Transforming data without formulas
The following steps assume that you have values in a range and you want to increase all values by five 
percent. For example, the range can contain a price list and you’re raising all prices by five percent:

	 1.	 Activate any empty cell and enter 1.05.

		  You will multiply the values by this number, which results in an increase of five percent.

	 2.	 Press Ctrl+C to copy that cell.

	 3.	 Select the range to be transformed.

		  The range can include values, formulas, or text.

	 4.	 Choose Home➜Clipboard➜Paste➜Paste Special to display the Paste Special dialog box (see 
Figure 57-1).

	 5.	 In the Paste Special dialog box, click the Multiply option.

	 6.	 Click OK.

	 7.	 Press Esc to cancel Copy mode.

Figure 57-1: Using the Paste Special dialog box to multiply a range by a value.
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The values in the range are multiplied by the copied value (1.05), and cells that contain text are 
ignored. Formulas in the range are modified accordingly. Assume that the range originally contained 
this formula:

=SUM(B18:B22)

After you perform the Paste Special operation, the formula is converted to

=(SUM(B18:B22))*1.05

This technique is limited to the four basic math operations: add, subtract, multiply, and divide.

For more versatility, keep reading to learn how to use formulas to transform values.

Transforming data by using temporary formulas
The previous section describes how to perform simple mathematical transformations on a range of 
numeric data. This tip describes the much more versatile method of transforming data (numerical or 
text) by using temporary formulas.

Figure 57-2 shows a worksheet with names in column A. These names are in all uppercase letters, 
and the goal is to convert them to proper case (only the first letter of each name is uppercase).

Figure 57-2: The goal is to transform the names in column A to proper case.
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Follow these steps to transform the data in column A:

	 1.	 Create a temporary formula in an unused column.

		  For this example, enter this formula in cell C2:

=PROPER(A2)

	 2.	 Copy the formula down the column to accommodate all cells to be transformed.

	 3.	 Select the formula cells (in column C).

	 4.	 Press Ctrl+C.

	 5.	 Select the original data cells (in column A).

	 6.	 Choose Home➜Clipboard➜Paste➜Paste Values (V).

		  The original data is replaced with the transformed data (see Figure 57-3).

	 7.	 Press Esc to cancel Copy mode.

	 8.	 When you’re satisfied that the transformation happened as you intended, you can delete the 
temporary formulas in column C.

Figure 57-3: The formula results from column C replace the original data in column A.

You can adapt this technique for just about any type of data transformation you need. The key, of 
course, is constructing the proper transformation formula in Step 1.
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Creating a Drop-Down List in a Cell
Most Excel users probably assume that some advanced feature (such as a VBA macro) is required to 
display a drop-down list in a cell. But it’s not. You can easily display a drop-down list in a cell — no 
macros required.

Figure 58-1 shows an example. Cell B2, when selected, displays a down arrow. Click the arrow, and 
you get a list of items (in this case, month names). Click an item, and it appears in the cell. The drop-
down list can contain text, numeric values, or dates. Your formulas, of course, can refer to cells that 
contain a drop-down list. The formulas always use the value that’s currently displayed.

Figure 58-1: Creating a drop-down list in a cell is easy and doesn’t require macros.

The trick to setting up a drop-down list is to use the data validation feature. The following steps 
describe how to create a drop-down list of items in a cell:

	 1.	 Enter the list of items in a range.

		  In this example, the month names are in the range F1:F12.

	 2.	 Select the cell that will contain the drop-down list (cell B2, in this example).

	 3.	 Choose Data➜Data Tools➜Data Validation.

	 4.	 In the Data Validation dialog box, click the Settings tab.

	 5.	 In the Allow drop-down list, select List.

	 6.	 In the Source box, specify the range that contains the items.

		  In this example, the range is E1:E12.

	 7.	 Make sure that the In-Cell Dropdown option is checked (see Figure 58-2) and click OK.
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If your list is short, you can avoid Step 1. Rather, just type your list items (separated by commas) in 
the Source box in the Data Validation dialog box.

If you plan to share your workbook with others who use Excel 2007 or earlier, make sure that the list 
is on the same sheet as the drop-down list. Alternatively, you can put the list on any sheet, as long as 
it’s a named range. For example, you can choose Formulas➜Defined Names➜Define Name to define 
the name MonthNames for E1:E12. Then, in the Data Validation dialog box, enter =MonthNames in 
the Source box.

Figure 58-2: Using the Data Validation dialog box to create a drop-down list.
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Comparing Two Ranges by Using 
Conditional Formatting
A common task is comparing two lists of items to identify differences between the two lists. Doing it 
manually is far too tedious and error-prone, but Excel can make it easy. This tip describes a method 
that uses conditional formatting.

Figure 59-1 shows an example of two multicolumn lists of names. Applying conditional formatting 
can make the differences in the lists become immediately apparent. These list examples contain text, 
but this technique also works with numeric data.

Figure 59-1: You can use conditional formatting to highlight the differences in these two ranges.

The first list is in A2:A20, and this range is named OldList. The second list is in C2:C20, and the range is 
named NewList. The ranges were named by using the Formulas➜Defined Names➜Define Name 
command. Naming the ranges isn’t necessary, but it makes them easier to work with.

Start by adding conditional formatting to the old list:

	 1.	 Select the cells in the OldList range.

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the New Formatting Rule  
dialog box.

	 3.	 In the New Formatting Rule dialog box, click the option labeled Use a Formula to Determine 
Which Cells to Format.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 59: Comparing Two Ranges by Using Conditional Formatting 163

	 4.	 Enter this formula in the dialog box (see Figure 59-2):

=COUNTIF(NewList,A2)=0

		  When using this technique with your own data, substitute the actual range address (or 
name) for NewList, and substitute the address of the top left selected cell for A2.

	 5.	 Click the Format button and specify the formatting to apply when the condition is true.

		  A different fill color is a good choice.

	 6.	 Click OK.

Figure 59-2: Applying conditional formatting.

The cells in the NewList range use a similar conditional formatting formula.

	 1.	 Select the cells in the NewList range.

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the New Formatting Rule dia-
log box.

	 3.	 In the New Formatting Rule dialog box, click the option labeled Use a Formula to Determine 
Which Cells to Format.

	 4.	 Enter this formula in the dialog box:

=COUNTIF(OldList,C2)=0

		  When using this technique with your own data, substitute the actual range address (or 
name) for OldList, and substitute the address of the top left selected cell for C2.
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	 5.	 Click the Format button and specify the formatting to apply when the condition is true (a dif-
ferent fill color).

	 6.	 Click OK.

Figure 59-3 shows the result. Names that are in the old list but not in the new list are highlighted. In 
addition, names in the new list that aren’t in the old list are highlighted in a different color. Names 
that aren’t highlighted appear in both lists.

Figure 59-3: Conditional formatting causes differences in the two lists to be highlighted.

Both of these conditional-formatting formulas use the COUNTIF function. This function counts the 
number of times a particular value appears in a range. If the formula returns 0, it means that the item 
doesn’t appear in the range. Therefore, the conditional formatting kicks in and the cell’s background 
color is changed.
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Finding Duplicates by Using Conditional 
Formatting
You might find it helpful to identify duplicate values within a range of cells. For example, take a look 
at Figure 60-1. Are any of the values duplicated?

One approach to identifying duplicate values is to use conditional formatting. After applying a condi-
tional formatting rule, you can quickly spot duplicated cell values.

Figure 60-1: You can use conditional formatting to quickly identify duplicate values in a range.

Here’s how to set up the conditional formatting:

	 1.	 Select the cells in the range (in this example, A1:G22).

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the Conditional Formatting 
dialog box.

	 3.	 In the Conditional Formatting dialog box, select the option labeled Use a Formula to 
Determine Which Cells to Format.
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	 4.	 For this example, enter this formula (change the range references to correspond to your own 
data):

=COUNTIF($A$1:$G$22,A1)>1

	 5.	 Click the Format button and specify the formatting to apply when the condition is true.

		  Changing the fill color is a good choice.

	 6.	 Click OK.

Figure 60-2 shows the result. The seven highlighted cells are the duplicated values in the range.

Figure 60-2: Conditional formatting causes the duplicated cells to be highlighted.

You can extend this technique to identify entire rows within a list that are identical. The trick is to add 
a new column and use a formula that concatenates the data in each row. For example, if your list is in 
A2:G500, enter this formula in cell H2:

=A2&B2&C2&D2&E2&F2&G2
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Copy the formula down the column and then apply the conditional formatting to the formulas in col-
umn H. In this case, the conditional formatting formula is

=COUNTIF($H$2:$H$500,H2)>1

Highlighted cells in column H indicate duplicated rows.

Note 	

You can use Data➜Data Tools➜Remove Duplicates to remove duplicate rows. That 
command, however, doesn’t identify the duplicates before deleting them.
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Working with Credit Card Numbers
If you’ve ever tried to enter a 16-digit credit card number into a cell, you may have discovered that 
Excel always changes the last digit to a zero. Even worse, maybe you didn’t discover the changed 
credit card number until it was too late.

Why does Excel change your numbers? The reason is that Excel can handle only 15 digits of numeri-
cal accuracy.

Entering credit card numbers manually
If you need to store credit card numbers in a worksheet, you have three options:

➤	 Precede the credit card number with an apostrophe. Excel then interprets the data as a 
text string rather than as a number.

➤	 Preformat the cell or range by using the Text number format. Select the range, choose 
Home➜Number and then select Text from the Number Format drop-down control.

➤	 Enter the card number with dashes or spaces. Embedding a dash character (or any other 
non-numeric character) forces Excel to interpret the entry as text.

This tip, of course, also applies to other long numbers (such as part numbers) that aren’t used in 
numeric calculations.
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Importing credit card numbers
If you’re importing credit card numbers from a CSV text file, Excel will import the credit card numbers 
as values — and erroneously change the last digit to zero. To avoid this, don’t use File➜Open to 
import the text. Rather, use Data➜Connections➜Get External Data➜From Text. When you use this 
command, Excel displays the TextImport Wizard. In Step 3 of the wizard, make sure that you specify 
Text as the column data format for the credit card numbers. See Figure 61-1.

Figure 61-1: Using the TextImport Wizard to ensure that credit card numbers are imported as text.
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Identifying Excess Spaces
A common type of spreadsheet error involves something that you can’t even see: a space character. 
Consider the example shown in Figure 62-1. Cell B2 contains a formula that looks up the color name 
in cell B1 and returns the corresponding code from a table. The formula is

=VLOOKUP(B1,D2:E9,2,FALSE)

Figure 62-1: A simple lookup formula returns the code for a color entered in cell B1.

In Figure 62-2, the formula in cell B2 returns an error — indicating that Red wasn’t found in the table. 
Hundreds of thousands of Excel users have spent far too much time trying to figure out why this sort 
of thing doesn’t work. In this case, the answer is simple: Cell D7 doesn’t contain the word Red. Rather, 
it contains the word Red followed by a space. To Excel, these text strings are completely different.

Figure 62-2: The lookup formula can’t find the word Red in the table.
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If your worksheet contains thousands of text entries — and you need to perform comparisons using 
that text — you may want to identify the cells that contain excess spaces and then fix those cells. The 
term excess spaces means a text entry that contains any of the following: 

➤	 One or more leading spaces

➤	 One or more trailing spaces

➤	 Two or more consecutive spaces within the text

One way to identify this type of cell is to use conditional formatting. To set up conditional formatting 
to identify excess spaces, follow these steps:

	 1.	 Select all text cells to which you want to apply conditional formatting.

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the New Formatting Rule dia-
log box.

	 3.	 In the top part of the dialog box, select the option labeled Use a Formula to Determine 
Which Cells to Format.

	 4.	 Enter a formula like the following in the bottom part of the dialog box (see Figure 62-3):

=A1<>TRIM(A1)

		  Note: This formula assumes that cell A1 is the upper-left cell in the selection. If that’s not the 
case, substitute the address of the upper-left cell in the selection you made in Step 1.

	 5.	 Click the Format button to display the Format Cells dialog box and select the type of format-
ting you want for the cells that contain excess spaces — for example, a yellow fill color.

	 6.	 Click OK to close the Format Cells dialog box, and click OK again to close the New Formatting 
Rule dialog box.

After you complete these steps, each cell that contains excess spaces and is within the range you 
selected in Step 1 is highlighted with the formatting of your choice. You can then easily spot these 
cells and remove the spaces.
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Figure 62-3: Using conditional formatting to identify cells that contain excess spaces.

Note 	

Because of the way the TRIM function works, the formula in Step 4 also applies the con-
ditional formatting to all numeric cells. A slightly more complex formula that doesn’t 
apply the formatting to numeric cells is

=IF(NOT(ISNONTEXT(A1)),A1<>TRIM(A1))
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Transposing a Range
You may have a range of data that should be transposed. Transposing a range is essentially making 
the rows columns, and the columns rows. Figure 63-1 shows an example. The original data is in 
A1:H9, and the transposed data is in A12:I19.

This tip describes two methods to transpose a range of data.

Figure 63-1: Data before and after being transposed.

Using Paste Special
To transpose a range of data by copying and pasting, follow these steps:

	 1.	 Select the range to be transposed.

	 2.	 Press Ctrl+C to copy the range.

	 3.	 Select the cell that will be the upper-left cell for the transposed range.

	 4.	 Choose Home➜Clipboard➜Paste➜Paste Special to display the Paste Special dialog box.

	 5.	 Choose the Transpose option.

	 6.	 Click OK.

Excel pastes the copied data, but reoriented.
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If the original range contains formulas, the formulas will be adjusted so they continue to refer to the 
correct cells.

Note 	

If the original range is in a table (created with Insert➜Tables➜Table), this technique has 
a few caveats. The original selection cannot include the Total Row or columns that con-
tain a formula. You can still paste the transposed data, but you must choose the Values 
option in the Paste Special dialog box. The transposed range will include the values (but 
not the formulas).

Using the TRANSPOSE function
In some cases, you may want the transposed range to be linked to the original range. In such a situa-
tion, changes made to the original range also appear in the transposed range. Here’s how to set up a 
transposed range that’s linked to the original source. Refer to Figure 63-2.

Figure 63-2: A13:J17 contains a multicell array formula, linked to the source range.

	 1.	 Make a note of the number of rows and columns in the source range.

		  In this example, the source range (A1:E10) has 10 rows and 5 columns.

	 2.	 Select a range of blank cells that has the same number of rows as source range columns, and 
the same number of column as source range rows.

		  In this example, the selection should be 5 rows and 10 columns. For example, you can put 
the transposed range in A13:J17.
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	 3.	 Type a formula that uses the TRANSPOSE function, with the source range address as its argu-
ment.

		  In this example, the formula is

=TRANSPOSE(A1:E10)

	 4.	 Press Ctrl+Shift+Enter (not just Enter) to create a multicell array formula in all of the selected 
cells.

Any changes made in the source range also appear in the transposed range.
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Using Flash Fill to Extract Data
When you import data, it’s often necessary to clean up some of the text. For example, names may 
appear in uppercase that they should be in proper case. One approach is to use formulas to modify 
the text (see Tip 57). Another approach uses a feature introduced in Excel 2013: Flash Fill.

Flash Fill uses pattern recognition to extract data (and also concatenate data) from adjoining col-
umns. Just enter a few examples in a column that’s adjacent to the data, and then choose Data➜Data 
Tools➜Flash Fill (or press Ctrl+E). Excel analyzes the examples you typed and attempts to fill in the 
remaining cells. If Excel didn’t recognize the pattern you had in mind, press Ctrl+Z, add another 
example or two, and try again.

Changing the case of text
Figure 64-1 shows a list of U.S. presidents in column A. Column B shows the result of using Flash Fill 
to convert the text to proper case.

Start by providing a few examples: Type George Washington in cell B1 and John Adams in cell B2. 
You’ll notice that Excel kicks in as soon as you start typing John Adams. It recognizes your pattern 
(which is “make all text proper case”) and fills the column with the transformed text (in a light gray 
color). You can press Enter to keep Excel’s suggestion, or continue typing more examples. At any 
time, you can press Ctrl+E to have Excel fill the column.

Figure 64-1: Flash Fill quickly converted the names in Column A to proper case.
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Extracting last names
In this example, we want to extract the last name of each president, so the list can be sorted by last 
name. This is a simple job for Flash Fill. It takes only two examples, and the pattern is recognized.

Figure 64-2 shows the worksheet after Excel extracted the last names. Now, you can sort the list by 
column C, so the name will be in alphabetical order, by last name.

Figure 64-2: Flash Fill extracted the last names.

Extracting first names
You’ll find that Flash Fill is equally adept at extracting first names. Figure 64-3 shows the list of presi-
dents after using Flash Fill to extract the first names in Column D. Again, it took only two examples 
before Excel identified the pattern.

Figure 64-3: Flash Fill extracted the first names.
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Extracting middle names
Some (but not all) of the presidents on the list have a middle name. Can Flash Fill extract the middle 
names?

The answer: Sort of. I provided several examples of middle names, and Flash Fill successfully 
extracted the other middle names. But for names without a middle name, it extracted the first name. 
No matter what I tried, I could not get Flash Fill to ignore names that had no middle name.

Extracting domain names from URLs
Here’s another example of using Flash Fill. Say you have a list of URLs and need to extract the file-
name (the text that follows the last slash character).

Figure 64-4 shows a list of URLs. Flash Fill required just one example of a filename entered in column 
B. I pressed Ctrl+E, and Excel filled in the remaining rows. Flash fill worked equally well removing the 
filename from the URL, in column C.

Figure 64-4: Flash Fill extracted the filenames from URLs.

Potential problems
Flash Fill is a great feature, but if you use it for important data, you should be aware of some poten-
tial problems:

➤	 Sometimes it just doesn’t work. Extracting middle names seems like a simple pattern, but 
Flash Fill was not capable of recognizing the pattern.

➤	 It’s not always accurate. With a small set of data, it’s usually easy to check to ensure that 
Flash Fill worked as you intended it to work. But if you use Flash Fill on thousands of rows of 
data, you can’t be assured that it worked perfectly unless you examine every row. Flash Fill 
works best with data that is very consistent.

➤	 It’s not dynamic. If you change any of the information that Flash Fill used, the changes are 
not reflected in the filled column.

➤	 There is no “audit trail.” If you use formulas to extract data, the formulas provide documen-
tation so anyone can figure out how the data was extracted. Using Flash Fill, on the other 
hand, provides no such audit trail. There is no way to see which rules Excel used to extract 
the data.
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Using Flash Fill to Combine Data
Tip 64 described how to extract data using the Excel 2013 Flash Fill feature. This tip looks at the other 
side of Flash Fill: combing data.

If you need to combine the data in two or more columns, you can write a formula that uses the con-
catenation operator (&). For example, this formula combines the contents of cells A1, B1, and C1:

=A1&B1&C1

For more complicated types of combinations, Flash Fill might be able to do the job and save you the 
trouble of creating (and debugging) a formula.

Figure 65-1 shows a worksheet with first names in column A and last names in column B. I used Flash 
Fill to create e-mail addresses (in Column C) for the domain example.com. The e-mail addresses con-
sist of the first initial, an underscore, and the last name — all lowercase.

Figure 65-1: Flash Fill can quickly convert these names into e-mail addresses.

It took only two examples before Flash Fill recognized the pattern and filled in the rest of the column.

Flash Fill is simpler than composing this equivalent formula:

=LOWER(LEFT(A1,1)&”_”&B1&”@example.com”)
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Figure 65-2 shows another example. Column A:D hold the original data, and the text in column E was 
filled in using Flash Fill, after providing two examples. The equivalent formula to generate the text in 
column E is

=A4&” “&B4&”: “&TEXT(D4,”$0”)&” due on 10/”&C4&”/2013”

Figure 65-2: Flash Fill generated the text in column E.
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Inserting Stock Information
This tip describes how to insert refreshable stock data into a worksheet. For some reason, Microsoft 
makes this feature rather difficult to find.

Here’s how to do it:

	 1.	 Make sure that you’re connected to the Internet.

	 2.	 Type a stock symbol into a cell — for example, MSFT for Microsoft. Make sure the characters 
are all uppercase.

	 3.	 Right-click the cell and choose Addition Cell Actions➜Insert Refreshable Stock Price from the 
shortcut menu.

		  The Insert Stock Price dialog box appears.

	 4.	 Specify the location for the information (on a new sheet, or starting at a particular cell).

	 5.	 Click OK.

Excel retrieves current information about the stock and inserts data that occupies 18 rows and 16 col-
umns (see Figure 66-1).

Figure 66-1: Refreshable stock information inserted into a worksheet.

You can refresh the information at any time. Select any cell in the table, right-click, and choose 
Refresh from the shortcut menu. If your worksheet has information for multiple stocks, you can 
refresh them all by choosing Data➜Connections➜Refresh All.
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Hiding irrelevant rows and columns
Notice that, of the 18 rows, only one of them contains actual data. The other rows are links and dis-
claimers. Unfortunately, there is no direct way to retrieve the information without all of the extrane-
ous information. But you can hide the irrelevant rows and columns — and the hidden rows and 
columns remain hidden when you refresh the information.

Figure 66-2 shows a worksheet that has information for four stocks. I hid the irrelevant rows and col-
umns, for a concise display.

Figure 66-2: Information for four stocks, after hiding irrelevant rows and columns.

Behind the scenes
Using the Addition Cell Actions➜Insert Refreshable Stock Price shortcut menu item is just a quick 
way of performing a web query and retrieving data from Microsoft’s MSN Money site. You can 
retrieve the same information by performing a web query. Choose Data➜Get External Data➜From 
Web and use this URL:

http://moneycentral.msn.com/investor/external/excel/quotes.asp?symbol=MSFT

The URL retrieves information for Microsoft. You can replace MSFT with a different stock symbol. 
Figure 66-3 shows the New Web Query dialog box before the information is inserted into a worksheet.
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Figure 66-3: Using the New Web Query dialog box to retrieve stock information.

Cross-Ref	
See Tip 67 for more information about web queries.
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Getting Data from a Web Page
This tip describes three ways to capture data contained on a web page:

➤	 Paste a static copy of the information.

➤	 Create a refreshable link to the site.

➤	 Open the page directly in Excel.

Pasting static information
One way to get data from a web page into a worksheet is to simply highlight the text in your 
browser, press Ctrl+C to copy it to the Clipboard, and then paste it into a worksheet. The results will 
vary, depending on what browser you use and how the web page is coded.

If pasting doesn’t yield the results you want, choose Home➜Clipboard➜Paste➜Paste Special and 
then try various paste options.

Figure 67-1 shows some currency exchange rates, pasted from a web page at msn.com. As you can 
see, even the hyperlinks are pasted.

Figure 67-1: A table of exchange rates copied from a website and pasted to a worksheet.
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Pasting refreshable information
If you need to regularly access updated data from a web page, create a web query. Figure 67-1 shows 
a website that contains currency exchange rates in a three-column table.

Note 	

The term web query is a bit misleading because this operation is not limited to the web. 
You can perform a web query on a local HTML file, a file stored on a network server, or a 
file stored on a web server on the Internet. To retrieve information from a web server, 
you must be connected to the Internet. After the information is retrieved, an Internet 
connection is not required to work with the information (unless you need to refresh the 
query).

These steps create a web query that allows this information to be retrieved and then refreshed at any 
time with a single mouse click:

	 1.	 Choose Data➜Get External Data➜From Web to display the New Web Query dialog box.

	 2.	 In the Address field, enter the URL of the website and click Go.

		  For this example, the URL for the web page shown in Figure 67-2 is

http://investing.money.msn.com/investments/exchange-rates

		  Notice that the New Web Query dialog box contains a web browser (Internet Explorer). You 
can click links and navigate the website until you locate the data you’re interested in.

		  When a web page is displayed in the New Web Query dialog box, you see one or more yel-
low boxes with an arrow, which correspond to tables defined in the web page — plus 
another yellow box that will retrieve the entire page.

	 3.	 Click a yellow box, and it turns into a green check box, which indicates that the data in that 
table will be imported.

		  Unfortunately, the table in the example is not selectable, so the only choice is to retrieve the 
entire page.

	 4.	 Click the Import button to display the Import Data dialog box.

	 5.	 In the Import Data dialog box, specify the location for the imported data.

		  It can be a cell in an existing worksheet or a new worksheet.

	 6.	 Click OK, and Excel imports the data.
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Figure 67-2: Using the New Web Query dialog box to specify the data to be imported.

Part of the results is shown in Figure 67-3. Although I was interested only in the 17-row and 3-column 
currency table, this web query retrieved 145 rows of mostly irrelevant information.

By default, the imported data is a web query. To refresh the information, right-click any cell in the 
imported range and choose Refresh from the shortcut menu.

If you don’t want to create a refreshable query, specify this choice in Step 5 of the preceding step list. 
In the Import Data dialog box, click the Properties button and deselect the Save Query Definition 
check box.

Note 	

Excel’s Web query feature works by identifying tables (specified using the HTML 
<TABLE> tag) in the document. Increasingly, website designers use cascading style 
sheets (CSS) to display tabular information. As demonstrated in this example, Excel 
doesn’t recognize these as tables and, therefore, doesn’t display a yellow arrow so you 
can retrieve only the table. Therefore, you may have to retrieve the entire document 
and then delete (or hide) everything except the table that you want.
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Figure 67-3: Information retrieved from a web query.

Opening the web page directly
Another way to get web page data into a worksheet is to open the URL directly, by using Excel’s 
File➜Open command. Just enter the complete URL into the File Name field and click Open. 

The results will vary, depending on how the web page is laid out. Most of the time, you’ll get satisfac-
tory results. In some cases, you’ll retrieve quite a bit of extraneous information. Also, note that the 
information is not refreshable. If the data on the web page changes, you’ll need to close the work-
book and use the File➜Open command again.
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Importing a Text File into a Worksheet 
Range
If you need to insert a text file into a specific range in a worksheet, you may think that your only choice 
is to import the text into a new workbook (by choosing Office➜Open) and then to copy the data and 
paste it to the range where you want it to appear. However, you can do it in a more direct way.

Figure 68-1 shows a small CSV (comma separated value) file. The following instructions describe how 
to import this file, named monthly.csv, beginning at cell C3.

Figure 68-1: This CSV file will be imported into a range.

	 1.	 Choose Data➜Get External Data➜From Text to display the Import Text File dialog box.

	 2.	 Navigate to the folder that contains the text file.

	 3.	 Select the file from the list and then click the Import button to display the Text Import 
Wizard.

	 4.	 Use the Text Import Wizard to specify how the data will be imported.

		  For a CSV file, specify Delimited, with a Comma Delimiter.

	 5.	 Click the Finish button.

		  The Import Data dialog box appears.

	 6.	 Click the Properties button, and the External Data Range Properties dialog box appears.

	 7.	 Deselect the Save Query Definition check box and click OK to return to the Import Data dia-
log box.
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	 8.	 Here, specify the location for the imported data.

		  It can be a cell in an existing worksheet or a new worksheet.

	 9.	 Click OK, and Excel imports the data (see Figure 68-2).

Note 	

You can ignore Step 7 if the data you’re importing will be changing. By saving the query 
definition, you can quickly update the imported data by right-clicking any cell in the 
range and choosing Refresh.

Figure 68-2: This range contains data imported directly from a CSV file.
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Using the Quick Analysis Feature
One of the new features in Excel 2013 is Quick Analysis. When you select a range of data, Excel dis-
plays a Quick Analysis button in the lower-right corner of the range. Click the button to view some 
options, shown in Figure 69-1. You can also press Ctrl+Q on the keyboard to display the Quick 
Analysis options.

Figure 69-1: Quick Analysis options for the selected range.

The words along the top (Formatting, Charts, Totals, Tables, and Sparklines) are menu items. Click an 
item and a different set of icons appears. When you hover your mouse over an icon, Excel sometimes 
displays a preview of how the option will appear.

The options available depend on the type of data in the selected range. For example, if the range 
contains only text, the Sparklines option will not be available.

Figure 69-2 shows an example of a range of numbers in column C, with a preview of the Quick 
Analysis option to create running totals in column D.
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Figure 69-2: A preview of Quick Analysis running totals.

Figure 69-3 shows another example. The range A2:G7 is selected, and Quick Analysis is previewing 
the Line Sparklines option in column H.

Figure 69-3: A preview of Quick Analysis Sparklines.

Note 	

The Quick Analysis options don’t enable you to do anything that you can’t do using 
Excel’s normal commands. But sometimes it can you save a bit of time. If you find the 
Quick Analysis button annoying, turn if off in the General tab of the Excel Options dialog 
box. Deselect the check box labeled Show Quick Analysis Options on Selection.
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Filling the Gaps in a Report
When you import data, you can sometimes end up with a worksheet that looks something like the 
one shown in Figure 70-1. This type of report formatting is common. As you can see, an entry in col-
umn A applies to several rows of data. If you sort this type of list, the missing data messes things up, 
and you can no longer tell who sold what when.

Figure 70-1: This report contains gaps in the Sales Rep column.

If your list is small, you can enter the missing cell values manually or by using a series of Home➜ 

Editing➜Fill➜Down commands (or its Ctrl+D shortcut). But if you have a large list that’s in this for-
mat, you need a better way of filling in those cell values. Here’s how:

	 1.	 Select the range that has the gaps (A3:A14, in this example).

	 2.	 Choose Home➜Editing➜Find & Select➜Go To Special.

		  The Go To Special dialog box appears.

	 3.	 Select the Blanks option and click OK.

		  This action selects the blank cells in the original selection.

	 4.	 On the Formula bar, type an equal sign (=) followed by the address of the first cell with an 
entry in the column (=A3, in this example) and press Ctrl+Enter.

	 5.	 Reselect the original range and press Ctrl+C to copy the selection.

	 6.	 Choose Home➜Clipboard➜Paste➜Paste Values to convert the formulas to values.
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After you complete these steps, the gaps are filled in with the correct information, and your work-
sheet looks similar to the one shown in Figure 70-2. Now it’s a normal list, and you can do whatever 
you like with it — including sorting.

Figure 70-2: The gaps are gone, and this list can now be sorted.
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Performing Inexact Searches
If you have a large worksheet with lots of data, locating what you’re looking for can be difficult. The 
Excel Find and Replace dialog box is a useful tool for locating information, and it has a few features 
that many users overlook.

Access the Find and Replace dialog box by choosing Home➜Editing➜Find & Select➜Find (or by 
pressing Ctrl+F). If you’re replacing information, you can use Home➜Editing➜Find & Select➜Replace 
(or Ctrl+H). The only difference is which of the two tabs is displayed in the dialog box. Figure 71-1 
shows the Find and Replace dialog box after clicking the Options button, which expands the dialog 
box to show additional options.

Figure 71-1: The Find and Replace dialog box with the Find tab selected.

In many cases, you want to locate “approximate” text. For example, you may be trying to find data for 
a customer named Stephen R. Rosencrantz. You can, of course, search for the exact text: Stephen R. 
Rosencrantz. However, there’s a reasonably good chance that the search will fail. The name may have 
been entered differently, as Steve Rosencrantz or S.R. Rosencrantz, for example. It may have even 
been misspelled as Rosentcrantz.

The most efficient search for this name is to use a wildcard character and search for st*rosen* and 
then click the Find All button. In addition to reducing the amount of text that you enter, this search is 
practically guaranteed to locate the customer, if the record is in your worksheet. The search may also 
find some records that you aren’t looking for, but that’s better than not finding anything.

The Find and Replace dialog box supports two wildcard characters:

➤	 ? matches any single character.

➤	 * matches any number of characters.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 71: Performing Inexact Searches 195

Wildcard characters also work with values. For example, searching for 3* locates all cells that contain 
an entry that begins with 3. Searching for 1?9 locates all three-digit entries that begin with 1 and end 
with 9.

Note 	

To search for a question mark or an asterisk, precede the character with a tilde character 
(~). For example, the following search string finds the text *NONE*:

~*NONE~*

If you need to search for the tilde character, use two tildes.

If your searches don’t seem to be working correctly, double-check these three options (which some-
times have a way of changing on their own):

➤	 Match Case: If this check box is selected, the case of the text must match exactly. For exam-
ple, searching for smith does not locate Smith.

➤	 Match Entire Cell Contents: If this check box is selected, a match occurs if the cell contains 
only the search string (and nothing else). For example, searching for Excel doesn’t locate a 
cell that contains Microsoft Excel.

➤	 Look In: This drop-down list has three options: Values, Formulas, and Comments. If, for 
example, Values is selected, searching for 900 doesn’t find a cell that contains 900 if that 
value is generated by a formula.

Remember that searching operates on the selected range of cells. If you want to search the entire 
worksheet, select only one cell before you begin your search.

Also, remember that searches do not include numeric formatting. For example, if you have a value 
that uses currency formatting so that it appears as $54.00, searching for $5* doesn’t locate that value.

Working with dates can be a bit tricky because Excel offers many ways to format dates. If you search 
for a date by using the default date format, Excel locates the dates even if they’re formatted differ-
ently. For example, if your system uses the m/d/y date format, the search string 10/*/2013 finds all 
dates in October 2013, regardless of how the dates are formatted.

You can also use an empty Replace With field. For example, to quickly delete all asterisks from your 
worksheet, enter ~* in the Find What field and leave the Replace With field blank. When you click the 
Replace All button, Excel finds all the asterisks and replaces them with nothing.
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Proofing Your Data with Audio
Excel 2002 introduced a handy feature: text-to-speech. In other words, Excel is capable of speaking to 
you. You can have this feature read back a specific range of cells, or you can set it up so that it reads 
the data as you enter it.

For some reason, this feature appears to be missing in action, beginning with Excel 2007. You can 
search the Ribbon all day and not find a trace of the text-to-speech feature. But the feature is still 
available — you just need to spend a few minutes to make it accessible.

Adding speech commands to the Ribbon
Following are instructions to add these commands to a new group in the Review tab of the Ribbon:

	 1.	 Right-click the Ribbon and then choose Customize the Ribbon from the shortcut menu.

		  The Customize Ribbon tab of the Excel Options dialog box appears.

	 2.	 In the list box on the right, select Review and click New Group.

	 3.	 Click Rename and overwrite the default name with a more descriptive name, such as Text To 
Speech.

	 4.	 Click the drop-down list on the left and choose Commands Not in the Ribbon.

	 5.	 Scroll down the list, and you find five items that begin with the word Speak; select each one 
and then click Add.

		  They’re added to the newly created group (see Figure 72-1).

	 6.	 Click OK to close the Excel Options dialog box.

After you perform these steps, the Review tab displays a new group with five new icons (see  
Figure 72-2).

Using the speech commands
To read a range of cells, select the range first and then click the Speak Cells button. You can also 
specify the orientation (By Rows or By Columns). To read the data as it’s entered, click the Speak On 
Enter button.
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Some people (myself included) find the voice in this “love it or hate it” feature much too annoying to 
use for any extended period. And, if you enter the data at a relatively rapid clip, the voice simply can-
not keep up with you.

You have a small bit of control over the voice used in the Excel Text To Speech feature. To adjust the 
voice, open the Windows Control Panel and display the Text to Speech tab of the Speech Properties 
dialog box. You can adjust the speed and select a different voice (if other voices are installed). Click 
the Preview Voice button to help make your choices.

Figure 72-1: Adding the speech commands to the Ribbon.

Figure 72-2: Speech commands added to the Ribbon.
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Getting Data from a PDF File
A PDF file is a document format that displays text or graphics in a way that’s independent of the 
hardware and operating system used to create the document. PDF files are very common, and just 
about everyone has software that can read PDF files.

Excel can export a worksheet (or workbook) as a PDF file, but it cannot open PDF files. This tip 
describes two ways to get data from a PDF file into an Excel worksheet.

Using copy and paste
Figure 73-1 shows a PDF file displayed in Adobe Reader. I selected the table of data and pressed 
Ctrl+C to copy it to the Clipboard. Then I activated Excel and pressed Ctrl+V to copy the Clipboard 
contents. The result is shown in Figure 73-2.

Figure 73-1: Data in a PDF file that needs to be transferred to a worksheet.
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Figure 73-2: Using copy and paste doesn’t work very well.

The data is copied, but it’s all in a single column. I could spend some time and rearrange the data, but 
there’s a more efficient way to transfer the PDF file data to Excel.

Note 	

When coping from a PDF file and pasting to a worksheet, the actual results will vary, 
depending on the layout of the PDF file. In some cases, the pasted text is usable. But in 
most cases, it’s not.
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Using Word 2013 as an intermediary
Excel can’t open PDF files, but Word 2013 can. Figure 73-3 shows a Word document after importing 
the PDF file. The information can be copied and pasted to an Excel worksheet — and the result will 
require minimal reformatting (see Figure 73-4).

After making a few minor edits, the table looks perfect.

Figure 73-3: A PDF file, imported into World 2013.
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Figure 73-4: A Word 2013 document pasted into an Excel worksheet.

Note 	

The ability to open PDF files is new to Word 2013, so this method won’t work with other 
previous versions of Word.
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PART V
Tables and  
Pivot Tables
This part contains tips that deal with two of Excel’s most useful features: tables and 
pivot tables. If you work with large amounts of structured data, you owe it to 
yourself to understand these features. 
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Understanding Tables
An important but often underutilized feature in Excel is tables. This tip describes when to use a table 
and also lists the advantages and disadvantages.

Understanding what a table is
A table is a rectangular range of structured data. Each row in the table corresponds to a single entity. 
For example, a row can contain information about a customer, a bank transaction, an employee, or a 
product. Each column contains a specific piece of information. For example, if each row contains 
information about an employee, the columns can contain data, such as name, employee number, 
hire date, salary, or department. Tables have a header row at the top that describes the information 
contained in each column.

You’ve probably created ranges that meet this description. The magic happens when you tell Excel 
to convert a range of data into an “official” table. You do so by selecting any cell within the range and 
then choosing Insert➜Tables➜Table.

When you explicitly identify a range as a table, Excel can respond more intelligently to the actions 
you perform with that range. For example, if you create a chart from a table, the chart expands auto-
matically as you add new rows to the table. If you create a pivot table from a table, refreshing the 
pivot table will include any new data that you added to the table.

Figure 74-1 shows a range before it was converted to a table, and Figure 74-2 shows the range after it 
was converted to a table.
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Figure 74-1: A range of data that’s not an official table.

Figure 74-2: A range of data that has been designated a table.

Range versus table
What’s the difference between a standard range and a range that has been converted to a table?
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➤	 Activating any cell in the table gives you access to a new Table Tools context tab on the 
Ribbon.

➤	 You can quickly apply background color and text color formatting by choosing from a gal-
lery. This type of formatting is optional.

➤	 Each column header contains a filter button that, when clicked, lets you easily sort the rows 
or filter the data by hiding rows that don’t meet your criteria.

➤	 A table can have “slicers,” which makes it easy for novices to quickly apply filters to a table.

➤	 If you scroll down the sheet so that the header row disappears, the table headers replace the 
column letters in the worksheet header. In other words, you don’t need to freeze the top row 
to keep the column labels visible.

➤	 If you create a chart from data in a table, the chart automatically expands if you add new 
rows to the end of the table.

➤	 If you create a name for a column in a table, the “refers to” range for the name adjusts as you 
add new rows to the table.

➤	 Tables support calculated columns. A single formula entered in a cell is automatically propa-
gated to all cells in the column (see Tip 75).

➤	 Tables support structured references in formulas outside of the table. Rather than use cell 
references, formulas can use table names and column headers.

➤	 When you move your mouse pointer to the lower-right corner of the lower-right cell, you can 
click and drag to extend the table’s size, either horizontally (add more columns) or vertically 
(add more rows).

➤	 Selecting rows and columns within the table is simplified.

Limitations of using a table
If a workbook contains at least one table, a few Excel features are not available:

➤	 For some reason, when a workbook contains at least one table, Excel doesn’t allow you to 
use the Custom Views feature (choose View➜Workbook Views➜Custom Views).

➤	 You cannot share a workbook (using Review➜Changes➜Share) if the workbook contains a 
table.

➤	 You can’t insert automatic subtotals within a table (by choosing Data➜Outline➜Subtotal).

➤	 You cannot use array formulas within a table.
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Using Formulas with a Table
This tip describes some ways to use formulas with a table. The example uses a simple sales summary 
table with three columns: Month, Projected, and Actual, as shown in Figure 75-1. I entered the data 
and then converted the range to a table by using the Insert➜Tables➜Table command. Note that I 
didn’t define any names, but the data area of the table is named Table1 by default.

Figure 75-1: A simple table with three columns.

Working with the Total row
If you want to calculate the total projected and total actual sales, you don’t even need to write a for-
mula. Just click a button to add a row of summary formulas to the table:

	 1.	 Activate any cell in the table.

	 2.	 Select the Table Tools➜Design➜Table Style Options➜Total Row command and check the 
Total Row check box.

	 3.	 Activate a cell in the Total row and select a summary formula from the drop-down list (see 
Figure 75-2).

		  For example, to calculate the sum of the Actual column, select SUM from the drop-down list 
in cell D15. Excel creates this formula:

=SUBTOTAL(109,[Actual])

For the SUBTOTAL function, 109 is an enumerated argument that represents SUM. The second argu-
ment for the SUBTOTAL function is the column name, in square brackets. Using the column name 
within brackets is a way to create structured references within a table.
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Figure 75-2: A drop-down list enables you to select a summary formula for a table column.

Note 	

You can toggle the Total row display on and off by choosing Table Tools➜Design➜ 

Table Style Options➜Total Row. If you turn it off, the summary options you selected are 
remembered when you turn it back on.

Using formulas within a table
In many cases, you want to use formulas within a table. For example, in the table shown in Figure 
75-1, you may want a column that shows the difference between the actual and projected amounts 
for each month. As you can see, Excel makes this process very easy:

	 1.	 Activate cell E2 and type Difference for the column header.

		  Excel automatically expands the table for you.

	 2.	 Move to cell E3 and type an equal sign (=) to signal the beginning of a formula.

	 3.	 Press the left-arrow key to point to the corresponding value in the Actual column.

	 4.	 Type a minus sign (–) and then press the left-arrow key twice to point to the corresponding 
value in the Projected column.
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	 5.	 Press Enter to end the formula.

		  The formula is entered into the other cells in the column, and the Formula bar displays this 
formula:

=[@Actual]-[@Projected]

Figure 75-3 shows the table with the new column.

Figure 75-3: The Difference column contains a formula.

Although the formula was entered into the first row of the table, that’s not necessary. Anytime a for-
mula is entered into an empty table column, it propagates to the other cells in the column. If you 
need to edit the formula, edit any formula in the column, and the change is applied to the other cells 
in the column.

Note 	

Propagating a formula to other cells in a table column is actually one of Excel’s 
AutoCorrect options. To turn off this feature, click the icon that appears when you enter 
a formula and choose Stop Automatically Creating Calculated Columns.

The preceding set of steps uses the column names to create the formula. Alternatively, you can enter 
the formula by using standard cell references. For example, you can enter the following formula in 
cell E3:

=D3-C3

If you type the cell references, Excel still automatically copies the formula to other cells in the column.
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Referencing data in a table
Formulas that are outside of a table can refer to data within a table by using the table name and col-
umn headers. You don’t need to create names for these items. The table itself has a name (for exam-
ple, Table1), and you can refer to data within the table by using column headers.

You can, of course, use standard cell references to refer to data in a table, but using table references 
has a distinct advantage: The names adjust automatically if the table size changes by adding or delet-
ing rows.

Refer to the table shown earlier in Figure 75-1. This table was given the name Table1 when it was cre-
ated. To calculate the sum of all data in the table, use this formula:

=SUM(Table1)

This formula always returns the sum of all the data, even if rows or columns are added or deleted. 
And, if you change the name of Table1, Excel automatically adjusts formulas that refer to that table. 
For example, if you rename Table1 as AnnualData (by using the Name Manager), the preceding for-
mula changes to

=SUM(AnnualData)

Most of the time, you want to refer to a specific column in the table. The following formula returns 
the sum of the data in the Actual column (but ignores the total row):

=SUM(Table1[Actual])

Notice that the column name is enclosed in square brackets. Again, the formula adjusts automatically 
if you change the text in the column heading.

Even better, Excel provides some helpful assistance when you create a formula that refers to data 
within a table. Figure 75-4 shows the Formula AutoComplete feature helping to create a formula by 
showing a list of the elements in the table.

Figure 75-4: The Formula AutoComplete feature is useful when creating a formula that refers to data in a table.
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Numbering Table Rows Automatically
In some situations, you may want a table to include sequential row numbers. This tip describes how 
to take advantage of the calculated column feature (explained in Tip 75) and create a formula that 
numbers table rows automatically.

Figure 76-1 shows a table (named Table1) with information about job applicants. The first column of 
the table, labeled Num, displays sequential numbers.

Figure 76-1: The numbers in column B are generated with a formula.

The calculated column formula, which you can enter into any cell in the Num column, is

=ROW()-ROW(Table1)+1

When you enter the formula, it’s automatically propagated to all other cells in the Num column.

The ROW function, when used without an argument, returns the row that contains the formula. 
When the ROW function has an argument that consists of a multirow range, it returns the first row of 
the range.

Note 	

A table’s name does not include the header row of the table. So, in this example, the first 
row of Table1 is row 5.

The numbers are table row numbers, not numbers that correspond to a particular row of data. For 
example, if you sort the table, the numbers will remain consecutive — and they will no longer be 
associated with the same row of data.
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If you filter the table, rows that don’t meet the filter criteria will be hidden. In such a case, some table 
row numbers will not be visible. Figure 76-2 shows the table after filtering to display only the Clerk 
positions.

Figure 76-2: When the table is filtered, the row numbers are no longer consecutive.

If you want the table row numbers to remain consecutive when the table is filtered, a different for-
mula is required. Referring to the example in Figure 76-1, enter this formula in cell B5, and it will be 
propagated to the other rows:

=SUBTOTAL(3,C$5:C5)

This formula uses the SUBTOTAL function, with a first argument of 3 (which corresponds to COUNTA). 
The SUBTOTAL function ignores hidden rows, so only visible rows are counted. Notice that the for-
mula refers to a different column — which is necessary to avoid a circular reference error.

Figure 76-3 shows the filtered table using the SUBTOTAL formula in column B.

Figure 76-3: When the table is filtered, the row numbers remain consecutive.
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Identifying Data Appropriate for a Pivot 
Table
A pivot table requires that your data is in the form of a rectangular database table. You can store the 
database in either a worksheet range (which can be a table or just a normal range) or an external data-
base file. And although Excel can generate a pivot table from any database, not all databases benefit.

Figure 77-1 shows part of a simple database table that has five columns and 3,144 rows (one row for 
each county). This data is appropriate for a pivot table. For example, a pivot table can instantly calcu-
late the total population by state or by region and display the values in a nicely formatted table.

Figure 77-1: This data is appropriate for a pivot table.

Generally speaking, fields in a database table consist of two types of information:

➤	 Data: Contains a value or data to be summarized. For this example, the 1990 Population and 
the 2000 Population fields are data fields.

➤	 Category: Describes the data. For this example, the Country, State, and Region fields are cat-
egory fields because they describe the two data fields.

The data versus category distinction can be blurry at times. Often a pivot table will display counts of 
items within a category. In such a case, a category is serving as a data field.

Note 	

A database table that’s appropriate for a pivot table is said to be normalized. In other 
words, each row contains information that describes the data in the row.
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A single database table can have any number of data fields and category fields. When you create a 
pivot table, you usually want to summarize one or more of the data fields. Conversely, the values in 
the category fields appear in the pivot table as rows, columns, or filters.

Figure 77-2 shows a pivot table created from the example. This pivot table displays the 2000 
Population values, totaled by state.

Figure 77-2: A pivot table created from the data.

Figure 77-3 shows an example of an Excel range that is not appropriate for a pivot table. Although 
the range contains descriptive information about each value, it does not consist of normalized data, 
and you cannot create a useful pivot table from it. In fact, this range actually resembles a pivot table 
summary, but it’s much less flexible.

Figure 77-3: This range is not appropriate for a pivot table.
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Figure 77-4 shows the same data, but normalized. This range contains 78 rows of data — one for 
each of the six monthly sales values for the 13 states. Notice that each row contains category infor-
mation for the sales value. This table is an ideal candidate for a pivot table and contains all informa-
tion necessary to summarize the information by region or quarter.

Figure 77-5 shows a pivot table created from the normalized data. As you can see, it’s virtually identi-
cal to the non-normalized data shown in Figure 77-3. Working with normalized data provides ulti-
mate flexibility in designing reports.

Figure 77-4: This range contains normalized data and is appropriate for a pivot table.
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Figure 77-5: A pivot table created from normalized data.
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Using a Pivot Table Instead of Formulas
The Excel PivotTable feature is incredibly powerful, and you can often create pivot tables in lieu of 
creating formulas. This tip describes a specific problem and provides three different solutions.

Figure 78-1 shows a range of data that contains student test scores. The goal is to calculate the aver-
age score for all students plus the average score for each gender.

Figure 78-1: What’s the best way to calculate the average test score for males versus females?

Inserting subtotals
The first solution involves automatically inserting subtotals. To use this method, the data must be 
sorted by the column that will trigger the subtotaling. In this case, you need to sort by the Gender 
column. Follow these steps:

	 1.	 Select any cell in column C.

	 2.	 Right-click and choose Sort➜Sort A to Z from the shortcut menu.

	 3.	 Choose Data➜Outline➜Subtotal.

		  The Subtotal dialog box appears.
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	 4.	 Specify At Each Change in Gender, Use Function Average, and Add Subtotal to Score.

The result of adding subtotals is shown in Figure 78-2. Notice that Excel also creates an outline, so 
you can hide the details and view just the summary.

The formulas inserted by Excel use the SUBTOTAL function, with 1 as the first argument (1 represents 
average). Here are the formulas:

=SUBTOTAL(1,B2:B13)
=SUBTOTAL(1,B15:B28)
=SUBTOTAL(1,B2:B28)

The formula in cell B30 calculates the Grand Average and uses a range that includes the other  
two SUBTOTAL formulas in cells B14 and B29. The SUBTOTAL function ignores cells that contain 
other SUBTOTAL formulas.

Figure 78-2: Excel adds subtotals automatically.
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Using formulas
Another method of creating averages is to use formulas. The formula to calculate the average of all 
students is simple:

=AVERAGE(B2:B27)

To calculate the average of the genders, you can use the AVERAGEIF function and create these  
formulas:

=AVERAGEIF(C2:C27,”Female”,B2:B27)
=AVERAGEIF(C2:C27,”Male”,B2:B27)

Using Excel’s PivotTable feature
A third method of averaging the scores is to create a pivot table. Many users avoid creating pivot 
tables because they consider this feature too complicated. As you can see, it’s simple to use:

	 1.	 Select any cell in the data range and choose Insert➜Tables➜PivotTable.

		  The Create PivotTable dialog box appears.

	 2.	 Verify that Excel selected the correct data range and specify a cell on the existing worksheet 
as the location.

		  Cell E1 is a good choice.

	 3.	 Click OK.

		  Excel displays the PivotTable Fields task pane.

	 4.	 Drag the Gender item to the Rows section, at the bottom.

	 5.	 Drag the Score item to the Values section.

		  Excel creates the pivot table but calculates the sum of the scores rather than the average.

	 6.	 To change the summary function that’s used, right-click any of the values in the pivot table 
and choose Summarize Data By➜Average from the shortcut menu.

Figure 78-3 shows the pivot table and the PivotTable Fields task pane.
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Figure 78-3: This pivot table calculates the averages without using formulas.

Note 	

Unlike a formula-based solution, a pivot table doesn’t update itself automatically if the 
data changes. If the data changes, you must refresh the pivot table. Just right-click any 
cell in the pivot table and choose Refresh from the shortcut menu.

The pivot table in this example is extremely simple, but it’s also very easy to create. Pivot tables can 
be much more complex, and they can summarize massive amounts of data in just about any way you 
can think of — without using any formulas.
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Controlling References to Cells Within a 
Pivot Table
In some cases, you may want to create a formula that references one or more cells within a pivot 
table. Figure 79–1 shows a simple pivot table that displays income and expense information for three 
years. In this pivot table, the Month field is hidden, so the pivot table shows the year totals.

Figure 79-1: The formulas in column F reference cells in the pivot table.

Column F contains formulas, and this column is not part of the pivot table. These formulas calculate 
the expense-to-income ratio for each year. I created these formulas by pointing to the cells. You may 
expect to see this formula in cell F3:

=D3/C3

In fact, the formula in cell F3 is

=GETPIVOTDATA(“Sum of Expenses”,$B$2,”Year”,2010)
/GETPIVOTDATA(“Sum of Income”,$B$2,”Year”,2010)

When you use the pointing technique to create a formula that references a cell in a pivot table, 
Excel replaces those simple cell references with a much more complicated GETPIVOTDATA function. 
If you type the cell references manually (rather than pointing to them), Excel does not use the 
GETPIVOTDATA function.

The reason? Using the GETPIVOTDATA function helps ensure that the formula will continue to refer-
ence the intended cells if the pivot table layout is changed.
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Figure 79-2 shows the pivot table after expanding the years to show the month detail. As you can 
see, the formulas in column F still show the correct result even though the referenced cells are in a 
different location. For example, the summary row for 2011 was originally row 4. After expanding the 
years, the summary row for 2011 is row 16. Had I used simple cell references, the formula would have 
returned incorrect results after expanding the years.

Figure 79-2: After expanding the pivot table, formulas that used the GETPIVOTDATA function continue to dis-
play the correct result.

Using the GETPIVOTDATA function has one caveat: The data that it retrieves must be visible in the 
pivot table. If you modify the pivot table so that the value used by GETPIVOTDATA is no longer visi-
ble, the formula returns an error.

Note 	

You may want to prevent Excel from using the GETPIVOTDATA function when you point 
to pivot table cells when creating a formula. If so, choose PivotTable Tools➜Analyze➜ 

PivotTable➜Options➜Generate GetPivot Data (this command is a toggle).
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Creating a Quick Frequency Tabulation
This tip describes a quick method for creating a frequency tabulation for a single column of data. 
Figure 80-1 shows a small part of a range that contains more than 20,000 rows of city and state data. 
The goal is to tally the number of times each state appears in the list.

Although you can tally the states in a number of ways, a pivot table is the easiest choice for this task.

Figure 80-1: You can use a pivot table to generate a frequency tabulation for these state abbreviations.

Before you get started on this task, make sure that your data column has a heading. In this example, 
it’s in cell B1.

Activate any cell in the column A or B and then follow these steps:

	 1.	 Choose Insert➜Tables➜PivotTable.

		  The Create PivotTable dialog box appears.
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	 2.	 If Excel doesn’t correctly identify the range, change the Table/Range setting.

	 3.	 Specify a location for the PivotTable.

	 4.	 Click OK.

		  Excel creates an empty pivot table and displays the PivotTable Fields task pane.

	 5.	 Drag the State field into the Rows section.

	 6.	 Drag the State field into the Values section.

Excel creates the pivot table, which shows the frequency of each state (see Figure 80-2).

Figure 80-2: A quick pivot table shows the frequency of each state abbreviation.
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This pivot table can be sorted, by using the Home➜Editing➜Sort & Filter command. In addition (as 
shown in Figure 80-3), you can even create a pivot chart to display the counts graphically. Just select 
any cell in the pivot table and choose PivotTable Tools➜Analyze➜Tools➜PivotChart.

Figure 80-3: A few mouse clicks creates a chart from the pivot table.
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Grouping Items by Date in a Pivot Table
One of the more useful features of a pivot table is the ability to combine items into groups. Grouping 
items is simple: Select them and choose PivotTable Tools➜Options➜Group➜Group Selection.

You can go a step further, though. When a field contains dates, Excel can create groups automati-
cally. Many users overlook this helpful feature. Figure 81-1 shows a portion of a table that has two 
columns of data: Date and Sales. This table has 731 rows and covers dates between January 1, 2012, 
and December 31, 2013. The goal is to summarize the sales information by month.

Figure 81-1: You can use the PivotTable feature to summarize the sales data by month.

Figure 81-2 shows part of a pivot table (in columns D:E) created from the data. Not surprisingly, it 
looks exactly like the input data because the dates haven’t been grouped.

To group the items by month, right-click any cell in the Date column of the pivot table and select 
Group from the shortcut menu. You see the Grouping dialog box, shown in Figure 81-3. In the By list 
box, select Months and Years and verify that the starting and ending dates are correct. Click OK.

The Date items in the pivot table are grouped by years and by months (as shown in Figure 81-4).

Note 	

The Group command is available only if every item in the field is a date (or a time). Even 
a single blank cell will make it impossible to group by date.
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Figure 81-2: The pivot table, before grouping by months and years.

Figure 81-3: Use the Grouping dialog box to group items in a pivot table.

Note 	

If you select only Months in the Grouping list box, months in different years are com-
bined. For example, the June item would display sales for both 2012 and 2013.
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Figure 81-4: The pivot table, after grouping by months and years.

Notice that the Grouping dialog box contains other time-based units. For example, you can group 
the data into quarters. Figure 81-5 shows the data grouped by quarters and years.

Figure 81-5: The pivot table, after grouping by quarters and years.
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Creating Pivot Tables with Multiple 
Groupings
If you’ve created multiple pivot tables from the same data source, you may have noticed that group-
ing a field in one pivot table affects the other pivot tables. Specifically, all the other pivot tables auto-
matically use the same grouping. Sometimes, this is exactly what you want. Other times, it’s not at all 
what you want. For example, you may want to see two pivot table reports: one that summarizes data 
by month and year, and another that summarizes the data by quarter and year.

The reason grouping affects other pivot tables is because all the pivot tables are using the same pivot 
table cache. Unfortunately, there’s no direct way to force a pivot table to use a new cache. But there is 
a way to trick Excel into using a new cache. The trick involves assigning multiple range names to the 
source data.

For example, if your source range is named Table1, give the same range a second name: Table2. The 
easiest way to name a range is to use the Name box, to the left of the Formula bar. Select the range, 
type a name in the Name box, and press Enter. Then, with the range still selected, type a different 
name, and press Enter. Excel will display only the first name, but you can verify that both names exist 
by choosing Formulas➜Define Names➜Name Manager (see Figure 82-1).

Figure 82-1: A range has two names.

When you create the first pivot table, specify Table1 as the Table/Range in the Create PivotTable dia-
log box (see Figure 82-2). When you create the second pivot table, specify Table2 as the Table/Range. 
Each pivot table will use a separate cache, and you can create groups in one pivot table, independent 
of the other pivot table.
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Figure 82-2: Using a named range as the Table/Range.

You can use this trick with existing pivot tables. Make sure that you give the data source a different 
name. Then select the pivot table and choose PivotTable Tools➜Analyze➜Data➜Change Data 
Source. In the Change PivotTable Data Source dialog box, type the new name that you gave to the 
range. This will cause Excel to create a new pivot cache for the pivot table.

Figure 82-3 shows two pivot tables (with different groupings) created from the same data source. 
One pivot table is grouped by quarters and years, and the other is grouped by months and years.

Figure 82-3: These pivot tables were created from the same data source, but use different groupings.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 83: Using Pivot Table Slicers and Timelines232

Using Pivot Table Slicers and Timelines
If you’ve worked with pivot tables, filtering data in a pivot table is fairly easy. Just click the filter but-
ton for a field, and remove the check mark from items that you don’t want to see. This tip describes 
two ways to simplify pivot table filtering: slicers and timelines. These methods are most useful when 
the worksheet will be viewed by novices, or for those who prefer things very simple.

Using slicers
Figure 83-1 shows an unfiltered pivot table that summarizes bank account information by three 
fields: Customer Type (either New or Existing), Branch (either Central, North County, or Westside), 
and OpenedBy (either New Accts or Teller).

Figure 83-1: The normal way to filter items in a pivot table.

A slicer is an interactive control that makes it easy to apply simple filters to data in a pivot table. 
Figure 83-2 shows a pivot table with three slicers. Each slicer represents a particular field in the pivot 
table. In this case, the pivot table is displaying data for existing customers, opened by tellers at the 
Central branch.

The same type of filtering can be accomplished by using the field labels in the pivot table, but slicers 
are intended for those who might not understand how to filter data in a pivot table. Slicers can also 
be used to create an attractive and easy-to-use interactive dashboard.
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Figure 83-2: Using slicers to filter the data displayed in a pivot table.

To add one or more slicers to a worksheet, start by selecting any cell in a pivot table. Then choose 
Insert➜Filter➜Slicer. The Insert Slicers dialog box appears, with a list of all fields in the pivot table. 
Place a check mark next to the slicers you want, and then click OK.

Note 	

In Excel 2013, slicers aren’t limited to pivot tables. You can also use slicers with a table 
(created with Insert➜Tables➜Table).

Slicers float on the worksheet’s drawing layer, and they can be moved and resized. You can change 
the look and also specify multiple columns of buttons.

To use a slicer to filter data in a pivot table, just click a button in the slicer. To display multiple values, 
press Ctrl while you click the buttons. Press Shift and click to select a series of consecutive buttons.

To remove the effects of filtering by a particular slicer, click the icon in the slicer’s upper-right corner.

Figure 83-3 shows a pivot table with two slicers to enable filtering the data (by State and by Month). 
In this case, the pivot table and pivot chart show only the data for California, Oregon, and 
Washington for the months of January through March. Slicers provide a quick-and-easy way to create 
an interactive chart.
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Figure 83-3: Using slicers to filter a pivot table by state and by month.

Using a timeline
A timeline is conceptually similar to a slicer, but this control is designed to simplify time-based filter-
ing in a pivot table. Timelines are new to Excel 2013, and (unlike slicers) this feature is for pivot 
tables only.

A timeline is relevant only if your pivot table has a field that’s formatted as a date. This feature does 
not work with times. To add a timeline, select a cell in a pivot table and choose Insert➜Filter➜ 

Timeline. A dialog box appears listing all date-based fields. If your pivot table doesn’t have a field for-
matted as a date, Excel displays an error.

Figure 83-4 shows a pivot table created from the data in columns A:E. This pivot table uses a timeline, 
set to allow date filtering by quarters. Click a button that corresponds to the quarter you want to view, 
and the pivot table is updated immediately. To select a range of quarters, press Shift while you click 
the buttons. Other filtering options (selectable from the drop-down in the upper-right corner) are 
Year, Month, and Day. In the figure, the pivot table displays data from the first two quarters of 2012.

You can, of course, use both slicers and a timeline for a pivot table. A timeline has the same type of 
formatting options as slicers, so you can create an attractive interactive dashboard that simplifies 
pivot table filtering.
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Figure 83-4: Using a timeline to filter a pivot table by date.
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PART VI
Charts and  
Graphics
A well-conceived chart can make a range of incomprehensible numbers make sense. 
The tips in this part deal with various aspects of chart making, and also covers topics 
related to other types of graphics.
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Understanding Recommended Charts
One of the new features in Excel 2013 is Recommended Charts. Select your data, choose Insert➜ 

Charts➜Recommended Charts, and Excel responds by displaying the Recommended Charts of the 
Insert Chart dialog box (see Figure 84-1). This dialog box displays a preview of your data using several 
chart type options.

Figure 84-1: The Recommended Charts feature displays your data using several different chart types.
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How does it work? According to the Excel Help:

Want us to recommend a good chart to showcase your data? Select data in your worksheet and click this 
button to get a customized set of charts that we think will fit best with your data.

Don’t believe it. Excel uses some simple algorithms to make its suggestions, but don’t expect any 
advanced artificial intelligence. In other words, you will probably never see a recommended chart 
that will make you say, “Why didn’t I think of that!”

The recommended charts seem to be limited to the basic chart types: column charts, line charts, area 
charts, bar charts, pie charts, and scatter charts.

The recommendations don’t seem to take the magnitude of the data into account. For example, if 
you select two data series that vary drastically in scale, a combination chart would be a good recom-
mendation. But I’ve never seen Excel recommend a combination chart. Rather, it recommends a col-
umn or line chart in which one of the data series is so close to the axis that it may not even be visible.

Even when data is perfectly suited (and labeled) for a stock market chart, that chart is never recom-
mended. But it does offer some recommendations that are clearly inappropriate.

But the recommended charts feature is not completely useless. For example, if a data series has more 
than eight data points, Excel will not recommend a pie chart. That’s certainly good advice because 
pie charts are often used inappropriately to display too much data. Also, Excel will never recommend 
a 3D chart. That’s also good advice because a 3D chart is almost never the best choice.

Excel’s Recommended Charts feature is certainly a good idea, but the current implementation leaves 
much to be desired. The main problem is this feature is intended for novice users — and many of 
them will actually believe that a recommended chart is an appropriate way to present their data.

Bottom line: Don’t trust Excel’s chart recommendations, except for very simple data sets. Instead, 
take some time and become familiar with Excel’s chart types. Strive for simplicity and clarity, and you 
won’t be tempted to take bad advice from a computer program.
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Customizing Charts
If you’ve ever been frustrated when trying to customize a chart, here’s some good news: Excel 2013 
makes this task easier than ever.

When you click on a chart in Excel 2013, you see three buttons at the upper-right of the chart. These 
buttons are the key to quick and easy chart customization.

Adding or removing chart elements
Figure 85-1 shows the options available when you click the Chart Elements button. Note that each 
item can be expanded to show additional options. To expand an item in the Chart Elements list, 
hover your mouse over the item and click the arrow that appears.

When you display the options for a button, hover the mouse over the item to get a preview of how 
the chart will look if you select (or deselect) an item.

Figure 85-1: Options available from the Chart Elements button.

Modifying a chart style or colors
Figure 85-2 shows the options available when you click the Chart Styles button.

Notice that there’s a two-item menu at the top: Style and Color. Click the Color item, and you can 
choose a different color palette for your chart.
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Figure 85-2: Options available from the Chart Styles button.

Filtering chart data
Options for the third button, Chart Filters, are shown in Figure 85-3. These options enable you to 
quickly hide one or more charts series or even data points within a chart series.

Note that previewing works differently for these options, and you must click the Apply button to see 
the effect of filtering.

Figure 85-3: Options available from the Chart Filters button.
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Making Charts the Same Size
If you have several embedded charts on a worksheet, you might want to make them all exactly the 
same size. Figure 86-1 shows a worksheet with four charts that would look better if they were all the 
same size and aligned.

Figure 86-1: These charts would look better if they were all the same size.

To make all the charts the same size, first identify the chart that is already the size you want. In this 
case, you want to make all the charts the same size as the Subject 2 chart in the upper-right area.

	 1.	 Click the chart to select it.

	 2.	 Choose Chart Tools➜Format.

		  You see the Height and Width settings in the Size group.

	 3.	 Make a note of the Height and Width settings.

	 4.	 Press Ctrl while you click the other three charts (so that all four are selected).

	 5.	 Choose Drawing Tools➜Format, enter the Height and Width settings that you noted in  
Step 3 and then click OK.

		  The charts are now exactly the same size.
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You can align the charts manually, or you can use the Chart Tools➜Format➜Arrange➜Align commands. 
Figure 86-2 shows the result.

Note that if you Ctrl+click a chart, you select it as a graphic object so that you can use the arrow keys 
to move the chart. Using the arrow keys moves the chart one pixel at a time and allows more control 
than dragging it with your mouse.

Figure 86-2: Four charts, resized and aligned.
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Creating a Chart Template
If you find that you’re continually making the same types of customizations to your charts, you can 
probably save some time by creating a template. Many users avoid this feature because they think 
that it’s too complicated. Creating a chart template is actually very simple.

Figure 87-1 shows a highly customized chart that will be saved as a template so it can be used for 
future charts. This chart includes a shape and a text box, and both of these added elements are 
included in the template.

Figure 87-1: This chart will be saved as a template.

Creating a template
To create a chart template, follow these steps:

	 1.	 Create a chart to serve as the basis for your template.

		  The data you use for this chart isn’t critical, but for best results, it should be typical of the 
data that you will eventually plot with your custom chart type.

	 2.	 Apply any formatting and customizations that you like.

		  This step determines the appearance of the charts created from the template.

	 3.	 Activate the chart; then right-click and choose Save as Template from the shortcut menu. 
(The Excel 2013 Ribbon doesn’t have a command to create a chart template.)

		  The Save Chart Template dialog box appears.

	 4.	 Provide a name for the template and click Save.

Chart templates are stored as *.ctrx files. You can create as many chart templates as you need.
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Using a template
To create a chart based on a template you’ve created, follow these steps:

	 1.	 Select the data to be used in the chart.

	 2.	 Choose Insert➜Charts➜Recommended Charts.

		  The Insert Chart dialog box appears.

	 3.	 At the top of the Insert Chart dialog box, choose the All Charts tab.

	 4.	 Choose Templates from the list on the left.

		  Excel displays a preview image (using the selected data) for each custom template that has 
been created (see Figure 87-2).

	 5.	 Click the image that represents the template you want to use and click OK.

		  Excel creates the chart based on the template you selected.

You can also apply a template to an existing chart. Select the chart and choose Chart Tools➜ 

Design➜Change Chart Type. That command displays a dialog box that’s exactly the same as the Insert 
Chart dialog box. Choose the All Charts tab and then choose Templates from the list on the left.

Figure 87-2: Choosing a chart template.
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Creating a Combination Chart
A combination chart combines two chart types in a single chart. A combination chart may use a sec-
ondary vertical axis. In the past, creating a combination chart in Excel was relatively complicated and 
required some non-intuitive steps. Excel 2013 finally gets it right: creating a combination chart is easy.

Figure 88-1 shows a column chart with two data series: Temperature and Precipitation. Because 
these two measures have drastically different scales, the columns for the precipitation data are hardly 
visible. This is a good candidate for a combination chart.

Figure 88-1: The two data series in this chart use drastically different scales.

Inserting a preconfigured combination chart
The following steps describe how to create a combination chart from the data in range A2:M4. The 
chart will display temperature as columns, and precipitation as a line. In addition, the precipitation 
series will use a secondary vertical axis.

	 1.	 Select the range A2:M4.

	 2.	 Choose Insert➜Charts➜Combo.

		  This command expands to display three icons (see Figure 88-2). Hover your mouse over the 
icons, and you’ll see a preview.
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	 3.	 Choose the second icon: Clustered Column — Line on Secondary Axis.

		  Excel creates the chart shown on Figure 88-3.

Figure 88-2: Excel proposes three preconfigured combination charts.

Figure 88-3: Excel created this combination chart with just a few mouse clicks.

The chart clearly shows both data series. The primary axis (on the left) is for the Avg Temperature 
series (columns). The secondary axis (on the right) is for the Avg Precipitation series (the line). You 
may want to add axis labels to make it easier to distinguish the two axes.

Customizing a combination chart
In some cases, none of the preconfigured combination charts will be exactly what you want. But cre-
ating a customized combination chart is a simple matter.

Choose Insert➜Charts➜Combo➜Create Custom Combo Chart, and the Insert Chart dialog box 
appears with the Combo section displayed (see Figure 88-4). Use the controls at the bottom of the All 
Charts tab of the Insert Chart dialog box to specify the chart type for each data series. Use the check 
boxes to indicate which (if any) of the series will use a secondary axis.
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Figure 88-4: Use the controls at the bottom of this dialog box to customize a combination chart.

You have a great deal of control in customizing combination charts. But just because Excel allows 
you to create a certain combination chart doesn’t mean it’s a good idea. Figure 88-5 shows a custom 
combination chart that uses bars and columns — and it’s not a good example of an effective chart.

Figure 88-5: An example of a poorly conceived custom combination chart.
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Handling Missing Data in a Chart
Sometimes, data that you’re charting may be missing one or more data points. As shown in Figure 89-1, 
Excel offers three ways to handle the missing data:

➤	 Gaps: Missing data is simply ignored, and the data series will have a gap. This is the default 
way missing data is handled in a chart.

➤	 Zero: Missing data is treated as zero.

➤	 Connect Data Points with Line: Missing data is interpolated, calculated by using data on 
either side of the missing point(s). This option is available for line charts, area charts, and XY 
charts only.

Figure 89-1: Three options for dealing with missing data.

To specify how to deal with missing data for a chart, choose Chart Tools➜Design➜Data➜Select 
Data. In the Select Data Source dialog box, click the Hidden and Empty Cells button. The Hidden and 
Empty Cell Settings dialog box appears, as shown in Figure 89-2. Make your choice in the dialog box.
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The option that you choose applies to the entire chart, and you can’t set a different option for differ-
ent series in the same chart.

Figure 89-2: The Hidden and Empty Cell Settings dialog box.

Note 	

Normally, a chart doesn’t display data that’s in a hidden row or column. You can use the 
Hidden and Empty Cell Settings dialog box to force a chart to use hidden data, though.
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Using High-Low Lines in a Chart
Excel supports a number of stock market charts, which are normally used to display stock market 
data. For example, you can create a chart that shows a stock’s daily high, low, and closing prices. That 
particular chart type requires three data series.

But stock market charts aren’t just for stock prices. Figure 90-1 shows a chart that depicts daily tempera-
tures for a month. The vertical lines (called high-low lines) show the temperature range for the day.

This chart was created with a single command. I selected the range A3:D34, chose Insert➜Charts➜ 

Other Charts, and selected the High-Low-Close option. You can, of course, format the high-low lines 
any way you like. And you may prefer to have the average temperatures connected with a line.

Figure 90-1: Using a stock market chart to plot temperature data.

When creating stock market charts, the order of the data for the chart series is critical. Because I 
chose the High-Low-Close chart type, the series must be arranged in that order. In this case, the 
“Close” data corresponds to Average temperatures.
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Using Multi-Level Category Labels
Most users don’t realize it, but when you create a chart, you can display multi-level category labels. 
You don’t have to do anything special. Just select all of the data before you create the chart. Excel 
takes care of the details for you.

Figure 91-1 shows an example of a chart that uses two columns for the category labels. Here, the first 
level is the region, and the second level is the state. Notice that the Region labels in column A aren’t 
repeated for each state. The blank regions cause the region name to appear once in the chart.

Figure 91-1: A chart that uses two columns for category labels.

Figure 91-2 shows another example, which uses three columns for the category axis labels. In this exam-
ple, the additional lines of text are used to provide more information about each of the four branches.

Figure 91-2: A chart that uses three columns for category labels.
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You can apply formatting to the category axis labels, but the formatting is applied to all of the text. In 
other words, you can’t apply different formatting for each level.

Figure 91-3 shows a variation of the previous example. After creating the chart with a multi-level 
category axis, I selected the category axis and pressed Ctrl+1 to display the Format Axis task pane. 
In the Axis Options➜Labels section, I specified the Label Position to be High. I also deselected the 
Multi-level Category Labels option, which has the effect of making the lines closer together.

Figure 91-3: A chart that displays category labels at the top.
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Linking Chart Text to Cells
When you create a chart, you may want to have some of the chart’s text elements linked to cells. That 
way, when you change the text in the cell, the corresponding chart element is updated. You can even 
link chart text elements to cells that contain a formula. For example, you might link the chart title to a 
cell that contains a formula that returns the current date.

You can create a link to a cell for the chart title, the axis titles, and individual data labels.

	 1.	 Select the chart element that will contain the cell link.

	 2.	 Click the Formula bar.

	 3.	 Type an equal sign (=).

	 4.	 Click the cell that will be linked to the chart element.

	 5.	 Press Enter.

Figure 92-1 shows a chart title being linked to cell A1.

Figure 92-1: Adding a cell link to a chart title.
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Oddly, this technique doesn’t work if the cell has a name. Excel displays an error claim-
ing that the formula contains an error. If you must link the chart element to a named 
cell, override the name with the sheet name and cell address. For example:

=Sheet1!A12

In addition, you can add a linked text box (or a linked shape) to a chart:

	 1.	 Select the chart.

	 2.	 Choose Insert➜Text➜Text Box. Or choose Insert➜Illustrations➜Shapes and choose a shape 
that supports text.

	 3.	 Click inside the chart to add an empty text box (or shape).

	 4.	 Click the Formula bar.

	 5.	 Type an equal sign (=).

	 6.	 Click the cell that will be linked to the object.

	 7.	 Press Enter.

Note
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Freezing a Chart
Normally, an Excel chart uses data stored in a range. Change the data, and the chart is updated auto-
matically. Usually, that’s a good thing. But sometimes you want to “unlink” the chart from its data 
range to produce a static chart — a snapshot of a chart that never changes. For example, if you plot 
data generated by various what-if scenarios, you may want to save a chart that represents a baseline 
so that you can compare it with other scenarios. You can freeze a chart in two ways:

➤	 Convert the chart to a picture.

➤	 Convert the range references to arrays.

Converting a chart into a picture
To convert a chart to a static picture, follow these steps:

	 1.	 Create the chart as usual and format it the way you want.

	 2.	 Click the chart to activate it.

	 3.	 Choose Home➜Clipboard➜Copy➜Copy As Picture.

		  The Copy Picture dialog box appears.

	 4.	 Accept the default settings and click OK.

	 5.	 Click any cell to deselect the chart.

	 6.	 Press Ctrl+V to paste the picture at the cell you selected in Step 5.

The result is a picture of the original chart. This chart can be edited as a picture, but not as a chart. In 
other words, you can no longer modify properties such as chart type and data labels. It’s a dead 
chart — just what you wanted.

When you select the picture, Excel displays its Picture Tools contextual menu. You can use all of the 
tools in Picture Tools➜Format, plus those available in the Format Picture dialog box (displayed when 
you press Ctrl+1). Figure 93-1 shows a few examples of picture styles applied to a chart that was cop-
ied as a picture.
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Figure 93-1: Applying picture styles to a chart that was copied as a picture.

Converting range references into arrays
The other way to unlink a chart from its data is to convert the SERIES formula range references to 
arrays. Follow these steps:

	 1.	 Activate your chart.

	 2.	 Click a chart series.

		  The Formula bar displays the SERIES formula for the selected data series.

	 3.	 Click the Formula bar.

	 4.	 Press F9 and then press Enter.

Repeat these steps for each series in the chart.

Figure 93-2 shows a pie chart that has been unlinked from its data range. Notice that the Formula bar 
displays arrays, not range references. The original data SERIES formula was

=SERIES(,Sheet3!$A$1:$A$6,Sheet3!$B$1:$B$6,1)
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The converted SERIES formula is

=SERIES(,{“Work”,”Sleep”,”Commute”,”Eat”,
“Play Banjo”,”Other”},{8,7,2,1,3,3},1)

Note 	

Excel places a limit on the length of a SERIES formula. Therefore, this method may not 
work if the series consists of a large number of data points.

Figure 93-2: This chart is no longer linked to a data range.
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Creating a Chart Directly in a Range
This tip describes two ways to display a bar chart directly in a range of cells:

➤	 Using conditional formatting data bars

➤	 Using formulas that display repeating characters

These “non-chart” charts often serve as a quick way to display lots of data graphically, without creat-
ing actual charts.

Using conditional formatting data bars
Using the data bars conditional formatting option can sometimes serve as a quick alternative to cre-
ating a chart. The data bars conditional format displays horizontal bars directly in the cell. The length 
of the bar is based on the value of the cell, relative to the other values in the range. When you adjust 
the column width, the bar lengths adjust accordingly. The differences among the bar lengths are 
more prominent when the column is wider. 

Figure 94-1 shows results from a survey, using data bars to visualize the distribution for each survey 
item.

Figure 94-1: These tables use data bars conditional formatting.
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To add data bars to a range, select the range and choose Home➜Conditional Formatting➜Data Bars 
and select one of the fill options.

Excel provides quick access to 12 data bar styles via Home➜Styles➜Conditional Formatting➜Data 
Bars. For additional choices, click the More Rules option, which displays the New Formatting Rule dia-
log box. Use this dialog box to do the following:

➤	 Show the bar only (hide the numbers).

➤	 Specify Minimum and Maximum values for the scaling.

➤	 Change the appearance of the bars.

➤	 Specify how negative values and the axis are handled.

➤	 Specify the direction of the bars.

Using formulas to display repeating characters
Figure 94-2 shows an example of a chart created by using formulas.

Figure 94-2: A histogram created directly in a range of cells.

Column D contains formulas that incorporate the rarely used REPT function, which repeats a text 
string a specified number of times. For example, the following formula displays five asterisks:

=REPT(“*”,5)

In the example shown in Figure 94-2, cell D3 contains this formula, which was copied down the column:

=REPT(“*”,C3/2)
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Notice that the formula divides the value in column B by 2. This is a way to scale the chart. Instead of 
displaying 60 asterisks, the cell displays 30 asterisks. For improved accuracy, you can use the ROUND 
function:

=REPT(“*”,ROUND(C3/2,0))

Without the ROUND function, the formula truncates the result of the division (disregards the decimal 
part of the argument). For example, the value 67 in column B displays 33 characters in column D. 
Using ROUND rounds up the result to 34 characters.

You can use this type of graphical display in place of a column chart. As long as you don’t require 
strict accuracy (because of rounding errors), this type of nonchart might fit the bill.

Figure 94-3 shows some other examples that use different characters and fonts. The chart that dis-
plays the solid bars (beginning in row 39) uses the pipe character of the Script font. On most key-
boards, the pipe character is generated when you press Shift+backslash. The formula in cell D39 is

=REPT(“|”,C39/2000)

Figure 94-3: Examples of in-cell charting using the REPT function.
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The example in Figure 94-4 uses formulas in columns F and H to graphically depict monthly budget 
variances by displaying a series of characters. You can then easily see which budget items are under 
or over budget. This pseudo bar chart uses the character n, which appears as a small square in the 
Wingdings font.

The key formulas are

F3: =IF(D3<0,REPT(“n”,-ROUND(D3*100,0)),””)
G3: =A3
H3: =IF(D3>0,REPT(“n”,-ROUND(D3*-100,0)),””)

Figure 94-4: Displaying monthly budget variances by using the REPT function.

For this example, follow these steps to set up the bar chart after entering the preceding formulas:

	 1.	 Assign the Wingdings font to cells F3 and H3.

	 2.	 Copy the formulas down columns F, G, and H to accommodate all the data.

	 3.	 Right-align the text in column E and adjust any other formatting.

Depending on the numerical range of your data, you may need to change the scaling. Experiment by 
replacing the 100 value in the formulas. You can substitute any character you like for the n in the for-
mulas to produce a different character in the chart.
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Creating Minimalistic Charts
Effective charts don’t always have to be complicated. In fact, simpler charts that convey a clear mes-
sage are almost always preferable to more complex charts.

This tip presents some simple charts that demonstrate various ways to provide a different visual 
experience, compared to the standard chart types. The point is to help you realize that, with a bit of 
creativity, you can create charts that don’t look like everyone else’s charts.

Simple column charts
Figure 95-1 shows four charts, each of which uses only one data point. This data could be displayed 
in a single chart, but using four charts provides a different, cleaner look.

These are very minimalistic charts. The only chart elements displayed are the single data point series, 
the data label for that data point, and the chart tile (displayed on the left, and rotated). The single 
column fills the entire width of the plot area.

Figure 95-1: Four minimalistic column charts.

Simple pie charts
Figure 95-2 shows the same data, plotted as four pie charts. These charts were adjusted such that the 
angle of the first slice is 0 degrees. That step makes it easy to make comparisons across the four 
charts.

The chart titles are linked to the cells in column E (see Tip 92). Each title is generated with a formula 
that uses the original data. For example, the formula in cell E2 is

=A2&” (“&TEXT(B2,”0%”)&”)”
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Figure 95-2: Four pie charts.

Simple line charts
Figure 95-3 shows four line charts, with all chart elements removed except for the series and the data 
labels. Importantly, all four charts use the same vertical scale values (0 through 50). If you allowed 
Excel to calculate the scale bounds, comparisons among the charts would be difficult.

Figure 95-3: Four line charts.

Using four charts makes it very easy to spot trends. The alternative, four series in a single chart, is 
shown in Figure 95-4.
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Figure 95-4: A line chart with four series.

Note 	

Another option is to use Sparkline graphics — perhaps the ultimate in minimal charts. 
Sparklines are small graphics that display directly in a cell.

A gauge chart
Figure 95-5 shows a chart based on a single cell. It’s a pie chart set up to resemble a gauge. Although 
this chart displays only one value (entered in cell B1), it actually uses three data points (in A4:A6).

Figure 95-5: This chart resembles a speedometer gauge and displays a value between 0 and 100 percent.
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One slice of the pie — the slice at the bottom — always consists of 50 percent. I rotated the pie so 
that the 50-percent slice was at the bottom. Then I hid that slice by specifying No Fill and No Border 
for the data point. The other two slices are apportioned based on the value in cell B1. The formula in 
cell B4 is

=MIN(B1,100%)/2

This formula uses the MIN function to display the smaller of two values: either the value in cell B1 or 
100 percent. It then divides this value by 2 because only the top half of the pie is relevant. Using the 
MIN function prevents the chart from displaying more than 100 percent.

The formula in cell A5 simply calculates the remaining part of the pie — the part to the right of the 
gauge’s needle:

=50%-A4

The chart’s title (Percent Completed) was moved below the half-pie. A linked text box displays the 
percent completed value in cell B1.
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Applying Chart Data Labels from a Range
Excel 2013 introduced a feature that’s been on the wish lists of many users for at least 15 years: the 
ability to specify an arbitrary range to be used as data labels for a series.

Figure 96-1 shows an XY scatter chart that uses data labels stored in a range to identify the data 
points. In previous versions of Excel, adding these data labels had to be done manually, or with the 
assistance of a macro.

Figure 96-1: Excel 2013 can add data labels from an arbitrary range.

To specify data labels from a range:

	 1.	 Activate the chart and select the series that will contain data labels.

	 2.	 Click the Chart Elements icon (to the right of the chart) and add data labels.

		  Excel displays default data labels for the series.

	 3.	 Select the data labels and press Alt+1 to display the Format Data Labels task pane.

	 4.	 In the Label Options section of Format Data Labels task pane, deselect any check boxes that 
are selected and select the Values from Cells check box.

		  The Data Label Range dialog box appears, as shown in Figure 96-2.

	 5.	 Specify the range that contains the labels and click OK.
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Figure 96-2: Specifying a range to be used as data labels.

Note 	

When the data labels are placed on the chart, you can fine-tune the location of each one, 
if necessary. Click one data label to select them all; then click a single data label and 
drag it to its new position.
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Grouping Charts and Other Objects
If you create a number of charts, you may want to be able to work with them all as a group. For 
example, move them all, or resize them all. The solution is to group the charts into a single object.

Grouping charts
Start by creating the charts that you’d like to group and then arrange and size them as you like. Then 
press Shift and click each chart. When the charts are selected, right-click any one of them and choose 
Group➜Group.

Figure 97-1 shows six charts that have been grouped. The group name (Group 14) appears in the 
Name box.

Figure 97-1: Six charts, combined into a group.

To move the entire group, click anywhere in the group and drag.

Note 	

If the group is already selected when you click and drag, you will select a particular chart 
in the group and change its position. Most of the time, this is not what you want. Press 
Ctrl+Z to undo.

To resize the entire group, click anywhere in the group to select the group. Then drag any of the 
resizing handles that appear in the group’s outline.
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Figure 97-2 shows the grouped charts after I resized the entire group.

Figure 97-2: Grouped charts, after resizing the group.

Even though charts are grouped, you can still work with a particular chart in a group — and charts 
that are in a group can still be moved and resized individually. To work with a single chart in a group, 
click anywhere in the group to select the group; then click the chart you want to work on.

To ungroup the objects in the group, right-click anywhere in the group and choose Group➜ 

Ungroup.

Grouping other objects
You can combine various types of objects into a group. Figure 97-3 shows a group that consists of a 
shape (which serves as the background), a text box, and a chart. Figure 97-4 shows the group after I 
resized it to change the proportions. Resizing a group is much easier than resizing three separate 
objects.

Note 	

When combining objects that overlap, you’ll often need to adjust the stack order. Right-
click an object and use the Bring to Front or Send to Back commands.
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Figure 97-3: Three objects in a group.

Figure 97-4: The object group, after resizing.
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Taking Pictures of Ranges
Excel makes it easy to convert a range of cells into a picture. The picture can either be a static image 
(it doesn’t change if the original range changes) or a live picture (which reflects changes in the origi-
nal range). The range can even contain objects, such as charts or shapes.

Creating a static image of a range
To create a snapshot of a range, start by selecting a range of cells and then press Ctrl+C to copy the 
range to the Clipboard. Then choose Home➜Clipboard➜Paste➜Other Paste Options➜Picture (U). 
The result is a graphic image of the original range, pasted on top of the original range. Just click and 
drag to move the picture to another location. When you select this image, Excel displays its Picture 
Tools context menu — which means that you can apply some additional formatting to the picture.

Figure 98-1 shows a range of cells (B2:E9), along with a picture of the range after I applied one of the 
built-in styles from the Picture Tools➜Format➜Picture Styles gallery. It’s a static picture, so changes 
made within the range B2:E9 aren’t shown in the picture.

Note 	

If you want to include a graphic that shows information from another (non-Excel) win-
dow, choose Insert➜Illustrations➜Screenshot. You can capture an entire window or 
just a portion of a window (by choosing Screen Clipping). The copied information is 
pasted as a picture in the active worksheet.

Figure 98-1: A picture of a range, after applying some picture formatting.
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Creating a live image of a range
To create an image that’s linked to the original range of cells, select the cells and press Ctrl+C to copy 
the range to the Clipboard. Then choose Home➜Clipboard➜Paste➜Other Paste Options➜Linked 
Picture (I). Excel pastes a picture of the original range, and the picture is linked — if you make 
changes to the original, those changes are shown in the linked picture.

Notice that when you select the linked picture, the Formula bar displays the address of the original 
range. You can edit this range reference to change the cells that are displayed in the picture. To 
unlink the picture, just delete the formula on the Formula bar.

As with an unlinked picture, you can use Excel’s Picture Tools context menu to modify the appear-
ance of the linked picture.

You can also cut and paste this picture to a different worksheet, if you like. Doing so makes it easy to 
refer to information on a different sheet.

Figure 98-2 shows a linked picture of a range placed on top of a shape, which has lots of interesting 
formatting capabilities. Placing a linked picture on top of a shape is a good way to make a particular 
range stand out.

Figure 98-2: A linked picture of a range, placed on top of a shape.
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Saving a range as a graphic image
If you need to save a range as a graphic image, the best approach is to use one of several screen cap-
ture programs that are available. This type of software makes it easy to capture complete windows or 
just a portion of a window. After you capture the screen, click a button to save it as a graphics image 
in the format you choose (GIF, PNT, TIF, and so on).

If you don’t have a screen capture program, you probably have some other type of graphics software. 
When you copy a range of cells, that range is stored on the Windows Clipboard in several different 
formats. One of those formats is a graphic image. Therefore, you can copy a range, activate your 
graphics software, and press Ctrl+V to paste the range as a graphic. Then save the graphics file in 
your desired format.

Figure 98-3 shows a range after it was copied and pasted into a freeware program named IrfanView.

Figure 98-3: A range of data, ready to be saved as a graphic image.

Copying a range is a what-you-see-is-what-you-get thing. For example, if the selected range contains 
a chart, the chart will also appear in the image.

Cross-Ref	
For another method to save a range as a graphic image, see Tip 101.
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Changing the Look of Cell Comments
Cell comments are useful for a variety of purposes. But sometimes you just get tired of looking at the 
same old yellow rectangle. This tip describes three tricks that you can use to make your comments 
stand out:

➤	 Format a comment.

➤	 Change the shape of a comment.

➤	 Add an image to a comment.

Note 	

All of these changes require that the cell comment is visible. If the comment isn’t visible, 
right-click the cell and choose Show/Hide Comments from the shortcut menu.

Setting up your Quick Access toolbar
The operations described in this tip require commands that aren’t normally available in the Ribbon 
when a comment is selected. So the first step is to add three commands to your Quick Access toolbar:

	 1.	 Right-click the Quick Access toolbar and choose Customize Quick Access Toolbar.

		  The Customization section of the Excel Options dialog box appears.

	 2.	 From the Choose Commands From drop-down list, select All Commands.

	 3.	 In the list on the left, select Format Shape and then click the Add button.

	 4.	 In the list on the left, select Change Shape and then click the Add button.

	 5.	 In the list on the left, select Picture Fill and then click the Add button.

	 6.	 Click OK to close the Excel Options dialog box.

After you complete these steps, your Quick Access toolbar has three new icons.

Formatting a comment
To change the formatting of a comment, Ctrl+click the comment (to select it as a shape) and then 
click the Format Shape icon in your Quick Access toolbar, or you can press Ctrl+1. Either of these 
actions displays the Format Comment dialog box. This dialog box has eight tabs that enable you to 
change just about any aspect of the comment.
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Figure 99-1 shows a normal cell comment, and the same comment after changing the font, align-
ment, fill color, text color, and border width and style.

Figure 99-1: A normal cell comment and a comment with different formatting.

Changing the shape of a comment
Comments don’t have to display as a rectangular box. Figure 99-2 shows a cell comment, after apply-
ing a different shape.

To change the shape of a comment, Ctrl+click the comment (to select it as a shape). Click the Change 
Shape button on the Quick Access toolbar and choose a new shape for the comment from the Shape 
gallery.

Figure 99-2: A cell comment that uses a nonstandard shape.
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Adding an image to a cell comment
Most users don’t realize it, but a cell comment can display an image. The image can reside in a file or 
can come from the Office.com Clip Art collection. You can’t use shapes or clip art images that are 
copied to the Clipboard.

To add an image to a comment, Ctrl+click the comment to select it as a shape and then click the 
Picture Fill icon in the Quick Access toolbar. Excel displays the Insert Pictures dialog box, in which you 
can select or search for an image.

Figure 99-3 shows a comment that contains a clip art image. Using an image in a comment increases 
the size of your workbook, so keep that in mind before you go overboard with images.

Figure 99-3: Displaying an image in a cell comment.
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Enhancing Images
A set of features that you might overlook is image enhancement. These tools allow you to modify 
and enhance images that you insert on a worksheet. This doesn’t mean you can uninstall your favor-
ite image editing software, but you may be surprised at the type of enhancements you can perform 
without even leaving Excel.

To embed an image on a worksheet, choose Insert➜Illustrations➜Pictures (for an image stored on 
your hard drive) or Insert➜Illustrations➜Online Pictures (to search for and retrieve an image from an 
online source).

When you select an embedded image, use the tools in the Picture Tools➜Format➜Adjust group to 
work it. The tools include the following:

➤	 Remove Background: Makes it very easy to remove an extraneous background from a 
photo.

➤	 Corrections: Sharpen or soften the image or adjust the brightness and contrast.

➤	 Color: Adjust the color saturation and color tone or convert the image to use just a few colors.

➤	 Artistic Effects: Apply some Photoshop-like filters to the image.

➤	 Compress Pictures: Make your images smaller.

➤	 Change Picture: Substitute a different image for the selected image.

➤	 Reset Picture: Undo all modifications you’ve made.

In most cases, you get a live preview of the effect when you move your mouse pointer over the icon. 
Just click to apply it. For more control over the enhancements, right-click the image and choose 
Format Picture. Then use the controls in the Format Picture task pane to adjust the parameters.

Figure 100-1 shows a photo before and after I removed the background. The parts of the image that 
are removed become transparent. This feature works surprisingly well.
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Figure 100-1: The result of using the Remove Background command.

Figure 100-2 shows a clipart image before and after I applied the Pencil Grayscale effect.

Figure 100-2: Applying an artistic effect to a photo.

Even if you have no need to adjust images, you might enjoy playing around with these features 
when you need a break from number crunching.
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Saving Shapes, Charts, and Ranges as 
Images
Excel supports quite a few types of graphics, but it doesn’t provide a way to save the graphic as a 
separate file for use in another program. For example, you may want a separate PNG or GIF file cre-
ated from a chart, a shape, SmartArt, or even a range pasted as a picture (see Tip 98).

Although Excel doesn’t provide a direct way to export a graphic, here’s a useful trick you can use. 
First, a bit of set-up work is required:

	 1.	 Right-click the Quick Access toolbar and choose Customize the Quick Access Toolbar.

		  The Quick Access Toolbar tab of the Excel Options dialog box appears.

	 2.	 In the upper-left drop-down control, choose Commands Not in the Ribbon.

	 3.	 In the list box, scroll down and select Web Options and then click the Add button.

	 4.	 In the list box, select Web Page Preview and click the Add button.

	 5.	 Click OK to close the Excel Options dialog box.

		  Your Quick Access toolbar now has two new buttons.

Here’s how to use these tools to export graphic objects (including charts) from a worksheet.

	 1.	 Make sure that your graphics appear the way you want.

	 2.	 Click the Web Page Preview button in the Quick Access toolbar.

		  A copy of your workbook is converted to an HTML file and is displayed in your default 
browser.

	 3.	 In the browser, right-click a graphic object, choose Save Image As, and specify a location for 
the file.

		  Your browser may have a different, but equivalent, command. Or you can just drag the 
graphic image to your desktop.

If the quality of the images in your browser is lacking, click the Web Options button in your Quick 
Access toolbar. The Web Options dialog box is shown in Figure 101-1.
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Figure 101-1: The Web Options dialog box.

In the Web Options dialog box, click the Browsers tab and make sure Allow PNG as a Graphics Format 
is enabled. If graphics don’t appear in your browser at all, remove the check mark from Rely on VML 
for Displaying Graphics in Browser. Next, click the Pictures tab and choose the 120 Pixels Per Inch 
option. Click OK and do the web preview again. You should see higher-quality graphics (transparent 
PNG files).
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formulas, entering properly, 114, 123
IFERROR function, using with, 124
limitations of, 207
lists, generating with, 27–28
multicell formulas, creating, 174–175
nonblank cells, finding with, 117
range references, converting into, 258–259

asterisk (*) wildcard character, 194
audio

proofing data with, 196
text-to-speech feature, enabling, 196
voice qualities, adjusting with, 197

AutoComplete, 211
AutoCorrect, propagating formulas with, 210
AutoFill

date series, creating with, 152
filling range with, 151
lists, creating for, 153
predicting values with, 152–153
table of data types, 153

autofit, issues with merged cells, 45
AutoRecover

autosave intervals, setting, 21
recovering unsaved workbooks with, 20–21
saved versions of current workbooks, using, 20

autosave
AutoRecover, using with, 20
intervals, setting, 21

AutoSum button (alt+=), 85–86
AVERAGE function, inserting with AutoSum button, 85
AVERAGEIF function, 220

B
bar charts, creating directly in ranges

condition formatting data bars, 260–261
formulas, using to display, 261–263
with repeating characters, 261

bullet lists
additional columns, creating with, 60–61
characters for, creating, 60
numbered lists, using for, 60–61
SmartArt, creating with, 61
wrap-text formatting, using with, 60

Symbols
#DIV/0! error message, 130
#REF! error message

avoiding display of, 90–91
displaying in name lists, 28, 30

* wildcard character, 194
? wildcard character, 195
~ search character, 195

A
absolute references. See also formulas

identifying with dollar signs, 87
in mixed references, 88–89
relative versus, 87
usefulness of, 88

add-ins
file format for, 37
Inquire, 132–134
XDATE, 111–112

Add-Watch dialog box, 83
Advanced Text Import Settings dialog box, 154
age calculations, 108–109
AGGREGATE function, 125–127
alignment

adjusting by indenting, 48–49
defaults for text and numbers, 48
font substitution, avoiding, 72–74

analysis tools, 132
apostrophes

including in worksheet names, 93
preceding credit card numbers with, 168

appearance. See also formatting
fonts, adjusting with, 75
ranges, converting into tables, 205–206
shading, adjusting with, 62–64

array formulas
curly braces, using with, 2
lookups, using with, 103

arrays
AGGREGATE function, replacing with, 125
concatenation, using with, 103
curly braces, using with, 2
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Chart Tools
aligning charts, 243–244
Hidden and Empty Cell Settings dialog box

dealing with missing data, 250
forcing hidden data use, 251

managing as graphic objects, 244
managing missing chart data with, 250
templates, applying with, 246

charts
aligning multiples of, 243–244
combination, 247–249
customization of

combination charts, 248–249
size alignment of multiples, 243–244
styles and colors, modifying, 241

data labels from ranges, applying, 268–269
dialog boxes for

Change Chart Type, 246
Hidden and Empty Cell Settings, 250–251
Insert Chart, 239, 246–250
Recommended Charts, 239
Save Chart Template, 245

filtering data in, 242
freezing

by converting into arrays, 258–259
by converting into static pictures, 257–258

graphic objects, managing as, 244
hidden data management, 251
high-low lines, uses for, 252
interactive, creating, 233
linking to cells, 255–256
missing data management, 250
multi-level category labels, using, 253–254
Quick Analysis feature, 190
saving as images, 281–282
slicers, creating with, 233
stock market, 240, 252
tables, creating from

advantages of, 207
overview, 205
pivot tables, 226
Recommended Charts, 239–240

templates, using with
applying to existing charts, 246
creating, 245
Insert Chart dialog box, 246
saving, 245

themes, using with, 32
types of, 240

cloud computing
advantages of, 22
disadvantages of, 22–23

C
calculated columns

numbering rows automatically with, 212–213
supported by tables, 207

calendars, 114–115
cascading style sheets (CSS), 186
case sensitivity, 3
CEILING.MATH function

overview, 118
rounding values up with, 119

cell comments
appearance of, adjusting, 276–277
commands, adding to toolbar, 276
images, adding to, 278
shape of, changing, 277

cells
cleaning formatting from, 134
copying formatting to ranges of, 67
diagramming relationships between, 133
dialog boxes for

Format Cells, 47–49, 52, 54–58, 62–63, 65
Hidden and Empty Cell Settings, 250–251

drop-down lists, creating in, 160–161
error identification in, 130
fonts in formatted, changing, 76
formatting individual characters in, 65
formatting with Format Painter, 66–67
hiding, 135–137
importing CSV files into, 188–189
last nonblank, finding, 116–118
linking to charts, 255–256
locating all merged types, 45
locking, 135–137
merging, 43–47
mixing text and values in, 70–71
mouse versus keyboard selection, 147
pivot tables, controlling within, 222–223
Protection option, using with, 53
references, making unchangeable, 140
restricting formula entries, 155–156
restrictions on protected worksheets, 137
selecting current region, 148
selecting noncontiguous, 148
shading rows and columns of, 62–64
text length limitations in HYPERLINK functions, 98
themes, using with, 32
unchangeable references, creating, 140
Watch Window, monitoring with, 83–84

Change Chart Type dialog box, 246
Change PivotTable Data Source dialog box, 231
chart sheets, 30
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comma separated values (CSV) files
importing text with, 188–189
issues with credit card numbers, 169

commands
listing of, 11–12
Quick Access toolbar, 10–12

comparing files, 133–134
compatibility

DATEIF function for Lotus 1-2-3, 109
IFERROR versus ISERROR functions in, 91
limitations of, 38
sharing issues, 161, 207
updating fonts on old worksheets, 75–77
zip and XML files, 37

Compatibility Checker, 38
concatenation

Flash Fill, using instead of, 179
for HYPERLINK function, 98
lookup tables, creating with, 104
text and numbers, displaying with, 70

conditional formatting
alternate row shading, creating with, 62–63
checkerboard shading, creating with, 63
comparing ranges with, 162–164
Conditional Formatting dialog box, 163, 165–167
duplicates, finding with, 165–167
excess spaces, identifying with, 171–172
shading groups of rows with, 64
themes, using with, 32

Conditional Formatting dialog box, 163, 165–167
CONVERT function

arguments required for, 121–122
measurement systems converted, 121

Convert Text to Columns Wizard dialog box, 129
converting measurements

overview, 121–122
table of functions, 122

Copy Picture dialog box, 257
copying data

importing from PDF files, 198–201
ranges of formulas, 128–129

COUNT function, inserting with AutoSum button, 85
COUNTA function, 116
COUNTIF function, 164
Create Names from Selection dialog box, 102
Create New Theme Fonts dialog box, 35
Create PDF/XPS button, 24
Create PivotTable dialog box

frequency tabulations, creating, 224–225
multiple groupings, 230–231
overview, 220

Excel Web App versus desktop version, 22
synching files with, 22

colors
in charts, modifying, 241–242
custom themes, selecting for, 35
customizing for themes, 36
highlighting list changes with, 163–164, 166
identifying errors with, 171

column charts, 264–265
COLUMN function, using for column shading, 62–64
column names

in formulas, 208
formulas, creating with, 210
naming with dialog box, 102
structured references, creating with, 208

columns
automatically adjusting with tables, 207
averaging with pivot tables, 230–231
calculated, 207, 212–213
centering text across, 47
concatenating for lookups, 103–104
copying and pasting data into, 128
credit cards, specifying Text number format for, 168–169
dialog boxes for

Convert Text to Columns Wizard, 129
Text to Columns, 154

duplicates of, identifying, 167
filters, creating in tables, 207
Format Painter, copying formatting with, 67
frequency tabulations, creating for, 224–226
hidden data management, 251
last value in, finding, 116–117
missing data management, 250
naming, 102, 207
propagating formulas automatically in, 210, 212
running totals, creating in, 190–191
selecting entire, 149
shading options for, 62–64
sorting contents in, 84
subtotals, inserting with pivot tables, 220–221
transposing with rows, 173–175
vertical ranges, converting to tables, 142–143
width of, changing

with autofit, 45
manually, 84

COM Add-Ins dialog box, 132
combination charts

creating, 247
customizing, 248–249
inserting preconfigured charts, 247–248
unavailable from Recommended Charts, 240
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Flash Fill
using to combine, 179–180
using to extract, 176–178

hidden data management, 251
importing from web pages, 184–185
indenting in cells, 48–49
keyboard selection of, 148
lists, comparing, 162–164
merged cells, issues with, 45
missing data management, 250
pivot table requirements, 214
proofing with audio, 196
quick queries for, 185–186
referencing in pivot tables with outside formulas, 222
SUBTOTAL versus TOTAL functions, 86
table references, using to access, 211
Text to Columns Wizard, managing with, 129
trailing minus signs, fixing, 154
transforming

with temporary formulas, 158–159
vertical records into tables, 142–143
without formulas, 157–158

unchangeable cell references, creating, 140
Data Label Range dialog box, 268
data labels

adjusting location of, 269
applying in charts from ranges, 268–269
Format Data Labels, using with, 268
linking to cells, 255

Data Validation dialog box, 160–161
database tables

normalized versus non-normalized, 214–216
overview, 214

DATEIF function
calculating ages with, 108–109
code list for, 109
overview, 109

dates
AutoFill

creating series with, 152
predicting values with, 152–153

CONVERT function, using with, 121–122
custom formats of, codes for, 57
holidays, calculating, 105–107
live calendars, displaying, 114–115
pre-1900

Google Spreadsheet, using for, 113
issues with, 110–111
XDATE functions, using for, 111–112

searching options, 195
diagram tools, 133

credit card numbers
importing as text for accuracy, 169
importing with CSV files, 169, 189
manual entry of, 168
storing accurately, 168

CSS (cascading style sheets), 186
CSV (comma separated values) files

importing text with, 188–189
issues with credit card numbers, 169

curly braces, 2
cursor movement, restricting to Input cells, 155–156
custom number formats

codes for, 55–56
data testing format strings, 55
dates and times, codes for, 57
displaying text and numbers with, 71
Format Cells dialog box, creating with, 54, 58
overview, 54
scale values, 58–59
specifying codes for, 55

Custom Views
forbidden within tables, 207
named worksheet views, creating with, 8

Customize Ribbon tab
accessing by right-click, 15
expanding lists on, 15
hiding built-in tabs with, 16
renaming tabs and groups with, 16

D
dashboards

slicers, creating with, 232
timelines, using with, 234–235

data. See also cells; filters; formulas; lookups
AutoFill, predicting values with, 152–153
concatenation of, 70, 103–104, 179
copying and pasting, 128
copying from Protected View documents, 18
custom number formats, testing with, 55
default alignment of, 48
dialog boxes for

Change PivotTable Data Source, 231
Data Validation, 160–161
External Data Range, 188–189
Hidden and Empty Cell Settings, 250–251
Import Data, 185–186
Select Data Source, 250

displaying in pivot table charts, 226
filtering

with Chart Filters, 242
with labels, 232
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EVEN function, 118
exact values, finding

with implicit intersections, 102
with intersection formulas, 101–102
with VLOOKUP and HLOOKUP, 99–100

Excel Options dialog box
AutoRecover, controlling with, 21
commands on, 11
Customize Ribbon tab, accessing, 14–15
enabling error-checking in, 130–131
hiding display elements with, 9
limitations of, 12
overview, 11–12
Quick Access toolbar, customizing with, 10–13
Ribbon, customizing with, 14–15

Excel Web App, 22–23
External Data Range dialog box, 188–189

F
filenames

available formats, 37
creating list with macro, 27–28
macro-enabled file extensions, 28, 31

files
Compare Files command, 133–134
Compatibility Checker use, 38
compatibility issues with, 37–38
copying data from Protected View, 18
Import Text file dialog box, 188–189
macro-enabled extensions, 31
MHTML format

advantages of, 26
saving in, 25

Office Compatibility Pack, installing, 37–38
Page Layout view, using before saving, 24
PDF format, saving in, 24–25
printing from Protected View, 18
Protected View management, 17–19
protecting integrity of, 24–26
read-only, sending as, 26
web browsers, creating in, 22
XML, reading with zip utilities, 37
XPS format, saving in, 24

FILES function, 27
fill handles, enabling, 151
filling

autofill, 151–153
cells with color, 166, 171
Flash Fill, 176–180
reporting gaps with, 192–193
shading, 62–64
styles for, 50

dialog boxes. See also specific dialog boxes by name
formulas, editing in, 141
modeless, advantages of, 131
toggling point mode and edit mode, 141

display, changing
alternative themes, 7
hiding elements from view, 9
hiding Ribbon display, 8
hiding status bar, 9
View tab options, 8

#DIV/0! error message, 130
dollar signs, identifying absolute references with, 87
DOLLARDE function, 118
DOLLARFR function, 118
Drawing Tools

modifying text boxes with, 47
sizing charts with, 243

drop-down lists
Data Validation dialog box, creating with, 160
in named range for sharing, 161

duplicates
COUNTIF function, using to find, 164–167
finding in ranges with conditional formatting, 165
identifying entire columns, 167
identifying entire rows, 166
removing, 167

E
Edit DWORD dialog box, 73
Edit Name dialog box, 95
e-mail

creating address lists with Flash Fill, 179
sending from Excel, 96–98

ENCODEURL function
encoding non-alphanumeric characters with, 96
examples of, 97–98

Error Checking dialog box, 131
error messages

#DIV/0!, 130
#REF!, 28, 30
AGGREGATE function, handling with, 125–127
avoiding displays of, 90–91
overriding with named cells, 256

error-checking
cautions regarding, 131
cells, identifying errors in, 130
dialog boxes for

Error Checking, 131
Ignore Error option, 131
New Formatting Rule, 171

excess spaces, identifying, 171

www.it-ebooks.info

http://www.it-ebooks.info/


Index288

style attributes, setting, 50
superscript and subscript, applying, 65

Format Comment dialog box, 276
Format Painter

basics, 66
copying from range of cells, 67
removing all formatting with, 67

Format Picture dialog box, 257
formatting. See also custom number formats

combining four series, 254
dialog boxes for

Find Format, 45
Format Cells, 47–49, 52, 54–58, 62–65
Format Comment, 276
Format Picture, 257

fonts on old worksheets, updating, 75–77
Format Painter, 66–67
individual text characters in cells, 65
inexact searches, issues with, 195
of numbers, 54
Quick Analysis feature, 190
ranges versus tables, 206–207
superscript and subscript, applying, 65

Formatting (R) command, 67
Formula AutoComplete feature, 211
formula bar, resizing to edit worksheets, 81–82
Formula view mode, toggling, 128
formulas. See also absolute references; mixed references

accidental overwrites of, preventing, 155–156
automatically adjusting through tables, 211
AutoSum button, inserting with, 85–86
bar charts, creating with, 261–263
column names, creating with, 210
editing in dialog boxes, 141
enabling error-checking for, 130–131
exactly copying ranges of, 128–129
filenames, generating list of, 27–28
hiding, 135–137
INDIRECT function, building flexibility with, 138–140
intellisense drop-down list for, 95
locking, 135–137
named, 27–31
versus pivot tables, 218–221
in pivot tables, 222–223
propagating automatically in tables, 207, 210, 212
ranges, converting to tables with, 142–143
referencing cells in pivot tables, 222–223
restrictions on protected worksheets, 137
sheet names, generating list of, 28–31
table references with, 211
tables, adding to, 209–210
transforming data with, 157–158
updating by linking cells to charts, 255–256

filters
chart, 242
displaying multiple values with, 233
filter buttons for, 207
hiding rows

using AGGREGATE function, 126
using SUBTOTAL function, 126, 213

with images, 279
labels for, 232
merged cell issues, 45
overview, 213
pivot tables, sorting with, 226
with Quick Access Toolbar, 11
with slicers, 207, 232–233
SUBTOTAL versus SUM functions with, 86
in tables versus ranges, 206–207
timelines with, 234–235

Find and Replace dialog box
inexact searches with, 194–195
merged cells, finding, 45–46
searching for values with, 195
unwanted characters, removing with, 195
updating fonts in formatted cells with, 76
wildcard characters, 194–195

Find Format dialog box, 45
FIND function, 28–29
Flash Fill

case of text, changing with, 176
combining data with, 179–180
domain names, extracting from URLs with, 178
extracting names with, 177–178
overview, 176
potential problems with, 178
training pattern recognition in, 176–180

FLOOR.MATH function, 118–119
fonts

Create New Theme Fonts dialog box, 35
for custom themes, 35
legibility, adjusting with, 75
substitution with registry editing, disabling, 72–74
updating in formatted cells, 76
updating on old worksheets, 75–77

footers
inserting images into, 68
printer options for, specifying, 40
watermarks, creating with, 68–69

Format Cells dialog box
alternate row shading, displaying, 62–63
centering text across columns, 47
codes for, specifying, 55
custom number formats, creating, 54–58
formatting new styles, 52
indentation, 48–49

www.it-ebooks.info

http://www.it-ebooks.info/


Index 289

I
icons

displaying names of, 10
finding hidden on toolbar, 10
rearranging on Quick Access toolbar, 12–13

IF function, using with ISERROR function, 91
IFERROR function

for error message substitutions, 100
hiding error values with, 90–91
ISERROR versus, 91

images
capturing from windows, 273
comments, adding to, 278
dialog boxes for

Copy Picture, 257
Format Picture, 257
Insert Picture, 68, 278

enhancing within Excel, 279–280
exporting from worksheets, 281–282
Format Picture dialog box, adjusting with, 68
modifying linked, 274
modifying on worksheets, 279
for Office Background, 7
Picture Tools, using with, 274
ranges, converting into

live images, 274
static images, 273

saving as graphics, 275
saving shapes, charts and ranges as, 281–282
watermarks, creating with, 68–69

Import Data dialog box
refreshable links, 185
static links, 186

Import Text File dialog box
importing CSV files with, 188
static or refreshable content, choosing, 189

importing
data

pasting refreshable information, 185–186
trailing minus sign issues, 154

dialog boxes for
Advanced Text Import Settings, 154, 246
Import Data, 185–186
Import Text file, 188–189
New Web Query, 185–187

indenting, 48–49
INDEX function, 27–28, 102, 116
INDIRECT function

making cell references unchangeable with, 140
specifying rows with, 138–139
specifying worksheet names with, 139

volatile for automatic updates, making, 30
XLM functions in, 27–31

frequency tabulations, using pivot tables for, 224–226
fx button, 85

G
gauge charts, 266–267
GETPIVOTDATA function, 222–223
GET.WORKBOOK function, 29
global (workbook-level) names, 92
Go To dialog box (F5), 95
Go To Special dialog box

filling report gaps with, 192–193
hiding and locking cells with, 135

Google Spreadsheet, 113
Group mode, 150
Grouping dialog box, 227–229
groups

creating automatically, 228–229
creating with pivot tables, 227
grouping charts, 270–272
grouping dissimilar objects, 271–272
ungrouping charts, 271

H
headers

column widths, changing with, 84
inserting images into, 68
keyboard selection of, 148
with merged cells, 45
printer options for, specifying, 40
sorting columns with, 84
themes, customizing with, 35
unmerging cells with, 46
watermarks, creating with, 68–69

Hidden and Empty Cell Settings dialog box, 250–251
hiding

cells
formula, 135
security, 137
unhiding nonformula, 136

filtering chart data, 242
slices of pie charts, 267

HLOOKUP function, 99
holiday calculations, 105–107
HYPERLINK function

chart sheets, limitation with, 30
navigating to web pages with, 96
sending e-mail with, 96–98
subject line, including in, 96
text length, limitation on, 98
URLs, including in, 96
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tying transposed formulas to source ranges, 174
unlinking data ranges, 257–259

local (worksheet-level) names
apostrophes with, 93
in formulas, 93
Name box, creating with, 92–93
Name Manager dialog box, 93
spaces in, 93

locking cells
formula, 135
restricting cursor movement, 155–156
security, 137
unlocking nonformula, 136

lookups
concatenation with, 104
implicit intersections for, 102
INDEX function for, 102
intersection formulas for, 101–102
MATCH function for, 101
two columns for, 103–104

M
macros

enabling in Protected View, 17
Excel 4 XLM functions, in formulas, 27–31
filenames list, creating with, 27–28
on Quick Access Toolbar, 12
saving with proper file extensions, 28, 31

malware. See also Protected View
avoiding, 17
concerns about, 17
opening safe files, 18

MATCH function, 101
MAX function, inserting with AutoSum button, 85
Merge and Center button

available commands, 44
merging cells with, 43
unmerging cells

selecting all worksheet cells, 46
selecting individual cells, 44

Merge Styles dialog box
sharing styles between workbooks, 53
updating fonts on old worksheets, 76–77

merging cells
alternatives to, 47
combining cells, 43
issues with, 45
limitations of, 44–45
locating with Find and Replace, 45–46
with Merge and Center button, 43–44
unmerging actions, 43

Inquire add-in
comparing files with, 133–134
diagram tools, 133
workbook analysis with, 132

Insert Chart dialog box
combination charts

creating, 247–248
customizing, 248–249

Recommended Charts, using in, 239
stock market charts, using, 252
templates, applying with, 246

Insert Function dialog box, 85
Insert Picture dialog box, 68
Insert Pictures dialog box, 278
Insert Refreshable Stock Price shortcut menu, 181–182
Insert Slicers dialog box, 233
Insert Timeline dialog box, 234
INT function

converting values to integers with, 119–120
definition of, 118
TRUNC function versus, 119
YEARFRAC function versus, 108

intellisense drop-down list, 95
interactive charts, creating, 233
intersections

definition of, 101
implicit, 102
for look-ups, 101–102

ISERROR function, 91

L
labels

axis, adding to charts, 248
chart data, applying from ranges, 268–269
filtering data with, 232
multi-level category, 253–254

layout choices
affected by themes, 34
centering text, 43–44, 47
indenting text and numbers, 48–49
named styles, 50–53

legibility, adjusting with fonts, 75
line charts

combining four series in, 266
using four charts together, 265

linking
to charts, 255–256
with HYPERLINK function, 30, 35, 96–98
live pictures to charts, 274
refreshable links, 184
text boxes to charts, 256
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managing for worksheets, 93
for named constants, 94–95
workbook-level, 92
worksheet-level, 92–93

New Formatting Rule dialog box
bar charts, modifying with, 261
for conditional formatting, 163
excess spaces, identifying with, 171
ranges, comparing with, 163
shading, applying with, 62

New Name dialog box, 94
New Web Query dialog box

HTML files, accessing with, 185
limitations of, 185–186
refreshable links, creating, 185
refreshing information with, 181, 186
servers, accessing with, 185
specifying data to retrieve, 186–187
stock market reports, retrieving with, 182–183
web browsers, accessing with, 185

Normal style
changing fonts for, 52
displaying settings in Style dialog box, 51

Normal view
forcing from Protected View, 18–19
in workbooks, 8

number format codes
code categories, 55
displaying in scale values, 58
managing with Format Cells dialog box, 54–58
tables of

custom formats for, 56
formats for dates and times, 57
scale values, 58–59

numbers. See also custom number formats; rounding
converting measurements, 121–122
counting nonduplicated entries, 123–124
credit cards, working with, 168–169
digit changes with long, avoiding, 167
displaying with text, 70–71
font substitution, avoiding, 72–74
inexact searches for, 195
row

automatic, 212
consecutive, maintaining when filtering, 213
sequential, 212–213

TRIM function, identifying excess spaces with, 172

O
ODD function, 118
Office Compatibility Pack, 37–38
Open dialog box, 18

unmerging all worksheet cells, 46
wrapping text in, 44

MHTML file format
advantages of using, 26
saving workbooks in, 25

MIN function
comparing values with, 267
inserting with AutoSum button, 85

mixed references, 88–89
MOD function, 62–64
modifications

of chart pictures, 257
of chart styles and colors, 241–242
of images on worksheets, 279
of linked pictures, 274
of named styles, 51
of pivot table data, 223
protecting against

passwords, 136–137
Styles dialog box, 53

of Quick Access toolbar, 12
of Ribbon, 14
of speech qualities, 197
Style gallery for, 50
of text with formulas, 176
of themes, 35
transforming data

temporary formulas, 158–159
without formulas, 157–158

MROUND function, 118
multi-level category labels, 253–254

N
Name Manager dialog box, 93
named constants

controlling scope of, 94
creating with New Name dialog box, 94–95
for formulas, 94
simplifying formulas with, 95
for text shortcuts, 95

named ranges
comparing ranges with, 162–164
creating drop-down lists in, 161
in formulas, 101

names
apostrophes with, 93
dialog boxes for

Create Names from Selection, 102
Edit Name, 95
Name Manager, 93
New Name, 94
Paste Name (F3), 93, 95

www.it-ebooks.info

http://www.it-ebooks.info/


Index292

formulas versus, 218–221
frequency tabulations, creating with, 224–226
grouping items

avoiding blank cells, 227
by dates, 227–228
optional time-based units, 229

multiple groupings, creating
by assigning multiple range names, 229
with existing tables, 230

output, controlling with hidden fields, 222
purpose of, 215
ranges versus, 215
references to cells within, controlling, 222–223
referencing with outside formulas, 222
refreshing with new table data, 205
requirements for, 214
slicers, using with

advantages of, 232
applying simple filters, 232
creating interactive charts, 233
creating interactive dashboards, 232
displaying multiple values, 233
Insert Slicers dialog box, 233

themes, using with, 32
timelines, using with, 234–235

Power Utility Pak, 4
predicting values, 152–153
printers

adjusting settings for, 39–40
Page Setup dialog box, 40

printing
chart of printer settings, 39–40
Page Setup dialog box, 40
printer settings, adjusting, 39
from Protected View, 18
Quick Print option, 39

propagating formulas, 210
properties

of cells
locking and hiding formula cells, 135
unlocking nonformula cells, 136

dialog boxes for
Import Data, 186
Properties, 18–19
Speech Properties, 197

forcing Protected View files open, 18
modifications

of chart pictures, 257
of speech qualities, 197

of PDF documents, 24
web queries, controlling with, 186

P
page displays, changing with Workbook Views, 8
Page Layout view, 24
Page Setup dialog box, 39–40
passwords

bypassing with Inquire add-in, 134
limitations of, 137, 156
Protect Sheet dialog box, 136–137

Paste Name dialog box (F3)
finding named constants in, 95
for worksheet-level names, 93

Paste Special dialog box, 157–158, 173–174
pasting data

from autosaved workbook copies, 20
copies of range formulas, 128–129
dialog boxes for

Paste Name (F3), 93, 95
Paste Special, 157–158, 173–174

filling gaps in reports by, 192–193
into graphics files, 273–275
Import Text file dialog box, 188–189
mixed cell references, 88–89
from PDF files, 198–199
pictures of charts, managing, 257–258
from Protected View documents, 18
refreshable information, creating, 185–187
from web pages, 184
from Word 2013 into Excel, 257–258

pattern recognition, 176–180
PDF files

importing data by copying, 198–199
importing data using Word 2013, 200–201
opening with Word 2013, 200
sending files as, 24–25

Picture Tools menu, 274
pictures. See images
pie charts

creating simple, 264–265
gauge charts, creating from, 266–267

pivot tables
advantages of using, 216, 221
charts, creating from, 226
complicated formulas, creating with, 222
dialog boxes for

Change PivotTable Data Source, 231
Create PivotTable, 220, 224–225, 230–231
Insert Slicers, 233

document themes, incorporating in, 32
ease of use, 220
flexibility of, 216
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with AutoSum function, 85–86
conditional formatting, comparing with, 162–164
conditional formatting for shading, 62–64
counting nonduplicated entries in, 123–124
data labels from, using, 268–269
document themes, controlling with, 32
duplicate values, identifying in, 165–167
exact copies of, making, 128–129
with Format Painter, 66–67
in formulas, 92–93
importing text into, 188–189
live calendars, displaying in, 114–115
lookup tables, naming for, 103
Merge functions, using with, 43–47
in mixed references, 88–89
mouse plus keyboard selections, 148
mouse versus keyboard selection, 147
names for, creating, 101–102
normalized versus non-normalized, 214–216
official tables, converting into, 205–206
PDFs, saving as, 24
pictures, converting into

live images, 273–274
saving as graphic images, 275, 281–282
static images, 273

pivot table usage of, 215
pivot tables versus, 215
searches, performing on, 195
selecting

across multiple worksheets, 149–150
current region, 148
noncontiguous ranges, 148

spaces, using for intersection operators, 102
styles, applying to, 50
tables versus, 205–207
transforming data in, 157–158
transposing columns and rows, 173–175
vertical, converting into tables, 142–143
VLOOKUP and HLOOKUP with, 101–102
in Watch Window, 83

read-only file sharing, 26
Recommended Charts

with Insert Charts dialog box
advantages of, 240
previewing data in, 239

limitations of, 240
trust issues with, 240

#REF! error message
avoiding display of, 90–91
displaying in name lists, 28, 30

Properties dialog box, 18–19
Protect Sheet dialog box, 136–137
Protected View. See also security

copying data from, 18
disabling to edit files in, 17
forcing Normal view with Properties dialog box, 18–19
macros, working with in, 17
opening by choice, 18
overview, 17
printing documents from, 18
printing issues with cloud computing, 22
saving workbooks into Normal view, 18–19
triggering situations for, 17
Trust Center, controlling with, 17–18
warning messages displayed for, 17

protecting formula cells, 155–156
Publish as PDF or XPS dialog box, 24

Q
question mark (?) wildcard character, 195
Quick Access toolbar

comments, setting up for, 276
copying Ribbon commands to, 10
default location of, 10
displaying below Ribbon, 13
displaying icon names on, 10
filters, using with, 11
finding

additional icons on, 10
all Excel commands on, 12
macros on, 12

icons
adding, 10–12
changing, 12
rearranging, 13
removing, 13

resetting to default, 13
Ribbon use versus, 10
sharing with others, 13
work-specific macros, adding, 12

Quick Analysis
overview, 190–191
preventing display of, 191

Quick Print, 39

R
ranges

in absolute versus relative references, 87–88
AGGREGATE function, using with, 126
AutoFill, generating with, 151
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Hidden and Empty Cell Settings dialog box
dealing with missing data, 250
forcing hidden data use, 251

hiding
AGGREGATE function, 126
filter buttons, 207
SUBTOTAL function, 126

last value in, finding, 116–117
naming

with Create Names from Selection dialog box, 102
for implicit intersection lookups, 102

numbering sequentially, 212–213
row numbers versus data numbers, 212
selecting entire, 149
shading options for, 62–64
Total Row command, 208
transposing with columns, 173–175

ruler display, changing with Show group, 8

S
sandbox environment, 17
Save As dialog box, 25
Save Chart Template dialog box, 245
scope

identifying names by, 93
limiting workbook names with, 94
Scope drop-down list, 92

searching
Find and Replace dialog box, 195
question marks and asterisks, looking for, 195
wildcard characters, 194–195

security
limitations of

in hiding and locking cells, 137
for passwords, 156

precautions with macros, 17
role of Protected View in, 17–18

Select Data Source dialog box, 250
selecting

across noncontiguous worksheets, 150
choosing current region, 148
entire column, 149
entire row, 149
mouse plus keyboard selections, 148
mouse versus keyboard selections, 147
multisheet ranges, 149–150
noncontiguous cells and ranges, 148

shading
alternate rows with, 62–63
checkerboard patterns, 63
groups of rows with, 64

refreshing
CSV files in worksheet ranges, 188–189
manually

for pivot tables, 221
for static pages, 187

updating pivot tables, 221
web page data, 185–186

Registry Editor
disabling font substitution with, 72–74
Edit DWORD dialog box in, 73

relative references
absolute versus, 87
in mixed references, 88–89

Replace Format dialog box, 76
REPLACE function, 28–29
REPT function, 261–262
Reset Ignored Errors button, 131
Ribbon display

built-in tabs, hiding, 14, 16
customizing

with Excel Options dialog box, 14–15
overview, 14–16
Quick Access toolbar, 10

hiding, 8
Quick Access Toolbar versus, 10
renaming tabs and groups on, 16

ROUND function
rounding currency values with, 119
rounding to significant digits, 120
scaling bar charts with, 262

ROUNDDOWN function
definition of, 118
rounding to significant digits with, 120

rounding
currency values, 119
formatting versus, 118
INT versus TRUNC functions, 119–120
MROUND function, 118
to nearest multiple, 118–119
ROUND function, 119–120, 262
to significant digits, 120
table of functions, 118

ROUNDUP function, 118
ROW function

generating integers with, 28
numbering table rows automatically with, 212
with row shading, 62–64

rows
consecutive numbers, maintaining when filtering, 213
duplicates of, identifying, 166
Format Painter, copying formatting with, 67
height of, changing, 45

www.it-ebooks.info

http://www.it-ebooks.info/


Index 295

Sort & Filter command, sorting pivot tables with, 226
sorting

contents of columns, 84
issues with gaps, 192–193
issues with merged cells, 45

spaces
encoding with ENCODEURL function, 96
issues with excess, 170–172
as range intersection operators, 102
in worksheet names, 93

sparklines
with Quick Analysis, 190–191
themes with, 32

speech
enabling text-to-speech feature, 196
proofing data with, 196
reading data with, 196
Ribbon, customizing for, 16
voice qualities, adjusting, 197

Speech Properties dialog box, 197
status bar

Custom Views with, 8
hiding with VBA command, 9

stock market charts
unavailable from Recommended Charts, 240
uses for high-low lines, 252

stock market reports
automatically inserting into spreadsheets, 181
entering symbols correctly, 181
hiding irrelevant information, 182
Insert Refreshable Stock Price shortcut menu, 181–182
plotting with, 252
refreshing data in, 181
retrieving with New Web Query dialog box, 182–183
retrieving with web queries, 182

structured references
creating with column names, 208
supported by tables, 207
with Total Row display, 208–209

Style dialog box
creating new styles with, 52–53
modifying existing styles with, 51–52

Style gallery
creating and naming new styles with, 52–53
merging styles between workbooks with, 53
modifying styles with, 50–52
protecting styles from modification, 53
sharing styles in master workbooks, 53

styles
additional formatting with, 50
attributes affected by, 50

shapes
Format Painter, copying formatting with, 67
linked, adding to charts, 256
saving as images, 281–282
themes, using with, 32, 36

SharePoint, 22
sharing

Compatibility Checker, 38
compatibility issues with, 161
file format choices for, 24–26
IFERROR versus ISERROR functions, 207
Ribbon customizations, 13
tabled workbooks, 207

sheet names
combining with HYPERLINK function, 30
creating list with macro, 29–31
updating list, 30

Show group, 8
sizing

Chart Tools, 244
charts, 243–244
copying ranges, 67
dragging cells for, 207
Drawing Tools, 243
font substitution issues, 72–73
Formula bar appearance, changing, 82
of indentation values, changing, 49
referencing data when, 211
of shading values, changing, 64
of slicers, 233
SmartArt, 61
Styles for, 52
with themes, 34
Watch Window display, customizing, 84

SkyDrive
advantages of using with Excel, 22
disadvantages of, 22–23
synching files with, 22
working using workbooks in, 22

slicers
appearance of, adjusting, 233
compatibility issues with, 38
definition of, 232
Insert Slicers dialog box, 233
interactive dashboards, creating with, 232
multiple values, displaying with, 233
pivot tables, using with, 234
removing from filters, 233
simple filters, applying with, 232
themes, using with, 32

SmartArt dialog box
creating bullet lists with, 61
using themes with, 32, 36
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size of, adjusting, 207
slicers with, 207
structured references with, 207
SUM versus SUBTOTAL functions in, 86
themes with, 32
values at intersections, finding, 101–102
workbook sharing issues with, 207

templates
applying to existing charts, 246
creating for charts, 245
file formats for workbooks, 37
with new charts, 246
text boxes, adding to, 245

temporary formulas, 158–159
text

centering without merging, 47
chart

adding with multi-level category labels, 253
linking to cells, 255–256

converting arguments to range references, 138–139
dialog boxes for

Advanced Text Import Settings, 154, 246
Convert Text to Columns Wizard, 129
Import Text file, 188–189
Text to columns, 154

displaying
with numbers, 70–71
in text boxes, 47
in vertical format, 47

encoding for e-mail, 96
excess spaces, 170–172
font substitution, avoiding, 72–74
formatting individual characters in cells, 65
in HYPERLINK functions, 96, 98
importing into worksheet ranges, 188–189
in merged cells, 43
modifying

with Flash Fill, 176–178
with styles, 50–53
with temporary formulas, 158–159

searching with wildcards, 194
shortcuts using named constants, 95
superscript and subscript, applying, 65
wrapping in merged cells, 44

text boxes
adding to charts with multi-level category labels, 256
including in groups, 271
including in templates, 245
linking to pie-charts, 267

TEXT function, displaying text and numbers with, 71
Text to Columns dialog box, 154
TextImport Wizard, 169

styles (continued)
chart modification with

changing chart elements, 241
modifying styles and colors, 241–242

creating from existing formats, 52–53
custom sets, limitations of, 53
dialog boxes for

Merge Styles, 53, 76–77
Style, 51–53

master workbooks for sharing, creating, 53
modifications

of Normal style, 52
protecting from, 53
with Style gallery, 51–52

multiple cells, adjusting with, 50
sizing, adjusting with, 50–52
updating fonts on old worksheets, 76–77

subscript, applying to text, 65
Subtotal dialog box, 218–219
SUBTOTAL function

automatically inserting subtotals with, 218–219
sequential numbers, maintaining when filtering, 213
sorting data with, 218–219
SUM function versus, 86
with Total Row command, 208

SUM function
AutoSum button for, 85
SUBTOTAL function versus, 86

superscript, applying to text, 65

T
table references, 211
tables. See also pivot tables

AutoSum button with, 86
calculated columns supported by, 207
charts, creating from, 205
converting from vertical ranges, 142–143
copying from web pages, 185–187
CSS displays, issues with, 186
exact values in, finding, 99–100
filters with, 207
formatting options, 207
formulas with, 208
limitations of, 207
merged cell issues, 45
normalized, definition of, 214
numbering rows automatically, 212
official, creating, 205
overview, 205–207
pivot tables, creating from, 205
propagating formulas automatically in, 210, 212
Quick Analysis feature, creating with, 190
ranges versus, 206–207
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U
unlocking cells

nonformula, 136
restricting cursor movement, 155–156

updating
CSV files in worksheet ranges, 188–189
manually for static pages, 187
refreshing pivot tables, 221
web page data, 185–186

URLs
for e-mail, 96–98
extracting domain names from with Flash Fill, 178
with HYPERLINK, 96
retrieving stock market reports with, 181–183
for web queries, 182

V
values

displaying with text, 70–71
finding at intersections, 101–102
looking up exact values, 99–100
searching with wildcards, 195

VBA code
hiding status bar with, 9
problems with merged cells, 45
XDATE add-ins, 111–112

VLOOKUP function, 99

W
Watch Window

customizing display of, 84
monitoring cells and ranges with, 83
navigating between worksheets with, 84
overview, 83
sorting contents in, 84

watermarks
example of, 69
Format Picture dialog box, 68
in headers and footers, creating, 68
Insert Picture dialog box, 68

Web Options dialog box, 281–282
web pages

accessing directly by URL command, 187
copying static information from, 184, 186
CSS displays, issues with, 186
dialog boxes for

New Web Query, 118, 182–183, 185–187
Web Options, 281

Excel Web App, 22–23
HYPERLINK function, navigating to with, 96
importing data from, 184

text-to-speech feature, 196
themes

colors for, choosing, 35
creating, 35–36
custom colors for, creating, 36
custom sets in Office applications, 36
default Office, new fonts for, 75
gallery, choosing from, 34
limitations of using, 34
modifying, 35–36
overview, 32
saving customized sets, 36

tilde (~) character, using in searches, 195
timelines

filters with, 234–235
Insert Timeline dialog box, 234
themes with, 32

times
AutoFill

creating series with, 152
predicting values with, 152–153

CONVERT function, using with, 121–122
custom formats of, codes for, 57
holidays, calculating, 105–107
live calendars, displaying, 114–115
pre-1900

Google Spreadsheet, using for, 113
issues with, 110–111
XDATE functions, using for, 111–112

searching options, 195
Total Row command

with tables, 208
toggling display on and off, 209

totals
AutoSum button, creating with, 86
ignoring with formulas, 211
pivot tables, calculating with, 214
running, creating, 190–191
SUBTOTAL versus SUM functions, 190–191

transforming data
with temporary formulas, 158–159
without formulas, 157–158

TRANSPOSE function, 174–175
transposing ranges

linking to source ranges, 174
Paste Special dialog box, 173–174
TRANSPOSE function, 174–175

TRIM function, 172
TRUNC function

converting values to integers with, 119–120
definition of, 118
INT function versus, 119

Trust Center, controlling Protected View with, 17–18

www.it-ebooks.info

http://www.it-ebooks.info/


Index298

exporting graphics from, 281–282
filling gaps for sorting, 192–193
Format Painter, removing formatting with, 67
names, identifying by scope, 93
password limitations with, 156
pivot tables, using with, 214
protecting with Protect Sheet dialog box, 136–137
refreshable data, creating in, 188–189
resizing formula bar for editing, 81–82
selecting multisheet ranges, 149–150
selecting noncontiguous worksheets, 150
spaces, including in names, 93
themes, adjusting for different, 34

Wrap Text
using with bullet lists, 60
using with merged cells, 44

X
XDATE custom functions

issues with pre-1583 dates, 112
list of extended date functions, 111–112
for pre-1900 dates, 111

XLM-style macros
FILES function, 27
GET.WORKBOOK function, 29

.xls file extensions, 28, 31

.xlsm file extensions, 28, 31
XPS file format, 24

Y
YEARFRAC function, 108

Z
zip files, compatibility with XML files, 37
Zoom group, 8
zooming

avoiding font substitution during, 72–74
Zoom group versus Zoom slider for, 8

web pages (continued)
pasting methods for inserting, 184
quick queries for, creating, 185–186
refreshable links to, creating, 185
specifying data to retrieve, 186–187
web queries, making

New Web Query dialog box, 182–183
URLs, 182

workbooks, using in browsers
with Microsoft SkyDrive account, 22
with SharePoint, 22

wildcard search characters
searching for question marks or asterisks, 195
searching for text, 194–195
searching for values, 195

Word 2013
copying formula ranges with, 128–129
copying PDF data with, 200–201
opening PDF files with, 200
sharing themes with Excel, 36

Workbook Analysis Report dialog box, 132
Workbook Views

adding watermarks with, 68
overview, 8
restriction of tables from, 207

workbook-level (global) names, 92
workbooks

analyzing with Workbook Analysis Report dialog box, 132
bypassing passwords with Inquire, 134
diagramming relationships between, 133
sharing prohibitions with tables, 207

worksheet-level (local) names
apostrophes with, 93
in formulas, 93
Name box, creating with, 92–93
Name Manager dialog box, 93
spaces in, 93

worksheets. See also pivot tables
apostrophes, using with names, 93
common themes, using with, 34
diagramming relationships between, 133
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